Interface with I2C SDA and SCL with PCI 6224 digital ouputs in C/C++

I am trying to use the pci 6224 in order to send SDA and SCL to an I2C. I have been able to control the Digital Output, but I have been unsuccessful with generating a clock source to satify the I2C. I am writing this code in C/C++. Any ideas or examples would surely be appreciated. I need a good starting point, but I have not been able to find any useful examples that have worked. I am using the SCB-68 and I am trying to use my digital multi-meter to verify my code. 
I have looked at the examples provided, but is there a description of these functions that are being called using the NIDAQmx.h? 

Hello VJohnson,
The counter will give you control of the clock frequency and duty cycle.  However, this card also has correlated DIO, which means that you can clock your digital lines.  Because of this, you can write a specific pattern (101010) to the buffer and just have it continuously output.  However, you will have to write this in a way that you know what values you're writing based on the part of the clock you're at.  
My I2C implemetation knowledge isn't the greatest, so I do not know how big each of your communication packets will be, but one implemetation would be to write your data in packets to regulate your SDA and SCL lines.  The WriteDigChan-ExtClk is the best option that shows how to write a digital channel with a clock.  You will just need to modify the DAQmxCfgSampClkTiming( function call.  The second input should be changed from "/Dev1/PFI0" to OnboardClock or NULL.  Hope this helps! 
ColeR
Field Engineer

Similar Messages

  • MY system folder, including hidden folders are littered with duplicate folders and files with the suffix (from old Mac) How do I remove them

    I have a Macbook Pro running Leopard 10.5.8. I had a problem with my my operating system (my fault, I moved a file I shoudnt have) couldnt boot up but was able to boot up from a backup. I managed to repair my original system except now all the system folders, including hidden folders are littered with duplicate folders and files with the suffix (from old Mac).  For the most part the dupes are an exact copy, but not always.  I want to remove them to free up space and cant imagine duplicate folders in the /system/library are not hindering my computer. But I dont know where to start and am afraid of doing irreparable damage. Any ideas

    pacull,
    Use iCal>View>Show Notifications to choose what to do with the notification.

  • I can't install ADE on my PC, because as I try to open it a message of error appears to me: The application will be closed. I've already try with different browsers and also with the manual installation, but nothing..

    I can't install ADE on my PC, because as I try to open it a message of error appears to me: The application will be closed. I've already try with different browsers and also with the manual installation, but nothing..

    1
    Close all iWork applications
    2
    Uninstall Keynote; this must be done with an application remover tool to delete the installation properly. Appcleaner is known to work correctly for this purpose, it is free and can be downloaded from here: Appcleaner Download
    3
    empty the trash
    4
    shutdown the Mac and restart. After the start up chime, hold down the shift key until the apple logo appears
    let the Mac complete the start up procedure completely, it will take longer than usual as the hard drive is being repaired
    5
    Reinstall Keynote by logging into the Mac App Store using download / install

  • Why my MacBook pro with Maverick, when I'm connected with internet key and connect with usb cable my HTC One the Mac restat with error?

    Why my MacBook pro with Maverick, when I'm connected with internet key and connect with usb cable my HTC One the Mac restat with error?

    Solution may be found if you search in the "More Like This" section over in the right column. 

  • What  is mechanism to integrate with the rdf and Rtf with concurrent manger

    hi
    what is mechanism to integrate with the rdf and Rtf with concurrent manger in oracle apps .
    can any one help me
    Thanks in advance

    1. Create executable for Oracle Reports.
    2. Create a concurrent program based on this executable with output type as xml.
    3. Now from XMLP responsibility, create a data definition with data definition short code = concurrent program short code
    4. Create template definition choosing the data definition created above. Upload RTF/other template format created.
    Now run the concurrent program and test it.
    Step by step guide is available here http://www.oracle.com/technetwork/middleware/bi-publisher/overview/xmlebsrep-132947.pdf

  • I do a movie whith iMovie. I finalize the project and I pass it to iDvd. Then I do a little menu and I burn my DVD. When I play my DVD on a computer or in my TV it ALWAYS begins directly with the movie and not with the menu... PLEASE HELP!!!!

    I do a movie whith iMovie. I finalize the project and I pass it to iDvd. Then I do a little menu and I burn my DVD. When I play my DVD on a computer or in my TV it ALWAYS begins directly with the movie and not with the menu... PLEASE HELP!!!!

    Go to the Map mode in your iDVD project and make sure the blue bin at the left is empty.  That's where you drag slideshows to if you want the DVD to open immediately to that slideshow and bypass the menu. 
    Click to view full size
    If there is an item in there drag it out.
    OT

  • When i open my emails with outlook first and then with my ipad 4, the ipad does not show me that i have new mail despite that it actually downloads them. iphone 3g and 4s used to do that. any suggestions please?

    when i open my emails with outlook first and then with my ipad 4, the ipad does not show me that i have new mail despite that it actually downloads them. iphone 3g and 4s used to show them as new emails. any suggestions?

    1. Open iTunes.
    2. Click the View option in the iTunes menu.
    3. Select the Show Sidebar option.
    Connect your phone, select it in the Sidebar...the various tabs will now show as before.

  • Code works with Dreamweaver CS6 and not with CC

    <p><a href="javascript:void(0)" onclick="window.open('http://www.anything.comt', '', 'top=20,left=20,toolbar=0,statusbar=1,scrollbars=1,resizable=1')" title="title">name</a></p> works with Dreamweaver CS6 and not with CC
    [Edited Title and moved to Dreamweaver- JTS]

    I'm not quite sure I understand your point.
    I have just tested the Open Browser Window behavior in Dreamweaver CC. It creates slightly different code from Dreamweaver CS6, but it works correctly. This is what is created in the HTML:
    <p>my <a href="#" onClick="MM_openBrWindow('http://www.adobe.com/','mywindow','toolbar=yes,location=yes,status=yes,menubar=yes,scrollb ars=yes,resizable=yes')">link</a>
    </p>
    Dreamweaver CC also adds the following code to the <head> of the page:
    <script type="text/javascript">
    function MM_openBrWindow(theURL,winName,features) { //v2.0
      window.open(theURL,winName,features);
    </script>
    The definition of the MM_openBrWindow() function is needed in the <head> for the code to work. But it definitely works OK.
    With regard to _self and _blank not working, I can't find any problem with the way Dreamweaver CC handles them.
    However, if you feel happier working with Dreamweaver CS6, you can download it from the following page:
    https://creative.adobe.com/products/dreamweaver
    Open the drop-down menu under "In this version", and select Dreamweaver CS6 as shown in the following screenshot:
    With Dreamweaver CS6 selected, click the large Download button at the top-right of the page. You can then download CS6, and install it alongside Dreamweaver CC.

  • Current 1TB computer dying.  Installing new 3TB drive next Thursday.  Can I just go directly to my account and install Creative Cloud with Proshow Producer and Bridge with a hastle?

    Current 1TB computer dying.  Installing new 3TB drive next Thursday.  Can I just go directly to my account and install Creative Cloud with Proshow Producer and Bridge with a hastle?

    When I look at the forum index Welcome | Adobe Community I do not find a program called proshow
    Cloud Getting Started https://helpx.adobe.com/creative-cloud/topics/getting-started.html
    or
    http://forums.adobe.com/community/download_install_setup/creative_cloud_faq

  • Hi there i have ipod touch 2nd gen and i am tryna restore it but i get error 21 with orginal fireware and 1601 with custom fireware and when it connected to itunes and i try to boot it up by restoring it white screen with lines thorugh it

    hi there i ahve ipod touch 2nd gen and i am tryna restore it but get error 21 with orginal fireware and 1601 with custom firewarw and when connected it to itunes and i try to boot it by resotring it white screen with lines through it

    Those errors are covered here:
    http://support.apple.com/kb/TS3694

  • Serial interfaces, ip vrf forwarding, and PBR with set vrf

    I am doing some work with VRF-lite but I am having some trouble with serial interfaces. I have a PE router with a serial interface where I want to take incoming traffic and using policy-based routing send the traffic to the appropriate VRF. I want to assign the serial interface itself to be in one of those VRFs, not the global routing table. Eventually, I also want to overlap the VPNs/VRFs to send traffic going out the serial interface through the VRF assigned to the serial interface. Initially, it looks something like this:
    ip vrf VRF1
    rd 65000:3
    route-target export 65000:3
    ip vrf VRF2
    rd 65000:18
    route-target import 65000:3
    ip route vrf VRF1 10.90.51.0 255.255.255.0 192.168.11.18
    interface Serial0/0/0
    ip vrf forwarding VRF1
    ip address 192.168.11.17 255.255.255.252
    router bgp 65000
    no synchronization
    bgp log-neighbor-changes
    no auto-summary
    address-family ipv4 vrf VRF1
    redistribute static
    no auto-summary
    no synchronization
    exit-address-family
    ip access-list extended remote-source
    permit ip 10.90.0.0 0.0.255.255 any
    route-map SERIAL-INCOMING permit 100
    match ip address remote-source
    set vrf VRF2
    But if I try to turn on the policy based routing at the serial interface, I get an error:
    Router(conf)#interface Serial0/0/0
    Router(config-if)#ip policy route-map SERIAL-INCOMING
    % Can not apply route-map SERIAL-INCOMING to this interface
    % Either remove 'set vrf' from route-map or unconfigure 'ip vrf forward'
    I can sort of get around the problem by using an "ip vrf receive" instead of "ip vrf forward", but unfortunately, that leaves my Serial interface in the global table which isn't what I wanted.
    What troubles me is that I can do this without any problems on an Ethernet interface. Are there any known issues with "ip vrf forward" and using PBR and "set vrf" on Serial interfaces, or have I configured something wrong?
    If I stick with the "ip vrf receive", how can I force the physical Serial interface into the appropriate VRF?
    Thanks.
    Clarke Morledge
    College of William and Mary

    Upon further investigation....
    The serial interface issue was a red herring. It just so happens that every other time I've done this it has been on a flavor of 12.2x on a 6500/7600 where this feature is supported. The only systems I have with Serial interfaces are 1841s.
    The problem with the 1841 is that most of the code revisions out there do not support this feature. It was only added to the regular code train with the recent release of 12.2(24)T. I tested with 12.2(24)T1 and you are now able to use "ip vrf forwarding" on all interfaces along with a PBR route-map that uses the "set vrf" option.
    Thanks, Laurent, for pointing me towards the TAC on this.
    Clarke Morledge
    College of William and Mary

  • Branch office setup with L3 switch and router with IOS security

    Hello,
    I am in the process of putting together a small branch office network and I am in need of some design advise. The network will support about 10-15 workstations/phones, 3-4 printers, and 4-5 servers. In addition we will eventually have up to 25-30 remote users connecting to the servers via remote access VPN, and there will also be 2-3 site-to-site IPSec tunnels to reach other branches.
    I have a 2911 (security bundle) router and 3560 IP Base L3 switch to work with. I have attached a basic diagram of my topology. My initial design plan for the network was to setup separate VLANs for workstation, phone, printer, and server traffic. The 3560 would then be setup with SVIs to perform routing between VLANs. The port between the router and switch would be setup as a routed port, and static routes would be applied on the switch and router as necessary. The thought behind this was that I'd be utilizing the switch backplane for VLAN routing instead instead of doing router-on-a-stick.
    Since there is no firewall between the switch and router my plan was to setup IOS firewalling on the router. From what I am reading ZBF is my best option for this. What I was hoping for was a way to set custom policies for each VLAN, but it seems that zones are applied per interface. Since the interface between the router and switch is a routed interface, not a trunk/subinterface(s), it doesn't seem like there would be a way for me to use ZBF to control traffic on different VLANs. From what I am gathering I would have to group all of my internal network into one zone, or I would have to scrap L3 switching all together and do router-on-a-stick if I want to be able to set separate policies for each VLAN. Am I correct in my thinking here?
    I guess what I am getting at is that I really don't want to do router-on-a-stick if I have a nice switch backplane to do all of the internal routing. At the same time I obviously need some kind of firewalling done on the router, and since different VLANs have different security requirements the firewalling needs to be fairly granular.
    If I am indeed correct in the above thinking what would be the best solution for my scenario? That is, how can I setup this network so that I am utilizing the switch to do L3 routing while also leveraging the firewall capabilities of IOS security?
    Any input would be appreciated.
    Thanks,
    Austin

    Thanks for the input.
    1. I agree, since I have only three to four printers, they need not be in a separate VLAN. I simply was compartmentalizing VLANs by function when I initially came up with the design.
    2. Here's a little more info on the phone situation. The phones are VoIP. The IP PBX is on premise, but they are currently on a completely separate ISP/network. The goal in the future is to converge the data and voice networks and setup PBR/route maps to route voice traffic out the voice ISP and data traffic out the other ISP. This leads up to #3. 
    3. The reason a router was purchased over a firewall was that ASA's cannot handle routing and dual ISPs very well. PBR is not supported at all on an ASA, and dual ISPs can only be setup in an active/standby state. Also, an ASA Sec+ does not have near the VPN capabilities that the 2911 security does. The ASA Sec+ would support only 25 concurrent IPSec connections while the 2911 security is capable of doing an upwards of 200 IPSec connections.
    Your point about moving the SVI's to a firewall to perform filtering between VLANs makes sense, however, wouldn't this be the same thing as creating subinterfaces on a router? In both cases you are moving routing from the switch backplane to the firewall/routing device, which is what I am trying to avoid.  

  • Booting with mode CLI and not with the console.

    hi,
    On a SF300-08, is anybody knows how to work with CLI and not with the Console Menu Interface ?
    Thank you for your help.
    Pascal Linglin

    Hi Pascal.
    Firstly make sure your switch is using the most recent firmware, which is now as of yesterday  1.1.2.0 .
    When that firmware is running on the switch,  a textview CLI option should be seen on the main menu as per the following screen capture;
    to get back to the menu, just type menu from the cli interface.
    Hope i answered your question?
    regards Dave

  • Open report with "Save as" and "Open with" dialogue

    Hi,
    I'm using jasper reports within my application. I manage to open them in a new window but in that case the url containing JasperServer username and password is shown. I would like to open the report without showing the url.
    I tryed using a database procedure (http://sqlcur.blogspot.com/2009/02/jasperreports-in-apex.html) but all I get is a alert window saying "file does not begin with ' pdf-'". Couldn't see what is the problem (I used the same procedure as Ino has in his example) so I thought of another way. Is it possible, when someone clicks a button to open a report, to open that report with a "Save as" and "Open with" pop up window?
    The javascript function that I use:
    <script language="JavaScript" type="text/javascript">
    function openLAPopUpJasper(url){
    w = open(url,"winLov","toolbar=false,menubar=false,location=false,resizable=yes, //scrollbars=yes,status=yes,fullscreen=true");
    if (w.opener == null)
    w.opener = self;
    w.focus();
    </script>
    Thanks in advance!
    Edited by: Josip on Oct 29, 2009 2:55 AM

    Anyone?

  • All of you who use the 80gb ipod classic and have problems with it freezing and syncing with itunes...well I have joined the club. This is a serious issue with apple and they need to correct it. I have tried everything to no avial.

    This is beyond frustrating. I just wasted 70 dollars between a new battery and gas for my ipod 80gb classic. It was having major issues syncing and freezing with itunes. I tried everything possible and noticed that a lot of people have been having the same issues with their ipod classics as well. I must have restored it several times and now it just totally bit the dust. Now I have to shell out 130 dollars to send it in to apple to be rebuilt/fixed. This is nonsense and I just cant believe apple isn't doing anything to address this issue. My ipod was doing great for about nearly 5 years and now  this. I even down-graded to itunes 10.7, but by the time I had it set up to try, that's when my ipod totally failed and will not even come on. Grrrrrrrrrrrrrrr

    Here is what worked for me:
      My usb hub, being usb2, was too fast. I moved the wire to a usb port directory on my pc. That is a usb1 port which is slow enough to run your snyc.

Maybe you are looking for

  • Internet Explorer 7.0 setting for Planning

    Hi Hyperion Experts, I read many times in this forum that Planning faces problem with Internet explorer 7.0 and better to use earlier version. otherwise some settings required in IE 7.0. Could anybody help me how to set IE 7.0 for Planning as I'm una

  • Cmd-esc undesirabley launches Front Row?

    Hi I have LiteSwitch installed (www.proteron.com/liteswitchx). According to its documentation, hitting esc while toggling through the apps (with CMD-TAB) would exit it without switching to the selected app. However, on my machine, hitting esc (while

  • How do I get the music on my iPhone back into iTunes?

    Last night after much effort I was able to get my music and audiobooks synced with my iPhone 3G. This morning iTunes on the Laptop has crashed and been re-installed several times. Now the playlists and audiobooks are missing/incomplete. Is there a wa

  • Buffer I/O error on device sdd1, logical block, HDD failure? [SOLVED]

    Hello! I'm a bit puzzled here to be honest. Granted i'm not using linux as much as I used to (not after windows 7). I have archlinux running on my HTPC. Never had any issues before that was this severe, unless I upgraded and forgot to read news secti

  • TCode for table search

    Can any one suggest me a TCOde,by which we can find out all the tables releted to a tcode in ECC 6.0 like in sap r/3 4.6B,there was a tcode me49, we  could put there tcode and got all the tables releted to that perticular tcode.