Just came from Python; Learning XCode

So I just started learning Python like half a year ago (And haven't been working very hard at it), but I do learn rather fast.I've already mastered mult-threading, classes/functions and reading and writing data to .txt and .py documents. I don't want to use Python forever though. I want to start using XCode to develop applications for Mac OS X, Windows and iOS using Objective C.
So I got XCode, started looking through it, and was (Obviously) baffled. Heck, If I just knew where to write my source code and why, I'd be off.
Note the why. I've been googling it for awhiule, and can find nowhere that tells me what I want to know. I don't want "Follow all these steps and write your code here" because then I won't understand it and will have to come back to a tutorial for every project. So here are my questions:
1. From what I understand, a .h File is a header file where you put your classes. Is it an Objective C file? Or does it not matter?
2. And a .m file is a MATLAB file for working with the interface? Could I get a more detailed explanation, and I take it that this is not an Objective C file? Am I supposed to learn two programming languages, or am I missing something?
3. I really don't understand what a plist is. Is it what compiles all the files into an application?
4. What is Core Data? What's the difference between Core Data files and a Core Data model?
5. What is the AppDelegate.h file for?
6. These storyboards, I take it they're the progression of menus? So like the Openning Menu>Sub Menu>Actual Content?
7. What do I put in the MasterViewController.h and DetailViewController.h files? Unlike the .m files, they're not self-explanatory.
8. This .pch file... It's a pre-compiled header? What does that mean and what does it do?
9. What do I put in the main.m file?
10. What code is read first? Does the device start with the main.m, or does it start at the top? And what code is read next, all the way to the end? (I'm assuming that .h files won't be included in this since I understand that they're just defining classes, nothing more)
11. Go get your self a cookie if you read all that and still want to answer.

The Apple developer site has all this and more:
https://developer.apple.com/library/mac/#referencelibrary/GettingStarted/Learnin g_Objective-C_A_Primer/_index.html
.m files have *nothing* to do with MATLAB!

Similar Messages

  • Hello i just came back from the apple store and they had to restore my phone and i just downloaded all my apps and music back but my photos that are on icloud i only got 80 out of 768 back. what do i do to get all of them back?

    hello i just came back from the apple store and they had to restore my phone and i just downloaded all my apps and music back but my photos that are on icloud i only got 80 out of 768 back. what do i do to get all of them back?

    If you tried to restore to your iCloud backup and your photos didn't fully restore, first go to Settings>iCloud>Storage & Backup and make sure it isn't still in the process of restoring.
    If the restore is complete and all your photos weren't restored, all you can do is try restoring the backup again.  You might try the solution posted by ezjules in this discussion: https://discussions.apple.com/message/19518589#19518589.  This involves opening the photos app after the phone restarts and you provide the passwords for your Apple IDs, then leaving it open for the remainder of the restore process.

  • I just came back from a family vacation and tried to sync my phone to my laptop. It didnt recognize my phone, and did i want to add device or restore to old device.  i chose to restore and in doing so, i lost all the photos taken on our vacation.

    i just came back from a family vacation and tried to sync my phone to my laptop.  It didnt recognize my phone, and did i want to add device or restore to old device.  i chose to restore and in doing so, i lost all the photos taken on our vacation.  is there a way to retrieve photos?  the completely disappeared from my iphone altogether. I am using iphone 5. I did not have any backup since I was about to download the photo. Please help me. Thank you

    See:
    Syncing to a "New" Computer or replacing a "crashed" Hard Drive: Apple Support Communities

  • If i have Time Machine backed up on an external hard drive, do i just plug the drive into another macbook pro and all my stuff is in the new computer?  also, does it matter if the new computer is running Lion when the backed up info came from Snow Leopard

    If i have Time Machine backed up on an external hard drive, do i just plug the drive into another macbook pro and all my stuff is in the new computer?  Also, does it matter if the new computer is running Lion when the backed up info came from Snow Leopard 10.6.8?

    No and Yes
    Don't use TM for this purpose, clone your drive to an external, plug the external into another MBP and reboot from it. Please note that booting a machine that came with Lion may not be possible from a drive with Snow Leopard.

  • When i try to add music from itunes to my ipod itune tells me the music on my ipod came from a differnt libray and  wants to erase my whole ipod. i just loaded my ipod two days ago. i don't want to replace everything every time i want to add to songs

    When i try to add music from itunes to my ipod, Itune tells me the music on my ipod came from a differnt libray and  wants to erase my whole ipod. i just loaded my ipod two days ago. i don't want to replace everything every time i want to add two to songs. My MacBook Pro is the only autherized computer.

    To prevent a sync when plugging in the iPod/iPhone - hold down the 'option' and the 'command' keys when plugging in the iPod/iPhone - key the keys down until the iPod/iPhone is listed under the Devices list in iTunes - this will prevent a sync from taking place and you will be able to change your settings.
    MJ

  • I have a symbol that has appeared on my iphone 4s top right just left off the bluetooth sign, it's an arrow on a circle with a padlock in the middle any idea where it came from and what it is

    i have a symbol that has appeared on my iphone 4s top right just left off the bluetooth sign, it's an arrow on a circle with a padlock in the middle any idea where it came from and what it is

    That's the portrait orientation lock (keeps the screen from rotating to landscape mode).  To turn it off, double-tap the home button, swipe the list at the bottom to the right, then tap the left-most icon (to the left of the music controls).

  • Hi, I just got my Iphone 5s when I open my camera when my phone is lock te icons of the flash and the reversing camera is there, but when I try to open my camera from the apps camera the icons of the flash, the reversing camera is not there anymore?

    Hi, I just got my Iphone 5s when I open my camera when my phone is lock te icons of the flash and the reversing camera is there, but when I try to open my camera from the apps camera the icons of the flash, the reversing camera is not there anymore?

    Have you tried restarting or resetting your iPhone?
    Restart: Press On/Off button until the Slide to Power Off slider appears, select Slide to Power Off and, after the iPhone shuts down, then press the On/Off button until the Apple logo appears.
    Reset: Press the Home and On/Off buttons at the same time and hold them until the Apple logo appears (about 10 seconds).

  • Just now i started learning ABAP and basically from JAVA background.

    hi,
    Just now i started learning ABAP and basically from JAVA background.Can anyone tell me how to implement(steps) java in sap(from where i have to start).
    regards,
    Venkat.

    Hi Venkat,
         if u know java very well, then u can take up EP. ABAP is also very easy one to read and understand, as ur basically from prgming background.
    To start with go thro the classical abap and then come to abapoo.
    u can find so many link when u search for doc in sdn.
    all the best,
    Regards
    Sathish

  • Does anyone know how to permanently remove a device that is trying to pair with my computer? I don't know what this device is or where it came from. I just want it gone. Thanks

    Does anyone know how to permanently remove a device that is trying to pair with my computer? I don't know what this device is or where it came from. I just want it gone. This is the name of the device ArbAx6h2P6.

    If it's a bluetooth device:
    Bluetooth: How to delete a paired device:
    http://support.apple.com/kb/ta27116

  • HT4061 I bought my mom an iPad for Christmas this year.  We can't use it as it will not recognize her passwords.  How do I reset it without using passwords.  I want this thing wiped clean, just like it came from the store so that I might start over.

    I bought my mom an iPad for Christmas this year.  We can't use it as it will not recognize her passwords.  How do I reset it without using passwords.  I want this thing wiped clean, just like it came from the store so that I might start over.  This is very frustrating!

    How can I unlock my iPad if I forgot the passcode?
    http://www.everymac.com/systems/apple/ipad/ipad-troubleshooting-repair-faq/ipad- how-to-unlock-open-forgot-code-passcode-password-login.html
    iOS: Device disabled after entering wrong passcode
    http://support.apple.com/kb/ht1212
    How can I unlock my iPad if I forgot the passcode?
    http://tinyurl.com/7ndy8tb
    How to Reset a Forgotten Password for an iOS Device
    http://www.wikihow.com/Reset-a-Forgotten-Password-for-an-iOS-Device
    Using iPhone/iPad Recovery Mode
    http://ipod.about.com/od/iphonetroubleshooting/a/Iphone-Recovery-Mode.htm
    You may have to do this several times.
     Cheers, Tom

  • I've just installed Xcode 4.5 but i can not get iPhone simulator 5.1, 5.0 in tab component from preferences of Xcode ? what should i do ?

    I need some simulator 5.1, 5.0 for Xcode 4.5.  but when i go to component tab from preferences's Xcode 4.5. i got a message is "No components are avaible".
    Can you suggest for me  how to get simulator 5,1, 5.0 from Xcode 4.5 ?
    Thanks,

    Yes. i've restart my computer afterwards it's appear in tab component of Xcode.
    Thanks you.

  • Capture an image using the web camera from a web application

    Hi All,
    Could anyone please share the steps what have to be followed for capture an image using the web camera from a web application.
    I have a similar requirement like this,
    1) Detect the Webcam on the users machine from the web application.(To be more clear when the user clicks on 'Add Photo' tool from the web application)
    2) When the user confirms to save, save the Image in users machine at some temporary location with some unique file name.
    3) Upload the Image to the server from the temporary location.
    Please share the details like, what can be used and how it can be used etc...
    Thanks,
    Suman

    1) Detect the Webcam on the users machine from the web application.(To be more clear when the user clicks on 'Add Photo' tool from the web application)There's not really any good way to do this with JMF. You'd have to somehow create a JMF web-start application that will install the native JMF binaries, and then kick off the capture device scanning code from the application, and then scan through the list of devices found to get the MediaLocator of the web cam.
    2) When the user confirms to save, save the Image in users machine at some temporary location with some unique file name.You'd probably be displaying a "preview" window and then you'd just want to capture the image. There are a handful of ways you could capture the image, but it really depends on your situation.
    3) Upload the Image to the server from the temporary location.You can find out how to do this on google.
    All things told, this application is probably more suited to be a FMJ (Freedom for Media in Java) application than a JMF application. JMF relies on native code to capture from the web cams, whereas FMJ does not.
    Alternately, you might want to look into Adobe Flex for this particular application.

  • How do I access a network camera from internet via 501

    Please understand that I am nowhere near being a network guru and I'm even farther away from being a PIX guru.
    I have a 501 PIX between my home network and the outside internet. The PIX is connected to a cable modem and pretty much keeps the same DHCP IP address as assigned by the ISP. I have an AXIS 207 IP camera connected to my home network on IP 192.168.1.11. For the sake of illustration say the address assigned by my cable ISP is 123.123.123.1.
    What I need to do is to access the camera from the internet. To do that I suppose I need to add some instructions to the PIX configuration but I don't know where to start...I have never even thought about communicating with devices on my home network through the internet. Can someone please provide some pointers or better yet the commands I need to add. The next question is how do I access the camera assuming the PIX is all set up. I don't think I use the camera's address and I don't know how the ISP address would get to a specific device such as the camera - maybe appending a port number or whatever to the IP address I type when trying to access the camera from the internet?
    The way the camera works on the internal network is you type in it's IP address in a browser window and the camera opens up a web page just like any url and the video is streamed to a window in the web page.
    I hope I've provided enough info to understand what I'm trying to do and I would be most appreciative for any help.
    thanks

    I tried installing the commands as provided but am running into issues. Here are the error messages:
    pixfirewall(config)# nat (inside) 1 0.0.0.0
    ERROR: Duplicate NAT entry
    ERROR: fail to insert nat entry
    pixfirewall(config)# global (outside) 1 xxx.xxx.114.55
    ERROR: xxx.xxx.114.55-xxx.xxx.114.55 overlaps with outside interface address
    pixfirewall(config)#
    And here is a copy of my current configuration (including the code prior to entering the changes and the successful changes). Any Idea what needs to be done to fix things?
    thanks
    Building configuration...
    : Saved
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password xxx
    passwd xxx
    hostname pixfirewall
    domain-name ciscopix.com
    clock timezone CST -6
    clock summer-time CDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any time-exceeded
    access-list 100 permit icmp any any unreachable
    access-list inbound permit tcp any host xxx.xxx.114.55 eq www
    pager lines 24
    logging timestamp
    logging trap informational
    logging host inside 192.168.1.3
    icmp deny any echo outside
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.1.3 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp xxx.xxx.114.55 www 192.168.1.11 www netmask 255.255.255.255 0 0
    access-group inbound in interface outside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa authentication http console LOCAL
    aaa authentication telnet console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 15
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.6-192.168.1.10 inside
    dhcpd dns 207.69.188.171 207.69.188.172
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    username administrator password xxx privilege 15
    terminal width 80
    Cryptochecksum:xxx
    : end
    [OK]

  • How can I verify an odd Email came from Verizon?

    Today an email arrived apparently from Verizon, with the following message:
    (quote)
    Dear Valued Verizon Customer,
    Thank you for providing an updated email address for your Verizon account on a recent visit to Verizon.com or call to Verizon. To verify this email address, please select the 'Verify Email Address' link below and enter your zip code.
    Verify Email Address
    Verifying your email address improves the security of your Verizon account. Once you've verified your email address, you will be able to:
    Get important updates about your account and services 
    Receive a code for your online account if you forget your password or get locked out 
    Protect your identity and help keep your account secure 
    Thank you for choosing Verizon.
    Sincerely,
    Your Verizon Team
    (unquote)
    **********All well and good, but I have NOT HAD ANY "recent visit" to Verizon.com for MONTHS until this came.
    ************How can I find out if Verizon actually sent me this specific email?
    PS: Incidently, trying to "post" this very message containing that "copied/pasted" email content here resulted in this error message:
    " Your post has been changed because invalid HTML was found in the message body. The invalid HTML has been removed. Please review the message and submit the message when you are satisfied."
    That makes it even MORE suspect.

    KaLin wrote:
    PJL wrote:
    Plztakemymoney wrote:
    Today an email arrived apparently from Verizon, with the following message:
    (quote)
    Dear Valued Verizon Customer,
    Thank you for providing an updated email address for your Verizon account on a recent visit to Verizon.com or call to Verizon. To verify this email address, please select the 'Verify Email Address' link below and enter your zip code.
    Verify Email Address
    Verifying your email address improves the security of your Verizon account. Once you've verified your email address, you will be able to:
    Get important updates about your account and services 
    Receive a code for your online account if you forget your password or get locked out 
    Protect your identity and help keep your account secure 
    Thank you for choosing Verizon.
    Sincerely,
    Your Verizon Team
    (unquote)
    **********All well and good, but I have NOT HAD ANY "recent visit" to Verizon.com for MONTHS until this came.
    ************How can I find out if Verizon actually sent me this specific email?
    PS: Incidentally, trying to "post" this very message containing that "copied/pasted" email content here resulted in this error message:
    " Your post has been changed because invalid HTML was found in the message body. The invalid HTML has been removed. Please review the message and submit the message when you are satisfied."
    That makes it even MORE suspect.
    Most email clients allow you to view the embedded header information.  This should show the path of the message from the sender to you.  It may give you insight as to where the message came from.
    P.S. the posting error is a bug in this forum's software (Lithium).  I've seen it myself more times than I can count sadly.
    You will get this message when copying/pasting unless you use the word editor in the text editor toolbar.
    Copying/pasting into the word editor will strip the invalid HTML and post your text without any error messages.
    KaLin, I get the posting error all the time and I NEVER paste anything into the message like you suggest as being the issue.  I get it when I simply quote a message that I am replying to.  In fact, I just now got the error when I was trying to post this reply.  This is a well documented issue that was discussed in the Community Leader's forum and dropped by Verizon/Lithium.
    I truly apologize to this thread's OP, but I really had to respond to KaLin's assumption of what was happening when they knew not about which they replied.  (Other words come to mind in response KaLin's comment but my parents taught me not to use them.)

  • I used a third party programme called Mackeeper UGHHH,it moved loads of files to the trash now i do not know where they originally came from or belong!! the put back option is in grey??how can i manually put these files back where they belong?SO upset!!

    I used a third party programme called Mackeeper UGHHH SOOO Stupid i know,it moved loads of files to the trash now i do not know where they originally came from or belong!! the put back option is in grey??and will not work even when i highlight one by one!!
    how can i manually put these files back where they belong?
    i know i should have used time machine but i have not set it up and its too late for that now
    i have been researching and racking my brain on how to put these folders and contents of them back to where they once were all of the contents of the folder are still in tact AND i have not emptied my trash,my programmes and some of my apps are not working properly now...i use my computer alot for making music and things are jumbled up now...
    is there anyone out there who knows the answer to my prayers on how to go about putting these folders/files back to where they came from to restore functionality to my mac..Yes and thank u if u were going to tell me i HAVE un installed mackeeper...A very sad and upset Mac user!! Cheers Shane

    hello there thank u so much for ur reply!! ok i uninstalled mackeeper now and the put back option is still in grey im so confused...i tried restarting my computer like u said and put back still in grey??!! the files that are in my trash are everything from Accounts,address book plug-ins,address book,adobe,aim.........then stuff like apple,Audio,....to caches color pickers,colors,com.apple.TCC,to DVD player to facebook,google to ilifemedia browser to itunes to keychains to movie effects,preferences printers to skype...my Native instruments files BUT not all of them my garage band but not all of it...it seriously looks like my whole library is in the trash i tried to put things back where i THINK they belong and it just added the item or folder under where i thought it went and didnt restore functionality to for instance google chrome and all my book marks are there....they seem to be only certain things from my library that would have added some functionality to apps and programmes like my garageband is missing stuff photobooth wont work so on.......kinda looks a bit like this thats only the half of it!! Cheers shane!!!

Maybe you are looking for