Priority queue for voice/audio traffic

Hi,
Still in limbo after multiple discussions with our vendors, TAC and in general other engineers, so starting a thread here.  In the process of rolling out enterprise audio, with the intent to prioritize and allocate 25% of link bandwidth for voice class.
Our config snapshow is as follows -
policy-map qos-wan-out
 class dscp-voice-lan
  set ip precedence 5
  priority percent 25
I understand that
-DURING congestion, this will ensure voice gets a maximum of 25% and is dequeued first due to the priority setting
-And during NO congestion, the voice traffic will be dequeued before other traffic, but at the same time, can go over 25% as QoS kicks in only during congestion.
I am seeing some contradictory results in that we are having high packet loss if we exceed 25% even when the link is less than 40% utilized. I doubt the above CE configurations are an issue. But, wanted to run this by this group.
Alternate theory is that with the above configurations, our traffic is exiting fine - but the service provider who is using priority class queuing within their MPLS network may be capping the bandwidth at 25% at all times (with or without congestion).
thanks

Hi Bro
Maybe the incoming voice packets into your FW isn't marked with ef. For this reason, you don't see anything at all. I hope the QOS isn't tied to a subinterface, as QOS is only supported on the main interface itself. What you're doing here is QoS Configuration based on DSCP. You could refer to this URL for troubleshooting purposes.
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008080dfa7.shtml#tab4
Did you marked on the Cisco Catalyst switchports, which ports are ef?

Similar Messages

  • Priority queues for external loading

    Hi, I was wondering if there was a way to load multiple external files (via the Loader class) in parrallel, but with a priority queue. That is, I want to load 5 images, but I want image 1 loaded as fast as possible.
    Obviously I could make my own load queue, but if I do that the loading process could easily get hung up on loading a single image.
    I want to be able to run multiple Loader.load()s in parrallel, but assign priority weighting to each of the files.

    i don't know of any way to pause a loading file with flash.   in as3 once a file starts to load you can either let it complete loading or you can stop its load.  if you stop its load and then later want to continue, you must restart from the begining.  i don't believe flash has any way to complete the load of a partially downloaded file.

  • QoS for voice tagged traffic

    I am trying to confirm my assumption that given voice traffic arriving at an AP or wireless bridge is already tagged with COS (and TOS) precedence, the wireless device will properly deal with it by default.
    It appears from the documentation, but isn't explicitly stated, that the only QoS configuration required is to classify and tag (COS) packets. If they are tagged already, no configuration is required.
    Is this correct?
    Also, are COS precedence values preserved across a wireless bridge link, or must they be re-tagged at the far end?

    Hi there,
    in "Configuring QoS" of the Aironet 1310 Configuration Guide
    http://www.cisco.com/en/US/products/ps5861/products_configuration_guide_chapter09186a00804ed713.html
    it reads:
    "Precedence of QoS Settings
    When you enable QoS, the access point/bridge queues packets based on the Layer 2 class of service value for each packet. The access point/bridge applies QoS policies in this order:
    1. Packets already classified—When the access point/bridge receives packets from a QoS-enabled switch or router that has already classified the packets with non-zero 802.1Q/P user_priority values, the access point/bridge uses that classification and does not apply other QoS policy rules to the packets. An existing classification takes precedence over all other policies on the access point/bridge.
    Note Even if you have not configured a QoS policy, the access point always honors tagged 802.1P packets that it receives over the radio interface."
    Hope this helps
    Martin

  • Class for Voice-Audio

    ....How can i send Audio(Voice )from one sytem to another...

    ....How can i send Audio(Voice )from one sytem to
    another...You can store the voice recording on a file and then send it like any other file.

  • Eight-Class Model QoS for voice and video

    One of the QoS recomendation in the SRND "Enterprise QoS" is to create a Eight-Class QoS Model utilizing a seperate priority queue for voice and video.
    It says that even though you have only one physical priority queue, that LLQ has an implicit policer that allows for time-division multiplexing of the single priority queue. This implicit policer abstract the fact that there is essentially a single LLQ within the algorithm and, thus, allows for the "provisioning" of multiple LLQs.
    My question is if anyone has tried this and if there are any limitations on the platforms that can support this "dual-LLQ design."

    Design guide which is basically the QoSDesign recommendation bible.
    http://www.cisco.com/univercd/cc/td/doc/solution/esm/qossrnd.pdf
    It has a large section for WAN recommendations...while you may not
    need to follow one of these Based on my understanding what what you
    have for a link (DS3) and what you are trying to accomplish, I
    believe the following section would be a good place to start.
    - WAN Aggregator QoS Design
    - WAN Edge Classification and Provisioning Models
    - High Link Speed QoS Class Model
    - Eight-Class Model

  • Multiple Priority Queues?

    All,
    I have read that one may configure up to 4 priority queues, not using the Modular QOS CLI (e.g. "priority-list" command, etc).
    For the Modular QOS CLI, PQs are implemented using LLQ ("priority" command), and for this one can only specify a single PQ (though multiple classes may be mapped to this single PQ).
    What I would like to do is to have 2 distinct PQs (as should be possible in the non modular cli case) and also use CBWFQ (e.g. "bandwidth" command) for the rest of the clases. Basically I want to have EF in one PQ, another "special" class in the other PQ (lower priority than EF), and AF classes using CBWFQ.
    Does anyone know of a way to combine the 2 methods (modular and non modular CLI) of configuring LLQ in order to implement such a configuration? I was encouraged to see that heirarchical policies are supported but so far I have not found a way to specify multiple PQs as well as CBWFQ.
    Thanks much!

    There has been alot of discussion on this subject. But it seems that while IOS will allow you to configure multiple priority queues, its not really possible for it to deliver multiple priority queues.
    Which, if you think about it makes sense. A priority queue is just that, it takes priority over all other queues. If you configue 2 priority queues, how would you then then tell the scheduler that these are both priority, but the 2nd is less of a priority?
    One way you can accomplish what you're trying to do:
    1. Create a single "priority" queue for your EF traffic
    2. Use "bandwidth" to guarantee bandwidth to your special class.
    3. Put your AF traffic in class-default and let it "fair-queue".
    Something like this:
    policy-map foo
    class EF
    priority 100
    class Special
    bandwith 50
    class class-default
    fair-queue
    -Geoff

  • Implemention QOS for Voice

    Hi,
    We have a 2Mbps LL 1:4
    we are using CSICO ATA for Voice.
    we are using cisco 2620 router .
    Here are my questions.
    1.Kindly check My config and say whether this QOS config will work for prioritising the Voice.
    class-map match-all VOIP-RTP
    match ip dscp ef
    policy-map VOICE-QOS
    class VOIP-RTP
    priority 1024
    interface Serial0/0
    description ### STPI-GATEWAY-VASHI ###
    bandwidth 2048
    ip address 213.11.12.115 255.255.255.252
    ip access-group 103 in
    ip access-group 103 out
    service-policy output VOICE-QOS
    shutdown
    2.How can i filter the HTTP,TELNET,SSH,RDP,FTP traffic.
    Kindly help me.
    Thanks
    Ranga

    A more scalable config (that you dont have to redo too much) might include bandwidth guarantees for other classes of traffic as well...
    Also, I like to go with the qos design guide recommendation and set aside a queue for voice signalling... like the following...
    i also dont "match ip dscp ef" but rather just look for rtp audio... dont always have a marking switch/phone system behind your router... sometimes its a whitebox phone system sending rtp packets, and a dumb switch... I also go with a nested policy, which shapes all to the speed of the link, then decides which traffic will follow the rules of the child policy to leave the single queue ;)
    class-map match-any manage
    match protocol dhcp
    match protocol dns
    match protocol kerberos
    match protocol ldap
    match protocol snmp
    match protocol syslog
    class-map match-any bulk
    match protocol exchange
    match protocol ftp
    match protocol pop3
    match protocol smtp
    class-map match-any voicesignal
    match protocol h323
    match protocol rtcp
    class-map match-any transactional
    match protocol citrix
    match protocol pcanywhere
    match protocol secure-telnet
    match protocol sqlnet
    match protocol sqlserver
    match protocol ssh
    match protocol telnet
    match protocol tsrvrdp
    class-map match-any video
    match protocol rtp video
    match protocol cuseeme
    match protocol netshow
    match protocol rtsp
    match protocol streamwork
    match protocol vdolive
    class-map match-any voicebearer
    match protocol rtp audio
    policy-map Pol-S0/0/0.1-child
    class voicebearer
    set dscp ef
    priority percent 25
    class transactional
    bandwidth percent 25
    class voicesignal
    bandwidth percent 5
    class manage
    bandwidth percent 5
    policy-map Pol-S0/0/0.1-parent
    class class-default
    shape average 1444000
    service-policy Pol-0/0/0.1-child
    int s0/0/0.1
    service-policy output Pol-S0/0/0.1-parent
    (yes not all my classes are used in my policy; they are for future use... nice to have them in there now though, as they can always be allocated some bandwidth later on, at the expense of what is carved out now...)
    Tschuss,
    Joe

  • About priority queue

    I tried to use priority queue which I saw on the JavaTM 2 Platform
    Standard Ed. 5.0(on the web),but when I tried to create a priority queue for my work(PriorityQueue myQ = new PriorityQueue();)the compiler complaint about that,
    "C:\Program Files\Xinox Software\JCreator LE\MyProjects\Trypq\Trypq.java:7: cannot resolve symbol"
    and then I found that I can not find this priority queue class in JavaTM 2 Platform Std. Ed. v1.4.2,so what's wrong with this 2 different API,does it mean that I have to create the priority queue class by myself,because my work can only base on JavaTM 2 Platform Std. Ed. v1.4.2???
    can you help?
    thanks!

    The feature was added in the latest release of Java. If you want to use it, you have to have the latest release.
    Some of the concurrency features added in 1.5 (J2SE 5.0) were taken from Doug Lea's util.concurrent library, but I don't believe this was one of them. For those that were you have the option of using Doug's excellent library with pre 1.5 code.
    You could also write your own, but I wouldn't particularly recommend it if you can upgrade to J2SE 5.0
    Dave.

  • AutoQoS for voice traffic settings?

    Hi Everybody, 
    I have enabled auto qos on switch and following are information
    Voice is the most important traffic in network, must ensure voice traffic goes first
    SW# show mls qos map dscp-output-q
       Dscp-outputq-threshold map:
         d1 :d2    0     1     2     3     4     5     6     7     8     9
          0 :    04-03 04-03 04-03 04-03 04-03 04-03 04-03 04-03 04-01 04-02
          1 :    04-02 04-02 04-02 04-02 04-02 04-02 03-03 03-03 03-03 03-03
          2 :    03-03 03-03 03-03 03-03 02-03 02-03 02-03 02-03 02-03 02-03
          3 :    02-03 02-03 03-03 03-03 03-03 03-03 03-03 03-03 03-03 03-03
          4 :    01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-03 02-03 02-03
          5 :    02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03
          6 :    02-03 02-03 02-03 02-03
    SW# show mls qos queue-set
    Queueset: 1
    Queue     :       1       2       3       4
    buffers   :      10      10      26      54
    threshold1:     138     138      36      20
    threshold2:     138     138      77      50
    reserved  :      92      92     100      67
    maximum   :     138     400     318     400
    For the 
    DSCP 46 : it's 01-03 (voice)
    DSCP 0 : it's 04-03 (general traffic)
    From my understanding 
    - 01-03 means queue 1 and threshold3. (by default threshold3 is 100 and hidden)
    - queue-set 1 is enabled by default on all interface and hidden
    According to the above information, 
    - Does the Auto Qos is design for voice goes first?
    - Why the Q1 buffer and maximum are less then Q4? isn't suppose to set more buffer on Q1 for voice traffic? or I have to re-distribute the queue buffer and threshold, etc...
    - or I just use priority-queue out, then those queue setting will be ignored?
    Thanks in advance
    Sam

    udp ports 16384 to 32767 for rtp traffic
    1720 tcp for control (h323 protocol)

  • Low-latency prio queue for udp traffic, but not matching ACL?

    Hi,
    I have an OpenVPN service running behind an ASA for which I would like to prioritize the packets.
    The OpenVPN service connects to a remote OpenVPN service on 1194/udp, and accepts traffic on udp/1194 for yet another OpenVPN server.
    Here's what I did:
    access-list priority extended permit udp any any eq 1194
    priority-queue outside
    class-map priotraffic
    match access-list priority
    policy-map QoS_policy
    class priotraffic
      priority
    service-policy QoS_policy global
    priority-queue outside
    I know there are hundreds of packets per second on this OpenVPN, but still I only see 2 matched packets on the ACL "priority":
    # show access-list | inc priority
    access-list priority line 1 extended permit udp any any eq 1194 (hitcnt=2) 0xbbdd01d4
    Am I missing something? Must I know both src AND destination ports in order to achieve this?

    I started suspecting that it only matched packets for new connections (in iptables called NEW / UNREPLIED). I tested my thesis by restarting one of my openvpn tunnels, and indeed I see now a hit count of one packet.
    Question is, how come only new udp connections being matched? I would obviously like to prioritize all packets for an already established session.
    Thanks,
    By the way, the statistics after I reinitiated one of the tunnels:
    asa# show access-list | inc priority
    access-list priority line 1 extended permit udp any any eq 1194 (hitcnt=1) 0xbbdd01d4
    asa# show service-policy
    Global policy:
      Service-policy: QoS_policy
        Class-map: priotraffic
          Priority:
            Interface outside: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface inside: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface mobenga: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface escom: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface management: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface server: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface vpn: aggregate drop 0, aggregate transmit 0
          Priority:
            Interface cafe_member: aggregate drop 0, aggregate transmit 0
        Class-map: class-default

  • My iphone 4 speakers stopped giving me sounds when i play audio or video even while gaming. It works fine when ringing tunes of for voice mails. What is wrong with it?

    My iphone 4 speakers stopped giving me sounds when i play audio or video even while gaming. It works fine when ringing tunes of for voice mails, even works fine with headsets. What is wrong with it?

    well i'd seriosly say point a hot hair drier at the speakers as water has entered the phone most commonly via the home button but avoid getting it too hot let it cool every 3 minutes after constant drying. Don't worry I have honestly dont this with my iPhone 4 GSM 16GB. For future reference avoid letting it get wet.

  • [svn] 3539: Updated RadioButtonGroup to account for recent changes to LayoutManager priority queue .

    Revision: 3539
    Author: [email protected]
    Date: 2008-10-09 10:58:31 -0700 (Thu, 09 Oct 2008)
    Log Message:
    Updated RadioButtonGroup to account for recent changes to LayoutManager priority queue. The order that a RadioButtonGroup was traversed was always dependent on what order that the radio buttons properties were validated. Since this assumption no longer holds true, we are now very specific about how the group orders the RadioButtons (breadth-first for consistency with Flex 2 and Flex 3).
    Check-in Tests: Pass
    Mustella Tests: (RadioButton, RadioButtonGroup) Pass
    Reviewer: Glenn
    QA: Yes
    Bugs: SDK-17248
    Ticket Links:
    http://bugs.adobe.com/jira/browse/SDK-17248
    Modified Paths:
    flex/sdk/trunk/frameworks/projects/framework/src/mx/controls/RadioButtonGroup.as

    Revision: 3539
    Author: [email protected]
    Date: 2008-10-09 10:58:31 -0700 (Thu, 09 Oct 2008)
    Log Message:
    Updated RadioButtonGroup to account for recent changes to LayoutManager priority queue. The order that a RadioButtonGroup was traversed was always dependent on what order that the radio buttons properties were validated. Since this assumption no longer holds true, we are now very specific about how the group orders the RadioButtons (breadth-first for consistency with Flex 2 and Flex 3).
    Check-in Tests: Pass
    Mustella Tests: (RadioButton, RadioButtonGroup) Pass
    Reviewer: Glenn
    QA: Yes
    Bugs: SDK-17248
    Ticket Links:
    http://bugs.adobe.com/jira/browse/SDK-17248
    Modified Paths:
    flex/sdk/trunk/frameworks/projects/framework/src/mx/controls/RadioButtonGroup.as

  • [svn] 3497: Changing internal datastructure utilized by the LayoutManager' s priority queue, in order to provide a mechanism for quicker lookup of items being validated with 'ValidateNow/ValidateClient'.

    Revision: 3497
    Author: [email protected]
    Date: 2008-10-06 14:48:38 -0700 (Mon, 06 Oct 2008)
    Log Message:
    Changing internal datastructure utilized by the LayoutManager's priority queue, in order to provide a mechanism for quicker lookup of items being validated with 'ValidateNow/ValidateClient'. Will be keeping a close watch on perf suite results after this change, to ensure we did not inject memory issues.
    Reviewer: Glenn
    QA: No (Keeping watch on Mustella, but cyclone looked good).
    Modified Paths:
    flex/sdk/trunk/frameworks/projects/framework/src/mx/managers/layoutClasses/PriorityQueue. as

  • What is the best audio or voice audio recording app for iPhone 5 because I want to record audio at a book signing event this coming Tuesday!!!

    What is the best audio or voice audio recording app for iPhone 5 because I want to record audio at a book signing event this coming Tuesday!!! Please get back to me as soon as you can! Thanks

    Ok sorry to bug ya again but if I use the voice memos app if I have the screen locked and just on my belt clip on my side of my pants will it still pick up the authors voice and do I need to have all the volume turned all the way up for it or do I get the app u said for better sound?

  • Does the priority queue always work?

    Hi 
    I have a 8Mbp of wan link which sometime gets saturated and I have shaped average this to 8Mbps but i am running vocie on this WAN link and have defined priority for voice with 850kbps under voice class. My question is when the link is not fully utilized, Will the packets from priority queue are always dequeued first as compared to packets sent from from other queus or will the QoS will not do anything here since the link utilization is lot less than what is sepecified in shape average. I am asking this to confirm if the priority queue always help to overcome the issue of jitter if either the link is saturated or not?
    Thanks

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    You describe PQ and shaping, but the former is usually a part of doing QoS on L2/L3 switches, and the latter on routers.  What device(s) and their IOS versions and the WAN media are you working with?
    On "routers", interfaces generally have FIFO tx-rings, only when they overflow, are packets placed in CBWFQ queues.  Within CBWFQ, LLQ will be dequeued first, but such packets might have already been queued behind other non-LLQ traffic within the interface tx-ring.  (NB: for routers, with tx-rings, when supporting VoIP, you may want to minimize the size of the tx-ring.)
    Shapers, in my experience, are "interesting".  First, I believe many shapers don't account for L2 overhead, but provider CIRs often do.  So unless you shape slower than the nomimal CIR rate, you can send faster than the available bandwidth.  (Often I've found shaping 10 to 15% slower allows for average L2 overhead.)
    Second, shapers work on averages over time intervals.  For VoIP, you'll often want to insure the shaper is using a small Tc, otherwise it will allow FIFO bursts.  (I've found a Tc of 10ms seems to support VoIP fairly well.)
    Third, I suspect some shapers might have their own queues between the interface and the defined policy queues.  If they do, unknown what their queuing organization is or their supported queuing depths.  If this is the case, makes it difficult to engineer QoS.
    Whenever possible, I've found it beneficial to work to avoid using shapers especially for timing sensitive traffic, like VoIP.  In your case, I would suggest, if possible, obtaining 10 Mbps of WAN bandwidth and somewhere passing the traffic through a physical 10 Mbps interface, with a QoS policy.
    But to more directly answer your question, PQ (or LQ) will dequeue its packets next compared to other "peer" queues.  This should always help VoIP for delay and jitter, but there's more involved whether this is necessary and/or whether it's helpful enough when necessary.
    You ask about when a link is saturated, but a link is 100% saturated everytime a packet is being transmitted.  Often link usage is represented in percentages of usage of possible maximum transmission rate over some time period, but when it comes to QoS, 100% utilization might be just fine while 1% utilization is not.  Much, much more information, about your situation, might be needed to offer truly constructive recommendations.

Maybe you are looking for

  • Authorization BI Report

    Hi, I have some problem with the authorization. Here is the scenario, I need to make one user in to access BI report, but only from one cube(let say cube A). The user cannot access, display or execute any others report except the reports generate fro

  • Using 1.3 Action Framework, JButton firing strangely...

    I have a bunch of AbstractActions in an array, like so:      AbstractAction posHousingActions[] = new AbstractAction[] {          new AbstractAction("", UP_ARROW_ICON) {               public void actionPerformed(ActionEvent evt) {                Syst

  • Your message contains profanity - actually no it doesn't

    I've had problems with this forum software before over claims of profanity but after trying to help a fellow toshiba user out with her laptop problems it's claiming my post contains swear words which is untrue. What I would really like to see from th

  • Can't receive messages from one specific contact

    I have turned iMessage off to save my data but for some reason I can send the message as an sms to one all of my contacts ( who have iPhones) and they can read them and I can receive their messages too but for some reason if doesn't work with one con

  • Installeren van een oudere versie photoshop op nieuwe pc

    How photoshop 5.0 up to Windows XP, now to install new PC Windows 7 or 8