Problem connecting oracle10g using php script

i have run following script to check how well configuration is done. I am getting error of
Fatal error: Call to undefined function OCILogon() in C:\Program Files\Apache Group\Apache2\htdocs\oci8test.php on line 2 .
i am new to php. I hv check php apache together. works well.
oracle10g works well.
where could be the problem. i entered username and password also.. pl help me to resolve this.
<?PHP
if ($conn=OCILogon("user@hr","1")) {
echo "<B>SUCCESS ! Connected to database<B>\n";
} else {
echo "<B>Failed :-( Could not connect to database<B>\n";
Ora_Logoff($conn);
phpinfo();
?>

There are various installation guides on the web and in published Oracle-PHP books.
For example there are steps in the Underground PHP and Oracle Manual
-- cj

Similar Messages

  • Using php scripts in catalyst

    I was wondering if it was possible to put a php script on part of a flash page. For example, when u click a button, a box appears that has the most recent posts from your forum. I have the php scipt and everything, i just need to know how i can get it to function like that. Thanks

    That is beyond the scope of Flash Catalyst. You would be able to add that functionality to a Flash Catalyst project from within Flash Builder. You would need to add some ActionScript code to the project to make it work. But you could do the visual design in Flash Catalyst first before working with the code.
    Take a look at the new Data Wizard in Flash Builder to assist in the connections to the PHP script. There are tutorials on tv.adobe.com on this.
    Chris

  • Using PHP scripts to authenticate - "unique_name_from_itunes" ???

    We are attempting to use the PHP scripts (version 1.1) designed by Aaron Axelsen of University of Wisconsin - Whitewater (http://omega1.uww.edu/itunesu) to help facilitate authentication to iTunes U. We're bouncing credentials off our AD via PHP and LDAP, and once the user is authenticated, we're attempting to authorize them with the appropriate level of permission to iTunes U. To start off we're keeping it really simple. We have three levels: admin, instructor, and student. The administrative login works, but when we attempt to authorize a student or instructor, it appears to work but then brings the student to a blank iTune Store page. It does not recognize the identity string. Here's the debug output:
    Analysis
    +The destination string is valid and the corresponding destination item was found.+
    +The identity string is valid and provides the following information:+
    +Display Name Training Test01+
    +Email Address [email protected]+
    +Username testt+
    +User Identifier userid+
    +The credential string is valid but contains no known credentials.+
    +The credential string contains the following credential which is not used within iTunes U:+
    +1. Student@urn:mace:itunesu.com:sites:centenarycollege.edu:uniquename_fromitunes+
    At the end of the Student credential string there it says "uniquename_fromitunes" - what is suppose to be there and where/how do I obtain that data string?
    I have emailed the developer of these scripts and am awaiting his reply, but was hoping someone here might be able to help. Any help would be extremely appreciated. I'm befuddled at the moment and suspect the answer is a simple one.
    Regards,
    John

    It's been a while since I mucked around with credentials, and I'm doing this via Perl rather than PHP, but the principle is the same. To give students site-level browse capability within iTunes U, I've created a credential called "Student@urn:mace:lafayette.edu" and given it download rights within iTunes. When I connect a student to iTunes U, they're given that credential by default. I have similar credentials for Faculty and College (college being everyone who isn't a student or faculty member).
    If memory serves, iTunes U should automatically assign someone the "authenticated" role when they connect via your connection script, so if you setup content to be downloadable by "authenticated", then that should allow your students (and anyone else who properly authenticates) into the site. That allows for a quick and dirty separation of public vs. college content without mucking around with specific faculty/student/staff roles. If you want to go further, and restrict access to specific sections our courses, then you'll definitely want those sorts of focused roles, and make use of the ${IDENTIFIER} technique described in the access control documentation.
    Ken Newquist
    Lafayette College

  • Problem-Report generation using shell script

    Hi
    We have the Production database and the Reporting database (copy of Production database),
    both on Oracle 9.2.0.5 and Solaris 5.8. There is a package inside the Oracle database, which extracts some data from inside the
    database, and would generate a report. A shell script has been created in Solaris which would
    send in the parameters and call the pakage to generate the report. The parameters it is sending is
    the name of report to be generated, and the location where it is to be generated, both hard-coded into
    the script. The script is scheduled to run through crontab.
    The problem we are facing is that, if we run the script for Reporting database, it successfully
    generates the report. But if we use that script for Production database, it gives the error
    "Invalid directory Path". I have tried using various other directory paths, even '/tmp'
    and '/', but it still gives the same error when executed for Production dataabse.
    Could somebody provide any ideas what might be going wrong.
    The reasons it is to be executed on Prod db and not the Reporting database are unavoidable.
    It anyway runs in off business hours and takes about 10secs to execute.
    Please do let me know if there is any other info that I missed to provide here.
    Thanks in advance...

    I will be just guessing because you didn't provide contents of script and package.
    The "Invalid directory path" as you said could be ORA-29280 due non existent directory.
    Try execute (as sys or system) select * from dba_directories; (or select * from all_directories; as user which the script is login to) on both databases and compare the results. If there is missing your important directory then create it using create directory <dirname>; (from sqlplus and don't forget to grant rights for user).
    This error could come from shell script. In that case you should find resolution yourself because you didn't provide script source.

  • Problem uploading images with php script.

    As a webdebdesigner i developped a cms system to upload images with php to a mysql database. Firefox version 5.0.1 for MAC and earlier have no problems with uploading through the script. But after that version it is impossible to upload images bigger then 250kb. The page where the customer chooses his image for upload stalls and the form is not sent to the actual upload script, which should validate and process the image.
    This problem only occurs in Firefox, all other browsers work just fine!
    On top of that: Giving feedback to firefox not possible for MAC.

    Try posting at the Web Development / Standards Evangelism forum at MozillaZine. The helpers over there are more knowledgeable about web site development issues with Firefox. <br />
    http://forums.mozillazine.org/viewforum.php?f=25 <br />
    You'll need to register and login to be able to post in that forum.

  • DW CS5, Sending contact form results to email with page redirection using php script

    I am currently building a site from scratch with Dreamweaver, with the intent of replacing my current website layout that was designed using Intuit's website builder. My dreamweaver site is not online, but i have setup a local test server on my computer, using XAMPP, and i have an apache server with a MySQL database and a mercury mailserver running. I mention that in case it makes a difference in your answers. If necessary, I can include those settings, but that may be asking too much.
    I have an html contact form for users to schedule service appointments. I need the resulting actioned php file to do the following after submit is clicked: verify certain fields have been entered; prevent spammers or verify human visitors; send the form results to a (hidden from public view of any kind) email address; redirect user to a confirmation page, or an error page.
    I found the following code but being less than a newbie im not sure what needs to be changed, or if its even the right script i should be using:
    5 <?php
    6 $email = $_POST['email'];
    7 $mailto = '[email protected]';
    8 $mailsubj = 'You Have a Service Request';
    9 $url = '/MyLandingPage.html';
    10 $req = '0';
    11 $mailbody = "Results from form:\r\n";
    12 $space = ' ';
    13 $line = '
    14 ';
    15 foreach ($_POST as $key => $value)
    16 {
    17 if ($req == '1')
    18 {
    19 if ($value == '')
    20 {echo "$key is empty";die;}
    21 }
    22 $j = strlen($key);
    23 if ($j >= 20)
    24 {echo "Name of form element $key cannot be longer than 20 characters";die;}
    25 $j = 20 - $j;
    26 for ($i = 1; $i <= $j; $i++)
    27 {$space .= ' ';}
    28 $value = str_replace('\r\n', "$line", $value);
    29 $conc = "{$key}:$space{$value}$line";
    30 $text .= $conc;
    31 $space = ' ';
    32 }
    33 mail($emailadd, $subject, $text, 'From: '.$emailadd.'');
    34 echo '<META HTTP-EQUIV=Refresh CONTENT="0; URL='.$url.'">';
    35 ?>
    Can anyone please illuminate me on what I need?
    Thank You in advance

    Take a read here, this might enlighten you a little.
    http://www.paulgdesigns.com/learncontactform.php
    You are doing this with your local testing server, is it set up to email?
    Gary

  • Problem connecting after using Itunes 5.0. Please help!

    I updated to Itunes 5.0 a couple of days ago. I didn't have any problems installing it and was running fine. Then when I had purchased some music when it was imported to my Ipod, a couple of the songs were freezing. I was trying to figure out whether it was the song on my Ipod or if it was the purchased song. While I was doing that my program froze and told me it no longer recognized my Ipod and come up with the error message that says Itunes is not responding, End Now.
    After I did that, it seemed as though my Ipod had been deleted, and I thought all hope was lost. Now after looking in the files, it shows my Ipod Control folder has just been hidden. I have gone in and shown the files so they are no longer hidden. I also noticed it had the 4 letter song names in there too now. When I open Itunes again, it just hides them again and continues to say its unable to recognize my Ipod and that I need to update my Ipod software, which I have tried and still doesn't work.
    What should I do now? I was thinking about uninstalling Itunes 5.0 and going back to my old version, but I have seen that other people have been having problems with that.
    My main concern is that I don't want to lose my music because I don't have it backed up because my computer doesn't have the space to hold all of my songs and I don't have any external drives or anything to store them on.
    Please help!

    I have had a very similar problem
    -Currently using: Windows XP Home edition with most recent updates
    -2.39Ghz processor, Itunes 5
    -IPOD 20GB I only have used up 3.9GB
    Very similar problem
    My IPOD has recently had a weird problem after installing Itunes 5. When I first connect the ipod to the computer everything seems to be working fine, because the ipod displays the "please do not disconnect" message, and ITUNES come up on the screen and lets me play music from my ipod only for a brief few minuets. The computer then stops playing the song it was currently playing and I tunes freezes. After that point the only way to unfreeze Itunes is to press select/menu on the ipod. When the ipod restarts and I plug the ipod back into my computer it won't bring I tunes up again, and I am unable to access the ipod drive. A screen comes up after 10 minuets saying I have to reformat my ipod because it can not be read. I have already done so about 10 times and I still have the same problem.
    My ipod doesn't freeze when I'm just listening to it with my earphones or on my stereo, but it laggs more thean usual when changeing songs or menus (I have only used up 3.9GB). I have also tried using my ipod on other computers and I get the same problem. Please Help!

  • Problems with ö, ü, ä when using download script in apex

    My Problem is that the procedure which is described here http://download.oracle.com/docs/cd/B32472_01/doc/appdev.300/b32469/up_dn_files.htm#CJAHDJDA returns
    for file nöx.txt -> nöx.txt
    if i change the coding from UTF8 to "westeuropean (Windows)" the name is also on the page nöx.txt.
    Why does the internetexplorer not support the UTF8 for the filesnames?

    Hello Oliver,
    Try setting the “Automatic CSV Encoding” field, in your application globalization section, to “YES”.
    Regards,
    Arie.

  • Having problems connecting getting results from MySQL

    Hi,
    I'm trying to learn some aspects of J2EE but i'm a bit
    stuck with EJB and i'm not sure what is going wrong so that's why i'm here :)
    What I want to do is very simple.
    I have a working MySQL database "musiccatalog" and I want to query it using any sort of client so to do that
    I create an Entreprise Application using netBeans 4.1
    Then I create a new CMP Bean called Album.
    I need something simple to test on so I have only one CMP Bean.
    My Album CMP Beans contains following CMP fields albumId, artistId, name, releaseDate, insertionTime.
    I also have a bunch of methods for LocalInterface: getters, setters, finders, and create() method.
    I don't need to add anything or write in the code cause it is generated by the IDE (netBeans 4.1)
    So my Album CMP Bean is written and I deploy project to see if all works fine. It works. My EJB-Module and Web-Module are deployed on the server (Sun Application Server 8).
    Next I create a new SessionBean called AlbumFacade that will access my CMP bean.
    I will have to add a lookupAlbumBean() method that will return a LocalHome interface, I also add a private variable of Type AlbumLocalHome. This variable is intialized in ejbCreate() method using the lookAlbumBean() method.
    Now it's time to add a business method to my SessionBean.
    I create a new buisness method public String getAlbumInfo()
    public String getAlbumInfo(int idAlbum) throws javax.ejb.FinderException {
    ejb.AlbumLocal albumL = albumLH.findByPrimaryKey(new Integer(idAlbum));
    return albumL.getAlbumName();
    so in this method i will get a reference to albumL interface and i will ask it to return the albumName of an album.
    So at this moment i'm done with Beans :)
    I redeply the app and it is redeplyed successfully.
    Now to test my beans i write a client. It'll be a servlet.
    What I need to do next is to create a ServiceLocator in my WebModule. This ServiceLocator will be used in the Servlet to lookup the remote interface of the AlbumFacade SessionBean.
    MyServlet will output a form with a textfield and a submit button where the user (me) types a number.
    If the servlet receives albumId parameter it'll look up the remote AlbumFacadeRemote interface and then i'll call the buisness logic of the SessionBean ( getAlbumInfo())
    and at this moment I should reach what I wanted but....
    The Application deploys and after I enter a number I got a vert nice StackTrace like this
    type Exception report
    message
    description The server encountered an internal error () that prevented it from fulfilling this request.
    exception
    javax.transaction.TransactionRolledbackException: CORBA TRANSACTION_ROLLEDBACK 9998 Maybe; nested exception is:
         org.omg.CORBA.TRANSACTION_ROLLEDBACK: vmcid: 0x2000 minor code: 1806 completed: Maybe
         com.sun.corba.ee.impl.javax.rmi.CORBA.Util.mapSystemException(Util.java:207)
         com.sun.corba.ee.impl.javax.rmi.CORBA.Util.wrapException(Util.java:651)
         javax.rmi.CORBA.Util.wrapException(Util.java:279)
         com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:177)
         com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(Unknown Source)
         ejb._AlbumFacadeRemote_DynamicStub.getAlbumInfo(_AlbumFacadeRemote_DynamicStub.java)
         web.AlbumServlet.processRequest(AlbumServlet.java:55)
         web.AlbumServlet.doPost(AlbumServlet.java:81)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:767)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
         sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         java.lang.reflect.Method.invoke(Method.java:585)
         org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:249)
         java.security.AccessController.doPrivileged(Native Method)
         javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
         org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:282)
         org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:165)
         java.security.AccessController.doPrivileged(Native Method)
         org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:362)
    note The full stack trace of the root cause is available in the Sun-Java-System/Application-Server logs.
    and it happens when the application queries the database.
    And unfortunately I don't see what may be wrong. If I do the same with a pointbasde sample database everything works fine.
    I tried to connect to MySQL via JConnector and also via jdbc:odbc bridge but i got still the same error.
    It drives me really mad 'coz I don't know what I do wrong.
    I can connect to database. But then something goes wrong.
    Can somebody give me an idea of what maybe wrong?
    Thanks :)

    Hail!!
    In fact, the problem IS in your PHP script.
    $senderEmail = $_POST['eMail'];
    $senderEmail = stripslashes($eMail);
    The last one should be:
    $senderEmail = stripslashes($senderEmail);
    PS:
    Next time, put your code inside formating tags...
    It will be easy for people to read your question and will improve the chances that someone answer it.

  • Connecting oracle with php

    hi all,
    i am using Xammp 1.7.4, PHP version 5.3.5, apache 2.2, and oracle 11g. actually i know how to connect MySql using php, but now i am trying to connect oracle using php. Can any 1 tell me the clear cut steps to do the same ?

    You need to add the right oci8 DLL or .so to php.ini and make sure it has access to Oracle client libraries. These Oracle libraries are from an Oracle Home or Oracle Instant Client.
    Without knowing your platform and whether the Oracle DB is on the same machine as Xampp the best place to start is to look at
    http://www.oracle.com/technetwork/articles/technote-php-instant-084410.html

  • PHP scripts are not working after deploying it on website

    Hi,
    I have recently deployed my flex application on a web hosting (000webhost.com) and now my application is getting launched properly. Visit (www.kpratik.webatu.com).
    I have used PHP script to interact with database MySQL. Locally everything was working fine but when I have deployed it to internet my PHP scripts are not working and any database opeartion is not getting performed. I have already chaned to host, username password in the PHP file as given my service provider.
    Please let me know if you have any input on this.
    Reponse will be highly appreciated.
    Regards,
    Pratik

    Hello,
    Ok let me explain you where exactly it is going wrong.
    I am constructing SQL query in my ActionScript code and I am passing this query to my PHP script using HTTPService. Now when I am hardcoing the query in PHP script i found it is working perfectly which means my query is not getting passed to PHP script.
    Please let me know what could be the reason.
    I am using POST method for HTTPService.
    Thanks,
    Pratik

  • URLVariables and php script conflict

    I am trying to set up some url variables to post to a php
    contact script. Problem is that the php script expects a variable
    'full-name' (note the hyphen). When I try to set my url variables
    in flash with urlVars.full-name = "cool dude"; it give me an error
    saying "1050: cannot assign a non-reference value". I can only
    assume that the hyphen is giving the error. I could simply take out
    the hyphen in the php script, I know that seems like the right
    thing to do, but it's not, because all other scripts that post to
    the contact would be broken! Any ideas?

    this is from w3schools:
    http://www.w3schools.com/php/php_variables.asp
    Variable Naming Rules
    * A variable name must start with a letter or an underscore
    * A variable name can only contain alpha-numeric characters
    and underscores (a-Z, 0-9, and _ )
    * A variable name should not contain spaces. If a variable
    name is more than one word, it should be separated with underscore
    ($my_string), or with capitalization ($myString)
    i believe POST data is just a string in an associative array
    and not treated like a normal php variable. i would think hyphens
    in that are ok, but i'm not sure. however, i do know that hyphens
    in actual php variable names is not allowed.

  • I have a problem with a php script for loading dynamic pages using flash as menu bar, but the urls in the flash is not processed by the php script only in firefox

    '''php script:'''
    <?php
    $page = $_GET['page'];
    if ($page)
    include ("inc/".$page.".php");
    else
    include ("inc/home.php");
    ?>
    '''Action script 2.0 in flash:'''
    on(release){
    getURL("index.php?page=new");
    }

    A good place to ask questions and advice about web development is at the mozillaZine Web Development/Standards Evangelism forum.<br />
    The helpers at that forum are more knowledgeable about web development issues.
    You need to register at the mozillaZine forum site in order to post at that forum.
    See http://forums.mozillazine.org/viewforum.php?f=25

  • Webserver on DMZ cannot send email via php script using SMTP (cisco firewall pix 515e)

    Hello,
    I have two web servers that are sitting in a DMZ behind a Cisco Firewall PIX 515e. The webservers appear to be configured correctly as our website and FTP website are up. On two of our main website, we have two contact forms that use a simple html for to call a php script that uses smtp as its mailing protocol. Since, I am not the network administrator, I don't quite understand how to  read the current configurations on the firewall, but I suspect that port 25 is blocked, which prevents the script from actually working or sending out emails.  What I've done to narrow the problem done is the following: I used a wamp server to test our scripts with our smtp servers settings, was able to successfully send an email out to both my gmail and work place accounts. Currently, we have backupexec loaded on both of these servers, and when I try to send out an alert I never receive it. I think because port 25 is closed on both of those servers.  I will be posting our configuration. if anyone can take a look and perhaps explain to me how I can change our webservers to communicate and successfully deliver mail via that script, I would gladly appreciate it. our IP range is 172.x.x.x, but it looks like our webservers are using 192.x.x.x with NAT in place. Please someone help.
    Thanks,
    Jeff Mateo
    PIX Version 6.3(4)
    interface ethernet0 100full
    interface ethernet1 100full
    interface ethernet2 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security50
    enable password GFO9OSBnaXE.n8af encrypted
    passwd GFO9OSBnaXE.n8af encrypted
    hostname morrow-pix-ct
    domain-name morrowco.com
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    no fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 12.42.47.27 LI-PIX
    name 172.20.0.0 CT-NET
    name 172.23.0.0 LI-NET
    name 172.22.0.0 TX-NET
    name 172.25.0.0 NY-NET
    name 192.168.10.0 CT-DMZ-NET
    name 1.1.1.1 DHEC_339849.ATI__LEC_HCS722567SN
    name 1.1.1.2 DHEC_339946.ATI__LEC_HCS722632SN
    name 199.191.128.105 web-dns-1
    name 12.127.16.69 web-dns-2
    name 12.3.125.178 NY-PIX
    name 64.208.123.130 TX-PIX
    name 24.38.31.80 CT-PIX
    object-group network morrow-net
    network-object 12.42.47.24 255.255.255.248
    network-object NY-PIX 255.255.255.255
    network-object 64.208.123.128 255.255.255.224
    network-object 24.38.31.64 255.255.255.224
    network-object 24.38.35.192 255.255.255.248
    object-group service morrow-mgmt tcp
    port-object eq 3389
    port-object eq telnet
    port-object eq ssh
    object-group network web-dns
    network-object web-dns-1 255.255.255.255
    network-object web-dns-2 255.255.255.255
    access-list out1 permit icmp any any echo-reply
    access-list out1 permit icmp object-group morrow-net any
    access-list out1 permit tcp any host 12.193.192.132 eq ssh
    access-list out1 permit tcp any host CT-PIX eq ssh
    access-list out1 permit tcp any host 24.38.31.72 eq smtp
    access-list out1 permit tcp any host 24.38.31.72 eq https
    access-list out1 permit tcp any host 24.38.31.72 eq www
    access-list out1 permit tcp any host 24.38.31.70 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq https
    access-list out1 permit tcp any host 24.38.31.93 eq smtp
    access-list out1 permit tcp any host 24.38.31.93 eq ftp
    access-list out1 permit tcp any host 24.38.31.93 eq domain
    access-list out1 permit tcp any host 24.38.31.94 eq www
    access-list out1 permit tcp any host 24.38.31.94 eq https
    access-list out1 permit tcp any host 24.38.31.71 eq www
    access-list out1 permit tcp any host 24.38.31.71 eq 8080
    access-list out1 permit tcp any host 24.38.31.71 eq 8081
    access-list out1 permit tcp any host 24.38.31.71 eq 8090
    access-list out1 permit tcp any host 24.38.31.69 eq ssh
    access-list out1 permit tcp any host 24.38.31.94 eq ftp
    access-list out1 permit tcp any host 24.38.31.92 eq 8080
    access-list out1 permit tcp any host 24.38.31.92 eq www
    access-list out1 permit tcp any host 24.38.31.92 eq 8081
    access-list out1 permit tcp any host 24.38.31.92 eq 8090
    access-list out1 permit tcp any host 24.38.31.93 eq 3389
    access-list out1 permit tcp any host 24.38.31.92 eq https
    access-list out1 permit tcp any host 24.38.31.70 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq www
    access-list out1 permit tcp any host 24.38.31.74 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq smtp
    access-list out1 permit tcp any host 24.38.31.75 eq https
    access-list out1 permit tcp any host 24.38.31.75 eq www
    access-list out1 permit tcp any host 24.38.31.75 eq smtp
    access-list out1 permit tcp any host 24.38.31.70 eq smtp
    access-list out1 permit tcp any host 24.38.31.94 eq smtp
    access-list dmz1 permit icmp any any echo-reply
    access-list dmz1 deny ip any 10.0.0.0 255.0.0.0
    access-list dmz1 deny ip any 172.16.0.0 255.240.0.0
    access-list dmz1 deny ip any 192.168.0.0 255.255.0.0
    access-list dmz1 permit ip any any
    access-list dmz1 deny ip any any
    access-list nat0 permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255.0
    access-list nat0 permit ip host 172.20.8.2 host 172.23.0.2
    access-list nat0 permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-split-tun permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255
    .0
    access-list vpn-split-tun permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.2
    55.255.0
    access-list vpn-dyn-match permit ip any 192.168.220.0 255.255.255.0
    access-list vpn-ct-li-gre permit gre host 172.20.8.2 host 172.23.0.2
    access-list vpn-ct-ny permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list vpn-ct-ny permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-2 permit ip host 192.168.10.141 CT-NET 255.255.248.
    0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.255.25
    5.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-1 permit ip host 192.168.10.140 CT-NET 255.255.248.
    0
    access-list static-dmz-to-li-1 permit ip CT-DMZ-NET 255.255.255.0 CT-NET 255.255
    .248.0
    access-list vpn-ct-li permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip host 10.10.2.2 host 10.10.1.1
    access-list in1 permit tcp host 172.20.1.21 any eq smtp
    access-list in1 permit tcp host 172.20.1.20 any eq smtp
    access-list in1 deny tcp any any eq smtp
    access-list in1 permit ip any any
    access-list in1 permit tcp any any eq smtp
    access-list cap4 permit ip host 172.20.1.82 host 192.168.220.201
    access-list cap2 permit ip host 172.20.1.82 192.168.220.0 255.255.255.0
    access-list in2 deny ip host 172.20.1.82 any
    access-list in2 deny ip host 172.20.1.83 any
    access-list in2 permit ip any any
    pager lines 43
    logging on
    logging timestamp
    logging buffered notifications
    logging trap notifications
    logging device-id hostname
    logging host inside 172.20.1.22
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside CT-PIX 255.255.255.224
    ip address inside 172.20.8.1 255.255.255.0
    ip address DMZ 192.168.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool ctpool 192.168.220.100-192.168.220.200
    ip local pool ct-thomson-pool-201 192.168.220.201 mask 255.255.255.255
    pdm history enable
    arp timeout 14400
    global (outside) 1 24.38.31.81
    nat (inside) 0 access-list nat0
    nat (inside) 1 CT-NET 255.255.0.0 2000 10
    nat (DMZ) 0 access-list nat0-dmz
    static (inside,DMZ) CT-NET CT-NET netmask 255.255.0.0 0 0
    static (inside,outside) 24.38.31.69 172.20.8.2 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.94 192.168.10.141 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.71 172.20.1.11 dns netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.93 192.168.10.140 netmask 255.255.255.255 0 0
    static (DMZ,inside) 24.38.31.93 access-list static-dmz-to-ct-1 0 0
    static (DMZ,inside) 24.38.31.94 access-list static-dmz-to-ct-2 0 0
    static (inside,outside) 24.38.31.92 172.20.1.56 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.91 192.168.10.138 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.90 192.168.10.139 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.72 172.20.1.20 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.73 172.20.1.21 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.70 172.20.1.91 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.88 192.168.10.136 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.89 192.168.10.137 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.74 172.20.1.18 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.75 172.20.1.92 netmask 255.255.255.255 0 0
    access-group out1 in interface outside
    access-group dmz1 in interface DMZ
    route outside 0.0.0.0 0.0.0.0 24.38.31.65 1
    route inside 10.10.2.2 255.255.255.255 172.20.8.2 1
    route inside CT-NET 255.255.248.0 172.20.8.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa-server ct-rad protocol radius
    aaa-server ct-rad max-failed-attempts 2
    aaa-server ct-rad deadtime 10
    aaa-server ct-rad (inside) host 172.20.1.22 morrow123 timeout 7
    aaa authentication ssh console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 173.220.252.56 255.255.255.248 outside
    http 65.51.181.80 255.255.255.248 outside
    http 208.65.108.176 255.255.255.240 outside
    http CT-NET 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community m0rroW(0
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt connection permit-pptp
    crypto ipsec transform-set 3des-sha esp-3des esp-sha-hmac
    crypto ipsec transform-set 3des-md5 esp-3des esp-md5-hmac
    crypto dynamic-map dyn_map 20 match address vpn-dyn-match
    crypto dynamic-map dyn_map 20 set transform-set 3des-sha
    crypto map ct-crypto 10 ipsec-isakmp
    crypto map ct-crypto 10 match address vpn-ct-li-gre
    crypto map ct-crypto 10 set peer LI-PIX
    crypto map ct-crypto 10 set transform-set 3des-sha
    crypto map ct-crypto 15 ipsec-isakmp
    crypto map ct-crypto 15 match address vpn-ct-li
    crypto map ct-crypto 15 set peer LI-PIX
    crypto map ct-crypto 15 set transform-set 3des-sha
    crypto map ct-crypto 20 ipsec-isakmp
    crypto map ct-crypto 20 match address vpn-ct-ny
    crypto map ct-crypto 20 set peer NY-PIX
    crypto map ct-crypto 20 set transform-set 3des-sha
    crypto map ct-crypto 30 ipsec-isakmp
    crypto map ct-crypto 30 match address vpn-ct-tx
    crypto map ct-crypto 30 set peer TX-PIX
    crypto map ct-crypto 30 set transform-set 3des-sha
    crypto map ct-crypto 65535 ipsec-isakmp dynamic dyn_map
    crypto map ct-crypto client authentication ct-rad
    crypto map ct-crypto interface outside
    isakmp enable outside
    isakmp key ******** address LI-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address 216.138.83.138 netmask 255.255.255.255 no-xauth no-c
    onfig-mode
    isakmp key ******** address NY-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address TX-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp identity address
    isakmp nat-traversal 20
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    isakmp policy 30 authentication pre-share
    isakmp policy 30 encryption 3des
    isakmp policy 30 hash md5
    isakmp policy 30 group 1
    isakmp policy 30 lifetime 86400
    vpngroup remotectusers address-pool ctpool
    vpngroup remotectusers dns-server 172.20.1.5
    vpngroup remotectusers wins-server 172.20.1.5
    vpngroup remotectusers default-domain morrowny.com

    Amit,
    I applaud your creativity in seeking to solve your problem, however, this sounds like a real mess in the making. There are two things I don't like about your approach. One, cron -> calling Java -> calling PHP -> accessing database, it's just too many layers, in my opinion, where things can go wrong. Two it seems to me that you are exposing data one your website (with the PHP) that you may not want expose and this is an important consideration when you are dealing with emails and privacy and so on.
    I think the path of least resistance would be to get a new user account added to the MySQL database that you can access remotely with your Java program. This account can be locked down for read only access and be locked down to the specific IP or IP range that your Java program will be connecting from.
    Again I applaud your creativity but truly this seems like a hack because of the complexity and security concerns you are introducing and I think is a path to the land of trouble. Hopefully you will be able to get a remote account set up.

  • Calling Apex Application using a php script

    Hi guys,how can i directly call my Apex Application using a php script.i have apex 2.1 intalled on my system.i created an application and i want my application users to connect directly to the applications login page.I mean somthing like this
    (http://127.0.0.1:8080/apex/f?p=103)
    and i want users to connect using somthing like this
    (http://my system/index.php) or localhost/index.php?
    i can run a script query and access my data stored on the database,but what i really want is to connect directly to the login page of my application,so that the staffs in HR can connect direstly to there HR application while those in Sales Will connect direcly to there applications page so it will look like this
    http://my system/hr.php
    http://mysystem/sales.php

    Originally, I had problems w/ the file being placed in
    C:/whatever.ext b/c I wasn't using relative paths.
    This is the code I use:
    $MAXIMUM_FILESIZE = 1024 * 1024 * 2; // 2MB
    $newFileLoc = "./wherever/file.jpg"
    if ($_FILES['Filedata']['size'] <= $MAXIMUM_FILESIZE) {
    move_uploaded_file($_FILES['Filedata']['tmp_name'],
    "./temporary/".$_FILES['Filedata']['name']);
    rename( "./temporary/".$_FILES['Filedata']['name'],
    $newFileLoc );
    chmod( $newFileLoc, 0777 );
    Modified from this article by Adobe:
    http://livedocs.adobe.com/flex/201/html/wwhelp/wwhimpl/common/html/wwhelp.htm?context=Live Docs_Book_Parts&file=17_Networking_and_communications_173_6.html

Maybe you are looking for

  • Associative array comparison and INSERT upon IF condition

    Hi Guys, I have written this pl sql code to identify non existing sellers and insert their sales channel information into the dimension table (dimensional table update). Somehow,......nothing is inserted and this script runs for 12 hours+ without any

  • Safari can't open, always crashes

    Just completed a java update from system update. Now Safari won't open. Searched through crash log and didn't see an error. Don't know what else to look for among the long list of words. Process: Safari [3499] Path: /Applications/Safari.app/Contents/

  • How to use this forum - is there a way i an receive an email alert ?

    Hi Everyone, Is there a way I can receive an email alert when I post, or when I want to follow another's post? Is there a way to receive an email digest of the day's posting actiivity? pls advise, tx, sandra

  • Weird non-responding MacBook Pro 13

    From time to time my MBP goes mad. Everything that was already launched is working as usual, but I cannot change the volume or launch any application, it just jumps in dock and then closes down. Reboot is only possible with power button (I mean I hol

  • Is it possible map a scenario...intergating OM n SD...???

    Dear All, One of our client is required a report based on sales people...The requirement is in this way...there is hirachy from Sales Representative...Sales Officer...ASM....RM....GM. for getting sales report... they want it separately...like Sales r