Problem - Discussion auto-linkify breaks IPv6 addresses

Discussions auto-linkify feature seems to break when specifying a URL with an IPv6 address.
Safari (and most web browsers) use square brackets when specifying an IPv6 address in the URL. The discussions software seems to see this and then break the link into two separate (useless) links.
Example- http://[2001:4860:0:2001::68]
In the example, I have added brackets around the address, but Discussions strips the address). There appears to be no way to actually get a link to an IPv6 address[0].
[0]- Of course, everyone should be doing DNS and in a perfect world, we'd never see IP addresses, I'm just being pedantic.

Unfortunately, the href formatting strips the brackets too. Typing this:
<a href="http://[2001:4860:0:2001::68]">This should link to Google's IPv6 IP</a>
but gets mangled to this:
This should link to Google's IPv6 IP
Looks like Discussions strips all pairs of square brackets (possibly because it thinks it's a BBCode command). Using the HTML codes for the brackets in the href doesn't seem to fix it either.
TinyURL works with IPv6 IPs, but oddly I think you've lead me to find a bug with Safari. Safari doesn't seem to be able to parse the location HTML header if it directs to an IPv6 address:
Going to the following link in Safari (v4):
http://tinyurl.com/bc8x9a
will give the error +Safari can’t open the page “http://tinyurl.com/bc8x9a” because Safari can’t find the server “tinyurl.com”.+
But if you go to Tiny URL's preview site:
http://preview.tinyurl.com/bc8x9a
It will show as a legitimate site and you can click the link from there and it works.

Similar Messages

  • IPv6 address is not send over WLan

    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Normale Tabelle";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-parent:"";
    mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
    mso-para-margin:0cm;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:10.0pt;
    font-family:"Times New Roman";
    mso-ansi-language:#0400;
    mso-fareast-language:#0400;
    mso-bidi-language:#0400;}
    Hi!
    My Cisco router is working fine with Ethernet and IPv6. There is a “little” problem concerning the promotion of IPv6 addresses under WLan. When I’m using WLan the router is not providing any IPv6 addresses, only IPv4. Do you have any clue why the router is not promoting the IPv6 addresses.
    btw. I will post the config later on, when I’m at home.
    Cheers

    It´s an integrated AP!
    Here is the Code:
    gateway#sh ver
    Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(15)T11, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2009 by Cisco Systems, Inc.
    Compiled Thu 29-Oct-09 12:35 by prod_rel_team
    ROM: System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE
    gateway uptime is 8 weeks, 13 hours, 17 minutes
    System returned to ROM by power-on
    System restarted at 20:04:22 MET Thu Apr 29 2010
    System image file is "flash:c870-advipservicesk9-mz.124-15.T11.bin"
    bridge irb
    dot11 ssid v6gregor
       vlan 2
       authentication open
       authentication key-management wpa
       wpa-psk ascii 7 1407051D5A03382E232721
    ip dhcp pool wlan_v6
       network 10.11.60.0 255.255.255.0
       default-router 10.11.60.1
       domain-name ipv4.at
       dns-server 195.70.224.45 62.218.28.35
    interface Dot11Radio0
    description Provisioned by CSM (private interface)
    no ip address
    load-interval 30
    no dot11 extension aironet
    encryption vlan 2 mode ciphers tkip
    encryption vlan 3 mode ciphers tkip
    encryption vlan 1 mode wep optional
    ssid daham
    ssid open
    ssid v6gregor
    mbssid
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    power local cck 17
    power local ofdm 17
    power client 17
    channel 2432
    station-role root
    rts threshold 2312
    antenna receive right
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0.2
    encapsulation dot1Q 2
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 spanning-disabled
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    interface BVI1
    ip address 10.10.10.1 255.255.255.0
    ip nbar protocol-discovery
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1300
    ipv6 address 2001:938:DAD:400::1/64
    ipv6 enable
    ipv6 nd prefix 2001:938:DAD:400::/64
    ipv6 nd router-preference High
    interface BVI2
    ip address 10.11.60.1 255.255.255.0
    ip nbar protocol-discovery
    ip nat inside
    ip virtual-reassembly
    ipv6 address 2001:938:DAD:800::1/64
    ipv6 enable
    ipv6 mtu 1300
    ipv6 nd prefix 2001:938:DAD:800::/64
    ipv6 nd managed-config-flag
    ipv6 nd router-preference High
    ipv6 nd ra interval 60

  • How to solve the auto word break problem in Arabic language Flex project

    Hi, I'm using Flex SDK 3.5 to develop a game in Arabic. Now I have a problem with the auto word break on the TextArea Control.
    The output looks like this (Sorry I can't type arabic, so I use English instead)
    I don't know any A
    rabic text
    The expected outpit should be
    I don't know any
    Arabic text
    My settings of the textarea are fine in English version games. But just didn't work in Arabic. Any idea how to solve this problem? Thanks.

    Hi Rodger,
    Sorry to reopen this thread again. I was puzzled by the data format in Motion-DDK.
    From the Motion-DDK, if u32, i32 and f64 data are passed to and from the controller, a specific format must be followed as below:
    u32:
    u32 cmddata[x] = (WORD) (u32data ?16);
    cmddata[x + 1] = (u16) u32data;
    i32:
    i32 cmddata[x] = (WORD) (i32data ?16);
    cmddata[x + 1] = (i16) i32data;
    f64:
    f64—big endian order cmddata[x] = ((u16) (&f64data)) [3];
    cmddata[x + 1] = ((u16) (&f64data)) [2];
    cmddata[x + 2] = ((u16) (&f64data)) [1];
    cmddata[x + 3] = ((u16) (&f64data)) [0];
    f64—little endian order cmddata[x] = ((u16) (&f64data)) [0];
    cmddata[x + 1] = ((u16) (&f64data)) [1];
    cmddata[x + 2] = ((u16) (&f64data)) [2];
    cmddata[x + 3] = ((u16) (&f64data)) [3];
    My first question: is the "?" symbol means the >> (shift operator) or something else?
    The second question is: if "?" means ">>" in this list, all the u32 and i32 data are always transferred in big-endian order. Is it the only correct way to deliver the i32 and u32 data? Or I can pass the u32 and i32 either in little-order or big-order depending on my platform?
    The last one: could you provide a feasible C code on how to convert the f64 data to u16?
    I first followed the format in the list to convert the f64 data, but met with a lot of compiler errors in VC++. After checked with MSDN, it is said the convert process is double(f64)->long(i32)->unsigned short(u16). But the decimal part of double will be truncated during converting to long...
    So, could you help me with some very simple sample code on the convert process? 
    Thank you for your support!
    Rick
    MSP

  • Mail has problem with auto address.

    My mail recently has had a problem with auto addressing. Sometimes it fills in the address, at other times it will not. I have checked mail preferences often...making sure auto-address is on. I CAN use the address book to click on an address when auto addressing doesn't work. Mail is also quirky about quitting and sometimes preferences have to be re-edited to send. Basically, it is behaving badly. What to do? Thanks ACE

    My mail recently has had a problem with auto
    addressing. Sometimes it fills in the address, at
    other times it will not. I have checked mail
    preferences often...making sure auto-address is on. I
    CAN use the address book to click on an address when
    auto addressing doesn't work. Mail is also quirky
    about quitting and sometimes preferences have to be
    re-edited to send. Basically, it is behaving badly.
    What to do? Thanks ACE
    Later...12/03. Autofill not working with mail or safari. Autofill icon, when touched says something like...autofill has no infomation. this is weird, since it had been working nicely for 2.5 years. I've tried everything I could think of. Need a pro's help...MNICE

  • IPv6 Addressing Point to Point Links in the enterprise

    For an enterprise, it doesn't seem to make sense to use Global addressing for point to point, transit-only links and loopbacks.
    Link-local only addressing breaks debugging tools like traceroute, DNS, etc.
    Is Unique Local the correct choice for this?
    I've searched quite a bit and I've not found a lot of discussion about scope selection for point to point links.  Some RFCs such as 6164 imply Global scope vs Unique Local scope usage is a preference.  Most discussions of point to point addressing focus on bit length.  I'm assuming this means design concerns are agnostic toward scope selection.
    Is anyone aware of documentation I've missed or have any recommendations in this area?
    If ULA was the correct choice, address hierarchy might look like this:
    DataNetwork1 -- Router1 -- ULA.1.1 -- Link -- ULA1.2 -- Agg Router -- Core
    DataNetwork2 -- Router2 -- ULA.2.1 -- Link -- ULA2.2 -- Agg Router /
    DataNetwork3 -- Router3 -- ULA.3.1 -- Link -- ULA3.2 -- Agg Router /
    The network core would have summarized entries for DataNetwork[1|2|3] and ULA[1|2|3].  IE, there would be a Global hierarchy and a ULA hierarchy.

    Scott,
    Let me break this down into some categories for you.
    Address selection:
    I believe that best practice is to use Global Unicast Addressing everywhere (coupled with a proper security policy at your edge). ULA was a compromise for Site Local never being properly defined and whilst it can be used in the same way as GUA I don't believe it is worth it. Irrespective of what you use (GUA or ULA), subject to your security and routing policy traceroute will work from both ends (e.g. you tracing out, someone tracing in)
    Address masking:
    The general rule of thumb is that you allocate /64s to eveything and then mask down to the appropriate mask for the function you are expecting (P.S. Forget everything you learnt about IPv4 address conservation). If you are using /127 masks then in theory every p2p link in your network is either a 0 (::) or a 1 (::1)
    e.g.
    traceroute HostB:
    1     2001:1234:abcd:1::1
    2     2001:1234:abcd:2::1
    3     2001:1234:abcd:3::1
    4     2001::4:10
    The only exception to this is loopbacks, you can sequentially allocate /128s from the same /64 block
    NOTE: /127 support is recent and may not be supported by some vendors, in this case use /126 masking (same as you would use /30s in IPv4)
    If you have a /48 ( a normal enterise allocation) or larger then this should not be an issue ( you have access to 65536 x /64s) the only reason you would consider ULA for infrastructure numbering is because you have a small IPv6 pool. I would still argue you should get more IPv6 addresses than use ULA.
    I hope this helps
    Cheers

  • Can't get ipv6 address assigned correctly.

    I use NetworkManager and dhclient for auto-configuration but it has some weird problems.
    When I boot up my laptop, I only have chance to get access to ipv6 network, when I fail, I tried to delete the connection in Network Management Settings, and then added a new profile, disable and then enable the network again. Sometimes it works well, but sometimes it failed to auto-config.
    If I use the command:
    $ ip -6 rout
    then I'll get the following message:
    unreachable fe80::/64 dev lo proto kernel metric 256 error -101
    fe80::/64 dev wlan0 proto kernel metric 256
    default via fe80::2e0:2ff:fe54:59 dev wlan0 proto static metric 1
    every time the default gateway is configured well, sometimes the address the address is missed , and if I do the following:
    $ ping6 -I wlan0 -c 4 fe80::2e0:2ff:fe54:59
    It responses normally.
    PING fe80::2e0:2ff:fe54:59(fe80::2e0:2ff:fe54:59) from fe80::1034:56ff:fe78:9124 wlan0: 56 data bytes
    64 bytes from fe80::2e0:2ff:fe54:59: icmp_seq=1 ttl=64 time=5.32 ms
    64 bytes from fe80::2e0:2ff:fe54:59: icmp_seq=2 ttl=64 time=6.64 ms
    64 bytes from fe80::2e0:2ff:fe54:59: icmp_seq=3 ttl=64 time=10.6 ms
    64 bytes from fe80::2e0:2ff:fe54:59: icmp_seq=4 ttl=64 time=3.60 ms
    --- fe80::2e0:2ff:fe54:59 ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3005ms
    rtt min/avg/max/mdev = 3.603/6.546/10.617/2.587 ms
    do the following:
    $ ip -6 addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 2001:250:4400:d000::161/128 scope global
    valid_lft forever preferred_lft forever
    inet6 fe80::1034:56ff:fe78:9124/64 scope link
    valid_lft forever preferred_lft forever
    I found I just sometimes can get the ipv6 address start with 2001:
    If the address is assigned, then:
    $ ping6 ipv6.google.com
    PING ipv6.google.com(ipv6.google.com) 56 data bytes
    ^C
    --- ipv6.google.com ping statistics ---
    11 packets transmitted, 0 received, 100% packet loss, time 10008ms
    response nothing!
    Then I switch into Windows 7, if something like above happened, then I managed to set the MAC address to a random value such as 12-34-56-78-91-23, soon, the problem will be corrected, I'll get a new ipv6 address assigned by DHCPv6 server. If I switch back to arch, set the MAC address in NetworkManager, it didn't have function at most time, and the ipv6 address even won't change!
    Can anyone help me with this problem?
    by the way, I never get ipv6 address when I use dhcpcd.

    bernarcher wrote:
    Hello and welcome to the forums heliumhgy.
    Just in case you are wondering where your post has been gone: The moderators board received this message from you:
    I dont need tunnel to access to ipv6, My univ use dual-stack to get both ipv4 and v6 work around all campus.
    This is because you inadvertently used the "Report" link. But don't worry this happens rather often.
    Just cause I caught the glimpse of re-blabla, and mistaken it as reply
    Last edited by heliumhgy (2012-11-29 03:16:11)

  • IPv6 Address Management and Security Questions

    I'm trying to draft an IPv6-based version of our location's current routing configuration in anticipation of when our ISP will finally roll it out, and address management has been giving me the biggest headache - ironic, considering IPv6 was supposed to simplify address allocation.
    My first config draft was made assuming that I would be getting a static /56 or /60 prefix from the ISP, and I was just going to insert the prefix into my DHCP pools and there would be no issues. That was before reading around and discovering that some ISPs are considering prefix delegation (PD) for both residential and business accounts instead of static blocks. Now I have questions about how to stick as close to the current IPv4 configuration as possible.
    For the PD scenario, what I am looking at now are two addresses ranges for each network - a ULA /120 space that I want to control using stateful DHCPv6, and the global space which can be /64 and auto-configured. That way there will be a "private" address space for internal routing in the event of a prefix change or an extended outage. But I'm not sure how the config should look for such a scenario. What I have drafted so far is this:
    ipv6 dhcp pool DHCP6_INTERNAL
     address prefix FDAB::1:0/120
     domain-name whatever.net
     dns-server FDAB::1:1
    ipv6 dhcp pool DHCP6_DMZ-WIFI
     address prefix FDAB::2:0/120
     domain-name guest.whatever.net
     dns-server FDAB::2:1
    interface GigabitEthernet0
     description WAN-LINK
     ipv6 enable
     ipv6 address dhcp
     no ipv6 unreachables
     no ipv6 redirects
     ipv6 flow ingress
     ipv6 flow egress
     ipv6 virtual-reassembly in
     ipv6 nd autoconfig default-route
     ipv6 dhcp client pd hint ::/56
     ipv6 dhcp client pd ISP-PREFIX
     zone-member security OUTSIDE
     speed auto
     duplex auto
     no cdp enable
    interface FastEthernet8.1
     description VLAN_1-INTERNAL
     encapsulation dot1Q 1 native
     ipv6 enable
     ipv6 address FDAB::1:1/120
     ipv6 address ISP-PREFIX ::1:0:0:0:1/64
     ipv6 flow ingress
     ipv6 flow egress
     ipv6 virtual-reassembly in
     zone-member security INSIDE
     ip tcp adjust-mss 1300
     ipv6 dhcp server DHCP6_INTERNAL
     ipv6 nd managed-config-flag
     ipv6 nd other-config-flag
    interface FastEthernet8.2
     description VLAN_2-DMZ-WIFI
     encapsulation dot1Q 2
     ipv6 enable
     ipv6 address FDAB::2:1/120
     ipv6 address ISP-PREFIX ::2:0:0:0:1/64
     ipv6 flow ingress
     ipv6 flow egress
     ipv6 virtual-reassembly in
     zone-member security DMZ
     ip tcp adjust-mss 1300
     ipv6 dhcp server DHCP6_DMZ-WIFI
     ipv6 nd managed-config-flag
     ipv6 nd other-config-flag
    Will this config work? By which I mean: will the DHCPv6 servers provide ULA addresses, and will SLAAC work for global address allocation? If not, what needs to be changed?
    Also, another question. I found a few references to a prefix name (the "ISP-PREFIX") which can be used as part of a static IPv6 address on an interface, which is a good idea in case the prefix changes. But that brings up another concern - if the prefix changes, that will invalidate ACLs referencing the global addresses using the previous prefix. Is there anything similar to the prefix name string that can be used in ACLs to keep this from occurring?

    DHCPv6-PD is not necessarily dynamic the same way as DHCP was with the public IPv4 addresses in the IPv4 world.
    While the outside network (PPPoE, DHCPv6, anything) might be truly dynamic and changing with possibly every login session, the DHCPv6 delegated prefix might be tied to your login credentials or DHCPv6 client's DUID after the first connection. A bit like a DHCP lease reservation.
    If that is the case, there is some possibility that your ISP will run reverse route injection, and will always route your "fixed" prefix  to the currently active dynamic "outside" address.
    Talk to your ISP and have them confirm that, once the PD'd /48 or /56 is initially assigned, it won't change, and that the same prefix will be delegated every time. Then you can treat it as if it were fully static, and you won't have to go down the ULA path.
    I contacted one of our local ISPs, and they're doing it exactly that way: PPPoE for IPv4 and IPv6 (fully dynamic), and DHCPv6-PD with the /48 tied to the PPPoE login credentials. I might change to that ISP sooner or later.
    With my current ISP, my IPv6 access is 6RD based. I get a /60, with my current public ipv4 address (by DHCP) embedded into those 60 bits. Readressing is bound to happen sooner or later, and it happens every so often, and it breaks my IPv6 ACLs.
    I'm also looking for a way to write IPv6 ACLs with wildcard bits, not prefix/mask, so I can use them with ZBFW. So far, no sign of it.
    A few more comments:
    ULA addressing: 
    It may look tempting, plausible and intuitive to use dual global and ULA addressing. 
    I started this way as well. However, it turns out that Windows 7 has (had?) some issues with proper source address selection. The "longest common prefix" rule never seemed to work properly. In some cases, it would pick the global address to talk to ULA hosts, or stubbornly insist to use the ULA address to talk to an IPv6 internet host. It was a frustrating experience. Be sure to test this to the full extent (and back, and again and then some more) with every operating system you intend to use.
    Using /120:
    Be sure to test this as well, and very thoroughly. Subnet masks longer than /64 are sometimes called "uncharted territory" in IPv6. Longer subnet masks will break SLAAC, and there may be (embedded) devices that will not react benevolently to a subnet mask other than /64, or simply lack support for DHCPv6.
    adjust-mss
    I see you have "ip tcp adjust-mss 1300". While PMTUd may be mandatory with IPv6, I found it being broken already :-( . "ipv6 tcp adjust-mss .... " is now a separate command since IOS 15.4(1). I would suggest considering it, depending with your experience with PMTUd on IPv6.

  • Connect to server using IPv6 address in afp URL

    I'm not sure whether this is the correct forum for this question, but does anyone know whether I can specify an IPv6 address in the "Connect to Server" dialog?
    I've setup IPv6 over direct-wired ethernet between my MBP and Mini. Using ping6, I can ping one from the other (but only when I specify -I en0)
    I've tried the following URLs:
    afp://[fe80::0216:cbff:dead:beef]
    afp://[fe80::0216:cbff:dead:beef%en0]
    I think the problem might be because I don't have an IPv6 router between the two hosts.
    Thanks.
    MacBook Pro 15 2.0GHz   Mac OS X (10.4.8)   mini 1.83GHz

    I have the same problem and for me it extends to everything from SSH to HTTP. I think that mac has a bug in it networking. I can't get it to work on any mac I've tried. Can your mini connect to your laptop?
    I've been googling for 3 days and can't find any solution.
    MBP   Mac OS X (10.4.9)  

  • Problems with auto upgrade Anyconnect 3.1

    Hello,
    I'm having problem with auto upgrade of Anyconnect 2.5 to 3.1.
    Here is the situation :
    I have ASA5510 running ASA 8.4.5 and clients are running Anyconnect 2.5.3055 and 3.1.00495 with 2 different profiles.
    Clients with 2.5 can upgrade to 3.1 but then receive an "Invalid host entry" when they try to connect with new client. It works if they use FQDN instead of profiles. It's the same situation with Windows 7, Mac OS X and linux.
    If I configure client software back to 2.5 on ASA, it works again for every client.
    Do you have an idea ?
    Thanks for your reply.
    Yann

    I have seen the same behavior on Mac OS X. A couple of points for me:
    If I delete the profiles from /opt/cisco/anyconnect/profile then I can connect once (using the FQDN) but it then downloads the client profile and on next attempted connection it receives "invalid host entry." My profiles use the FQDN of my ASA and both forward and reverse DNS resolution are configured properly.
    My workaround is to remove the AnyConnect Client Profile entirely, but I can get away with that because I have a very simple setup, with all users in one default group. If I had to pass different profile information to different users that would not be a solution.
    Second, better workaround: I just exported the client profile, imported it under a different name, edited the new client profile to remove the server address, and assigned the new profile to the group policy. At their next login, users get all the profile settings and since the client remembers the FQDN they used to connect it doesn't adversely affect the user experience.

  • Windows 2012 R2 - Access problems to NFS shares via IPv6

    Hello,
    we setup some NFS shares on HNAS storage box. The connection to this storage is only possible over IPv6 network.
    My server with Windows 2012 R2 has the feature 'Client for NFS' installed and a 'showmount -e servername/or IPv6 address' works. I can see all shares when i try to open the storagebox in Windows Explorer with the command "\\servername" or "\\IPv6
    address", too. 
    My problem is, when I try to mount the share via "Map network drive" or "mount \\servername\sharename *" I get Error 53 - Network path not found.
    The share is configured that every server in the IPv6 subnet could access it and it works on Unix machines, but not on Windows. 
    It does not matter if i set some option parameters for the "mount" command like sec=sys or anon, everytime error 53.
    I don't know, if the share needs special options for Windows. I hope somebody can help.
    Kind regards

    Hi,
    here is the output of your 2 commands:
    PS C:\Users\admin> get-SmbConnection
    PS C:\Users\admin> get-SmbServerConfiguration
    AnnounceServer                  : False
    AsynchronousCredits             : 64
    AutoShareServer                 : True
    AutoShareWorkstation            : True
    CachedOpenLimit                 : 0
    AnnounceComment                 :
    EnableDownlevelTimewarp         : False
    EnableLeasing                   : True
    EnableMultiChannel              : True
    EnableStrictNameChecking        : True
    AutoDisconnectTimeout           : 0
    DurableHandleV2TimeoutInSeconds : 30
    EnableAuthenticateUserSharing   : False
    EnableForcedLogoff              : True
    EnableOplocks                   : True
    EnableSecuritySignature         : True
    ServerHidden                    : True
    IrpStackSize                    : 15
    KeepAliveTime                   : 2
    MaxChannelPerSession            : 32
    MaxMpxCount                     : 50
    MaxSessionPerConnection         : 16384
    MaxThreadsPerQueue              : 20
    MaxWorkItems                    : 1
    NullSessionPipes                : HydraLsPipe
    NullSessionShares               :
    OplockBreakWait                 : 35
    PendingClientTimeoutInSeconds   : 120
    RequireSecuritySignature        : False
    EnableSMB1Protocol              : True
    EnableSMB2Protocol              : False
    Smb2CreditsMax                  : 2048
    Smb2CreditsMin                  : 128
    SmbServerNameHardeningLevel     : 0
    TreatHostAsStableStorage        : False
    ValidateAliasNotCircular        : True
    ValidateShareScope              : True
    ValidateShareScopeNotAliased    : True
    ValidateTargetName              : True
    EncryptData                     : False
    RejectUnencryptedAccess         : True
    I try to access the file share with Windows Explorer. When I enter \\fe08--babe-face-cafe-dead.ipv6-literal.net (just example), I can see all shares on the storage box. When I double-click the share, I want to access, where an access is definitely allowed,
    it takes a while and then the error "\\fe08--babe-face-cafe-dead.ipv6-literal.net\share is not accessable. You might not have permission to use this network resource. ..." appears.  Of this action a recorded the trace.
    Another way I tried is to open command line an type "mount \\fe08--babe-face-cafe-dead.ipv6-literal.net\share *". After this an error 53 occurs immediately without any wait time.

  • IP phone not getting IPv6 address

    Hi guys,
    I am having trouble with receiving IPv6 address from my 2811 CME router that has been configured as a DHCPv6. Could you please help me what is wrong with my configuration below? Thank you.
    Router#sh run
    Building configuration...
    Current configuration : 2327 bytes
    ! Last configuration change at 22:52:14 UTC Mon Feb 17 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip cef
    no ip domain lookup
    ipv6 unicast-routing
    ipv6 cef
    ipv6 dhcp pool VOICE
    address prefix 2001::/64
    vendor-specific 9
      suboption 1 address 2001::1
      suboption 2 ascii "IP-Phone"
    multilink bundle-name authenticated
    voice-card 0
    crypto pki token default removal timeout 0
    license udi pid CISCO2811 sn FHK1213F0HN
    redundancy
    interface FastEthernet0/0
    bandwidth 50
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ipv6 address 2001::1/64
    ipv6 enable
    ipv6 nd other-config-flag
    ipv6 dhcp server VOICE
    interface FastEthernet0/1
    bandwidth 50
    no ip address
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    tftp-server flash:SCCP41.9-3-1SR2-1S.loads
    tftp-server flash:cnu41.9-3-1ES13.sbn
    tftp-server flash:cvm41sccp.9-3-1ES13.sbn
    tftp-server flash:dsp41.9-3-1ES13.sbn
    tftp-server flash:jar41sccp.9-3-1ES13.sbn
    tftp-server flash:term41.default.loads
    tftp-server flash:apps41.9-3-1ES13.sbn
    tftp-server flash:mk-sccp.jar alias English_United_States/mk-sccp.jar
    tftp-server flash:g3-tones.xml alias United_States/g3-tones.xml
    control-plane
    mgcp profile default
    telephony-service
    protocol mode dual-stack preference ipv6
    max-ephones 5
    max-dn 5
    ip source-address 2001::1
    cnf-file location flash:
    load 7941 SCCP41.9-3-1SR2-1S.loads
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    ephone-dn  1
    number 1000
    ephone-dn  2
    number 2000
    ephone-dn  3
    number 7000
    ephone  1
    device-security-mode none
    mac-address 0017.9406.FD55
    type 7941
    button  1:1
    ephone  2
    device-security-mode none
    mac-address 0016.46F5.F08E
    button  1:2
    ephone  3
    device-security-mode none
    mac-address 0017.941D.BE05
    type 7941
    button  1:3
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    end

    Duplicate posts. 
    Go here:  https://supportforums.cisco.com/thread/2267863

  • How to disable ipv6 address autoconfiguration ???

    I am trying to disable ipv6 stateless address autoconfiguration to implement what this document describes:
    http://docs.sun.com/app/docs/doc/816-4554/6maoq01o3?a=view
    There are several problems though:
    1)The manual says that something must be put inside the hostname6.xxx file but then goes on to give the command as it should be given from the command line instead of the content of the file. The manual should provide some form of exapmle content for the file.
    2)I go to /etc/inet/ndpd.conf and put "ifdefault StatelessAddrConf false" inside, then I pkill -HUP in.ndpd and finally I issue ifconfig eri0 inet6 token fe80::c/10. However nothing happens. The interface address remains the one generated through autoconfiguration.
    Could someone that has knowledge of this subject provide any help?
    Thanks very much,
    Thanasis

    Hi,
    I have a same problem, and think we didn't understand the documentation.
    Here is the link of the ndpd.conf configuration page:
    http://docs.sun.com/app/docs/doc/816-4554/6maoq01qt?a=view#ipv6-ref-10
    I think this is the right sintax:
    if
    Sets per-interface parameters. Use the following syntax:
    if interface [variable-value]
    Table 11�3 /etc/inet/ndpd.conf Interface Configuration Variables
    StatelessAddrConf
    True
    Controls whether the node configures its IPv6 address through stateless address autoconfiguration. If False is declared in ndpd.conf, then the address must be manually configured. For more information, refer to How to Configure a User-Specified IPv6 Token.
    I think the variable is this: StatelessAddrConf
    if-variable-name StatelessAddrConf false
    I think: if StatelessAddrConf false
    But I found the 'false' parameter with uppercase and lowercase letter.
    (It is not working for me!)
    And I found another configuration file, what is include the rules of the address (/usr/sbin/ipaddrsel ).
    Here is the link:
    http://docs.sun.com/app/docs/doc/816-5166/6mbb1kq56?a=view
    Maybe, I found the solution.
    http://docs.sun.com/app/docs/doc/816-4554/6maoq01qt?a=view#ipv6-ref-10
    You can creat a logical interface, and you can set the IP address of this interface.
    Example 11�6 Adding a Logical IPv6 Interface With the -addif Option of the ifconfig Command
    The following form of the ifconfig command creates the hme0:3 logical interface:
    // this is teh example, and it is not perfect on Sol10
    # ifconfig hme0 inet6 addif up
    Created new logical interface hme0:3
    This form of ifconfig verifies the creation of the new interface:
    # ifconfig hme0:3 inet6
    hme0:3: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 2
              inet6 inet6 fe80::203:baff:fe11:b321/10
    Here is my solution:
    ifconfig e1000g0 inet6 addif 1234:0000:0000:0000:0200:50FF:FE09:B980/10
    ifconfig e1000g0:1 inet6 up
    # ifconfig -a6
    lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
    inet6 ::1/128
    e1000g0: flags=2000840<RUNNING,MULTICAST,IPv6> mtu 1500 index 2
    inet6 fe80::20d:60ff:feee:aba8/10
    ether 0:d:60:ee:ab:a8
    e1000g0:1: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 2
    inet6 1234::200:50ff:fe09:b980/10
    I have special IP address, but I don't know that it is working or not.
    If you have any idea, please write!
    Br,
    Sanyi

  • Static ipv6 address from a /64

    Hi all
    I have a cisco 6500 that i configured a /64 on int1/39 that has a linux server connected to it and supressed RAs. On this server i assigned a static ip, 
    2001:x:77:4::2. i can ping to/from the server with no issues. However when doing a show ipv6 neighbors i still see the auto config ipv6 on fast1/39.
    interface FastEthernet1/39
    ip address x.x.x.33 255.255.255.240
    ip flow ingress
    speed 100
    duplex full
    ipv6 address 2001:x:77:4::1/64
    ipv6 nd ra suppress
    spanning-tree portfast edge
    My question why is that attached server getting an auto config ipv6 address when i have the supress command under interface. Also is it correct to assign a /64 to an int/vlan and statically assign ips instead or should i move to a /56. I'm not really sure if what im doing is common or if it create issues.
    TIA, Paul

    Deepak, while i assigned a static ip to the server doing a show ipv6 neighbor shows this static ip and it also shows the auto config ip. Again based on my config above shouldnt it jsut show the static ip. Why is SLAAC in play here if i have
    ipv6 nd ra suppress on the interface, will this setup cause issues.
    sh ipv6 neighbors
    IPv6 Address                              Age Link-layer Addr State Interface
    2001:x:77:4::2                            1 0019.b9e6.5647  STALE Fa1/39
    2001:x:77:4:219:B9FF:FEE6:x     49 0019.b9e6.5647  STALE Fa1/39
    FE80::219:B9FF:FEE6:5647                    1 0019.b9e6.5647  STALE Fa1/39
    note i can ping the static and auto config ip and the server lists both of them.

  • IPv6 Address in Internal Enterprise

    Hello All,
    I was looking at a Pilot deploment of IPv6 in our Labs.
    I was little confused with rgards to what should I use as IPv6 address on Internal Network Infrastructure and hosts.
    This is when I jumped across BRKRST-2301 where Shanon McFarland gives some idea on use of IPv6 in the internal.
    So what it said is:
    1. ULA Only -- Not recommended as NAT 66 solution does not exist <-- Can I use NPT Solution. But it would require same no. of GUA as well.
    2. ULA + Global -- More problems with DNS, DHCP and SAS  <-- Is this really that difficult ?
    3. Global Only -- Recommended but security folks are not ready.     <--  I could even not convince some R&S folks for this!!! Even though I am convinced.
    Apart from this, if i use a GUA which is not allocated to anyone internally & then NPT it while going outside.
    I would like to know your thoughts and what would you recommend to do.
    Maulik

    Hi,
    Reading many such things I think having GUA to end Hosts is best bet and that is what many people recommend to do.
    I'm a bit confused since you say that all hosts will have 4 addresses but ULA must be used internally.
    How will you dictate to every server and PC that they will only use their ULA addresses and ignore their global addresses for all internal communications? How will you monitor that this is actaully happening?
              <-- SAS should be used for this. Please refer this RFC and the problem statement it gives for SAS. But I am not sure every OS out there has implemented it correctly.
    http://tools.ietf.org/html/rfc5220#page-12
    You also state that all GUA addresses will be advertised to the Internet but these devices are not be reachable from the Internet. However you have just advertised these addresses to the Internet. I'm puzzled as to how you can achieve both conflicting requirements.
              <-- By this I actually meant that on all Infrastructure links and loopbacks of Routers we will use ULA, only end hosts will be given GUA and this GUA will be advertised into the routing protocol (exterior) for reachability. Both GUA and ULA in IGP. Advantage of this is that infrastructure network devices will not be reachable from Internet whatsoever.
    I have had bad experiences with SP's in the past. Therefore I would not trust my IPv6 Security policy to them.
              <-- I agree, applying policies should be done at enterprise end must never trust SP.
    For NAT 66, yes i am aware that it is still not available in major implementations, but some LB do that. So just was giving a thought.
    http://tools.ietf.org/html/rfc6296
    So I was just giving a thought:
    1. To allocate ULA to Infrastructure Links and network devices.
    2. Provide only GUA to end hosts. I too feel that should be the best approach.
    Let me know on the 1st point. Thanks.

  • Ipv6 address setup in local zone

    I'm having problems with a local zone that needs a defined IPv6 address. I've had a number of issues -- now i'm down to routing.
    I've set up a manual address on a physical interface, and assigned it to a zone by setting it from the global zone:
    ifconfig bge3 inet6 addif 2001:6b0:8:1::54/64 zone g.ns.se upThe zone "gets" the interface but there are no default routes visible in the local zone. I can ping the interface from the local LAN connected to bge3, but not beyond. snoop in the global zone sees the packets.
    The global zone can configure ipv6 by RA and gets its routing information all right.
    Manually adding a default route from the global zone does not help.
    Clues?

    My experience with a default route ipv6 visibility within a local zone is the same.
    One way to get an ipv6 default route info into the local zone is to let the global zone in.ndpd daemon do the ipv6 autoconfig including a default route discovery (ipv6 RA you've mentioned) and manully configure/add a new unique link-local FE80::/10 address within the local zone (besides the global ipv6 address you've already set up). At that point default route makes it into the local zone table and ipv6 connectivity happens. Both ipv6 interfaces - a global zone with ndpd and also a local zone one - have to stay within the same LAN.
    I see this as a temporary workaround as this way lacks autoconfig ability (remember ipv6 ?) and currently offers less compared to ipv4 setup options.

Maybe you are looking for

  • Submitting Concurrent request from PL/SQL

    Hi I am currently attempting to submit a concurrent program from a pl/sql block that itself is being run as a concurrent program. However the call to submit_request would only returned zero. I inserted a call to FND_GLOBAL.INITIALIZE as suggested on

  • Where can I buy parts to Satellite 2140cds

    Does anyone know were I can get some parts for my laptop? I know its an old laptop but i need to know. I'm hoping to look for a new battery and maybe a new hdd?

  • G4 iBook and Leopard?

    hey folks I have G4 iBook and would like to install Leopard. NOt at my machine right now, but I believe I have 1 or 1.25 GB of RAM and enough HD space. Your thoughts and recs. are very appreciated. Chuck S

  • Using mail and its rss feed on 2 mac computers

    Hello to the mac users comunity! I have 2 questions here: 1st: I am using for work a iMac and i am planning to use for my business trips a mac book air. I am using the mail and its rss feeeds, i would like to be able to read my mails and rss on both

  • SQL Developer EA4 - compile/open spec/body take longer then 3.2.2

    The Compile takes too long in compare to SQL Developer 3.2.2          Sometimes the SQL Developer  freeze          Sometimes a warning of low memory window come up  and then goes away The Opening of Spec/body takes too long compare to SQL Developer 3