Problem with stickiness in CSS

Hi,
I'm trying to configure a stickiness for wireless clients ( mobile phones) that accessing our sites through WAP gateway.
After doing some manual reading and some testing I created the following configuration that still doesn't work:
service server1
ip address 10.10.10.1
port 80
protocol tcp
keepalive port 80
keepalive frequency 10
keepalive uri "/heartbeat"
keepalive type http
active
service server2
ip address 10.10.10.2
port 80
protocol tcp
keepalive port 80
keepalive frequency 10
keepalive uri "/heartbeat"
keepalive type http
active
header-field-group wap
header-field 4 custom "x-up-calling-line-id" contain "34"
content http
vip address 10.10.5.10
port 80
protocol tcp
add service server1
add service server2
active
content wap
url "/*"
protocol tcp
port 80
vip address 10.10.5.10
add service server1
add service server2
advanced-balance wap-msisdn
header-field-rule wap
no persistent
active
theoretically it should check whether x-app-calling-id header contain digits 34 - in case of existence it should perform a sticky connection to the same server all the time ,if not it should go to standard http connection that is load balanced with round robbin

First of all thanks for the response.
#show rule test-1 test-wap services
The output is :
server1 6,521,242 S-1 Alive 25 HTTP-80:H 0 0
server2 5,494,544 S-1 Alive 18 HTTP-80:H 0 0
so i guess it hits the rule
I also have about 1 million hits on the http rule.
So i guess the rule is being hit but the stickiness is not working correctly.
Are there any specific commands you can recommend to troubleshoot?

Similar Messages

  • Problem with redundancy in CSS 11051

    I have a problem with redundancy in CSS 11051. I use firewall load balancing and server load balancing. Load balancers which only load balance over 3 firewall switch from primary to master with no problems.
    problem is with load balancers which load balance over firewalls and over servers two. whene the master is shutdown, backup keeps master function, all services on backup LB are alive, but it is not possible to display web page on address 10.10.7.16. Even if I try from the network 10.10.7.0/24, so before firewalls. below my config. any help appreciate.
    ===primary LB=====
    !Generated on 10/30/2002 10:42:53
    !Active version: ap0500002
    configure
    !*************************** GLOBAL ***************************
    ip redundancy master
    no console authentication
    restrict ftp
    app
    app session 10.10.60.13
    ip firewall 1 10.10.7.1 10.10.8.1 10.10.8.10
    ip firewall 2 10.10.7.2 10.10.8.2 10.10.8.10
    ip firewall 3 10.10.7.3 10.10.8.3 10.10.8.10
    ip route 0.0.0.0 0.0.0.0 firewall 1 1
    ip route 0.0.0.0 0.0.0.0 firewall 2 1
    ip route 0.0.0.0 0.0.0.0 firewall 3 1
    ip route 10.10.1.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.2.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.12.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.14.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.22.0 255.255.255.0 10.10.3.1 1
    !************************* INTERFACE *************************
    interface e1
    phy 100Mbits-FD
    bridge vlan 62
    interface e2
    phy 100Mbits-FD
    bridge vlan 7
    interface e3
    bridge vlan 3
    interface e4
    phy 100Mbits-FD
    bridge vlan 7
    interface e5
    phy 100Mbits-FD
    interface e6
    phy 100Mbits-FD
    bridge vlan 6
    interface e7
    phy 100Mbits-FD
    interface e8
    phy 100Mbits-FD
    bridge vlan 6
    !************************** CIRCUIT **************************
    circuit VLAN62
    ip address 10.10.60.14 255.255.255.252
    redundancy-protocol
    circuit VLAN7
    redundancy
    ip address 10.10.7.10 255.255.255.0
    circuit VLAN3
    redundancy
    ip address 10.10.3.10 255.255.255.0
    no redirects
    circuit VLAN6
    redundancy
    ip address 10.10.6.10 255.255.255.0
    !************************** SERVICE **************************
    service cc1
    ip address 10.10.3.129
    keepalive type tcp
    keepalive port 443
    service cc2
    ip address 10.10.3.130
    keepalive type tcp
    keepalive port 443
    active
    service ssl1
    ip address 10.10.6.131
    keepalive port 443
    keepalive type tcp
    active
    service ssl3
    ip address 10.10.6.133
    keepalive port 443
    keepalive type tcp
    active
    service ssl4
    ip address 10.10.6.141
    keepalive type tcp
    keepalive port 443
    active
    service ssl6
    ip address 10.10.6.143
    keepalive port 443
    keepalive type tcp
    active
    service www1
    ip address 10.10.6.101
    keepalive type tcp
    keepalive port 443
    weight 2
    active
    service www3
    ip address 10.10.6.103
    keepalive type tcp
    keepalive port 443
    active
    service www4
    ip address 10.10.6.121
    keepalive port 443
    keepalive type tcp
    active
    service www6
    ip address 10.10.6.123
    keepalive type tcp
    keepalive port 443
    active
    !*************************** OWNER ***************************
    owner L5_Owner
    content L5_Rule
    vip address 10.10.7.6
    application ssl
    protocol tcp
    port 443
    url "/*"
    add service www1
    add service www3
    add service www4
    advanced-balance sticky-srcip
    add service www6
    balance weightedrr
    active
    content L5_Rule_CC
    vip address 10.10.3.120
    advanced-balance sticky-srcip
    add service cc1
    add service cc2
    active
    content L5_Rule_SSL
    vip address 10.10.7.16
    application ssl
    protocol tcp
    port 443
    url "/*"
    add service ssl1
    add service ssl3
    add service ssl4
    advanced-balance sticky-srcip
    add service ssl6
    active
    !*************************** GROUP ***************************
    group CC
    vip address 10.10.3.120
    add destination service cc1
    add destination service cc2
    active
    ======
    ===backup LB=====
    !Generated on 10/29/2002 20:47:30
    !Active version: ap0503015
    configure
    !*************************** GLOBAL ***************************
    ip redundancy
    console authentication primary none
    restrict ftp
    app
    app session 10.10.60.14
    ip firewall 1 10.10.7.1 10.10.8.1 10.10.8.10
    ip firewall 2 10.10.7.2 10.10.8.2 10.10.8.10
    ip firewall 3 10.10.7.3 10.10.8.3 10.10.8.10
    ip route 0.0.0.0 0.0.0.0 firewall 1 1
    ip route 0.0.0.0 0.0.0.0 firewall 2 1
    ip route 0.0.0.0 0.0.0.0 firewall 3 1
    ip route 10.10.1.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.2.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.12.0 255.255.255.0 10.10.3.1 1
    ip route 10.10.14.0 255.255.255.0 10.10.3.1 1
    !************************* INTERFACE *************************
    interface e1
    phy 100Mbits-FD
    bridge vlan 62
    interface e2
    phy 100Mbits-FD
    bridge vlan 7
    interface e3
    phy 100Mbits-FD
    bridge vlan 3
    interface e4
    phy 100Mbits-FD
    bridge vlan 7
    interface e5
    phy 100Mbits-FD
    interface e6
    phy 100Mbits-FD
    bridge vlan 6
    interface e7
    phy 100Mbits-FD
    interface e8
    phy 100Mbits-FD
    bridge vlan 6
    !************************** CIRCUIT **************************
    circuit VLAN62
    ip address 10.10.60.13 255.255.255.252
    redundancy-protocol
    circuit VLAN7
    redundancy
    ip address 10.10.7.10 255.255.255.0
    circuit VLAN3
    redundancy
    ip address 10.10.3.10 255.255.255.0
    no redirects
    circuit VLAN6
    redundancy
    ip address 10.10.6.10 255.255.255.0
    !************************** SERVICE **************************
    service cc1
    ip address 10.10.3.129
    active
    service cc2
    ip address 10.10.3.130
    active
    service ssl1
    ip address 10.10.6.131
    keepalive port 443
    keepalive type tcp
    active
    service ssl3
    ip address 10.10.6.133
    keepalive port 443
    keepalive type tcp
    active
    service ssl4
    ip address 10.10.6.141
    keepalive type tcp
    keepalive port 443
    active
    service ssl6
    ip address 10.10.6.143
    keepalive port 443
    keepalive type tcp
    active
    service www1
    ip address 10.10.6.101
    keepalive type tcp
    keepalive port 443
    weight 2
    active
    service www3
    ip address 10.10.6.103
    keepalive type tcp
    keepalive port 443
    active
    service www4
    ip address 10.10.6.121
    keepalive port 443
    keepalive type tcp
    active
    service www6
    ip address 10.10.6.123
    keepalive type tcp
    keepalive port 443
    active
    !*************************** OWNER ***************************
    owner L5_Owner
    content L5_Rule
    vip address 10.10.7.6
    protocol tcp
    port 443
    url "/*"
    add service www1
    add service www3
    add service www4
    advanced-balance sticky-srcip
    add service www6
    balance weightedrr
    active
    content L5_Rule_CC
    vip address 10.10.3.120
    advanced-balance sticky-srcip
    add service cc1
    add service cc2
    active
    content L5_Rule_SSL
    vip address 10.10.7.16
    protocol tcp
    port 443
    url "/*"
    add service ssl1
    add service ssl3
    add service ssl4
    advanced-balance sticky-srcip
    add service ssl6
    active
    !*************************** GROUP ***************************
    group CC
    vip address 10.10.3.120
    add destination service cc1
    add destination service cc2
    active
    =======

    Please visit the folloiwing page where you can find many configuration examples on configuring CSS for Load Balancing.
    http://www.cisco.com/en/US/products/hw/contnetw/ps789/prod_configuration_examples_list.html
    Hope it helps.

  • I'm still seeing the problem with printing when css overflow is hidden (bug 104040) which I had heard was claimed fixed

    Example:
    http://scaled.com/projects/whiteknighttwo_spaceshiptwo_test_summaries
    User: firefox 40b7/32 on fedora core 11 x86_64
    Linux 2.6.30.8-64.fc11.x86_64 #1 SMP
    Symptom: printout truncates at end of first page instead of printing several pages of information
    I've seen this behavior on many websites, this is an example
    I can fix it by copying the page and hacking the css to remove all cases of "overflow:hidden". But really firefox needs to handle this - I just discovered from googling that something like this has been a known problem for 10 years.

    I just thought I should post this comment, to say my long running problem has finally....FINALLY been sorted out!
    It was actually really fixed at the end of September, but I have waited till now, until I received my first proper bill to feel confident enough to say it is finally sorted out.....but what a long winded process!...it took over a month to sort this out, with endless hours on the phone, and endless promises not kept.
    The problem with BT's customer service is the fact that going through normal channels, no one person can sort a problem out. You get passed from pillar to post, with every department saying that it is someone else's area of responsibility and then it takes hours on the phone with various deparments in different countries, to get a commitment to sort it out, and then nothing happens!
    It was only after posting my final desperate plea on this forum, for all the world to see, that I finally got one of the Moderators to take up my case, and sort the problem out, although it took him over a month to get through all the treacle of BT's admin before a solution was found.
    I am very greatful to the Mods for dealing with my problem, which was not of my making, but was due to something going wrong with BT's system.
    There is however something fundamentally wrong with BT's Customer Service set up, where no one person seems to take responsibilty for a CXXk-up on their part, and seems unable to have the authority to sort it out.
    Once again, Thank you Mods for your help.

  • Problem with ACL in CSS-to-CSS redundancy configuration

    I have two CSSes - first is master, second is backup. When I enable ACL on master CSS, it can't see more the backup CSS. My first rule is to allow all traffic between both CSSes. I have CSS 11050 with 4.10 Build 10.
    Here is a part of my config:
    --- begin ---------------------------------------------------
    !************************* INTERFACE *************************
    interface e8
    bridge vlan 254
    description "css1 <-> css2 (net 192.168.254.0/30)"
    !************************** CIRCUIT **************************
    circuit VLAN254
    ip address 192.168.254.1 255.255.255.252
    redundancy-protocol
    !**************************** NQL ****************************
    nql n_csw_to_csw
    ip address 192.168.254.1 255.255.255.255
    ip address 192.168.254.2 255.255.255.255
    !**************************** ACL ****************************
    acl 1
    clause 1 bypass any nql n_csw_to_csw destination nql n_csw_to_csw
    apply circuit-(VLAN254)
    --- end ---------------------------------------------------
    Where is the problem? Is it a bug in my current version or an error in my configuration?
    Thanks
    Thomas Kukol

    at first step read http://www.cisco.com/warp/customer/117/css_packet_trace.html
    and trace your unworking configuration
    if you give flow option 0xffffff you should see why ACL didn't pass app traffic..
    second idea is to use normaln acls w/o nql....
    with permit keyword...
    share expirience here again 8-)

  • Problem with validation of css page

    Hi all
    why can't I validate this page with w3c, here is the page
    /* CSS Document */
    @charset "iso-8859-1";
    @media all {
    body {
    font-family: "Times New Roman", Times, serif;
    color: #FFFFFF;
    font-style: italic;
    background-color: #0000CC;
    text-align: center;
    font-size: 18px;
    h1 {
    text-align:center;
    color: #FFFFFF;
    font-family: "Bookman Old Style";
    visibility: visible;
    font-size: 36px;
    font-style: italic;
    h2{
    color: #FFFFFF;
    text-align: center;
    font-size: 18px;
    address{
    font-size:0.8em;
    float:left;
    margin-right:5em;
    .souhait {
    font-family: "Times New Roman", Times, serif;
    font-size: 18px;
    font-style: italic;
    line-height: normal;
    font-weight: normal;
    font-variant: normal;
    color: #FFFFFF;
    text-decoration: none;
    text-align: center;
    a:link{
    color:#FFFFFF;
    Thanks

    a:link{
    color:#FFFFFF;
    Are the two closing braces a typo?
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.dreamweavermx-templates.com
    - Template Triage!
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    http://www.macromedia.com/support/search/
    - Macromedia (MM) Technotes
    ==================
    "Sebweb12345" <[email protected]> wrote in
    message
    news:ekt0an$712$[email protected]..
    > Hi all
    >
    > why can't I validate this page with w3c, here is the
    page
    >
    > /* CSS Document */
    > @charset "iso-8859-1";
    > @media all {
    > body {
    > font-family: "Times New Roman", Times, serif;
    > color: #FFFFFF;
    > font-style: italic;
    > background-color: #0000CC;
    > text-align: center;
    > font-size: 18px;
    > }
    > h1 {
    > text-align:center;
    > color: #FFFFFF;
    > font-family: "Bookman Old Style";
    > visibility: visible;
    > font-size: 36px;
    > font-style: italic;
    > }
    > h2{
    > color: #FFFFFF;
    > text-align: center;
    > font-size: 18px;
    > }
    > address{
    > font-size:0.8em;
    > float:left;
    > margin-right:5em;
    > }
    >
    > .souhait {
    > font-family: "Times New Roman", Times, serif;
    > font-size: 18px;
    > font-style: italic;
    > line-height: normal;
    > font-weight: normal;
    > font-variant: normal;
    > color: #FFFFFF;
    > text-decoration: none;
    > text-align: center;
    > }
    > a:link{
    > color:#FFFFFF;
    > }
    > }
    >
    > Thanks
    >

  • Client Http Connection Problems With CSS

    Hi,
    We have a pair of CSS 11050s configured in a redundant pair. We have a content service defined on both CSS's. They are configured for Layer 5 balancing, with Sticky timout configured at Layer 4 for the respective service (I don't know if this is correct).
    When doing a show service summary on both CSS boxes - the content servers are seen as alive. There do not appear to be any problems. However when clients try to connect to the content, there is often a very noticeable delay in connection.
    First attempt, the http request does not reach the web server and is not displayed in the log during this delay. On first access to the login URL, no page was returned for 50 secs, no entry in the web server logs, and the browser displayed “page cannot be displayed” after 50 seconds. On a 2nd attempt, the same happened (again 50 secs before timeout). On the 3rd attempt, after 25 seconds the request appeared in the Apache log, and the page was displayed on the browser. I can now access all areas of the HTML based application without further delays, and subsequent logins are not subject to the same delay.
    It is almost as if the CSS's need to cache information - but so far I have not managed to find any explanation for this.
    Any help would be most gratefully received.

    Hello Rus!
    I have recently experince the same issue serveral times. My fix was to reload the CSS. Not sure why this happens but it seems that all is well! Also check your "sticky-inact-timeout XX" setting in your content rule. Cisco recommed 60 min for connections to timeout.

  • Problem with .css for Spry menu

    Hi,
    I am having a problem with the Spry menu I have created and edited. All looks great in the Design view of Photoshop however under the Live view or opened using a browser the menu reverts to a list of hyperlinks!
    I have checked the .css link but when using Firefox CSS editor the CSS file for the menu is simply blank?
    Any suggestions would be great!
    Thanks,
    Ozan

    Your SpryMenuBarHorizontal.css needs to be within your SpryAssets folder, which is where it would have been put automatically when you inserted the SpryMenuBar. You can move it back in there using the Files Panel.
    Here is what the file structure needs to look like:
    SpryAssets
    SpryMenuBar.js
    SpryMenuBarHorizontal.css
    cssstyletemplate.css
    index.html (or whatever the name of your page is)
    Hierarchally, the top level of your root folder will show folders for SpryAssets and css and the html pages will be on the same level.
    The Spry assets themselves will be down a level IN the SpryAssets folder, as the styletemplate.css file will be down a level IN the css folder.
    In the head of the document, you will have
         <link rel="stylesheet" type="text/css" href="css/styletemplate.css" />
         <script src="SpryAssets/SpryMenuBar.js" type="text/javascript"> </script>
         <link rel="stylesheet" type="text/css" href="SpryAssets/SpryMenuBarHorizontal.css" />
    At the end, remove the slash before Spry inside the imgDown and imgRight sections:
         <script type="text/javascript">
    <!--
    var MenuBar1 = new Spry.Widget.MenuBar("MenuBar1", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
    //-->
    </script>
    Compare these with your files and file structure and correct any small typos, and they should be correctly linked.
    Beth

  • Problem with CSS styles and Previewing in Firefox

    Hello,
    I recently rebooted my Mac OS X system (leopard) and reinstalled Adobe CS3. Before this I had virtually no problems with Dreamweaver and everything was running smoothly. However, now whenever I preview my pages in Safari, the CSS code is completely mangled.
    Also, my site won't preview in Firefox unless I close any existing tabs and exit Firefox completely. I have no idea why these problems are occurring, but I have pasted the code below so any advice would be extemely helpful.
    ---------------------------------html----------------------------------------
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv= "Content-Type" content="text/html; charset= UTF-8" />
    <title>armed and harmless</title>
    <link href="untitled.css" rel="stylesheet" type="text/css" />
    </head>
    <body>
    <div id="wrapper">
        <div id="nav">
        </div>
    </div>
    </body>
    </html>
    -----------------------------------css-----------------------------------
    @charset "UTF-8";
        background-color: #000000;
        background-image: url(images/header.jpg);
        background-repeat: no-repeat;
        margin: 0px;
    #wrapper {
        height: 800px;
        width: 1000px;
        margin-top: 0px;
        margin-right: auto;
        margin-left: auto;
        background-color: transparent;
        background-image: none;
    #wrapper #nav {
        background-color: transparent;
        background-image: none;
        height: 30px;
        width: 1000px;
        margin-top: 260px;
        clear: both;
        border-top-width: 1px;
        border-bottom-width: 1px;
        border-top-style: solid;
        border-bottom-style: solid;
        border-top-color: #FFFFFF;
        border-bottom-color: #FFFFFF;

    hey there,
    thanks so much for the insight on the firefox issue. hopefully they fix that soon.
    as for the css, i do have a screenshot of what's happening. the background image seems to repeat after the navigation bar instead of keeping the transparent background. it's extremely odd and i've never seen it before. it can be seen in the attached photo.
    thanks again for your help,
    -e

  • Problem with CSS files when placed in multiple locations.

    Hi,
    In our application we have a folder structure for the code files. Folder structure looks something like the one shown below:
    ABC
    ---Scripts
    ---Stylesheets
    DEF
    Scripts
    Stylesheets
    Common
      ---Scripts
      ---Stylesheets
      The problem is, if we create a CSS file and place it in its module specific folder (Eg: ABC) to which it belongs to and call the CSS on a page, then the styles are not getting applied to the page. But if we move the stylesheet to the Common folder, then page renders properly. In common folder, we already have a common CSS which is used across the project.
    Facing similar problem with module specific and common js files.
    We have to move all the module specific files to the module folders and all the common files to be placed in the Common folder.
    MII Version: 11.5
    Please help!
    Regards,
    Rajesh.

    Rajesh,
    Also note that, If your html is referencing to multiple css files then the last referenced CSS file style classes will override all the style class having same names in the previous css files.
    for example,
    say CSS1 has
    .bodycolor
    background-color:yellow;
    .button
    color:red;
    h1
    font-size:50pt;
    and CSS2 has
    .bodycolor
    background-color:red;
    .button
    color:yellow;
    And your HTML is,
    <html>
    <head>
    <link rel="stylesheet" type="text/css" href="css1.css"/>
    <link rel="stylesheet" type="text/css" href="css2.css"/>
    <title>CSS Test</title>
    </head>
    <body class="bodycolor">
    <h1>Hello World</h1>
    <input type="button" class="button" name="B1" id="B1" value="      Click         " size="50">
    </body>
    </html>
    In this case the classes "bodycolor" and "button" will be overridden by css2 file but h1 will be taken from css1
    Hope this helps!!
    Regards,
    Adarsh

  • Problem with CSS/Template in IE display

    Hi,
    I have a problem with a new web site
    http://www.halloween-mayhem.com.
    The CSS is at
    http://www.halloween-mayhem.com/MasterCSS3Col240606.css
    and the template at
    http://www.halloween-mayhem.com/Templates/MasterHM3Col250606.dwt
    When viewed in Firefox everything is fine, but in IE the
    content slips right down the page to beyond the menu . Any idea
    what I have missed or done wrong please?
    Any help greatly appreciated.
    Roy

    The slipping content is too wide for the space you've
    allotted. Make it 3px
    narrower.
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.dreamweavermx-templates.com
    - Template Triage!
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    http://www.macromedia.com/support/search/
    - Macromedia (MM) Technotes
    ==================
    "roythom" <[email protected]> wrote in
    message
    news:ecti8e$ohh$[email protected]..
    > Hi,
    >
    > I have a problem with a new web site
    http://www.halloween-mayhem.com.
    The
    > CSS
    > is at
    http://www.halloween-mayhem.com/MasterCSS3Col240606.css
    and the
    > template
    > at
    http://www.halloween-mayhem.com/Templates/MasterHM3Col250606.dwt
    >
    > When viewed in Firefox everything is fine, but in IE the
    content slips
    > right
    > down the page to beyond the menu . Any idea what I have
    missed or done
    > wrong
    > please?
    >
    > Any help greatly appreciated.
    >
    > Roy
    >

  • Problem with css processing in Firefox8 on Win7.

    Hi guys. I have a problem with css processing in Firefox8 on Win7. I need to make div which width and left css properties should be dynamically changed. Inside this div i have an swf object. When i change width and left css styles for my div, it jumps on the page, but other browsers render that well. What can you suggest to fix this problem? Thanks

    A good place to ask advice about web development is at the mozillaZine Web Development/Standards Evangelism forum.<br />
    The helpers at that forum are more knowledgeable about web development issues.<br />
    You need to register at the mozillaZine forum site in order to post at that forum.<br />
    See http://forums.mozillazine.org/viewforum.php?f=25

  • Problem with PHP, CSS & Code Navigator in CS4

    Hi,
    I've got al little problem with code navigator. To show the problem, I created this 3 files:
    test1.html
    The CSS-Definition is defined static, with simple HTML.
    <html>
    <head>
         <style type="text/css">
              @import "test.css";
         </style>
    </head>
    <body>
          <p>Hello World</p>
    </body>
    </html>
    test2.php
    The CSS-Definition is defined dynamic, with PHP-Code.
    <html>
    <head>
         <style type="text/css">
              <? echo "@import \"test.css\";\n"; ?>
         </style>
    </head>
    <body>
          <p>Hello World</p>
    </body>
    </html>   
    test.css
    The CSS-File which is imported in test1.html and test2.php
    p {
         font-size:20px;
    The Problem in Dreamweaver CS4
    When opening the test.html - File in Dreamweaver CS4, I can easily see the CSS-Definition of the <p>-Tag in Code Navigator. To edit these definition I can simple open the test.css by clicking on the definition in Code navigator. For a complex webpage this is a greate feature. Sadly, this does not work, when I open the test2.php. Although when going to Live View and selecting the <p>-Tag I can see the CSS-Definition and the file in which it is defined in Code Navigator. But by clicking on the definition the test.css DOES NOT OPEN!
    Has anybody a solution? Because many of our projects have dynamic CSS-Definitions, it would be a shame, if this would not work.
    Tanks for help! :-)

    I've done some testing, which might point you in the direction of an interim solution.
    This is the code for related_files.php:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Related files test</title>
    <?php include('include.css'); ?>
    </head>
    <body>
    <p>This is a paragraph.</p>
    </body>
    </html>
    This is the code for include.css:
    <style type="text/css">
    p {
         font-family:"Trebuchet MS", Arial, Helvetica, sans-serif;
         color:#F00;
    </style>
    Note that the include file contains the opening and closing style tags.
    By including your styles like this in a PHP include file, Dreamweaver applies the CSS in Design view (you don't need to turn on Live View). Holding down the Alt key while clicking in Design view brings up the Code Navigator with all the details of the CSS. The one missing link in the chain is that clicking the style selector in the Code Navigator does not open the CSS file. However...
    The file that contains the CSS is listed in the Related Files toolbar, so you can edit it in Split view, and see the results in Design view in exactly the same way as with an HTML page and ordinary style sheet.
    As I say, not the full solution that you wanted, but it might be something worth experimenting with.

  • Weird problems with CSS being applied to JSF pages

    I have this really weird problem with my CSS rules being applied to my JSF pages. My CSS rules don't get applied unless one of the following two things happen:
    - A page is reloaded (by redirecting to itself, or if there were validation errors)
    - The previous page in the history had the same relative reference to the same CSS file.
    If a page is newly loaded, and the previous page did not have that same CSS reference, the CSS styles will not show up. Also, if the above is true, and the page is reloaded by JSF, the CSS styles show up.
    Now, my problem could be solved if I put all JSP files in the same level, but the display of the first page would still be without the CSS style applied.
    Is this known behaviour? And if it is, does it have anything to do do with the way JSF handles URLs (always one level back)? Help and input is kindly appreciated!

    Dude,
    I tried the same
    <link rel="stylesheet" href="<h:outputText value="#{facesContext.externalContext.requestContextPath}"/pages/css/default.css" />
    and I got the following Jasper exception.... pointers plz ??
    =============================================================
    2005-08-24 14:18:55,937 [http-8080-Processor25] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[mydemo].[FacesServlet] - Servlet.service() for servlet FacesServlet threw exception
    org.apache.jasper.JasperException: /myproj/eventCrit.jsp(8,78) Unterminated <h:outputText tag
         at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:39)
         at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:405)
         at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:130)
         at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1049)
         at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1367)
         at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1564)
         at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1793)
         at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1060)
         at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1367)
         at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1564)
         at org.apache.jasper.compiler.Parser.parse(Parser.java:126)
         at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:211)
         at org.apache.jasper.compiler.ParserController.parse(ParserController.java:100)
         at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:146)
         at org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
         at org.apache.jasper.compiler.Compiler.compile(Compiler.java:267)
         at org.apache.jasper.compiler.Compiler.compile(Compiler.java:255)
         at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:556)
         at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:293)
         at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:291)
         at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
    =========================================================

  • Minor Problem with CSS?

    I'm having a minor problem with my CSS for the menu on this page.  The child "2014 Fall Season" under "Season Information" is not adopting the font attributes that all of the other children sub menus are using.  I've racked my brain and can't figure out why.  Any thoughts?
    http://www.simiyouthsoccer.org/all_stars.html

    That menu item contains no anchors (links) so it's not picking up link styles from your #menu CSS.  Try adding a null anchor like the one above it.
    <li><a href="#">2014 Fall Season &9658;</a><ul>
    EDIT:  The code for a Right Triangle should be this &#9658;  (with the # sign)
    Nancy O.

  • My Safari 2.0 crashes - problems with css?

    Hi,
    I have problem with a webpage I built (www.elpskatt.se) using css. When I try to go there with Safari it craches (unsuspectable fault..). I have tried everything, and thinks it has something to do with the way the webpage is built. Can someone help me?
    It works perfect with Firefox, and even Explorer works quite fine. Where can I find info regarding Safari and problems with reading webpages?
    //Annika
    MacBookPro 2,1 Mac OS X (10.4.9)
    MacBookPro 2,1   Mac OS X (10.4.9)  

    Hello annika:
    Welcome to Apple discussions.
    I do not (and could not) develop Safari software. However, this forum may provide you with a place to search and/or ask questions:
    http://discussions.apple.com/category.jspa?categoryID=162
    Barry

Maybe you are looking for

  • Difference between Transaction Figures and Line Items

    Hi, I gone through FI like FI-GL,FI-AR,FI-AP..there i find... Line Items & Transaction figures as main...like in FI we have Line Items - 0FI_GL_4,0FI_AR_4,0FI_AP_4 etc... Transaction Figures - 0FI_GL_6,0FI_AR_6,0FI_AP_6 etc... Now Can some please exp

  • Clearing Out Download Queue in iTunes

    Here's my situation: You know how iTunes lets you scroll through songs you've purchased in iTunes? Great feature, except there's almost a self-destruct button in there. The "Download All" button in the upper right hand corner. If you accidentally hit

  • No matter what tool I choose, all I get is a hand cursor

    I recently installed Photoshop CS4 and didn't have any problems with the installation.  However, quite frequently the program gets into a mode where no matter what tool I choose all I get is a hand cursor.  I've tried logging off to correct the probl

  • User exit for tcode ME9A

    Hi Guys, Im trying to add custom error message for tcode ME9A. Is there any user exits or badi available to do this? Thanks.

  • Why does the Firefox service stay active in the background?

    When closing Firefox, the service keeps running in the task manager. I can not reopen the browser unless i close the service manually. I have deleted Firefox and reinstalled it, it didn't help.