Question on Static keyword  design with JVM

hi
how jvm identify this one is static and other is non-static, if it identifies by using any keyword what is that? see, don't tell by static word. To identify that static, what is implemented in jvm?

DrClap wrote:
jverd wrote:
ejp wrote:
At an educated guess, they are both set by the associated subsystems if the corresponding item was declared static, and not otherwise.
Were you expecting something different?I was hoping it was magic bunnies.I use that hypothesis all the time. Garbage collection? Done by magic bunnies. JIT compiling? Those magic bunnies again. As long as they keep doing their magic, I'm happy because I can get real work done.I tell our junior developers that it is all done by the random effect of gamma rays. I leave out the part about man-in-the-moon marigolds because I don't want Paul Zindel to sue me.
¦ {Þ                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

Similar Messages

  • Designer beginner's question: How to populate form with XML web service output?

    sorry, here is yet another Adobe Designer beginners question: <br /><br />My form uses a webservice data connection which returns <br />an xml-string like this: <br /><br /><?xml version="1.0" encoding="utf-16"?> <br /><CurrentWeather> <br />  <Location>Sion, Switzerland (LSGS) 46-13N 007-20E 481M</Location> <br />  <Time>Apr 26, 2007 - 09:50 AM EDT / 2007.04.26 1350 UTC</Time> <br />  <Wind> from the WSW (240 degrees) at 15 MPH (13 KT):0</Wind> <br />  <Visibility> greater than 7 mile(s):0</Visibility> <br />  <SkyConditions> partly cloudy</SkyConditions> <br />  <Temperature> 80 F (27 C)</Temperature> <br />  <DewPoint> 46 F (8 C) </DewPoint> <br />  <RelativeHumidity> 30%</RelativeHumidity> <br />  <Pressure> 29.88 in. Hg (1012 hPa)</Pressure> <br />  <Status>Success</Status> <br /></CurrentWeather> <br /><br />What is the simplest and recommended way to extract the <br />element fields to my form? <br /><br />Thank you very much an kind regards, <br />Hans Grund

    The question is still unanswered!
    Let me give some details and break up the problem
    in more specific questions:
    - In Designer 8.1 I click new data binding --> wsdl -->
    http://www.webservicex.net/globalweather.asmx?wsdl
    A message box comes up and says "cannot load wsdl file"
    ==> 1. Question:
    Why maybe refuses Designer to load the http-wsdl,
    although this option is explicitly allowed?
    - When I save the wsdl to a file, Designer loads it
    without any problems. The web service uses two input parameters
    (CountryName and CityName) and returns an xml-string GetWeatherResult)
    like the one in my first posting. I drag these fields from the binding view to my form, and it runs ok!
    - THE PROBLEM IS, THAT I NEET TO EXTRACT THE ELEMENT FIELDS
    FROM THE RESULT XML-STRING!
    ==> 2. Question:
    How to extract xml element fields from wsdl output into a form?
    - I tried with eclipse and XmlSpy to build a modified wsdl file
    with structured output definition, so that the specific element fields
    show up in the data binding view and are usable to my form,
    and the modified wsdl maps consistently to the web service result string.
    So far without success: In the PDF -preview or Reader-
    when the wsdl-binding is executed and the web service output
    should show up in the result fields, just nothing happens.
    ==> 3. Question:
    Can this strategy to provide a "modified wsdl" possibly succeed,
    and how?
    ==> 4. Question:
    Is is possible -and how?- to check whether an xml string
    is valid as web service output against the wsdl-definition?
    ==> 5. Question:
    How to debug a web service connection with Designer?
    - Finally I tried to find a way to load the result xml-string
    into a local var in the script editor and parse it, much like:
    var xmlDoc = new ActiveXObject("Microsoft.XMLDOM");
    xmlDoc.load(DataSet.MyForm.GetWeatherResult.rawValue);
    ==> 6. Question:
    Is it possible -and how?- to use a framework like dotnet?
    How to utilize SAX or DOM in Designer?
    Many thanks and appreciations for your help!!

  • Native Multi-VRF-Lite Design with EIGRP Question

    Hello,
    we think about to implement a VRF-Lite design (no MPLS and MBGP) in our campus network (10,000 ports, 20x 6500Sup720, 400x L2-Switches). MPLS is from our point of view oversized for our requirements. We need only a segmentation from different departments. Our IGP is eigrp.
    In the latest IOS-Release for the cat6500 (12.2.18SXD) is finally a VRF-Lite support for EIGRP inside.
    We could test successful a design with different VRFs in our lab, the division workes fine. But we didn't found a way to implement shared service. These are in our case DHCP, DNS, InternerAccess and some others. We thought about a redistribution between our global EIGRP routing table and the EIGRP-vrf tables, but we didn't found a way to do this.
    How can we do this?
    Thanks

    Use a crossover cable to connect a port belonging to the global routing table to a port belonging to a VRF. This way you can leak EIGRP routes from the global routing table into the VRF (through that physical connection). The drawback is that you use 2 ports (that could instead be used for other things...).
    Another way to this, would be to use static routing; use ip route vrf VRF x.x.x.x m.m.m.m n.n.n.n global to allow traffic to go from the VRF into the global routing table.
    Hope that helps...

  • What is difference when using import statement with static keyword ?

    10. package com.sun.scjp;
    11. public class Geodetics {
    12. public static final double DIAMETER = 12756.32; // kilometers
    13. }
    Which two correctly access the DIAMETER member of the Geodetics class? (Choose two.)
    A. import com.sun.scjp.Geodetics;
    public class TerraCarta {
    public double halfway()
    { return Geodetics.DIAMETER/2.0; }
    B. import static com.sun.scjp.Geodetics;
    public class TerraCarta{
    public double halfway() { return DIAMETER/2.0; } }
    C. import static com.sun.scjp.Geodetics.*;
    public class TerraCarta {
    public double halfway() { return DIAMETER/2.0; } }
    D. package com.sun.scjp;
    public class TerraCarta {
    public double halfway() { return DIAMETER/2.0; } }
    The correct answer is A,C.I understood how A is the answer ,but can anyone explain me about package import using static keyword.The above example can be used as a reference.
    Thanks for your consideration.

    amtidumpti wrote:
    10. package com.sun.scjp;
    11. public class Geodetics {
    12. public static final double DIAMETER = 12756.32; // kilometers
    13. }
    Which two correctly access the DIAMETER member of the Geodetics class? (Choose two.)
    A. import com.sun.scjp.Geodetics;
    public class TerraCarta {
    public double halfway()
    { return Geodetics.DIAMETER/2.0; }
    B. import static com.sun.scjp.Geodetics;
    public class TerraCarta{
    public double halfway() { return DIAMETER/2.0; } }
    C. import static com.sun.scjp.Geodetics.*;
    public class TerraCarta {
    public double halfway() { return DIAMETER/2.0; } }
    D. package com.sun.scjp;
    public class TerraCarta {
    public double halfway() { return DIAMETER/2.0; } }
    The correct answer is A,C.I understood how A is the answer ,but can anyone explain me about package import using static keyword.The above example can be used as a reference.
    Thanks for your consideration.here's a link to a small tutorial:
    [http://www.deitel.com/articles/java_tutorials/20060211/index.html]

  • Problem with static keyword

    I faced Problem while using static keyword in Netbeans 6.5

    'static' doesn't exist anymore in JavaFX Script. Instead, put your functions and variable definitions outside of your class. Then they will be script level, which is roughly equivalent to 'static' in Java.

  • Does Crystal Report 10 compatible with JVM 1.5/1.6

    Hi,
    I am working on a project that use Crystal Report 10 Advanced Developer's Java Reporting Component APIs to generate report. Java Bean Connectivity feature is also used
    My client suggests us to use JVM 1.5/1.6, but according to the link http://support.businessobjects.com/communityCS/TechnicalPapers/cr10_supported_platforms.pdf.asp, Crystal Report 10 was only tested with JVM 1.4.2, and Crystal Report 10 is pretty old product, before the JVM 1.5 release
    Would like to know if someone has used JVM 1.5/1.6 with Crystal Report 10 Java Reporting Component APIs/Java Bean Connectivity?? if they works together probably

    Hi,
    You should upgrade Crystal Report 10 to Crystal Report 2008 to keep utilizing publishing from Crystal Report designer or you can use u201CPublishing Wizardu201D to publish these report which are created in Crystal Report 10. But you will not be able utilized any new feature and any bug fixed after Crystal Report 10.
    My recommendation will be to upgrade to Crystal Report 2008.
    Hope it helps.
    Thanks,
    Muhammad

  • Dual-DMVPN Design with Dual Hubs on a single router ??

    Hi All,
    In DMVPN, in Dual-DMVPN Design with Dual Hubs , can a single router perform the role of dual hubs.
    The router has two different internet links. It is intended that when one link goes down, spokes shud connect to the same router onto the other active internet connection. Is this possible ?

    Since no one has answered yet, I'll give you the practical answer.
    You'll have issues with IPSec and static routing. "DMVPN" itself probably wouldn't have an issue, but it would depend on IPSec and routing to work.
    It is easier, by far, to put in a second router. And when you factor in your time to try to make it work (and it may not work), the second router is less expensive.
    Rob

  • Use of 'static' keyword in synchronized methods. Does it ease concurrency?

    Friends,
    I have a query regarding the use of 'synchronized' keyword in a programme. This is mainly to check if there's any difference in the use of 'static' keyword for synchronized methods. By default we cannot call two synchronized methods from a programme at the same time. For example, in 'Program1', I am calling two methods, 'display()' and 'update()' both of them are synchronized and the flow is first, 'display()' is called and only when display method exits, it calls the 'update()' method.
    But, things seem different, when I added 'static' keyword for 'update()' method as can be seen from 'Program2'. Here, instead of waiting for 'display()' method to finish, 'update()' method is called during the execution of 'display()' method. You can check the output to see the difference.
    Does it mean, 'static' keyword has anything to do with synchronizaton?
    Appreciate your valuable comments.
    1. Program1
    public class SynchTest {
         public synchronized void display() {
              try {
                   System.out.println("start display:");
                   Thread.sleep(7000);
                   System.out.println("end display:");
              } catch (InterruptedException e) {
                   e.printStackTrace();
         public synchronized void update() {
              try {
                   System.out.println("start update:");
                   Thread.sleep(2000);
                   System.out.println("end update:");
              } catch (InterruptedException e) {
                   e.printStackTrace();
         public static void main(String[] args) {
              System.out.println("Synchronized methods test:");
              final SynchTest synchtest = new SynchTest();
              new Thread(new Runnable() {
                   public void run() {
                        synchtest.display();
              }).start();
              new Thread(new Runnable() {
                   public void run() {
                        synchtest.update();
              }).start();
    Output:
    Synchronized methods test:
    start display:
    end display:
    start update:
    end update:
    2. Program2
    package camel.java.thread;
    public class SynchTest {
         public synchronized void display() {
              try {
                   System.out.println("start display:");
                   Thread.sleep(7000);
                   System.out.println("end display:");
              } catch (InterruptedException e) {
                   e.printStackTrace();
         public static synchronized void update() {
              try {
                   System.out.println("start update:");
                   Thread.sleep(2000);
                   System.out.println("end update:");
              } catch (InterruptedException e) {
                   e.printStackTrace();
         public static void main(String[] args) {
              System.out.println("Synchronized methods test:");
              final SynchTest synchtest = new SynchTest();
              new Thread(new Runnable() {
                   public void run() {
                        synchtest.display();
              }).start();
              new Thread(new Runnable() {
                   public void run() {
                        synchtest.update();
              }).start();
    Output:
    Synchronized methods test:
    start display:
    start update:end update:
    end display:

    the synchronized method obtain the lock from the current instance while static synchronized method obtain the lock from the class
    Below is some code for u to have better understanding
    package facado.collab;
    public class TestSync {
         public synchronized void add() {
              System.out.println("TestSync.add()");
              try {
                   Thread.sleep(2000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              System.out.println("TestSync.add() - end");          
         public synchronized void update() {
              System.out.println("TestSync.update()");
              try {
                   Thread.sleep(2000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              System.out.println("TestSync.update() - end");          
         public static synchronized void staticAdd() {
              System.out.println("TestSync.staticAdd()");
              try {
                   Thread.sleep(2000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              System.out.println("TestSync.staticAdd() - end");
         public static synchronized void staticUpdate() {
              System.out.println("TestSync.staticUpdate()");
              try {
                   Thread.sleep(2000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              System.out.println("TestSync.staticUpdate() - end");
         public static void main(String[] args) {
              final TestSync sync1 = new TestSync();
              final TestSync sync2 = new TestSync();
              new Thread(new Runnable(){
                   public void run() {
                        sync1.add();
              }).start();
              new Thread(new Runnable(){
                   public void run() {
                        sync2.update();
              }).start();
              try {
                   Thread.sleep(3000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              new Thread(new Runnable(){
                   public void run() {
                        sync1.staticAdd();
              }).start();
              new Thread(new Runnable(){
                   public void run() {
                        sync2.staticUpdate();
              }).start();
    }

  • Transparent design with router on both sides?

    I am looking to solve a design which has to work in two scenarios. Preferably with an in-line solution.
    1. Transparent design with VRF on both sides:
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      | ACE (Subnet A)
          |
          | (VLAN 12)
          |
    LAN-VRF
          |
          |  (VLAN 13)
          |
    Real servers (Subnet B)
    2. Transparent design in plain bridge mode
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      |
       ACE (Subnet A)
          |
          | (VLAN 12)
          |
    Real servers (Subnet A)
    As mentioned, I am aiming for a single design for both scenarios. A routed design will not pass in the first scenario and a one-arm solution will be inefficient in the second scenario. (both due to existing infrastructure) Is it possible to solve this with a transparent solution in both scenarios? I can't seem to get it to work.
    Thanks in advance for any help!

    I'm gonna expand my question a bit as I can not seem to get a working config in scenario 1. From the ACE I can ping the VRFs on both side of the ACE. I can on the other hand not ping neither the bvi-address of the ACE nor one VRF from the other. Can anyone notice any immediate errors in my config? Thanks in advance for any help!
    Addresses:
    10.3.66.1 - FW_VRF on client side
    10.3.66.6 - LAN_VRF on server side
    10.3.66.7 - BVI if on ACE
    ===Admin===
    resource-class TEST_res
    limit-resource all minimum 10.00 maximum unlimited
    boot system image:c4710ace-mz.A3_2_0.bin
    hostname 4710Appl
    interface gigabitEthernet 1/1
    description Management port
    switchport access vlan 752
    no shutdown
    interface gigabitEthernet 1/2
    description Client side LAN
    switchport trunk allowed vlan 2522
    no shutdown
    interface gigabitEthernet 1/3
    description Server side LAN
    switchport trunk allowed vlan 2524
    no shutdown
    interface gigabitEthernet 1/4
    shutdown
    access-list BPDU ethertype permit bpdu
    access-list ALL line 8 extended permit ip any any
    access-list everyone line 8 extended permit ip any any
    access-list everyone line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    4 match protocol snmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    description Management VLAN
    ip address 10.7.52.63 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1
    context TEST_context
    allocate-interface vlan 752
    allocate-interface vlan 2522
    allocate-interface vlan 2524
    member TEST_res
    context TEST_context_routed
    username admin password 5 $1$bale5EiS$bEdquz.bbcW3wRcfeSzbu/  role Admin domain
    default-domain
    username www password 5 $1$bsOdgxav$1uywtkwFEj3QalKaOTrkZ1  role Admin domain de
    fault-domain
    ssh key rsa 1024 force
    ===Application context===
    access-list ALL line 8 extended permit ip any any
    access-list ALL line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    ip address 10.7.52.64 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    interface vlan 2522
    description Client side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface vlan 2524
    description Server side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface bvi 1
    ip address 10.3.66.7 255.255.255.240
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1

  • How to register Key fingerprint with JVM 1.4.2?

    Hi,
    We need to register RSA key fingerprint with JVM 1.4.2. Does anyone know about this how to go about it?
    Thanks,
    Asawari

    Hi,
    as far as I know there is no "official" API in 1.4.2 to do this (since 1.5 there are the Management APIs). But I had the same problem once and found a pretty easy solution: Put the "perf.jar" and "perfdata.jar" from the 1.4.2 jvmstat distribution into your classpath (I hope you can find the old download somewhere...).
    The following piece of code demostrates how to access the perfdata from the JVM (note: with new VMIdentifier(0) you access your own JVM, so running the little sample program without any argument (or argument "0") would introspect the own JVM).
    import com.sun.jvmstat.perfdata.monitor.local.*;
    import com.sun.jvmstat.monitor.*;
    import java.util.*;
    public class PerfDataReader {
        public PerfDataReader() {
        public void run(String[] args) {
        try {
          PerfDataBuffer perfDataBuffer = new PerfDataBuffer(new VMIdentifier((args.length == 0 ? "0" : args[0])));
          System.out.println("VmId="+perfDataBuffer.getLocalVmId());
          List l = perfDataBuffer.findByPattern(".*");
          for (int i=0; i<l.size(); i++) {
              Monitor m = (Monitor)l.get(i);
              System.out.println(m.getName()+" = "+m.getValue());
        } catch(Exception e) {
          e.printStackTrace();
        public static void main(String[] args) {
            PerfDataReader main = new PerfDataReader();
            main.run(args);
    }Hope this helps!
    Nick.

  • Updating qms0012f.fmb in designer with qms0012f.fmb from 6.5.2.2 patch

    Hi,
    I have recently updated our headstart templates/objects with patch 6.5.2.2.
    I would like to update designer with these more up to date libraries and forms.
    I have been able to do a design capture of the libraries (eg. qms0012l.pll) back into
    designer but I am having a bit of trouble with the form (eg. qms0012f.fmb). The
    form capture doesn't seem to work. It is possible that I have missed the procedure
    to do this in the documentation. If so can you please direct me to the right spot.
    Is it possible to receive an export so we can import it back into designer?

    Marc,
    Do not put too much effort in design capturing forms (fmb files). This is NOT 100% real-roundtrip-
    reengineerable, I gathered that hence my question in this forum :)
    in opposite to the forms pll libraries, which can be generated 100% after a succesfull >design capture.The reason for my attempt to capture the form qms0012f is to keep the module in designer in sync with the fmb file we received in the patch.
    What we would like to do is customise the form (which we have previously done in designer). If we make the changes in the fmb file itself then it means it is not held in designer which would really defeat our efforts in 100% generation. How do you suggest we do this?

  • Question on how networking works with new Macbook Pro

    Hi,
    I have a question about how networking works with my new Macbook Pro. This is my first laptop so am new to mobile computing. I am about to configure it to replace my desktop which uses a wired DSL connection. Once I have my Macbook Pro configured to run off the DSL modem, what happens when I take this computer to a location that has ethernet? Will just plugging in the ethernet cable be enough to get on line? Or is there further configuration work that needs to be done?
    I used a Windows laptop from work and all I had to do was plug it in to a hotel ethernet cable to get on line. However, this laptop was never configured to run on my DSL network so I am not certain if that makes things more complicated.
    Thanks for your help!

    Hi
    Your MacBook Pro should just work when plugged into an ethernet connection.
    Just check something, Open Network Preferences, you can select it from the Airport icon in the menu bar.
    In the left-hand pane click on Ethernet and just check that it is set to configure using DHCP in the right-hand pane, that's it.
    So when you plug in the ethernet cable it will ask the router for an IP address and off you go.
    I assume that any system you plug into will use DHCP rather than static IP addresses. If it is a static IP address, you will need to manually configure the ethernet settings by inputting the IP address and subnet mask info plus DNS servers.
    Usually it is done with DHCP and you don't have to do a thing and likewise your home DSL is DHCP?
    If not then you will have to change your settings, make a 'Hotel' setting which you can use when in hotels and keep your 'Home' set-up for when you are at home. In the pull down menu select Edit Locations to add new ones.
    Phil
    Message was edited by: Philip Tyler

  • ZBFW design with vrf

    Hello,
    I am preparing a zbfw design with 400+ ISR/ASR remote  routers, Flexvpn and 1 vrf.  Each router has a tunnel for visitors and another tunnel for normal users. Config below. In the documentation, I read "All interfaces in a zone must belong to the same Virtual Routing and Forwarding (VRF) instance"
    There is no need to communicate between vrf visitor and the GRT, but both use the common wan zone on gigibit 0/0 and gigabit 0/2  to communicate to central.
    My question: Can I put all 4 tunnel interfaces below in the same zone :vpn ?
    ip vrf Visitors
    interface Tunnel1111
    description === FlexVPN to nrtc102 (DC1 AVC - primary line) ===
    ip unnumbered Loopback1
    ip mtu 1380
    ip tcp adjust-mss 1340
    tunnel source GigabitEthernet0/0
    tunnel destination 10.255.117.104
    tunnel protection ipsec profile Primary-line
    interface Tunnel1112
    description === FlexVPN to nrtc102 (DC1 AVC - Secondary line) ===
    ip unnumbered Loopback2
    ip mtu 1380
    ip tcp adjust-mss 1340
    tunnel source GigabitEthernet0/2
    tunnel destination 10.255.117.105
    tunnel protection ipsec profile Secondary-line
    interface Tunnel1113
    description === FlexVPN to nrtcDMZ (DC1 - visitors - primary line) ===
    ip vrf forwarding Visitors
    ip unnumbered Loopback3
    ip mtu 1380
    ip tcp adjust-mss 1340
    tunnel source GigabitEthernet0/0
    tunnel destination 10.255.112.104
    tunnel protection ipsec profile Primary-line-visitors
    interface Tunnel1114
    description === FlexVPN to nrtcDMZ (DC1 - visitors - Secondary line) ===
    ip vrf forwarding Visitors
    ip unnumbered Loopback4
    ip mtu 1380
    ip tcp adjust-mss 1340
    tunnel source GigabitEthernet0/2
    tunnel destination 10.255.112.105
    tunnel protection ipsec profile Secondary-line-visitorsinterface
    Many thanks Karien

    Hello Karien,
    Not sure I get the question..
    The definition you are looking I guess is this one:
    A router can only inspect inter-VRF traffic if traffic must enter or leave a VRF through an interface to cross to a different VRF. If traffic is routed directly to another VRF, there is no physical interface where a firewall policy can inspect traffic, so the router is unable to apply inspection.
    Based on that I would say that on each VRF there will need to be a dedicated security zone applied,
    I will try to run a lab real quick tomorrow and get back to u,
    Remember to rate all of the helpful posts. That's as important as a Thanks.
    Julio Carvajal Segura

  • How to get the amazon book list design with the RowRepeater

    Hello,
    at the moment I am programming a small book management application. After the fight with the row repeater (that at least was a bug in the rowrepeater) I would like to have a desing like the amazon-list:
    http://www.amazon.com/s/ref=nb_ss?url=search-alias%3Dstripbooks&field-keywords=sap
    Could someone tell me how I can achive this?
    - How can I use the Image with the url to the image.
    - How can I get the title as link to a view that shows the details of the book (is it LinkToAction? if yes, how can I pass a parameter?)
    - How can I get the design with 2 cols and for the text new lines?
    Thank you very much in advance and have a nice week,
      Vanessa

    How can I use the Image with the url to the image.
    With image you cannot have URL. You have use Image UI element and you can place an linktourl element below the image.
    How can I get the title as link to a view that shows the details of the book
    For links, you are right . You have to use LinkToAction UI element. On the Action of Link , you can get the value selected by reading the attribute binded to that link.
    How can I get the design with 2 cols and for the text new lines
    For columns , you have to use Table UI element.
    For designing you view according to the requirements , you can use various UI elements :
    Tray , Group , Transparent containers. These would help you in making specific containers or grouping particular set of elements together.

  • Replace "static" Entitlement banner with "slideshow" Entitlement banner in html implementation of default library v3

    I'm currently in the process of updating an existing Enterprise DPS App. I'm using the online "DPS Configurator" to create an updated iOS7-style HTML implementation of the default library (v3). I also want to implement the DPS Configurator's Slideshow entitlement banner. Is there any documentation on replacing the static entitlement banner with slideshow entitlement banner for the custom HTML implementation? Or is it one or the other? If I can incorporate both, do I have to manually replace static with slideshow banner in code (via DreamWeaver) or will it replace when I go to App Builder. I should also mention that this isn't a true entitlement App, I'm just using Ivan Mironchuck's article... Adding HTML banners to non-entitlement apps | Adobe Developer Connection "fake out" technique to include an entitlement banner in the first place on existing v1 of our current app. Any guidance would be greatly appreciated.

    Thanks for your quick reply Derek. My follow up question is how is TopGear Magazine achieving the iOS7 look on their library along with what looks like the slideshow Entitlement banner? Am I over-thinking things here? If I simply want the brighter iOS7 look for my library is Viewer v31 like this right out of the box then?

Maybe you are looking for