Script to enable WOL for list of computers in CSV format

We are looking to enable Wake On LAN in our environment of 30,000+ workstations. I have been successful in getting the workstation to wake up, but I had to manually a) change the BIOS setting to enable WOL and b) change the Adapter setting enabling
power management and WOL in Windows.
We will be piloting this to 250 or so workstations, to see the functionality of getting WOL to work (for software updates in the middle of the night). However, we don't want to have to "touch" each and every one of them. Thus, I'm looking to create
a VBS script to enable WOL and having it reference a CSV file that contains a list of workstation names.
Any help would be great!
Thank you!

Hi,
If you have Dell machines, you can use their CCTK to adjust the BIOS settings:
http://en.community.dell.com/techcenter/systems-management/w/wiki/1952.dell-client-configuration-toolkit-cctk.aspx
I haven't used this tool in years, but I remember it being pretty friendly.
Don't retire TechNet! -
(Don't give up yet - 12,575+ strong and growing)

Similar Messages

  • Script that enables mail users and kicks out two csv files

    I am working on a script that will mainly be used as a scheduled task to enabled mailuser by calling the update-recipient command. 
    But before it calls that command it will get for various issues that can cause errors.
    Missing PrimarySMTP
    Display name having a space at front or back.
    The external email address being blank.
    I have IF statements setup to check for those and then call a function that will save into an array the issue for that user. 
    Here is the script
    <#
    .SYNOPSIS
    Enable-MailUsers Synced Mail Users in the Exchange environment
    THIS CODE IS MADE AVAILABLE AS IS, WITHOUT WARRANTY OF ANY KIND. THE ENTIRE
    RISK OF THE USE OR THE RESULTS FROM THE USE OF THIS CODE REMAINS WITH THE USER.
    Version .9, 30 June 2014
    .DESCRIPTION
    This script mail-enables Synced Mail Users and creates a CSV report of mail users that were enabled.
    The following is shown:
    * Report Generation Time
    .PARAMETER SendMail
    Send Mail after completion. Set to $True to enable. If enabled, -MailFrom, -MailTo, -MailServer are mandatory
    .PARAMETER MailFrom
    Email address to send from. Passed directly to Send-MailMessage as -From
    .PARAMETER MailTo
    Email address to send to. Passed directly to Send-MailMessage as -To
    .PARAMETER MailServer
    SMTP Mail server to attempt to send through. Passed directly to Send-MailMessage as -SmtpServer
    .PARAMETER ScheduleAs
    Attempt to schedule the command just executed for 10PM nightly. Specify the username here, schtasks (under the hood) will ask for a password later.
    .EXAMPLE
    Generate the HTML report
    .\Enable-MailUsers.ps1 -SendMail -MailFrom [email protected] -MailTo [email protected] -MailServer ex1.contoso.com -ScheduleAs SvcAccount
    #>
    param(
    [parameter(Position=0,Mandatory=$false,ValueFromPipeline=$false,HelpMessage='Send Mail ($True/$False)')][bool]$SendMail=$false,
    [parameter(Position=1,Mandatory=$false,ValueFromPipeline=$false,HelpMessage='Mail From')][string]$MailFrom,
    [parameter(Position=2,Mandatory=$false,ValueFromPipeline=$false,HelpMessage='Mail To')]$MailTo,
    [parameter(Position=3,Mandatory=$false,ValueFromPipeline=$false,HelpMessage='Mail Server')][string]$MailServer,
    [parameter(Position=4,Mandatory=$false,ValueFromPipeline=$false,HelpMessage='Schedule as user')][string]$ScheduleAs
    # Sub Function to neatly update progress
    function _UpProg1
    param($PercentComplete,$Status,$Stage)
    $TotalStages=5
    Write-Progress -id 1 -activity "Mail enabled Objects" -status $Status -percentComplete (($PercentComplete/$TotalStages)+(1/$TotalStages*$Stage*100))
    #Sub Function create ErrObject output
    function _ErrObject{
    Param($name,
    $errStatus
    If(!$err){
    Write-Host "error detected"
    $script:err = $True
    $ErrObject = New-Object -TypeName PSObject
    $Errobject | Add-Member -Name 'Name' -MemberType Noteproperty -Value $Name
    $Errobject | Add-Member -Name 'Comment' -MemberType Noteproperty -Value $errStatus
    $script:ErrOutput += $ErrObject
    # 1. Initial Startup
    # 1.0 Check Powershell Version
    if ((Get-Host).Version.Major -eq 1)
    throw "Powershell Version 1 not supported";
    # 1.1 Check Exchange Management Shell, attempt to load
    if (!(Get-Command Get-ExchangeServer -ErrorAction SilentlyContinue))
    if (Test-Path "D:\Exchsrvr\bin\RemoteExchange.ps1")
    . 'D:\Exchsrvr\bin\RemoteExchange.ps1'
    Connect-ExchangeServer -auto
    } elseif (Test-Path "D:\Exchsrvr\bin\Exchange.ps1") {
    Add-PSSnapIn Microsoft.Exchange.Management.PowerShell.Admin
    .'D:\Exchsrvr\bin\Exchange.ps1'
    } else {
    throw "Exchange Management Shell cannot be loaded"
    # 1.2 Check if -SendMail parameter set and if so check -MailFrom, -MailTo and -MailServer are set
    if ($SendMail)
    if (!$MailFrom -or !$MailTo -or !$MailServer)
    throw "If -SendMail specified, you must also specify -MailFrom, -MailTo and -MailServer"
    # 1.3 Check Exchange Management Shell Version
    if ((Get-PSSnapin -Name Microsoft.Exchange.Management.PowerShell.Admin -ErrorAction SilentlyContinue))
    $E2010 = $false;
    if (Get-ExchangeServer | Where {$_.AdminDisplayVersion.Major -gt 14})
    Write-Warning "Exchange 2010 or higher detected. You'll get better results if you run this script from an Exchange 2010/2013 management shell"
    }else{
    $E2010 = $true
    $localserver = get-exchangeserver $Env:computername
    $localversion = $localserver.admindisplayversion.major
    if ($localversion -eq 15) { $E2013 = $true }
    #Get date
    $filedate = get-date -uformat "%m-%d-%Y"
    $filedate = $filedate.ToString().Replace("0", "")
    #Get the valid users that are not mail-enabled
    _UpProg1 1 "Getting User List" 1
    #$Users = Get-mailuser -ResultSize unlimited -OrganizationalUnit "R0018.COLLABORATION.ECS.HP.COM/Accounts/AbbVienet/Users" | ?{$_.legacyexchangeDN -eq ""}
    $i = 0
    $output = @()
    $errOutput = @()
    $err = $False
    #2 Process users
    ForEach ($User in $Users){
    $i++
    _UpProg1 ($i/$Users.Count*100) "Updating Recipients" 2
    If ($user.ExternalEmailAddress -eq $null){
    _ErrObject $user.Name, "Missing External Email Address"
    ElseIf($user.DisplayName -NotLike "* "){
    _ErrObject $user.Name, "DisplayName contains a trailing space"
    ElseIf($user.DisplayName -NotLike "_*"){
    _ErrObject $user.Name, "DisplayName contains a Leading space"
    ElseIf($user.PrimarySmtpAddress -eq $null){
    _ErrObject $user.Name, "Missing Primary SMTP address"
    Else{
    #Disable EmailAddressPolicy on these users
    Set-Mailuser $User.Name -EmailAddressPolicyEnabled $false
    #pass to Update-recipient
    Update-Recipient $User.Name
    $LEDN = Get-MailUser $User.Name | Select {$_.LegacyExchangeDN}
    If ($LEDN -ne ""){
    $object = New-Object -TypeName PSObject
    $X500 = "x500:" + $LEDN.'$_.LegacyExchangeDN'
    $object | Add-Member -Name 'Name' -MemberType Noteproperty -Value $User.Name
    $object | Add-Member -Name 'x500' -MemberType Noteproperty -Value $X500
    $output += $object
    #Creating CSVFile Output
    _UpProg1 99 "Outputting CSV file 3" 3
    $CSVFile = "c:\scripts\Mail-enable\Mailenabled_$((Get-Date).ToString('MM-dd-yyyy_hh-mm-ss')).csv"
    If($err){
    $ErrCSVFile = "c:\scripts\Mail-enable\ProblemUsers_$((Get-Date).ToString('MM-dd-yyyy_hh-mm-ss')).csv"
    $errOutput | Select-Object Name, Comment | ConvertTo-CSV -NoTypeInformation > $ErrCSVFIle
    $Output | ConvertTo-Csv -NoTypeInformation > $CSVFile
    if ($SendMail)
    _UpProg1 95 "Sending mail message.." 4
    If($err){
    Send-MailMessage -Attachments $CSVFile,$ErrCSVFile -To $MailTo -From $MailFrom -Subject "Enable Mail Users Script" -BodyAsHtml $Output -SmtpServer $MailServer
    Else{
    Send-MailMessage -Attachments $CSVFile -To $MailTo -From $MailFrom -Subject "Enable Mail Users Script" -BodyAsHtml $Output -SmtpServer $MailServer
    if ($ScheduleAs)
    _UpProg1 99 "Attempting to Schedule Task.." 4
    $dir=(split-path -parent $myinvocation.mycommand.definition)
    $params=""
    if ($SendMail)
    $params+=' -SendMail:$true'
    $params+=" -MailFrom:$MailFrom -MailTo:$MailTo -MailServer:$MailServer"
    $task = "powershell -c \""pushd $dir; $($myinvocation.mycommand.definition) $params\"""
    Write-Output "Attempting to schedule task as $($ScheduleAs)..."
    Write-Output "Task to schedule: $($task)"
    schtasks /Create /RU $ScheduleAs /RP /SC DAILY /ST 22:00 /TN "Enable Mail Users" /TR $task
    The Problem is that when I look at the $errOutput I see things but when I pipe the $erroutput to convertTo-CSV I get this within the CSV file. I think its because I an calling a function to do the updating. But not sure.
    Jeff C

    Hi Jeff,
    Any updates? If you have any other questions, please feel free to let me know.
    A little clarification to the script:
    function _ErrObject{
    Param($name,
    $errStatus
    If(!$err){
    Write-Host "error detected"
    $script:err = $True
    $ErrObject = New-Object -TypeName PSObject
    $Errobject | Add-Member -Name 'Name' -MemberType Noteproperty -Value $Name
    $Errobject | Add-Member -Name 'Comment' -MemberType Noteproperty -Value $errStatus
    $script:ErrOutput += $ErrObject
    $errOutput = @()
    _ErrObject Name, "Missing External Email Address"
    $errOutput
    _ErrObject Name "Missing External Email Address"
    $errOutput
    If you have any feedback on our support, please click here.
    Best Regards,
    Anna Wang
    TechNet Community Support

  • Creating DataSources for File Source Systems in csv format in sap bw 7.0

    Hi,
    Please explain how to Create DataSources for File Source Systems in csv format in sap bw 7.0. WITH SCREENSHOTS
    Thanks
    JINI
    Edited by: Jini  Jayan on Jun 11, 2008 11:36 AM

    Step 1. Select Source systems under Modelling in the left panel. In the right panel, right-click Source systems and select Createu2026.
    Step 2. Select the FileSystem, manual meta data, data using file inte option, and then click  to continue.
    Step 3. Enter a name and a description for the source system, and then click  to create the source system.
    Now create an application component
    Step 1. Select InfoSources under Modelling in the left panel. In the right panel, right-click InfoSources and select Create application componentu2026.
    Step 2. Enter a name and a description for the application component, and then click  to continue. (BW automatically adds a prefix of "Z" to the technical names of application components, unlike the naming system used for other BW objects.If u give the name as AC_DEMO it will be saved as ZAC_DEMO in the system.
    Now create infosource
    Step 1.Select InfoSources under Modelling in the left panel. Right-click the newly created Application Component , and then select Create InfoSourceu2026.
    Step 2. Select the option Master data/texts/hierarchies, and then click  to continue.
    Step 3. Enter your infoobject name, and then click  to continue.
    Now you will be asked
    Infosource(name) assigned to Appln component(name)?
    Click continue
    Now go back to workbench and see the Infoobject listed under the Application component name (under Infosource)
    Right click the infoobject name and select Assign Datasource
    Enter the Infoobject name as Infosource name and the source system name and continue
    Now you ll get datasource assignment confirmations for Infosource_ATTR and Infosource_TEXT for master data and text.
    Click yes and continue
    Now you ll be taken to the Infosource(master data) change screen
    Source system name will be given
    Below that u need to give the datasource name u2026.._ATTR
    Click Activate.
    Now Click the tab transfer rules
    Copy the communication str infoobject names to an excel sheet
    For ex if your infoobj are IO_MATNUM and IO_MATNAME (material number and material name) copy and paste as
    IO_MATNUM      IO_MATNAME
    MAT001     TEA
    MAT002     COFFEE
    MAT003     SUGAR
    GIVE YOUR DATA IN THE EXCEL. AND CLICK File Save As CSV(comma delimited) and save to ur system. Give file name as something like infosourcename_ATTR.csv
    Now back to the Infosourcechange screen
    Source system name will be given
    Below that u need to give the datasource name u2026.._TEXT
    And activate
    Now Click the tab transfer rules
    Copy the communication str infoobject names to an excel sheet
    GIVE YOUR DATA IN THE EXCEL. AND CLICK File Save As CSV(comma delimited) and save to ur system. Give file name as something like infosourcename_TEXT.csv
    Now create Infoobject to load data
    Go to Infosourceu2014Appln Componentu2014InfoObju2014SourceSystemu2014rightclick->create Infopackage
    Step 2. Select the DataSource Material number (Master data), enter a description for the InfoPackage, and then click  to continue.
    Give infopackage description as Infopackage:InfoObj_ATTR
    Now take care to select the first item in datasource and click continue
    In the next screen click external data tab
    Click client workstation
    Datafileu2026.file name (browse to give the file u saved in ur system)
    There will be an option to remove header data from file.remove 1 row.
    File typeu2014csv file
    Now click schedule tabu2014start dataload immediatelyu2014start.
    In the same way
    Go to Infosourceu2014Appln Componentu2014InfoObju2014SourceSystemu2014rightclick->create Infopackage
    Step 2. Select the DataSource Material number (text)enter a description for the InfoPackage, and then click  to continue.
    Give infopackage description as Infopackage:InfoObj_TEXT
    Now take care to select the second  item in datasource and click continue
    In the next screen click external data tab
    Click client workstation
    Datafileu2026.file name (browse to give the file u saved in ur system)
    There will be an option to remove header data from file.remove 1 row.
    File typeu2014csv file
    Now click schedule tabu2014start dataload immediatelyu2014start.
    Click the icon below admn workbench to go to monitor and check the load
    Or you go back to Infosourceu2014Appln Componentu2014InfoObju2014right clickmaintain master data
    Click execute
    You can see the data load
    Hope this helps!!!

  • Materialized View Log - Compress Clause for List Partition

    Hi All,
    In Syntax diagram it states that Compress Clause for List Partition of Materialized View Log is valid , but when we run any script with compress clause for list partition on Materialized view log then Database throws error as ORA-14020: this physical attribute may not be specified for a table partition
    So in any chance we can have the compress clause for the partition of materialized view log.
    Thanks in advance,
    Manu.

    The "CREATE MATERIALIZED VIEW LOG" syntax refers to the "Table Partitioning" section of the CREATE TABLE documentation.
    The "Table Partitioning" section refers to "table_partition_description" which then refers to "table_compression". "table_compression" then states that you can specify compression for entire table in the physical_properties clause and for range partition / list partition in the "table_partition_description". The Restrictions section on Table Compression says "You cannot define table compression explicitly for hash partitions or hash and list subpartitions" which implies that you can define partition for list partitions.
    Moreover, error 14020 lists valid options for Range or Composite Range and for Hash partitoins -- which implies that all other Table physical attributes are applicable for List partitions. (But then, is Compression a physical attribute -- it is really part of "physical properties" not "physical attributes").
    I think that the documentation isn't explicit enough and needs to be fixed.
    N.B : Referencing the 10.2 documentation.
    Hemant K Chitale
    Edited by: Hemant K Chitale on Feb 1, 2010 4:12 PM

  • Powershell for single service status of all ad computers in csv result

    What have you tried so far?

    Dear All, Pl help to find the single service status for all ad computers with csv, html or any format result.
    Pl do not suggest for third party tools or softwares.
    Pl share batch script, powershell or vbs
    This topic first appeared in the Spiceworks Community

  • Amending script to read list of computers, run script and output to log file

    Hello all,
    I have cobbled together a script that runs and does what I want, now I would like to amend the script to read a list of computers rather than use the msg box that it is currently using for the strcomputer, if the computers doesn't respond to a ping, then
    log that, if it does continue with the script and when it is complete, log a success or failure. I have just started scripting and would really appreciate some help on this one,thanks. I created the script to fix an SCCM updates issue and failing task sequences,
    so it may prove useful to others.
    There are msg box entries that can be removed that were originally in there for the user running the script.
    'setting objects
    Dim net, objFSO, shell
    Dim objFile, strLine, intResult
    Set objnet = CreateObject("wscript.network")
    Set objFSO = CreateObject("scripting.filesystemobject")
    Set objshell = CreateObject("wscript.shell")
    strfile = "c:\wuafix\wuafix.vbs"
    strUser = "domain\user"
    strPassword = "password"
    'getting server name or IP address
    strComputer=InputBox("Enter the IP or computer name of the remote machine on which to repair the WUA agent:", "Starting WUA Fix")
    'check to see if the server can be reached
    Dim strPingResults
    Set pingExec = objshell.Exec("ping -n 3 -w 2000 " & strComputer) 'send 3 echo requests, waiting 2secs each
    strPingResults = LCase(pingExec.StdOut.ReadAll)
    If Not InStr(strPingResults, "reply from")>0 Then
    WScript.Echo strComputer & " did not respond to ping."
    WScript.Quit
    End If
    'Check if source file exists
    If Not objFSO.FileExists(strFile) Then
    WScript.Echo "The source file does not exist"
    WScript.Quit
    End If
    MsgBox "The WUA Fix is in process. Please wait.", 64, "Script Message"
    'mapping drive to remote machine
    If objFSO.DriveExists("Z:") Then
    objnet.RemoveNetworkDrive "Z:","True","True"
    End If
    objnet.MapNetworkDrive "Z:", "\\" & strComputer & "\c$", True
    'creating folder for install exe on remote machine
    If (objFSO.FolderExists("Z:\wuafix\") = False) Then
    objFSO.CreateFolder "Z:\wuafix"
    End If
    'copying vbs to remote machine
    objFSO.CopyFile strFile, "Z:\wuafix\wuafix.vbs"
    'set command line executable to run a silent install remotely
    strInstaller1 = "cscript.exe c:\wuafix\wuafix.vbs"
    'strInstaller2 = "c:\wuafix\wuafix.vbs"
    strExec = "c:\pstools\PsExec.exe "
    'objshell.Run strExec & " \\" & strComputer & strInstaller1
    On Error Resume Next
    result = objshell.Run(strExec & " \\" & strComputer & " " & strInstaller1)
    If Err.Number = 0 Then
    WScript.Echo "PSXEC Runing WUA fix remotely"
    Else MsgBox Err.Number
    MsgBox result
    End If
    Set objWMIService = GetObject("winmgmts:" _
    & "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2")
    Set colLoggedEvents = objWMIService.ExecQuery _
    ("SELECT * FROM Win32_NTLogEvent WHERE Logfile = 'Application' AND " _
    & "EventCode = '4'")
    Wscript.Echo "Event Viewer checked and Fix Applied:" & colLoggedEvents.Count
    MsgBox "Removing mapped drive Please wait.", 64, "Script Message"
    If objFSO.DriveExists("Z:") Then
    objnet.RemoveNetworkDrive "Z:","True","True"
    End If
    MsgBox "The WUA Fix has been applied.", 64, "Script Message"
    quit
    wscript.quit
    Any help appreciated and explanations on the process would be great as I would like to learn the process involved, which is difficult when working during the day.
    many thanks

    Hi Bill,
    long story short, I have approx. 2800 clients with an old entry in WMI for updates that the sccm client cannot clear or run because they do not exist anymore, so the client will not run updates or use a task sequence because of this, so my script fixes this
    and does a couple of other things, I have found another way to do this by running  a different script that uses WMI to call a cscript function that uses the wuafix.vbs that is coped to the machine, I am also changing the echo entries to output to a log
    file instead so that I can track what client has run the fix andn which ones haven't.
    If you have any suggestions then please let me know, nothing nefarious :)
    many thanks

  • Powershell Script to Enable and Disable SharePoint list versioning

    Hi,
    We have a Sharepoint list with a date and time field named 'Today' which we update overnight
    via PowerShell script to give the current date and this recalculates other calculated fields
    in the list.
    All is fine but we have versioning enabled on the list and so we get a new version created everyday.
    Is there a way to disable the versioning prior to running the update and then re-enable
    after?
    This is the script
    Add-PSSnapin Microsoft.SharePoint.PowerShell
    Start-SPAssignment -Global
    $SPWeb = Get-SPWeb "<SharePointSiteUrl>"
    $List = $SPWeb.Lists["ListName"]
    $Items = $List.Items
    foreach ($item in $items)
     $modifiedBy = $item["Editor"]
     $modified = $item["Modified"]
     $item["Today"] = Get-Date
     $item["Editor"] = $modifiedBy
     $item["Modified"] = $modified
     $item.Update()
     $list.Update()
    $SPWeb.Dispose()
    Stop-SPAssignment -Global  

    Hi
    Here is a quick powershell script to iterate a site collection and remove versioning on all list of base-type Document Library. Also the iteration removes all the current versions of list items. Great for freeing up space and also to make publishing sites
    a little more easy to manage content for trusted content approvers!
    Check the below powershell script
    [void][System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint")
    # Get site
    $site = new-object Microsoft.SharePoint.SPSite("http://YoServer:1002")
    # Iterate all the webs of the site
    foreach ($web in $site.AllWebs)
    # loop through all lists in web
    foreach ($list in $web.Lists)
    # Ensure list is of base Document Library
    if ($list.BaseType -ne "DocumentLibrary")
    # Move on
    continue
    # Loop through each item
    foreach ($item in $list.Items)
    # Get the file
    $file = $item.File
    # Delete all versions
    $file.Versions.DeleteAll()
    # Remove version from the list
    $list.EnableVersioning = $false
    $list.EnableModeration = $false
    # We still want to ensure check out
    $list.ForceCheckout = $true
    $list.Update()
    $web.Dispose();
    $site.Dispose();
    Please mark the Answer and Vote me if you think that it will help you to resolved your issue

  • My laptop crashed and it was an authorized computer for my iPhone.  How do I remove this from my list of computers?

    My laptop crashed and it was an authorized computer for my iPhone.  When I downloaded iTunes to my new laptop and authorized it, I see that my old laptop is included in the count of authorized computers.  How do I remove this from my list of computers?

    You do not, nor do you need to until you reach the limit of 5. Then you can deauthorize all.

  • How to chcek if Java Script is enabled for the browser

    Hi all,
    I wanted to know if there was any way to check if Java Scripts is enabled in the browser on which the jsp screen is being displayed. This type of check should be in Java and im working on a struts framework.
    Thanks

    There are multiple ways of doing it. Depends on wether you need this information only at the Client (browser) or do you need it at the Server.
    In case of Client its trivial. You could do it in HTML:
    <div id="jsEnabled" style="visibility:hidden">
    JavaScript is enabled
    </div>
    <div id="jsDisabled">
    JavaScript is disabled
    </div>The first div contains the text "JavaScript is enabled" while the second one says "JavaScript is disabled". The first div is also made hidden. Now, we attach the checkJavaScriptValidity function to the onload event of the page.
    <body onload="checkJavaScriptValidity()">checkJavaScriptValidity hides the second div and make the first one active. If JavaScript is enabled you will see the first div which says "JavaScript is enabled". If JavaScript is disabled you will see the second div which says "JavaScript is disabled".
    <script language="javascript" type="text/javascript">
    function checkJavaScriptValidity()
    document.getElementById("jsEnabled").style.visibility = 'visible';
    document.getElementById("jsDisabled").style.visibility = 'hidden';
    </script>But I guess since you want it to do it in Java, you'll need this information at the Server side as Browsers dont execute Java code. In that case you could just do an HTTP hit from a javascript function on load with information about the current session. But I still do not understand why would need this information at the server side as your purpose seems to be to ask the user to enable Javascript on his browser.

  • Report to list all computers and their collection membership

    Hi
    I am currently working on a site where direct membership is used for collections but a need has arisen to move to AD Queries.
    I have created a simple powershell script that creates groups based on the contents of a csv file and another script which populates this with the members listed in another csv file.
    To help speed up the process is there a way to generate a report that lists ALL Computers and their Collection membership?
    The only reports I seem to find that are built in require an inputted value of either computer name of collection ID. I simply need a report that lists Computer Name is column 1 and Collection Name in column 2 for all computers and all collections.
    Many Thanks,
    Matt Thorley

    select 
    FCM.Name,
    C.Name
    from 
    dbo.v_Collection C
    join dbo.v_FullCollectionMembership FCM on C.CollectionID = FCM.CollectionID
    Thanks to Garth for original query. I just modified it :)
    Anoop C Nair (My Blog www.AnoopCNair.com)
    - Twitter @anoopmannur -
    FaceBook Forum For SCCM

  • Traffic only allowed one-way for VPN connected computers

    Hello,
    I currently have an ASA 5505.  I have set it up as a remote access SSL VPN. My computers can connect to the VPN just fine.  They just can't access the internal LAN (192.168.250.0).  They can't ping the inside interface of the ASA, or any of the machines.  It seems like all traffic is blocked for them.  The strange thing is that when someone is connected to the VPN, I can ping that VPN-connect machine from the ASA and other machines inside the LAN.  It seems the traffic only allows one way.  I have messed with ACL's with no avail.  Any suggestions please?
    DHCP Pool: 192.168.250.20-50 --> For LAN
    VPN Pool: 192.168.250.100 and 192.168.250.101
    Outside interface grabs DHCP from modem
    Inside interface: 192.168.1.1
    Current Running Config:
    : Saved
    ASA Version 8.2(5)
    hostname HardmanASA
    enable password ###### encrypted
    passwd ####### encrypted
    names
    interface Ethernet0/0
    switchport access vlan 20
    interface Ethernet0/1
    switchport access vlan 10
    interface Ethernet0/2
    switchport access vlan 10
    interface Ethernet0/3
    shutdown
    interface Ethernet0/4
    shutdown
    interface Ethernet0/5
    shutdown    
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    switchport access vlan 10
    interface Vlan1
    no nameif
    no security-level
    no ip address
    interface Vlan10
    nameif inside
    security-level 100
    ip address 192.168.250.1 255.255.255.0
    interface Vlan20
    nameif outside
    security-level 0
    ip address dhcp setroute
    ftp mode passive
    dns domain-lookup inside
    dns domain-lookup outside
    pager lines 24
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_Pool 192.168.250.100-192.168.250.101 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 10 interface
    nat (inside) 10 192.168.250.0 255.255.255.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.250.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet timeout 5
    ssh 192.168.250.0 255.255.255.0 inside
    ssh timeout 5
    ssh version 2
    console timeout 0
    dhcpd dns 8.8.8.8
    dhcpd address 192.168.250.20-192.168.250.50 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 2
    svc image disk0:/anyconnect-linux-2.5.2014-k9.pkg 3
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    tunnel-group AnyConnect type remote-access
    tunnel-group AnyConnect general-attributes
    address-pool VPN_Pool
    tunnel-group AnyConnect webvpn-attributes
    group-alias AnyConnect enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:30fadff4b400e42e73e17167828e046f
    : end

    Hello,
    I seem to be having the same kind of issue although I cannot ping from either end.
    Ive set up a l2tp/ipsec vpn which I am able to connect to and get ip from my ip pool (radius authentication is working).
    I tried running:
    access-list NAT_0 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
    nat (inside) 0 access-list NAT_0
    but i get an error msg saying that the syntax of the nat command is deprecated. Im running ASA version 8.4.
    Ive fiddled around abit to find the correct syntax but have been unsuccessfull so far.
    Any help would be much appreciated
    This is a part of my config:
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network AD1
    host 192.168.1.31
    description AD/RADIUS
    object network NETWORK_OBJ_192.168.1.0_24
    subnet 192.168.1.0 255.255.255.0
    object network vpn_hosts
    subnet 192.168.2.0 255.255.255.0
    access-list AD_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
    access-list split-acl standard permit 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0
    access-list inside_0_outbound extended permit ip object NETWORK_OBJ_192.168.1.0_24 object vpn_hosts
    ip local pool POOL2 192.168.2.2-192.168.2.10 mask 255.255.255.0
    nat (inside,outside) source static any any destination static NETWORK_OBJ_192.168.1.0_25 NETWORK_OBJ_192.168.1.0_25 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_192.168.1.0_25 NETWORK_OBJ_192.168.1.0_25 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static vpn_hosts vpn_hosts
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 ########## 1
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp

  • Enabling calendaring for a user or group not working

    Am having an issue getting ical server/sharing and webcalandars working. Think it is all related.
    First a description of my server environs. One xserve acting as OD master, fileserver, vpn, DNS and DHCP server as well. Second xserve acting as DNS, mail, web and ical server. Second server is OD replica.
    DNS is working. All OD functions including kerberos are working. Mail and webmail are working as well.
    The hostname in iCal Server Admin settings is the FQDN of my second xserve. icalxserve.domain.com. I can start iCal. Then I get this error in the logs:
    twistedcaldav.directory.appleopendirectory.OpenDirectoryInitError: Open Directory has no /Computers records with a virtual hostname: icalxserve.domain.com
    Remember this server is a OD replica. It is listed in the Computers pane under Workgroup Manager and its name is server.domain.com$. All the computers have $ at the end so I assume this is normal. All services are set for access from all users in Server Admin -> server -> Access. In Server Admin Web -> Sites -> (default site highlighted) Web Services webmail, wiki and blog and web calendaring are all checked as well. I have also tried to enable wiki and blog and web calendar for groups in Workgroup Manager. The only choices in the pop up are none and wiki host for domain.com. Strange.
    I cannot enable calendaring for any user. I check the Enable calendaring box under Advanced in the Accounts pane in Workgroup Manager and no server is listed in the pop up menu. It only reads No calendar host selected without any other choices. It should show me icalxserve.domain.com.
    When I goto http://icalxserve.domain.com site I get the default homepage and webmail works. If I click on the Groups button I see the 2 groups I have enabled services for. But when I click on the groupname I get the following error page:
    Not Found
    404: No group with that name (thomas) hosted on this server
    Not sure what to do next. OD doesn't seem to be working like I would expect. Any advice would be greatly appreciated.
    Thanks in advance.
    Please note I am posting this late on Sunday night and have jury duty tomorrow. I will obviously try to check back as soon as I can but maybe not until Monday night. Thanks again.

    Hi
    +"I don't see this option. Am I doing doing something wrong?"+
    Your Rider seems to indicate 10.6? If you're not seeing this option in WorkGroup Manager I'm guessing you're using 10.6 Server? In which case you've posted in the wrong forum with a question that's not applicable anymore. Apple removed those options in 10.6. Another possibility is you're trying to manage a 10.5 Server using 10.6 Server Admin Tools and it's giving unpredictable results? The Server Administration Applications cab behave oddly if you're trying use a newer version on an older server. You should use the version of the Tools that came with the Server.
    The 10.6 iCal Server Admin Manual is here:
    http://manuals.info.apple.com/enUS/iCalServerv10.6.pdf
    Tony

  • VBScript to search PST files on a list of computers

    Hello guys,
    Not-even-close-to-expert to scripting, i've been in charge to develop a script, only in VBS or batch file, that can do the following:
    - Search a list of pre-determined computers and specific path (example: \\computer\c:\<random folder>\<random folder> for only *.pst files, if not, returns an information saying that it
    doesnt have any file present.
    - Export that list to excel by date created, date last modified, size, attributes and path
    I've search and compiled a vbs that does something like what i want, but it extracts all the files except the specific file i want and it lacks the string/syntax to point for the list of computers and their specific path.
    Here's the VBS i've managed to compile:
    ==========================================================
    Dim strFolder, objFSO, objFolder
    Dim strExcelPath, objExcel, objSheet, intRow
    Const xlExcel7 = 39
    ' Specify main folder.
    strFolder = "C:\Program Files"
    ' Retrieve folder object.
    Set objFSO = CreateObject("Scripting.FileSystemObject")
    Set objFolder = objFSO.GetFolder(strFolder)
    ' Specify spreadsheet to be created.
    strExcelPath = "C:\get_pst_info.xls"
    ' Create workbook.
    Set objExcel = CreateObject("Excel.Application")
    objExcel.Workbooks.Add
    ' Bind to worksheet.
    Set objSheet = objExcel.ActiveWorkbook.Worksheets(1)
    objExcel.Cells(1, 1).Value = "Nome"
    objExcel.Cells(1, 2).Value = "Ficheiro"
    objExcel.Cells(1, 3).Value = "Data Criação"
    objExcel.Cells(1, 4).Value = "Data Última Modificação"
    objExcel.Cells(1, 5).Value = "Atributos"
    objExcel.Cells(1, 6).Value = "Tamanho (bytes)"
    objExcel.Cells(1, 7).Value = "Caminho"
    objExcel.Range("A1:B1:C1:D1:E1:F1:G1").Select
    objExcel.Range("A1:G1").Columns.AutoFit
    objExcel.Range("A2:G2").Rows.Autofit
    objExcel.Selection.Interior.ColorIndex = 19
    objExcel.Selection.Font.ColorIndex = 11
    objExcel.Selection.Font.Bold = True
    ' Enumerate files.
    intRow = 0
    Call GetFiles(objFolder)
    ' Save spreadsheet, close workbook, and quit Excel.
    objExcel.ActiveWorkbook.SaveAs strExcelPath, xlExcel7
    objExcel.ActiveWorkbook.Close
    objExcel.Application.Quit
    ' Alert user.
    Wscript.Echo "Done"
    Sub GetFiles(ByVal objParent)
      ' Enumerate files in folder.
      ' Variable intRow must have global scope.
      Dim objFile, objChild
      For Each objFile In objParent.Files
        intRow = intRow + 2
        objSheet.Cells(intRow, 1).value = objFile.Name
        objSheet.Cells(intRow, 2).value = objFile.Type
        objSheet.Cells(intRow, 3).value = objFile.DateCreated
        objSheet.Cells(intRow, 4).Value = objFile.DateLastModified
        objSheet.Cells(intRow, 5).value = objFile.Attributes
        objSheet.Cells(intRow, 6).value = objFile.Size
        objSheet.Cells(intRow, 7).Value = objFile.Path 
      Next
      ' Recurse through nested folders.
      For Each objChild In objParent.SubFolders
        Call GetFiles(objChild)
      Next
    End Sub
    ==========================================================
    Can anyone help me to adapt for the changes i want to implement ?
    Thanks in advance,
    Marex

    I think your expectations of free help in a user-to-user support forum may be a little unrealistic.
    This isn't a script on demand forum where people post a list of requirements and have other people write scripts for you (or completely rewrite/fix broken scripts).
    Bill
    Well, although you might be write, in no way i "demand" anything.
    As i've seen on other posts, i presented my doubts/difficulties, i showed what i did by myself and the results it had and i'm asking if anyone can help me with my problems, that's all.
    I think my post doesnt differ, in anything, from other posts of "free help" i've seen.
    Marex
    What you did for yourself is to copy a script from the Internet that seems to have nothing to do with what you are asking.
    Use the learning tools and try and write the scrip you are asking for.   Look in the Gallery for scripts that do nearly what you need.  A little testing and effort will get you closer.
    Start here:
    http://technet.microsoft.com/en-us/scriptcenter/dd772284
    All of the pieces you are asking for are demonstrated in the tutorials.
    When you get stuck on a specific item then post pack with a single question.  You are asking a smorgasbord of questions that amount to asking for a complete design and build.
    Your post is not a question but is a list of requirements that you want to see fulfilled.  Try asking a single question.
    ¯\_(ツ)_/¯

  • Enable group mailing list in Server.app not working

    Hello everyone,
    I have been trying to enable a new (?) feature of Server.app : "Enable group mailing list". Until now, it does not work for me. When I try to send an email to the group [email protected], Mail tells me that the smtp server cannot send my message. Here is what I see on the server's /var/log/mail.log file :
    Sep 10 16:55:54 testserver01.pretendco.net postfix/smtpd[2311]: NOQUEUE: reject: RCPT from testclient01.pretendco.net[10.1.101.10]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<testclient01.pretendco.net>
    Sep 10 16:55:54 testserver01.pretendco.net postfix/smtpd[2311]: disconnect from testclient01.pretendco.net[10.1.101.10]
    It is interesting to note that group mailing list aren't even mentioned in the Mac OS X Server Advanced Administration Guide :
    http://help.apple.com/advancedserveradmin/mac/10.8/#apd9430d30c-5796-4a20-a8f9-1 20638938942
    Does any has any good/bad experience with group mailing lists under Mountain Lion Server ? Any advice ?
    Thanks a lot !

    Hello Mark23 and thanks for your help !
    The log says nothing particular when I (un)set the "Enable Group Mailing List Option". The only difference I see is a line saying mail_groups[127]: sleeping for: 1 hour(s). I have no idea what this means exactly. Googling it did not help me much either.
    I post the /etc/aliases file below. Interesting : every time I (un)set the "Enable Group Mailing List" option, the /etc/aliases last access time changes. But the md5 hash of the file stays the same.
    I guess that the "sudo newaliases" uses /etc/aliases to construct the binary database file /etc/aliases.db ? It seems that this script is run every time I (un)check the option since the access time of *both* /etc/aliases and /etc/aliases.db are changed to the current time.
    Do you have any other option checked ?
    Here is my /etc/aliases (I removed the blocks of comments at the beginning and at the end):
    # Person who should get root's mail. Don't receive mail as root!
    #root:                    you
    # Basic system aliases -- these MUST be present
    MAILER-DAEMON:          postmaster
    postmaster:          root
    # General redirections for pseudo accounts
    bin:                    root
    daemon:                    root
    named:                    root
    nobody:                    root
    uucp:                    root
    www:                    root
    ftp-bugs:          root
    postfix:          root
    # Put your local aliases here.
    # ==== Begin auto-generated section ========================================
    # This section of the aliases file is auto-generated by server admin tools
    # Please do not edit this section or your modifications will be lost
    # === End auto-generated section ===========================================
    # Well-known aliases
    manager:          root
    dumper:                    root
    operator:          root
    abuse:                    postmaster
    # trap decode to catch security attacks
    decode:                    root

  • Last logon time from list of computers?

    Hello,
    I'm looking for some type of script that will query a list (c:\script\computers.txt) of computers and return the last logon date and user.
    I do not want to do this from active directory, but instead want to get the data directly from the machines. So to sum it up I need to input a list of host names (all on the network) and output a list of last logon time stamps.
    Any help is appreciated!
    Thank you,
    Brian

    Hi
    Well AD will be your best option but you can try this in a bat file:
    net user User| findstr /B /C:"Last logon"
    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

Maybe you are looking for

  • How to insert a new field in the Report Designer

    Hi all. I have a query and a report, but the query evolve. We have a new key figure (inside rows). In the report designer, I check the data provider. The new key figure is added in the catalog field. Now, I would like to insert the new field in the r

  • Trasaction code for invoices detail which has hit the WBS element

    Hi All Usually my users receive a list of assets which were capitalized from AUC account through Project system. Generally charges are posted to WBS element and then users capitalize assets using that WBS element through settlement. Users have been a

  • Will the order of elements stored in pl.sql table retains

    Hello Friends, I am having a record type and the for each element of record , i am having corresponding pl.sql table type . If i am storing the values into the records from a query and also the individual elements in the pl.sql table type will the or

  • How to protect JDBC data srouce

    How to configure the WebLogic server to enable users to access data sources through beans only? I don't want the users to look up the data source objects directly in the JNDI tree and use them? My problem is this: if I disable the users to look up th

  • Looking for large PSA tables

    Hi All, I'm trying to get a list of PSA tables in the system based on their size. Can anyone advise me on how to go about that? Thanks. Regards, TK