Simple VRF+BGP lab not working

I have set up a simple lab:
router A - 7200 IOS 12.2(27) JS
router B - 2611
There is a serial link between A and B.
On A the serial interface is in VRF.
The B router has no VRF - just ordinary IP.
I am trying to set up eBGP between them.
But the session does not start.
The A config:
ip vrf v2
rd 7:2
route-target export 7:2
route-target import 7:2
ip cef
interface Serial2/0
ip vrf forwarding v2
ip address 192.168.25.5 255.255.255.0
router bgp 65005
no synchronization
bgp log-neighbor-changes
no auto-summary
address-family ipv4 vrf v2
neighbor 192.168.25.2 remote-as 2
neighbor 192.168.25.2 activate
no auto-summary
no synchronization
network 192.168.6.0
exit-address-family
I have done some tests:
Ping from B to A works.
Ping vrf from A to B works as well.
telnet from B to A on port 179 gets RST.
telnet /vrf from A to B on port 179 works.
Debug on B shows session establishment attempts, but
with TCP RST response.
Debug on A shows the neighbor is Idle - no attempts.
On A:
sh ip bgp nei
BGP neighbor is 192.168.25.2, vrf v2, remote AS 2, external link
BGP version 4, remote router ID 0.0.0.0
BGP state = Idle
Last read 02:03:54, hold time is 180, keepalive interval is 60 seconds
Connections established 0; dropped 0
Last reset never
No active TCP connection
I know, that I am new to the VRF stuff, but it is very basic case. What am I doing wrong?
Michal

I have solved the problem.
The keyword is "bgp router-id".
I had no "normal" interfaces, all were VRF ones.
IOS apparently uses by default only IP address
from "normal" interface as a bgp router ID, so:
#sh ip bgp vpnv4 vrf v2
BGP table version is 1, local router ID is 0.0.0.0
As I have forced the ID (bgp router-id ...) all the sessions got up.
Interesting case.

Similar Messages

  • Very simple Char* conversion operator not working

    This should be simple, but it's not working.  The code below gives me a compiler error:
    Error 2 error C2440: 'initializing' : cannot convert from 'Foo' to 'char *' 
    class Foo
     char * _data;
    public:
     operator const char * () { return _data; }
     Foo f;
     char * bar = f;
    char*_data;
    public
    operatorconstchar*(){return_data;}
    Eric Jorgensen http://www.ericjorgensen.com

    On 3/5/2015 12:26 AM, "Eric Jorgensen" wrote:
    This should be simple, but it's not working.  The code below gives me a compiler error:
    Error 2 error C2440: 'initializing' : cannot convert from 'Foo' to 'char *'
    Foo can be converted to const char*, but not to char*
    Igor Tandetnik

  • Simple calculations in Universe not working for XI 3.0

    Simple calculations in Universe using key figures are not working in XI 3.0(without any Fix Pack)
    Below is the steps I followed.
    1. Using key figure [Jan] I am trying to round the values by deviding it by 1000.
    <EXPRESSION>@Select([Jan])/1000</EXPRESSION>
    This gives me a null cell value.
    2. I tried addition then
    <EXPRESSION>@Select([Jan])+1000</EXPRESSION> result was all the cell values changed to 1000.
    3. Finally without calculation I tried
    <EXPRESSION>@Select[Jan]</EXPRESSION> this also resulted null value
    But without EXPRESSION tag if I try @Select[Jan] it works fine.
    Am I missing anything in above expressions.
    As of now I am creating variable in report to incorporate the rounding.
    Thanks
    Raghu

    It was my mistake while writing the question. Path I have used is correct one only @Select(Key Figures/.
    If i use the above alone, I am able to se the data. But if I use in betwen <EXPRESSION> then it gives null value.
    Note: Pls dont confuse with flower bracket i used it just to avoid coverting it to a html link and also the backslash it was not showing in preview
    I have followed that pdf and created calculation in universe.
    Edited by: Raghavendra Barekere on Feb 6, 2009 6:42 AM

  • Why this simple IF - ENDIF is NOT working??

    Hi Experts,
    Am wrting a simple  IF condition with WILD CARD value , in the user exit, as below,
    if xlikp-lgbzo = 'AB'. (pls. notice that, there is WILD CARD in the 'AB' value)
    sy-subrc = 0.
    else.
    sy-subrc = 4.
    endif.
    1) Say, the XLIKP-LGBZO value = AB-01-02 (pls. notice that, there  ' - ' in the value of AB-01-02)
    then, sy-subrc is becoming 4 ?????????????
    2 )Say, the XLIKP-LGBZO value = ZB-01-02
    then, sy-subrc is becoming 4
    the 2nd case is OK, but, Why the 1st case is becoming FALSE?? actuallym it shuld b TRUE, right??
    Is it bcoz of hiphans -  " - "?? but, i tried with WITH OUT hiphans , then also NOT working CORRECTLY??
    thanq

    Hi Srini,
    Try the following:
    IF XLIKP-LGBZO  CP 'AB*'.
    sy-subrc = 0.
    ELSE.
    sy-subrc = 4.
    ENDIF.
    CP - Contains Pattern
    Hope this helps you.
    Regards,
    Chandra Sekhar

  • Simple 960px html does not work???

    I've b een coding pages a while but this has me perplexed.
    I have a page with simple code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Untitled Document</title>
    <style type="text/css">
    #960Wrapper {
    width: 960px;
    background-color: #0F0;
    margin-right: auto;
    margin-left: auto;
    #header {
    background-color: #C9F;
    #footer {
    background-color: #C0F;
    </style>
    </head>
    <body>
    <div id="960Wrapper">Content for  id pageWrapper Goes Here
            <div id="header">This area is reserved for logo</div>
        <div id="contentArea">
       <p>Please click a button:</p>
      </div>
         <div id="footer">This area is reserved for footer</div>
      </div>
    </div>
    </body>
    </html>
    However everything is going to full width and edge of the browser - all of them.
    Maybe my grey cells are tired - or something is corrupt but the machine does not accept it - in or out of dreamweaver.
    I've rebooted - run ccleaner and rebooted again but something is not working for me.
    I'd appreciate if someone could confirm I'm not going mad please.
    Terry

    GROAN!
    Forgot about that one - it's as simple as that???!
    I had a whole page written and then it stopped working - I've even stripped it back to basics and it was as simple as that???
    Thank you very much for pointing this out.
    Terry

  • Simple ws-policy demo not working

    Hi Gurus,
    It's been quite awhile, I could not work it out though. I guess your help would be the last change to stop it from driving me crazy~
    The goal is to implement a simple ws-seurity enabled webservice demo using only username/password token as the policy. username/password in the ones listed in "myrealm" (might have SQL Authentication provider as well),and X509 is not the thing to be considered in this simple test.
    Env:
    WebLogic Server Version: 10.3.0.0
    JVM: Sun one installed with weblogic
    WebLogic Eclipse plugin: 1.0.0.2008.0808135653
    Windows XP sp3
    After reading that much docs, it came to below procedure and code:
    1. Eclipse -> new Dynamic web project "WSTest3"
    2. create file: example.ws.HelloW1.java
    package example.ws;
    import javax.jws.WebService;
    import weblogic.jws.Policy;
    import weblogic.jws.Policies;
    @WebService(serviceName="HelloW1")
    @Policies( { @Policy(uri = "policy:usernametoken.xml") } )
    public class HelloW1 {
         public String sayHi(String hi){
              System.out.println("Already here: " + hi);
              return "Welcome, you said: " + hi;
    3. add "weblogic.jar" to build path
    4. create WEB-INF/policies/usernametoken.xml
    <?xml version="1.0"?>
    <wsp:Policy
    xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy"
    xmlns:sp="http://docs.oasis-open.org/ws-sx/ws-securitypolicy/200512"
    >
    <sp:SupportingTokens>
    <wsp:Policy>
    <sp:UsernameToken
    sp:IncludeToken="http://docs.oasis-open.org/ws-sx/ws-securitypolicy/200512/IncludeToken/AlwaysToRecipient">
    <wsp:Policy>
    <sp:WssUsernameToken10/>
    </wsp:Policy>
    </sp:UsernameToken>
    </wsp:Policy>
    </sp:SupportingTokens>
    </wsp:Policy>
    5. Publish the project WSTest3 to weblogic server
    6. Test the webservice within weblobic admin console, get below response which is expected since there is no input for user/pass in the simple test web page:
    ~~~~~~~~~~~~~~~~~~~
    <faultcode>wsse:InvalidSecurity</faultcode>
    <faultstring>Error on verifying message against security policy Error code:1000</faultstring>
    ~~~~~~~~~~~~~~~~~~~
    7. create the WSTest3Client project
    8. new "web service client"
    9. input the WSDL "http://127.0.0.1:7001/WSTest3/HelloW1?WSDL" and have the webservice related stub files created.
    10. create java file: example.ws.client.Main.java
    package example.ws.client;
    import java.rmi.RemoteException;
    import java.util.ArrayList;
    import java.util.List;
    import java.util.Map;
    import java.security.cert.X509Certificate;
    import javax.xml.rpc.ServiceException;
    import org.apache.axis.client.Stub;
    import example.ws.HelloW1_PortType;
    import example.ws.HelloW1_Service;
    import example.ws.HelloW1_ServiceLocator;
    import weblogic.jws.jaxws.ClientPolicyFeature;
    import weblogic.jws.jaxws.policy.InputStreamPolicySource;
    import weblogic.security.SSL.TrustManager;
    import weblogic.wsee.security.unt.ClientUNTCredentialProvider;
    import weblogic.xml.crypto.wss.WSSecurityContext;
    import weblogic.xml.crypto.wss.provider.CredentialProvider;
    public class Main {
         public static void main(String[] args)
         throws ServiceException, RemoteException{
              String username = "weblogic";
              String password = "weblogic";
              CredentialProvider cp = new ClientUNTCredentialProvider(username.getBytes(), password.getBytes());
              List credProviders = new ArrayList();
              credProviders.add(cp);
              HelloW1_Service service = new HelloW1_ServiceLocator();
              HelloW1_PortType port = service.getHelloW1Port();
         Stub stub = (Stub)port;
         stub._setProperty(WSSecurityContext.CREDENTIAL_PROVIDER_LIST, credProviders);
    //Map rc = ((BindingProvider)port).getRequestContext();
    //rc.put(WSSecurityContext.CREDENTIAL_PROVIDER_LIST, credProviders);
         System.out.println(port.sayHi("nihao"));
    11. add weblogic.jar to build path and let it go.
    The expected output string was not coming, but still the exception there:
    ~~~~~~~~~~~~~~~
    Exception in thread "main" AxisFault
    faultCode: {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}InvalidSecurity
    faultSubcode:
    faultString: Error on verifying message against security policy Error code:1000
    faultActor:
    faultNode:
    faultDetail:
         {http://xml.apache.org/axis/}stackTrace:Error on verifying message against security policy Error code:1000
         at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:222)
         at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:129)
    {WITH MANY OTHER LINES BELOW}
    ~~~~~~~~~~~~~~~~~~
    use below code suggested from reference link (2)
    Map rc = ((BindingProvider)port).getRequestContext();
    rc.put(WSSecurityContext.CREDENTIAL_PROVIDER_LIST, credProviders);
    to replace stub._setProperty, but I was told can not make the CAST from stub to BindingProvide, seems it's something in Jdeveloper11, not for my env.
    if I comment "@Policies( { @Policy(uri = "policy:usernametoken.xml") } ) " off and republish the webservcie, the test would be running good, but defniately there is no anthentication, which is not what I want.
    reference link (1): http://e-docs.bea.com/wls/docs103/webserv_sec/message.html
    reference link (2): http://kingsfleet.blogspot.com/2008/12/simple-custom-policy-example-using-jax.html
    I am grateful to have your input, thanks in advance and wish you a good day!
    Regards,

    Hi, it comes to episode2.
    Now the WS client's very smoothly working in my Jdev10.1.3, the code is very alike, but it uses
    stub._setProperty(Stub.USERNAME_PROPERTY, "weblogic");
    stub._setProperty(Stub.PASSWORD_PROPERTY, "weblogic");
    // This source file is generated by Oracle tools and is subject to change
    // It is a utility client for invoking the operations of the Web service port.
    // For reporting problems, use the following
    // Version = Oracle WebServices (10.1.3.1.1, build 070111.22769)
    package proj2.proxy;
    import oracle.webservices.transport.ClientTransport;
    import oracle.webservices.OracleStub;
    import javax.xml.rpc.ServiceFactory;
    import javax.xml.rpc.Stub;
    public class HelloW1PortClient {
    private proj2.proxy.HelloW1_PortType _port;
    public HelloW1PortClient() throws Exception {
    ServiceFactory factory = ServiceFactory.newInstance();
    port = ((proj2.proxy.HelloW1Service)factory.loadService(proj2.proxy.HelloW1_Service.class)).getHelloW1Port();
    * @param args
    public static void main(String[] args) {
    try {
    proj2.proxy.HelloW1PortClient myPort = new proj2.proxy.HelloW1PortClient();
    System.out.println("calling " + myPort.getEndpoint());
    // Add your own code here
    myPort.setUsername("weblogic");
    myPort.setPassword("weblogic");
    System.out.println( myPort.sayHi("Hello") );
    } catch (Exception ex) {
    ex.printStackTrace();
    * delegate all operations to the underlying implementation class.
    public String sayHi(String arg0) throws java.rmi.RemoteException {
    return _port.sayHi(arg0);
    * used to access the JAX-RPC level APIs
    * returns the interface of the port instance
    public proj2.proxy.HelloW1_PortType getPort() {
    return _port;
    public String getEndpoint() {
    return (String) ((Stub) port).getProperty(Stub.ENDPOINT_ADDRESS_PROPERTY);
    public void setEndpoint(String endpoint) {
    ((Stub) port).setProperty(Stub.ENDPOINT_ADDRESS_PROPERTY, endpoint);
    public String getPassword() {
    return (String) ((Stub) port).getProperty(Stub.PASSWORD_PROPERTY);
    public void setPassword(String password) {
    ((Stub) port).setProperty(Stub.PASSWORD_PROPERTY, password);
    public String getUsername() {
    return (String) ((Stub) port).getProperty(Stub.USERNAME_PROPERTY);
    public void setUsername(String username) {
    ((Stub) port).setProperty(Stub.USERNAME_PROPERTY, username);
    public void setMaintainSession(boolean maintainSession) {
    ((Stub) port).setProperty(Stub.SESSION_MAINTAIN_PROPERTY, Boolean.valueOf(maintainSession));
    public boolean getMaintainSession() {
    return ((Boolean) ((Stub) port).getProperty(Stub.SESSION_MAINTAIN_PROPERTY)).booleanValue();
    * returns the transport context
    public ClientTransport getClientTransport() {
    return ((OracleStub) _port).getClientTransport();
    the weird thing is when I moved "
    stub._setProperty(Stub.USERNAME_PROPERTY, "weblogic");
    stub._setProperty(Stub.PASSWORD_PROPERTY, "weblogic");
    into Eclipse, it still complains the same error: "Error on verifying message against security policy Error code:1000", meanwhile the server outputs:
    <WSEE:18>Trying to validate identity assertion token http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#UsernameToken<SecurityMessageInspector.inspectIdentity:629>
    Thanks,

  • Simple copy of reports not working - help please

    Hello
    I have this function that was written to copy a given report object to a given folder. The code is not working - the copyObj = col.Copy(obj,2) appears to be failing.
    Can anyone shed some light on this? Thank you in advance!
    - Russell
    My function:
    function CopyReport (objID, DestFolder, iStore)
    dim col
    dim obj
    dim copyObj
    on error resume next
    'QUERY FOR OBJECT TO COPY
    str = "SELECT * FROM CI_INFOOBJECTS WHERE SI_ID = " + objID
    set col = iStore.Query ( str )
    obj = col.Item(1)
    'COPY THE OBJECT
    copyObj = col.Copy(obj,2)
    'SET THE PARENTID OF THE COPIED OBJECT
    copyObj.Properties.Item("SI_PARENTID").Value = DestFolder
    'SET THE PARENT FOLDER OF THE COPIED OBJECT
    copyObj.Properties.Item("SI_PARENT_FOLDER").Value = DestFolder
    'COMMIT THE COLLECTION
    iStore.Commit(col)
    end function

    Hi All
    I've resolved the problem with the copy and am posting the code below. I'd appreciate it if it could be placed in the appropriate forum so that it may be a resource for other developers in the future. I've left in all of my debugging/error checking code for reference as well.
    - Russell
    The working copy function (with loads of debugging code) is this:
    function CopyReport (objID, DestFolder, iStore)
    'Function CopyReport
    'Parameters:
    '  objID - the ID of the report to copy
    '  DestFolder - the ID of the destination folder for the copy
    '  iStore - the InfoStore to use
    'Returns: A text string that is displayed in a web page via response.write that includes the
    '  name of the report if copied or the error information as appropriate.
    dim col
    dim obj
    dim copyObj
    dim newCol
    on error resume next
    'QUERY FOR OBJECT TO COPY
    str = "SELECT * FROM CI_INFOOBJECTS WHERE SI_ID = " + objID
    set col = iStore.Query ( str )
    If Err.Number <> 0 Then
      CopyReport = "iStore.Query failed<br>"
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
      CopyReport = CopyReport & "<br>" & str
      Exit Function
    End If
    set newCol = iStore.NewInfoObjectCollection()
    If Err.Number <> 0 Then
      CopyReport = "newCol creation error"
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
      CopyReport = CopyReport & "<br>" & str
      Exit Function
    End If
    set obj = col.Item(1)
    If Err.Number <> 0 Then
      CopyReport = "OBJ = col.item(1) error<br>"
      CopyReport = CopyReport & "<br>" & str
      CopyReport = CopyReport & "<br>Error: " & Err.Number & " - " & Err.Description
      Exit Function
    End If
    'COPY THE OBJECT
    set copyObj = newCol.Copy(Obj, 2)
    If Err.Number <> 0 Then
      CopyReport = "copyOBJ error"
      CopyReport = CopyReport & "<br>Count: " & col.Count
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
    '  Exit Function
    End If
    'SET THE PARENTID OF THE COPIED OBJECT
    copyObj.Properties.Item("SI_PARENTID").Value = DestFolder
    If Err.Number <> 0 Then
      CopyReport = "Error setting SI_PARENTID to " & DestFolder
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
      Exit Function
    End If
    'SET THE PARENT FOLDER OF THE COPIED OBJECT
    copyObj.Properties.Item("SI_PARENT_FOLDER").Value = DestFolder
    If Err.Number <> 0 Then
      CopyReport = "Error setting SI_PARENT_FOLDER to " & DestFolder
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
      Exit Function
    End If
    'COMMIT THE COLLECTION
    iStore.Commit(newCol)
    If Err.Number <> 0 Then
      CopyReport = "Commit error"
      CopyReport = CopyReport + "<br>Error: " & Err.Number & " - " & Err.Description
      Exit Function
    End If
    'Return the object info
    CopyReport = copyObj.Title
    end function
    Edited by: Russell L Magidson on Dec 11, 2008 5:12 PM
    Edited by: Russell L Magidson on Dec 11, 2008 10:28 PM
    Edited by: Russell L Magidson on Dec 11, 2008 10:29 PM

  • Why this simple 'IF' syntax is not working?

    Hello
    Pls. help me that,
    var myObject = /TextField11/
    var greyFieldsList = "TextFieldAA TextFieldBB TextFieldCC "
    var ReqFieldsList = "TextField11 TextField22 TextField33 "
    var returnValue = greyFieldsList.search(myObject);
    var returnValueReq = ReqFieldsList.search(myObject);
    if (returnValue != -1) {
    this.fillColor = "192,192,192"; //GREY
    this.access    = "readOnly";
    else if (returnValueReq != -1)
    this.fillColor = "255,255,191";  //YELLOW
    else
    // do nothing
    Yellow is not working at all!!
    Grey is working some times, some times not!
    Pls. correct my IF condition in such a way it shoud work.
    At given point of time, any field possess only one color
    Thank you

    Hi Srini,
    Try the following:
    IF XLIKP-LGBZO  CP 'AB*'.
    sy-subrc = 0.
    ELSE.
    sy-subrc = 4.
    ENDIF.
    CP - Contains Pattern
    Hope this helps you.
    Regards,
    Chandra Sekhar

  • Simple Update query Will not work

    I am new to sql and I am doing an update query in access and it will not work, here is the query.
    UPDATE Change Code Master Table SET change code = '0';
    Edited by: 805337 on Oct 26, 2010 8:05 AM

    805337 wrote:
    I am new to sql and I am doing an update query in access and it will not work, here is the query.
    UPDATE Change Code Master Table SET change code = '0';
    Edited by: 805337 on Oct 26, 2010 8:05 AMI'm not at all sure why you are asking an MS Access question on an Oracle forum. Last I heard, Larry had not bought Microsoft yet.
    The MS Access equivalent to double quoting an identifier is square brackets like:
    UPDATE [Change Code Master Table] SET [change code] = '0';John

  • Technet Virtual Labs not Working

    Recently I have not been able to launch the Technet Virtual labs for Systems Center Operations Manager 2007.  I get the following message after the lab starts to build:
         We're sorry, but your request has failed.
         Please try again later or contact customer service to address the issue.    
    I used a few of the labs late last week and early this week, but now I get that error every time I try them.  I've cleared my IE cache, rebooted, and even logged in under another i.d. on my laptop.  The SCOM 2012 labs seem to work, but that's
    not what we're using.
    Is the problem on Microsoft's side?
    thx,
    LM

    Slyth:
    1) responding to an 'answered' thread with a new question is a bad idea, because new posts are often missed in 'answered' threads since the answer was already found.  If you have a new issue, feel very free to start a new thread.
    2) If you need help with Virtual Labs, 
    - start here: http://technet.microsoft.com/en-us/virtuallabs/default
    - click "View System Requirements for Virtual Labs" in the red box (*not* the 'support' link at the top, sorry this is confusing)
    - Find this text at the top:
    Read below for the full list of system requirements or use this link to check
    your system requirements. For support, email [email protected]
     Thanks,
    Mike
    MSDN and TechNet Subscriptions Support

  • Help:simple file upload example not working

    Request input on what's wrong with this -
    Using JDeveloper 10G.
    1) I created a simple jsp file upload file using the OJSP
    File Access Tag library options. With empty JSP file,I
    dropped in the httpUploadForm and the httpUpload tags.
    Now when I run this I get the following error stack on
    the web page.
    javax.servlet.jsp.JspTagException: Posted content type isnt multipart/form-data at oracle.jsp.webutil.fileaccess.tagext.HttpUploadTag.doStartTag(HttpUploadTag.java:130)at test4.jspService(test4.jsp:10)[test4.jsp]
    2)Now if I use a simple JSP without the tag library - the
    page fails to display. Found that commenting out the
    line "upbean.upload()" lets the page run and atleast
    show me the upload form. What's wrong with this
    standard example from the OC4J documentation -
    <%@ page import =
    "javax.servlet.http.*,
    java.io.*,
    java.util.*,
    oracle.jsp.webutil.fileaccess.*;" language="java" session="true" contentType="text/html;charset=windows-1252"
    %>
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    <title>Upload</title>
    </head>
    <body>
    <% String userdir = "mydir"; %>
    <form action="pUpload.jsp" ENCTYPE="multipart/form-data" method=POST>
    <br>
    File to upload: <INPUT TYPE="FILE" NAME="File" SIZE="50" MAXLENGTH="120" >
    <br>
    <INPUT TYPE="SUBMIT" NAME="Submit" VALUE="Send">
    </form>
    <jsp:useBean id="upbean" class="oracle.jsp.webutil.fileaccess.HttpUploadBean" >
    <jsp:setProperty name="upbean" property="destination" value="<%= userdir %>" />
    </jsp:useBean>
    <% upbean.setBaseDir(application, request);
    //upbean.upload(request);
    %>
    </body>
    </html>

    It's not clear from your post, but are you aware that the
    documentation is really showing multiple files?
    The doc examples are based on the ones you can try out by downloading the ojspdemos.ear file.
    They use discrete steps. For example, the fileUploadIndex.html contains the following
    This will call the form and set the action in the form to call the tag upload jsp file. The form will do the multi-part post and the tag upload file does display the text after the <upload:httpUpload> tag. I just re-ran the example to be sure.
    The same basic mechanism applies to the upload bean. That is it is called via:
    This is the only way that these can work because the upload code (beans & tags) both require a multi-part post. I hope this helps

  • Simple Button Hit Zone not working

    I am somewhat new to Flash CS4 andt am having a problem making simple buttons in Flash CS4 on a Macintosh: I have made a few buttons with a graphic and can go into them and successfully create the Up, Over and Down stages of the graphic. Then when I create a new box for the hit state (which is larger than the graphic and I have deleted the graphic itself from the hit state) it doesn't want to appear correctly when I test the movie. When I test the movie, the hit state is correct everywhere around the graphic (to the bounds of my hit state box), but is not active where the graphic is. When I go under the Control menu, down to Enable Simple Buttons, the hit zone looks great right in my Flash file, but when I preview it or publish it and look it on different browsers (PC and Mac), I don't get my pointer right over the actual graphic, but get it everywhere around the graphic to the boundaries of my hit box. Why can't I get the actual graphic to be a hot spot in this situation? I have tried leaving the graphic in the hit timeline, and tried putting both the larger box and the graphic in the hit timeline, and still can't get them to respond correctly with the pointer in the browser window. Thank you....

    Well, since the graphic itself doesn't activate my pointer in a web browser, I thought maybe I needed to add both the box and the graphic itself to the hit state. That's what has me puzzled - the box that I use for the hit zone is "active" everywhere but where the actual graphic is...

  • MPLS Vrf opsf interfaces not working

    P/PE router VRF ospf interfaces unable to receive or advertised routing to and from CE router.
    Config attahced.
    Routes from PE VRF nortel shld be forwarded to CE router
    So are routes from CE 50.50.50.0 network
    Any ideas?

    Hello,
    Looks to me as if you did not start the ospf process in the VRF. So adjust the config according to:
    interface Serial2/0
    description MPLS VRF 1:1 connection to Cisco 2611 PPP
    ip vrf forwarding nortel
    ip address 200.0.30.1 255.255.255.0
    encapsulation ppp
    clock rate 128000
    interface FastEthernet4/0
    description MPLS connection for vrf Nortel 1:1
    ip vrf forwarding nortel
    ip address 70.70.70.1 255.255.255.0
    duplex auto
    speed auto
    no router ospf 1
    router ospf 1 vrf nortel
    network 200.0.30.0 0.0.0.255 area 0
    network 70.70.70.1 0.0.0.0 area 0 !In case you want OSPF over this interface as well
    With the current config I would assume that you do not see an OSPF adjacency on the CE.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Simple Pass/ fingerprint scan not working

    I have recently begun to experience trouble with my Simplepass 2012/fingerprint scan and have contacted Hp Customer Services to no avail. I Just want to know if there is a fix to this or is this a really expensive lesson I had to learn?

    Many users seems to be experiencing the same: worked great under iOS 7.0X, now just not scanning. Some 'kinda' fixes: make sure your finger is cold or, plug in the phone to the charger or computer, or place your phone in the fridge for half an hour or so. All the others of rescanning / resetting your iPhone seem to offer no improvement.
    Not exactly what we have come to expect from Apple!
    Other users who have experienced the same issue are saying Apple will swop out your 5s for a new one (indicating this is a hardware issue that is exacerbated under the 7.1 changes to the scanning software). That sounds great in the US or Europe; however, it remains to be confirmed the same will apply in South Africa...

  • Hp simple pass identity protection not working with windows 8.

    HP pavilion dm4 1006tu
    Windows 8 consumer preview

    @Dewan
    Hi,
    Uninstall current driver and software for fingerprint reader and restart system.
    Resource:
    Uninstalling Software in Windows 7
    Uninstall or change a program in Windows 7
    Download and install Validity fingerprint reader driver from here.
    Download and install HP SimplePass Software by DigitalPersona for fingerprint reader from here.
    Restart system and check the results.
    ** Say thanks by clicking the "Thumb up" icon which is on the left. **
    ** Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue. **

Maybe you are looking for

  • Error when trying to activate new valuation area - AU158

    Hi, I´m getting an error when trying to activate a new valuation area by using AFBN transaction. I get a message that says "Closed fiscal years for areas 01 and 08 differ by more than 1 year" (AU158). Then the system recomends me to check the setting

  • How do i delete this workbook?

    This following workbook (W0178756.PERF Performance Contracts) has been created for a specific user. In the mean time the user has been end dated on oracle. How do i now delete this workbook? If i go to Manage Workbooks > Delete then this workbook doe

  • Migration Assistant fails to copy identity

    I am trying to copy a second Identify form an other MBP.  All has failed so far. FileVault is of on both I have done a archive and install on both machines 10.9.2 Software is up to date on both Tried over Ethernet Tried in Tmode I am at my end.  is t

  • Cannot get Flash to work on certain websites

    I am having problems getting the Flash Player to run on certain websites. Those websites are ESPN.com and MLB.com. I am running Vista and have Flash Player 9.0.45. Any solutions would be greatly appreciated.

  • Background User BWREMOTE got changed to Dialog user

    Hello, Recently we had a refresh in our system and after the refresh I found that a background user BWREMOTE got changed to dialog user and more strange the change documents is showing that the BWREMOTE has itself changed the user type. anybody can c