SQLPLUS multiple data entry. Very easy question for experts.

Hi sorry to bother you again but is it the same method as in MySQL to enter multiple data at once?
I am trying to save time by entering all the contents of a table all at once,
For example;
INSERT INTO Borrower (BorId, BorName, BorMaxBooks) VALUES (
(001, 'Bob', 4),
(002, 'James', 5),
(003, 'Dave', 6);
Please can you tell me where I cam going wrong and I promise I will shut up and go away.
Thanks.

i can! :)
SQL> create table T
  2  (BorId varchar2(64),
  3  BorName varchar2(64),
  4  BorMaxBooks number)
  5  /
Table created
SQL> insert into t
  2  select '001', 'Bob', 4 from dual
  3  union all
  4  select '002', 'James', 5 from dual
  5  union all
  6  select '003', 'Dave', 6 from dual
  7  /
3 rows inserted
SQL> select * from t
  2  /
BORID                                                            BORNAME                                                          BORMAXBOOKS
001                                                              Bob                                                                        4
002                                                              James                                                                      5
003                                                              Dave                                                                       6
SQL>

Similar Messages

  • Another very very difficult question for EXPERTS

    Hello again to all my friends at Macromedia. A big hello to
    Mr
    DownWithTheBugs, Mr Chris In Madison, Mr Car Crash (he he)
    and especially
    Mrs Nancy *Adobe Community Expert. You are all my special
    friends. I have
    good good sleep and wake up today and solve my mystery
    straight away. The
    answer was:
    select * from thebigtable
    where ID LIKE '39%'
    Although I am glad of all your futile attempts to help me and
    I very pleased
    at the time you spendwith me, my expertise showed me the path
    in the end.
    You all need to do some homework to reach this standard.
    Perhaps you are not
    used to databases of this size and were all a little
    perplexed. I
    understand!! This sintax is quite complicated to the
    untrained eye but
    thankyou all anyway.
    My new question is this:
    How do I put my beautiful new webpage on the Internet?? I
    would like it to
    appear inside the Microsoft website as it will benefit all
    Microsoft users.
    How do I put it there?? Very tough!!
    Thankyou.
    My moto - If your best is not good enough then try even
    better, or go and
    drink lots and lots of alcohol. If that does not work then do
    both together
    XX.

    >I have good good sleep and wake up today and solve my
    mystery straight
    >away.
    I always knew that an expert like you would solve the problem
    without much
    hassle.Well done!
    > How do I put my beautiful new webpage on the Internet??
    I would like it to
    > appear inside the Microsoft website as it will benefit
    all Microsoft
    > users. How do I put it there?? Very tough!!
    Not much, print it using you printer (it's should be not far
    from your
    computer: Have a look around and if you find something with
    paper inside,
    that's the printer). Put the papers in a folder and send them
    to Someone at
    MS (You don't need to put a name: Usually it's Mr. Gates the
    one who uploads
    the pages himself, but I'm sure there are lots of MS experts
    that will be
    glad to help with the job).
    Just a reminder: if your pages need to be uploaded as soon as
    possible,
    don't forget to put some extra Air Mail stamps on the
    envelope!
    Best of luck trying to find the printer!!
    Andres.
    "THE WEBDEV KING" <[email protected]> escribi�
    en el mensaje
    news:[email protected]...
    > Hello again to all my friends at Macromedia. A big hello
    to Mr
    > DownWithTheBugs, Mr Chris In Madison, Mr Car Crash (he
    he) and especially
    > Mrs Nancy *Adobe Community Expert. You are all my
    special friends. I have
    > good good sleep and wake up today and solve my mystery
    straight away. The
    > answer was:
    >
    > select * from thebigtable
    > where ID LIKE '39%'
    >
    > Although I am glad of all your futile attempts to help
    me and I very
    > pleased at the time you spendwith me, my expertise
    showed me the path in
    > the end. You all need to do some homework to reach this
    standard. Perhaps
    > you are not used to databases of this size and were all
    a little
    > perplexed. I understand!! This sintax is quite
    complicated to the
    > untrained eye but thankyou all anyway.
    >
    > My new question is this:
    >
    > How do I put my beautiful new webpage on the Internet??
    I would like it to
    > appear inside the Microsoft website as it will benefit
    all Microsoft
    > users. How do I put it there?? Very tough!!
    >
    > Thankyou.
    >
    > My moto - If your best is not good enough then try even
    better, or go and
    > drink lots and lots of alcohol. If that does not work
    then do both
    > together XX.
    >

  • DMZ config! How to do? Easy question for experts! (ASA 5510

    Dear All
    I would like to add a DMZ and VPN to inside network to my ASA5510 configuration, but I'm not sure about the correct way to achieve my goal (I'm a newbie).
    I'll rate your post and promise to send to the best answer a traditional Christmas gift from my country, I'm sure that you will be pleased with it!:)
    Goal:
    1- I want to put a Microsoft Exchange Server 2007 (EDGE Role- Front-Side e-mail server) on a new DMZ.
    2- VPN access to inside network.
    1.1 This e-mail server (name EDGESRV) in the DMZ needs the following configurations:
    Access to EDGESRV from Internet (SMTP)
     Access from EDGESRV to internet (SMTP)
     Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    ROUTER :
    Interface Serial IP: 195.22.12.46/30
    IP route 0.0.0.0 0.0.0.0 195.22.12.45
    Interface Ethernet f0/0: IP 195.22.26.17/29 (connect to router)
    ASA NETWORK
    Interface External e0/0 :IP 195.22.26.18/29 (connect to router)
    Interface internal: e0/1: IP 10.10.100.1 mask 255.255.252.0
    Interface DMZ: e0/2 : IP 10.10.150.1 mask 255.255.255.0 (not implemented yet)
    ASA Configuration (actual)
    ASA Version 8.0(2)
    interface Ethernet0/0
    nameif Interface_to_cisco_router
    security-level 0
    ip address 195.22.26.18 255.255.255.248
    interface Ethernet0/1
    nameif Int_Internal_domain
    security-level 100
    ip address 10.10.100.1 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    passwd xxxxxxxxxxxxx encrypted
    boot system disk0:/asa802-k8.bin
    ftp mode passive
    clock timezone WEST 0
    clock summer-time WEDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    dns domain-lookup Interface_to_cisco_router
    dns domain-lookup Int_Internal_domain.com
    dns server-group DefaultDNS
    name-server 195.22.0.136
    name-server 195.22.0.33
    domain-name domain.com
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list Interface_to_router_Cisco_access_in extended permit object-group TCPUDP any any eq domain
    access-list Interface_to_router_Cisco_access_in extended permit tcp any any eq www
    pager lines 24
    logging list Registo_eventos_william level emergencies
    logging list Registo_eventos_william level emergencies class vpn
    logging asdm informational
    logging recipient-address [email protected] level critical
    mtu management 1500
    mtu Interface_to_router_Cisco 1500
    mtu Int_Internal_domain 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-602.bin
    no asdm history enable
    arp timeout 14400
    global (Interface_to_router_Cisco) 101 interface
    nat (Int_Internal) 101 10.10.100.0 255.255.255.0
    nat (Int_Internal) 101 0.0.0.0 0.0.0.0
    nat (management) 101 0.0.0.0 0.0.0.0
    access-group Interface_to_router_Cisco_access_in in interface Interface_to_router_Cisco
    route Interface_to_router_Cisco 0.0.0.0 0.0.0.0 195.22.26.17 1
    access-list Int_Internal_access_in extended permit tcp any any
    access-list Int_Internal_access_in extended permit udp any any
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 10.10.100.0 255.255.255.0 Int_Internal_domain
    http 10.10.10.0 255.255.255.0 management
    http 195.22.26.16 255.255.255.248 Interface_to_router_Cisco
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    no crypto isakmp nat-traversal
    Kind Regards
    MP

    Mario,
    I think you have much more to go but this is a start, I don't think I have cover everything .. others in netpro may add to this.
    1- I want to put a Microsoft Exchange Server 2007 (EDGE Role- Front-Side e-mail server) on a new DMZ.
    Use this example, Configuring Mail server on DMZ http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806745b8.shtml
    2- VPN access to inside network.
    You can configure RA VPN server using/creating in ASA5510 Local user database
    http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008060f25c.shtml
    or configure RA VPN server using IAS RADIUS-Windows AD for authentication
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806de37e.shtml
    1.1 This e-mail server (name EDGESRV) in the DMZ needs the following configurations:
    Access to EDGESRV from Internet (SMTP)
     Access from EDGESRV to internet (SMTP)
     Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    -Access to EDGESRV from internet on port smtp if you have spare public IP you can create a one-to-one NAT for this server and create
    inbound access rules to allow access on SMPT from outside internet.
    If you do not have spare public IPs for a one-to-one nat on this server you can use ASA outside interface static PAT.
    Example : static (dmz,outside) tcp interface smtp netmask 255.255.255.255
    -Access from EDGESRV to internet (SMTP)
    You need to PAT DMZ network, if EDGESRV does not have one-to-one static NAT
    typical scenario
    global (outside ) 101 interface
    nat (dmz ) 101 0 0
    or
    nat (dmz) 101 <255.255.255.255>
    also for the MAIL Server, if you are using DNS server from your inside network you need acl to allow traffic from MAILserver DMZ to DNS in inside network.
    -Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    from low sec level 0 to high sec level access is permited by default, you do however need to create static nat to allow comm between inside and dmz
    in your scenario if you have 192.168.1.0/24 for inside interface network you would then create something like this.
    static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    Observation -
    I see you have interface Ethernet0/2 free, I assume you will probably be using this interface for your DMZ, I would advice to use subinterfaces and use dot1q in order to scale your DMZs in the future.
    Look this link for reference on working with subinterfaces
    http://www.cisco.com/en/US/docs/security/asa/asa80/configuration/guide/intrface.html
    Rgds
    Jorge

  • PROBLEM  TRANSFERRING   MULTIPLE   DATA  ENTRIES    FOR  ONE KEY-FIELD.

    DEAR   EXPERTS ,
       I  HAVE  TRANSFERRED  DATA  FROM  THE  FINAL  INTERNAL  TABLE  OF  MY  ABAP REPORT (NOT ALV)  TO  CUSTOM  Z-TABLE  CREATED  IN  SE11.
    BUT  MY  PROBLEM  IS  :  I   COULD  NOT   TRANSFER  MULTIPLE   DATA  ENTRIES   FOR  A  PARTICULAR  FIELD.
    FOR  EXAMPLE :  IN  TABLE  EKKO  THERE  ARE   FOUR  EBELN-4900006375  AND  FOR  THAT  DIFFERENT  EBELP S  ARE
    PRESENT.  I  COULD  TRANSFER  ONLY  THE  FIRST  ENTRY ,  THAT  IS :  EBELN -  4900006375  AND   EBELP - 0010,
    AFTER  THAT  THE  ZTABLE  IS  NOT  GETTING  UPDATED  TO  EBELN-4900006375 FOR  EBELP - 0020  AND  SO ON.
    I  HAVE  TRIED  ALL  THE  '  MODIFY, INSERT,  UPDATE  '  STATEMENTS.  I  HAVE  USED  AT - USERCOMMAND - HIDE  AND  CHECKBOXES.
       PLEASE   SUGGEST   A   SAMPLE   CODE   FOR   THIS.
    Moderator message: please post again, but not in all upper case.
    [Rules of engagement|http://wiki.sdn.sap.com/wiki/display/HOME/RulesofEngagement]
    Edited by: Thomas Zloch on Jun 19, 2011 10:05 PM

    There are actually 5 queries in this report now. From what I understand about a union query, I don't think it will work here because the data being returned in each of the queries is so different. I basically need to know how to make all the criteria for each individual to be displayed before proceeding to the next data set, which will include the same data as the first, but for the next employee, and so on. I need to basically create a repeating frame with each individual's respective data I guess, but every time I do, it tells me that it's referencing an invalid group.

  • Multilple Data entry profiles in ESS for CATS

    hi,
    We are implementing CATS and configured the data entry profiles in IMG. Can u tell me if multiple data entry profiles can be chosen by employees through ESS webdynpro applcaition. I need this as the screen layouts for an employee logging time to different projects are different. Is choosing data entry profile provided in ESS ?
    Apprecaite your help
    Regards
    PN

    Hi Bala /Krish,
    Thanks for the replies. i understand that based on the employee groups, sub groups a data enry profile would be assigned to an employee..
    Lets take up this scenario
    1) Employee 1 is assigned to Per Area 1 (HR) and lets say data entry profile 1 on monday
    2) He is asked to work for a diffrent Per area 2 ( project systems ) for 1 day and then after that day he is assigned back to profile 1 again.
    3) On wednesday he comes bak , he is already assigned to data entry profile 1, where he books his time for Per Area 1 (HR). Now how does he book his time for the one day where he was assigned to Per Area 2 ( PS)
    any ideas ? I know this wud be a custom enhancement,
    wanted to know
    1) if BAPI and Web dynpro ESS record working time code will need to be modified ?
    2) What wud be effort and time estinate for such a requirement ?
    3) is it possible ?
    Appreciate your inputs,  i guess i am going on asking questions
    Regards
    PN

  • Converted XML not showing multiple data entries correctly

    Hello
    I am creating a PDF Form from a xsd scheme but when I have data that could require multiple entries the converted xml is a mess. I am curently trying to create a way to add fields for multiple children. I created an expanding table and the fields are automatically copied when I click on „+“ or are deleted when I click on „-“ . If I have multiple rows for children then the converted xml looks like this :
    The correct xml for multiple data entries should look like this (this is from a xml scheme not made in LiveCycle) :
    Even if I copy the fields without creating a table, the converted xml is still a mess just like on the first image. Is there a way to show the xml from the PDF from correctly. I linked the xsd scheme that I am using for the PDF form: https://drive.google.com/file/d/0B30LkLSwYgB4SFN5bTkyLW1fOVU/edit?usp=sharing
    Best regards
    Ivica

    Hello
    I am creating a PDF Form from a xsd scheme but when I have data that could require multiple entries the converted xml is a mess. I am curently trying to create a way to add fields for multiple children. I created an expanding table and the fields are automatically copied when I click on „+“ or are deleted when I click on „-“ . If I have multiple rows for children then the converted xml looks like this :
    The correct xml for multiple data entries should look like this (this is from a xml scheme not made in LiveCycle) :
    Even if I copy the fields without creating a table, the converted xml is still a mess just like on the first image. Is there a way to show the xml from the PDF from correctly. I linked the xsd scheme that I am using for the PDF form: https://drive.google.com/file/d/0B30LkLSwYgB4SFN5bTkyLW1fOVU/edit?usp=sharing
    Best regards
    Ivica

  • Multiple Data entry profiles in ESS -Webdynpro?

    Hi All,
    We have an issue here with the data entry profile.
    The current system(ITS with 4.6c) has multiple data entry profile, from which the employee can select the profile according to the personel area,  he is in. ( Employee can have multiple data entry profiles ) .
    But in new frontend Portal, we dont have such option in EP 7 how can we achieve this in ESS- Webdynpro applications.
    Need your valuable inputs on this.
    Regards,
    NR

    Hi,
    The newer version does not allow you to enter multiple ESS Profile. You will have to define one profile for the CVR parameter. If you think you the ESS User needs multiple profiles, its better to revisit those profiles and change them so that each user gets one profile that fits his time entry.
    If you search in this forum, I think one earlier post had a good informative discussion about the same.
    Thanks,
    Ravi

  • Can anyone answer a very simple question for me ive heard the apple was giving a free iphone 4 or 4s bumper away is there any truth to that?

    can anyone answer a very simple question for me ive heard the apple was giving away iphone 4 or 4s bumpers is there any truth to that?

    Not any more, no. There was a free bumper program back when the iPhone 4 originally came out. It has long since expired.

  • A very important question for every After Effects user

    a very important question for every After Effects user, from product manager Steve Forde:
    http://adobe.ly/1exI6tI

    Tom Daigon Great idea everybody! Encourage Adobe to do ONLY ONE THING with AE for 2014. Since theres not a heck of a lot of development that can be done on the present foundation, they can really stretch the rental scheme out for many years.And once you get used to the concept, every year they will do ONE THING to placate you. So now they have you swallowing no "ownership" of software and limited development. 

  • Easy question for the MODS

    Unlike more difficult questions like CRC problems, ps problems, etc, this is rather an easy question.
    The KT4V manual (page 3-8) lists the onboard NIC as a "boot device" option.  This "feature" is available in Bios 1.1, 1.2 but not available in Bios 1.4 and later.  
    Any reason why this feature was mutilated and not available anymore in the later bioses?
    Are there two different bioses for KT4V and KT4V-L?  If yes where can one find the bios for KT4V-L?
    I know this feature is not very popular with the majority of users, and I'm not trying to bust anyone's balls for removing un-popular features, but the "boot from NIC"  was one of the features/reasons why I got this mb, and I would rather use a much newer bios than 1.2 (for known reasons).
    Also, while on this topic, boot-from-usb (especially thumb drives) feature would also be greatly appreciated - I think it is also listed in the manual.
    TIA

    Hi,
    Quote
    Please suggest him to update the BIOS Ver1.9 which can support Boot from LAN and boot from USB devices.
    AMI BIOS can boot from the devices which support BIOS Boot specifications (BBS, you can refer to the attached file for the information).
    Email me, so I can send you the BIOS PDF.

  • Very easy question about variables

    Can I convert float-variable to String-variable?

    Hi, a very easy way to convert almost anything is
    called "typecasting". It might sound difficult, but
    it isn't.
    You use it like this example
    > String outcome;
    Double input;
    input = 3.54789654587;
    Output = ""+input;
    That's not casting. It's implicit formatting.
    What it does is making an empty string and pasting
    your number behind it. VERY easy! You can do this
    with allmost every type of variables.What it's doing is creating a StringBuffer, appending an empty string to it, then appending the result of calling toString on the Double, which is itself a String. (Though things change a bit in jdk1.5.) It works because StringBuffer.append has versions for each primitive type, and toString exists for all Objects.
    One problem is that it's not efficient -- you're doing a lot of work behind the scenes to do something that can be done much more simply. But the bigger problem is that it's using operators in a roundabout way and with implicit results. So it's sort of a hack. "+" is the append operator for Strings (well it actually comes down to an implicit method call, or several). Putting the double on the right side of that also causes an implicit format. So you're implicitly formatting a value, and then appending it to nothing, to get a result. You're not actually meaning to append, you're meaning to format, but you're using an append operator.
    The more straightforward way to do it is simply to explicitly format it, using the methods already shown on this thread, or using java.text.DecimalFormat.

  • Combobox --- very easy question

    How can I set numbers in a Combobox and assign them
    to a variable ?

    Very easy answer: RTFT
    http://web2.java.sun.com/docs/books/tutorial/

  • Very easy question - loading member list

    Very simple question.
    Do I have to make everyone log off of HFM before I load a member list?
    I had a typo in the member list that I didn't see until I want to do the yearly tax extract, now that I corrected it I want to load the member list, but I don't want to kick everyone off. Just curious to see if it is necessary or not.

    Good morning,
    When I make some changes in the objects (metadata, list, rules, etc.), usually the users, while refreshing, are notified that the application has changed and that it's necessary to log in again. So since it only takes 5 minutes to update the list, I would recommend doing it the first thing in the morning or after the workday.
    Cheers,
    Lu

  • Activity monitor question for experts.

    When I open activity monitor it is constantly changing. I have safari open, but it is there and then it isn't and then it is in activity monitor. How do I read this and is that normal?

    mike sanders3 wrote:
    I entered the thread because it clearly said Activity Monitor for experts and I had an AM problem please tell me where I went wrong I thought we were here to help each other not be picky about threads. If your thread was something different then maybe it should have been more specific I just needed help and there was an opening that seemed to refer to my problem. I don't spend half my life here as you seem to do judging by your posts, let's just be nice to people who need help.
    In order to help people, they should understand the purpose of these boards.
    Had you read the OP's post, you would see that his Activity Monitor is working and his question was simply why Safari appears and disappears from the AM window.
    Your issue is entirely different and that is why I suggested starting a new thread with your particular problem/issue which has nothing to do with Safari in the Activity Monitor.
    Perhaps the term "hijacking a thread" seems rash to you, but it is a common expression with no personal attachment to it. It merely means that someone has used another poster's thread to pose a completely different topic.
    To best get help on this or any technical board, first search for instances of your particular issue, which may have already been solved, and if you do not find such a topic, start a new thread with the Subject describing your issue.
    Once people start responding to other posts in a thread, nobody any longer knows who is answering whom.
    It is always preferable to start a new topic if you want a quick solution to a problem, rather than bury it in another person's thread. It's called "Netiquette" and it is not my invention. It's been around as long as the net has been around AFAIK.
    Message was edited by: nerowolfe

  • Very easy question - How to find out the first date of year

    Hi Experts,
    I have created Web Dynpro program. I have to set one field "start_date" as first date of year. For example if current date is 04/10/2009, then program should set value of field "start_date" as 01/01/2009.
    If suppose program is used on 12/12/2012, then program should set the value of "start_date" as 01/01/2012.
    Please peovide me some code.
    Regards,
    Gary

    Hi,
    This line should give you the current year.
    Calendar.getInstance().get(Calendar.YEAR);
    Prefix 01/01/ to this will give you the first day of that year.
    Thanks,
    Venkat

Maybe you are looking for