SSL Load Balancing (Java applets problem)

Hi,
I have implemented loadbalancing of two webservers using CSS 11503.
Servers are containing SSL pages which need to be loadbalanced.
I have tried configuring the content rule for ssl using
port 443
application ssl
advanced-balance ssl
commands.The site opens properly using the VIP address (checked the SSL certificate issued by one of the servers. ) and I am able to see all the TABS on the same.The real problem starts when I am trying to upload a file to the server using the VIP address.
The moment I try to upload a file the session shifts to the second server and prompts for new certificate issued by the second server.
One more thing which I would like to mention here is that while uploading the file, JAVA is used.
i.e.the files are being uploaded using JAVA applets.
If anybody has encountered this kind of problem kindly suggest on the same.
Would appreciate if you send the solution on [email protected]
Any configs needed plz contact me on the above e-mail ID.
Thanks,
Pankaj P.

HI Pankaj,
depending on your Java applett it might be possible that the applett opens a new connection. therefore depending on your total configuration it might be possible taht another server is used.Even worse if you do SSL-offloading the applett might tell the user to do http instead of https. I suggest that you check with a sniffertrace what is happening:
1) is there a new connection setup while the applett runs
2) is it again http or https and if https is it a new https session which will be again balanced not depending on the original https session.
Hope that helps
regards,
Joerg

Similar Messages

  • Java applets problem!

    I cannot load/bring up webpages/chatroom links. The consistent error message is "Loading Java Applet Failed". I have J2SE RE 5.0Update 9 already on my pc.
    I have ZoneAlarm PC protection yet I have never had this problem before. I am running Windows XP SP2. HELP anyone????
    An example of an error message is below:
    java.io.IOException: Server returned HTTP response code: 403 for URL: http://host.digichat.com/DigiChat/DigiClasses/Client.jar
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)
    at sun.plugin.cache.CachedJarLoader.isUpToDate(Unknown Source)
    at sun.plugin.cache.CachedJarLoader.loadFromCache(Unknown Source)
    at sun.plugin.cache.CachedJarLoader.load(Unknown Source)
    at sun.plugin.cache.JarCache.get(Unknown Source)
    at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)
    at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)
    at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)
    at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)
    at sun.misc.URLClassPath$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.misc.URLClassPath.getLoader(Unknown Source)
    at sun.misc.URLClassPath.getLoader(Unknown Source)
    at sun.misc.URLClassPath.getResource(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at sun.applet.AppletClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadCode(Unknown Source)
    at sun.applet.AppletPanel.createApplet(Unknown Source)
    at sun.plugin.AppletViewer.createApplet(Unknown Source)
    at sun.applet.AppletPanel.runLoader(Unknown Source)
    at sun.applet.AppletPanel.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    load: class com.diginet.digichat.client.DigiChatApplet not found.
    java.lang.ClassNotFoundException: com.diginet.digichat.client.DigiChatApplet
    at sun.applet.AppletClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadCode(Unknown Source)
    at sun.applet.AppletPanel.createApplet(Unknown Source)
    at sun.plugin.AppletViewer.createApplet(Unknown Source)
    at sun.applet.AppletPanel.runLoader(Unknown Source)
    at sun.applet.AppletPanel.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.io.IOException: open HTTP connection failed.
    at sun.applet.AppletClassLoader.getBytes(Unknown Source)
    at sun.applet.AppletClassLoader.access$100(Unknown Source)
    at sun.applet.AppletClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 10 more
    load: class com.diginet.digichat.client.DigiChatApplet not found.
    java.lang.ClassNotFoundException: com.diginet.digichat.client.DigiChatApplet
    at sun.applet.AppletClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadCode(Unknown Source)
    at sun.applet.AppletPanel.createApplet(Unknown Source)
    at sun.plugin.AppletViewer.createApplet(Unknown Source)
    at sun.applet.AppletPanel.runLoader(Unknown Source)
    at sun.applet.AppletPanel.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.io.IOException: open HTTP connection failed.
    at sun.applet.AppletClassLoader.getBytes(Unknown Source)
    at sun.applet.AppletClassLoader.access$100(Unknown Source)
    at sun.applet.AppletClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 10 more

    HI Pankaj,
    depending on your Java applett it might be possible that the applett opens a new connection. therefore depending on your total configuration it might be possible taht another server is used.Even worse if you do SSL-offloading the applett might tell the user to do http instead of https. I suggest that you check with a sniffertrace what is happening:
    1) is there a new connection setup while the applett runs
    2) is it again http or https and if https is it a new https session which will be again balanced not depending on the original https session.
    Hope that helps
    regards,
    Joerg

  • Webdispatcher SSL load balance server mismatch errors

    We are setting up a webdispatcher to access an Enterprise Portal with multiple instances.  Currently it is working but we are having to overide host mismatches.  in webdispacther log we see
    [Thr 4856] Mon Mar 07 11:38:02 2011
    [Thr 4856] MatchTargetName("aaa.mycompany.com", "CN=bbb.mycompany.com, OU=xxx, O=ooo, L=ccc, SP=sss, C=US") FAILS
    [Thr 4856] SSL NI-sock: local=##.21.13.137:50746 peer=##.21.13.131:51001
    [Thr 4856] <<- ERROR: SapSSLSessionStart(sssl_hdl=0000000008565100)==SSSLERR_SERVER_CERT_MISMATCH
    The Portal instances are on
    aaa.mycompany.com
    bbb.mycompany.com
    Currently have a CA approved certificate for each server installed in the portal.  Dispatcher on aaa uses aaa cert, dispatcher on bbb uses bbb cert.
    Message server is on aaa, but it will load balance and place you on either instance.
    have following related parameters
    wdisp/ssl_encrypt = 2
    wdisp/ssl_auth = 2
    wdisp/ssl_cred = C:\usr\sap\XXX\W00\sec\XXX.pse
    wdisp/ssl_certhost = aaa.mycompany.com
    wdisp/ssl_ignore_host_mismatch = TRUE
    C:\usr\sap\XXX\W00\sec\XXX.pse has ssl cert of both aaa and bbb servers.
    All seems to be working, as users are load balancing.  They are not getting certificate mismatches in their browser anymore.  We are getting the SSSLERR_SERVER_CERT_MISMATCH errors, but the messages do not seem to cause an issue since we have wdisp/ssl_ignore_host_mismatch set.
    Can we eliminate those mismatch errors instead of masking the problem with wdisp/ssl_ignore_host_mismatch?
    Should each portal instance have their own ssl cert, or is there a way to use one cert such as the aaa.mycompany.com cert on each portal instance?  It seems like that might eliminate the mismatch errors.  However, what happens when you go directly to the bbb.mycompany.com portal instance? there is a certificate error if you specify aaa's and you go to bbb.  I was wondering if the wdisp/ssl_auth and wdisp/ssl_certhost are valid in the portal system so that each server uses the aaa server and certificate.  I could not tell if this parameter is valid for java-only portal systems.
    Thanks for your help.
    Edited by: Fett Patrick on Mar 7, 2011 8:35 PM

    Thank you Martin for your prompt reply.  Can you clarify please, can we use the wdisp/ssl_certhost parameter in the instance profiles of the portal instances?  I wasn't sure if that is only valid for webdispatchers or can also be used in abap/java systems?
    We orginally had the aaa server certificate listed for each dispatcher in the portal under ssl provider runtime server identity.  That caused a browser "certificate error" when accessing the bbb server.  So we then installed an ssl certificate for bbb for its dispatcher.  We could then go to either server with no browser "certificate mismatch" error.
    Then when we added the webdispatcher, we started getting the server mismatch errors at the webdispatcher level.  If the wdisp/ssl_certhost can be used in the portal profiles, then that would hopefully resolve direct access or via web dispatcher aceess mismatches.  I.E. only the aaa ssl certificate would be used and parameters would be set at both the webdispatcher and portal profiles
    Thanks, Pat.

  • Failed to load a java applet to safari5.1(windows 7)--prompt "missing plug-in"(i have installed JAVA JRE),  but succeed in IE and Chrome.

    I suspect this is a minor code error issue.
    The html code like below, do i need to add other parameter for Safari 5.1 ?  And is there any other method to load applet in Safari? thanks.
    system is Windows 7, browser version is Safari 5.1 for windows.

    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    <!--[if !IE]> Firefox and others will use outer object --> 
    <object classid="java:com.keithley.SCPI.SCPIApplet.class" type="application/x-java-applet;version=1.6" archive="../jar/SCPI.jar" height="480" width="640">
    <param name = "scriptable"   value = "true">
    <!-- Konqueror browser needs the following param -->
    <param name = "ARCHIVE"    value = "../jar/SCPI.jar">
             <!-- (Microsoft Internet Explorer) will use inner object -->
             <object classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"codebase="http://java.sun.com/update/1.6.0/jinstall-6u35-windows-i586.cab#Version=6,0,0,10"
                     height="480" width="640" >
                     <param name = "CODE"       value = "com.keithley.SCPI.SCPIApplet.class">
                     <param name = "ARCHIVE"    value = "../jar/SCPI.jar">
                     <param name = "type"       value = "application/x-java-applet;version=1.6">
                     <param name = "scriptable" value = "false">
              </object>
               <!--[if !IE]> close outer object -->
    </object>

    Does the Safari5.1 in Windows7 use its own java plug-in instead of SUN's?

  • CONSTANT Java Applet Problems, HELP!

    Alright, since I've had my mac, Java has never worked properly. I have the latest version of OSX and of Java, I tried repairing permissions and also tried manually installing the latest OSX update, but whenever a website uses the Java Applet (for a game / chatroom, etc.) It will never load, or it will freeze the computer while attempting to load.
    I used to use Safari but now use Firefox.. Java doesn't work in either. This is a screen shot of what happens after a few seconds of waiting for this game to load:

    Several issues
    1) Don't paint in the JApplet itself. Instead paint in a JPanel and override its paintComponent method, not its paint method. In fact you would do well to create the GUI in this JPanel and then add the JPanel to the JApplet's contentPane.
    2) Don't override update and don't call update.
    3) The first line of your paintComponent(Graphics g) override should be a call to super.paintComponent(g)
    4) I would strongly urge you to not use NetBeans to generate your Swing code. By doing this, you're hampering your Swing education.
    5) You really shouldn't be adding a MouseListener to a JButton. Instead you add ActionListener's to buttons.
    Good luck and HTH

  • Certificate based authentication with SSL load balancer

    I've been asked to implement certificate-based authentication (CBA)
    on a weblogic cluster serving up web services. I've read through
    Chapter 10 (security) and understand the "Identity Assertion" concept.
    Environment:
    Weblogic 8.1 cluster fronted by a load-balancer that handles SSL and
    uses sticky-sessions.
    Question:
    If the load balancer is used to handle SSL, do I still need to turn
    on SSL on the weblogic cluster in order to use CBA? Is there another
    way to request the client's certificate?
    If the above is yes, what is the minnimal level of SSL? Does it have
    to be two-way?
    If SSL has to be turned on is there any reason to use the load
    balancer's SSL? Is there still a performance benefit?

    I think the simplest and most secure way is to have the servers configured for
    2-way ssl, since this would ensure that the certificate they receive and use for
    authentication has been validated during the ssl handshake. In this case the load
    balancer itself does not need to and cannot do the handshaking, and would need
    to pass the entire SSL connection through to the WLS server (ie: act similar to
    a router)
    Pavel.
    "George Coller" <[email protected]> wrote:
    >
    I've been asked to implement certificate-based authentication (CBA)
    on a weblogic cluster serving up web services. I've read through
    Chapter 10 (security) and understand the "Identity Assertion" concept.
    Environment:
    Weblogic 8.1 cluster fronted by a load-balancer that handles SSL and
    uses sticky-sessions.
    Question:
    If the load balancer is used to handle SSL, do I still need to turn
    on SSL on the weblogic cluster in order to use CBA? Is there another
    way to request the client's certificate?
    If the above is yes, what is the minnimal level of SSL? Does it have
    to be two-way?
    If SSL has to be turned on is there any reason to use the load
    balancer's SSL? Is there still a performance benefit?

  • Load balancing and RFC problem

    Hi!
    I have a problem regarding load balancing and RFC's. We use the follow function in librfc32.dll (from VB6) for RFC calls: RfcOpenExt It's working fine no problem, but from now on we will have to use the this funcion due to load balancing: RfcOpenExtV3
    The only difference between the two functions is the parameters. RfcOpenExtV3 has 5 additional parameters:
    intLoadBalance1, strLbHost1, strLbSysName1, strLbGroup1, intSapGui1
    I asked our tech guys for the details so that I can set up the parameters (double check everything) and the RfcOpenExtV3 doesn't working. Return value is zero.
    Have somebody faced with this issue before?
    Thanks in advance!

    Hi,
    1. Probably this  link may help.
    [http://help.sap.com/saphelp_nw04/helpdata/en/22/042f18488911d189490000e829fbbd/content.htm]
    Especially see the function parameters on this page,
    which are the bottom.
    regards,
    amit m.

  • IOS NAT Load Balancing w/ Failover Problem

    Greetings, i am currently using the configuration below to provide failover between two DSL connections, all is working fine but i had expected outbound connections to be load balanced between the two DSL links on a round robin basis, however looking at the nat translations shows that only one of the links is being used, failover on the other hand works without issue.
    track 1 ip sla 1 reachability
    interface FastEthernet0/0
    ip address 10.50.1.254 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    interface FastEthernet0/1
    ip address 192.168.1.6 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    interface Dialer0
    description WAN Interface
    mtu 1492
    ip address **********
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 1
    interface Dialer1
    description WAN Interface
    mtu 1492
    ip address **********
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 2
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 212.74.102.15 track 1
    ip route 0.0.0.0 0.0.0.0 213.246.177.200 10
    ip nat translation timeout 2
    ip nat translation tcp-timeout 2
    ip nat translation udp-timeout 2
    ip nat translation icmp-timeout 2
    ip nat inside source route-map opal interface Dialer1 overload oer
    ip nat inside source route-map pipex interface Dialer0 overload oer
    ip access-list extended dynamicNat
    permit ip 10.50.1.0 0.0.0.255 any
    permit ip 192.168.1.0 0.0.0.255 any
    deny ip any any
    ip sla 1
    icmp-echo 212.74.102.15
    frequency 5
    ip sla schedule 1 life forever start-time now
    route-map opal permit 10
    match ip address dynamicNat
    set ip next-hop 213.246.177.200
    route-map pipex permit 10
    match ip address dynamicNat
    set ip next-hop verify-availability 212.74.102.15 1 track 1
    Any assistance would be much appreciated.
    Regards

    Hi 
    Thank you for this post man ! this have been so useful. I experienced almost the same problem the router was load balancing well, but the failover was not occuring well between both equal default route.
    After using those command: ip nat translation timeout for tcp icmp and udp all the system has worked propertly.  yeah you need a Big bottle of Jack Daniel  :)    the funniest thing behind is that help me 5 years After......................!!!!

  • ML1000 RPR load balancing and multicast problem

    Hello,
    We have SDH network consisting in a STM16 ring with 7 ONS15454 MSPP nodes, sw version 9.0.1. In each node we have a ML1000-2 card connected in a RPR configuration through VC4-8C(8x155Mbs) circuits.
    My questions:
    Q1 We had expected the ring to balance itself but instead 90% of the traffic is going anti-clockwise which is the direction of the POS-0.
    Q2 We are not able to transmit Multicast packets and we sometimes have problems with udp losses. Could this be due to a bad configuration of the ML-1000? Should we investigate higher in the core switches(6500’s)?
    Thanks

    Manuel,
    I just published a document on load balancing on the ML card.  (ML Load Balancing after 5.doc).
    Check the document section in the Optical Forum.
    Also check the on-line configuration guide.
    http://www.cisco.com/en/US/docs/optical/15000r9_0/ethernet/454/guide/45490a_mlcardovw.html
    As for question #2.  o may find some answers on multicast in the load balancing document or configuration guide.  If not, I suggest opening a TAC case so they can verify your ML configuration.
    Hope this Helps,
    Steve Noyes
    CSE Cisco TAC

  • Load balancing Java instances with EP

    Hi all,
    I am wondering if EP provides load balancing when connecting to backend java systems. For example, when a user connects to the enterprise portal and then, through portal, connects to a java system like BI portal or Biller Direct, are they being load balanced? From what I have read, it sounds like the portal connects to the message server to load balance these backend systems, however I have heard some concerns that a web dispatcher instance may be needed for each backend java system. Is this true or is the load balancing functionality provided by the portal sufficient?
    Our users will only be connecting to these systems via enterprise portal. We are planning to install a web dispatcher instance to balance the portal users but I am trying to figure out if more instances are needed to balance the other java systems.
    I have read the help.sap.com documentation on webdispatcher, as well as these two notes, but none directly addresses this question. Experts, I would really appreciate your help!
    Note 1040325 - HTTP load balancing: Message Server or Web Dispatcher?
    Note 649008 - HTTP load balancing using the SAP message server
    Thanks,
    Michelle

    Michael,
    If I understand you right then the Enterprise portal you are talking about is your "super/main/consumer" portal and you ahfe other portals and java systems as producers?
    If a java installations have one or more Dialog Instances then I would advice you to also install Webdispatchers for those systems too.
    But If these java installations only hava a CI then you don't need webdispatcher as the dispatcher in the instance will load balance on the server nodes.
    Instead of a webdispatcher you could also use a hardware solution but webdispatcher will suit your needs I guess.
    Following ASCII art figure hopefully makes it a litle bit clear:
                                       1. Webdispatcher
                                              |              
                          2. Enterprise Portal CI + DI etc etc
                                              |        
              |                                      |                                     |
    3a. Webdispatcher                       3b. Webdispatcher                              |
              |                                      |                                     |           
    4a. BI Portal CI + DI etc etc           4b. XYZ Portal CI + DI etc etc         4c. Java instance CI only
             |                                       |                                    
    5a. BI ABAP system                      5b. XYZ ABAP system                  
    Good Luck,
    Benjamin Houttuin

  • Java Applet problem in Internet Explorer 7 with Tab Key

    Hi
    I am developing some web pages in which iam using a java applet. so far the intended user are supposed to be using Internet Explorer 7. the problem i am facing is that when i press the tab key within the applet. the control get transferred to new tab position in the web page outside the applet and i have to click back to the applet to get control again transferred to the applet.
    i want to restrict the control of tab so that when tab is pressed within the applet the tab should not move to next tab position in the page and remain confined within the applet.
    Can someone please help me how can i achieve this and whether i have to do coding for it in the applet or in the web page...so that within the applet the Internet Explorer tab control should remain disabled..

    Hello all,
    I have the same problem, but I don't found a solution. Could you resolved the problem and who??
    Thank you.
    Jorge

  • SSL load balancing requirements

    Hi all
    I'm fairly new to CSS so apologies if this is an aobvious question...
    Do I need an ssl module to load balance https requests using certificates on the servers themselves, simple round robin, two web servers, setup
    regards
    nigel

    Nigel,
    you only need and ssl module if you want the css to decrypt the traffic in order to make loadbalancing decision based on the http data contained in the encrypted ssl data.
    For example, if you want to check the url or do stickyness based on a cookie.
    All this info is encrypted in HTTPS, so this is when you need the ssl module.
    If you don't need this feature, you can simpply consider https as normal tcp traffic and loadbalanced based on the tcp destination port.
    Gilles.

  • JavaScript calls method on Java Applet-- Problem

    Hi all,
    I have a problem as following:
    I have a method on JavaScript calling a method on Java Applet. A method on JavaScript repeatedly retrieves data form the server , let's say; every 100 ms and it calls the method on Java to draw a graph(I use thread to call repaint()). The problem is, if I leave the applet site(or the site has lost the focus), the stop() will be called and I can't recieve data from JavaScript anymore. If I go back to the site, the applet starts, but the graph doesn't show the figure, as it supposes to show.
    how can I tell the browser doesn't call the stop() or there is another way to solve this problem?
    Thanks for all answers. CU.
    A-Pex

    my own fault.. it's not the browser or the applet.. It's my computer.. it's too old for this applet..
    Does anyone know, how to optimize the applet with thread? thanks..

  • I am running 10.5.8, and just updated my java to java 5 update10. Now my firefox is missing the Java plugin, and I can't load any Java applet at all. When I try it with Safari, it hangs when certain Java applet loads. HELP!!!

    Suddenly my Java plugin is missing and i can't load any Java with Firefox at all, even though i have it enabled in the browser! i've tried loading in java embedding plugin, but it doesn't work. what should i do???

    It's not in Tools> Add-ons >plugins?  Should be Java Plug-in 2 for NPAPI browsers 13.5.0. What are you seeing there? I don't think it's called the embedding plugin any longer.
    Might try getting the Firefox 5 standalone application. Trash the current one and replace it. Doing this won't affect your Profile or any settings.
    http://www.mozilla.com/en-US/firefox/all.html
    If it's enabled, how can it be missing?
    If this doesn't work, ask here. No need to register. Make sure you put (Mac) in the title.
    http://forums.mozillazine.org/viewforum.php?f=38
    Message was edited by: WZZZ
    EDIT. Oops, may be different for 10.5.8. Was thinking recent Java update for 10.6. But try installing a new app anyway. In the past, this got me the latest Java plugin.

  • SQL Server 2000 - JDBC + Java Applet problem

    Hai
    I have some problem connecting my SQL server database with Java.
    I use Applet to make my interface.
    I use Windows 2000 server.
    Here is my program listing :
    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.event.*;
    import java.sql.*;
    public class VLookup extends JApplet {
    String database = "jdbc:odbc:Driver={SQL Server};SERVER=Windows2000;uid=sa;pwd=;Database=User-Phone Database";
    String user = "sa";
    String password = "";
    Statement s;
    Connection c;
    JTextField searchFor = new JTextField(10);
    JLabel completion = new JLabel(" ");
    JTextArea results = new JTextArea(40, 20);
    public void init() {
    searchFor.getDocument().addDocumentListener(new SearchL());
    JPanel p = new JPanel();
    p.add(new Label("ID to search for :"));
    p.add(searchFor);
    p.add(completion);
    Container cp = getContentPane();
    cp.setLayout(new BorderLayout());
    cp.add(p, BorderLayout.NORTH);
    cp.add(results, BorderLayout.CENTER);
    try {
    Class.forName( "sun.jdbc.odbc.JdbcOdbcDriver" );
    c = DriverManager.getConnection(database, user, password);
    s = c.createStatement();
    } catch(Exception e) {
    results.setText(e.getMessage());
    class SearchL implements DocumentListener {
    public void changedUpdate(DocumentEvent e){}
    public void insertUpdate(DocumentEvent e){
    textValueChanged();
    public void removeUpdate(DocumentEvent e){
    textValueChanged();
    public void textValueChanged() {
    ResultSet r;
    if(searchFor.getText().length() == 0) {
    completion.setText("");
    results.setText("");
    return;
    try {
    r = s.executeQuery("SELECT " + "Tipe " + "FROM " + "Time " + "WHERE " + "(Tipe Like '" + searchFor.getText() + "%') "
    + "GROUP BY " + "Tipe " + "ORDER BY " + "Tipe " );
    if(r.next())
    completion.setText(r.getString("Tipe"));
    r = s.executeQuery("SELECT " + "ID_Pengguna, Phone_Number, Tipe " + "FROM " + "Time "
    + "WHERE " + "(Tipe ='" + completion.getText() + "') "
    + "GROUP BY " + "ID_Pengguna, Phone_Number, Tipe "
    + "ORDER BY " + "ID_Pengguna, Phone_Number " );
    } catch(Exception e) {
    results.setText(searchFor.getText() + "\n");
    results.append(e.getMessage());
    return;
    results.setText("");
    try {
    while(r.next()) {
    results.append(r.getString("ID_Pengguna") + ", " + r.getString("Phone_Number") + ", " + r.getString("Tipe") + "\n");
    } catch(Exception e) {
    results.setText(e.getMessage());
    public static void main(String[] args) {
    JApplet applet = new VLookup();
    JFrame frame = new JFrame("User ID");
    frame.addWindowListener(new WindowAdapter() {
    public void windowClosing(WindowEvent e){
    System.exit(0);
    frame.add(applet);
    frame.setSize(500, 200);
    applet.init();
    applet.start();
    frame.setVisible(true);
    } ///:~
    And java catch error like this : access denied (java.lang.RuntimePermission access ClassInPackage.sun.jdbc.odbc)
    What is wrong ??
    Is there any problem with my DNS ? 'cos I don't know how to set up my DNS.
    Can u help my with this problem ??
    Thank's

    You need to read up on what applets are capable of. Applets generally cannot open connections to things like databases due to sandboxing. There are a couple of ways to get around this. The applet can connect to a servlet on the same machine from which it came and have the servlet do the database accesses. Alternately, you can create a signed applet which allows you to get around some of these sandboxing issues.If tried to make localhost on my computer ( by setting my IIS configuration setting, and using Configure SQL XML Support in IIS I've created a new http://localhost/skripsi to my SQL database.
    Is there any command that I have to add to my program listing so the applet can work as I wish ??
    Is there any way to use applet to connect my database withaout using servlet, and can u explain siggned applet to mey ??
    Sorry, I don't really know java very well.
    driver type 4 ??

Maybe you are looking for

  • Scroll One Page at a Time

    Using InDesign CS5 version 7, on a mac OS10.6.8 I would like to be able to scroll through a document one page at a time using my mouse scroll wheel. In some other programs there is a setting to scroll "continuously" or "by pages" - in the latter, eac

  • Safari does not display correct font

    I just upgraded to Snow Leopard. When I did this, it did something to the fonts displayed in Safari 5.1.7. When I go to a webpage (like someone's blog) the entire body of text is in a cursive font. I've tried emptying the cache, changing the fonts in

  • Oracle 10g(10.1.0.4) , BusIntelligence 10g(10.1.2),   ApSrv 10g(10.1.2)

    I have all ready successfully installed Oracle 10g Database 10.1.0.4 with appropriate olap patch. The latest version of Analytical Warehouse Manager (10.1.0.4) is also installed and working prior to installing application server 10g(10.1.2) 1.Install

  • Can i start a photo slideshow directly on detail view?

    Hi all, Im working on my website right now, and am trying to make a photo page where the album is displayed directly with the detail view (with the small thumbnails on top), is this possible? I tried Cyclosaurus' way, but i still dont see anything ha

  • Adobe Photoshop Quick Mask Won't Work

    I'm using Adobe Photoshop 7. I didn't feel like upgrading. Ok. I'm trying to use the Quick Mask but it won't mask. Instead, it does a light red mask instead and it won't select anything. I deletes the mask. I can't figure out how to make it so it cre