T420 Not recognizing keyboard before OS loads

The T420 my company buys will not recognize an external keyboard while docked before the OS loads.  After the OS loads, there is no problem.  We us a disk encryption software that requires a username and password before it will load the OS and each time I have to open the lid of my T420 and enter the password there.  We also have the same problem with the X220 models we get.  I've updated to the latest BIOS, is there anything in the BIOS that will enable the keyboard?

Is it this mini dock 3?
Check out the Community Knowledge Base for hints and tips.
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
X240 | 8GB RAM | 512GB Samsung SSD

Similar Messages

  • Apple monitor not recognizing keyboard

    My 7 day old Apple 23" monitor is not recognizing my 7 day old Apple keyboard (hardwired, not wireless). I am using a MacBook Air. All was fine until last night.

    Some similar things but not many. I have not changed anything in the computer. Update , I did borrow a VGA to VGA cable was able to get this to work. But for the life of me I cannot get a signal from  the Displayport. Also I tried a Displayport  to DVI-D cable with no results. I would like to use a digital signal rather than an analog. Maybe I will try to update my Bios.
    Thanks for your reply. Anybody else had this problem?

  • MacBook not recognizing Keyboard and trackpad

    Our white MacBook has suddenly devepoped the problem of not recognizing any of the internal input devices. A dialog box appears seeking keyboard and trackpad connections over bluetooth on the desktop after start up. I was able to work around this with a USB keyboard and mouse. What might be the problem?

    sorry you say your built in trackpad.  and your built in keyboard.  reboot.  reset your pram.  maybe your smc
    see if that helps

  • My monitor is not recognized correctly before I'm logged in.

    I have a Dell U24H14 monitor. Connected with a Mini DP to DP port cable.
    In preferences I've set the monitors to extends. Not duplicate. This is al working just fine.
    When I boot my MacBook, with the monitor connected, half way during the boot process, when the monitor is being recognized by OS X, it goes to the standard setting, which is duplicate the screens.
    I've tried with other monitors, but they all are on extend at the login screen after boot.
    I think that somehow the settings(extend) of the monitor are not loaded before I login. Or the settings only apply to my user account and not to the root user.
    I've tried:
    - Reset NVRAM
    - Reset SMC
    - Factory reset Dell Screen
    I have to try with HDMI, maby that works, but I do NOT want to use HDMI.
    How can I fix this? I really love the screen but it is getting annoying when I boot.
    Any help is very appreciated.

    You should set the Unattended Execution Account if you don't want to set credentials for data sources.
    Kind regards,
    Margriet Bruggeman
    Lois & Clark IT Services
    web site: http://www.loisandclark.eu
    blog: http://www.sharepointdragons.com

  • Screen flicker problem with T420s, from power-on -- before OS loads, even before boot.

    I've just bought a new T420s and installed Debian GNU/Linux on it.  Had no screen problems the first few days.
    This morning when I turned it on, the screen was flickering -- like it was doing a very slow refresh rate or something.  Extremely noticeable, and quite annoying :-).  Interestingly, the flicker started from the moment the screen came alive, when I turned the power on.  It persists through the boot loader sequence and into the operating system, etc.  I have powered the machine off and back on several times since then, but the flicker is still here.
    Now, there is one interesting fact:
    The last thing I did, right before the flicker started, was use the laptop with a dock + external monitor.  Not dual monitor, just a single external monitor -- the laptop's lid was down when it was in the dock.  The external monitor worked fine; at one point I opened the laptop's lid just to see what the screen looked like (I was curious because the external monitor's dimensions were very different from the T420s screen dimensions).  The laptop screen had garbage on it -- a kind of distorted, miscolored, and mis-aligned version of my usual operating system desktop.  But that didn't bother me -- I was using the external monitor, and didn't need the laptop screen for anything.  I closed the lid and kept working.
    That night I powered it down in the dock.  This morning I packed it up and took it to work.  The first time I powered up, this new flicker was there.
    Does it have something to do with the fact that I used it with a dock and/or external monitor?  It seems suspicious that the problem started right after the first time I did that.
    By the way, this is a T420s with the stock video card, not the fancier Nvidia card.
    Any ideas how to fix this?

    hey kfogel,
    welcome to the forums.
    could you remove your Nix and place back the original OS ? I would like to know if the flicker occurs when your unit is on Windows or if it occurs while it is on Debian.
    if the flicker doesn't occur when you have windows installed; i would suggest heading over to http://support.lenovo.com and update your whole unit before attempting to use Debian.
    WW Social Media
    Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.
    Did someone help you today? Press the star on the left to thank them with a Kudo!
    If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
    Follow @LenovoForums on Twitter!
    Have you checked out the Community Knowledgebase yet?!
    How to send a private message? --> Check out this article.

  • Macbook pro not recognizing keyboard

    I have a late 2006 Macbook Pro15" Core 2 duo 2.2 with the latest 10.7.2 OS.
    Recently the mouse pad hasbecome intermittently responsive and the keyboard cuts in and out. Yesterdaythe whole keyboard was not being detected by the computer and it started tolook for a blue tooth device. I restarted a couple times with the same results.I then took it to my local MacMall here in SM where it started workingperfectly. They did some tests and could not find any hardware issues... Gothome and its working intermittently again.
    Help!!!! Any ideas whats goingon or suggstions?

    Could be. I also have a 2006 MBP that I've opened several times due to some overheating issues that required my cleaning up the fans and hot air exhaust, so I remember the layout inside the chassis; sure enough, the keyboard is linked to the logic board by a small flat cable that attaches thanks to a flat, square nylon connector. It barely clips on in the best of circumstances, and I remember one time where I had to open the machine again because I couldn't get my keyboard to work at all. Yours seems to work intermittently, so I may be wrong...
    In any case, one picture is worth a thousant words, they say: http://www.ifixit.com/Guide/Installing-MacBook-Pro-15-Inch-Core-Duo-Model-A1150- Keyboard/484/4

  • USB extension cord not recognizing keyboard

    I bought a USB extension cord to connect my keyboard to my iMac. I plug it in and nothing. I test it on a ipod and no problem. Where am I not understanding?

    How long is the USB extension cable?
    Since you noticed this problem, have you shut down (powered off completely) your iMac, and then restarted?
    I assume you tried connecting the keyboard directly to the iMac's port AFTER noting that the USB extension cable connection is not working. And it worked when connected directly AFTER trying it with the extension cable.

  • IMacs randomly not recognizing keyboards.

    iMac 21.5", Early 2013 Models
    I've got a problem with several iMacs that are refusing to recognize their USB keyboards. Come in the next morning and you'll get an error message on the login screen that there is no keyboard detected. No devices are associated with Bluetooth, and Bluetooth is infact turned off. The keyboards are unresponsive, and the LEDs on the mice do not light up. Now the mice are plugged into the keyboards when this happens, but if I plug the mouse into a USB slot on the back of the iMac it works just fine, including the same one that the keyboard was plugged into.
    If I swap keyboards with another iMac that isn't having the problem the keyboards will suddenly work on both machines. It's only if I reset the SMC and clear the NVRAM can I *sometimes* get the keyboards to respond. I've replaced the keyboards with brand new replacements, and the issue randomly persists on the same machines. MRI isn't detecting any issues, nor has ASD EFI & OS. The occurance of this issue is totally random.
    Any Ideas?

    Still having this issue.

  • Amadeus Pro not recognizing keyboard shortcut

    Am using the latest Amadeus Pro (1.4.5) and the keyboard shortcuts for zooming in/out vertically is "option +-" but this isn't working for me. Just getting horizontal zooming. Unfortunately, there is no explicit Menu Command for zooming in/out vertically (just the shortcut according to the manual) so I can't customize the Keyboard Shortcut. Any ideas?

    I don't see any of those keyboard combos in my shortcut menus and Command +- doesn't do anything. Option +- worked fine on pervious versions of Amadeus Pro...but just stopped working for this new version, for some reason. The developer has no clue and says he can't reproduce this.

  • Flash CS3 Debugger not recognizing keyboard input

    I am trying to debug a piece of code involving a keystroke.
    While debugging, when I hit the key the first time, the breakpoint
    is triggered. But after the breakpoint, the debugger simply ignores
    any other keystrokes. I'm trying to see what happens when the key
    is pressed a second time so you can see why this is frustrating me.
    I'm running Flash CS3 on an intel iMac. The program is
    written in AS3.
    Is this a known issue? Are there any workarounds?
    Thanks in advance!


  • Re: MSI Gaming 5 Z97 not recognizing keyboard and boot devices.

    Jaspericus, open your own thread for your issue please. Don&#39;t resurrect or hijack other&#39;s. >>Please read and comply with the Forum Rules.<<

    We don&#39;t assist with OEM hardware but MSI retail hardware only. >>Please read and comply with the Forum Rules.<< Contact HP about it.

  • I can not chat in the web site Anastasia. I could before I loaded firefox 4

    I have been chatting for months on the site. I can't now! I have to go to internet explorer to use the chat. Then it is really slow.
    If I go to the chat page it will load but not entirely. Before I loaded Mozilla 4 it worked fine.

    I have been chatting for months on the site. I can't now! I have to go to internet explorer to use the chat. Then it is really slow.
    If I go to the chat page it will load but not entirely. Before I loaded Mozilla 4 it worked fine.

  • Zr300 Via USB cable is not recognized by my window 8 OS

    The operating system windows 8 is not recognizing Canon ZR300 for loading into my computer for editing. I have a Dell 660s that only has USB, no fire wire which nearly outdated since the USB is faster now.
    On the Canon sight it stated they have no driver specific to that camera concerning Windows 8. That Windows 8 OS would likely have dirver included in it. 
    Is it possible the USB cables I have which are older may not be compatible to the 3.0 and 4.0 etc. USB cards?
    Thank in advance for your response.

    Hi Wilbert!
    Thanks for posting!
    In order to transfer the video from the camcorder, a firewire connection must be used.
    This didn't answer your question or issue? Find more help at Contact Us.
    Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

  • Wireless keyboard not recognized

    Every time I restart since installing Yosemite, the wireless keyboard is not recognized.  It takes several minutes for the keyboard to be found and then I must enter a code before it is recognized.  The batteries are new.  How do I get the keyboard to automatically load?

    Try resetting the PRAM.

  • Not recognizing wireless keyboard/trackpad/mouse

    Just installed windows 7 on new 2012 imac.  loaded the support software. still not recognizing the mac's wireless keyboard, trackpad, or mouse.  what should I try??

    the N70 mouse has a USB dongle to connect to
    Spoiler (Highlight to read)
    You may be able to connect the mouse but the Keyboard should be a pair SK8861
    The SK8861 mouse and keyboard should be a pair because the USB dongle for both is in the SK8861 mouse.
    Im not sure If you can pair the SK8861 keyboard with the n70 USB dongle.
    But here's how to pair the keyboard. you can try this out with the N70 usb dongle.
    Make sure that the keyboard is very close to the dongle when pairing
     1. Unplug the dongle from the computer
     2. Remove the battery
     3. Hold the F2 F3 and F4 keys on the keyboard all throughout the process
     4. Use your left had put the battery in but do not put the keyboard battery cover yet.
     5.  Left hand still, plug in the USB dongle then right away put the keyboard battery cover
    Light will blink but once it stopped you can now let go of the F2 F3 and F4 keys and try the keyboard out.
    If this does not work You might need to conatct where you bought it and ask about the keyboard and mouse, that it should come in pair" sk8861 mouse and keyboard.
    Solid Cruver
    Did someone help you today? Press the star on the left to thank them with a Kudo!
    If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.
    Follow @LenovoForums on Twitter!

Maybe you are looking for

  • Mail Adapter to Soap Adapter keeping the attachments - How?

    Hi guys, I am working on a scenario where I should pull emails from an Exchange server and I should forward them (with their attachments) to a separate systems via a Web Service. So far I have been able to pull the emails using the Mail Adapter and I

  • Connecting shuffle to an existing itunes library

    i have a regular 20GB pod, but i also have a used shuffle that was given to me. ive never tried loading anything into the shuffle, what do i need to do in order to load songs into my shuffle as the shuffle obviously doesnt have the memory to load all

  • LMS 4.2.1 restore question.

    Dears, I  need your help in verifing the restore command for LMS 4.2.1 in windows server:                   the command: C:\Program files (86)\CSCOpx\bin} perl.exe backup.pl -d C:\bkp where the bkp is the backup folder? Kindly confirm if this is corr

  • Transaction (Process ID 112) was deadlocked on lock resources

    i got a error when i run the ssis,how to fix it. Transaction (Process ID 112) was deadlocked on lock resources with another pr                                ocess and has been chosen as the deadlock victim

  • Posting date for payment program

    Hi, The payment program has a posting date in the header information. I want to be able to post with posting date equal to due date and in a payment proposal there will then be more than one due date. Does anyone have a solution to this???