Trouble with xsd:any and web services

I am trying to generate client code from a WSDL for a getter and setter for a chunk of XML.
The getter:<s:element name="GetData">
  <s:complexType>
    <s:sequence>
      <s:element minOccurs="0" maxOccurs="1" name="id" type="s:string"/>
    </s:sequence>
  </s:complexType>
</s:element>
<s:element name="GetDataResponse">
  <s:complexType>
    <s:sequence>
      <s:element minOccurs="0" maxOccurs="1" name="GetDataResult">
        <s:complexType>
          <s:sequence>
            <s:any/>
          </s:sequence>
        </s:complexType>
      </s:element>
    </s:sequence>
  </s:complexType>
</s:element>The setter:<s:element name="SetData">
  <s:complexType>
    <s:sequence>
      <s:element minOccurs="0" maxOccurs="1" name="id" type="s:string"/>
      <s:element minOccurs="0" maxOccurs="1" name="data">
        <s:complexType>
          <s:sequence>
            <s:any/>
          </s:sequence>
        </s:complexType>
      </s:element>
    </s:sequence>
  </s:complexType>
</s:element>
<s:element name="SetDataResponse">
  <s:complexType/>
</s:element>When we use the <autotype> and <clientgen> ant tasks to generate our web service client code from the WSDL, we're getting the following warnings:
[autotype] Autotyping for wsdl http://xxx.xxx.xxx.xxx:8080/xxx/xxx.asmx?WSDL
[autotype] WARNING: Unable to fully map ['http://xxx.xxx/xxx/xxx/2005/11/30']:GetDataResultAnonType using javax.xml.soap.SOAPElement
[autotype] WARNING: Unable to fully map ['http://xxx.xxx/xxx/xxx/2005/11/30']:dataAnonType using javax.xml.soap.SOAPElement
[autotype] WARNING: Unable to fully map ['http://xxx.xxx/xxx/xxx/2005/11/30']:SetData using javax.xml.soap.SOAPElement
[autotype] WARNING: Unable to fully map ['http://xxx.xxx/xxx/xxx/2005/11/30']:GetDataResponse using javax.xml.soap.SOAPElementOur client code for the getData() call looks mostly correct. There's a GetData object created with an "id" field. Typically, I've seen that when the web service method calls are generated, it gives me two ways to call:
- one that takes a bean (in this case, a GetData object)
- one that takes the actual fields (in this case, just a String)
Only the method that takes the bean is getting generated, but that's not a big deal.
The client code for the setData() call, however, is all screwed up. There is no SetData bean object, and the only method call that gets generated takes just a SOAPElement, the "id" field is left completely out. Without any way to specify the id of the data I'm setting, the setData() method call is worthless.
My first suspicion was that the Ant tasks did not know how to handle the <any> tag. But we're getting exactly what we want, a SOAPElement object returned in the getter and a SOAPElement to set in the setter. The problem is that it's leaving out the "id" string in the setter. I guess I'm having a hard time seeing why it's almost working.
Anyone have any ideas? I almost feel like this could be a bug. Sorry for the long post.
Tobin

Hi!
Did you ever solve this? I get similar warnings for our wsdl, and can't figure out if they are the kind I can ignore, or if they indicate that my code will go down the drain :).
/JMK

Similar Messages

  • Help with Radio Group and Web Service

    Hi,
         I created a Radio Group with Dynamic Entry List (Web Service).  It seems my list keeps coming back empty.  I am on SP10. 
         When I deploy I get warnings that "Entry List is missing output fields mapping.  I think this is a warning only because I don't have my form connected to any other components.  I just want to see the radio group populated. I don't think this is the cause. 
    I see references out there to this "Dynamic List" not working until SP12?  Can anyone add some insight to what is wrong?  unsupported until later?
    Thanks!

    I created a new model and the new model works fine.  Something must be cached.

  • Cfc component with readonly properties and web services

    I want to transfer a cfc component across coldfusion web
    services as a data transfer object. This cfc component is received
    when calling a load web service, and then supplied to an update web
    service. Some properties within the cfc need to be readonly since
    the update web service would ignore them.
    In java I would have my data transfer object with only public
    set methods for those properties which are not readonly. How can I
    achieve this in coldfusion?

    Hi,
    Please check note 1004108.
    Methods of Application and/or Entity Services (Business Objects) of CAF of SAP NetWeaver CE 7.1 cannot be exposed in document style, only RPC/literal is possible. Sorry.
    It's a restriction that is planned to be solved in one of the next releases.
    Regards,
       Jan

  • Problem running report with BI Publisher and Web Service

    Hello,
    I actually try to run a Bi Publisher report via the Web Service.
    I use the following documents:
    - http://download.oracle.com/docs/cd/E10415_01/doc/bi.1013/e10416/bip_webservice_101331.htm
    - "How to integrate Oracle BI Publisher via Web Services in Oracke Forms"
    Everything works fine. But when I try to copy it on local computer the file is 0 length. I use the "getReportBytes" method.
    Here is the code I tried with:
    String userName = “Administrator”;
    String passWord = “Administrator”;
    System.out.println(”calling ” + myPort.getEndpoint());
    System.out.println(myPort.validateLogin(userName,passWord));
    ReportRequest repReq = new ReportRequest();
    ReportResponse repRes = new ReportResponse();
    repReq.setAttributeFormat(”pdf”);
    repReq.setAttributeLocale(”en-US”);
    repReq.setAttributeTemplate(”World Sales”);
    repReq.setReportAbsolutePath(”/Sales Manager/World Sales/World Sales.xdo”);
    repRes = myPort.runReport(repReq,userName,passWord);
    System.out.println(repRes.getReportContentType());
    byte[] binaryBytes = repRes.getReportBytes();
    OutputStream out = new FileOutputStream(”D:
    out.pdf”);
    out.write(binaryBytes);
    out.close();
    System.out.println(”Success for Run Report”);
    Thanks in advance.

    Hi,
    I assume that you use 10.1.3.4. If not, my hint is not relevant for you ....
    There's a new parameter in the web service API to set the Chunk-Size. Unfortunaltely is the default value not so, that the behaviour is like in older releases (no chunk-size ... the whole document at once). If you set the chunk size to -1, you should get your document. So try to add
    repRequest.setSizeOfDataChunkDownload(-1);
    regards
    Rainer

  • Not Working-central web-authentication with a switch and Identity Service Engine

    on the followup the document "Configuration example : central web-authentication with a switch and Identity Service Engine" by Nicolas Darchis, since the redirection on the switch is not working, i'm asking for your help...
    I'm using ISE Version : 1.0.4.573 and WS-C2960-24PC-L w/software 12.2(55)SE1 and image C2960-LANBASEK9-M for the access.
    The interface configuration looks like this:
    interface FastEthernet0/24
    switchport access vlan 6
    switchport mode access
    switchport voice vlan 20
    ip access-group webauth in
    authentication event fail action next-method
    authentication event server dead action authorize
    authentication event server alive action reinitialize
    authentication order mab
    authentication priority mab
    authentication port-control auto
    authentication periodic
    authentication timer reauthenticate server
    authentication violation restrict
    mab
    spanning-tree portfast
    end
    The ACL's
    Extended IP access list webauth
        10 permit ip any any
    Extended IP access list redirect
        10 deny ip any host 172.22.2.38
        20 permit tcp any any eq www
        30 permit tcp any any eq 443
    The ISE side configuration I follow it step by step...
    When I conect the XP client, e see the following Autenthication session...
    swlx0x0x#show authentication sessions interface fastEthernet 0/24
               Interface:  FastEthernet0/24
              MAC Address:  0015.c549.5c99
               IP Address:  172.22.3.184
                User-Name:  00-15-C5-49-5C-99
                   Status:  Authz Success
                   Domain:  DATA
           Oper host mode:  single-host
         Oper control dir:  both
            Authorized By:  Authentication Server
               Vlan Group:  N/A
         URL Redirect ACL:  redirect
             URL Redirect: https://ISE-ip:8443/guestportal/gateway?sessionId=AC16011F000000510B44FBD2&action=cwa
          Session timeout:  N/A
             Idle timeout:  N/A
        Common Session ID:  AC16011F000000490AC1A9E2
          Acct Session ID:  0x00000077
                   Handle:  0xB7000049
    Runnable methods list:
           Method   State
           mab      Authc Success
    But there is no redirection, and I get the the following message on switch console:
    756005: Mar 28 11:40:30: epm-redirect:IP=172.22.3.184: No redirection policy for this host
    756006: Mar 28 11:40:30: epm-redirect:IDB=FastEthernet0/24: In epm_host_ingress_traffic_qualify ...
    I have to mention I'm using an http proxy on port 8080...
    Any Ideas on what is going wrong?
    Regards
    Nuno

    OK, so I upgraded the IOS to version
    SW Version: 12.2(55)SE5, SW Image: C2960-LANBASEK9-M
    I tweak with ACL's to the following:
    Extended IP access list redirect
        10 permit ip any any (13 matches)
    and created a DACL that is downloaded along with the authentication
    Extended IP access list xACSACLx-IP-redirect-4f743d58 (per-user)
        10 permit ip any any
    I can see the epm session
    swlx0x0x#show epm session ip 172.22.3.74
         Admission feature:  DOT1X
         ACS ACL:  xACSACLx-IP-redirect-4f743d58
         URL Redirect ACL:  redirect
         URL Redirect:  https://ISE-ip:8443/guestportal/gateway?sessionId=AC16011F000000510B44FBD2&action=cwa
    And authentication
    swlx0x0x#show authentication sessions interface fastEthernet 0/24
         Interface:  FastEthernet0/24
         MAC Address:  0015.c549.5c99
         IP Address:  172.22.3.74
         User-Name:  00-15-C5-49-5C-99
         Status:  Authz Success
         Domain:  DATA
         Oper host mode:  multi-auth
         Oper control dir:  both
         Authorized By:  Authentication Server
         Vlan Group:  N/A
         ACS ACL:  xACSACLx-IP-redirect-4f743d58
         URL Redirect ACL:  redirect
         URL Redirect:  https://ISE-ip:8443/guestportal/gateway?sessionId=AC16011F000000510B44FBD2&action=cwa
         Session timeout:  N/A
         Idle timeout:  N/A
         Common Session ID:  AC16011F000000160042BD98
         Acct Session ID:  0x0000001B
         Handle:  0x90000016
         Runnable methods list:
         Method   State
         mab      Authc Success
    on the logging, I get the following messages...
    017857: Mar 29 11:27:04: epm-redirect:IDB=FastEthernet0/24: In epm_host_ingress_traffic_qualify ...
    017858: Mar 29 11:27:04: epm-redirect:epm_redirect_cache_gen_hash: IP=172.22.3.74 Hash=271
    017859: Mar 29 11:27:04: epm-redirect:IP=172.22.3.74: CacheEntryGet Success
    017860: Mar 29 11:27:04: epm-redirect:IP=172.22.3.74: Ingress packet on [idb= FastEthernet0/24] matched with [acl=redirect]
    017861: Mar 29 11:27:04: epm-redirect:IDB=FastEthernet0/24: Enqueue the packet with if_input=FastEthernet0/24
    017862: Mar 29 11:27:04: epm-redirect:IDB=FastEthernet0/24: In epm_host_ingress_traffic_process ...
    017863: Mar 29 11:27:04: epm-redirect:IDB=FastEthernet0/24: Not an HTTP(s) packet
    What I'm I missing?

  • Error during EAR deployment with EJB and web service

    I created a simple stateless EJB with one method called echo that returns a string.  I created a web service using the wizard, did a build and deployed.  The deployment did not report an error, but the logs in the visual administrator showed the follwoing message, and the web service did NOT deploy.
    Am I missing something related to EJB and web service security?
    PLEASE HELP ME.
    >>> Warning: delete security configuration [apps/com.areva/ear/ejb/security/com.areva~ejb.jar]
    [EXCEPTION]
    java.lang.Exception
         at com.sap.engine.services.security.server.PolicyConfigurations.unregisterPolicyConfiguration(PolicyConfigurations.java:153)
         at com.sap.engine.services.ejb.EJBAdmin.remove(EJBAdmin.java:2538)
         at com.sap.engine.services.deploy.server.application.RemoveTransaction.removeApplication(RemoveTransaction.java:294)
         at com.sap.engine.services.deploy.server.application.RemoveTransaction.prepare(RemoveTransaction.java:178)
         at com.sap.engine.services.deploy.server.application.ApplicationTransaction.makeAllPhasesOnOneServer(ApplicationTransaction.java:299)
         at com.sap.engine.services.deploy.server.application.ApplicationTransaction.makeAllPhases(ApplicationTransaction.java:321)
         at com.sap.engine.services.deploy.server.DeployServiceImpl.makeGlobalTransaction(DeployServiceImpl.java:3028)
         at com.sap.engine.services.deploy.server.DeployServiceImpl.remove(DeployServiceImpl.java:820)
         at com.sap.engine.services.deploy.server.DeployRuntimeControlImpl.remove(DeployRuntimeControlImpl.java:271)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:324)
         at com.sap.pj.jmx.introspect.DefaultMBeanInvoker.invoke(DefaultMBeanInvoker.java:58)
         at com.sap.pj.jmx.mbeaninfo.AdditionalInfoProviderMBean.invoke(AdditionalInfoProviderMBean.java:289)
         at com.sap.pj.jmx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:944)
         at com.sap.pj.jmx.server.interceptor.MBeanServerWrapperInterceptor.invoke(MBeanServerWrapperInterceptor.java:288)
         at com.sap.engine.services.jmx.CompletionInterceptor.invoke(CompletionInterceptor.java:400)
         at com.sap.engine.services.jmx.RedirectInterceptor.invoke(RedirectInterceptor.java:340)
         at com.sap.pj.jmx.server.interceptor.MBeanServerInterceptorChain.invoke(MBeanServerInterceptorChain.java:330)
         at com.sap.engine.services.jmx.MBeanServerSecurityWrapper.invoke(MBeanServerSecurityWrapper.java:287)
         at com.sap.engine.services.jmx.MBeanServerInvoker.invokeMbs(MBeanServerInvoker.java:157)
         at com.sap.engine.services.jmx.ClusterInterceptor.invokeMbs(ClusterInterceptor.java:220)
         at com.sap.engine.services.jmx.ClusterInterceptor.invoke(ClusterInterceptor.java:803)
         at com.sap.engine.services.jmx.MBeanServerInterceptorInvoker.invokeMbs(MBeanServerInterceptorInvoker.java:102)
         at com.sap.engine.services.jmx.connector.p4.P4ConnectorServerImpl.invokeMbs(P4ConnectorServerImpl.java:61)
         at com.sap.engine.services.jmx.connector.p4.P4ConnectorServerImplp4_Skel.dispatch(P4ConnectorServerImplp4_Skel.java:64)
         at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(DispatchImpl.java:291)
         at com.sap.engine.services.rmi_p4.DispatchImpl._run(DispatchImpl.java:183)
         at com.sap.engine.services.rmi_p4.server.P4SessionProcessor.request(P4SessionProcessor.java:119)
         at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:37)
         at com.sap.engine.core.cluster.impl6.session.UnorderedChannel$MessageRunner.run(UnorderedChannel.java:71)
         at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
         at java.security.AccessController.doPrivileged(Native Method)
         at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:94)
         at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:162)

    I have the same message. I am running sp11.
    Does anyone have an answer for this?????
    >>> Warning: delete security configuration [apps/avalero.com/rtfa-ear/contextRoot]
    [EXCEPTION]
    java.lang.Exception
         at com.sap.engine.services.security.server.PolicyConfigurations.unregisterPolicyConfiguration(PolicyConfigurations.java:153)
         at com.sap.engine.services.servlets_jsp.server.container.WebContainerHelper.removeSecurityResources(WebContainerHelper.java:905)
         at com.sap.engine.services.servlets_jsp.server.container.WebContainerHelper.remove(WebContainerHelper.java:447)
         at com.sap.engine.services.servlets_jsp.server.container.RemoveAction.remove(RemoveAction.java:50)
         at com.sap.engine.services.servlets_jsp.server.container.WebContainer.remove(WebContainer.java:150)
         at com.sap.engine.services.deploy.server.application.RemoveTransaction.removeApplication(RemoveTransaction.java:294)
         at com.sap.engine.services.deploy.server.application.RemoveTransaction.prepare(RemoveTransaction.java:178)
         at com.sap.engine.services.deploy.server.application.ApplicationTransaction.makeAllPhasesOnOneServer(ApplicationTransaction.java:299)
         at com.sap.engine.services.deploy.server.application.ApplicationTransaction.makeAllPhases(ApplicationTransaction.java:323)
         at com.sap.engine.services.deploy.server.DeployServiceImpl.makeGlobalTransaction(DeployServiceImpl.java:3033)
         at com.sap.engine.services.deploy.server.DeployServiceImpl.remove(DeployServiceImpl.java:821)
         at com.sap.engine.services.deploy.server.DeployRuntimeControlImpl.remove(DeployRuntimeControlImpl.java:271)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:324)
         at com.sap.pj.jmx.introspect.DefaultMBeanInvoker.invoke(DefaultMBeanInvoker.java:58)
         at com.sap.pj.jmx.mbeaninfo.AdditionalInfoProviderMBean.invoke(AdditionalInfoProviderMBean.java:289)
         at com.sap.pj.jmx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:944)
         at com.sap.pj.jmx.server.interceptor.MBeanServerWrapperInterceptor.invoke(MBeanServerWrapperInterceptor.java:288)
         at com.sap.engine.services.jmx.CompletionInterceptor.invoke(CompletionInterceptor.java:400)
         at com.sap.pj.jmx.server.interceptor.BasicMBeanServerInterceptor.invoke(BasicMBeanServerInterceptor.java:277)
         at com.sap.jmx.provider.ProviderInterceptor.invoke(ProviderInterceptor.java:255)
         at com.sap.engine.services.jmx.RedirectInterceptor.invoke(RedirectInterceptor.java:340)
         at com.sap.pj.jmx.server.interceptor.MBeanServerInterceptorChain.invoke(MBeanServerInterceptorChain.java:330)
         at com.sap.engine.services.jmx.MBeanServerSecurityWrapper.invoke(MBeanServerSecurityWrapper.java:287)
         at com.sap.engine.services.jmx.MBeanServerInvoker.invokeMbs(MBeanServerInvoker.java:157)
         at com.sap.engine.services.jmx.ClusterInterceptor.invokeMbs(ClusterInterceptor.java:220)
         at com.sap.engine.services.jmx.ClusterInterceptor.invoke(ClusterInterceptor.java:803)
         at com.sap.engine.services.jmx.MBeanServerInterceptorInvoker.invokeMbs(MBeanServerInterceptorInvoker.java:102)
         at com.sap.engine.services.jmx.connector.p4.P4ConnectorServerImpl.invokeMbs(P4ConnectorServerImpl.java:61)
         at com.sap.engine.services.jmx.connector.p4.P4ConnectorServerImplp4_Skel.dispatch(P4ConnectorServerImplp4_Skel.java:64)
         at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(DispatchImpl.java:294)
         at com.sap.engine.services.rmi_p4.DispatchImpl._run(DispatchImpl.java:183)
         at com.sap.engine.services.rmi_p4.server.P4SessionProcessor.request(P4SessionProcessor.java:119)
         at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:37)
         at com.sap.engine.core.cluster.impl6.session.UnorderedChannel$MessageRunner.run(UnorderedChannel.java:71)
         at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
         at java.security.AccessController.doPrivileged(Native Method)
         at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:94)
         at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:162)

  • HT3529 I'm having trouble with my iPhone 5 iMessage service. The device does not recognize the users who have iMessage when I try to contact them using this feature. Who have the same issue and what did you do in order to solve it?

    I'm having trouble with my iPhone 5 iMessage service. The device does not recognize the users who have iMessage when I try to contact them using this feature. Who have the same issue and what did you do in order to solve it?

    Read here:
    http://support.apple.com/kb/ts2755

  • Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

    Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T
    I am having trouble making outgoing call or answering incoming call.
    When I try to call out from my IP 7961 phone, it fails with the message "unknown number".
    For incoming call, it rings but when I pick up the call nothing happens,
    Put the receiver back on hook, the phone carries on ringing. I am in UK
    and just trying to set up test system with one analogue line. Any help will
    be most appreciated. My config of the 2811 router is posted below. All calls ineternally works fine.
    Thank you for your help.
    hostname Test-CME
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1 10.10.10.10
    ip dhcp excluded-address 10.139.139.1 10.139.139.10
    ip dhcp pool host
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    option 150 ip 10.10.10.1
    ip dhcp pool data
    network 10.139.139.0 255.255.255.0
    default-router 10.139.139.1
    dns-server 10.139.139.5
    voice-card 0
    no dspfarm
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    h323
    sip
    header-passing
    registrar server expires max 3600 min 3600
    interface FastEthernet0/1
    no ip address
    no ip mroute-cache
    duplex auto
    speed auto
    no shut
    interface FastEthernet0/1.2
    description ** Data VLAN **
    encapsulation dot1Q 2
    ip address 10.139.139.1 255.255.255.0
    interface FastEthernet0/1.3
    description ** Voice VLAN **
    encapsulation dot1Q 3
    ip address 10.10.10.1 255.255.255.0
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    tftp-server flash:S00104000100.sbn
    tftp-server flash:TERM41.7-0-3-0S.loads
    tftp-server flash:term61.default.loads
    tftp-server flash:term41.default.loads
    tftp-server flash:CVM41.2-0-2-26.sbn
    tftp-server flash:cnu41.2-7-6-26.sbn
    tftp-server flash:Jar41.2-9-2-26.sbn
    tftp-server flash:term70.default.loads
    tftp-server flash:term71.default.loads
    tftp-server flash:cnu70.2-7-6-26.sbn
    tftp-server flash:Jar70.2-9-2-26.sbn
    tftp-server flash:TERM70.7-0-3-0S.loads
    tftp-server flash:CVM70.2-0-2-26.sbn
    control-plane
    voice-port 0/3/0
    connection plar opx 202
    caller-id enable
    dial-peer voice 1 pots
    incoming called-number .
    destination-pattern 9T
    port 0/3/0
    telephony-service
    load 7914 S00104000100
    load 7941 TERM41.7-0-3-0S
    load 7961 TERM41.7-0-3-0S
    load 7970 TERM70.7-0-3-0S
    max-ephones 20
    max-dn 40
    ip source-address 10.10.10.1 port 2000
    calling-number initiator
    service phone videoCapability 1
    system message MKC CME
    url services http://10.10.10.1/voiceview/common/login.do
    url authentication
    http://10.10.10.1/voiceview/authentication/authenticate.do
    time-zone 21
    date-format dd-mm-yy
    voicemail 600
    max-conferences 8 gain -6
    call-forward pattern .T
    call-forward system redirecting-expanded
    moh music-on-hold.au
    web admin system name admin secret 0 test
    dn-webedit
    time-webedit
    transfer-system full-consult dss
    transfer-pattern 9.T
    secondary-dialtone 9
    create cnf-files
    ephone-dn 1 dual-line
    number 201
    label 201
    description Sarah
    name Sarah
    ephone-dn 2 dual-line
    number 202
    label 202
    description Vitthal
    name User2 Vitthal
    ephone-dn 3 dual-line
    number 203 secondary
    label 203
    description Neil
    name User3 Neil
    ephone 1
    video
    username "user1" password 201
    mac-address 0018.18EE.947F
    type 7961 addon 1 7914
    button 1:1
    ephone 2
    video
    username "user2" password 202
    mac-address 0018.18BB.B973
    type 7941
    button 1:2
    ephone 3
    video
    username "user3" password 203
    mac-address 0018.1885.6BA2
    type 7970
    button 1:3

    Hi
    Please find enclosed debug attachment for voice ccapi and ephone. First, I called from outside. Extension 202 rings but when I answered on extension 202 nothing happens. Replace the rceiever and the pone starts ringing again.Second step. I tried to call out by dialing 9 and then number but after a while phone displays unknown number.
    Thank you for your help.
    Vitthal

  • SSL certificates and Web Services Usage inside Oracle Database Questions!

    We have implemented a specific business logic using PL/SQL for our client, so we open a file and process each line of this, doing something in the Database and also call a Web Services (Service1) using UTL_HTTP package. Service1 runs in a Windows 2008 Server in the DMZ as Database server.
    Service1 is already working, and we can call the service from PL/SQL without troubles.
    However, according with security client's policies they requires all Web services be consumed via https including Service1, so we must to follow the procedure established for Oracle in order to enable the calling of service1 via https from the Database.
    Our client's DBA and IT Team are concerned about two subjects before to continue to follow the certificate installation:
         - SSL Certificates:
    1- Can installed certificates in the Database put in risk the stability of the database?
              2- Can installed certificates in the Database generate performance issues?
              3- Can installed certificates reloading the Databases?
              2- Can installed certificates in the Database generate security issues?
         - Web services:
    1- Can web services calling from the Database put in risk the stability of the database?
    2- Can web services calling from the Database generate performance issues?
    3- Can web services calling from the Database generate security issues in the DMZ?
    Could you please give us any clues, about the possible negative impact related with the SSL certificates and Web Services Usage inside Oracle Database, if it’s the case this impact exists?.
    Those are the links describing the procedure mentioned above.
    1 -http://www.kotti.es/2009/11/oracle-wallet/
    DB: Oracle 9i.
    Average number of lines in file: 300
    Periodicity: Twice at day.

    Thiago:
    You are correct in that there should be no problem interacting with a Web service that has an HTTPS endpoint as long as you create a wallet and specify it when you make your UTL_HTTP calls, like the PayPal example.
    I am not aware of a PL/SQL utility to create a XMLDsig Standard message, but if you find some Java source out there that does it, you may be able to follow a technique I used for a similar use case:
    http://jastraub.blogspot.com/2009/07/hmacsha256-in-plsql.html
    Regards,
    Jason

  • XML and Web Service Data Source Missing in Crystal Reports for VS

    I would like to use a Web Service as the data source for a Crystal Report that will be running outside of my Visual Studio application.  So setting the data source to the web service in code is not possible.  My understanding is Crystal Reports has a connection (in the Database Expert under New Connection) named XML and Web Service.  Here you can select web service and enter the WSDL URL for the web service.  However it does not appear in the list for Crystal Reports for Visual Studio.  Does this connection type come with the Visual Studio version of Crystal Reports and if not is their a way to obtain it? 
    Thank you for your assistance.

    None of the bundled versions of CR have the driver. Reason is that the driver responsible for these connections requires the Java framework and I suspect MS would not be too pleased if we installed the Java framework. The stand alone versions, since they are not part of any bundle can and do install the Java framework and the driver. Note that even the latest release of CR - CRVS2010 does not have the driver as it essentially becomes a bundle or a VS2010 plug-in.
    So, the short of it is; you have to obtain a stand-alone version of CR. I'd recommend CR 2008 (12.x) as CRXI R2 will run out of support in June of this year.
    - Ludek

  • Can't run wiki and web services at the same time?

    I'm a newbie with Lion Server, but I've been running several web sites successfully for about 6 months.  I'm up to Server 10.7.4.
    I've been trying ever since the first installation of Server to get the wiki service running.  I had absolutely no luck until I turned OFF the web service (always got the "URL does not exist" error when I tried to create a group wiki from inside the Server app).  With the web service off, it all starts up fine and I created my first wiki (woohoo).  Turning web service back on kills access to the wiki.  I don't find reference to this in any of the dicussions, and especially not in Apple's documentation.
    Are the Wiki and Web services mutually exclusive?  Or is there a way around this?
    I'm using Dyndns to provide me with sub-domains to use, and I've dedicated one of them to the wiki service.  Traffic comes in on port 8080, where my web sites are on port 80.
    Thanks for any pointers...
    edbok

    LR supports tethering using a Canon DLL and EOS Utility probably also supports tethering or at least uses something from a similar Canon DLL.  You probably cannot have two different versions of that DLL loaded at the same time, so it makes sense there are problems.

  • Message Monitoring and Web services Sequences  .. SOAMANAGER

    When can I use Mesage Monitoring and Sequence Monitoring .
    We are making a proof a concept and we are the following.
    1. A program which executes a proxy and with this proxy we are consuming a web services.
    2. The proxy and web services were implemented in the same Abap Machine .
    3. We execute the test and everything works very well and we consume the webservice and the program displays the expected result.
    Now want to know How can we use the Message Monitoring and the Sequence Monitoring . Is this posible ? Do we have to make any previous configuration?
    We don´t have any XI installation and for that we wonder if we can monitorize the  webservices  sequences ?
    Any idea about if we can realize such king of actions ..
    Many Thanks

    Hi
    I assumes u have dual stack.
    You can do the sequence monitoring with or without PI. But without PI you would achieve that thing on the local machine.
    You have to do those things at Java End using SAP NWA.
    Please see this link
    http://help.sap.com/saphelp_nwce10/helpdata/en/46/b00c2a99930764e10000000a1553f6/content.htm
    http://help.sap.com/saphelp_nwce10/helpdata/en/46/9cb2b57ded371ae10000000a11466f/content.htm

  • Enterprise services and Web services

    Hi Everyone
         I need documents about Invoking enterprise services from Netweaver PI and web services from Netweaver PI, I can find only NetWeaver CE, but not PI. So help, any links?? or pdfs?? or ideal would be some demo example of invoking a web service using PI.
    Thank you
        Vijay

    Hi,
    Since you would need to wet your hands by playing with webservice and PI. Please consider the following links.
    SOAP scenario
    /people/siva.maranani/blog/2005/09/03/invoke-webservices-using-sapxi
    https://weblogs.sdn.sap.com/pub/wlg/1334 [original link is broken] [original link is broken] [original link is broken]
    https://weblogs.sdn.sap.com/pub/wlg/2131 [original link is broken] [original link is broken] [original link is broken]
    https://weblogs.sdn.sap.com/pub/wlg/1442 [original link is broken] [original link is broken] [original link is broken]
    Regards
    joel
    Edited by: joel trinidade on Mar 25, 2009 10:41 AM
    Edited by: joel trinidade on Mar 25, 2009 10:43 AM

  • GTC Connector using SPML Format Provider and Web Services Transport Provide

    Hello All,
    Did any body create a GTC connector which uses SPML Format for Format Provider and Web Services format for Transport Provider?
    Is there any doc which talks about the same?
    I need to provision to a system over web services and I thought GTC using the above formats should be an easy approach. Am I right?
    I was trying to follow:
    http://download.oracle.com/docs/cd/E14571_01/doc.1111/e14309/devgtc.htm#BABDFDFE
    But Iam getting lost in the immerse details.
    Thanks in advance.

    Hi ,
    I tried creating one and am getting the following error while provisioning:
    SPML Response failed V2 schema validation
    Th eoracle document says :Ensure that the SPML response returned by the target system conforms to the SPML V2 standard specification
    Please help me with the same. What is it that needs to be done here.
    Thanks
    WIP

  • Studio Creator and Web Service Clients

    Can somebody please explain to me or point me to some actual documentation on how this junk works?
    I have a web service client that was generated from a wsdl file being used by my studio creator project... the web service has changed and now i need to update/replace the client with a new one. It seems like no matter what I do it wants to tag a '3' onto the end of the name of the web service port and also build it into the package names - requirign me to go to all the places in my code that use this client and fix it to have a stupid 3 in it....
    Just replacing web service clients appears to be a huge ordeal involving removing the client libraries from the library folder, and even going into the build-impl.xml to remove references to the old client jars...
    I can't find any options to specify the web service client jar which would allow me to just overwrite the old ones instead of creating these new ones with archaic numbers (e.g. 1384793814) on the end of them...
    Is there an easy way to wipe clean or update a web service from an entire project without leaving these ridiculous references everywhere? When I try to replace the name personService3 with personService in the web service client generator tool it tells me the name is already in use but I can't for the life of me find it...
    can somebody shed some light on this for me? please help before i yank all my hair out...
    Thanks....
    Message was edited by:
    kregan77

    Please see the article I wrote called, "Web Service Consumption Security" at http://devservices.sun.com/premium/jscreator/standard/reference/tips/ws_consumption_security.html
    This will give you an idea of what is supported for the current version of Creator. Also, if you want some other feature supported, please submit a detailed use case to this forum.
    Thanks!
    -David

Maybe you are looking for

  • Bitlocker without TPM and USB

    Hello Team, I am working for a company which has  Windows Server 2012 R2 domain server and mixture of Windows 7 and Windows 8 client computers. The problem is, I need to configure bit-locker in all client machine, but some machine doesn't have TPM. I

  • Aggregated and Disaggregated value not matching

    Hi, I have two levels: 1. Aggregated, this has cost center group 2. Disaggregated, where there are package for each cost center group above with associated cost centers respectively. When is disaggregated entry I enter value for each costcenter, the

  • How to install CC on 30 Imacs without downloading 30 times

    How to install CC on 30 iMacs without downloading 30 times? Thank You

  • Pages Video Tutorials: how do I find them?

    I don't seem to be able to find tutorials for Pages (or for Keynote, which I know exists). Not sure why this is so hard to find!!

  • Card Reader issue on Qosmio F50-10Z

    I have had this issue for a while, It began with the original os Vista 32 bit, so i decided to buy the toshiba upgrade cd for windows 7, after upgrading everything worked fine, except the card reader, no matter how many times i installed/uninstalled,