Adobe Photoshop Elements 12 does not work with Yosemite 10.10

My Adobe Photoshop Elements 12 does not work with Yosemite 10.10 nor does my Premier Elements 12. When I try to start them up I get the error message. After uninstalling and reinstalling a few times its still the same. Strangely enough PSE 11 seem to work with Yosemite.  I uninstalled my Premier Elements as well and it behave the same way. How do I get a new copy of Premier Elements 12 to reinstall?

Just to further test what is happening to my iMac on Yosemite is I downloaded the trial version of Photoshop CC and when I go to launch it it gives mr the same error message as when I try to launch PES 12 or Premier Elements 12. So whatever the problem is it involves all three and so upgrading to Photoshop CC doesn't even help.  Could there be an Adobe file damaged or missing somewhere that is common to these and yet does not effect Revel and Lightroom?

Similar Messages

  • Why is my adobe photoshop elements 12 not working. it says initializing and then it says there is an error and closes itself

    why is my adobe photoshop elements 12 not working. it says initializing then error and shuts itself down.

    Three things you can try:
    1. Clean the superdrive with a proprietory CD/DVD lens cleaner that uses tiny brushes.
    2. Perform an SMC reset:
    Resetting the SMC (System Management Controller) on Intel-based Macs:
    http://support.apple.com/kb/ht3964  and
    http://support.apple.com/kb/HT1237?viewlocale=en_US
    Resetting your Mac's PRAM and NVRAM:
    http://support.apple.com/kb/ht1379
    If you are using a Wireless Keyboard:
    http://support.apple.com/kb/TS3273
    3. Try the free DVD player VLC:
    http://www.videolan.org/vlc/
    which performs better than the built-in DVD Player.

  • Adobe Photoshop CS5 is not working with Lion.

    Adobe Photoshop CS5 is not working with Lion. It is totally non responsive to a point where i cannot work. all other CS5 programs seem to be running well so far. any advice? if no, then how do i revert back to Snow leopard?

    I had real problems with all Adobe apps - it said I needed to install a version of Jave Runtime, but kept saying that I wasn't connected to the internet to complete the action. This was not the case - I was connected to the internet.
    I followed this link : http://support.apple.com/kb/DL1421  to install a version of Java and all Adobe apps fire up now. Haven't done much testing within the apps, but at least I'm further ahead than I was.
    So thanks to the message boards for helping me out.
    Reg

  • I have aperture 3.4.4, which does not work with Yosemite. Is there a way to upgrade my Aperture version, or do I have to buy Aperture again?

    I have aperture 3.4.4, which does not work with Yosemite. Is there a way to upgrade my Aperture version, or do I have to buy Aperture again?

    If you own any version of Aperture 3, you are entitled to a free update. Only it can be tricky, if your version is not associated with your AppleID, because you bought it with a serial number.
    Have you checked, if you can see an update at the App Store Updates page? Or an "Accept" button on the Purchases tab of the app Store?
    Contact the AppStore Support and request a redeem code, to be able to buy the update for free. You will need to provide a proof op purchase of Aperture.
    Use this link: http://www.apple.com/support/mac/app-store/contact/
    Apple sent redeem codes for Aperture 3.6 to several users who had bought the version on disks, if they could provide a serial number.  See for example this discussion: (The post marked as the solution)
    Re: Aperture update not possible after update to Yosemite
    It is really unfortunate you missed the window of opportunity with Mavericks MacOS X 10.9.5, when the update was easy.

  • Final Cut Pro does not work with Yosemite. Can it be fixed?

    Final Cut Pro does not work with Yosemite. Can it be fixed?

    Hi Tom, I don't know if you can help me.
    I'm using Final Cut version 10.1.4 with Yosemite 10.10.2 and whenever I open FCP it opens for about 5 seconds (not allowing me to click anywhere) before closing with the message  "Final Cut Pro quit unexpectedly. click reopen to open the application again. This report will be sent to apple automatically." I have tried opening it multiple times and the same thing has been happening over and over again and i've tried everything I could find on the internet and nothing is working.
    HELP.
    Jada.

  • Photoshop 7 DOES NOT WORK with Leopard ( OS 10.5 )

    If you are not prepared to upgrade your Photoshop 7, DO NOT UPGRADE TO LEOPARD.
    Photoshop 7 and OS 10.5.x (Leopard) are not compatible. When Adobe released Photoshop 7 in 2001 as a Universal Binary for OS9 and OSX they had no idea that Apple would be switching to an Intel chip in 2006. As the release of Leopard is also the end of the Classic environment, this may be the reason Photoshop 7 does not work in Leopard.
    As of the release of CS4, Photoshop 7 can no longer be used as a path to upgrade Photoshop. A full version has to be bought now. But Photoshop CS or later can still be used as an upgrade to Photoshop CS4.
    It is recommended that Photoshop 7 owners still looking to save money on upgrades stay away from eBay, as, unfortunately, much of the software listed is pirated or misrepresented and you will still not be able to upgrade to CS4.
    [topic updated by Forum Host]

    There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

  • Adobe Flash Player does not work with Safari. What can I do?

    Hi,
    I have a MacBook Pro, Retina, 15 inch, late 2013,  2 GHz Intel Core i7, using OS X 10.9.4. I have installed Adobe Flash Player. In my System Preference, in the advanced settings, it is set to install updates also tells me that I have the NPAPI Plug-in (version 14.0.0.145) installed but not the PPAPI Plug-in. Is this the reason why it does not work with Safari (keeps telling me to download the app, which I did but still does not work)? Is there any way I could fix the problem? Please, help.
    Thanks.

    If you can't install or update Flash, follow these instructions.
    If you have installed the latest version of Flash, please take each of the following steps that you haven't already tried. After each step, relaunch Safari and test. For a "missing plug-in" error, start with Step 8. Back up all data before making any changes.
    Step 1
    You might have to log out or restart the computer before a Flash update takes effect.
    Step 2
    From the Safari menu bar, select
              Safari ▹ Preferences... ▹ Privacy ▹ Remove All Website Data...
    and confirm. Close the window. Then select
               ▹ System Preferences… ▹ Flash Player ▹ Advanced
    and click Delete All. Close the preference pane.
    Step 3
    If you're only having trouble with YouTube videos, log in to YouTube and load this page. You may see a link with the text "Leave the HTML5 Trial." If so, click that link.
    Step 4
    a. If you get a warning of a "blocked" or "outdated" plug-in, then select the Security tab in the Safari preferences window. In the list of plugins on the left, there should be one—and only one—entry for "Adobe Flash Player," showing the same version number that you installed. Select that entry. On the right there will be a list of websites for which you have specifically allowed Flash, if any. It's normal for the list to be empty. Below that is a menu labeled
              When visiting other websites
    From that menu, select either Allow or Ask.
    b. If you still get the alerts, then go back to the Flash Player preference pane and select the Advanced tab. Click Check Now. Quit and relaunch the browser.
    c. If the alerts still persist, triple-click anywhere in the line below on this page to select it:
    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources
    Right-click or control-click the highlighted text and select
              Services ▹ Open
    from the contextual menu.* A folder should open. Inside it, there should be a file named "XProtect.meta.plist". If that file is missing and you know why it's missing, restore it from a backup or copy it from another Mac running the same version of OS X. Otherwise, reinstall OS X.
    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select
              Go ▹ Go to Folder...
    from the menu bar and paste into the box that opens by pressing command-V. You won't see what you pasted because a line break is included. Press return.
    Step 5
    In the Safari preferences window, select the Advanced tab and uncheck the box marked
              Stop plug-ins to save power
    Step 6
    Open this folder as in Step 4:
    /Library/Internet Plug-Ins
    Delete the following item, or anything with a similar name, if present:
              Flash Player (failing).plugin 
    You may be prompted for your login password.
    Step 7
    Re-download and reinstall Flash. Download it from the domain "get.adobe.com". Don't click a link from any other website, including this one, because you can't trust links. They may be an attempt to trick you into installing malware masquerading as Flash. Type the address into the browser window. Never download a Flash update from anywhere else.
    Step 8
    If you get a "missing plug-in" error, select
              Safari ▹ Preferences... ▹ Security
    from the Safari menu bar and check the box marked  
              Allow (or Enable) plug-ins
    Then click the button marked
              Manage Website Settings...
    if present and make sure that the website is not blocked for Flash.
    Step 9
    Select
              Safari ▹ Preferences... ▹ Extensions
    from the Safari menu bar. If any extensions are installed, disable them.

  • Why does Photoshop Elements 6 not work with Apple OSX version 10.9?

    I have recently updated my MacBook Pro and my Mac desk top to OSx version 10.9 and now Photoshop elements 6 does not respond.  It opens and then stays frozen.  Nothing responds.  Does anyone have any suggestions for how to fix this issue?

    Specifically, this:
    http://forums.adobe.com/message/5860819
    But it is also very important to delete any existing preferences after a major OS X upgrade. For PSE 6 that would be:
    com.adobe.Photoshop.Elements.plist
    Adobe Photoshop Elements 6 paths
    Adobe Photoshop Elements 6 settings
    They're in your username>library>preferences. Here's how to find it in 10.9:
    http://www.cultofmac.com/251544/mavericks-makes-it-way-easier-to-access-your-library-folde r-os-x-tips/

  • Adobe Photoshop Elements 4.0 work with iTunes?

    I been using Adobe Photoshop Elements 3.0 and iTunes does see it and tranfer my photo to my iPod. i upgraded to Adobe Photoshop Elements 4.0 and now iTunes doesn't see it. on Apple support page, it said Adobe Photoshop Elements 3.0 and later but that isn't the case.
    Does anyone else having this issue or apple need to fix it?
    5G 60GB iPod   Windows XP Pro  

    You are going to have to contact Adobe on this one. We are other users.
    Sounds like it's not even an Apple question? Not sure.
    But the Adobe program changed, nothing changed in iTunes, right?

  • Adobe photoshop elements will not work?

    Adobe photoshop elements 8 will not work?

    What doesn't work, what happens when you try, and what operating system?

  • Photoshop Element 7 not working with Babylon 8

    I recently added Babylon 8 to my software.  I use it a lot as well as Elements 7 in my work.  Element 7 worked fine when I had Babylon 7 but when I upgraded to Babylon 8 Photoshop Element 7 stopped working.  Any ideas as to why and how to fix?

    You seem to have done most of the recommended troubleshooting procedures with FCP 7.
    All I can suggest is that you create a new User Account in System Preferences and try to install it under that.
    As you know, FCP 7 is now 4 years old (prehistoric in computer years) and was discontinued two years ago when Apple stopped supporting it, so there is little wonder that problems are arising with the latest OS, which can only get worse as the OS is updated.
    The alternatives are to move to something like Premiere Pro, if you  prefer a traditional interface/workflow or get Final Cut Pro X if you want to have cutting edge 21st. century technology supported by Apple.

  • Adobe photoshop 5.5 does not work with Yosemite

    When I upgraded my Mac to Yosemite, Adobe photoshop ceased to work. Is there any way of fixing this problem?

    Yosemite is known to break CS5 installs, so there are two ways to fix this:
    Install this Java for OS X 2014-001
    If that fails, reinstall CS5.5
    Gene

  • "Open with Photoshop Elements" does not work

    My picture does not open in Photoshop Elemtens when I use "open with" for a JPEG. The programm starts but no picture opens. What can I do?

    Any JPEG?
    How about other file types?
    See here:
    Files won't open in Photoshop Elements 11
    Re: jpeg files won't open in elements 10

  • Elements 12 not working with yosemite

    Is anyone else having issues with elements 12 working in the new yosemite upgrade? I can't move text or image boxes without the check/X boxes showing up, can't use eraser or lasso.

    Photoshop Elements doesn't respond when you use editing tools in Mac OS X 10.10

  • Adobe Photoshop Elements does not respond when quicktime is installed

    I currently have a Windows Vista PC with Photoshop Elements 5.0. Photoshop seems to work fine, however when Quicktime is installed, Photoshop stops working (sometimes immediately and sometimes within a few days). When Quicktime is installed, Photoshop will start, but freezes and never loads pictures. I read a post at another website with the same problem suggesting that I could unistall Quicktime and then reinstall. I tried uninstalling and Photoshop started working immediately. However, when I reinstalled Quicktime the same thing happened. I've tried this numerous times, both by installing Quicktime separately and as a package with iTunes. I would be fine w/o quicktime on my computer, however it seems that I need it in order to use iTunes. Any advice on what to do? Thanks.

    FYI, I'm using a Mac with the latest OS, whatever that's called.

Maybe you are looking for