Hand code or design with tool in netbean ?

Hello everybody, at first i am sorry for my best English. So last time my teacher taught me java with Netbean IDE. But he has just taught me with free design and null layout /:)
So now i don't know how to design GUI with layout. It's difficult. If when i work in a company so do i have to hand code or design with tools ? Sorry if my post are wrong in this box.

Well, IMO, when you learn to code with a tool, you are just learning the tool--you are now finding the facts about that the hard way. You need to go through the Java tutorial on GUI building and actually learn how to do it now. If you reacher is teaching how to use the GUI builder in NetBeans instead of how to build GUI's, he's doing you and everyone else a grave disservice.
When I find someone uses a code builder that is the point that their prospects usually start circling the drain unless they are willing to do a GUI development test using all manual tools; I've ran into far too many self proclaimed programmers that can use tool <name goes here> and really have no idea how to do anything except use that tool to get what ever that tool will produce--they cannot make a GUI or any other significant coding by themselves.

Similar Messages

  • Mapping Code to Design with UML Modelling

    Hello
    I want to know if I could map code to design automatically with using UML modelling function using JDeveloper 10.1.3? What I mean is... I know I could transform Java classes from Class Diagram, but, how about mapping code automatically with Sequence Diagram? By the way, what is the main function provides to us for other diagrams besides Java Class Diagram? Thank you.
    Charoite

    You can create a sequence diagram from a debugger session in JDeveloper by adding a breakpoint to your existing code and then picking Debug -> Debug with diagram. Every time you step into a class the sequence diagram will update, you can then save the diagram after ending your debug session and edit it from publication.
    JDeveloper does not support creating java code from the sequence diagram.
    Thanks,
    Geoff

  • Problem with code and design view

    When I try to have both the code and design view
    side by side in Dreamweaver CS4 on a PC -- I get the html code in both sections.
    How  do I see the layout while looking at the code?
    Thanks for help.
    Library Friend

    You've probably got View > Split Code checked.
    Click View > Code and Design

  • Migrating VB code to Java - what does Studio/NetBeans/Creator offer?

    I realise this may be a dumb question but I have tried searching various sites for any form answer/help and so far no joy.
    I am trying to understand what support/capability Studio/Creator/NetBeans offer to import Visual Basic code and spit out Java.
    There may be more hand cranking required than the tools can offer but if there was even some limited functionality and some documented ways of importing VB code that would be helpful.
    Thanks in advance.
    Paul

    Not only do they not provide that, neither does any
    OTHER Java tool out there - at least not one that
    would work to any real merit.
    Seriously, you aren't going to learn Java programming
    with a 'converter' tool. And the only way to realy
    BE a Java developer is to learn Java - and more
    importantly - learn OOP.Hi,
    Thanks for the comments.
    I have a customer who wants to retain their investment in application code (VB) and move forward using Java. Training in OOP and Java is obviously a must but like any business they have to explore how to retain investment previously made.
    Hence the question.
    It looks like a possible opportunity got some tool vendor out there.
    Thanks
    P

  • What can a non-coder reasonably accomplish with ADDT?

    Sorry to post again, but I suppose this is my fundamental issue: Apart from sprucing up forms with validation, etc. (which is of course nothing to sniff at), what can an independent web designer with limited PHP coding experience (and limited time to develop coding skills) reasonably use ADDT for?

    Paul,
    ADDT at it's most basic allows for creating tools that interact with a database. Both for submitting data, editing data, and displaying data.
    It makes it simple to create forms and dispay data because it connects directly to your database and reads in the database structure. This is a big time saver.
    Hand coding forms in PHP and doing all the validation manually takes a lot of time. One of the reasons is that almost every form you make is different from the last one. You have to manually add all the form fields and match them to your database fields. ADDT creates the forms based on your database structure and allows for a lot of customization and helps cut down on a lot of typing errors.
    Also, hand coding pages to display lists of data that does sorting and pagination also takes way too much time. The ADDT Dynamic List saves me more time than I can quantify. It reads the info from the database and asks you how you want it displayed. The list it creates
    is sortable, searchable and has pagination. Not to mention it allows you to delete, edit and add records when paired with the Dynamic Form Wizard.
    To answer your question: "what can an independent web designer with limited PHP coding experience (and limited time to develop coding skills) reasonably use ADDT for?"
    You can use it to create robust forms for entering, editing and deleting data. In these forms you can add lots of cool things like dependent dropdowns, date pickers, file uploading and email triggers just to name a few.
    Next you can easily display data from your database. The Dynamic List Wizard paired with the Dynamic Form Wizard allows you to create lists of data that are sortable, searchable, and editable. You can even add and delete records. There are also a lot of tools for displaying data on the front end of the site.
    The ease at which this can be done is hard to explain when compared to hand coding. I think anyone can use these tools with minimal programming skill.
    However, you are limited in some ways by lack of programming knowledge. The more complex your needs for manipulating the data entered are, the more programming knowledge you need. ADDT allows you to easily take data and put it in a database. If you need to change the value of the data, or calculate a new value based on what the customer entered, you would have to do hand coding using ADDT Custom Triggers.
    For me the price has been completely justified by the time I save over hand coding. Someone with a little coding ability will benefit most from ADDT. People with limited ability can easily create forms and list, but they are limited by their ability to manipulate data and do custom routines that are required for more dynamic sites(real estate sites, ticketing systems, or ecommerce sites for example).
    I'm always so longwinded :)
    Shane

  • How can i execute in the same block diagram two separate labview codes each one with diferent execution timings?

    Hello guys. I have been trying to solve this by a long time now...but i cant solve it....
    I have my main code in labview beying executed in one timed loop of 1second.....but now i need to pulse a lazer very fast than one second...
    my ideia was like executing the lazer pulse code in paralel with the main code but with a mutch faster timed loop....but when i put the second timed loop outside of the main one....it hapens that the aplication keeps runing only the faster loop and the main loop doesnt run....
    I really dont know how to solve this....
    many thanks
    JOSE

    JOSE,
    your code is really difficult to read. Please do some cleanup work, your diagram should be only little larger than an average computer screen. What I have glanced so far is that your code has a lot of beginner mistakes (overuse of local variables).
    For multi-loop applications, you shoul have a look at the tutorials concerning Producer-Consumer design pattern. The quick and dirty approach is to use locals (a bit contradictonary to suggest using locals here after I stated an overuse of them). The drawback will be, that you lose the latch mechanism of the button and must code it on your own (and make a big set of mistakes, using locals always attracts race conditions). Most important is that you write to your button only once, after all loops have finished spinning.
    Felix
    www.aescusoft.de
    My latest community nugget on producer/consumer design
    My current blog: A journey through uml

  • Designing with CSS in Design View

    Hey guys, I'm working on learning CSS. One problem I'm having
    is that while I'm working on the code, what shows in the design
    view in dreamweaver isn't the same, (not even close), to what it
    looks like in any browser. For example the location of a div will
    be totally different.
    It seems like it would be very hard to design this way. Why
    doesn't dreamweaver attempt to reflect what it looks like in one of
    the browsers. Is this just the way it is when designing with css?
    If so, how the heck do people do it? Do you just have to keep
    previewing the site every time you change the css?
    Using dreamweaver MX
    thanks, mike

    > Using dreamweaver MX
    Sadly, that's the dullest knife in the drawer. Is it DMX6.0
    or 6.1?
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.dreamweavermx-templates.com
    - Template Triage!
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    http://www.macromedia.com/support/search/
    - Macromedia (MM) Technotes
    ==================
    "southdaytona" <[email protected]> wrote in
    message
    news:f08qoq$bed$[email protected]..
    > Hey guys, I'm working on learning CSS. One problem I'm
    having is that
    > while
    > I'm working on the code, what shows in the design view
    in dreamweaver
    > isn't the
    > same, (not even close), to what it looks like in any
    browser. For
    > example the
    > location of a div will be totally different.
    >
    > It seems like it would be very hard to design this way.
    Why doesn't
    > dreamweaver attempt to reflect what it looks like in one
    of the browsers.
    > Is
    > this just the way it is when designing with css? If so,
    how the heck do
    > people
    > do it? Do you just have to keep previewing the site
    every time you change
    > the
    > css?
    >
    > Using dreamweaver MX
    >
    > thanks, mike
    >

  • Transparent design with router on both sides?

    I am looking to solve a design which has to work in two scenarios. Preferably with an in-line solution.
    1. Transparent design with VRF on both sides:
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      | ACE (Subnet A)
          |
          | (VLAN 12)
          |
    LAN-VRF
          |
          |  (VLAN 13)
          |
    Real servers (Subnet B)
    2. Transparent design in plain bridge mode
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      |
       ACE (Subnet A)
          |
          | (VLAN 12)
          |
    Real servers (Subnet A)
    As mentioned, I am aiming for a single design for both scenarios. A routed design will not pass in the first scenario and a one-arm solution will be inefficient in the second scenario. (both due to existing infrastructure) Is it possible to solve this with a transparent solution in both scenarios? I can't seem to get it to work.
    Thanks in advance for any help!

    I'm gonna expand my question a bit as I can not seem to get a working config in scenario 1. From the ACE I can ping the VRFs on both side of the ACE. I can on the other hand not ping neither the bvi-address of the ACE nor one VRF from the other. Can anyone notice any immediate errors in my config? Thanks in advance for any help!
    Addresses:
    10.3.66.1 - FW_VRF on client side
    10.3.66.6 - LAN_VRF on server side
    10.3.66.7 - BVI if on ACE
    ===Admin===
    resource-class TEST_res
    limit-resource all minimum 10.00 maximum unlimited
    boot system image:c4710ace-mz.A3_2_0.bin
    hostname 4710Appl
    interface gigabitEthernet 1/1
    description Management port
    switchport access vlan 752
    no shutdown
    interface gigabitEthernet 1/2
    description Client side LAN
    switchport trunk allowed vlan 2522
    no shutdown
    interface gigabitEthernet 1/3
    description Server side LAN
    switchport trunk allowed vlan 2524
    no shutdown
    interface gigabitEthernet 1/4
    shutdown
    access-list BPDU ethertype permit bpdu
    access-list ALL line 8 extended permit ip any any
    access-list everyone line 8 extended permit ip any any
    access-list everyone line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    4 match protocol snmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    description Management VLAN
    ip address 10.7.52.63 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1
    context TEST_context
    allocate-interface vlan 752
    allocate-interface vlan 2522
    allocate-interface vlan 2524
    member TEST_res
    context TEST_context_routed
    username admin password 5 $1$bale5EiS$bEdquz.bbcW3wRcfeSzbu/  role Admin domain
    default-domain
    username www password 5 $1$bsOdgxav$1uywtkwFEj3QalKaOTrkZ1  role Admin domain de
    fault-domain
    ssh key rsa 1024 force
    ===Application context===
    access-list ALL line 8 extended permit ip any any
    access-list ALL line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    ip address 10.7.52.64 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    interface vlan 2522
    description Client side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface vlan 2524
    description Server side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface bvi 1
    ip address 10.3.66.7 255.255.255.240
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1

  • Protecting code from design view?

    Can you configure the tag pattern that tells Dreamweaver to
    "leave this code alone in design view"?
    Dreamweaver does a good job of respecting code blocks (PHP,
    ASP, whatever) in design mode. However, we're going to have some
    people develop Smarty templates with Dreamweaver, so I need to
    specify the tag pattern of stuff that should only be accessible in
    code view.
    Is this possible?

    I found out how to do this. Open
    "configuration/ThirdPartyTags/Tags.xml". Add a new "directive_spec"
    tag there, defining the start and end tags. I also specified an
    icon to replace the code in design view.
    Works beautifully.

  • Delayed live screen drawing with tools in Photoshop. Video driver update?

    Delayed live screen drawing with tools in Photoshop CS5 on my iMac running system 10.6.7.
    Hi there. Recently, I've been having issues with the tools. There's a distinct DELAY in the live drawing. For example, if I open a random image, take the pencil, paintbrush, or even eraser tool, and I draw a large line across the image, I don't see anything. If I zoom in or out 1 click, I see the line. If I draw ANOTHER line, same thing - I need to zoom in or out to see it. With all of the tools. I've never had this issue before and it's incredibly frustrating (that might be an understatement as you can imagine - I use PS daily as I am a full-time designer.) Any ideas or solutions? I've already TRASHED my preferences and reset the tool. If it IS a driver issue (which is weird, because this issue just recently started happening) I contacted the driver manufacturer (AMD) and was told:
    "Unfortunately, Apple does not authorize us to release drivers for their products.
    All drivers are provided to Apple who then customize and release them to their customers.
    You will need to contact Apple to obtain the most current drivers for your product."

    You are correct - only Apple can deliver display drivers to you.  That's what you get with a Mac as Apple wants to be your "one stop shop" for support..
    Just curious:  Are you painting with large brushes and very small Spacing values?  That can cause some delay, though it normally catches up on its own - you don't have to do anything to make it happen.
    Have you tried disabling OpenGL Drawing in your Photoshop Edit - Preferences - Performance menu.  Restart Photoshop after making that change and before testing.
    -Noel

  • Use gcc/g++ with Tools.h++ in Solaris 8

    In Solaris 8, can I use gcc/g++ compiler to link a program with Tools.h++ library that is shipped with Sun CC compiler (Sun ONE studio 7).
    Thanks and regards,
    Luu Vo.

    Sun C++ and g++ generate incompatible binary code. You cannot mix binaries from the two compilers in one program, not even using shared libraries.
    For a detailed discussion of C++ binary compatibiltiy problems, see my paper "The Stability of the C++ ABI" at
    http://developers.sun.com/prodtech/cc/reference/techart/index.html

  • When I design with Muse and export as HTML Dreamweaver doesn't attach the style sheets. Any answers?

    When I design with Muse and export as HTML Dreamweaver doesn't attach the style sheets when I open the files with Dreamweaver. Essentially when I design with Muse the files don't render the same with Dreamweaver. Is this a bug? Any work arounds?

    Then you will have to install a local server and use live view.  It's not that DW isn't rendering it or isn't attaching it, it's that Muse decided to use server-side processing to include it which is ok for a CMS practice when you are combining stylesheets for better caching, but it really isn't ideal for a single style sheet.  This is a shortcoming of Muse and one of the reasons many professionals don't back the product at the moment.  That and you can't actually buy Muse, so unless you are on a subscription you don't have it.  It's trying to fill a void for those who don't want to invest in the professional design tools like Fireworks or Photoshop or Dreamweaver, but want a cross between them to make designs.  If you have invested in the subscription though and want a better way to make layouts I highly recommend coding it yourself and using Fireworks or Photoshop to do the layout for you.  There is an excellent tutorial on the devnet (3 parts) to show you how its done ( http://www.adobe.com/devnet/dreamweaver/articles/dw_fw_css_pt1.html ).  Once you start using Fireworks or Photoshop you will realize just how limited Muse is in design.

  • Split Code and Design will not stay

    I like the classic design with the split screen code on top and design on the bottom.  Somehow I have gotten it where it will also come up in code, the splot and design are greyed out.  I can force it to split with the layout, and I save this as a template.  But whenever I bring up a new page, I either have to reset the template or hit layout to force the split.  Very annoying.
    I have looked all over and I cannot see a setting.  Live view/Live code are off, in fact greyed out.  I just tried to reload the software completely and this did not reset it.

    I opened a case to Support, and they fixed it.  I needed to delete the Configuration file and then edit the regedit, removing the CS4 entry.  I did not have much in the way of customization,so it was not a big deal.
    My thanks to the Suport Team.
    Re-create the Dreamweaver preferences folder to eliminate problems that
    a damaged preferences files might cause.
    Note: When you use this solution, Dreamweaver will create a new
    preferences folder and you will lose custom settings associated with
    your current preferences file. However, the folder you rename in step 2
    is your original preferences file. If you determine that the preferences
    files is not causing the problem, then you can restore your custom
    settings by following the instructions below.
    Disclaimer: This procedure involves editing the Windows registry. Adobe
    doesn't provide support for editing the registry, which contains
    critical system and application information. Make sure to back up the
    registry before editing it. For more information about the registry, see
    the Windows documentation or contact Microsoft.
    To re-create the Dreamweaver preferences file:
    1. Quit Dreamweaver.
    2. Rename the Configuration folder (for example, Configuration old)
    in the "\Users\[user]\AppData\Roaming\Adobe\Dreamweaver CS4\(
    installation language)\" folder.
    3. Choose Start > type regedit, then press Enter, and click Continue
    for the next dialog box. (note, this did not work in Win 7, had to get help to find new regedit).
    4. Browse to the following location:
    HKEY_CURRENT_USER\Software\Adobe\Dreamweaver CS4 and delete the whole
    Dreamweaver CS4 folder then close the registry editor.
    5. Start Dreamweaver. Dreamweaver creates a new preferences file.
    If the problem continues, then the preferences file isn't the cause. To
    restore custom settings, delete the new preferences file and restore the
    original name of the previous preferences file.

  • Design methods & Tools

    Hi,
    What are the design methods & design tools in SAP?
    I am a functional consultant & looked/searched a lot in SDN/google but in vain.
    I need guidance on this please.
    Kindly do not lock with such haste.
    Thanks,
    Suz
    Moderator Message: locked without any haste, too vague, relation to ABAP development unclear, please keep looking for available information, do your own research before asking.
    Edited by: Thomas Zloch on Dec 13, 2010 12:31 PM

    What do yoy mean by Design methods & Tools in SAP ?
    Please be more clear about what is your exact requirement.

  • Lync 2013 Clients in Child Domain Log "The server returned HTTP status code '403 (0x193)' with text 'Forbidden'."

    Hey All, I am really stumped on this one. 
    Environment - Is using split DNS
    Forest Root Domain - Contains new Lync 2013 Server Standard, ADDS, DNS, Enterprise CA, Workstations
    Clients in this domain connect and work beautifully. No errors. 
    Child Domain - ADDS, DNS, Workstation, Lync 2013 client
    Client autodiscovers, and then asks for a password. Enter the password and this comes up...
    Can't sign in to Lync, You didnt get signed in, It might be your sign-in address or logon credentials..  blah blah blah" 
    Client log shows 
    Error:
    There was an error communicating with the endpoint at 'https://domainlync13srv.Domain.net/WebTicket/WebTicketService.svc'.
    The server returned HTTP status code '403 (0x193)' with text 'Forbidden'.
    The server understood the request, but cannot fulfill it.
    As far as i can tell certificates are correctly configured with all the SAN's possible in my forest. The user is correctly set up in Lync control panel. Autodiscovery seems to be working as it should. EWS is working correctly. 
    Repaired client, removed cached creds, has all lync 2013 updates no dice
    Thank you all! 

    I am an IDIOT. 
    I did not prepare the child domain with the LYNC setup tool. Logged on to a file server in the child domain with domain admin rights and sure enough the setup said the domain was "partial". Ran the setup and bam it all started working. 

Maybe you are looking for