Native sequence issue

Hi,
I have a News domain object which is mapped to a News table. I have inserted some sample data into the table. The newsid column reaches 81 and hence i created a sequence for this column like
CREATE SEQUENCE NEWS_SEQ START WITH 100 INCREMENT BY 50;
i configured toplink to use native sequencing and also set the pre-allocation size to 50.
When do a bulk insert .,toplink registers the objects and start to assign the sequence number. When it does a call to get the sequence number, the value returned is suprising.
2003.08.27 09:58:57.467--UnitOfWork(4435274)--Thread[Thread-22,5,main]--begin unit of work commit
2003.08.27 09:58:57.473--ClientSession(19256680)--Thread[Thread-22,5,main]--Execute query DataReadQuery()
2003.08.27 09:58:57.495--ServerSession(14765756)--Thread[Thread-22,5,main]--Connection(33038931)--SELECT NEWS_SEQ.NEXTVAL FROM DUAL
2003.08.27 09:58:57.526--ServerSession(14765756)--Thread[Thread-22,5,main]--sequencing preallocation for NEWS_SEQ: objects: 50 , first: 51, last: 100
2003.08.27 09:58:57.527--UnitOfWork(4435274)--Thread[Thread-22,5,main]--assign sequence to the object (51 -> oracle.otnsamples.ibfbs.toplink.News@1e4bece)
2003.08.27 09:58:57.527--UnitOfWork(4435274)--Thread[Thread-22,5,main]--assign sequence to the object (52 -> oracle.otnsamples.ibfbs.toplink.News@e77781)
when it does the insert, i get primary key constraint violation error ( since news ids 1 to 81 are already inserted as sample data).
i have created a sequence to start with 100, but how can news_seq.nextval be 50 ( first: 51 )
thanks in advance.
Regards
Elango.

When TopLink aquires a new sequence value with preallocation it assumes that the prevous 50 (preallocation size) of values are valid to be used.
i.e.
when we aquire 150 we assume we have 100-150, when we next aquire 200 we assume we have 150-200.
So you need to set the START WITH to 50 > than the actualy number you wish TopLink to start with. In your case this should be 150. In general if you wish to start with 1, then START WITH 50 should be used.

Similar Messages

  • Oracle native sequencing: nextVal executed two times.

    We are migrating from Weblogic 6.1 sp 5 & TopLink 3.6.3 to Weblogic 8.1 sp 2 & TopLink 9.0.4 and we are having this issue:
    It seems that when assigning the sequence to new objets TopLink execs the nextVal for the sequence twice. In fact we probably wouldn't notticed it if it was just that, the problem is that TopLink seems to register the object into the cache with an oid and assigning the next one to the object stored in the database so we are getting NoSuchObjectException each time we try to access them.
    Here is a dump of TopLink's log showing the problem:
    [TopLink]: ServerSession(22807116)--Connection(0)--client acquired
    [TopLink]: ClientSession(25858791)--Connection(0)--acquire unit of work: 10772417
    [TopLink]: UnitOfWork(10772417)--Connection(0)--JTS register
    [TopLink]: ServerSession(22807116)--Connection(17740413)--SELECT SEQ_BOOK.NEXTVAL FROM DUAL
    [TopLink]: ServerSession(22807116)--Connection(17558511)--SELECT SEQ_PAGE.NEXTVAL FROM DUAL
    [TopLink]: UnitOfWork(10772417)--Connection(0)--Before JTS Completion
    [TopLink]: UnitOfWork(10772417)--Connection(25919386)--Begin batch statements
    [TopLink]: UnitOfWork(10772417)--Connection(25919386)--INSERT INTO AUTHOR (NAME, OCA, OID) VALUES (?, ?, ?)
    [TopLink]: UnitOfWork(10772417)--Connection(0)-- bind => [Roger Penrose, 2004-05-11 18:54:01.917, 442803]
    [TopLink]: UnitOfWork(10772417)--Connection(25919386)--End Batch Statements
    [TopLink]: ClientSession(25858791)--Connection(25919386)--Begin batch statements
    [TopLink]: ClientSession(25858791)--Connection(25919386)--INSERT INTO BOOK (NAME, OCA, OID, OID_AUTHOR) VALUES (?, ?, ?, ?)
    [TopLink]: ClientSession(25858791)--Connection(0)-- bind => [The Emperor's New Mind, 2004-05-11 18:54:01.92, 347404, 442803]
    [TopLink]: ClientSession(25858791)--Connection(0)-- bind => [Shadows of the Mind, 2004-05-11 18:54:01.943, 347405, 442803]
    [TopLink]: ClientSession(25858791)--Connection(25919386)--End Batch Statements
    [TopLink]: UnitOfWork(10772417)--Connection(0)--After JTS Completion
    [TopLink]: UnitOfWork(10772417)--Connection(0)--release unit of work
    [TopLink]: ClientSession(25858791)--Connection(0)--client released
    [TopLink]: ServerSession(22807116)--Connection(0)--client acquired
    [TopLink]: ClientSession(116689)--Connection(0)--acquire unit of work: 32580168
    [TopLink]: UnitOfWork(32580168)--Connection(0)--JTS register
    [TopLink]: UnitOfWork(32580168)--Connection(0)--Before JTS Completion
    [TopLink]: UnitOfWork(32580168)--Connection(17129104)--Begin batch statements
    [TopLink]: UnitOfWork(32580168)--Connection(17129104)--INSERT INTO AUTHOR (NAME, OCA, OID) VALUES (?, ?, ?)
    [TopLink]: UnitOfWork(32580168)--Connection(0)-- bind => [Benoit Mandelbrot, 2004-05-11 18:54:49.264, 442805]
    [TopLink]: UnitOfWork(32580168)--Connection(17129104)--End Batch Statements
    [TopLink]: ClientSession(116689)--Connection(17129104)--Begin batch statements
    [TopLink]: ClientSession(116689)--Connection(17129104)--INSERT INTO BOOK (NAME, OCA, OID, OID_AUTHOR) VALUES (?, ?, ?, ?)
    [TopLink]: ClientSession(116689)--Connection(0)-- bind => [Les objets fractals, forme, hasard et dimension, 2004-05-11 18:54:49.266, 347409, 442805]
    [TopLink]: ClientSession(116689)--Connection(0)-- bind => [The Fractal Geometry of Nature, 2004-05-11 18:54:49.282, 347408, 442805]
    [TopLink]: ClientSession(116689)--Connection(17129104)--End Batch Statements
    [TopLink]: UnitOfWork(32580168)--Connection(0)--After JTS Completion
    [TopLink]: UnitOfWork(32580168)--Connection(0)--release unit of work
    [TopLink]: ClientSession(116689)--Connection(0)--client released
    the test is about creating two objects (well, we are actually creating 6 objects in this sample as we are creating two "master" objects and adding two related (in a one to many relationship) objects to each one.)
    The thing I would like you to notice is this:
    The first AUTHOR object gets assigned the OID 442803 wether the next AUTHOR object gets the OID 442805 although we expected it to be 442804.
    The same occurs with the objects in the "many" side of the relation. They get sibiling OIDs but with a gap of two OIDs when creating the last two.
    I have been searching for simmilar problems in this forums and I found two posts:
    Both where related to a bug of an older version of TopLink (9.0.3 I think) when using something different than a number for the sequence field of an object. I expect it to be fixed in 9.0.4 version as it seemed to be fixed even for the 9.0.3 version. May it be a regression bug?
    Anyway, we are using BigDecimal on entity bean's sequence number and IIRC NUMBER(18) in Oracle tables.
    Currently our TopLink version is: 9.0.4 (031126)
    Our native sequence has an allocation size of 200 and it matches with SEQUENCEs defined in Oracle.
    As we are migratting from TopLink 3.6.3 and we have not changed the sequence prealocation size (we have not touched the database at all) we don't expect the problem to be on sequence prealocation.
    I must say we have changed the "default" JDBC driver that TopLink uses when doing the issuing the loging phase (which I think is a SUN driver) to an oracle.jdbc.driver.OracleDriver as we were having problems with timestamp locking.
    Any idea?
    Thanks in advance.
    Ignacio.

    Solved!
    It was my fault. I was doing a really nasty thing to the entity beans.
    I must publicly thank my work mate (which is a pretty smart girl, I must say) in tracking down this issue.
    Here is what (we think) was happening:
    As I told in previous post in this post we are in the process of moving from TopLink 3.6.3 (EJB 1.1) to TopLink 9.0.4 (EJB 2.0). We do have a "super class" in our application where we had some common things of our entity beans, i.e. entityContext, oid and oca attributes. We have also some methods that retrieve and set values from and to the entity beans via value objects (in order to avoid the heavy RMI operations when doing it through "standard" getters and setters) well, it happened that the current implementation of the "batch setting" method used the getDeclaringMethods to update in both UPDATE and INSERT opperations entity attributes with the data of the value object.
    When switching to EJB 2.0 we had to push down both the oid and oca attributes (in order of being able do deploy them) to each final entity bean and now they where being included in the setting process!
    You can imagine an scenario like this:
    1. ejbCreate() // TopLink issues the SELECT SEQ_XXX NEXT VAL FROM DUAL and sets the oid of the EJB
    2. setAttributes() // transfer info from the value object to the newly created EJB: including a setOid(null)!
    3. commit() (Before Completion)
    4. TopLink detects that the damm object surprisingly DOES NOT have the oid attribute setted so it performs another SELECT SEQ_XXX NEXT VAL FROM DUAL in order to "fix" this big problem.
    5. commit() (After Completion) // the object is written to the database with the second value from the sequence whereas the first value is used to identify the entity bean into the identity cache.
    Well it may not be "exactly" what is happening but I'm sure we are not so far from reality with our assumptions.
    Andrei Ilitchev, thanks for your interest, sorry I could not post this sooner.

  • Oracle 11g : Sequence Issues after impdp

    Hi All,
    We are migrating from Oracle 10g to Oracle 11g. As part of this, we take a expdp from 10g and successfully did an import using impdp on to Oracle 11g database.
    But the problem is, there were few Primary key violations which occurred and all of them relate to sequences.
    The Maximum data in the tables and the last number in the sequences differed which caused the issue.
    Upon investigation and browsing the Web, http://www.nerdliness.com/article/2009/03/18/my-oracle-sequencedatapump-shenanigans ; I understood it could be because of the export taken while the application is online and writing to the database.
    I reset all the failing sequences manually and it is fine now.
    My questions now are
    *1) Can we ascertain that the export taken when the source database is offline would eliminate the sequences issue.*
    2) As this is being done in Production, I would like to make few checks to ensure that the sequences are properly imported. ---
    Again reading few websites and oracle Forums, i found the below sql's..
    select table_name, column_name, utl_raw.cast_to_number(high_value) as highval
    from dba_Tab_columns
    where owner = 'PRODUCTION_OWNER'
    AND DATA_TYPE= 'NUMBER'
    AND (OWNER, TABLE_NAME, COLUMN_NAME) IN
    (SELECT CC.OWNER, CC.TABLE_NAME, CC.COLUMN_NAME
    FROM DBA_CONS_COLUMNS CC
    JOIN DBA_CONSTRAINTS C
    ON CC.OWNER=C.OWNER
    AND CC.CONSTRAINT_NAME=C.CONSTRAINT_NAME
    WHERE C.CONSTRAINT_TYPE ='P'
    ORDER BY 3;
    SELECT SEQUENCE_NAME, MIN_VALUE, MAX_VALUE, LAST_NUMBER
    FROM DBA_SEQUENCES
    WHERE SEQUENCE_OWNER = 'PRODUCTION_OWNER'
    ORDER BY LAST_NUMBER
    If I relate the last_number with the highval and if they are same, does that mean the sequences are imported properly.
    Note: We have sequence caching done and we are on RAC.
    Edited by: ramakrishnavydyula on Jan 30, 2013 9:36 AM

    We are migrating from Oracle 10g to Oracle 11g. As part of this, we take a expdp from 10g and successfully did an import using impdp on to Oracle 11g database.
    But the problem is, there were few Primary key violations which occurred and all of them relate to sequences.
    The Maximum data in the tables and the last number in the sequences differed which caused the issue.
    it could be because of the export taken while the application is online and writing to the database.I don't know what's your database's size , and what's acceptable downtime for you, but I could never propose such a migration tecnique to any of my customers, due to excessive downtime when databases are quite large.
    It's quite obvious that you get such errors when the export is done while people are working, unless you use FLASHBACK_SCN or FLASHBACK_TIME parameter while exporting. But in this case, assuming you don't get errors (e.g. ORA-01555), you'll probably lose a lot ot transactions.
    Assuming your 10g database is running in archivelog mode (which should be the default in production DBs) did you think of using RMAN to do the migration ?

  • Sequence issue with Toplink 9048

    We are trying to get sequences to work using Toplink 9.048 but keep getting errors. We reference are sequences in our descriptors like the following:
    descriptor.setSequenceNumberFieldName("ACRS_APPOINTMENT.ID");
    descriptor.setSequenceNumberName("ACRS_APPOINTMENT_SEQ");
    and have gotten this functionality to work in 10.1.3 using this reference in the sessions.xml:
    <sequencing>
         <default-sequence xsi:type="native-sequence">
              <name>Native</name>
              <preallocation-size>1</preallocation-size>
         </default-sequence>
    </sequencing>
    however when we try to get this to work using 9.048 we get the following error:
    2006.01.09 12:03:19.342--ClientSession(15015527)--Thread[HttpRequestHandler-26533782,5,main]--Execute query ValueReadQuery()
    2006.01.09 12:03:19.358--ServerSession(2573832)--Thread[HttpRequestHandler-26533782,5,main]--Connection(374929)--SELECT SEQ_COUNT FROM SEQUENCE WHERE SEQ_NAME = #SEQ_NAME
    2006.01.09 12:03:19.374--ClientSession(15015527)--Thread[HttpRequestHandler-26533782,5,main]--Exception [TOPLINK-4002] (OracleAS TopLink - 10g (9.0.4.8) (Build 050712)): oracle.toplink.excep
    tions.DatabaseException
    Exception Description: java.sql.SQLException: ORA-00911: invalid character
    Internal Exception: java.sql.SQLException: ORA-00911: invalid character
    Error Code: 911Local Exception Stack:
    Exception [TOPLINK-4002] (OracleAS TopLink - 10g (9.0.4.8) (Build 050712)): oracle.toplink.exceptions.DatabaseException
    Exception Description: java.sql.SQLException: ORA-00911: invalid character
    Internal Exception: java.sql.SQLException: ORA-00911: invalid character
    Error Code: 911
    at oracle.toplink.exceptions.DatabaseException.sqlException(DatabaseException.java:227)
    at oracle.toplink.internal.databaseaccess.DatabaseAccessor.executeCall(DatabaseAccessor.java:698)
    at oracle.toplink.threetier.ServerSession.executeCall(ServerSession.java:506)
    We have tried setting uses-native-sequencing to true in the sessions.xml but still get this error.
    Any help on what the exact syntax we need to enter to get it to try to read the separate sequences we have setup in the descriptors instead of trying to access a SEQUENCE object would be appreciated.
    Thanks,
    Mark

    Mark,
    Have you looked at the examples shipped with 9.0.4.X. The 2-tier Employee example uses a sequence table and works as expected.
    The #SEQ_NAME in the SQL almost looks like the sequence query is be customized instead of using the default generated SQL string.
    Doug

  • Native sequencing problem

    Hi all,
    I'm using Oracle9i database together with TopLink 9.0.4
    and I can't get started native sequencing.
    I've created a sequence using following script:
    CREATE SEQUENCE "ITMS"."SEQUENCE" INCREMENT BY 1 START WITH 1
    MAXVALUE 1.0E28 MINVALUE 1 NOCYCLE
    CACHE 50 NOORDER
    I've set up the project and session to use native sequencing, plus I've run the following code once:
    Project project = XMLProjectReader.read("project.xml");
    DatabaseSession session = project.createDatabaseSession();
    SchemaManager schemaManager = new SchemaManager(session);
    schemaManager.createSequences();
    but it's still not working.
    Then I've tried default sequencing option, but it's the same.
    Only the third option using custom sequence table works.
    Did anybody make it work or am I doing anything wrong?
    Any help will be appreciated.
    Roman

    sorry, my mistake, it's ok now

  • Wacky image sequence issue - flickers

    Hi guys,
    I've created a simple 2 image sequence I wanted to play through at the top of my DPS document - but when I preview the article (on both desktop, iphone and ipad) the image sequence fails..
    I took a quick screencap to show what Im going.
    DPS Image Sequence issue - YouTube
    Any advice?

    For a two-image effect, I would use a slideshow instead of an image sequence. Not sure what's causing the flicker.

  • Native sequences in DB2

    Hi,
    I've just read in the docs that native sequences for DB2 are not supported.
    Blissfully unaware of this, we have been using native sequencing with db2 (and toplink 9.0.3) and it worked OK. After updating to 9.0.4, it stopped working (same id is used several times).
    What is the problem with db2 sequences? Is there a plan to support them some time in the future?
    Thank you,
    Ana Oleski

    Cache connect does not cache Oracle sequences; so if you need to share the same Oracle sequence in both TimesTen and Oracle, then you will need to go to Oracle and retrieve the nextval each time.
    Simon

  • Use oracle native sequence

    How one can use oracle native sequence in Insert/update in a Toplink POJO?
    Thanks in advance...

    Just set the Oracle Sequence name as the descriptor's sequence name (ClassDescriptor.setSequenceName()), and configure your Session to use native sequencing.
    If you are using JPA you need to use a @SequenceGenerator see,
    http://en.wikibooks.org/wiki/Java_Persistence/Identity_and_Sequencing#Sequence_objects
    James : http://www.eclipselink.org

  • Why is the  "Use Native Sequencing" option disabled ?

    I am trying Toplink with SQL Server and I have some identity fields... I see in the documentation that I should select the "Use Native Sequencing" option in the mapping properties(Database Info tab) but it is disabled(I use JDeveloper 10.1.2.1.0). Is there any reason for this ?
    Thanks in advance.

    Native sequencing should be configurable for the SQL Server platform. I have filed a bug to track this.
    The easiest workaround is to select a different database platform (i.e. Oracle) and then enable native sequencing. You should then set it back to SQL Server. In my quick test it kept the native sequencing configuration even though it shows as disabled.
    Doug

  • QoS / Native VLAN Issue - Please HELP! :)

    I've purchased 10 Cisco Aironet 2600 AP’s (AIR-SAP2602I-E-K9 standalone rather than controller based).
     I’ve configured the WAP’s (or the first WAP I’m going to configure and then pull the configuration from and push to the others) with 2 SSID’s. One providing access to our DATA VLAN (1000 – which I’ve set as native on the WAP) and one providing access to guest VLAN (1234). I’ve configured the connecting DELL switchport as a trunk and set the native VLAN to 1000 (DATA) and allowed trunk traffic for VLAN’s 1000 and 1234. Everything works fine, when connecting to the DATA SSID you get a DATA IP and when you connect to the GUEST SSID you lease a GUEST IP.
    The problem starts when I create a QoS policy on the WAP (for Lync traffic DSCP 40 / CS5) and try to attach it to my VLAN’s. It won’t let me attach the policy to VLAN 1000 as it’s the native VLAN. If I change VLAN 1000 on the WAP to NOT be the native VLAN I can attach the policies however wireless clients can no longer attach to either SSID properly as they fail to lease an IP address and instead get a 169.x.x.x address.
    I'm sure I'm missing something basic here so please forgive my ignorance.
    This is driving me insane!
    Thanks to anyone that provides assistance. Running config below and example of the error...
    User Access Verification
    Username: admin
    Password:
    LATHQWAP01#show run
    Building configuration...
    Current configuration : 3621 bytes
    ! Last configuration change at 02:37:59 UTC Mon Mar 1 1993 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname LATHQWAP01
    logging rate-limit console 9
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    no ip routing
    dot11 syslog
    dot11 vlan-name Data vlan 1000
    dot11 vlan-name Guest vlan 1234
    dot11 ssid LatitudeCorp
       vlan 1000
       authentication open
       authentication key-management wpa version 2
       wpa-psk ascii
    dot11 ssid LatitudeGuest
       vlan 1234
       authentication open
       authentication key-management wpa version 2
       guest-mode
       wpa-psk ascii
    crypto pki token default removal timeout 0
    username admin privilege 15 password!
    class-map match-all _class_Lync0
    match ip dscp cs5
    policy-map Lync
    class _class_Lync0
      set cos 6
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 1234 mode ciphers aes-ccm
    encryption vlan 1000 mode ciphers aes-ccm
    ssid LatitudeCorp
    ssid LatitudeGuest
    antenna gain 0
    stbc
    station-role root
    interface Dot11Radio0.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 subscriber-loop-control
    bridge-group 255 spanning-disabled
    bridge-group 255 block-unknown-source
    no bridge-group 255 source-learning
    no bridge-group 255 unicast-flooding
    service-policy input Lync
    service-policy output Lync
    interface Dot11Radio1
    no ip address
    no ip route-cache
    encryption vlan 1234 mode ciphers aes-ccm
    encryption vlan 1000 mode ciphers aes-ccm
    ssid LatitudeCorp
    ssid LatitudeGuest
    antenna gain 0
    no dfs band block
    stbc
    channel dfs
    station-role root
    interface Dot11Radio1.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio1.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 subscriber-loop-control
    bridge-group 255 spanning-disabled
    bridge-group 255 block-unknown-source
    no bridge-group 255 source-learning
    no bridge-group 255 unicast-flooding
    service-policy input Lync
    service-policy output Lync
    interface GigabitEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    interface GigabitEthernet0.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 spanning-disabled
    no bridge-group 1 source-learning
    interface GigabitEthernet0.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 spanning-disabled
    no bridge-group 255 source-learning
    service-policy input Lync
    service-policy output Lync
    interface BVI1
    ip address 10.10.1.190 255.255.254.0
    no ip route-cache
    ip default-gateway 10.10.1.202
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    line vty 0 4
    transport input all
    end
    LATHQWAP01#conf
    Configuring from terminal, memory, or network [terminal]? t
    Enter configuration commands, one per line.  End with CNTL/Z.
    LATHQWAP01(config)#int dot11radio1.1000
    LATHQWAP01(config-subif)#ser
    LATHQWAP01(config-subif)#service-policy in
    LATHQWAP01(config-subif)#service-policy input Lync
    set cos is not supported on native vlan interface
    LATHQWAP01(config-subif)#

    Hey Scott,
    Thank you (again) for your assistance.
    So I' ve done as instructed and reconfigured the WAP. I've added an additional VLAN (1200 our VOIP VLAN) and made this the native VLAN - so 1000 and 1234 are now tagged. I've configure the BVI interface with a VOIP IP address for management and can connect quite happily. I've configured the connecting Dell switchport as a trunk and to allow trunk vlans 1000 (my DATA SSID), 1200(native) and 1234 (MY GUEST SSID). I'm now back to the issue where when a wireless client attempts to connect to either of my SSID's (Guest or DATA) they are not getting a IP address / cannot connect.
    Any ideas guys? Forgive my ignorance - this is a learning curve and one i'm enjoying.
    LATHQWAP01#show run
    Building configuration...
    Current configuration : 4426 bytes
    ! Last configuration change at 20:33:19 UTC Mon Mar 1 1993 by Cisco
    version 15.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname LATHQWAP01
    logging rate-limit console 9
    enable secret 5
    no aaa new-model
    no ip source-route
    no ip cef
    dot11 syslog
    dot11 vlan-name DATA vlan 1000
    dot11 vlan-name GUEST vlan 1234
    dot11 vlan-name VOICE vlan 1200
    dot11 ssid LatitudeCorp
       vlan 1000
       authentication open
       authentication key-management wpa version 2
       mobility network-id 1000
       wpa-psk ascii
    dot11 ssid LatitudeGuest
       vlan 1234
       authentication open
       authentication key-management wpa version 2
       mbssid guest-mode
       mobility network-id 1234
       wpa-psk ascii
       no ids mfp client
    dot11 phone
    username CISCO password
    class-map match-all _class_Lync0
     match ip dscp cs5
    policy-map Lync
     class _class_Lync0
      set cos 6
    bridge irb
    interface Dot11Radio0
     no ip address
     encryption vlan 1000 mode ciphers aes-ccm
     encryption vlan 1234 mode ciphers aes-ccm
     ssid LatitudeCorp
     ssid LatitudeGuest
     antenna gain 0
     stbc
     mbssid
     station-role root
    interface Dot11Radio0.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 subscriber-loop-control
     bridge-group 255 spanning-disabled
     bridge-group 255 block-unknown-source
     no bridge-group 255 source-learning
     no bridge-group 255 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio0.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio0.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 subscriber-loop-control
     bridge-group 254 spanning-disabled
     bridge-group 254 block-unknown-source
     no bridge-group 254 source-learning
     no bridge-group 254 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio1
     no ip address
     encryption vlan 1000 mode ciphers aes-ccm
     encryption vlan 1234 mode ciphers aes-ccm
     ssid LatitudeCorp
     ssid LatitudeGuest
     antenna gain 0
     peakdetect
     no dfs band block
     stbc
     mbssid
     channel dfs
     station-role root
    interface Dot11Radio1.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 subscriber-loop-control
     bridge-group 255 spanning-disabled
     bridge-group 255 block-unknown-source
     no bridge-group 255 source-learning
     no bridge-group 255 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio1.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio1.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 subscriber-loop-control
     bridge-group 254 spanning-disabled
     bridge-group 254 block-unknown-source
     no bridge-group 254 source-learning
     no bridge-group 254 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface GigabitEthernet0
     no ip address
     duplex full
     speed auto
    interface GigabitEthernet0.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 spanning-disabled
     no bridge-group 255 source-learning
     service-policy input Lync
     service-policy output Lync
    interface GigabitEthernet0.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 spanning-disabled
     no bridge-group 1 source-learning
    interface GigabitEthernet0.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 spanning-disabled
     no bridge-group 254 source-learning
     service-policy input Lync
     service-policy output Lync
    interface BVI1
     mac-address 881d.fc46.c865
     ip address 10.10. 255.255.254.0
    ip default-gateway 10.10.
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    line vty 0 4
     login local
     transport input all
    sntp server ntp2c.mcc.ac.uk
    sntp broadcast client
    end
    LATHQWAP01#

  • Navigation very slow and not able to enter in memory a sequence issue

    Hello,
    we have a big problem with oracle forms performance since we deployed our
    application to the web. all our customers are not confortable with this new
    environment because the sytem are very slow and working it's very difficult.
    our application is very slow in point of when the user use very quickly the key
    functions it doens't work.
    I explain :
    for example, we have a button &Verifier (alt+v : acces key to this button) and
    when clicking to button we have a dialox box that contains 2 buttons:
    Oui(alt+O:access key) and Non(alt+N:access key) and if we click Oui(alt+O) it
    popup as an information box and we must click Ok(alt+O: access key).
    then if we click quickly alt+v after alt+o after alt+o it doens't work and it
    wait to click againt alt+o.(like the system doesn't follow or has not yet enter all the sequence in the memory)
    before in client/server it work's fine.
    it's like our application in the web it's not able to entered in memory a
    serial of access key.
    please can you help me the problem is always occuring in the production
    environment.
    our environment:
    - oracle jiniator :1.3.1.22
    OAS 10G (9041)
    DATABASE 9206
    - the complete version of forms : 9.0.4.0.19
    - we have 23 USERS.
    any help are welcome, the problem are urgent.
    thank you.

    Hi
    Lets analyse and hope to narrow down your issue
    We have used the Pick and Pack Manager to release goods from Sales Order through to Invoice. The functionality offered is good,
    > Slow performance could be triggered by multile issue  , so lets wait
    > Do you know PICKand PACK manager is only for status ,but it actually doesn't affect inventory level .
    but in practise the system is so slow it is taking 2 to 3 times longer than copying to a Sales Invoice.
    > You need to do delivery first and transfer the delivery into invoice .
    Is there any way of cutting out part of the process to speed things up? What we really need is to be able to create an invoice(s) straight from the Pick and Pack manager.
    >> It basically depends upon your business process . but by software , You can bypass Pick and PACK Manager process. You can transfer  your sales order into A/R invoice  and while posting A/R invoice , inventory will be reduced .
    Hope this help to narrow down your issue
    thank you
    Bishal

  • Nested Sequence issue: keyframe scale setting changes after rendering?

    Hi,
    I'm using PremierePro CS5.5, and have been having this same issue since CS4. After nesting a group of clips, I make the timeline effects entries to animate the nested sequence. For this example, let's say I start at 00.00 with the scale set at 150%, and end the sequence with the scale set to 300%. Just zooming in. Looks OK, so I hit return and render the nested sequence. It plays back, all is good, but after it stops the 00.00 setting magically changes to 100% or some other percentage.  I've tried everything I can think of, from selecting Hold or Linear for the keyframe, to deleting all the keyframes and redoing the settings. It only happens with nested sequences and it seems to only be the scale setting that goes flukey. Anybody else have this happen and could you tell me what I am doing wrong?
    Thanks,
    Christy

    Thanks for checking it out Jim. It doesnt happen every time, you know how that goes... just often enough to drive me batty. I'm doing animated whiteboard videos. Lots of short bits of video layered with graphics and stills, some effects, then all that is nested and sometimes the rate compressed. Then I zoom in a bit and that seems to be the last straw. Maybe I am just doing too much? It's a simple, uncomplicated look to the finished piece, but it takes a lot of cuts and tweaks to get it that way.

  • Drag and Drop Image Sequence Issue

    Hello,
    Im having trouble dragging and dropping an image sequence folder. The folder drags in perfectly and the window even highlights but nothing happens. However when I go through FILE and IMPORT i do have success bringing in the image sequence as comp.

    > Is there anyplace to go to find known bugs with the program incase something like this arises in the future?
    We often post solutions to known issues on the Technical Support part of our site.
    I'll go ahead and write up a quick list of known issues in After Effects CC (12.2) with workarounds.
    Regarding the update that we thought we'd be releasing this week: We ran into a problem in which one of our fixes broke something else (which is why we do the testing), and we're having to redo some things. My current estimate is that the update will not come out this week but will come out some time within the next couple of weeks. Sorry for the delay, but we need to get this right more than we need to get it out fast.
    I'll post a summary of workarounds tomorrow to bridge the time between now and when the update is released.

  • Goa line item sequencing issue

    Hello experts,
    I am facing a problem in GOA line item sequencing in SRM 4.0.
    I create a GOA with lets say 3 line items and distribute it successfully to the backend.
    Now if I want to add extra items using option 'Add Calaog items' from R/3 material and service catalog. The new items that I select and tranfer to SRM are created under line item 53 54  and so on..
    Why is this gap in the line items and why I can't I get the new line items in proper sequence?
    Please help.
    Thanks and regards,
    CM

    Hello CM,
    Have you received any repsonse on this? we are facing same issue.

  • Anyconnect 2.5 and 3.1 on C1841 - Sequence issues

    Hi All,
    I have been trying to get this right for a while now and can't find documentation or anyone having the same issue, so probably I'm missing something.
    Here is the issue: Some clients are using Anyconnect 2.5 due to OS requirements and some other running on Win8 need to connect using Anyconnect 3.1
    This is working fine at the moment with the following swquence numbers
    #sh run | in install
    webvpn install svc flash:/webvpn/anyconnect-win-2.5.3046-k9.pkg sequence 1
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.05152-k9.pkg sequence 2
    webvpn install svc flash:/webvpn/anyconnect-macosx-i386-3.1.05152-k9.pkg sequence 3
    webvpn install svc flash:/webvpn/anyconnect-macosx-i386-2.5.6005-k9.pkg sequence 4
    Now if I change the sequence number for 3.1  to be preferred
    #sh run | in install
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.05152-k9.pkg sequence 1
    webvpn install svc flash:/webvpn/anyconnect-win-2.5.3046-k9.pkg sequence 2
    webvpn install svc flash:/webvpn/anyconnect-macosx-i386-3.1.05152-k9.pkg sequence 3
    webvpn install svc flash:/webvpn/anyconnect-macosx-i386-2.5.6005-k9.pkg sequence 4
    users running 2.5 are no longer able to connect to the VPN and the following error shows up
    Is there a limitation I am not aware of?
    Thank you

    AnyConnect 3.1 is a significant upgrade, even over 3.0.
    Over 3.0 it adds an enhanced GUI (common between Windows and Mac), NAM enhancement, crypto suite B enhancements, HostScan/Posture performance enhancements, IPv6 support, better untrusted certificate handling, plug-in component tiles, etc.
    3.0+ offers IPSec VPN client as opposed to SSL VPN.

Maybe you are looking for