Need some help on data encryption in Forms 6i with Oracle Database.

Hi,
Here is my requirement:
I have a username and a password field, and i can add new users to it and ofcourse set a password for it.This password will be visible as asteriks on the forms but i want it to entered in the encrypted format in the database in the designated table.Can anyone help me with this.(hope my question is clear!!!)
Thanks,
Aparna.
null

Hi,
try it in the follwing very simple way:
translate each character of the password to it's ascii value and add a constant value you like. e.g. i = asc(substr(pwstring,i,1)) + k. concatenate each char-value of i(whitch have to be a fix length string of f.e. 4 digits) to build op the encrypted string. you can rich up this by calculating k in differents ways like:
K = offset + i. and by the way this encryption can call n times, mean encrypt the encryption, if you want.
the decryption is yout turn ;-)
hope this will help you...
Regrads
biki
null

Similar Messages

  • Need  some help on data selection

    Hi all,
       In COST dbtable there are fields TKG001, TKG002, ... TKG016.
    From this i need to select one according to month.
    ie., if month is January i need to select TKG001,
                         June    i need to selct TKG006 and so on.
    How can i do this. Please help me in this.

    Write one select to fetch all the fields and in the program, filter out from he internal table only those ields that u require..

  • Need some help about Win 8.1 and linux with a dual boot

    Hi!
    I have a Lenovo z50-70 notebook and I have a Windows 8.1 on it. (The one which was shipped with this notebook...)
    My concerns are Intalling Linux as a dual boot and loosing Windows 8.1.
    As I am not familiar to Win 8.1, the product key is in the ?BIOS? and there's a lot of partitions...
    If I install Linux Ubuntu (latest version) as a dual boot by manually making the partitions, etc. and then if I lose my Windows 8.1 system, how can I get it back?
    I've made a backup of the system to the portable hdd but I don't know can I restore it, as I have no win installation disc and I am not sure if i can restore win 8.1 from the backup by using random win 8 installation disc that I've made from the downloaded ISO (for e.g. Win 8.1 pro iso from internet)...
    I need a Linux distro for developing my Android ROM but I don't want to lose that Win 8.1 OS from my notebook. So.. What should I do?

    Did you do a full disc backup of the C: Drive using a backup tool other than windows? If you did, then the recover of that partition will be up to your backup software.
    If worse comes to worse, you can use the novo button to restore your computer to what it was like when it came from the factory. But there really is nothing to worry about. Create your new partition and just make sure that you install Linux to that partition. Make sure it is not the same size as any other partition, that way even if the Linux installer does not show the volume labels, you can tell which partition you want to install Linux in just by the size.
    Hoov
    Microsoft MVP - Consumer Security
    SpywareHammer.com

  • How to Connect Forms or any version with Oracle Databases 8/6i/9i/10i/11i

    I want to know that how can i cannect Developer Forms / Reports with Oracle Databases with various versions and say developer 2000 to Oracel 6i/9i/10i/11i etc

    Using the appropriate setting in tnsnames.ora file located in your [Forms_Home]\network\admin directory.
    Sim

  • Need some help: my itunes won't sync with my iphone anymore. Both softwares are up to date and I've reinstalled itunes. After I reinstall, it syncs. But then when I reboot my computer, it no longer syncs anymore and I have to keep reinstalling itunes. Tho

    Need some help: my itunes won't sync with my iphone anymore. Both softwares are up to date and I've reinstalled itunes. After I reinstall, it syncs. But then when I reboot my computer, it no longer syncs anymore and I have to keep reinstalling itunes. Thoughts???

    thought that it was possible to have the same iTunes library on any machine that was authorised, a kind of cloud-iTunes I guess. 
    That would convenient, but sadly it is not the case. Sorry!
    Either way your welcome and best of luck!
    B-rock

  • The backup disk image "/Volumes/Data/David Witkowski's Mac Pro.sparsebundle" is already in use.  Whenever Time Machine starts to backup to Time Capsuel I get the previous error message. I need some help to fix this.

    The backup disk image “/Volumes/Data/David Witkowski’s Mac Pro.sparsebundle” is already in use.  Whenever Time Machine starts to backup to Time Capsuel I get the previous error message Where can I find this disk image?. I need some help to fix this.
    Thanks,
    David W

    There are multiple answers and solutions if you look just to the right under the heading of More Like This.

  • I bought a new song, but it won't play on my Mac or iPod. Everything is up to date. I need some help.

    I bought a new song on itunes, but for some reason it won't play on my itunes library or Ipod. It skips to another song. Need some help on this if you can spare your time.

    Hello
    Thanks for using Apple Support Communities.
    For more information on this, take a look at:
    iTunes repeatedly prompts to authorize computer to play iTunes Store purchases
    http://support.apple.com/kb/ts1389
    Best of luck,
    Mario

  • Need some Help configuring sip

    Hi all ! ,
    Im kind off new to sip calling and cisco telephony , but here goes ,: i have a 2821 router with CME installed
    IOS : C2800NM-IPVOICEK9-M
    Sofware version : 15.1(4)M4 / CME 8.6
    Attached to GE0/0 is a CISCO 3750 switch
    GEO - consisfts of 3 VLANS  , the native
    172.22.1.X
    172.22.100.X VOICE
    172.22.101.X DATA
    my tftpserver = 172.22.1.150
    i need some help configuring a sip trunk , i have 10 testing phonenumbers from vodafone , but i do not know where to start to get this working
    i have tried
    http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml
    but im getting stuck with what to fill in where .. is there anyone form NL whom has the same setup ? or similar ? or can give me some guidance on how to make the test calls

    ok.. here goes
    Building configuration...
    Current configuration : 9721 bytes
    ! Last configuration change at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone CET 1 0
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 E1 0/0/0
    network-clock-select 2 E1 0/0/1
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp pool VOICE
    network 172.22.100.0 255.255.255.0
    option 150 ip 172.22.1.150
    default-router 172.22.100.1
    ip dhcp pool DATA
    network 172.22.101.0 255.255.255.0
    default-router 172.22.101.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    ip address trusted list
      ipv4 172.22.1.50
      ipv4 172.22.1.51
      ipv4 172.22.100.1
      ipv4 172.22.101.1
      ipv4 62.140.159.225
    callmonitor
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server expires max 3600 min 3600
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    codec preference 4 g729br8
    voice register global
    voice translation-rule 1
    rule 1 /5123781291/ /601/
    rule 2 /5123781290/ /600/
    voice translation-rule 2
    rule 1 /^112$/ /112/
    voice translation-rule 3
    rule 1 /^.*/ /0262610290/
    voice translation-rule 4
    rule 2 /600/ /5123788000/
    rule 3 /601/ /5123788001/
    rule 4 /^2(..)$/ /51237812\1/
    voice translation-profile CUE_Voicemail/AutoAttendant
    translate called 1
    voice translation-profile PSTN_CallForwarding
    translate redirect-target 4
    translate redirect-called 4
    voice translation-profile PSTN_Outgoing
    translate calling 3
    translate called 2
    translate redirect-target 4
    translate redirect-called 4
    voice-card 0
    crypto pki token default removal timeout 0
    controller E1 0/0/0
    framing NO-CRC4
    pri-group timeslots 1-31
    controller E1 0/0/1
    framing NO-CRC4
    pri-group timeslots 1-31
    ip ftp username cisco
    ip ftp password cisco123
    ip tftp source-interface GigabitEthernet0/0.1
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    no keepalive
    interface GigabitEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 172.22.1.51 255.255.255.0
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.22.101.1 255.255.255.0
    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip address 172.22.100.1 255.255.255.0
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex full
    speed 100
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/0/1:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 16
    ip http path flash:gui
    ip route 0.0.0.0 0.0.0.0 172.22.1.50
    tftp-server flash:7941/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
    tftp-server flash:7941/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
    tftp-server flash:7941/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
    tftp-server flash:7941/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
    tftp-server flash:7941/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn
    tftp-server flash:7941/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
    tftp-server flash:7941/term41.default.loads alias term41.default.loads
    tftp-server debug
    control-plane
    voice-port 0/0/0:15
    voice-port 0/1/0
    voice-port 0/1/1
    voice-port 0/0/1:15
    voice-port 2/0/0
    voice-port 2/0/1
    voice-port 2/0/2
    voice-port 2/0/3
    voice-port 2/0/4
    voice-port 2/0/5
    voice-port 2/0/6
    voice-port 2/0/7
    voice-port 2/0/8
    voice-port 2/0/9
    voice-port 2/0/10
    voice-port 2/0/11
    voice-port 2/0/12
    voice-port 2/0/13
    voice-port 2/0/14
    voice-port 2/0/15
    voice-port 2/0/16
    voice-port 2/0/17
    voice-port 2/0/18
    voice-port 2/0/19
    voice-port 2/0/20
    voice-port 2/0/21
    voice-port 2/0/22
    voice-port 2/0/23
    mgcp profile default
    dial-peer voice 1 voip
    description **Incomming Call from SIP Trunk**
    translation-profile incoming CUE_Voicemail/AutoAttendant
    session protocol sipv2
    session target ipv4:172.22.1.50
    incoming called-number .%
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9........
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 3 voip
    description **Outgoing Call to SIP Trunk **
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 4 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[0-1][2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 5 voip
    description **911 Outgoing Call to SIP trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 6 voip
    description **Emergency Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 7 voip
    description **911/411 Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]11
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 8 voip
    description **International Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9011T
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 9 voip
    description **Star Code to SIP Trunk**
    destination-pattern *..
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 10 voip
    description **CUE Voicemail**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 600
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 11 voip
    description **CUE Auto Attendant**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 601
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    sip-ua
    authentication username 0262610290 password 7 15020A1F173D24362C realm 62.140.1
    59.225
    authentication username 0262610290 password 7 021605481811003348
    no remote-party-id
    retry invite 2
    retry register 10
    timers connect 100
    registrar ipv4:62.140.159.225 expires 3600
    sip-server ipv4:62.140.159.224
    host-registrar
    telephony-service
    max-ephones 58
    max-dn 192
    ip source-address 172.22.100.1 port 2000
    calling-number initiator
    system message testing
    cnf-file location TFTP tftp://172.22.1.150/
    load 7960-7940 P00307020200.loads
    load 7941 SCCP41.8-4-2S.loads
    load 7941GE SCCP41.8-4-2S
    time-format 24
    dialplan-pattern 1 26261029.. extension-length 3 extension-pattern 9..
    voicemail 600
    max-conferences 12 gain -6
    call-forward pattern 9.T
    moh music-on-hold.au
    web admin system name admin password password
    dn-webedit
    time-webedit
    transfer-system full-consult
    secondary-dialtone 9
    directory entry 1 101 name 101
    create cnf-files version-stamp 7960 Jan 02 2014 08:40:49
    ephone-dn  1
    number 290 secondary 0262610290
    name Phone 1
    hold-alert 30 originator
    ephone-dn  2
    number 291 secondary 0262610291
    name phone 2
    hold-alert 30 originator
    ephone-dn  3
    number 292 secondary 0262610292
    name Phone 3
    hold-alert 30 originator
    ephone-dn  4
    number 293 secondary 0262610293
    name Phone 4
    hold-alert 30 originator
    ephone-dn  5
    number 294 secondary 0262610294
    label Phone 5
    hold-alert 30 originator
    ephone  1
    mac-address 0019.E88F.3BDD
    button  1:1
    ephone  2
    mac-address 001E.4A92.0A27
    type 7961
    button  1:2
    ephone  3
    mac-address 0012.43F5.03AF
    button  1:3
    ephone  4
    mac-address 000F.F7AC.502A
    button  1:4
    ephone  5
    mac-address 0019.E851.090A
    button  1:5
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    ntp master
    end

  • Need some help frist time useing dreamweaver

    Hey all,
    I am totaly new to Dreamweaver and am needing some help. I am
    needing to make a feedback form. Would need it to e-mail me the
    feedback to something like [email protected] I also need to know
    how to make a footer for the copyright and desiged by, on each page
    without having to manually entering them. Any help I could get
    would be awsome.

    There are only two ways to process form data -
    1. Use mailto:[email protected]m as the action of the form
    2. Use a server-side scripting method to a) harvest the
    form's data, b)
    process it in some manner, e.g., enter it into a database, c)
    formulate and
    send an email to one or more email recipients, and d)
    redirect the visitor
    to some ending page
    Method 1 is quite simple, and is also the least reliable. It
    depends both
    on your visitor having an email client already installed on
    their computer -
    this eliminates public computers, or home users without email
    clients
    installed (more and more it seems) - and on the installed
    email client
    responding to
    the mailto call. It is not possible to use this method *and*
    send the
    visitor to a
    thank you page as well.
    Method 2a is the preferred method, since it eliminates the
    problems of
    method
    1, but it means that you have to grapple with
    server-scripting somehow (ASP,
    CF, PHP, perl, etc.).
    Method 2b would be to use some third-party form processing,
    like
    http://www.bebosoft.com/products/formstogo/.
    You would have to decide which of these methods is best for
    your needs,
    but if it's Method 2a, then start by asking your host what
    they provide for
    form
    processing. If it's 2b, then read their FAQ/instructions
    carefully.
    For your footer, investigate the use of DW's Templates (use
    F1 Help to read
    about them), or of server-side includes (again, F1 Help will
    give you some
    info here, as will Google).
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    ==================
    "Xysos_Designs" <[email protected]> wrote in
    message
    news:[email protected]
    > Hey all,
    > I am totaly new to Dreamweaver and am needing some help.
    I am needing to
    > make
    > a feedback form. Would need it to e-mail me the feedback
    to something like
    > [email protected] I also need to know how to make a
    footer for the
    > copyright
    > and desiged by, on each page without having to manually
    entering them. Any
    > help
    > I could get would be awsome.
    >

  • TS1702 I need some help the apps were downloading slowly

    The apps downloaded but it didn't cause it's stuck in downloading mode what should I do?
    The iOS 6 update didn't work.
    Please I need some help.
    The apps didn't download.
    Talking Angela and Ginger didn't download.
    Talking Santa didn't update.

    Try moving the existing backup file to a safe location so that iTunes has to create an entire new file.  The backup file is located here. You can delete that backup once you get a successfull backup.
    iTunes places the backup files in the following places:
    Mac: ~/Library/Application Support/MobileSync/Backup/
    Windows XP: \Documents and Settings\(username)\Application Data\Apple Computer\MobileSync\Backup\
    Windows Vista and Windows 7: \Users\(username)\AppData\Roaming\Apple Computer\MobileSync\Backup\
    Note: If you do not see the AppData or Application Data folders, you may need to show hidden files (Windows XP,  Windows Vista and Windows 7), or iTunes may not be installed in the default location. Show hidden files and then search the hard drive for the Backup directory.

  • Need some help...in need of a different way.

    Hi, I'm new to Java and need some help. I have 2 questions that are similar in nature.
    1st Question:
    In a program that I'm writting I have a do-while loop which at the end brings up a dialog box that asks the user to enter '1' for 'Yes' or '2' for 'No' to continue.
    I would rather have the option of having the user enter 'y' or 'Y' for Yes and 'n' or 'N' for No.
    Here is what I have currently:
    int x;
    String data;
    do{
    //Blah blah code
    data = JOptionPane.showInputDialog(null, "Enter 1 for Yes or 2 for No");
    x = Integer.parseInt(data);
    }while(x == 1);
    x++;
    2nd Question:
    In another part of my program I have a Case statement that asks the user to enter a number or a letter from a list of choices. They can enter '2' , 't', or 'T'.
    I would rather have all of this in an if-else chain. Is this possibe? if so, how would I do it.
    Thanks.

    I would rather have the option of having the user enter 'y' or 'Y' for Yes and 'n' or
    'N' for No. You can test the first letter of whatever the user inputs like this:String response = JOptionPane.showInputDialog(null, "Enter (Y)es or (N)o");
    response = response.toLowerCase();
    if(response.startsWith("y")) {
        // the user entered something starting with y
    } else if(response.startsWith("n")) {
        // the user entered something starting with n
    } else {
        // what are you going to do?
    }JOptionPane also has versions that would allow yes/no buttons. Eg, see:
    http://java.sun.com/docs/books/tutorial/uiswing/components/dialog.html

  • Please I need some help with a table

    Hi All
    I need some help with a table.
    My table needs to hold prices that the user can update.
    Also has a total of the column.
    my question is if the user adds in a new price how can i pick up the value they have just entered and then add it to the total which will be the last row in the table?
    I have a loop that gets all the values of the column, so I can get the total but it is when the user adds in a new value that I need some help with.
    I have tried using but as I need to set the toal with something like total
        totalTable.setValueAt(total, totalTable.getRowCount()-1,1); I end up with an infinite loop.
    Can any one please advise on some way I can get this to work ?
    Thanks for reading
    Craig

    Hi there camickr
    thanks for the help the other day
    this is my full code....
    package printing;
    import java.awt.*;
    import java.awt.event.*;
    import java.awt.print.*;
    import javax.swing.*;
    import javax.swing.table.*;
    import java.text.DecimalFormat;
    public class tablePanel
        extends JDialog  implements Printable {
      BorderLayout borderLayout1 = new BorderLayout();
      private boolean printing = false;
      private Dialog1 dialog;
      JPanel jPanel = new JPanel();
      JTable table;
      JScrollPane scrollPane1 = new JScrollPane();
      DefaultTableModel model;
      private String[] columnNames = {
      private Object[][] data;
      private String selectTotal;
      private double total;
      public tablePanel(Dialog1 dp) {
        dp = dialog;
        try {
          jbInit();
        catch (Exception exception) {
          exception.printStackTrace();
      public tablePanel() {
        try {
          jbInit();
        catch (Exception exception) {
          exception.printStackTrace();
      private void jbInit() throws Exception {
        jPanel.setLayout(borderLayout1);
        scrollPane1.setBounds(new Rectangle(260, 168, 0, 0));
        this.add(jPanel);
        jPanel.add(scrollPane1, java.awt.BorderLayout.CENTER);
        scrollPane1.getViewport().add(table);
        jPanel.setOpaque(true);
        newTable();
        addToModel();
        addRows();
        setTotal();
    public static void main(String[] args) {
      tablePanel tablePanel = new  tablePanel();
      tablePanel.pack();
      tablePanel.setVisible(true);
    public void setTotal() {
      total = 0;
      int i = table.getRowCount();
      for (i = 0; i < table.getRowCount(); i++) {
        String name = (String) table.getValueAt(i, 1);
        if (!"".equals(name)) {
          if (i != table.getRowCount() - 1) {
            double dt = Double.parseDouble(name);
            total = total + dt;
      String str = Double.toString(total);
      table.setValueAt(str, table.getRowCount() - 1, 1);
      super.repaint();
      public void newTable() {
        model = new DefaultTableModel(data, columnNames) {
        table = new JTable() {
          public Component prepareRenderer(TableCellRenderer renderer,
                                           int row, int col) {
            Component c = super.prepareRenderer(renderer, row, col);
            if (printing) {
              c.setBackground(getBackground());
            else {
              if (row % 2 == 1 && !isCellSelected(row, col)) {
                c.setBackground(getBackground());
              else {
                c.setBackground(new Color(227, 239, 250));
              if (isCellSelected(row, col)) {
                c.setBackground(new Color(190, 220, 250));
            return c;
        table.addMouseListener(new MouseAdapter() {
          public void mouseClicked(MouseEvent e) {
            if (e.getClickCount() == 2) {
            if (e.getClickCount() == 1) {
              if (table.getSelectedColumn() == 1) {
       table.setTableHeader(null);
        table.setModel(model);
        scrollPane1.getViewport().add(table);
        table.getColumnModel().getColumn(1).setCellRenderer(new TableRenderDollar());
      public void addToModel() {
        Object[] data = {
            "Price", "5800"};
        model.addRow(data);
      public void addRows() {
        int rows = 20;
        for (int i = 0; i < rows; i++) {
          Object[] data = {
          model.addRow(data);
      public void printOut() {
        PrinterJob pj = PrinterJob.getPrinterJob();
        pj.setPrintable(tablePanel.this);
        pj.printDialog();
        try {
          pj.print();
        catch (Exception PrintException) {}
      public int print(Graphics g, PageFormat pageFormat, int pageIndex) throws PrinterException {
        Graphics2D g2 = (Graphics2D) g;
        g2.setColor(Color.black);
        int fontHeight = g2.getFontMetrics().getHeight();
        int fontDesent = g2.getFontMetrics().getDescent();
        //leave room for page number
        double pageHeight = pageFormat.getImageableHeight() - fontHeight;
        double pageWidth =  pageFormat.getImageableWidth();
        double tableWidth = (double) table.getColumnModel().getTotalColumnWidth();
        double scale = 1;
        if (tableWidth >= pageWidth) {
          scale = pageWidth / tableWidth;
        double headerHeightOnPage = 16.0;
        //double headerHeightOnPage = table.getTableHeader().getHeight() * scale;
        //System.out.println("this is the hedder heigth   " + headerHeightOnPage);
        double tableWidthOnPage = tableWidth * scale;
        double oneRowHeight = (table.getRowHeight() +  table.getRowMargin()) * scale;
        int numRowsOnAPage = (int) ( (pageHeight - headerHeightOnPage) / oneRowHeight);
        double pageHeightForTable = oneRowHeight *numRowsOnAPage;
        int totalNumPages = (int) Math.ceil( ( (double) table.getRowCount()) / numRowsOnAPage);
        if (pageIndex >= totalNumPages) {
          return NO_SUCH_PAGE;
        g2.translate(pageFormat.getImageableX(), pageFormat.getImageableY());
    //bottom center
        g2.drawString("Page: " + (pageIndex + 1 + " of " + totalNumPages),  (int) pageWidth / 2 - 35, (int) (pageHeight + fontHeight - fontDesent));
        g2.translate(0f, headerHeightOnPage);
        g2.translate(0f, -pageIndex * pageHeightForTable);
        //If this piece of the table is smaller
        //than the size available,
        //clip to the appropriate bounds.
        if (pageIndex + 1 == totalNumPages) {
          int lastRowPrinted =
              numRowsOnAPage * pageIndex;
          int numRowsLeft =
              table.getRowCount()
              - lastRowPrinted;
          g2.setClip(0,
                     (int) (pageHeightForTable * pageIndex),
                     (int) Math.ceil(tableWidthOnPage),
                     (int) Math.ceil(oneRowHeight *
                                     numRowsLeft));
        //else clip to the entire area available.
        else {
          g2.setClip(0,
                     (int) (pageHeightForTable * pageIndex),
                     (int) Math.ceil(tableWidthOnPage),
                     (int) Math.ceil(pageHeightForTable));
        g2.scale(scale, scale);
        printing = true;
        try {
        table.paint(g2);
        finally {
          printing = false;
        //tableView.paint(g2);
        g2.scale(1 / scale, 1 / scale);
        g2.translate(0f, pageIndex * pageHeightForTable);
        g2.translate(0f, -headerHeightOnPage);
        g2.setClip(0, 0,
                   (int) Math.ceil(tableWidthOnPage),
                   (int) Math.ceil(headerHeightOnPage));
        g2.scale(scale, scale);
        //table.getTableHeader().paint(g2);
        //paint header at top
        return Printable.PAGE_EXISTS;
    class TableRenderDollar extends DefaultTableCellRenderer{
        public Component getTableCellRendererComponent(
          JTable table,
          Object value,
          boolean isSelected,
          boolean isFocused,
          int row, int column) {
            setHorizontalAlignment(SwingConstants.RIGHT);
          Component component = super.getTableCellRendererComponent(
            table,
            value,
            isSelected,
            isFocused,
            row,
            column);
            if( value == null || value .equals("")){
              ( (JLabel) component).setText("");
            }else{
              double number = 0.0;
              number = new Double(value.toString()).doubleValue();
              DecimalFormat df = new DecimalFormat(",##0.00");
              ( (JLabel) component).setText(df.format(number));
          return component;
    }

  • My airport problem has returned big time --Need some Help!!

    Aloha once again:
    I though that this was fixed by simply changing channels on my airport router, but that fix only lasted for a few days, but now it's back and even worse. Let me give you some background on this problem. Here's my original message concerning the problem:
    I have my Airport Router connected to the Internet via DSLcable. I then tie my two computers into the internet via their airport cards. For about 6 months this system has been working just fine. Recently my desktop computer quit listening to the router and can no longer connect to the internet. It shows no signal strength and the name of the network on the Airport is not seen in the "connect to internet" panel. The same Airport works just fine on my LapTop and I am using it right now to get this message off to the internet.
    I have fixed permissions, removed the airport card and cleaned the connector, the antenna plug and removed the system configuration folder from library preferences all to no avail!
    This problem has been hounding me, intermittently, for over a year now What can I do to remedy this??? HELP!!!!
    Dan Page
    Maui, Hawaii
    The suggestion to change channels, that came from this original request, worked but just for a very short time. Now I have to shut down my computer overnight to get connected and then it only lasts for several hours and the connection quits.
    I thought maybe heat was a problem, but the last time it happened I opened the computer and played a large fan right on the card. This did not help. I shut it down for the night and it was fine the next morning for about 2 hours.
    One new data point; if I turn off just the airport on my laptop computer overnight, that will fix the problem for a short time also.
    Still need some help!!!
    Dan

    First, power off both the Time Capsule and AirPort Express.
    Wait a few minutes, then power up the Time Capsule first, and let it run for a few minutes.
    Temporarily, move the AirPort Express to the same room or close proximity to the AirPort Express and power it up.
    If the Express powers up correctly, power it off again and move it approximately half the distance between the Time Capsule and the general area that needs more wireless coverage. Try to minimize obstructions like walls, ceiling, heavy furniture, etc as much as possible. 
    Please report on your results.

  • Need some help with a Macally enclosure and a spare internal drive

    Need some help with a Macally enclousure
    Posted: Oct 1, 2010 10:55 AM
    Reply Email
    Aloha:
    I have a Macally PHR-S100SUA enclousure that does not recognise,my WD 1001fals hard drive. It has worked just fine with other internal drives, but not this one?
    This is a spare internal drive that I am trying to make an external drive to store back ups for a lot of data. But so far I can not get it recognized by the computer. Maybe I need different drivers?
    Any suggestions?
    Dan Page

    Hi-
    Drivers aren't typically needed for external enclosures.
    Macally has none listed for that enclosure.
    The same is true for the WD drive, internal or external; no drivers.
    With the exception of high end PM multi drive enclosures, I can't think of any that use drivers.
    How is the external connected?
    Have you tried different cables, different ports?
    Bad/damaged cables are fairly common.
    Have you verified connections inside of the enclosure?

  • Need some help with downloading PDF's from the net.

    need some help with downloading PDF's from the net.  Each time I try to click on a link from a website, if it takes me to a new screen to view a pdf, it just comes up as a blank black screen?  any suggestions?

    Back up all data.
    Triple-click the line of text below to select it, the copy the selected text to the Clipboard (command-C):
    /Library/Internet Plug-ins
    In the Finder, select
    Go ▹ Go to Folder
    from the menu bar, or press the key combination shift-command-G. Paste into the text box that opens (command-V), then press return.
    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari, and test.
    The "Silverlight" web plugin distributed by Microsoft can also interfere with PDF display in Safari, so you may need to remove it as well, if it's present.
    If you still have the issue, repeat with this line:
    ~/Library/Internet Plug-ins
    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

Maybe you are looking for

  • Timeline Saying Clips are Offline, when Browser Shows Clips to be OK

    I have a few clips in my timeline that fews the OFFLINE WINDOW. Yet when I check my browser, the clips have no offline slash and can be seen as edited in the canvas. How do I make the clips show normally on the timeline. Also clips are trying to show

  • IC webclient doesn't work for role IC_AGENT

    Hi, we've got a major problem with our CRM 7.0 SP02 web UI: When starting the web UI and choosing business role IC_AGENT, the screen shows the message "Starting SAP CRM", however, the browser stops loading the page, actually the browser says that the

  • ABAP HR Report Category

    What is the best Report Category for the selection fields personnel no, personnel area, personnel subarea, employee group, employee subgroup, organizational unit? Thanks Vicky

  • CS3 windows icons, slow to open

    Hi I have CS3.  In windows explorer, when I right click on a graphics file such as a .pdf, it now takes a long time to open.  Because Adobe prepares a snapshot of that image.  But all I really want to do is to rename the file, I don't need to see the

  • Asha 501.1: Wireless error: Can't load this page a...

    Hello. I have a Nokia Asha 501.1 running Asha Platform 1.0. I am using this a test device and I do not have a SIM card and just trying to use the device over WiFi. However, when I open the Internet app and browse to a URL, I receive the following err


HashFlare