Sequence issue with Toplink 9048

We are trying to get sequences to work using Toplink 9.048 but keep getting errors. We reference are sequences in our descriptors like the following:
descriptor.setSequenceNumberFieldName("ACRS_APPOINTMENT.ID");
descriptor.setSequenceNumberName("ACRS_APPOINTMENT_SEQ");
and have gotten this functionality to work in 10.1.3 using this reference in the sessions.xml:
<sequencing>
     <default-sequence xsi:type="native-sequence">
          <name>Native</name>
          <preallocation-size>1</preallocation-size>
     </default-sequence>
</sequencing>
however when we try to get this to work using 9.048 we get the following error:
2006.01.09 12:03:19.342--ClientSession(15015527)--Thread[HttpRequestHandler-26533782,5,main]--Execute query ValueReadQuery()
2006.01.09 12:03:19.358--ServerSession(2573832)--Thread[HttpRequestHandler-26533782,5,main]--Connection(374929)--SELECT SEQ_COUNT FROM SEQUENCE WHERE SEQ_NAME = #SEQ_NAME
2006.01.09 12:03:19.374--ClientSession(15015527)--Thread[HttpRequestHandler-26533782,5,main]--Exception [TOPLINK-4002] (OracleAS TopLink - 10g (9.0.4.8) (Build 050712)): oracle.toplink.excep
tions.DatabaseException
Exception Description: java.sql.SQLException: ORA-00911: invalid character
Internal Exception: java.sql.SQLException: ORA-00911: invalid character
Error Code: 911Local Exception Stack:
Exception [TOPLINK-4002] (OracleAS TopLink - 10g (9.0.4.8) (Build 050712)): oracle.toplink.exceptions.DatabaseException
Exception Description: java.sql.SQLException: ORA-00911: invalid character
Internal Exception: java.sql.SQLException: ORA-00911: invalid character
Error Code: 911
at oracle.toplink.exceptions.DatabaseException.sqlException(DatabaseException.java:227)
at oracle.toplink.internal.databaseaccess.DatabaseAccessor.executeCall(DatabaseAccessor.java:698)
at oracle.toplink.threetier.ServerSession.executeCall(ServerSession.java:506)
We have tried setting uses-native-sequencing to true in the sessions.xml but still get this error.
Any help on what the exact syntax we need to enter to get it to try to read the separate sequences we have setup in the descriptors instead of trying to access a SEQUENCE object would be appreciated.
Thanks,
Mark

Mark,
Have you looked at the examples shipped with 9.0.4.X. The 2-tier Employee example uses a sequence table and works as expected.
The #SEQ_NAME in the SQL almost looks like the sequence query is be customized instead of using the default generated SQL string.
Doug

Similar Messages

  • Query caching issue with Toplink version 10.1.3.5.0

    We are in the process of upgrading the toplink version from 9.0.4.7 to 10.1.3.5.0
    We are finding an odd issue with insert statements generated for an aggregate collection mapping with addTargetForeignKeyFieldName.
    We have a Table Ticket and Table Task with Table Activity as a child for both.
    Table Ticket
    Ticket_Key (PK)
    Table B
    Task_Key (PK)
    Table C
    Activity_Key (PK)
    Task_Key (FK)
    Ticket_Key(FK)
    Notes
    Version
    Here are the mappings from
    Ticket Project
    AggregateCollectionMapping activitiesMapping = new AggregateCollectionMapping();
            activitiesMapping.setAttributeName("activities");
            activitiesMapping.setReferenceClass(com.common.Activity.class);
            activitiesMapping.dontUseIndirection();
    activitiesMapping.privateOwnedRelationship();
            activitiesMapping.useCollectionClass(java.util.ArrayList.class);
            activitiesMapping.addTargetForeignKeyFieldName("ACTIVITY.TICKET_KEY", "TICKET.TICKET_KEY");
    activitiesMapping.useBatchReading();
            descriptor.addMapping(activitiesMapping);
    Task Project:
    AggregateCollectionMapping activitiesMapping = new AggregateCollectionMapping();
            activitiesMapping.setAttributeName("activities");
            activitiesMapping.setReferenceClass(com.common.Activity.class);
            activitiesMapping.dontUseIndirection();
    activitiesMapping.privateOwnedRelationship();
            activitiesMapping.useCollectionClass(java.util.ArrayList.class);
            activitiesMapping.addTargetForeignKeyFieldName("ACTIVITY.TASK_KEY", "TASK.TASK_KEY");
    activitiesMapping.useBatchReading();
            descriptor.addMapping(activitiesMapping);
    The tickets and tasks with activities gets inserted in the same transaction.
    Here are the queries that what we get from the toplink version 9.x
    2013-10-29 10:30:50,582  - SELECT SEQ_ACTIVITY.NEXTVAL FROM DUAL
    2013-10-29 10:30:50,582  - INSERT  INTO ACTIVITY (TASK_KEY, VERSION, NOTES, ACTIVITY_KEY) VALUES (?, ?, ?, ?)
    2013-10-29 10:30:50,582  - bind => [2900830, 0, Create Task, 8590870]
    2013-10-29 10:30:50,926  - INSERT  INTO ACTIVITY (TICKET_KEY, VERSION, NOTES, ACTIVITY_KEY) VALUES (?, ?, ?, ?)
    2013-10-29 10:30:50,926  - bind => [326450, 1, Created Ticket, 8590860]
    Here are the queries generated from toplink version 10.x
    2013-10-26 23:31:10,426   SELECT SEQ_ACTIVITY.NEXTVAL FROM DUAL
    2013-10-26 23:31:10,430   INSERT INTO ACTIVITY (TASK_KEY, ACTIVITY_KEY,NOTES, VERSION) VALUES (?, ?, ?, ?)
    2013-10-26 23:31:10,430   bind => [2900690, 8590500, Create Task, 0]
    2013-10-26 23:31:10,509   INSERT INTO ACTIVITY (TASK_KEY, ACTIVITY_KEY, NOTES, VERSION) VALUES (?, ?, ?, ?)
    2013-10-26 23:31:10,510   bind => [null, 8590490, Created Ticket, 1]
    It appears like the new version of the toplink caching the prepared statements and it is not recognizing the targetForeignKeyFieldName mapping of the Ticket Project.
    Any help in resolving this issue is appreciated.
    Thanks

    Hi James,
    1)Yes it supports IE 8 .Please review the below link for certification details on browers :-
        http://www.oracle.com/technetwork/middleware/ias/downloads/as-certification-r2-101202-095871.html#BAJGCBEA
         Note: Oracle Application Server supports only those browsers.
    2)Forms only support Windows 7 32 bit only.
        Please refer to the note:1292919.1 "Certification of Oracle Developer Suite 10g (10.1.2) on Windows 7 (32-bit)"
    3)Could you provide more information of JVM because when you install 10gR2 it has JDK and JRE present in it.
    Regards,
    Prakash.

  • Sequence caching with toplink and oracle caching

    Hi,
    In my application, I use toplink as a JPA provider. For performance reasons, I defined an allocationSize on sequence generator for some persistence objects. I read some documentation to understand how it works, the result of my research is that the allocationSize of sequence generator must match with the increment value of the sequence in database.
    So if I want to cache 1000 of values, I must define on my sequence generator allocationSize of 1000 and create a sequence like this : create sequence myseq increment by 1000. Am I right ?
    Second question, what if my sequence define a cache in the database. For example, create sequence myseq increment by 1000 cache 20.
    Does it mean that 20 values will be cached or 1000*20 values will be cached ? Is the cache size defined per session or for all the sessions of the database ?
    Thanks.
    Will.

    Thank you for your response.
    I used the default parameter of toplink (increment by 50) and I left a cache size of 20 on database side.
    But I noticed that whenever the server restarts, I "lost" between 900 and 1000 ids (nearly 20*50). So even if sequence cache on oracle size is non transactional, I think there is a kind of prefetch somewhere on the server side. I must not lost more than 50 ids when a server restarts.
    If I remove the cache on database side, then the behavior is correct (the expected one to be more precise).
    Is there any kind of sequence caching in oracle jdbc drivers ?
    Thanks.
    Will.

  • Oracle Client 11g R2 sequencing issue with App-V 5.0

    Hi All,
    Can anyone help on a issue that I face while I try to create the ODBC connection after I have published the sequenced application. I get the error message as shown :
    Have already tried sequencing by creating the Dummy ODBC user DSN and system DSN on the base machine  before sequencing and have added the TNSNames.ora path as an environment variable.
    Thank in advance for your help!Installation of 32 bit and 64 bit 11.2.0.1 Oracle client on windows 7

    Akanksha,
    If your application is 64-bit, you need only 64-bit Oracle client software which installs 64-bit ODBC.
    There is no need to install 32-bit Oracle client.
    I am suspecting that some of the required components are missing from your installation.
    1)Are you able to connect to the Database using the the sql*plus ?
    (You need to open the sql*plus session from the machine where ODBC application is running)
    2) Try to run the application as administrator user and see whether it helps.
    3)What is the type of client installation which you performed ? (Administrator/Runtime/Custom)
    If it is custom type, might be you are missing some components.
    Try to install as Administrator and see whether it helps.
    Regards,
    Ravi   

  • Capturing image sequences - issues with nested for loops

    Hi all,
    I've written a vi. to capture a specific number of images ('Image No') and save these images, outputted to a folder of my choice.  Each image is identified sequentially.  However, I wish to do a number of iterations ('Run') of this capture sequence, such that the filename of each image would be 'Filename (Run)_(Image No).png', e.g. run 5, image 10 would be 'Filename 5_10.png'.  I have tried a nested for loop for this but I receive an error 'Asynchronous I/O operation in progress' (I've attached a printscreen).
    Can anyone assist me in solving this problem?  Please find attached my vi.
    Kindest regards and thanks,
    Miika
    Solved!
    Go to Solution.
    Attachments:
    Image sequence save to file.vi ‏48 KB
    Labview problem.jpg ‏3841 KB

    Hi,
    You cannot create a folder if this one is already existing.
    Just check that the folder exists before creating it.
    Regards

  • Issues with TopLink Cache Coordination using JMS for manual DB updates

    Hi,
    We are having 2 web application using same Database and Toplink library but 2 session objects for both the applications. We are using JMS for cache coordination. JMS propagating messages successfully between the applications and able to see the same object changes in both the applications properly. Now, we are trying to refresh cache for manual updates in Database. We are trying to refresh single object which is modified in database in one application, refreshing in one application from which refresh happened but not in other application (JMS publishing the topic but updating one).
    Our intention is refreshing in one application so that JMS should coordinate and update in others when DB manual updates. Please let us know any comments for the same.
    Database using: Oracle 11g
    Toplink Version:- 9.0.3

    See,
    http://www.coderanch.com/t/592919/ORM/databases/Toplink-Cache-coordination-JMS-manual

  • Issues with nested for loops - saving images from a camera

    Hi all,
    I've written a vi. to capture a specific number of images ('Image No') and save these images, outputted to a folder of my choice.  Each image is identified sequentially.  However, I wish to do a number of iterations ('Run') of this capture sequence, such that the filename of each image would be 'Filename (Run)_(Image No).png', e.g. run 5, image 10 would be 'Filename 5_10.png'.  I have tried a nested for loop for this but I receive an error 'Asynchronous I/O operation in progress' (I've attached a printscreen).
    Can anyone assist me in solving this problem? I preiously posted this in machine Vision but got no response (http://forums.ni.com/t5/Machine-Vision/Capturing-image-sequences-issues-with-nested-for-loops/m-p/19...).  Please find attached my vi.
    Kindest regards and thanks,
    Miika
    Solved!
    Go to Solution.
    Attachments:
    Labview problem.jpg ‏3841 KB
    Image sequence save to file.vi ‏48 KB

    Miika,
    the problem is not the filenam, but the name of the folder (AHHHHH!). You try to create the same folder in the outer for loop over and over again.... (it is the error message above the '======', not below )
    Norbert
    CEO: What exactly is stopping us from doing this?
    Expert: Geometry
    Marketing Manager: Just ignore it.

  • Issue with order or sequence of wbs elements appearance in planning layout

    Hi Experts
    we have an issue with order or sequence of wbs elements appearance in BPS planning layout.
    In BW - 0wbs element -  hierarchy order is as below
    1
    2
    3
    4
    5
    6
    7
    8
    but when we check the same wbs element in BPS planning layout, it appears as below
    1
    2
    3
    4
    6
    7
    5
    8
    Request you to advice how to correct the order.
    Best Regards
    krishna

    Hi,
    I came across a similar situation once. I dont remember exactly.
    We have two different DataSources on wbs hierarchy. The hiearchy was loaded using the two datasources.
    By mistake we were trying to use the hierarchy created by Datasource2, instead of hier created by datasource1.
    Can you check that.

  • Issue with sequence.currval in INSERT ALL...

    Hi Gurus,
    I am having an issue with using sequence.currval in INSERT ALL with WHEN clause.Please check following example
    Let say I have 4 tables
    1) SOURCE_PARENT
    PARENT_ID
    ========
    10
    20
    2) SOURCE_CHILD
    PARENT_ID CHILD_ID
    ========= ========
    10     1
    10     2
    20     1
    20     2
    Now i have another 2 tables same as above definition(DEST_PARENT, DEST_CHILD),which i want to populate with above source data with new parent_id's from a sequence.
    So I have used INSERT ALL as follows.
    =====================================================
    INSERT ALL
    WHEN (prev_parent_id = 0)THEN
    INTO dest_parent
    values(test_s.nextval)
    when 1 = 1 then
    INTO dest_child
    values(test_s.currval,child_id)
    select
    p.parent_id
    ,c.child_id
    ,LAG(c.parent_id, 1, 0) OVER (PARTITION BY c.parent_id ORDER BY c.child_id) prev_parent_id
    from
    source_parent p
    ,source_child c
    where
    p.parent_id = c.parent_id
    order by p.parent_id
    ========================================================
    Above INSERT ALL created following rows in DEST tables
    1) DEST_PARENT
    PARENT_ID
    =========
    75
    77
    2)DEST_CHILD
    PARENT_ID CHILD_ID
    ========= =======
    75     1
    76     2 --- this should be same as above record
    77     1
    78     2 --this should be same as above record
    As you can see test_s.nextval is executed 4 times even we do have WHEN Clause in INSERT ALL
    Can you please check what's wrong in this INSERT ALL statement?
    (or)
    Any otherway of doing these INSERTS in a single SQL statement?
    Any help would be appreciated!!
    Thanks
    srinivas.L

    Sorry, but this solution does not work. I had to remove the constraints on the two tables dest_parent and dest_child just to show you, how bad your solution is
    SQL> select * from source_parent;
    PARENT_ID
            10
            20
    2 rows selected.
    SQL> select * from source_child;
    PARENT_ID   CHILD_ID
            10          1
            10          2
            20          1
            20          2
            20          3
    5 rows selected.
    SQL> select * from dest_parent;
    no rows selected
    SQL> select * from dest_child;
    no rows selected
    SQL> insert all when
      2       (PREV_PARENT_ID = 0) then into DEST_PARENT
      3  values
      4       (TEST_S.nextval) when 1 = 1 then into DEST_CHILD
      5  values
      6       (case when PREV_PARENT_ID != 0 then TEST_S.currval - 1 else TEST_S.currval end,
      7        CHILD_ID)
      8       select P.PARENT_ID,
      9              C.CHILD_ID,
    10              LAG(C.PARENT_ID, 1, 0) OVER(partition by C.PARENT_ID order by C.CHILD_ID) PREV_PARENT_ID
    11       from SOURCE_PARENT P, SOURCE_CHILD C
    12       where P.PARENT_ID = C.PARENT_ID
    13       order by P.PARENT_ID
    14  /
    7 rows created.
    SQL> select * from dest_parent;
    PARENT_ID
            23
            26
    2 rows selected.
    SQL> select * from dest_child;
    PARENT_ID   CHILD_ID
            21          2   -- ??? !!!
            23          1
            23          2
            24          3   -- !!!
            26          1
    5 rows selected.
    SQL>

  • Having issues with patches that require multiple reboots in a task sequence?

    Are you guys having issues doing a build and capture or deployment, while including the recent patches ?
    It looks like another patch is requiring multiple reboots which breaks the task sequence...
    Long story short... the last time I created a .Wim file was in June (with ZTIWindowsUpdate) - it included all the patches as of June 2014. This image has been deployed since then with no problem. All the other monthly patches (07/08/09/10/11/12/01) can be
    installed successfully through the deployment task sequence with no problem.
    Then last week, I decided to create a new .Wim file to include all the patches as of January 2015. In my build and capture step, it exits because one of the updates requires multiple reboot. I checked on the following website and it has not been updated
    since October 22nd : http://support.microsoft.com/kb/2894518
    Do any of you experiences issues with a WSUS that requires multiple reboot recently ?
    Thanks!

    As mentioned, the MDT offline updates task will do it. Add it to your build and capture and it will do the work for you using the updates in an update package that you've previously created. Alternatively, use a stand-alone instance of MDT to create your
    image (using a build and capture TS of course) -- this can then use a stand-alone instance of WSUS to install the updates into your image which you then import into ConfigMgr.
    Jason | http://blog.configmgrftw.com | @jasonsandys

  • LR5.3 Export issue with Sequence Renumbering

    I just discovered an issue with the LR5.3 Export module on my Windows 7 system when exporting JPEG image files with 'Sequence' File renaming and 'Original' File Settings to a subfolder. When exporting approximately 100 JPEG image files LR shows a file count in the subfolder of ~1/2 the actual file count and the ability to 'Synchronize Folder' disappears. The correct number of files appear in the subfolder using Windows Explorer, so they all were successfully exported and renamed properly. LR must be closed and reopened to restore the ability to 'Synchronize Folders' and/or 'Import' images using the Import module. I've never encountered this problem before since I normally process raw image files, which do not exhibit this issue.
    Here are screenshots:

    Posted to the Photoshop Family site as a problem:
    http://feedback.photoshop.com/photoshop_family/topics/lr5_3_export_sequence_numbering_issu e

  • Issue with xsd Data type mapping for collection of user defined data type

    Hi,
    I am facing a issue with wsdl for xsd mapping for collection of user defined data type.
    Here is the code snippet.
    sample.java
    @WebMethod
    public QueryPageOutput AccountQue(QueryPageInput qpInput)
    public class QueryPageInput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class QueryPageOutput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class Account_IO implements Serializable, Cloneable {
    protected ArrayList <AccountIC> fintObjInst = null;
    public ArrayList<AccountIC>getfintObjInst()
    return (ArrayList<AccountIC>)fintObjInst.clone();
    public void setfintObjInst(AccountIC val)
    fintObjInst = new ArrayList<AccountIC>();
    fintObjInst.add(val);
    Public class AccountIC
    protected String Name;
    protected String Desc;
    public String getName()
    return Name;
    public void setName(String name)
    Name = name;
    For the sample.java code, the wsdl generated is as below:
    <?xml version="1.0" encoding="UTF-8" ?>
    <wsdl:definitions
    name="SimpleService"
    targetNamespace="http://example.org"
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
    xmlns:tns="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"
    >
    <wsdl:types>
    <xs:schema version="1.0" targetNamespace="http://examples.org" xmlns:ns1="http://example.org/types"
    xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://example.org/types"/>
    <xs:element name="AccountWSService" type="ns1:accountEMRIO"/>
    </xs:schema>
    <xs:schema version="1.0" targetNamespace="http://example.org/types" xmlns:ns1="http://examples.org"
    xmlns:tns="http://example.org/types" xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://examples.org"/>
    <xs:complexType name="queryPageOutput">
    <xs:sequence>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="accountEMRIO">
    <xs:sequence>
    <xs:element name="fIntObjectFormat" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageType" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageId" type="xs:string" minOccurs="0"/>
    <xs:element name="fIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fOutputIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fintObjInst" type="xs:anyType" minOccurs="0" maxOccurs="unbounded"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="queryPageInput">
    <xs:sequence>
    <xs:element name="fPageSize" type="xs:string" minOccurs="0"/>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    <xs:element name="fStartRowNum" type="xs:string" minOccurs="0"/>
    <xs:element name="fViewMode" type="xs:string" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    </xs:schema>
    <schema xmlns="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:tns="http://example.org" xmlns:ns1="http://example.org/types">
    <import namespace="http://example.org/types"/>
    <xsd:complexType name="AccountQue">
    <xsd:sequence>
    <xsd:element name="arg0" type="ns1:queryPageInput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQue" type="tns:AccountQue"/>
    <xsd:complexType name="AccountQueResponse">
    <xsd:sequence>
    <xsd:element name="return" type="ns1:queryPageOutput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQueResponse" type="tns:AccountQueResponse"/>
    </schema>
    </wsdl:types>
    <wsdl:message name="AccountQueInput">
    <wsdl:part name="parameters" element="tns:AccountQue"/>
    </wsdl:message>
    <wsdl:message name="AccountQueOutput">
    <wsdl:part name="parameters" element="tns:AccountQueResponse"/>
    </wsdl:message>
    <wsdl:portType name="SimpleService">
    <wsdl:operation name="AccountQue">
    <wsdl:input message="tns:AccountQueInput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    <wsdl:output message="tns:AccountQueOutput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    </wsdl:operation>
    </wsdl:portType>
    <wsdl:binding name="SimpleServiceSoapHttp" type="tns:SimpleService">
    <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
    <wsdl:operation name="AccountQue">
    <soap:operation soapAction=""/>
    <wsdl:input>
    <soap:body use="literal"/>
    </wsdl:input>
    <wsdl:output>
    <soap:body use="literal"/>
    </wsdl:output>
    </wsdl:operation>
    </wsdl:binding>
    <wsdl:service name="SimpleService">
    <wsdl:port name="SimpleServicePort" binding="tns:SimpleServiceSoapHttp">
    <soap:address location="http://localhost:7101/WS-Project1-context-root/SimpleServicePort"/>
    </wsdl:port>
    </wsdl:service>
    </wsdl:definitions>
    In the above wsdl the collection of fintObjInst if of type xs:anytype. From the wsdl, I do not see the xsd mapping for AccountIC which includes Name and Desc. Due to which, when invoking the web service from a different client like c#(by creating proxy business service), I am unable to set the parameters for AccountIC. I am using JAX-WS stack and WLS 10.3. I have already looked at blog http://weblogs.java.net/blog/kohlert/archive/2006/10/jaxws_and_type.html but unable to solve this issue. However, at run time using a tool like SoapUI, when this wsdl is imported, I am able to see all the params related to AccountIC class.
    Can some one help me with this.
    Thanks,
    Sudha.

    Did you try adding the the XmlSeeAlso annotation to the webservice
    @XmlSeeAlso({<package.name>.AccountIC.class})
    This will add the schema for the data type (AccountIC) to the WSDL.
    Hope this helps.
    -Ajay

  • Routing Issue with 3550 Switch

    I am having an issue with routing with one of my Cisco 3550 switches.  I know the 3550s are EoL but some of us have to work with what we have.
    I am using a 3550 on either side of a Layer 2 link.  The Layer 2 link is 2 Extreme Summit X-440 switches with Microwave between the switches.  I have a VLAN configured on both switches and tagged on the ports connected to the Microwave.  The 3550 switch on each end is configured for IP routing but I cannot pass traffic between the switches.  If I unplug the switch on the local end and plug in a laptop, I can ping the switch on the remote end and access devices at the remote end. 
    I know this should work because I am doing the same thing over another Microwave link and Layer 2 link using another 3550 and a HP ProCurve at the remote end.
    Here are the configs for each 3550:
    Local end;  Port Fa0/23 goes to the Remote Side.  Port Fa0/24 goes to the rest of the network
    Current configuration : 5417 bytes
    ! No configuration change since last restart
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname Brindley3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring 1 Sun Apr 2:00 1 Sun Nov 2:00
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos min-reserve 5 170
    mls qos min-reserve 6 10
    mls qos min-reserve 7 65
    mls qos min-reserve 8 26
    mls qos
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    ip name-server 1.2.150.5
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 18
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    |
    interface FastEthernet0/7
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/8
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     description To Gum Springs via Extreme P10
     no switchport
     ip address 1.2.147.1 255.255.255.252
     speed 100
     duplex full
    interface FastEthernet0/24
     description To Flint via Ceragon Eth 2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     mls qos trust cos
     auto qos voip trust
     wrr-queue bandwidth 20 1 80 1
     wrr-queue min-reserve 1 5
     wrr-queue min-reserve 2 6
     wrr-queue min-reserve 3 7
     wrr-queue min-reserve 4 8
     wrr-queue cos-map 1 0 1 2 4
     wrr-queue cos-map 3 3 6 7
     wrr-queue cos-map 4 5
     priority-queue out
     spanning-tree link-type point-to-point
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport access vlan 10
     switchport trunk native vlan 50
     switchport mode dynamic desirable
     spanning-tree portfast trunk
    interface Vlan1
     ip address 1.2.145.2 255.255.255.0
    ip default-gateway 1.2.145.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.145.1
    ip route 1.2.165.0 255.255.255.240 1.2.147.2
    ip route 1.2.166.0 255.255.255.240 1.2.147.2
    ip http server
    snmp-server community public RO
    snmp-server community public/RO RO
    snmp-server location Brindlee Mountain Tower Site
    snmp-server contact Jamey Wright
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  tty envmon syslog snmp
    control-plane
    ntp clock-period 17180143
    ntp server 1.2.150.21
    end
    And this is the config for the remote end.  Port Fa0/24 is the port for the link back to the local end.
    Current configuration : 5058 bytes
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname GS3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring
    mls qos map cos-dscp 0 8 16 24 32 46 46 56
    udld aggressive
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 21
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/2
     switchport access vlan 21
     switchport mode dynamic desirable
     power inline delay shutdown 20 initial 300
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     switchport access vlan 22
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     spanning-tree portfast
    interface FastEthernet0/24
     description To Brindlee via Extreme P10
     switchport mode dynamic desirable
    (Is a member of VLAN 1)
     speed 100
     spanning-tree portfast
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     spanning-tree portfast
    interface Vlan1
     ip address 1.2.147.2 255.255.255.252
    interface Vlan21
     ip address 1.2.165.1 255.255.255.240
     ip helper-address 1.2.150.11
     ip helper-address 1.2.150.5
    interface Vlan22
     ip address 1.2.166.1 255.255.255.240
     ip helper-address 1.2.150.5
     ip helper-address 1.2.150.11
    ip default-gateway 1.2.147.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.147.1 10
    ip http server
    snmp-server community public RO
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps hsrp
    snmp-server enable traps bridge newroot topologychange
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  envmon syslog snmp
    control-plane
    ntp clock-period 17180192
    ntp server 1.2.150.21 key 0 prefer
    Ideas?  Anything stand out as grossly wrong?  I have worked on this for 2 days and am at a loss.
    Thanks
    Jamey

    Sorry for the delay in replying.  Other items at the office took priority over this project.  I tried that and no change.  I pulled the switch from the remote site and took it back to the local end and connected the switches with a crossover cable and everything works fine.  I have pretty much determined that it is an issue with the config in one of the Extreme switches.  The config in those look pretty normal but there are a few things I am unsure of.  Guess I'll see if there is a similar site for Extreme gear.
    Thanks
    Jamey

  • Performance issues with Homesharing?

    I have a Time Capsule as the base station for my wireless network, then 2 Airport Express setup to extend the network around the house, an iMac i7 as the main iTunes Library and couple of iPads, and a couple of Apple TVs. Everything has the latest software, but I have several performance issues with Home sharing. I've done several tests making sure nothing is taking additional bandwidth, so here are the list of issues:
    1) With nothing else running, trying playing a movie via home sharing in an iPad 2 which is located on my iMac, it stops and I have to keep pressing the play button over and over again. I typically see that the iPad tries to download part of the movie first and then starts playing so that it deals with the bandwidth, but in many cases it doesn't.
    2) When trying to play any iTunes content (movies, music, photos, etc) from my Apple TV I can see my computer library, but when I go in on any of the menus, it says there's no content. I have to reboot the Apple TV and then problem fixed. I's just annoying that I have to reboot.
    3) When watching a Netflix movie on my iPad and with Airplay I send the sound to some speakers via Airplay through an Airport Express. At time I lose the connection to the speakers.
    I've complained about Wifi's instability, but here I tried to keep everything with Apples products to avoid any compatibility issues and stay within N wireless technology, which I understood it was much more stable.
    Has anyone some suggestions?

    Hi,
    you should analyze the db after you have loaded the tables.
    Do you use sequences to generate PKs? Do you have a lot of indexex and/or triggers on the tables?
    If yes:
    make sure your sequence caches (alter sequence s cache 10000)
    Drop all unneeded indexes while loading and disable trigger if possible.
    How big is your Redo Log Buffer? When loading a large amount of data it may be an option to enlarge this buffer.
    Do you have more then one DBWR Process? Writing parallel can speed up things when a checkpoint is needed.
    Is it possible using a direct load? Or do you already direct load?
    Dim

  • Performance issues with Planning data load & Agg in 11.1.2.3.500

    We recently upgraded from 11.1.1.3 to 11.1.2.3. Post upgrade we face performance issues with one of our Planning job (eg: Job E). It takes 3x the time to complete in our new environment (11.1.2.3) when compared to the old one (11.1.1.3). This job loads then actual data and does the aggregation. The pattern which we noticed is , if we run a restructure on the application and execute this job immediately it gets completed as the same time as 11.1.1.3. However, in current production (11.1.1.3) the job runs in the following sequence Job A->Job B-> Job C->Job D->Job E and it completes on time, but if we do the same test in 11.1.2.3 in the above sequence it take 3x the time . We dont have a window to restructure the application to before running Job E  every time in Prod. Specs of the new Env is much higher than the old one.
    We have Essbase clustering (MS active/passive) in the new environment and the files are stored in the SAN drive. Could this be because of this? has any one faced performance issues in the clustered environment?

    Do you have exactly same Essbase config settings and calculations performing AGG ? . Remember something very small like UPDATECALC ON/OFF can make a BIG difference in timing..

Maybe you are looking for

  • [SOLVED] KDE will not start, not sure if I set it up correctly

    I installed ArchLinux today and I've been looking through the Wiki to get things setup. In the Desktop Enviornment page it says to install the Xorg server first before installing an enviornment, so I installed xorg-server with: pacman -S xorg-server

  • Correlation error in BPM

    Hi All, I have configured scenario - Multiple IDoc to File using BPM. I have given the Correlation name, Involved messages, Correlation Container and properties in Correlation editor. While setting the properties of the receive step, I am unable to s

  • Urgent.. generic data source... table not activated.....

    Dear all experts, i am extracting generic data source while doing it, it is saying as the table which i have selected in the screen SE11 has not activated can anybody please tell solution... its very urgent. points will be assigned to your help.....

  • Email Attendee One Day Before Event

    I have scheduled clients to whom I would like to have iCal send reminders, one day prior to their appointments. I've looked through the forum and have not found a way to do this. Any suggestions, via alarm, run script, automator, etc? Thanks in Advan

  • C:import problem in JSF

    My code was... +<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>+ +<c:import url="${book.directory}/${chapter}.html"/>+ when i was requesting this page, it shows an error in the browser. That is- +The requested resource (/library/${bo