[Solved] Have issues starting a new X Server in XFCE

I'm trying to launch a WINE application in a new X Server and I get an error telling me xfce session manager already exists. How can I get around this?
>xinit env WINEPREFIX="/home/mark/.local/share/wineprefixes/SWG" wine /home/mark/.local/share/wineprefixes/SWG/drive_c/Program\ Files/Launchpad\ Enhanced/LaunchpadEnhanced.exe -- :1
xfce4-session: Another session manager is already running
xinit: connection to X server lost
waiting for X server to shut down Server terminated successfully (0). Closing log file.
Last edited by Virum (2013-06-21 17:36:20)

Okay I made progress!
I installed Openbox. I guess I need to use a new WM to avoid conflicting with XFCE-session?
#!/bin/sh
# ~/.xinitrc
# Executed by startx (run your window manager from here)
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
DEFAULT_SESSION=xfce4-session
case $1 in
lwm) exec lwm;;
openbox) exec openbox-session;;
xterm) exec dbus-launch xterm;;
xfce) exec dbus-launch xfce4-session ;;
*) exec dbus-launch $DEFAULT_SESSION ;;
esac
I am running into one issue im trying to solve.
Im trying launch the new session AND start an application in it. So I use the command:
> xinit openbox xchat -- :10
Im using xchat for testing the command. The new session starts, Openbox loads, but my application does not. I need to start it in openbox manually.
Also I can get to openbox using CTRL+ALT+2 can I change this to CTRL+ALT+8 somehow?

Similar Messages

  • I bought a new app ($0.99), bought $19.00 worth of on app purchases and the app crashed, now it says that I have to start a new game since i had just started it and didn't get a chance to save it, so my question is, how do i get my money back?

    I bought a new app ($0.99), bought $19.00 worth of on app purchases and the app crashed, now it says that I have to start a new game since i had just started it and didn't get a chance to save it, so my question is, how do i get my money back?

    I'm keeping the app, i just need the $19.00 back.

  • How do i transfer my messages from iphone 3gs to iphone 4s and i have already started my new phone as well?

    how do i transfer my messages from iphone 3gs to iphone 4s and i have already started using my new phone as well??

    from iphone 5 to iphone 6

  • Can i use the apps that i have on my iphone on the ipad or do i have to start a new farm/city/fashion

    i have got a iphone and have now just brought a ipad but can i share the apps like farm story and city story or do i have to start from strach with new farms and city, as some times i will be using the phone or i could b using the ipad, can any one shed any light on this pls.
    many thanks shirley

    sam2259 wrote:
    i have got a iphone and have now just brought a ipad but can i share the apps like farm story and city story or do i have to start from strach with new farms and city, as some times i will be using the phone or i could b using the ipad, can any one shed any light on this pls.
    many thanks shirley
    I don't know if you have already set up your ipad but you could try this.  Backup your iphone then do a restore to your ipad.  I think all the data will transfer over.  I am not a game type person so I do not know if this will work with games but it did transfer all my datas from other apps.  It might transfer the data from your games too.  But if you already set up your ipad and loaded some apps on it, you will have to re-download everything again and you will lose any data on your ipad if you do a restore from your iphone.

  • Is there a way to take a video pause and continue playing on same video so i dont have to start a new video on my ipad 2

    is there a way to start a video on my ipad 2 pause and continue playing on same video so i do have to start another video

    In I movie, load the player with your clip.  Play it until the frame you want is in the viewing window.  Then take a screen shot and the whole screen wil be captured and placed in the camera roll.  You can then crop it down to just the picture, or portion of the picture you want.
    Not elegant, but functional.

  • Have issue for access internal RDP server

    Hi All
    Problem again. Hope you all can help to solve.
    I have internal server 10.200.13.1 for RDP access. But base on below config not are work.
    Also if bypass this firewall can work.
    : Saved
    ASA Version 8.2(5)
    hostname mkofficefw01
    enable password XwzHd4VCVqrxvrzG encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    nameif HGC_BB
    security-level 0
    ip address 10.10.10.1 255.255.255.0
    interface Ethernet0/1
    description MK_Office_206
    nameif MK_206
    security-level 100
    ip address 10.206.0.253 255.255.254.0
    interface Ethernet0/2
    description MK_Office_207
    nameif MK_207
    security-level 100
    ip address 10.207.0.253 255.255.255.0
    interface Ethernet0/3
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 172.32.1.1 255.255.255.0
    management-only
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    access-list mk206_inside extended permit ip any any
    access-list mk207_inside extended permit ip any any
    access-list HGC_outside extended permit ip any any
    access-list inside_nat_206_outbound extended permit ip any 10.206.0.0 255.255.254.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.207.0.0 255.255.255.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.201.0.0 255.255.0.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.202.0.0 255.255.0.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.204.0.0 255.255.0.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.205.0.0 255.255.0.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.210.0.0 255.255.0.0
    access-list inside_nat_206_outbound extended permit ip 10.206.0.0 255.255.254.0 10.200.13.0 255.255.255.0
    access-list inside_nat_207_outbound extended permit ip any 10.207.0.0 255.255.255.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.200.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.201.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.202.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.204.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.205.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.210.0.0 255.255.0.0
    access-list inside_nat_207_outbound extended permit ip 10.207.0.0 255.255.255.0 10.206.0.0 255.255.254.0
    pager lines 24
    logging asdm informational
    mtu HGC_BB 1500
    mtu MK_206 1500
    mtu MK_207 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any HGC_BB
    icmp permit any MK_206
    icmp permit any MK_207
    no asdm history enable
    arp timeout 14400
    global (HGC_BB) 1 interface
    nat (MK_206) 0 access-list inside_nat_206_outbound
    nat (MK_206) 1 10.206.0.0 255.255.252.0
    nat (MK_206) 10 0.0.0.0 0.0.0.0
    nat (MK_207) 0 access-list inside_nat_207_outbound
    nat (MK_207) 1 10.207.0.0 255.255.255.0
    nat (MK_207) 10 0.0.0.0 0.0.0.0
    access-group HGC_outside in interface HGC_BB
    access-group mk206_inside in interface MK_206
    access-group mk207_inside in interface MK_207
    route HGC_BB 0.0.0.0 0.0.0.0 10.10.10.2 1
    route MK_206 10.200.0.0 255.255.0.0 10.206.0.254 1
    route MK_206 10.201.0.0 255.255.0.0 10.206.0.254 1
    route MK_206 10.202.0.0 255.255.0.0 10.206.0.254 1
    route MK_206 10.204.0.0 255.255.0.0 10.206.0.254 1
    route MK_206 10.205.0.0 255.255.0.0 10.206.0.254 1
    route MK_206 10.210.0.0 255.255.0.0 10.206.0.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    telnet 10.0.0.0 255.0.0.0 management
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 HGC_BB
    ssh 10.0.0.0 255.0.0.0 management
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username maxline password AxVGTgY4NjA2d3H8 encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
      inspect icmp error
    service-policy global_policy global
    prompt hostname context
    call-home reporting anonymous
    Cryptochecksum:c8df6eda8684cac25cc5a0e927f9b39a
    : end
    Thank for your help !!!
    Jacky

    From which IP are you trying to access it?
    Also what's the IP address you are putting into the RDP session? The real IP address for the server?
    For Networking Posts check my blog at http://www.laguiadelnetworking.com/category/english/
    Cheers,
    Julio Carvajal Segura

  • HT1338 ently started a  new   course and have to submit my work in word. What is the easiest PDF to word. or get word for mac?

    Hi, I am using Pages O9 with Endnote X4, I have recently started a new course and have to submit my work in word.
    What is the easiest way?  PDF to word or get word for mac?

    A document created in Pages must be translated during export into MS Word .doc format. As Pages is not an MS Word clone, it may allow you to create document content that upon export, is partially or wholly incompatible with Microsoft Word.
    Rather than wait for this potential, unpleasant surprise, you should consider using MS Word from Office for Mac 2011. The faculty may be using MS Office on Windows, or the Mac version. Paper submissions usually are time consuming and important for the course grade. Why gamble?

  • I want the Adobe phone number to call. I have issues on my Tablet and computer with the new version.

    I have issues with the new version of Adobe Flash Player on my Tablet and my computer. I get an error message from Microsoft when using Adobe Flash Player. I need a phone number to resolve all issues.

    Pat Willener wrote:
    Actually the number is 800-833-6687 according to http://www.adobe.com/support/programs/customer/gss.html
    And it's only $39.00 ...
    That's actually the number I posted, my good sir.
    And I'll make a note of the $.99 difference for future posts, thank you very much.

  • Backing up and restoring data to new cucm server

    Our publisher server went down.I have back up for the device.Cisco have send me the new CUCM server.Is there is any possible method i can restore the back during the installation or do i have to start installation from the scratch and after completing only i can restore the data.
    Sent from Cisco Technical Support iPhone App

    You install CUCM, THEN, you can restore a backup.
    HTH
    java
    if this helps, please rate
    www.cisco.com/go/pdihelpdesk

  • Error when creating a new Reports Server instance

    Hi,
    I have tried to create and start a new reports server instance using the following method:
    1- Creating the report server instance:
    rwserver server=%newrepserver% start
    2- Stopping the OPMN:
    *%ORACLEHOME%\opmn\bin\opmnctl stopall*
    3- Adding a new server target to OPMN.XML
    *%ORACLEHOME%\bin\addNewServerTarget.bat %newrepserver%*
    4- Updating the configuration with new OPMN settings:
    *%ORACLEHOME%\dcm\bin\dcmctl.bat updateconfig -ct opmn -v -d*
    *%ORACLEHOME%\dcm\bin\dcmctl.bat resyncinstance -v -d*
    5- Starting the OPMN again:
    *%ORACLEHOME%\opmn\bin\opmnctl startall*
    However, when I try to start the OPMN again, I receive the following error:
    opmn id="##########:6200 5 of 6 processes started
    ias-instance id=red.########.########.lan
    ++++++++++++++++++++++++++++++++++
    ias-component/process-type-process-set:
    *%newrepserver%/ReportsServer/%newrepserver%*
    Error --> Process (pid=6888) failed to start a managed process after the maximum retry limit.
    Log: %ORACLEHOME%\opmn\logs\%newrepserver%~ReportsServer~%newrepserver%
    Any ideas as to why the reports server instance cannot be started?
    I have tried rebooting the server many times and have recreated other reports server instances but with no luck.
    Many thanks in advance,
    Chris

    On Windows this is caused most often by the temporary directory setting.
    Change the temporary directory to some fixed directory writable by anybody, e.g. "C:\temp".
    Change this in:
    Registry entry: hkey_local_machine\software\oracle\key_<oashome>\REPORTS_TMP
    <oashome>\opmn\conf\opmn.xml: search for environment variable TEMP (under ias-instance)
    Good luck!

  • Testing moving to new Windows Server 2008 R2 DHCP Server.

    HI all,
    I want to bring up a new DCHP server on an existing Windows Server 2008 R2 Domain Controller.  The current DHCP server is a Windows 2003 Domain Controller.  I have moved all the FSMO Roles to the new 2008 R2 domain controller
    with the plan to eventually demote the 2003 server and take it off the network. I have the dhcp role installed on the new Windows Server 2008 R2 and have duplicated the exact settings (reservations, scope, etc.) from the old windows 2003 server
    on the new 2008 R2 server.  My plan was simply to disable the dhcp service on the old windows server 2003 and then authorize the new Windows Server 2008 R2 DHCP Server.  However, after reading several articles, I understand that once you authorize
    a new dhcp server, the old dhcp sever is unauthorized.  I also read where several people had major issues with the new dhcp server not handing out IP Addresses even though the new dhcp server was authorized successfully.  Since this is
    a production network, I would like to employ the correct method to bring up the new dhcp server.  Also, if there is a problem, is there an easy way to go back to the original dhcp server?  Thanks for your help.
    FD
    Bob Andres

    You can authorize multiple DHCP servers on a network.
    You can activate and deactivate different scopes independently. So you can test DHCP functionality with a test scope.
    Also, you can stop the old server in many ways that allow it to be online very rapidly: stop the dhcp server service, deactivate the scopes and yes even de-authorize the server.
    My advice would be to built a test so you are confident (=very important) and not to fear the final onlining too much. DHCP is no rockets science. If you've replicated the configuration and are aware of possible IP Helper configurations on your routers/switches,
    it should all work out fine.
    MCP/MCSA/MCTS/MCITP

  • Server 2003 SBS (with Exchange 2003) migrate to new machine Server 2012 Standard (with Exchange 2013)

    This is what I have:
    A very outdated machine running a small domain, SBS 2003 and Exchange - this is the ONLY server currently.
    This is what my boss ordered:
    A Dell R210 II machine with Server 2012 Standard (and I downloaded the trial for Exchange 2013).
    He wants the old server completely replaced and gone - with everything moved over (including Exchange) to the new machine. The main reason for the upgrade is that not all users can access email on their machines (Macs, new versions of Outlook, etc.)
    I have set up a new standalone server before but never migrated one - and I've found that going from SBS2003/Exchange2003 to Server2012/Exchange2013 is not simple in the least.
    I thought I could just set up the new server as a DC on the domain and have everything replicated to it from the source server. Then I could decommission the old server. I have been told that 1) I can't upgrade Exchange 2003 to 2013 and 2) that I shouldn't
    put Exchange on a DC. What do you do if you only have the one server?

    Hi,
    Just additional. Please also refer to following threads and article, then check if can help you.
    Migrate
    SBS 2003 to Windows Server 2012 Standard
    Migration
    SBS 2003 to Windows Server 2012 Standard
    Transition
    from Small Business Server to Standard Windows Server
    Hope this helps.
    Best regards,
    Justin Gu

  • Lightroom 4 crashes when trying to open the slideshow module. I spent over three hours with both Adobe and Apple tech support and we know it is a permission issue but have not been able to get it solved.  It started with the last upgrade to 10.8

    Lightroom 4 crashes when trying to open the slideshow module. I spent over three hours with both Adobe and Apple tech support and we know it is a permission issue but have not been able to get it solved.  It started with the last upgrade to 10.8

    Back up all data.
    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.
    Step 1
    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.
    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):
    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -Rh $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null
    Launch the Terminal application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.
    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.
    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.
    Step 2 (optional)
    The first step should give you usable permissions in your home folder. This step will restore special attributes set by OS X on some user folders to protect them from unintended deletion or renaming. You can skip this step if you don't consider that protection to be necessary.
    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.
    When the OS X Utilities screen appears, select
    Utilities ▹ Terminal
    from the menu bar. A Terminal window will open.
    In the Terminal window, type this:
    resetpassword
    That's one word, all lower case, with no spaces. Then press return. A Reset Password window will open. You’re not  going to reset a password.
    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.
    Select your username from the menu labeled Select the user account if not already selected.
    Under Reset Home Directory Permissions and ACLs, click the Reset button.
    Select
     ▹ Restart
    from the menu bar.

  • I'm trying to sync a new i phone to i tunes.  I get message that says cannot be used because the apple mobile device service is not started.  Any idea what I can do to solve this issue?

    I'm trying to sync a new iphone into i tunes.  I'm getting a message that says that this iphone cannot be used because the apple mobile device service is not started.  Any idea what I can do to solve this issue?

    See Here...
    AMDS for Windows
    http://support.apple.com/kb/TS1567
    AMDS for Mac
    http://support.apple.com/kb/ht1747

  • Due to NAS issues, when I started a new time machine backup it did not have the old backups available. My question is do I need to delete them or will time machine automatically reclaim the space?  Only one Sparse Bundle, same name.

    Due to NAS issues, when I started a new time machine backup it did not have the old backups available. My question is do I need to delete them or will time machine automatically reclaim the space?  There is only one sparse bundle but when I enter time machine I don't see my historic backups.  I use a synology DS212 for my time machine.  Started a new backup which is 218gb but it says 618 gb is occupied  therefore it looks like 2 or 3 backups are still on the disk. Before my NAS issues the last backup was in 2014.  As you can see there is a second sparse bundle from 2012.  Not sure what that is.

    This is an old message now, but what happened to me similarly was:
    I had a major computer crash and through complicated pathways ended up reinstalling (Mavericks) as a new user (long story).
    At least I had good Time Machine backups on an NAS drive (Synology DS212j), or so I thought - when I started Time Machine up again, the old backup file was gone, replaced by a new one using my "new computer" name. The old file was gone both by directly mounting the NAS drive and by clicking "Enter Time Machine".
    It's like I had {OldShareName}.sparsebundle and then it was replaced by {NewShareName}.sparsebundle, all of the old info vanished.
    (I have spent a week finding old files elsewhere and have completed a satisfactory self-restore. It pays to "archive" [my own variation of] as well as "back-up".)
    My belief is that if this were a wired-netword-drive, e.g. plugged right into my iMac with a USB cable, then the old file would have remained.
    But this is an NAS drive, connected directly to my Airport wireless router, and I don't know the significance of the fact that it stores its Time Machine backups as "sparsebundle" files rather than simply as plain(er) files.
    As usual when things get complicated with computers (not just Apple computers) there was never a warning message. Something like "YOU'RE ABOUT TO DELETE A TIME MACHINE BACK-UP FILE!!!" would have made my life a lot simpler.
    BTW, I did try a "restore from Time Machine" option the first thing I had my "new computer" (old hardware, 2009 iMac) up and running, using Migration Assistant, and it ran for many hours and then failed in the wee hours - what that has to do with anything I'm not sure.
    I'm not sure that I have a question about this other than "why do these things happen to me?", but it's a warning. Apart from that I've been very happy with the stability and reliability (but not the cost or set-up complexity) of NAS vs. directly-cabled external drives.
    Charles

Maybe you are looking for