About AToM (pe to pe)

7304做MPLS配置:MPLS VPN三层没有问题,二层VPN建立VC有问题,无法解决!!!请求关注!!!
Router#sh run
Building configuration...
Current configuration : 1802 bytes
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
enable password xxxx
hostname Router
logging snmp-authfail
logging queue-limit 100
ip subnet-zero
no ip domain-lookup
ip cef
ip vrf xjccw
rd ....
route-target export ....
route-target import ....
mpls ldp logging neighbor-changes
interface Loopback0
ip address 10.254.254.200 255.255.255.255
no ip route-cache
no ip mroute-cache
interface FastEthernet0
no ip address
no keepalive
shutdown
duplex auto
speed auto
interface GigabitEthernet0/0
description connect to GSR
mtu 1800
ip address 10.4.10.201 255.255.255.252
negotiation auto
tag-switching ip
interface GigabitEthernet0/1
mtu 1800
no ip address
negotiation auto
interface GigabitEthernet0/1.2
description connect to xjccw
encapsulation dot1Q 2
ip vrf forwarding xjccw
ip address 192.168.100.1 255.255.255.0
interface GigabitEthernet0/1.100
description connect to test_3550
encapsulation dot1Q 100
mpls l2transport route 10.254.254.129 100
tag-switching ip
router ospf 1
log-adjacency-changes
network 10.4.10.200 0.0.0.3 area 0
network 10.254.254.200 0.0.0.0 area 0
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.254.254.129 remote-as 100
neighbor 10.254.254.129 update-source Loopback0
address-family ipv4
no auto-summary
no synchronization
exit-address-family
address-family ipv4 multicast
no auto-summary
exit-address-family
address-family vpnv4
neighbor 10.254.254.129 activate
neighbor 10.254.254.129 send-community extended
no auto-summary
exit-address-family
address-family ipv4 vrf xjccw
redistribute connected
no auto-summary
no synchronization
exit-address-family
ip classless
no ip http server
line con 0
logging synchronous
line aux 0
line vty 0 4
password xjccw
exec-timeout 0 0
end
在GSR上做完MPLS L2TRANSPORT ROUTE 10.254.254.129 10时出现如下情况:
MPLS config error: 10.4.10.202 is not a valid LDP id, use 10.254.254.129 instead
09:22:10: %LDP-5-NBRCHG: TDP Neighbor 10.254.254.129:0 is UP
09:22:10: %TDP-4-PTCL: peer 10.254.254.129:0, bad PIE len
09:22:10: PDU HDR:
09:22:10: 0x00 0x01 0x00 0x3E 0x0A 0xFE 0xFE 0x81 0x00 0x00 0x04 0x00
09:22:10: PIE HDR:
09:22:10: 0x0B 0x96 0x01 0x00
09:22:10: %LDP-5-NBRCHG: TDP Neighbor 10.254.254.129:0 is DOWN

刚开始在7206做实验,结果三层VPN和二层VPN都不通,郁闷中。。。。。。
升级其IOS,还是不行,只能在7304上做实验,结果。。。。。。。。
7206-test#sh run
Building configuration...
Current configuration : 1823 bytes
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname 7206-test
boot-start-marker
boot-end-marker
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf xjccw1
rd ...
route-target export ...
route-target import ...
interface Loopback0
ip address 10.254.254.201 255.255.255.255
no ip directed-broadcast
interface FastEthernet0/0
no ip address
no ip directed-broadcast
duplex half
speed auto
interface FastEthernet0/0.101
description connect to sitB1_vc101_GSR
encapsulation dot1Q 101
no ip directed-broadcast
tag-switching ip
no cdp enable
xconnect 10.254.254.129 101 encapsulation mpls
interface FastEthernet0/0.105
description connect to xjccw1
encapsulation dot1Q 105
ip vrf forwarding xjccw1
ip address 192.168.10.1 255.255.255.0
no ip directed-broadcast
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
duplex half
speed auto
interface POS2/0
description connect to GSR
ip address 10.4.10.205 255.255.255.252
no ip directed-broadcast
tag-switching ip
fair-queue 64 256 0
router ospf 1
log-adjacency-changes
network 10.4.10.204 0.0.0.3 area 0
network 10.254.254.201 0.0.0.0 area 0
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.254.254.129 remote-as 100
neighbor 10.254.254.129 update-source Loopback0
no auto-summary
address-family vpnv4
neighbor 10.254.254.129 activate
neighbor 10.254.254.129 send-community extended
exit-address-family
address-family ipv4 vrf xjccw1
redistribute connected
no auto-summary
no synchronization
exit-address-family
ip classless
line con 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
no cns aaa enable
end

Similar Messages

  • Guarantees about atomic access in the ISR

    Hi,
    I have a global variable "x" in my DDK kernel-mode continuous data acquisition driver that I access several times in my ISR. In my particular case this is a fixed-size buffer in kernel space that I store read data in. I would like the access to that variable to be atomic in the ISR. Do you have suggestions how this can happen? I am thinking of three ways, but I have doubts about each:
    1) Disable other interrupts from my device (at same DIRQL).
    A. What happens if a higher-priority interrupt writes to "x"? Is this something I cannot avoid?
    B. Is it true that another device wired to memory directly can write to this location?
    2) Delay hardware writing to "x" (such as a DMA transfer running at the same time as the ISR).
    A. Is this a scenario and a option?
    3) Copy "x" to a temporary "y" in the beginning of the ISR.
    A. Is this really a solution? In my opinion this might be expensive for a big buffer and someone can write to parts of it while I am copying.
    Thanks.

    I have found the answer to this question. Thank you.

  • Stupid question about atomic operations

    Why there are separate atomic classes? Why not make all primitive operations atomic? Is this a performance issue?

    Currently, I'm readin this:
    http://www.oreilly.com/catalog/jthreads3/chapter/ch05.
    pdf . It says that, for example, ++ operation is not
    atomic.++ by nature is a 3 step process--read, add, write. I suppose it would have been technically possible to make that an atomic operation, but it probably would have involved complicating the JLS and JMM, and possibly hurting overall performance of all operations.

  • Atomic operation?

    When i am going through java docs i have encountered the following statement about Atomic action
    " An atomic action cannot stop in the middle: it either happens completely, or it doesn't happen at all. No side effects of an atomic action are visible until the action is complete."
    So i understand this as, A thread does not give up(does not move out of running state) until it completes the atomic action(a sequence of steps). So atomic action done by one thread is visible to all the threads. i mean to say no other thread executes until the the thread that is executing the atomic action completes. so any modification done by atomic action will be visible to other threads.
    Is my understanding right? Did I understood this rightly?
    Edited by: Muralidhar on Feb 16, 2013 5:37 PM

    teasp wrote:
    Atomic operation is totally different thing from visibility. When a Thread is executing atomic operation, it means no other thread have a chance to disturb the action, but it does not garantee other Threads can "see" the result of the operation immediately.Well if it isn't Mr. Concurrency Expert.
    Based on the ignorance and hostility you demonstrated in your other thread, I wouldn't start dishing out answers to people just yet.
    Offense very much intended.

  • Virtual PC and Atomic Park

    this is my first post, and i am not sure where best to ask this.
    i bought VPC 7 with windows 2000 in march, from an online retailer called atomic park. they had good ratings and the $220 price was a little lower than other places.
    today i had to reinstall it, and do not have the box with my key numbers so i called tech support. at first they said i could buy the keys for $10 each (one for VPC7, one for windows) but then they informed me that the part number on my cd is NOT a retail number. and they could not help me at all.
    apparently what i may have been sold is a "market" or "select" cd. (i never heard of these terms). the woman said that these CDs are usually sold to schools, are not the complete software, do not come with free support.
    i am wondering:
    is it possible i was not sold a retail copy?
    is it legal to do so?
    what should i do??
    i am frustrated especially after reading the bad press about atomic park online. for example... http://www.answers.com/topic/atomicpark-com?cat=technology
    i have sent an inquiry to atomicpark and informed my credit card company (who says it is probably too late to dispute the $220 charge). it seems as though they don't answer their phone often or respond to emails.
    any thoughts are appreciated.
    thank you ...

    Here is the message I first got when I tried to start up Virtual PC.
    http://homepage.mac.com/baiaz/virtualpc.jpg
    In a Norwegian Forum for mac, somebody said that I should upgrade Virtual PC 7 to Version 7.0.2.
    I just did and now I dont get this message but still I cant get into internett. any solutions?

  • Mov reference file will not open in QuickTime 7.7.4 for Windows

    Hi,
    I have a mov reference file which opened fine in QuickTime 7.6.2 but since upgrading to 7.7.4 the file will no open. I get the following error:
    Error -2002: a bad public movie atom was found in the movie.
    The file contains one PAL MPEG2 video track and one stereo PCM audio track. It also contains a timecode track.
    See movie inspector below:
    Can anyone help me understand why this file will not open with the latest version of QuickTime. I cannot supply the file but can give any information about atoms etc. which can be read using QTAtomViewer.
    I am using Windows 7 and Windows Server 2008.
    Many thanks,
    Kate

    For those who want to call, the following menu options will get you to the Quick Time install tech support:
    2 - takes you to the Quick Time submenu
    2 - takes you to tech support
    then, choose 1 for Mac or 2 for windows
    Initially, I was told by tier 1 tech rep Shawn that the update server may not be up or that it may be a firewall issue on my side.
    After telling him that I have confirmed that it is a problem with the update server sending a NULL (0 byte) response to the update query, he said I would have to just download the latest one in order to have the most up-to-date version and "just check back periodically to see if the update server is working".
    He mentioned there was a Quick Time standalone download available (http://www.apple.com/quicktime/download/standalone.html), but that is still ~20MB & doesn't help the fact that probably over 90% of the people who run Quick Time have the option to automatically check for updates set and will never realize they're running an old, vulnerable version of Quick Time.
    He gave me a case number after I asked for one: 58027568
    If you'd like to add to mine and/or Rob's, it surely couldn't hurt.
    I suppose my next course is to try emailing contacts at apple to see what kind of response they have. Considering this problem has been there ever since QT 7 for Windows has been released (I don't remember ever checking for updates when running QT 7 beta), it's strange that it's still a problem.
    hand made system   Windows XP Pro  

  • Java.util.Locale not thread-safe !

    In multithreading programming, we know that double-checking idiom is broken. But lots of code, even in sun java core libraries, are written using this idiom, like the class "java.util.Locale".
    I have submitted this bug report just now,
    but I wanted to have your opinion about this.
    Don't you think a complete review of the source code of the core libraries is necessary ?
    java.util.Locale seems not to be thread safe, as I look at the source code.
    The static method getDefault() is not synchronized.
    The code is as follows:
    public static Locale getDefault() {
    // do not synchronize this method - see 4071298
    // it's OK if more than one default locale happens to be created
    if (defaultLocale == null) {
    // ... do something ...
    defaultLocale = new Locale(language, country, variant);
    return defaultLocale;
    This method seems to have been synchronized in the past, but the bug report 4071298 removed the "synchronized" modifier.
    The problem is that for multiprocessor machines, each processor having its own cache, the data in these caches are never synchronized with the main memory.
    The lack of a memory barrier, that is provided normally by the "synchronized" modifier, can make a thread read an incompletely initialized Locale instance referenced by the static private variable "defaultlocale".
    This problem is well explained in http://www.javaworld.com/javaworld/jw-02-2001/jw-0209-double.html and other documents about multithreading.
    I think this method must just be synchronized again.

    Shankar, I understand that this is something books and articles about multithreading don't talk much about, because for marketing reasons, multithreading is supposed to be very simple.
    It absolutely not the case.
    Multithreading IS a most difficult topic.
    First, you must be aware that each processor has its own high-speed cache memory, much faster than the main memory.
    This cache is made of a mixture of registers and L1/L2/L3 caches.
    Suppose we have a program with a shared variable "public static int a = 0;".
    On a multiprocessor system, suppose that a thread TA running on processor P1 assign a value to this variable "a=33;".
    The write is done to the cache of P1, but not in the main memory.
    Now, a second thread TB running on processor P2 reads this variable with "System.out.prinln(a);".
    The value of "a" is retrieved from main memory, and is 0 !
    The value 33 is in the cache of P1, not in main memory where its value is still 0, because the cache of P1 has not been flushed.
    When you are using BufferedOutputStream, you use the "flush()" method to flush the buffer, and the "synch()" method to commit data to disk.
    With memory, it is the same thing.
    The java "synchronized" keyword is not only a streetlight to regulate traffic, it is also a "memory barrier".
    The opening brace "{" of a synchronized block writes the data of the processor cache into the main memory.
    Then, the cache is emptied, so that stale values of other data don't remain here.
    Inside the "synchronized" block, the thread must thus retrieve fresh values from main memory.
    At the closing brace "}", data in the processor cache is written to main memory.
    The word "synchronized" has the same meaning as the "sync()" method of FileDescriptor class, which writes data physically to disk.
    You see, it is really a cache communication problem, and the synchronized blocks allows us to devise a kind of data transfer protocol between main memory and the multiple processor local caches.
    The hardware does not do this memory reconciliation for you. You must do it yourself using "synchronized" block.
    Besides, inside a synchronized block, the processor ( or compiler ) feels free to write data in any order it feels most appropriate.
    It can thus reorder assignments and instruction.
    It is like the elevator algorithm used when you store data into a hard disk.
    Writes are reordered so that they can be retrieved more efficiently by one sweep or the magnetic head.
    This reordering, as well as the arbitrary moment the processor decides to reconciliate parts of its cache to main memory ( if you don't use synchronized ) are the source of the problem.
    A thread TB on processor P2 can retrieve a non-null pointer, and retrieve this object from main memory, where it is not yet initialized.
    It has been initialized in the cache of P1 by TA, though, but TB doen't see it.
    To summarize, use "synchronized" every time you access to shared variables.
    There is no other way to be safe.
    You get the problem, now ?
    ( Note that this problem has strictly nothing to do with the atomicity issue, but most people tend to mix the two topics...
    Besides, as each access to a shared variable must be done inside a synchronized block, the issue of atomicity is not important at all.
    Why would you care about atomicity if you can get a stale value ?
    The only case where atomicity is important is when multiple threads access a single shared variable not in synchronized block. In this case, the variable must be declared volatile, which in theory synchronizes main and cache memory, and make even long and double atomic, but as it is broken in lots of implementation, ... )

  • Is there any way to connect a RSS feed?

    Hello,
    This is something experimental!
    I am trying to add a Data Server and source as a RSS feed like: http://feeds.bbci.co.uk/news/rss.xml
    Is it possible or am I trying in vain?
    Thanks.

    the auto generated ddt contain some defintions about atom:link, if removed them, test connection works well.
    <!ELEMENT atom:link EMPTY>
    <!ATTLIST atom:link href CDATA #IMPLIED>
    <!ATTLIST atom:link rel NMTOKEN #IMPLIED>
    <!ATTLIST atom:link type CDATA #IMPLIED>
    so whether it means that dtd does not support multiple naming spaces?

  • Need to combine month and year to get date YYYY-MM-DD format

    Month and year are table fields and they will have values like
    Month in format = mm  example 01
    year in format = YYYY example 2010
    Now i need to concatenate month and year to derive date .
    Expected result Result :2010-01-01
    Example :Month =01
    Year =2010
    Mudassar

    The principle of any tiered architecture is that display formatting is done in a presentation layer. This is not just SQL and Client/Server programming; it is the foundation of all modern programming. Not knowing this is like a doctor who does not know
    about germs or a chemist who does not know about atoms. 
    This is reviewed in the first 1-2 weeks of any database class. Why are you violating it?? 
    Next, you do not even know that column are not fields! 
    T-SQL now has a DATE data type, which defaults to the ISO-8601 display format (yyyy-mm-dd). Are you using it? If you had been polite we would see your DDL and know. 
    --CELKO-- Books in Celko Series for Morgan-Kaufmann Publishing: Analytics and OLAP in SQL / Data and Databases: Concepts in Practice Data / Measurements and Standards in SQL SQL for Smarties / SQL Programming Style / SQL Puzzles and Answers / Thinking
    in Sets / Trees and Hierarchies in SQL

  • IPS 4240 Design Question

    I have two IPS 4240s that may be placed between our internal network and our extranet firewall. The firewall set is your standard ASA-5520 active/failover pair connected to two switches.
    Q1 - If I am not worried about atomic attacks, is there any other benefit to having the IPS inline over promiscuous?
    Q2 - Whether inline or promiscuous, is it necessary to connect the single IPS to both switches in order to receive packets when an ASA failover occurs? If so, is it done physically or via RSPAN?
    Q3 - If the IPS fails and it is configured inline, do the interfaces fail open (traffic continues to pass) or closed (traffic is dropped)? I could not find that on Cisco's site.
    Thanks!

    A1 - There are a few things that in-line mode can clean up by deafult, but that can also bite you. Check out some of the other forum posts on having ssh dropped without alerts. Since you have reduntant 4240s the realibility of the IPS sensors in-line shouldn't affect you as much. Just don't update them at the same time.
    A2 - Only the signatures that need state will be effected by a failover. Hopefully failovers do not happen frequently enough for missing a few potential hits to be an issue. If you are really performing good analysis and tuning out your false positives, then you might want to connect both sensors to both switches.
    A3 - You can configure the 4240s to fail-open (pass the traffic thru the sensor when it fails) or fail-closed (do not pass traffic during sensor failure). Since you have dual firewalls, switches and sensors, you can fail closed and force the traffic thru the running sensor and firewall. If one sensor is standby, you may want to make him fail open, so that you can still pass traffic in the event both sensors are down.

  • Bluetooth + system.getNano - distance?

    Hi, not sure exactly what forum to post this in so I'll take it here...
    Anyway I recently read an article about some new patents by apple, one which involved bluetooth finding lost keys and such via "hot/cold" feedback (using one device to find the other) and the other using triangulation (multiple devices) to more exactly pinpoint the lost device. I haven't looked at their patent so not sure exactly what it entails but from what I could get it worked similar to a gps but much smaller scale (it said something about atomic synced time for instance).
    Anyway the reason I found the article was because a colleague of mine was wondering if it was possible to create something like this.
    Now I'm most familiar with java so if possible it would be nice if I could use it... however got some questions on how plausible it is. And just cause I'm most familiar with java don't mean I'm all that good at that either ^^;
    Anyway, to make it simple lets skip the triangulation bit. We have 2 devices and we would like to find the distance between them. Now I read an article about using signal strength as well to do this but their conclusion was it didn't work very well. So lets skip that as well. And since I doubt I could sync two devices atomically and then as the GPS works send the time and calculate the distance from that.
    So my idea was this, since the clocks are not synced, could you use the round trip time (RTT) /2 to calculate the distance?
    pseudocode of the operations
    client1
    OpenConnectionToOtherDevice connection;
    is = connection.getInputStream();
    os = connection.getOutPutStream();
    start = System.getNano();
    os.write(1);
    is.read();
    rtt = System.getNano() - start;
    distance = speedoflight * (rtt/2) / 10^9  // last division to get it to secondsclient2
    waitforconnection();
    open inputstream is, openoutputstream os;
    is.read();
    os.write(1);The code above would also to improve accuracy not be allowed to be swapped out and such...
    Would something like that actually work? :S From what I've read as well the getNano uses the most accurate clock on the system. "On XP the best you can get (the windows performance timer) is microsecond timing (10^6)"
    Which wouldn't give high enough accuracy to calculate a distance in metres. But lets assume we get it in nanoseconds... Would something like this work or would you get a lot of delays on other parts on the code? :X
    Might not be entirely clear there towards the end... I'll try to make myself more clear if you got questions.
    Feedback appreciated
    Christian

    j2ee_ubuntu:
    Yeah, it is to get a RTT, since the clocks aren't synced you cant send the the timestamp when it was sent and then compare that to the internal clock on the receiving device.
    db:
    Yeah I read some of that and was kinda what I was afraid of... I get an average of just below 2000 something...and since like 100ns results in ca 30m, calculating a mean and substracting that is also out of the question obviously...
    Do you know if it's like possible (I think it was in some assignment way back in school in assembler) where you force a section to run, and it can't be placed on the stack before it's done it's stuff... :X
    I'm guessing you'd have to go lowlvl like this for it to work properly in the first place, or anyone else got any ideas? =)

  • Doubt about transaction atomicity

    Hello everyone.
    Here i am posting some extract from from oracle 10g Documentation "Concepts" manual, "Part Number B10743-01", Chapter 4. "Transcation Managment".
    Here are extracts :
    "A transaction is a logical unit of work that contains one or more SQL statements. A transaction is an atomic unit. The effects of all the SQL statements in a transaction can be either all committed (applied to the database) or all rolled back (undone from the database)."
    Some lines later, this has been given :
    "Statement-Level Rollback
    If at any time during execution a SQL statement causes an error, all effects of the statement are rolled back. The effect of the rollback is as if that statement had never been run. This operation is a statement-level rollback.
    Errors discovered during SQL statement execution cause statement-level rollbacks. An example of such an error is attempting to insert a duplicate value in a primary key. Single SQL statements involved in a deadlock (competition for the same data) can also cause a statement-level rollback. Errors discovered during SQL statement parsing, such as a syntax error, have not yet been run, so they do not cause a statement-level rollback.
    A SQL statement that fails causes the loss only of any work it would have performed itself. It does not cause the loss of any work that preceded it in the current transaction. If the statement is a DDL statement, then the implicit commit that immediately preceded it is not undone."
    Now, My question is If we are considering TRANSCATION as atomic unit, then whats the relevance of statement level rollback. Moreover, statement level rollback states that if sql statement fails, it causes the loss only of any work it would have performed itself. But in actual, if three statements are fired one after another.
    Say, statement 1 and 2 execute successfull but third fails then 1 and 2 also get rollbacked. Which is correct according to fact if we consider transcation as atomic.
    But this is not accordance with the statement level rollback (text which is given in bold).
    So, any explanation for this. What i am taking wrong.......

    SQL> begin
    2 insert into test values (1);
    3 insert into test values (2);
    4 insert into test values (2);
    5 end;
    6 /
    begin
    ERROR at line 1:
    ORA-00001: unique constraint (SCOTT.SYS_C001481) violated
    ORA-06512: at line 4
    SQL> select * from test;
    no rows selected
    See, in this case nothing is inserted in tables, because transcation is atomic.be aware that this result is due solely to the lack of exception handling in your code.
    Given this piece of code...
    SQL> declare
      2    procedure p (n in number) is
      3    begin
      4      insert into apc1 values (n);
      5      insert into apc1 values (n*2);
      6    exception
      7      when others then null;
      8    end;
      9  begin
    10    p(4);
    11    p(2);
    12  end;
    13  /
    PL/SQL procedure successfully completed.
    SQL>...what rows are currently in the table? Let's take a peek...
    SQL> select * from apc1;
          COL1
             4
             8
             2
    SQL> In other words, only the last insert failed. This is in accordance with the documentation:
    Also, if a stored subprogram fails with an unhandled exception, PL/SQL does not roll back database work done by the subprogram.
    In your example all the inserts fail, because you didn't have any exception handling. This was a decision made by your calling environment (I assume SQL*Plus) which does not know how to cope with an unhandled exception except by rolling back the failing statement. Note that it does not rollback the transaction, only the statement...
    SQL>  delete from apc1
      2  /
    1 row deleted.
    SQL> insert into apc1 values (1)
      2  /
    1 row created.
    SQL> begin
      2     insert into apc1 values (2);
      3     insert into apc1 values (2);
      4  end;
      5  /
    begin
    ERROR at line 1:
    ORA-00001: unique constraint (APC.SYS_C0010124) violated
    ORA-06512: at line 3
    SQL> select * from apc1
      2  /
          COL1
             1
    SQL> Cheers, APC

  • How do I stop the Atomic Browser on my iPod Touch from allowing websites to automatically load my App Store app?

    I have the Bejeweled Blitz app (for Facebooik) on my iPod Touch 4th gen.  If I want to find gems (special items used in Bejeweled) I have to use a browser (I'm using Atomic Browser) on my iPod so I can grab gems from Facebook's news feed.  What's SUPPOSE to happen is this:
    I set Atomic on my iPod to identify itself as Safari mobile (because the Bejeweled Blitz app on the iPod only recognizes Safari).
    I load my Bejeweled app on my ipod.
    I log into Facebook with Atomic and scan the news feed for gems and click on a gem.Atomic opens a new tab and tries to load the link.My iPod then switches from Atomic to my Bejeweled Blitz app and the gem appears in my game.
    When I'm done with the game, I double click Home and swtich back to Atomic.
    I close the new tab and search the news feed for the next gem.
    HOWEVER, the problem is this:  About two-thirds of the time, when Atomic opens a new tab to load the link, instead of my iPod swtching to Bejeweled Blitz, it opens my App Store app and takes me to the Bejeweled Blitz app download page.  Sometimes the problem occurs when I'm done with my game:  i.e., when I go back to the browser, the iPod swtiches from Atomic and loads the App Store app before I even have a chance to close the tab.  It's a big pain in the neck because it takes a long time for the App Store app to load and when I go back to my Bejeweled Bltz app, it acts like it got dumped from memory and has to restart.
    So... How do I make it so that my App Store app ONLY loads when I personally select the app myself?

    Covered in the settings section of the manual:
    iPod touch User Guide (For iOS 5.1 Software)

  • [bug] workqueue leaked lock or atomic when connecting Apple Trackpad

    Hi.
    Recently I reported pretty useless bug into archlinux bugtracker about system freezes caused by Apple Magic Trackpad.
    https://bugs.archlinux.org/task/37587
    I've been able to reproduce it and dump dmesg output to file. Now I need some help in «decoding» info from dmesg to be able to provide more info into bug ticket or even report a bug upstream
    Help me decide, please, what component (hid, bluetooth, etc) causes this bug.
    I'm not sure, because unloading hid_magicmouse module stops errors in dmesg. Though hci_rx_work [bluetooth] is mentioned in the log.
    [ 2723.850822] BUG: workqueue leaked lock or atomic: kworker/u9:0/0xfffffffe/1692
    last function: hci_rx_work [bluetooth]
    [ 2723.850826] CPU: 1 PID: 1692 Comm: kworker/u9:0 Tainted: P W O 3.12.0-1-ARCH #1
    [ 2723.850827] Hardware name: System manufacturer P5K/P5K, BIOS 1006 03/05/2008
    [ 2723.850833] Workqueue: hci0 hci_rx_work [bluetooth]
    [ 2723.850835] ffff8801a3837000 ffff8801a5239e20 ffffffff814ebffb ffff880037f19d80
    [ 2723.850838] ffff8801a5239e68 ffffffff8107dd07 00000000a3837000 ffff88018ccc1500
    [ 2723.850842] ffff8801a3837000 ffff8801a3837018 ffff880037f19db0 ffff8800ca8c88b0
    [ 2723.850845] Call Trace:
    [ 2723.850849] [<ffffffff814ebffb>] dump_stack+0x54/0x8d
    [ 2723.850852] [<ffffffff8107dd07>] process_one_work+0x3a7/0x450
    [ 2723.850855] [<ffffffff8107e4d1>] worker_thread+0x121/0x3a0
    [ 2723.850858] [<ffffffff8107e3b0>] ? manage_workers.isra.23+0x2b0/0x2b0
    [ 2723.850862] [<ffffffff81084e60>] kthread+0xc0/0xd0
    [ 2723.850865] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.850868] [<ffffffff814faafc>] ret_from_fork+0x7c/0xb0
    [ 2723.850871] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.850874] BUG: scheduling while atomic: kworker/u9:0/1692/0xffffffff
    [ 2723.850875] Modules linked in: hid_magicmouse hidp btusb bnep xt_mac ipt_REJECT xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack iptable_filter ip_tables x_tables coretemp kvm_intel kvm iTCO_wdt iTCO_vendor_support joydev hid_generic hid_logitech_dj usbhid gpio_ich hid evdev i2c_i801 microcode nvidia(PO) serio_raw lpc_ich snd_hda_codec_realtek snd_ice1724 snd_ak4113 snd_pt2258 snd_ak4114 snd_i2c snd_ice17xx_ak4xxx snd_ak4xxx_adda snd_ac97_codec ac97_bus snd_rawmidi snd_seq_device snd_hda_intel snd_hda_codec atl1 snd_hwdep snd_pcm snd_page_alloc snd_timer snd mii drm soundcore i2c_core shpchp asus_atk0110 intel_agp intel_gtt button processor rfcomm bluetooth rfkill nf_conntrack_ftp nf_conntrack ext4 crc16 mbcache jbd2 sd_mod sr_mod cdrom ata_generic pata_acpi firewire_ohci ata_piix firewire_core
    [ 2723.850922] crc_itu_t ahci pata_jmicron libahci libata scsi_mod ehci_pci uhci_hcd ehci_hcd usbcore usb_common [last unloaded: btusb]
    [ 2723.850931] CPU: 1 PID: 1692 Comm: kworker/u9:0 Tainted: P W O 3.12.0-1-ARCH #1
    [ 2723.850932] Hardware name: System manufacturer P5K/P5K, BIOS 1006 03/05/2008
    [ 2723.850937] ffff8801afc944c0 ffff8801a5239d40 ffffffff814ebffb ffff8801a3837000
    [ 2723.850940] ffff8801a5239d50 ffffffff814e95a6 ffff8801a5239e58 ffffffff814f15df
    [ 2723.850944] 00000000000144c0 ffff8801a5239fd8 ffff8801a5239fd8 00000000000144c0
    [ 2723.850947] Call Trace:
    [ 2723.850950] [<ffffffff814ebffb>] dump_stack+0x54/0x8d
    [ 2723.850954] [<ffffffff814e95a6>] __schedule_bug+0x4d/0x5b
    [ 2723.850957] [<ffffffff814f15df>] __schedule+0x93f/0x950
    [ 2723.850961] [<ffffffff81016f70>] ? show_stack_log_lvl+0xd0/0x1c0
    [ 2723.850964] [<ffffffff81018245>] ? show_stack+0x25/0x50
    [ 2723.850967] [<ffffffff8107db4c>] ? process_one_work+0x1ec/0x450
    [ 2723.850970] [<ffffffff814f1619>] schedule+0x29/0x70
    [ 2723.850973] [<ffffffff8107e578>] worker_thread+0x1c8/0x3a0
    [ 2723.850976] [<ffffffff8107e3b0>] ? manage_workers.isra.23+0x2b0/0x2b0
    [ 2723.850980] [<ffffffff81084e60>] kthread+0xc0/0xd0
    [ 2723.850983] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.850986] [<ffffffff814faafc>] ret_from_fork+0x7c/0xb0
    [ 2723.850989] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.861820] BUG: workqueue leaked lock or atomic: kworker/u9:0/0xfffffffe/1692
    last function: hci_rx_work [bluetooth]
    [ 2723.861824] CPU: 1 PID: 1692 Comm: kworker/u9:0 Tainted: P W O 3.12.0-1-ARCH #1
    [ 2723.861826] Hardware name: System manufacturer P5K/P5K, BIOS 1006 03/05/2008
    [ 2723.861831] Workqueue: hci0 hci_rx_work [bluetooth]
    [ 2723.861833] ffff8801a3837000 ffff8801a5239e20 ffffffff814ebffb ffff880037f19d80
    [ 2723.861837] ffff8801a5239e68 ffffffff8107dd07 00000000a3837000 ffff88018ccc1500
    [ 2723.861840] ffff8801a3837000 ffff8801a3837018 ffff880037f19db0 ffff8800ca8c88b0
    [ 2723.861843] Call Trace:
    [ 2723.861847] [<ffffffff814ebffb>] dump_stack+0x54/0x8d
    [ 2723.861850] [<ffffffff8107dd07>] process_one_work+0x3a7/0x450
    [ 2723.861853] [<ffffffff8107e4d1>] worker_thread+0x121/0x3a0
    [ 2723.861856] [<ffffffff8107e3b0>] ? manage_workers.isra.23+0x2b0/0x2b0
    [ 2723.861859] [<ffffffff81084e60>] kthread+0xc0/0xd0
    [ 2723.861863] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.861866] [<ffffffff814faafc>] ret_from_fork+0x7c/0xb0
    [ 2723.861869] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.861872] BUG: scheduling while atomic: kworker/u9:0/1692/0xffffffff
    [ 2723.861873] Modules linked in: hid_magicmouse hidp btusb bnep xt_mac ipt_REJECT xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack iptable_filter ip_tables x_tables coretemp kvm_intel kvm iTCO_wdt iTCO_vendor_support joydev hid_generic hid_logitech_dj usbhid gpio_ich hid evdev i2c_i801 microcode nvidia(PO) serio_raw lpc_ich snd_hda_codec_realtek snd_ice1724 snd_ak4113 snd_pt2258 snd_ak4114 snd_i2c snd_ice17xx_ak4xxx snd_ak4xxx_adda snd_ac97_codec ac97_bus snd_rawmidi snd_seq_device snd_hda_intel snd_hda_codec atl1 snd_hwdep snd_pcm snd_page_alloc snd_timer snd mii drm soundcore i2c_core shpchp asus_atk0110 intel_agp intel_gtt button processor rfcomm bluetooth rfkill nf_conntrack_ftp nf_conntrack ext4 crc16 mbcache jbd2 sd_mod sr_mod cdrom ata_generic pata_acpi firewire_ohci ata_piix firewire_core
    [ 2723.861920] crc_itu_t ahci pata_jmicron libahci libata scsi_mod ehci_pci uhci_hcd ehci_hcd usbcore usb_common [last unloaded: btusb]
    [ 2723.861929] CPU: 1 PID: 1692 Comm: kworker/u9:0 Tainted: P W O 3.12.0-1-ARCH #1
    [ 2723.861930] Hardware name: System manufacturer P5K/P5K, BIOS 1006 03/05/2008
    [ 2723.861935] ffff8801afc944c0 ffff8801a5239d40 ffffffff814ebffb ffff8801a3837000
    [ 2723.861938] ffff8801a5239d50 ffffffff814e95a6 ffff8801a5239e58 ffffffff814f15df
    [ 2723.861941] 00000000000144c0 ffff8801a5239fd8 ffff8801a5239fd8 00000000000144c0
    [ 2723.861945] Call Trace:
    [ 2723.861948] [<ffffffff814ebffb>] dump_stack+0x54/0x8d
    [ 2723.861951] [<ffffffff814e95a6>] __schedule_bug+0x4d/0x5b
    [ 2723.861955] [<ffffffff814f15df>] __schedule+0x93f/0x950
    [ 2723.861958] [<ffffffff81016f70>] ? show_stack_log_lvl+0xd0/0x1c0
    [ 2723.861962] [<ffffffff81018245>] ? show_stack+0x25/0x50
    [ 2723.861965] [<ffffffff8107db4c>] ? process_one_work+0x1ec/0x450
    [ 2723.861968] [<ffffffff814f1619>] schedule+0x29/0x70
    [ 2723.861971] [<ffffffff8107e578>] worker_thread+0x1c8/0x3a0
    [ 2723.861974] [<ffffffff8107e3b0>] ? manage_workers.isra.23+0x2b0/0x2b0
    [ 2723.861977] [<ffffffff81084e60>] kthread+0xc0/0xd0
    [ 2723.861981] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120
    [ 2723.861983] [<ffffffff814faafc>] ret_from_fork+0x7c/0xb0
    [ 2723.861987] [<ffffffff81084da0>] ? kthread_create_on_node+0x120/0x120

    Has anyone find a fix for this?  I've been using my Dragon Dictate headset on my MacBook Pro for about a year, and then today, when I plugged it in, I got this:
    4/16/14 10:01:04.000 AM kernel[0]: USBF:    47.766    The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 1 of Hub at 0x4000000)
    4/16/14 10:01:07.000 AM kernel[0]: USBF:    50.269    AppleUSBHubPort::FatalError - Port 1 of Hub at 0x4000000 reported error 0xe00002c7 while doing clearing port power feature
    4/16/14 10:01:07.000 AM kernel[0]: USBF:    50.269    The IOUSBFamily was not able to enumerate a device.
    Here is what I have tried so far:
    Reset the PRAM
    Reset SMC
    Verify disk (there were no problems)
    Repair permissions
    Boot with an external USB hard drive (which works fine on the "problem" computer) that contained an old SuperDuper clone of my hard drive from several months ago. I received the same "The IOUSBFamily was not able to enumerate a device" error when I plug in the headset.
    Tried to headset on another computer, and it worked fine.
    Plug in an external USB keyboard into the problem computer, and it works fine.
    All of this would lead me to conclude that it is a hardware problem. But it seems that if it were a hardware problem, the external USB keyboard and external USB hard drive would not work (which they do). If the problem were with the headset, it wouldn't work on another computer, but it does.  So I'm wondering if it's some sort of firmware issue…???????  URG!!!!!!

  • Calculating co-ordinate distances between specific atoms

    Hi,
    Below is some code to calculate distances between all pairs of atoms. However, i need to make it slightly more specific by only calculating the distance between certain pairs of atoms
    input
    ATOM 5 CA PHE 1 113.142 75.993 130.862
    ATOM 119 CA LEU 7 113.101 72.808 140.110
    ATOM 138 CA ASP 8 109.508 74.207 140.047
    ATOM 150 CA LYS 9 108.132 70.857 141.312
    ATOM 172 CA LEU 10 110.758 70.962 144.119
    e.g distance between all pairs for atoms 5, 119, 150 and 172 (say), last three columns are x,y and z co-ordinates
    code it self
    import java.util.*;
    import java.io.*;
    public class Distance {
    public static void main(String[] args) {
    System.out.println("***Campbells PDB Distance Calculator***" + "\n");
    new Distance();
    System.out.println("\nResults printed to file DistanceCalculations" + "\n");
    System.out.println("\nDue to nature of code, if rerun results will be appended to the end of previous run.");
    public Distance() {
    Vector atomArray = new Vector();
    String line;
    try{
    System.out.println("Enter PDB file:" + "\n");
    BufferedReader inputReader =new BufferedReader (new InputStreamReader(System.in));
    String fileName = inputReader.readLine();
    if ( fileName !=null) {
    BufferedReader inputDistance = new BufferedReader (new FileReader (fileName));
    while (( line = inputDistance.readLine()) !=null && !line.equals(""))
    Atom atom = new Atom(line);
    atomArray.addElement(atom);
    for (int j=0; j<atomArray.size(); j++) {
    for (int k=j+1; k<atomArray.size(); k++) {
    Atom a = (Atom) atomArray.elementAt(j);
    Atom b = (Atom) atomArray.elementAt(k);
    Atom.printDistance (a,b);
    } //if
    } //try
    catch (IOException e) {
    System.out.println("Input file problem");
    } catch (Exception ex) {
    System.out.println (ex);
    class Atom {
    public double x, y, z;
    public String name;
    public Atom(String s) throws IllegalArgumentException {
    try {
    StringTokenizer t = new StringTokenizer (s, " ");
    t.nextToken();
    this.name = t.nextToken();
    for (int j=0; j<3; j++) t.nextToken();
    this.x = new Double(t.nextToken()).doubleValue();
    this.y = new Double(t.nextToken()).doubleValue();
    this.z = new Double(t.nextToken()).doubleValue();
    catch (Exception ex) {
    throw new IllegalArgumentException ("Problem!!!! :-(");
    public String toString() {
    return "atom : " + name + "(x=" + x + " y=" + y + " z=" + z + ")";
    public double distanceFrom (Atom other) {
    return calculateDistance (x, y, z, other.x, other.y, other.z);
    public static double calculateDistance (double x1, double y1, double z1, double x2, double y2, double z2) {
    return Math.sqrt(Math.sqrt(Math.pow(Math.abs(x1-x2),2)+Math.pow(Math.abs(y1-y2),2))+Math.pow(Math.abs(z1-z2),2));
    public static void printDistance (Atom a, Atom b) {
    try{
    FileWriter fw = new FileWriter("DistanceCalculations", true);
    PrintWriter pw = new PrintWriter (fw, true);
    if
    (a.distanceFrom(b) <9){
    pw.println("Distance between " + a.toString() + " and " + b.toString() + " is " + a.distanceFrom(b));
    pw.flush();
    pw.close();
    } // if??
    } //try loop
    catch(IOException e) {
    System.out.println("System error");
    }

    ok, essentially
    want to calculate distance between to ranges. Say
    range 1 is the first three, range 2 the rest. THen
    calculate distance between all possible pairs between
    these two rangesYes - and no doubt that any number of people here could write it for you. But that's not what the forum is about. So what, exactly, is preventing you from doing it?
    Sylvia.

Maybe you are looking for

  • RFC Sender to start Sync/Async Bridge

    Hi, I'm trying to start a Sync/Async Bridge calling RFC. When importing RFC into Integration Repository, by default it creates two Message Type for request and response (RFCNAME and RFCNAME.response). My scenario is configured as follows: <b><u>Integ

  • How to check multiple special characters in this query.

    When the master_title has no comma in it, I am getting an empty master_title. This is because INSTR(master_title,',',1,1) is returning 0. In addition, I want to be able to specify other characters besides the comma. Example: ":" "/" "-". Can we fit t

  • Is iSight the BEST webcam available for Macs?

    Can anyone tell me if iSight is really the best webcam for the Mac? Assuming I find the appropriate 3rd party software to support it, is there a better webcam available? Also, my Digital Video Camcorder does will not work for this purpose. Thanks!

  • Individual episode artwork to show up for my podcast on itunes?

    I have individual artwork for each of my episodes for my podcast, filmception. I can't seem to get itunes to show this artwork for each episode. I read a bit on id3 tags and such, and it's all rather confusing. I've even added the artwork to the file

  • Weblogic Migration /  orion-ejb-jar.xml

    What is the best way to create the orion-ejb-jar.xml when migrating from Weblogic? This could be a utility that converts the weblogic deployment descriptors or a tool that helps me quickly create a new orion-ejb-jar.xml. I have quite a few so a manua