Accessing ora:getpreference inside xslt map

Hi
I need to access preferences values of the BPEL Suitcase Descriptor using ora:getpreference inside xslt map. I tried but it dosent work in xslt. Could any one please advise as to what is the way to access preferences values from inside a xslt.
Thanks
Buddhadev

is the bpws:getVariableData() function also not usable inside an XSL Mapper?
JDeveloper allows it. There is no error at compile and deploy times. It seens to be odd that those functions are there, but we cannot use them. Could any one explain this behavior?
I got the following error when trying to use ora:getPreference() or bpws:getVariableData():
(Error) Extension function namespace should start with 'http://www.oracle.com/XSL/Transform/java/
I need to call these functions to build a request from a variety of sources: process input, deployment descriptor preferences, variables, etc.... The real use case is more than one-to-one mapping/transformation.
If these functions are not usable inside an XSL Mapper, JDeveloper should not show them as available options.
Edited by: user9520923 on Sep 16, 2008 1:36 PM
Edited by: user9520923 on Sep 16, 2008 2:02 PM

Similar Messages

  • Ora:getPreference inside Transformation

    All,
    BPEL 10.1.3.4
    I declared a depl.descriptor variable in bpel and tried to access the value of this variable inside transformation using ora:getPreference. But when I invoked the bpel, the transformation got failed with the following stack
    avax.xml.transform.TransformerException: file:///C:/soa10g/product/10.1.3.1/OracleAS_1/bpel/domains/default/tmp/.bpel_OutOrderRequestMap_1.0_d0c3aa6e299725712cd454eb53c828f5.tmp/New.xsl<Line 38, Column 96>: XML-22016: (Error) Extension function namespace should start with 'http://www.oracle.com/XSL/Transform/java/'.
    *     at oracle.xml.jaxp.JXTransformer.reportXSLException(JXTransformer.java:926)*
    *     at oracle.xml.jaxp.JXTransformer.transform(JXTransformer.java:472)*
    *     at com.collaxa.cube.xml.xpath.functions.xml.GetElementFromXSLTFunction.transform(GetElementFromXSLTFunction.java:335)*
    *     at com.collaxa.cube.xml.xpath.functions.xml.GetElementFromXDKXSLTFunction.transform(GetElementFromXDKXSLTFunction.java:38)*
    *     at com.collaxa.cube.xml.xpath.functions.xml.GetElementFromXSLTFunction.evaluate(GetElementFromXSLTFunction.java:144)*
    *     at com.collaxa.cube.xml.xpath.functions.xml.GetElementFromXSLTFunction.call(GetElementFromXSLTFunction.java:89)*
    *     at com.collaxa.cube.xml.xpath.BPELXPathFunctionWrapper.evaluate(BPELXPathFunctionWrapper.java:50)*
    *     at oracle.xml.xpath.JXPathContext$JXFunction.invoke(JXPathContext.java:147)*
    *     at oracle.xml.xpath.JXPathContext$JXFunction.invoke(JXPathContext.java:116)*
    *     at oracle.xml.xpath.XPathExtFunction.evaluate(XPathExtFunction.java:254)*
    *     at oracle.xml.xpath.JXPathExpression.evaluate(JXPathExpression.java:181)*
    *     at com.collaxa.cube.xml.xpath.BPELXPathUtil.evaluate(BPELXPathUtil.java:189)*
    *     at com.collaxa.cube.engine.ext.wmp.BPELAssignWMP.evalFromValue(BPELAssignWMP.java:679)*
    *     at com.collaxa.cube.engine.ext.wmp.BPELAssignWMP.__executeStatements(BPELAssignWMP.java:143)*
    *     at com.collaxa.cube.engine.ext.wmp.BPELActivityWMP.perform(BPELActivityWMP.java:199)*
    *     at com.collaxa.cube.engine.CubeEngine.performActivity(CubeEngine.java:3698)*
    *     at com.collaxa.cube.engine.CubeEngine.handleWorkItem(CubeEngine.java:1655)*
    *     at com.collaxa.cube.engine.dispatch.message.instance.PerformMessageHandler.handleLocal(PerformMessageHandler.java:75)*
    *     at com.collaxa.cube.engine.dispatch.DispatchHelper.handleLocalMessage(DispatchHelper.java:217)*
    *     at com.collaxa.cube.engine.dispatch.DispatchHelper.sendMemory(DispatchHelper.java:314)*
    *     at com.collaxa.cube.engine.CubeEngine.endRequest(CubeEngine.java:5765)*
    *     at com.collaxa.cube.engine.CubeEngine.createAndInvoke(CubeEngine.java:1087)*
    *     at com.collaxa.cube.engine.delivery.DeliveryService.handleInvoke(DeliveryService.java:546)*
    *     at com.collaxa.cube.engine.ejb.impl.CubeDeliveryBean.handleInvoke(CubeDeliveryBean.java:342)*
    *     at sun.reflect.GeneratedMethodAccessor167.invoke(Unknown Source)*

    Please try to declare the namespace in XSLT for GetPreferences function. In case this deos not work, you can try below workaround,
    1. Create a temporary variable.
    2. Assign Value getPreferences values to temporary variable.
    3. Pass this temporary variable as input to XLST and then assign this variable in XSLT.
    Hope this will resolve your issue quickly.

  • Accessing ECC tables from XSLT mapping

    Hi All,
    I have requirement where I need to access a SAP table from PI XSLT mapping.
    Pls provide inputs on how to achieve it.
    Thanks,
    Navneeth K.

    Hello,
    You can refer to this document found in SAP Help
    http://help.sap.com/saphelp_nw04/helpdata/en/55/7ef3003fc411d6b1f700508b5d5211/frameset.htm
    And a sample blog
    /people/pooja.pandey/blog/2005/06/27/xslt-mapping-with-java-enhancement-for-beginners
    In your case, the idea is to call a java class inside the xslt mapping. So to access the ECC table, you can use a Java Mapping Class so that it would be easier to implement an RFC lookup.
    Hope this helps,
    Mark

  • How to use standard java functions in a XSLT mapping

    Hi All,
    I wish to use a standard java function in a XSLT mapping, The issue is either i am giving incorrect namespace which is used to invoke the function or the signature of the function call is incorrect, I have read all the links in http://help.sap.com, and i know <b> one can enhance a XSLT mapping by writing one's own java code and thereby using java standard functions </b>, but the requirement is such that i need to try and use java standard function in XSLT mapping itself.
    Please refer to the sample code below:
    <?xml version="1.0" encoding="UTF-8"?>
      <xsl:stylesheet version="1.0"  
        xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
        xmlns:javamap="java:java.lang.String">
    <xsl:output method="text"/>
    <xsl:template match="/">
    <xsl:variable name="input" select="Title">
    <xsl:if test="function-available('javamap:toUpperCase')">
    <xsl:value-of select="javamap:toUpperCase($input)"/>
    </xsl:if>
    Author:<xsl:value-of select="Author"/>
    </xsl:template>
    </xsl:stylesheet>
    error encountered is: Illegal number or type of arguments.
    please reply if you have tried a similar scenario in SAP XI.
    Thanks & Regards,
    Varun

    Hi Varun,
        First of all i want to tell you that as per the documentation you can only call the static function inside xslt mapping. Your toUpperCase method is a non static function.
    What i am getting is that you have an element called Author and you want to convert its value into uppercase.
    you can write your own user defined function which is static.
    Signature of your java method :
    public static string toUpperCase(String Author,Map inputparam)
    try this xslt map.
    <?xml version="1.0" encoding="UTF-8"?>
    <xsl:stylesheet version="2.0"
    xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    xmlns:javamap="java:JavaProgram">
         <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>
         <xsl:param name="Author">
                 <xsl:value-of select="//Author_name"/>
         </xsl:param>
         <xsl:param name="inputparam" />
         <xsl:template match="/">
         <Author>
                 <xsl:if test="function-available('javamap:toUpperCase')">
                  <xsl:value-of select="javamap:toUpperCase($Author,$inputparam)"/>
                 </xsl:if>
         </Author>
         </xsl:template>
    </xsl:stylesheet>
    Hope this will work.
    Thanks and Regards
    Vishal Kumar

  • How can i access value mapping table using xslt mapping

    Hi All,
    I have maintained value mapping table in integration directory.I want to access the data from the value mapping table in XSLT mapping using java function.PLease suggest me to do this.
    Thanks
    Pullarao.

    Value mapping that thread should solve your query !!!

  • Accessing a BPM Container Variable Inside A Mapping

    Hi
    Is It possible to access a BPM container variable (Simple type say a String )in a Mapping (message mapping). This mapping  is present in the same BPM itself. Is it possible to access the variable in the mapping.
    My basic objective is i need to read and update values between My message mapping and Bpm container simple type variable. I read a value  from BPM variable and then update this variable and again write it back to the BPM container variable and then again read it in a loop . Is it possible to do this exchange.

    Hi,
    The only way is to do with mapping. Totally you need to add your conatiner values into message and then thru mapping you can access.
    Using Container Operation-Append
    http://help.sap.com/saphelp_nw04/helpdata/en/59/e1283f2bbad036e10000000a114084/content.htm
    Regards,
    Moorthy

  • BPEL Processes failing in function ora:getPreference('STRING')

    Hi,
    I am having a BPEL process which is sometimes failing while fetching value of ora:getPreference('STRING') in a copy operation, and sometimes it works fine (like today there are 3 instances out of whcih 2 are success and the first one failed).
    The value of the preference is already defined in deployment descriptor.
    I am using SOA 10.1.3.3.
    Please help in this...
    Greetings,
    Ankit Chhabra

    Hi,
    To pass preference variables values in XSLT, create an element in one of the source schema of your XSLT.
    Use an assign action before that transformation,and assigns the value of preference var to that newly created variable.
    Use that variable value to map it to required target node.
    Hope this helps.
    Regards,
    Karan
    http://learn-oraclesoa.blogspot.com/

  • FileName in ABAP XSLT Mapping

    Dear SDN,
    In an integration scenario we are using sender File Adapter and a  ABAP XSLT Mapping.
    Is there any way to get the source FileName from such mapping.  Im trying to use the adapter-specific message attributes, but it doesn't work, and I didn´t find an example, probably I and doing somthing wrong.
    regards,
    GP

    Thank you for your help,
    I just try to access the adapter-specific attibutes using:
    <xsl:stylesheet version="1.0"
      xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
      xmlns:key="java:com.sap.aii.mapping.api.DynamicConfigurationKey">
    <xsl:variable name="filename"  select="key:create('http://sap.com/xi/XI/System/File', 'Directory')" />
    </xsl:stylesheet>
    but the following error raised:
    <SAP:Stack>Error while calling mapping program YXSLT_TEST (type Abap-XSLT, kernel error ID CX_XSLT_RUNTIME_ERROR) Call of unknown function</SAP:Stack>
    have you had this situation?

  • XSLT Mapping on ABAP Engine

    Hi All,
    I am trying to implement an XSLT mapping on the ABAP Engine. I went to the Transformation Workbench(SE80).I have created 4 levels of packages (Structure->Main->then 2 more levels) and  included Package Interface SAI_TOOLS in 'Use Accesses' tab.
    I have also set com.sap.aii.repository.mapping.additionaltypes=R3_ABAP|Abap-class;R3_XSLT|XSL (ABAP Engine)
    in the Exchange Profile.
    Now I want to create the tranformation (ST or XSLT) so that I can see it in the Repository.
    At which package level(1st to 4th), should I right-click and go to 'Create->More->Transformations' so that I can see this XSLT  Mapping program in the repository?
    I have followed all the links from help.sap.com but I am unable to get the desired result, i.e. see my Mapping in the Repository when I choose Mapping Program of type  'XSL->ABAP Engine', from the drop-down box in Interface Mapping.
    Kindly help.
    Regards,
    Puloma.

    Hi Naveen,
    I did as you told, i.e. keyed in the name of the ABAP Transformation program (mapping) name.I have not written any namespace for the Mapping program in the Interface Mapping Design, just the Program name.
    When I execute my mapping from se80, it works perfectly.
    I created this Transformation program at the topmost level (i.e. Structure package level).
    But when I execute my scenario, I get the following runtime error in sxmb_moni:
    Error in mapping program zpc_transfom2 (type R3_XSLT, kernel error ID UNCAUGHT_EXCEPTION).
    What is wrong? Did I create the transformation program at the wrong level?
    Regards,
    Puloma.

  • Can't Ping or access via SNMP Inside interface of 5505

    I have a remote site I'm trying to setup monitoring on and I can't get the inside interface to respond to a ping or SNMP requests.  I have tried everything I can find in the forums and on the web but this location will not cooperate.  I have full access to the ASA and to the inside network behind it.  IPSEC VPN tunnel is working perfectly.  I see the ping requests in the log on the ASA.  I turned on ICMP debugging and only see the echo request.. never an echo reply.  Below is a partial configuration.  If you need any more information, let me know.
    names
    name 192.168.0.0 Domain
    name 1.1.1.2 MCCC_Outside
    name 172.31.10.0 VLAN10
    interface Ethernet0/0
     switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
     nameif inside
     security-level 100
     ip address 192.168.23.1 255.255.255.0
    interface Vlan2
     nameif outside
     security-level 0
     ip address 1.1.1.1 255.255.255.0
    boot system disk0:/asa847-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns server-group DefaultDNS
     domain-name mtcomp.org
    object network obj-192.168.23.0
     subnet 192.168.23.0 255.255.255.0
    object network Domain
     subnet 192.168.0.0 255.255.0.0
    object network 172.31.0.0
     subnet 172.31.0.0 255.255.0.0
    access-list outside_1_cryptomap extended permit ip 192.168.23.0 255.255.255.0 any
    access-list outside_1_cryptomap extended permit ip 192.168.23.0 255.255.255.0 object Domain
    access-list inside_nat0_outbound extended permit ip 192.168.23.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.23.0 255.255.255.0 object Domain
    access-list Outside_NAT0_inbound extended permit ip object Domain 192.168.23.0 255.255.255.0
    access-list inside_access_in extended permit ip 192.168.23.0 255.255.255.0 any
    access-list inside_access_in extended permit ip any 192.168.23.0 255.255.255.0 inactive
    no pager
    logging enable
    logging timestamp
    logging buffered debugging
    logging trap informational
    logging asdm informational
    logging device-id hostname
    logging host inside 192.168.x.x 17/1514
    mtu inside 1500
    mtu outside 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (inside,any) source static obj-192.168.23.0 obj-192.168.23.0 destination static Domain Domain no-proxy-arp route-lookup
    route outside MCCC_Outside 255.255.255.255 1.1.1.1 1
    route outside 172.31.0.0 255.255.0.0 192.168.1.1 1
    route outside VLAN10 255.255.255.0 MCCC_Outside 1
    route outside Domain 255.255.0.0 192.168.1.1 1
    route outside 192.168.1.0 255.255.255.0 MCCC_Outside 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 192.168.1.81 255.255.255.255 inside
    http 192.168.1.0 255.255.255.0 inside
    http 192.168.23.0 255.255.255.0 inside
    snmp-server host inside 172.x.x.x community ***** version 2c
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs group1
    crypto map outside_map 1 set peer MCCC_Outside
    crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
    crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map interface outside
    management-access inside
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
      inspect icmp
    policy-map global-policy
    service-policy global_policy global
    prompt hostname context

    Hi,
    First of all let me clarify your trial.
    Where is your monitoring server?
    Is it behind inside or outside interface (please share ip adress)?
    From config it seems, it can be reach via outside interface. Then you have to make snmp check on outside interface, not on inside (cannot make a snmp/ping check on inside interface with request comming through outside inteface - it simply won't work).
    From the first check of routing table, I would suggest:
    delete : route outside MCCC_Outside 255.255.255.255 1.1.1.1 1 - doesn't make a sense route host address, when it's directly connected network (and more, route 1.1.1.2 to 1.1.1.1, when 1.1.1.1 is vlan2 interface)
    change : route outside 172.31.0.0 255.255.0.0 192.168.1.1 1; route outside Domain 255.255.0.0 192.168.1.1 1 - you should consider route it to 1.1.1.2 (if this is your next hop address at WAN).
    route outside VLAN10 255.255.255.0 MCCC_Outside 1 - why?
    I would use default route to somewhere at 1.1.1.0/24 range - next hop (router).
    HTH,
    Pavel

  • Raise error in an external-function of XSLT-mapping (ABAP)

    Hi,
    we implemented a xslt-mapping (ABAP) in PI with external-functions.
    It's a great feature and works fine.
    Now, we have to implement an error handling:
    The external-functions are reading data from an abap table. We have to stop the mapping (if a value in the table is missing).
    We wanna show an error inside the PI-Monitoring (red flag) with a valid error text.
    How can I raise an error inside an external-function?
    regards
    Wolfgang Hummel

    Hi Michal,
    thanks a lot for your answer.
    Can I set dynamic configuration inside an external funktion of an ABAP-XSLT?
    I added the CX_MAPPING_FAULT-Exception to my external-function method and raised an exception inside my external-funktion ... and I got an "UNCAUGHT_EXCEPTION" inside my mapping - bad
    regards
    Wolfgang

  • XSLT Mapping with Java Enhancement

    Hi All
    I am working on XSLT Mapping with Java Enhancement.
    To do this scenario i have followed the following link.
    http://help.sap.com/saphelp_nw04/helpdata/en/55/7ef3003fc411d6b1f700508b5d5211/frameset.htm
    As per the above link I have created Source and Target Data Types , Message Types , Mesage Interfaces, XSLT Mapping (using the transaction XSLT_TOOL) and Interface Mapping part and configred a simple file to file scenario in the ID part.
    Apart from this I have wirte the java code, compile the java code, create the jar file using .java and .class file and after creating the jar file import the .jar file in the imported archive of the IR..
    when I am trying to execute the scenario I am getting the successful message in SXMB_MONI but the target file is having the payload as given below.
    <?xml version ="1.0" encoding="UTF-8"?>
    <name xmlns:javamap="java:com.company.group.MappingClass"/>
    And as per the XSLT mapping the payload should be as below
    <?xml version ="1.0" encoding="UTF-8"?>
    <person>
    <name>Rinku Gangwani</name>
    </person>
    I have also followed the following blog link but still i am getting the same issue
    /people/pooja.pandey/blog/2005/06/27/xslt-mapping-with-java-enhancement-for-beginners
    could you please tell me what can be the reason that i am getting the blank targt field values in the payload.
    Thanks
    Rinku Gangwani

    Hi,
      The Transaction code XSLT_TOOL for ABAP xslt mapping.But the Java Enhancement is used for normal xslt mapping which we created using Stylus Studio.You can not access the Java Enhancement in ABAP xslt mapping.
    If you want to use Java Enhancement in xslt mapping then create a xslt mapping using Stylus Studio and save the file as .xsl and zip the .xsl and import to import archive.
    Regards,
    Prakasu.M
    Edited by: prakasu on May 28, 2009 1:46 PM

  • Java enhancement in XSLT mapping in PI 7.1 and JDK5 XML processing

    Hi,
    I am implementing an XSLT mapping and I need to use java enhancements. I got those working but only if I check "Use SAP XML Toolkit" from Operation Mapping. I would like to use JDK5 XML processing.
    I also got this message to trace:
    Resource not found: META-INF/services/javax.xml.parsers.SAXParserFactory
    Thrown:
    com.sap.aii.ib.server.mapping.execution.MappingClassNotFoundException: META-INF/services/javax.xml.parsers.saxparserfactory
    I tried to use com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl but still couldn't get java enhancement working.
    Is there a way to get JDK5 XML processing working with java enhancements?

    > Is there a way to get JDK5 XML processing working with java enhancements?
    No. Java processing inside XSLT is no standard. So it works only with SAP lib.
    Regards
    Stefan

  • How to Supress null target Elements in XSLT Mapping

    Hi Experts,
    I need to Strip off (remove) Null tags from my ouput XML document.
    My XSLT Mapping file
    <?xml version='1.0' ?>
    <xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
    <xsl:template match="/">
    <a:A2ACU>
    <a:PartNo>
    <xsl:value-of select="Specifications/Specification/PARTNO"/>
    </a:PartNo>
    <a:Revision>
    <xsl:value-of select="Specifications/Specification/REVISION"/>
    </a:Revision>
    <a:ENERGY>
    <xsl:for-each select="Specifications/Specification/Section">
    <xsl:variable name="Sec_ID">
    <xsl:value-of select="SECTIONID"/>
    </xsl:variable>
    <xsl:if test="$Sec_ID = '700015'">
    <xsl:for-each select="Item">
    <xsl:variable name="Item_ID">
    <xsl:value-of select="ITEMID"/>
    </xsl:variable>
    <xsl:if test="$Item_ID = '701134'">
    <xsl:for-each select="PropertyGroup/Property">
    <xsl:variable name="Pro_ID">
    <xsl:value-of select="PROPERTYID"/>
    </xsl:variable>
    <xsl:if test="$Pro_ID = '700232'">
    <xsl:variable name="Atr_ID">
    <xsl:value-of select="ATTRIBUTEID"/>
    </xsl:variable>
    <xsl:if test="$Atr_ID = '700064'">
    <xsl:value-of select="STRING2"/>
    </xsl:if>
    </xsl:if>
    </xsl:for-each>
    </xsl:if>
    </xsl:for-each>
    </xsl:if>
    </xsl:for-each>
    </a:ENERGY>
    </a:A2ACU>
    </xsl:template>
    </xsl:stylesheet>
    If any one of the condition in ENRGY TAG FAILS it is giving a output as
    - <A2ACU>
    <PartNo>123456789</PartNo>
    <Revision>2</Revision>
    <ENERGY></ENERGY>
    - </A2ACU>
    But as per my new requirement I need to check the Empty value in all the tags and need to strip of them form final output ...like..
    - <A2ACU>
    <PartNo>123456789</PartNo>
    <Revision>2</Revision>
    - </A2ACU>
    Can any one please suggest me whether any function is availble to this stripping
    Thanks in Advance
    Ram

    Hi Ram,
    try to put the tag inside the IF conditions.
    It'd be something like:
    > <xsl:for-each select="Specifications/Specification/Section">
    > <xsl:variable name="Sec_ID">
    > <xsl:value-of select="SECTIONID"/>
    > </xsl:variable>
    > <xsl:if test="$Sec_ID = '700015'">
    > <xsl:for-each select="Item">
    > <xsl:variable name="Item_ID">
    > <xsl:value-of select="ITEMID"/>
    > </xsl:variable>
    > <xsl:if test="$Item_ID = '701134'">
    > <xsl:for-each select="PropertyGroup/Property">
    > <xsl:variable name="Pro_ID">
    > <xsl:value-of select="PROPERTYID"/>
    > </xsl:variable>
    > <xsl:if test="$Pro_ID = '700232'">
    > <xsl:variable name="Atr_ID">
    > <xsl:value-of select="ATTRIBUTEID"/>
    > </xsl:variable>
    > <xsl:if test="$Atr_ID = '700064'">
    > <a:ENERGY><xsl:value-of select="STRING2"/></a:ENERGY>
    > </xsl:if>
    > </xsl:if>
    > </xsl:for-each>
    > </xsl:if>
    > </xsl:for-each>
    > </xsl:if>
    > </xsl:for-each>
    Regards,
    Henrique.

  • Alerts in case of XSLT Mapping failure without BPM

    Dear All,
    We are working on IDOC - SOAP Scenario and mapping is through XSLT Mapping.
    when the Vendor number field in IDOC is coming blank/invalid, the mapping should fail and an email alert should go to business.
    This IDOC-SOAP is Asynchronous and not using any BPM. So can we raise a alerts withut using BPM.
    I have gone through some blogs but I can see the alerts in Inbox but where as I want the alert through EMAIL.
    Any pointers are highly appreciated.
    Regards,
    Srini

    Dear Srinivas,
    When you want the Alert to be send through email,then you need to configure the required mentioned below.
    1.In SU01 ,Assign the corresponding Email ID for the Recipient of the ALERT.
    2. In , RWB>ALERT INBOX> PERSONALIZATION--> Go to Time Independent Delivery and  check the Email option.
    3. Go to the transaction  code SCOT,INT->SMTP and mention the corresponding  Mail Host and Port in SMTP Address.Then select the set in the Internet of supported Address Types and give mail address in the Address area.
    Note: Check whether Node is use is checked.
    You can find the mails which are pending/failed/success in the SOST Transaction code.
    Check if you have access for this configuration.Otherwise get help from Basis team.
    Regards
    B.Dheepa

Maybe you are looking for

  • GPS on N95

    Hello! How can I use the built-in GPS on my N95? Every time I start the Nokia Maps program, it connects to the internet. Can I use the GPS without having to connect to the internet? If yes, can anyone point me to some guide, because these nokia sites

  • Please Help!! Error in document : BKPFF $ DEVCLNT

    Hi All Gurus, I am trying to use BAPI - BAPI_ACC_DOCUMENT_POST to post to FB50. I am using the below paramaters - DOCUMENTHEADER          TABLES        ACCOUNTGL                      CURRENCYAMOUNT RETURN. But I am getting the error -   Error in docu

  • Cable box turning itself off

    A few times per night my cable box just randomly shuts off for no apparent reason then when I turn it back on it I get the FiOS loading screen. This is frustrating because many times I am in the middle of recording something. A lot of times I will be

  • Won't boot to Win XP off HDD but will load

    Just built system, all new, Windows XP installed and activated after flashing mobo and updating all drivers.  Boot order in BIOS is CD-HDD-Floppy, have tried HDD-CD-Floppy, no difference.  HDD is sole drive master on IDE 1 (yes, the two opticals on I

  • CUCM & Exchange on UCS

    Hi, Apologies for noob question but is it possible to run CUCM & MS Exchange on the same UCS C server? Is there a sizing tool that will help me spec this? Rich