ACE 30, dropped conns counter incorrect number

We have host in our network which tests reachability of ACE's VIP address at regular intervals. The test sequence consists of 4 TCP packets (SYN, SYN-ACK, FIN-ACK, RST-ACK; see picture attached) and causes incrementation of "dropped conns" counter in show service-policy output.
ACE30# sh service-policy XYZ detail | inc drop
        dropped conns    : 266812
        conn-rate-limit      : 0         , drop-count : 0
        bandwidth-rate-limit : 0         , drop-count : 0
                     dropped conns: 238177
            dropped conns    : 7
ACE30# sh service-policy XYZ detail | inc drop
        dropped conns    : 266813
        conn-rate-limit      : 0         , drop-count : 0
        bandwidth-rate-limit : 0         , drop-count : 0
                     dropped conns: 238178
            dropped conns    : 7
Is this normal behavior of ACE? Is there a way how to get rid of the dropped cons counter incrementation.
Petr

Hi Kanwal,
When I set "no normalization" problem is solved. Disadvantage of this appoach is that by this command all trafic on interface is affected.
I've also tried to tune  timeout for embrionic connection.
When I had set it to 0, dropped conns counter stopped to increase. Client which sends those "SYN,FIN" packets ends communication after 30 seconds using RST. This cause that connection ends and dropped conns counter does not increase.
Unfortunately for some reason sometimes happens that client doesn't send this final RST packet. This cause that number of active connection increases ...
ACE30-hto2/TEST-WEBAPP# sh service-policy XYZ | inc conn
        curr conns       : 9         , hit count        : 2279841   
        dropped conns    : 385467    
        conns per second    : 0         
        conn-rate-limit      : -         , drop-count : -         
ACE30-hto2/TEST-WEBAPP# sh service-policy XYZ | inc conn
        curr conns       : 22        , hit count        : 2283653   
        dropped conns    : 385467    
        conns per second    : 0         
        conn-rate-limit      : -         , drop-count : -
When I set timeout to 120, those "non RST" connections are cleared but of course dropped conns counter increases ...
I guess I will try to reconfigure the probe.
Kanwal, thanks for your suggestions!
Kind regards
Petr

Similar Messages

  • ACE dropped conns with New Vip

    I have been load balancing our mail servers for quite sometime without an issue however I have been using a dynamic Nat statement. This however causes our mail team to have problems with logging. I then created a whole new vlan and ace context for the mail servers to use. This is where my dilemma is.
    I now have dropped connections going to my vip but only from one server which is our Anti-span / Antivirus server which filters the mail from the internet and then passes it on to these other mail servers.
    I can send mail just fine if I don't use the VIP I created.
    Also if I use a Nat statement the mail sends fine but obviously I don't want to use that anymore.
    The only thing I see that the ACE is not doing is closing the connections. So if every five minutes I do a clear conn all, I won't get any dropped connections for at least 10 to 15 minutes but I am not going to be doing this. Right now I have a server with a script that logs into the ace and then clears the connection but this is a band aid problem.
    Here is my config. This is the only thing on this context. All 6 of my other contexts do not have this issue.
    access-list ALL line 10 extended permit ip any any
    access-list ALL line 18 extended permit icmp any any
    probe smtp SMTP_Probe
    interval 15
    passdetect interval 30
    expect status 210 250
    parameter-map type connection TCP_Mail_TO
    slowstart
    set timeout inactivity 2
    set tcp timeout half-closed 15
    set tcp ack-delay 300
    tcp-options timestamp allow
    rserver host hub2
    ip address *.*.*.*.*.*
    inservice
    serverfarm host Mail_Hub_Servers_SF
    probe SMTP_Probe
    rserver hub2 25
    inservice
    class-map match-all Mail_Hub_VIP
    2 match virtual-address *.*.*.*.*.* tcp eq smtp
    class-map type management match-any Remote_Management
    2 match protocol http any
    3 match protocol icmp any
    4 match protocol telnet any
    5 match protocol ssh any
    policy-map type management first-match rmt_mgt_policy
    class Remote_Management
    permit
    policy-map type loadbalance first-match Mail_Hub_VIP-l7slb
    class class-default
    serverfarm Mail_Hub_Servers_SF
    policy-map multi-match int7
    class Mail_Hub_VIP
    loadbalance vip inservice
    loadbalance policy Mail_Hub_VIP-l7slb
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    connection advanced-options TCP_Mail_TO
    access-group input ALL
    interface vlan 108
    ip address *.*.*.*.
    alias *.*.*.*
    peer ip address *.*.*.*.
    no normalization
    no icmp-guard
    service-policy input rmt_mgt_policy
    service-policy input int7
    no shutdown
    ip route 0.0.0.0 0.0.0.0 *.*.*.*

    I would like to avoid trying routed mode for this just right now because we haven't had a good experience in routed mode here. I can try creating a new context in routed mode because I cannot experiment with production mail. Also I have this scenario working fine on 3 other contexts with 0 Connections being dropped. The other thing is I am not dropping all connections its dropping about 2-8%. of the connections. I have been playing around with connection limits.
    Interface: vlan 108
    service-policy: int7
    class: Mail_Hub_VIP
    loadbalance:
    L7 loadbalance policy: Mail_Hub_VIP-l7slb
    VIP Route Metric : 77
    VIP Route Advertise : ENABLED-WHEN-ACTIVE
    VIP ICMP Reply : ENABLED-WHEN-ACTIVE
    VIP State: INSERVICE
    curr conns : 1 , hit count : 12052
    dropped conns : 839
    client pkt count : 385190 , client byte count: 375718706
    server pkt count : 133814 , server byte count: 11089648
    conn-rate-limit : 50 , drop-count : 0
    bandwidth-rate-limit : - , drop-count : -
    Parameter-map(s):
    TCP_Mail_TO

  • ACE dropped conns problem (Bridged mode)

    Dear all,
    I configured an ACE in bridged mode (inside vlan: 2012, outside vlan: 2021) and I apply the L4 policy on the 2 VLAN interface to loadbalance HTTP incoming request (Virtual IP: 172.22.22.130).
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    But I need also that some other server connected to the same vlan 2112 and having to send HTTP request on the same VIP but this failed and I get dropped conns.
    Can anyone helps?
    Regards
    Abdelaziz

    Hi Olivier,
    This below the full config, and my need is to make a server in the inside VLAN 2112 (172.22.22.121) to open HTTPS connexion on the VIP (172.22.22.130 for rserver .131 & .132). Trafic from the outside is working well.
    Thanx,
    Abdealziz
    Generating configuration....
    access-list BPDU-Allow ethertype permit bpdu
    probe tcp HTTPS
      port 443
      interval 15
      passdetect interval 15
      passdetect count 1
    probe icmp PING
      interval 5
    rserver host CASHUB131
      ip address 172.22.22.131
      inservice
    rserver host CASHUB132
      ip address 172.22.22.132
      inservice
    serverfarm host SFARM-EXCAS130
      probe HTTPS
      rserver CASHUB131
        inservice
      rserver CASHUB132
        inservice
    parameter-map type connection TCP_IDLE_30min
      set timeout inactivity 1800
    class-map match-all CLASS-L4-VIP-EXCAS130
      2 match virtual-address 172.22.22.130 any
    class-map type management match-any REMOTE-ACCESS
      description management ACE
      10 match protocol telnet any
      20 match protocol ssh any
      30 match protocol icmp any
      31 match protocol https any
      32 match protocol snmp any
    policy-map type management first-match REMOTE-MGT
      class REMOTE-ACCESS
        permit
    policy-map type loadbalance first-match POLICY-L7-VIP-EXCAS130
      class class-default
        serverfarm SFARM-EXCAS130
    policy-map multi-match POLICY-LB-HMC-2112
      class CLASS-L4-VIP-EXCAS130
        loadbalance vip inservice
        loadbalance policy POLICY-L7-VIP-EXCAS130
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface bvi 1
      ip address 172.22.22.250 255.255.255.0
      peer ip address 172.22.22.251 255.255.255.0
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.22.22.254

  • Special Field- Record Number count incorrect

    Hi,
    Looks like the record number special field is displaying the record count incorrectly. There are no records returned by the query nor there are any records in the detail section of the report. But the record number in the report footer shows 1. Is there any way to fix this?
    Thanks in advance,
    Sirisha

    One way to "fix" it would be to do a count on a field in the details section and then compare that count to NULL or zero and if so then display zero otherwise display the recordnumber.
    1.  Create a running total on a field in the details section that doesnt reset.
    2.  Create a formula with:
    if isnull({#RTotal0}) or {#RTotal0} = 0 then 0 else recordnumber
    3.  Display the formula instead of the recordnumber in the report footer.

  • ACE: dropped conns due to header insert

    My LB is dropping connections on port 443 when I have "insert-http source header-value "%is" configured. Other ports such as 80, or 8080 are working. The config is the same for all ports.
    class-map match-any Service_VIP_Class
    4 match virtual-address 1.1.1.1 tcp eq https
    policy-map type loadbalance first-match Service_L7_Policy
    class class-default
    serverfarm Service_Serverfarm
    insert-http source header-value "%is"
    policy-map multi-match Service_LB_Policy
    class Service_VIP_Class
    loadbalance vip inservice
    loadbalance policy Service_L7_Policy
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    I see dropped conns on the service policy. When I remove the header insertion config, it connects ok.
    Please help!

    There is no way any device (including ACE) can open an https packet to insert anything.
    Only exception:
    You offload ssl using server keys and certs.Then make changes to the decrypted packet.
    Syed

  • Macbook Air froze/turned it off to restart.  Now it won't restart it goes to Gray screen with apple like it is loading, but when gets to the end it turns off.  Try repairing it states incorrect number of thread records.Volume Macintosh HD found corrupt

    Macbook Air froze/turned it off to restart.  Will not restart just goes to gray screen like it is reloading and then shuts off.  Have tried everything.  When trying to reapir it says incorrect number of thread records, should be 108456 instead of 108455.  Invalid voume directory count/the volumbe macintosh HD was found corrupt and needs to be repaired.  How do I repair it?

    Hello cgstephen
    You would need to contact Apple or an Apple Authorized Service provider by checking out the page below. It will have everything you need to know about setting your MacBook Air up to get it repaired.
    Service Answer Center - Mac notebooks
    http://support.apple.com/kb/index?page=servicefaq&geo=United_States&product=Macn otebooks
    Regards,
    -Norm G.

  • Count the number of seeds using labview - new to labview

    hello,
    I am new to labview and need to create a VI to count the number of seeds being dropped.
    I understand you can do this using labview.
    please can someone direct me to a tutorial or an example to do this?
    I use a camera - how do you connect up the camera to work with labview?
    thanks

    You'll have to use IMAQ vision, an addon package that brings LabVIEW a series of tools for image analysis.
    There are a number of examples/solutions. Some deal already with particle counting.
    Although your question is rather vague, I suppose you want to get more info tahn the mere particle number (shape, color). That's definitely possible with LabVIEW, but will require a significant investment.
    There is a forum dedicated to Machine Vision where you'll get all the required help.
    Chilly Charly    (aka CC)
             E-List Master - Kudos glutton - Press the yellow button on the left...        

  • How to count the number or rows in file

    Hi Experts,
    I am file as source and Oracle as target. My file containing the some data which is going to load to the target.
    My requirement is that I want to count the number of rows which my file contains. Please help me how to count the total number of rows in file.
    Thx,
    Sahadeva.

    Hi,
    You won't give a name DEST_USER_NAME:ODI will get these information.
    it is important  Command on source and Command on Source side .
    -Pls write jython code on Command on Source side
    -And Command On Target side Choose technology as Oracle and set logical schema to HR_logical
    Sorry my mistake.İt is related jython syntax.Here is code:
    import java.lang as lang
    import java.sql as sql
    import java.lang.String
    import os
    lang.Class.forName("<%=snpRef.getInfo("DEST_JAVA_DRIVER")%>")
    cons=sql.DriverManager.getConnection("<%=snpRef.getInfo("DEST_JAVA_URL")%>", "<%=snpRef.getInfo("DEST_USER_NAME")%>", "<%=snpRef.getInfo("DEST_PASS")%>")
    dblinks= cons.createStatement()
    file1=open('EMP.txt','r')
    count=0
    line=file1.readline()
    while line !='':
         count+=1
         line=file1.readline()
    file1.close()
    sqlQuery = "insert into HR.ETL_FILE_LOG (FILE_COUNT) values (count)"
    rqQuery= dblinks.execute(sqlDBLink)
    cons.close()
    Regards

  • Is there a way to count the number of times an array moves from positive to negative?

    I have an array of values, and I need to find the number of times that the array changes signs (from positive to negative, or vice versa). In other words from a graphical standpoint, how many times a certain line crosses the x-axis. Counting the number of times the array equals zero does not help however, because the array does not always equal exactly zero when it crosses the axis (ie, the points could move from .1 to -.1).
    Thanks for you help. Feel free to email me at [email protected] I only have lv 5.1.1 so if you attach any files, they cannot be version 6.0.

    Attached is a VI showing the # of Pos and Neg numbers in an array, with 0 considered as non-Pos. It is easily modifiable to other parameters - including using the X-axis value as your compare point versus only Zero.
    This is a modified VI from LV (Separate Array.vi)
    Compare this with your other responses to find the best fit.
    Doug
    Attachments:
    arraysizesposneg.vi ‏40 KB

  • When I restore my Mac with Time Machine and then want to partition my disk, Disk Utility always says incorrect number of extended attributes

    When I need to restore my Mac from a time machine backup and then partition my hard disk (the disk inside the computer not the time machine disk), Disk Utility always says "Incorrect Number of Extended Attributes". I then boot into Recovery HD and run disk repair. The result? "The volume Macintosh HD appears to be OK". So then I reboot into normal OS and try the partition again, still Incorrect number of extended attributes. I have even tried /sbin/fsck -fy in single-user mode but it still says the volume is ok. I have tried partition my disk in the recovery HD and it still fails.
    Can anyone please help me solve this problem?

    Try something stronger, such as DiskWarrior or TechTool Pro.
    iMac refurb (27-inch Mid 2011), OS X Mavericks (10.9.4), SL & ML, G4 450 MP w/Leopard, 9.2.2

  • How do I count the number of records returned in the CMIS query

    How do I count the number of records returned in the query CMIS?
    SELECT COUNT(*) FROM ora:t:IDC:GlobalProfile WHERE ora:p:xRegionDefinition = \'RD_PROJETOS_EXCLUSIVOS\''}
    Euler Homero

    Hi Euler,
    interestingly enough, the reference guide for CMIS ( http://wiki.alfresco.com/wiki/CMIS_Query_Language ) that I found does not mention the COUNT function at all. On the other hand it states that: "The SELECT clause identifies which virtual columns to return in the result set. It can be either a comma-separated list of one or more queryNames of properties that are defined by queryable object types or * for all virtual columns."
    There are, however, some other posts like e.g. http://alfrescoshare.wordpress.com/2010/01/20/count-the-total-number-of-documents-in-alfresco-using-sql/ which state that they could make it working.
    Having asked in the WebCenter Portal forum, I assume that your content repository is WebCenter Content. The CMIS doc for the Content is available here: http://docs.oracle.com/cd/E23943_01/doc.1111/e15813.pdf (no COUNT there either). It does, however, mention explicitly that "CMIS queries return a Result Set where each Entry object will contain only the properties that were specified in the query.". This means your could rather investigate the Result Set. Note that there are also other means than CMIS how to get the requested result set (e.g. calling a search service directly via so-called RIDC).
    In the given context I am also interested what your use case is. OOTB CMIS in WebCenter Portal is used, for instance, in Content Presenter, where it is content rather than "parameters" what's displayed.

  • How to count the number of rows in a cube!!??

    Experts,
    I can somebody tell me how do I count the number of rows in my cube when i am using listcube???..
    Thanks
    Ashwin

    Hi,
    have a look ath this theard too
    Number of Records in Cube
    regards

  • How to count the number of rows in a resultser object?

    hi there
    how to count the number of rows in a resultser object which may contains millions of rows? besides using a while loop? thanks

    You don't, you execute a query whose result is the record count of those records that match the search and then you execute the actual query to create your record set. Typically you do
    select count(id) from YourTable where [filter]
    from the resulting ResultSet do
    int res.getInt(1);
    which gives you the count and then
    select id from YourTable where [filter]
    to produce the actual result set.
    in the second query the id part can be substituted with the actual fields you want.

  • Incorrect Number error message only started today ...

    Hi there
    Had my N900 since July and this is first time I have had major problem..
    Really weird...I text my wife everyday and have been doing so today as well..but within the last half hour, when I try to SMS her, I get an "Incorrect Number" error message
    I have tried deleteing the conversation and restrarting the phone but problem still there
    I can SMS other contacts
    I can still dial my wife's number
    But for some reason, the SMS for that number is now failing
    Any ideas??
    Thanks
    Solved!
    Go to Solution.

    Turns out three has disconnected phone by accident. So morale of the story is avoid the three network like the plague if you can! Their customer service well and truly sucks!

  • When I check my boot SSD drive using Disk Utility under Mavericks, I often get "Incorrect number of extended attributes" errors.  But if I boot off an external drive and check the same SSD, no errors are reported.  Is this a bug in Mavericks?

    When I check my boot SSD drive using Disk Utility under Mavericks, I often get "Incorrect number of extended attributes" errors.  But if I boot off an external drive and check the same SSD, no errors are reported. 
    This happens not just with the SSD in my Mac Mini, but with another SSD in my MacBook (both now running Mavericks).  So far as I know, all of the kit I am using is in good order (despite the file corruption reports).  So I am beginning to wonder if it could be due to a bug in Mavericks?  Both SSD drives have been formatted to MacOS Extended (journaled) format.  Should I have used a different format, I wonder?
    Has anyone else encountered this issue?
    Does anyone have a solution?
    Or an explanation that might help my investigation of the issue?
    Thanks guys,

    I understand that the Corsair Force 3 is not one of the SSD drives that are supported on Apple Macs. 
    I did try downloading and using Trim Enabler, but the error message came up both when it was off and when it was on.
    I understand that not everyone thinks Trim Enabler is a good program, though there is a new version out now, so I may give it another try.

Maybe you are looking for

  • Mapping transformation error

    I am getting following error in runtime analysis while i am trying to receive data through file adapter : com.sap.aii.utilxi.misc.api.BaseRuntimeExceptio thrown during application mapping com/sap/xi/tf/_abb2_mm_: RuntimeException in Message-Mapping t

  • TimeStampADD-Workflows

    Gusy I am trying to add 3 hours to a date/time field in service request and the result is to be displayed in another date/time field on the same service request The problem is Timestampadd function is giving errors on workflow. It gives me an error s

  • Query performance is BAD

    My query is like : SELECT s.cust_name, t.file_name, u.mail_name, v.address, count(1) FROM s, t, u,v WHERE GROUP BY s.cust_name, t.file_name, u.mail_name, v.address I have around 5 milion records I am getting in the query without the grouping finction

  • Can i delete history

    I am trying to delete history in ie and generaly any browser all atonce if possible. it is a roundabout way to log out. the way the login is set up is that you type in user name and pass and that is the page you go to */user+pass.html* it is nice and

  • Why I can not link an app to my FB account?, Why I can not link an app to my FB account?

    I would like to link several games to my Facebook account, and I am giving the allowance to the app, but afterall the app doent shown under  the Privancy - Facebook page. What can I do?