ACE: dropped conns due to header insert

My LB is dropping connections on port 443 when I have "insert-http source header-value "%is" configured. Other ports such as 80, or 8080 are working. The config is the same for all ports.
class-map match-any Service_VIP_Class
4 match virtual-address 1.1.1.1 tcp eq https
policy-map type loadbalance first-match Service_L7_Policy
class class-default
serverfarm Service_Serverfarm
insert-http source header-value "%is"
policy-map multi-match Service_LB_Policy
class Service_VIP_Class
loadbalance vip inservice
loadbalance policy Service_L7_Policy
loadbalance vip icmp-reply active
loadbalance vip advertise active
I see dropped conns on the service policy. When I remove the header insertion config, it connects ok.
Please help!

There is no way any device (including ACE) can open an https packet to insert anything.
Only exception:
You offload ssl using server keys and certs.Then make changes to the decrypted packet.
Syed

Similar Messages

  • ACE dropped conns with New Vip

    I have been load balancing our mail servers for quite sometime without an issue however I have been using a dynamic Nat statement. This however causes our mail team to have problems with logging. I then created a whole new vlan and ace context for the mail servers to use. This is where my dilemma is.
    I now have dropped connections going to my vip but only from one server which is our Anti-span / Antivirus server which filters the mail from the internet and then passes it on to these other mail servers.
    I can send mail just fine if I don't use the VIP I created.
    Also if I use a Nat statement the mail sends fine but obviously I don't want to use that anymore.
    The only thing I see that the ACE is not doing is closing the connections. So if every five minutes I do a clear conn all, I won't get any dropped connections for at least 10 to 15 minutes but I am not going to be doing this. Right now I have a server with a script that logs into the ace and then clears the connection but this is a band aid problem.
    Here is my config. This is the only thing on this context. All 6 of my other contexts do not have this issue.
    access-list ALL line 10 extended permit ip any any
    access-list ALL line 18 extended permit icmp any any
    probe smtp SMTP_Probe
    interval 15
    passdetect interval 30
    expect status 210 250
    parameter-map type connection TCP_Mail_TO
    slowstart
    set timeout inactivity 2
    set tcp timeout half-closed 15
    set tcp ack-delay 300
    tcp-options timestamp allow
    rserver host hub2
    ip address *.*.*.*.*.*
    inservice
    serverfarm host Mail_Hub_Servers_SF
    probe SMTP_Probe
    rserver hub2 25
    inservice
    class-map match-all Mail_Hub_VIP
    2 match virtual-address *.*.*.*.*.* tcp eq smtp
    class-map type management match-any Remote_Management
    2 match protocol http any
    3 match protocol icmp any
    4 match protocol telnet any
    5 match protocol ssh any
    policy-map type management first-match rmt_mgt_policy
    class Remote_Management
    permit
    policy-map type loadbalance first-match Mail_Hub_VIP-l7slb
    class class-default
    serverfarm Mail_Hub_Servers_SF
    policy-map multi-match int7
    class Mail_Hub_VIP
    loadbalance vip inservice
    loadbalance policy Mail_Hub_VIP-l7slb
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    connection advanced-options TCP_Mail_TO
    access-group input ALL
    interface vlan 108
    ip address *.*.*.*.
    alias *.*.*.*
    peer ip address *.*.*.*.
    no normalization
    no icmp-guard
    service-policy input rmt_mgt_policy
    service-policy input int7
    no shutdown
    ip route 0.0.0.0 0.0.0.0 *.*.*.*

    I would like to avoid trying routed mode for this just right now because we haven't had a good experience in routed mode here. I can try creating a new context in routed mode because I cannot experiment with production mail. Also I have this scenario working fine on 3 other contexts with 0 Connections being dropped. The other thing is I am not dropping all connections its dropping about 2-8%. of the connections. I have been playing around with connection limits.
    Interface: vlan 108
    service-policy: int7
    class: Mail_Hub_VIP
    loadbalance:
    L7 loadbalance policy: Mail_Hub_VIP-l7slb
    VIP Route Metric : 77
    VIP Route Advertise : ENABLED-WHEN-ACTIVE
    VIP ICMP Reply : ENABLED-WHEN-ACTIVE
    VIP State: INSERVICE
    curr conns : 1 , hit count : 12052
    dropped conns : 839
    client pkt count : 385190 , client byte count: 375718706
    server pkt count : 133814 , server byte count: 11089648
    conn-rate-limit : 50 , drop-count : 0
    bandwidth-rate-limit : - , drop-count : -
    Parameter-map(s):
    TCP_Mail_TO

  • ACE dropped conns problem (Bridged mode)

    Dear all,
    I configured an ACE in bridged mode (inside vlan: 2012, outside vlan: 2021) and I apply the L4 policy on the 2 VLAN interface to loadbalance HTTP incoming request (Virtual IP: 172.22.22.130).
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    But I need also that some other server connected to the same vlan 2112 and having to send HTTP request on the same VIP but this failed and I get dropped conns.
    Can anyone helps?
    Regards
    Abdelaziz

    Hi Olivier,
    This below the full config, and my need is to make a server in the inside VLAN 2112 (172.22.22.121) to open HTTPS connexion on the VIP (172.22.22.130 for rserver .131 & .132). Trafic from the outside is working well.
    Thanx,
    Abdealziz
    Generating configuration....
    access-list BPDU-Allow ethertype permit bpdu
    probe tcp HTTPS
      port 443
      interval 15
      passdetect interval 15
      passdetect count 1
    probe icmp PING
      interval 5
    rserver host CASHUB131
      ip address 172.22.22.131
      inservice
    rserver host CASHUB132
      ip address 172.22.22.132
      inservice
    serverfarm host SFARM-EXCAS130
      probe HTTPS
      rserver CASHUB131
        inservice
      rserver CASHUB132
        inservice
    parameter-map type connection TCP_IDLE_30min
      set timeout inactivity 1800
    class-map match-all CLASS-L4-VIP-EXCAS130
      2 match virtual-address 172.22.22.130 any
    class-map type management match-any REMOTE-ACCESS
      description management ACE
      10 match protocol telnet any
      20 match protocol ssh any
      30 match protocol icmp any
      31 match protocol https any
      32 match protocol snmp any
    policy-map type management first-match REMOTE-MGT
      class REMOTE-ACCESS
        permit
    policy-map type loadbalance first-match POLICY-L7-VIP-EXCAS130
      class class-default
        serverfarm SFARM-EXCAS130
    policy-map multi-match POLICY-LB-HMC-2112
      class CLASS-L4-VIP-EXCAS130
        loadbalance vip inservice
        loadbalance policy POLICY-L7-VIP-EXCAS130
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface bvi 1
      ip address 172.22.22.250 255.255.255.0
      peer ip address 172.22.22.251 255.255.255.0
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.22.22.254

  • ACE: SMTP Header insertion

    Is this possible with ACE?
    I'm trying to pass source address info through an imaginary realserver (a proxy). The real server is either configured on a secod ACE and/or on SMTP-proxy server.
    SS

    We only do header insertion for HTTP.
    G.

  • ACE 30, dropped conns counter incorrect number

    We have host in our network which tests reachability of ACE's VIP address at regular intervals. The test sequence consists of 4 TCP packets (SYN, SYN-ACK, FIN-ACK, RST-ACK; see picture attached) and causes incrementation of "dropped conns" counter in show service-policy output.
    ACE30# sh service-policy XYZ detail | inc drop
            dropped conns    : 266812
            conn-rate-limit      : 0         , drop-count : 0
            bandwidth-rate-limit : 0         , drop-count : 0
                         dropped conns: 238177
                dropped conns    : 7
    ACE30# sh service-policy XYZ detail | inc drop
            dropped conns    : 266813
            conn-rate-limit      : 0         , drop-count : 0
            bandwidth-rate-limit : 0         , drop-count : 0
                         dropped conns: 238178
                dropped conns    : 7
    Is this normal behavior of ACE? Is there a way how to get rid of the dropped cons counter incrementation.
    Petr

    Hi Kanwal,
    When I set "no normalization" problem is solved. Disadvantage of this appoach is that by this command all trafic on interface is affected.
    I've also tried to tune  timeout for embrionic connection.
    When I had set it to 0, dropped conns counter stopped to increase. Client which sends those "SYN,FIN" packets ends communication after 30 seconds using RST. This cause that connection ends and dropped conns counter does not increase.
    Unfortunately for some reason sometimes happens that client doesn't send this final RST packet. This cause that number of active connection increases ...
    ACE30-hto2/TEST-WEBAPP# sh service-policy XYZ | inc conn
            curr conns       : 9         , hit count        : 2279841   
            dropped conns    : 385467    
            conns per second    : 0         
            conn-rate-limit      : -         , drop-count : -         
    ACE30-hto2/TEST-WEBAPP# sh service-policy XYZ | inc conn
            curr conns       : 22        , hit count        : 2283653   
            dropped conns    : 385467    
            conns per second    : 0         
            conn-rate-limit      : -         , drop-count : -
    When I set timeout to 120, those "non RST" connections are cleared but of course dropped conns counter increases ...
    I guess I will try to reconfigure the probe.
    Kanwal, thanks for your suggestions!
    Kind regards
    Petr

  • ACE One-Arm Source-NAT HTTP Header Insert

    Hellow ACE Gurus,
    This is probably a dumb question but I'm looking for info on HTTP Header Insert for SSL sessions.  Does the HTTP header re-write action list work for SSL traffic?  I guess I'm not clear on whether or not the header is encrypted and if the ACE can modify on an HTTPS session.  Any input would be greatly appreciated.
    /r
    Rob

    Hi Rob,
    When using HTTPS, all the data is encrypted, including the HTTP headers.
    In such a situation, if you want to insert headers (or do any other kind of L7 processing), you will have to configure the ACE to do SSL termination. Once the connection is decrypted, the ACE can do any processing it needs before sending the connection towards the server either in clear text or again using HTTPS.
    I would recommend you to have a look at the link below. This is an example of how to configure an ACE for end-to-end SSL (so, HTTPS on both sides of the ACE). In the example, the only L7 processing that is being done is matching on the URL, but it would be enough to replace that part with whatever header insertion commands you need
    http://www.cisco.com/en/US/partner/products/hw/modules/ps2706/products_configuration_example09186a00809c6f37.shtml
    If you still need more help to understand any of the points involved in the process, please, do not hesitate to contact me again.
    Regards
    Daniel

  • HTTP header insertion problem with ACE

    Hi
    I try to configure the HTTP header insertion feature based on the action-list type modify http. Unfortunately it does not works.
    The config looks like that
    action-list type modify http TEST
    header insert both Host header-value test:test.
    I added this action-list to the correct policy-map.
    When I checked the snifer output on the server side, there is no test value in the HTTP header.
    I test the same feature based on the "insert-http" command in the policy-map and this one works.
    Could anybody help me with this problem?
    Thank you in advance
    Regards
    Lucas

    Hi Lukas,
    Add a new parameter-map named PRMAP_PERST_REBLNC and add this to the policy map using command appl-parameter http advanced-options PRMAP_PERST_REBLNC as shown below:
    action-list type modify http test-insert
    header insert both My-Header header-value test
    header insert both SSL header-value TRUE
    policy-map type loadbalance http first-match HtppInsert
    class class-default
    serverfarm linux1-80
    action test-insert
    policy-map multi-match SLB1
    class VIP-122-80
    loadbalance vip inservice
    loadbalance policy HtppInsert
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    loadbalance vip advertise metric 1
    connection advanced-options SetTos
    appl-parameter http advanced-options PRMAP_PERST_REBLNC
    parameter-map type http PRMAP_PERST_REBLNC
    persistence-rebalance
    Hope this will make all the packets are inserted with the http header not the first one only.
    If it works then plz inform.
    Kind Regards.
    Sachin Garg

  • Http header insertion with MSISDN

    Hi
    I know that we can define a http header insertion on the ACE to insert a custom header and a string in to the value. Is there a way for me to insert a dynamic string read from a database in to the value field. My exact requirement is to insert the MSISDN of mobile subscribers in to their http traffic. The MSISDN can be extracted form the Radius accounting messages
    Any ideas, I have no clue as to how to do such a thing.
    thanks

    I don't know about this feature. I think it's not possible. ACE can insert/generate only cookie. All other L7 methods (e.g. http header) are using existing data in communication.
    MSISDN inserting to http header/uri is role of wap-gw, or something like that device in data flow process.
    martin

  • Header Insert Statistics on SSL Module

    Hi,
    I use an SSL Module running SW 2.1.8. Within ouput of "sh ssl-proxy stats hdr" I have a lot of "Service Errors" without any configured http header insertion policy.
    Any idea what could cause this ??
    Any answer is appreciated.
    Volker Kreisel
    Header Insert Statistics:
    Session Headers Inserted : 0 Custom Headers Inserted : 0
    Session Id's Inserted : 0 Client Cert. Inserted : 0
    Client IP/Port Inserted : 0
    No End of Hdr Detected : 0 Payload no HTTP header : 0
    Desc Alloc Failed : 0 Buffer Alloc Failed : 0
    Client Cert Errors : 0 Malloc failed : 0
    Service Errors : 28730384 Conn Entry Invalid : 0
    Buffers allocated : 0 Buffers Scanned : 0
    Insertion Points Found : 0 Header Overflow : 0
    End of Header Found : 0 Buffers Accumulated : 0

    CSCsb82589
    show ssl-proxy stats hdr counter Service Errors is erroneously increment
    This has been fixed in 3.1.1 and will be fixed soon in the next 2.1 release.
    Regards,
    Gilles.

  • ACE Drop (Dest nat fail):

    Hi All,
    I'm using ACE module A2(2.4)
    I'm trying to use parameter server-conn reuse, but clients get sometimes statuscode 503.
    A#1/Test1# show np 1 me-stats "-socm -v"
    OCM Statistics: (Current)
    Errors:                                           0             0
    Connection create received:               231121503          1142
    LB dest decision received:                365473159          1473
    Nat app fixup recieved:                           0             0
    Connection unproxy received:               52997475           393
    Connection reproxy received:               51249279           375
    IPCP received:                                83227             2
    ACK trigger received:                      52733008           390
    TCP connected received                    218498529          1065
    Unknown message received:                         0             0
    Drop [LB dest decision fail]:                 29392             0
    Drop [invalid ifid]                               0             0
    Drop [Out of buffers]:                            0             0
    Dest decision transmitted:                248735645          1174
    TCP connect transmitted:                  212827881           828
    ACK trigger transmitted:                         12             0
    IPCP transmitted:                             83227             2
    NAT[static mapped]:                               0             0
    NAT[static real]:                                 0             0
    NAT[xlate alloc fail]:                            0             0
    NAT[xlate real hit]:                              0             0
    NAT[xlate mapped hit]:                            0             0
    NAT[invalid xlate]:                               0             0
    NAT[dump xlate]:                                  0             0
    NAT[xlate release failed]:                        0             0
    NAT Pool Alloc [fail]:                            0             0
    NAT Pool Alloc [addr]:                            0             0
    NAT Pool Alloc [addr/port]:                33689970            81
    NAT Pool Free [addr]:                             0             0
    NAT Pool Free [addr/port]:                 33689214            88
    NAT Pool Free [orphan IP]:                        0             0
    Reuse retrieve link update conn invalid           0             0
    Reuse retrieve link update conn not on r          0             0
    Reuse retrieve success but conn invalid:          0             0
    Drop [Next Hop queue full]:                       0             0
    Reuse retrieve miss:                         845627             3
    OCM Packet count (Hi & Lo):               976499360          4850
    Packet forward received:                    4343180            10
    NAF Error [no route or unresolved adjace          0             0
    NAF Error [nat resp fail]:                        0             0
    UDP Chaser received:                          10406             0
    (Context 1 Statistics)
    Drop [out of connections]:                        0             0
    Drop [out of proxies]:                            0             0
    Drop [out of ssl]:                                0             0
    Drop [mac lookup fail]:                           0             0
    Drop [route lookup fail]:                         0             0
    Drop [nat fail]                                   0             0
    Drop [ip sanity check fail]                       0             0
    Drop [acl deny]:                                  0             0
    Drop [redundant connection]:                      0             0
    Connection inserted:                         862670             3
    Packet message transmitted:                 6409302           230
    Reuse conns retrieved:                      6390611           238
    Drop [Reproxy fail]:                            171             0
    Drop [dest nat fail]:                         58286             2
    The last counter is increasing. What does it mean? Can this be the problem?
    I do not get 503 in the retcode map of the servers.
    Regards
    Mats

    Hi Mats,
    I find it very strange that the ACE is sending a 503 message back to the client, because, in case of issues, it normally just resets the connection. With that in mind, we should also investigate the server itself.  This is not trivial, so, you should open a TAC case.
    Let me just explain the meaning of the "Drop [dest nat fail]" counter. It will be incremented if, after a connection has been natted, one of the servers tries to open a new connection against the natted IP and port. This shouldn't happen unless you are using a protocol composed of several connections (for example, FTP)
    Regards
    Daniel

  • High Buffer Busy Wait due to Concurrent INSERTS

    Hi All,
    One of my OLTP database is running on 11.1.0.7 (11.1.0.7.0 - 64bit Production) with RHEL 5.4.
    On frequent basis, i am observing 'BUFFER BUSY WAITS' and last time i tried to capture some dictionary information to dig the waits.
    1. Session Watis :
              Oracle                                                  Sec                                     Hash
    Sid,Serial User     OS User  Svr-Pgm    Wait Event      State-Seq   Wt Module                  Cmnd       Value          P1          P2   P3
    633,40830 OLTP_USE fateadm  21646-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    647, 1761 OLTP_USE fateadm  22715-orac buffer busy wai Wtng-3837    0 ORDERS             ISRT  3932487748         384     1863905    1
    872, 5001 OLTP_USE fateadm  21836-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    702, 1353 OLTP_USE fateadm  21984-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    337,10307 OLTP_USE fateadm  21173-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    751,43016 OLTP_USE fateadm  21619-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    820,17959 OLTP_USE fateadm  21648-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863905    1
    287,63359 OLTP_USE fateadm  27053-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863905    1
    629, 1653 OLTP_USE fateadm  22468-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863905    1
    788,14160 OLTP_USE fateadm  22421-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863905    1
    615, 4580 OLTP_USE fateadm  21185-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863905    1
    525,46068 OLTP_USE fateadm  27043-orac buffer busy wai Wtng-9034    1 ORDERS             ISRT  3932487748         384     1863905    1
    919,23243 OLTP_USE fateadm  21428-orac buffer busy wai Wtng-6340    1 ORDERS             ISRT  3932487748         384     1863906    1
    610,34557 OLTP_USE fateadm  21679-orac buffer busy wai Wtng-6422    1 ORDERS             ISRT  3932487748         384     1863906    1
    803, 1583 OLTP_USE fateadm  21580-orac buffer busy wai Wtng-6656    1 ORDERS             ISRT  3932487748         384     1863906    1
    781, 1523 OLTP_USE fateadm  21781-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863906    1
    369,11005 OLTP_USE fateadm  21718-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863906    1
    823,35800 OLTP_USE fateadm  21148-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863906    1
    817, 1537 OLTP_USE fateadm  22505-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863906    1
    579,54959 OLTP_USE fateadm  22517-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863906    1
    591,33597 OLTP_USE fateadm  27027-orac buffer busy wai Wtng-9999    1 ORDERS             ISRT  3932487748         384     1863906    1
    481, 3031 OLTP_USE fateadm  21191-orac buffer busy wai Wtng-3502    1 ORDERS             ISRT  3932487748         384     1863906    1
    473,24985 OLTP_USE fateadm  22629-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863906    1
    868, 3984 OLTP_USE fateadm  27191-orac buffer busy wai Wtng-9999    0 ORDERS             ISRT  3932487748         384     1863906    1
    select owner,segment_name,segment_type from dba_extents where    file_id = 384 and   1863905 between block_id and block_id + blocks -1;
    OWNER                          SEGMENT_NAME                                                                      SEGMENT_TYPE
    ORDER                          ORDER_DETAILS                                                                      TABLE
    select TABLE_NAME,PARTITIONED,ini_trans ,degree,compression,FREELISTS from dba_TABLES WHERE TABLE_NAME='ORDER_DETAILS';
    TABLE_NAME                     PAR  INI_TRANS DEGREE                         COMPRESS  FREELISTS
    ORDER_DETAILS                   NO           1          1                     ENABLED           1
    Tablespace is not ASSM managed !
      select
       object_name,
       statistic_name,
       value
    from
       V$SEGMENT_STATISTICS
    where
       object_name = 'ORDER_DETAILS';
    OBJECT_NAME              STATISTIC_NAME                                                        VALUE
    ORDER_DETAILS             logical reads                                                     487741104
    ORDER_DETAILS             buffer busy waits                                                   4715174
    ORDER_DETAILS             db block changes                                                  200858896
    ORDER_DETAILS             physical reads                                                    143642724
    ORDER_DETAILS             physical writes                                                    20581330
    ORDER_DETAILS             physical reads direct                                              55239903
    ORDER_DETAILS             physical writes direct                                             19500551
    ORDER_DETAILS             space allocated                                                  1.6603E+11
    ORDER_DETAILS             segment scans                                                          9727
    ORDER_DETAILS table is ~ 153 GB non-partitioned table.
    It seems its not a READ BY OTHER SESSIONS wait but BUFFER BUSY due to write-wirte contention inside same block. I have never observed Cache Buffer Chain/ ITL-Wait/ High wait time on dbfile sequential/scattered reads.Table contains one PK (composite index on 3 columns) which seems to be highly fragmented.This non partitioned global Index has 3182037735 rows and blevel is 4.
    BHAVIK_DBA.FATE1NA>select index_name,status,num_rows,blevel,pct_free,ini_trans,clustering_factor from dba_indexes where index_name='IDX_ORDERS';
    INDEX_NAME                     STATUS     NUM_ROWS     BLEVEL   PCT_FREE  INI_TRANS CLUSTERING_FACTOR
    IDX_ORDERS                      VALID    3182037735          4          2          2        2529462377
    1 row selected.
    One of the index column value is being populated by sequence. (Monotonically increasing value)
    SEGMENT_NAME                                                                              MB
    IDX_ORDERS                                                             170590.438
    Index size is greater than table size !Tuning goal here is to reduce buffer busy waits and thus commit latencies.
    I think, i need to increase FREELISTS and PCT_FREE to address this issue, but not much confident whether it is going to solve the issue or not?
    Can i ask for any help here ?

    Hi Johnathan;
    Many thanks for your detailed write-up. I was expecting you !
    Your post here gave lot of information and wisdom that made me think last couple of hrs that is the reason for the delay in reply.
    I did visited your index explosion posts couple of times and that scenario only gave me insight that concurrent DML (INSERT) is cause of index fragmentation in my case.
    Let me also pick the opportunity to ask you to shed more light on some of the information you have highlighted.
    if you can work out the number of concurrent inserts that are really likely to happen at any one instant then a value of freelists that in the range of
    concurrency/4 to concurrency/2 is probably appropriate.May i ask you how did you derive this formula ? I dont want to miss learning opportunity here !
    Note - with multiple freelists, you may find that you now get buffer busy waits on the segment header block.I did not quite get this point ? Can you shed more light please? What piece in segment header block is going to result contention(BBW on SEGMENT HEADER) on all concurrent inserts ?
    The solution to this is to increase the number of freelist groups (making sure that
    freelists and freelist groups have no common factors).My prod db NON-RAC environment. Can i use FREELIST GROUPS here ? My little knowledge did not get, What "common factors" you are referring here ?
    The reads could be related to leaf block splits, but there are several possible scenarios that could lead to that pattern of activity - so the next step is to find out which blocks are being
    read. Capture a sample of the waits, then query dba_extents for the extent_id, file_id, and block_id (don't run that awful query with the "block_id + blocks" predicate) and cross-check the
    list of blocks to see if they are typically the first couple of blocks of an extent or randomly scattered throughout extents. If the former the problem is probably related to ASSM, if the
    latter it may be related to failed probes on index leaf block reuse (i.e. after large scale deletes).I have 10046 trace file with me (giving you some sample below) that can give some information. However, since the issue was critical, i killed the insert process and rebuilt both the indexes. Since, index is rebuilt, i am not able to find any information in dba_extents.
    select SEGMENT_NAME,SEGMENT_TYPE,EXTENT_ID from dba_extents where file_id=42 and block_id=1109331;
    no rows selected
    select SEGMENT_NAME,SEGMENT_TYPE,EXTENT_ID from dba_extents where file_id=42 and block_id=1109395 ;
    no rows selected
    select SEGMENT_NAME,SEGMENT_TYPE,EXTENT_ID from dba_extents where file_id=42 and block_id=1109459;
    no rows selected
    select SEGMENT_NAME,SEGMENT_TYPE,EXTENT_ID from dba_extents where file_id=10 and block_id=1107475;
    no rows selected
    select SEGMENT_NAME,SEGMENT_TYPE,EXTENT_ID from dba_extents where file_id=10 and block_id=1107539;
    no rows selected
    select object_name,object_Type from dba_objects where object_id=17599;
    no rows selected
    WAIT #4: nam='db file sequential read' ela= 49 file#=42 block#=1109331 blocks=1 obj#=17599 tim=1245687162307379
    WAIT #4: nam='db file sequential read' ela= 59 file#=42 block#=1109395 blocks=1 obj#=17599 tim=1245687162307462
    WAIT #4: nam='db file sequential read' ela= 51 file#=42 block#=1109459 blocks=1 obj#=17599 tim=1245687162307538
    WAIT #4: nam='db file sequential read' ela= 49 file#=10 block#=1107475 blocks=1 obj#=17599 tim=1245687162307612
    WAIT #4: nam='db file sequential read' ela= 49 file#=10 block#=1107539 blocks=1 obj#=17599 tim=1245687162307684
    WAIT #4: nam='db file sequential read' ela= 198 file#=10 block#=1107603 blocks=1 obj#=17599 tim=1245687162307905
    WAIT #4: nam='db file sequential read' ela= 88 file#=10 block#=1107667 blocks=1 obj#=17599 tim=1245687162308016
    WAIT #4: nam='db file sequential read' ela= 51 file#=10 block#=1107731 blocks=1 obj#=17599 tim=1245687162308092
    WAIT #4: nam='db file sequential read' ela= 49 file#=10 block#=1107795 blocks=1 obj#=17599 tim=1245687162308166
    WAIT #4: nam='db file sequential read' ela= 49 file#=10 block#=1107859 blocks=1 obj#=17599 tim=1245687162308240
    WAIT #4: nam='db file sequential read' ela= 52 file#=10 block#=1107923 blocks=1 obj#=17599 tim=1245687162308314
    WAIT #4: nam='db file sequential read' ela= 57 file#=42 block#=1109012 blocks=1 obj#=17599 tim=1245687162308395
    WAIT #4: nam='db file sequential read' ela= 52 file#=42 block#=1109076 blocks=1 obj#=17599 tim=1245687162308470
    WAIT #4: nam='db file sequential read' ela= 98 file#=42 block#=1109140 blocks=1 obj#=17599 tim=1245687162308594
    WAIT #4: nam='db file sequential read' ela= 67 file#=42 block#=1109204 blocks=1 obj#=17599 tim=1245687162308686
    WAIT #4: nam='db file sequential read' ela= 53 file#=42 block#=1109268 blocks=1 obj#=17599 tim=1245687162308762
    WAIT #4: nam='db file sequential read' ela= 54 file#=42 block#=1109332 blocks=1 obj#=17599 tim=1245687162308841
    WAIT #4: nam='db file sequential read' ela= 55 file#=42 block#=1109396 blocks=1 obj#=17599 tim=1245687162308920
    WAIT #4: nam='db file sequential read' ela= 54 file#=42 block#=1109460 blocks=1 obj#=17599 tim=1245687162308999
    WAIT #4: nam='db file sequential read' ela= 52 file#=10 block#=1107476 blocks=1 obj#=17599 tim=1245687162309074
    WAIT #4: nam='db file sequential read' ela= 89 file#=10 block#=1107540 blocks=1 obj#=17599 tim=1245687162309187
    WAIT #4: nam='db file sequential read' ela= 407 file#=10 block#=1107604 blocks=1 obj#=17599 tim=1245687162309618TKPROF for above trace
    INSERT into
                     order_rev
                     (aggregated_revenue_id,
                      legal_entity_id,
                      gl_product_group,
                      revenue_category,
                      warehouse_id,
                      tax_region,
                      gl_product_subgroup,
                      total_shipments,
                      total_units_shipped,
                      aggregated_revenue_amount,
                      aggregated_tax_amount,
                      base_currency_code,
                      exchange_rate,
                      accounting_date,
                      inventory_owner_type_id,
                      fin_commission_structure_id,
                      seller_of_record_vendor_id,
                      organizational_unit_id,
                      merchant_id,
                      last_updated_date,
                      revenue_owner_type_id,
                      sales_channel,
                      location)
                     VALUES
                     (order_rev.nextval,:p1,:p2,:p3,:p4,:p5,:p6,:p7,:p8,:p9,:p10,:p11,:p12,to_date(:p13, 'dd-MON-yyyy'),:p14,:p15,:p16,:p17,:p18,sysdate,:p19,:p20,:p21)
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        0      0.00       0.00          0          0          0           0
    Execute    613      5.50      40.32      96672     247585     306916         613
    Fetch        0      0.00       0.00          0          0          0           0
    total      613      5.50      40.32      96672     247585     306916         613
    Misses in library cache during parse: 0
    Optimizer mode: ALL_ROWS
    Parsing user id: 446
    Elapsed times include waiting on following events:
      Event waited on                             Times   Max. Wait  Total Waited
      ----------------------------------------   Waited  ----------  ------------
      db file sequential read                    164224        0.04         62.33
      SQL*Net message to client                     613        0.00          0.00
      SQL*Net message from client                   613        0.03          0.90
      latch: cache buffers chains                     8        0.00          0.00
      latch: object queue header operation            2        0.00          0.00Is there any other way to find out culprit amongst the two you have listed (ASSM / failed probes on index leaf block reuse ) ?

  • ACE: wrong IP in HTTP header HEALTHCHECK packet

    Hi,
    I encounter a strange problem with ACE when the blade performs a HTTP healthcheck towards a RSERVER.
    Sometimes, ACE insert in the HTTP header a strange IP address, others then the IP address of the rserver, for which it performs a healthcheck.
    Anyone encountered the same problem?
    Thx, Wim

    Hi Gillis,
    I reported this issue to our integrator. I think they will open a cisco case right now.
    We are able to reproduce this problem. So, that might not be the problem to troubleshoot at this moment.
    For your information, we had version A1.6 running until last week. Now, we upgraded to A2, but the healthcheck issue is still present.
    I assume you 'll informed via the support case?

  • Using a variable/drop down list in header of planning layout

    Dear all,
    I have created a simple BPS application for purely GL planning (No CO related objects like cost centre involved). I have the following characteristics in the header of the manuel planning layout.
    Business area
    Chart of accounts
    Company code
    Currency
    Currency Type
    Fiscal year
    Fiscal Year Variant
    Fiscal year/period
    Value type
    Version
    I have created variables for Business area, Fiscal Year, Fiscal Year Period, Posting Period and Version. The client wants either a variable or a drop down list for these characteristics in the header in the web application. When I assign a variable and put the characteristic in header, I get the error message in the web application saying header characteristic can only have a fixed value. Can someone tell me if it is possible and if so than how? I'll be very grateful for any inputs. Thanks a lot.
    Regards,
    Sumit

    Hi,
    When you create a variable, assign some values to the variable. These then become available in the drop down box. Ths first time a Web interface is called, these variable values are initial.As a result, u get the error messages. Select the variable values and then the error message should go away.
    Thanks,
    -NS

  • HP officejet pro 8600 plus need to reset, but no screen access due to head error

    hi,
    I had some HP's 8600 but one of them it is dead as printer and it was replaced.
    I need to use it only as scanner (no printing since its problem are the printing heads). The problem I cannot access to the menu through the screen since it is stock with the message mentioning the fail on printing head. The next option it is to watch a demo about heads.
    Im trying to access in order to fix a new static ip for the scan.
    Is there a way to reset so the printing gets an dhcp ip add? So far the scanner works fine through USB connection.
    Thanks in advance

    Hello @Rodrigo_cl,
    Welcome to the HP Support Forums!
    I understand that your HP Officejet Pro 8600 Plus e-All-in-One Printer has encountered a hardware Printhead failure and is not allowing you to scan using a static IP because of this. I would like to assist you today with resolving this issue.
    Now, due to the error on the front panel of the printer, you will not be able to perform any resets on your machine. But, if your printer is currently on the network with an automatic IP we can utilize the embedded web server to configure a static IP.
    Is your printer currently on your wireless or wired network?
    Once I know if your printer is currently on the network, I can guide you towards configuring the static IP through the computer. I look forward to hearing from you!
    X-23
    I work on behalf of HP
    Please click "Accept as Solution" if you feel my post solved your issue, it will help others find the solution.
    Click the "Kudos, Thumbs Up" on the right to say "Thanks" for helping!

  • Src IP HTTP header insertion problem

    I have configured a vserver to loadbalance to 2 proxy servers over TCP port 8080.
    I use a policy to insert the source ip address of the client workstation to be
    inserted in the HTTP header.
    We use the same vserver to loadbalance HTTPS traffix.
    Appearantly the CSM also tries to insert the ip address when HTTPS traffic
    is passing this vserver.
    Is this a correct beheavior? How can I solve this one?
    Thanks!
    Regards Wim

    Actually mozilla lets you specify different ports for proxy http and proxy https.
    Anyway, are the servers behing your CSM proxy servers ?
    Do you have 'persistent rebalance" configured ?
    If so, could you try to turn do 'no persistent rebalance' and see if that solves your problem.
    Normally, https connection via a proxy are still done with HTTP connection with the request "CONNECT x.x.x.x:443" and the CSM should be able to inset the requested info.
    But we need to avoid the CSM to inspect further packets as this would be ssl traffic -> so disable peristent rebalance.
    Just an idea.
    Regards,
    Gilles.

Maybe you are looking for

  • How to install and use DBXML package in Ubuntu Server 8.04 64bit

    Hi all. I used to install and use DBXML in Ubuntu Desktop 8.04 32bit. Now I want to use on Ubuntu Server 8.04 64bit. This is code for my installation (I use DBXML 2.2.13) env CFLAGS="-O0" sh buildall.sh enable-java with-xerces="xerces-c-src" with-ber

  • Fibre not working, please help.. 3 months I've been at this !

    Hi Guys, my fibre (40/10) unlimited is running (!) at about 2 Mbps down and 0.01 up, rendering it almost completely unusable. This started end of February , reported beginning of March. originally my issues were put down to REIN interference from the

  • Transporter - Basic installation and connection questions

    We have never used or installed the Transporter before.  We are currently using Tidal 5.3x and are upgrading a sandbox environment to 6.2.  I have looked at all the transporter documentation I can find and am still missing some very basic questions -

  • Italic headings when saving as PDF in Word 2007. Don't want italic headings...

    I'm using the Acrobat PDFMaker Office COM Addin for Word 2007. After months of successful 'Save As - PDF or XML', my PDFs are suddenly displaying italic headings: h1, h2, h3, h4, etc. My Word source file has regular headings just as intended. If I el

  • Copy & Paste in Photoshop Elements 9

    I want to use the heart cookie cutter and cut out just the part of the picture within the heart shape and paste it into a WORD document.  How do you do that? I am new to Photoshop Elements.  Using help didn't help.