Add routing entry in LabVIEW RT (on PAC)?

In short:
Is it possible to set up a routing on RT, to compensate for the fact that the second port on the dual ethernet type controllers does not support gateways?
Background:
I need to have a cfP-220 on two separate networks. The controller has dual Ethernet, but unfortunately the secondary port is crippled with no DHCP and no gateway support...Hopefully NI will offer dual ports with identical functionality soon, but until then I'm looking for a way around the limitation. The lack of DHCP support is something I can live with as I'm able to programmatically set its IP, and I do so based on a relation to the IP of the primary port - BUT, the missing gateway support is a show stopper...I really need both ports to be accessible from other networks, not just the local subnet.
So my hope is that I at least can define the routing to the gateway manually (or preferably; programmatically)...Is this possible?
MTO

FYI - the only reply I have received on this is that it cannot be done
For others that face the same issue I can give you one tip; check if you can get around it by expanding the subnet mask on the secondary port, and enable Proxy ARP on your router...As long as it is possible / acceptable to have a wide enough subnet mask and the router supports proxy ARP you are fine.
In my case this allows me to talk to the controller on its secondary port from the neighbour subnet (a minimum requirement), but not from devices another two routing steps away...(for that I would need to use NAT or VPLS, which I do not have available).
MTO

Similar Messages

  • How to save routing entries permanently after route add

    Hi guys,
    I have added routing entries through route add command. I know i can add routing entries permanently thru -p option in route add command but didin't use that option. How to save those routing entries now?
    Thanks...

    The filename you are looking for is /etc/inet/static_routes which is available only on Solaris 10 update 3 or later:
    root_sol10u3# route -p add -net 192.168.138.0/24 192.168.136.1
    root_sol10u3# cat /etc/inet/static_routes
    # File generated by route(1M) - do not edit.
    -net 192.168.128.0/22 192.168.136.1
    -net 192.168.138.0/24 192.168.136.1
    -net 172.31.68.0/24 192.168.149.253
    -net 172.31.69.0/24 192.168.149.253
    root_sol10u3#For Solaris 10 update 2 or earlier, persistent static routes are not implemented. Additionally, the old RC script method suggested above also will not work for Solaris 10 given the host isn't always guaranteed to reach the "multiuser" milestone and subsequently run the legacy /etc/rc*/S* scripts (say if a filesystem fails to mount). For those releases, you should create a new manifest file as follows:
    root_sol10u2# cat /var/svc/manifest/network/RKstatic-routes.xml
    <?xml version="1.0"?>
    <!DOCTYPE service_bundle SYSTEM "/usr/share/lib/xml/dtd/service_bundle.dtd.1">
    <!--
            Static Route SMF Manefest
            To be replaced by official Sun mechanism in next solaris release
    -->
    <service_bundle type='manifest' name='RKstatic-routes'>
    <service
      name='network/RKstatic-routes'
      type='service'
      version='1'>
        <create_default_instance enabled='true' />
        <single_instance/>
        <dependency name='network'
            grouping='require_any'
            restart_on='error'
            type='service'>
                <service_fmri value='svc:/network/service' />
        </dependency>
      <exec_method
        type='method'
        name='start'
        exec='/lib/svc/method/RKstatic-routes start'
        timeout_seconds='60' />
      <exec_method
        type='method'
        name='stop'
        exec='/lib/svc/method/RKstatic-routes stop'
        timeout_seconds='60' />
      <property_group name='startd' type='framework'>
        <propval name='duration' type='astring' value='transient' />
      </property_group>
      <stability value='Unstable' />
    </service>
    </service_bundle>
    root_sol10u2#Then create the method script:
    root_sol10u2# cat /lib/svc/method/RKstatic-routes
    #!/bin/sh
    # RKstatic-routes
    # To be called by the network/RKstatic-route SMF service
    ACTION=${ACTION:-add}
    setup_routes () {
    #Route to networks.
    /usr/sbin/route $ACTION net 172.1.0.0 -netmask 255.255.0.0 10.1.0.0
    /usr/sbin/route $ACTION net 172.2.0.0 -netmask 255.255.0.0 10.2.0.0
    case "$1" in
        start)
            echo "${ACTION}ing static routes"
            setup_routes
        stop)
            ACTION=delete
            echo "${ACTION}ing static routes"
            setup_routes
            echo "Usage: $0 {start|stop}"
            exit 1
    esac
    root_sol10u2#Then, import and enable/start the service:
    root_sol10u2# svccfg -v import /var/svc/manifest/network/RKstatic-routes.xml
    root_sol10u2# svcadm enable network/RKstatic-routes
    root_sol10u2# To stop:
    root_sol10u2# svcadm disable network/RKstatic-routes
    root_sol10u2# For posterity, here is a pre-Solaris 10 version:
    root_sol9# cat /etc/init.d/staticRoutes.sh
    #!/bin/sh
    case "$1" in
            start)
                    test -f /etc/routes.conf || exit 0
                    while read type route gateway
                    do
                            /usr/sbin/route add $type $route $gateway
                    done < /etc/routes.conf
            stop)
                    test -f /etc/routes.conf || exit 0
                    while read type route gateway
                    do
                            /usr/sbin/route delete $type $route $gateway
                    done < /etc/routes.conf
                    echo "Usage: /etc/init.d/routes { start | stop }"
    esac
    root_sol9# cat /etc/routes.conf
    172.1.2.0/24 172.1.2.4
    172.1.3.0/24 172.1.3.4
    root_sol9# ln -s /etc/rc2.d/S70staticRoutes /etc/init.d/staticRoutes.sh
    root_sol9#Best Regards,
    Bryan Wood

  • Cisco ASA 5505 VPN connection issue ("Unable to add route")

    I'm trying to get IPSec VPN working onto a new Cisco ASA5505. Pretty standard configuration.
    Setup:
    * Cisco VPN client on Windows 7 (v5.0.07.0290 x64 on Laptop1 and v5.0.07.0440 x64 on Laptop2)
    * PPPoE/NAT and internal DHCP on the ASA were configured with the Startup Wizard in ASDM
    NATting is working fine - internal PCs get an IP address in the 192.168.2.0/24 range and can all access the Internet.
    I wanted to be able to connect from anywhere to the ASA in order to reach one of the internal servers. Should be pretty basic.
    First I tried with the built-in ASDM IPSec Wizard, instructions found here.
    VPN clients can connect to the ASA, are connected (until they're manually disconnected), but cannot reach the internal network nor the Internet. Note VPN client can connect fine to a different VPN site (not administered by myself).
    Client logs show following error messages:
    1 15:53:09.363 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    2 15:53:13.593 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.101
    3 15:53:13.593 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100165, Gateway: ac100101.
    4 15:54:30.425 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    5 15:54:31.433 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    6 15:54:32.445 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CleanUpVASettings: Was able to delete all VA settings after all, error 0
    7 20:50:45.355 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    8 20:50:50.262 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.100
    9 20:50:50.262 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100164, Gateway: ac100101.
    I've already tried the suggestions from this link, although the problem is different there (as the user can still access the internet, even without split tunneling, which I cannot).
    A show run shows the following output (note in the below I have tried a different VPN network: 192.168.3.0/24 instead of 172.16.1.0/24 seen in the Client log)
    Result of the command: "sh run"
    : Saved
    ASA Version 8.2(5)
    hostname AsaDWD
    enable password kLu0SYBETXUJHVHX encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.2.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group DW-VPDN
    ip address pppoe setroute
    ftp mode passive
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.240
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    ip local pool DWD-VPN-Pool 192.168.3.5-192.168.3.15 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.2.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn group DW-VPDN request dialout pppoe
    vpdn group DW-VPDN localname fa******@SKYNET
    vpdn group DW-VPDN ppp authentication pap
    vpdn username fa******@SKYNET password *****
    dhcpd auto_config outside
    dhcpd address 192.168.2.5-192.168.2.36 inside
    dhcpd domain DOMAIN interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DWD internal
    group-policy DWD attributes
    vpn-tunnel-protocol IPSec
    username test password ******* encrypted privilege 0
    username test attributes
    vpn-group-policy DWD
    tunnel-group DWD type remote-access
    tunnel-group DWD general-attributes
    address-pool DWD-VPN-Pool
    default-group-policy DWD
    tunnel-group DWD ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum client auto
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:3e6c9478a1ee04ab2e1e1cabbeddc7f4
    : end
    I've installed everything using the CLI as well (after a factory reset). This however yielded exactl the same issue.
    Following commands have been entered:
    ip local pool vpnpool 172.16.1.100-172.16.1.199 mask 255.255.255.0
    username *** password ****
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash sha
    isakmp policy 1 group 2
    isakmp policy 1 lifetime 43200
    isakmp enable outside
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 10 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 10 set reverse-route
    crypto dynamic-map outside_dyn_map 10 set security-association lifetime seconds 288000
    crypto map outside_map 10 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp nat-traversal
    sysopt connection permit-ipsec
    sysopt connection permit-vpn
    group-policy dwdvpn internal
    group-policy dwdvpn attributes
    vpn-tunnel-protocol IPSec
    default-domain value DWD
    tunnel-group dwdvpn type ipsec-ra
    tunnel-group dwdvpn ipsec-attributes
    pre-shared-key ****
    tunnel-group dwdvpn general-attributes
    authentication-server-group LOCAL
    default-group-policy dwdvpn
    Unfortunately I'm getting the same "AddRoute failed to add a route with metric of 0: code 160" error message.
    I'm very confused as this should be a pretty standard setup. I tried to follow the instructions on the Cisco site to the letter...
    The only "differences" in my setup are an internal network of 192.168.2.0 (with ASA IP address 192.168.2.254) and PPPoE with DHCP instead of no PPPoE at all.
    Does anyone know what's going on?

    Yes, I have tried from a different laptop - same results. Using that laptop I can connect to a different IPSec site without issues.
    Please find my renewed config below:
    DWD-ASA(config)# sh run: Saved:ASA Version 8.2(5) !hostname DWD-ASAenable password ******* encryptedpasswd ****** encryptednames!interface Ethernet0/0 switchport access vlan 2!interface Ethernet0/1!interface Ethernet0/2!interface Ethernet0/3!interface Ethernet0/4!interface Ethernet0/5!interface Ethernet0/6!interface Ethernet0/7!interface Vlan1 nameif inside security-level 100 ip address 192.168.2.254 255.255.255.0 !interface Vlan2 nameif outside security-level 0 pppoe client vpdn group DWD ip address pppoe setroute !ftp mode passiveaccess-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224 pager lines 24logging asdm informationalmtu inside 1500mtu outside 1500ip local pool vpnpool 192.168.50.10-192.168.50.20 mask 255.255.255.0icmp unreachable rate-limit 1 burst-size 1no asdm history enablearp timeout 14400global (outside) 1 interfacenat (inside) 0 access-list inside_nat0_outboundnat (inside) 1 0.0.0.0 0.0.0.0timeout xlate 3:00:00timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolutetimeout tcp-proxy-reassembly 0:01:00timeout floating-conn 0:00:00dynamic-access-policy-record DfltAccessPolicyhttp server enablehttp 192.168.2.0 255.255.255.0 insidehttp 0.0.0.0 0.0.0.0 outsideno snmp-server locationno snmp-server contactsnmp-server enable traps snmp authentication linkup linkdown coldstartcrypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac crypto ipsec security-association lifetime seconds 28800crypto ipsec security-association lifetime kilobytes 4608000crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAPcrypto map outside_map interface outsidecrypto isakmp enable outsidecrypto isakmp policy 10 authentication pre-share encryption 3des hash sha group 2 lifetime 86400telnet timeout 5ssh 0.0.0.0 0.0.0.0 outsidessh timeout 5console timeout 0vpdn group DWD request dialout pppoevpdn group DWD localname *****@SKYNETvpdn group DWD ppp authentication papvpdn username *****@SKYNET password ***** dhcpd auto_config outside!dhcpd address 192.168.2.10-192.168.2.40 insidedhcpd enable inside!threat-detection basic-threatthreat-detection statistics access-listno threat-detection statistics tcp-interceptwebvpn enable outside svc enablegroup-policy DfltGrpPolicy attributes vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpngroup-policy dwdipsec internalgroup-policy dwdipsec attributes vpn-tunnel-protocol IPSec default-domain value DWDDOMusername user1 password ***** encrypted privilege 0username user1 attributes vpn-group-policy dwdipsectunnel-group dwdipsec type remote-accesstunnel-group dwdipsec general-attributes address-pool vpnpool default-group-policy dwdipsectunnel-group dwdipsec ipsec-attributes pre-shared-key *****tunnel-group dwdssl type remote-accesstunnel-group dwdssl general-attributes address-pool vpnpool!class-map inspection_default match default-inspection-traffic!!policy-map type inspect dns preset_dns_map parameters  message-length maximum client auto  message-length maximum 512policy-map global_policy class inspection_default  inspect dns preset_dns_map   inspect ftp   inspect h323 h225   inspect h323 ras   inspect rsh   inspect rtsp   inspect esmtp   inspect sqlnet   inspect skinny    inspect sunrpc   inspect xdmcp   inspect sip    inspect netbios   inspect tftp   inspect ip-options !service-policy global_policy globalprompt hostname context no call-home reporting anonymousCryptochecksum:f5c8dd644aa2a27374a923671da1c834: endDWD-ASA(config)#

  • How to add the entries and how to delete the entries from custom Z-table?

    Hi Experts,
    My requirement is I need to add the entries from program to three custom z-tables . Assume as zabc1,zabc2,zabc3.
    Here how to add the entries from program to Z-table.???
    And one more requirement is I want to provide a deletion checkbox in selection screen . Initial it was unchecked. If I am giving tick mark then the entries should be deleted from above custom Z-tables. this all will done in backgroung job?
    Could you please guide me the logic how to crack this???
    Let me know if you need more Info
    Thanks
    Sanju

    Hi Sanjana,
    What you can do is to use the ABAP keyword INSERT or MODIFY to add or modify records to a given database table. Here are the syntax taken from SAP documentation:
    *Insert Statement
    INSERT dbtab
    Syntax
    INSERT { {INTO target VALUES source }
           | {     target FROM   source } }.
    Effect
    The INSERT statement inserts one or more rows specified in source in the database table specified in target. The two variants with INTO and VALUES or without INTO with FROM behave identically, with the exception that you cannot specify any internal tables in source after VALUES.
    System Fields
    The INSERT statement sets the values of the system fields sy-subrc and sy-dbcnt.
    sy-subrc Meaning
    0 At least one row was inserted.
    4 At least one row could not be inserted, because the database table already contains a row with the same primary key or a unique secondary index.
    The INSERT statement sets sy-dbcnt to the number of rows inserted.
    Note
    The inserted rows are finally included in the table in the next database commit. Up until this point, they can still be removed by a database rollback.
    *Modify Statement
    MODIFY dbtab
    Syntax
    MODIFY target FROM source.
    Effect
    The MODIFY statement inserts one or several lines specified in source in the database table specified in target, or overwrites existing lines.
    System fields
    The MODIFY statement sets the values of the sy-subrc and sy-dbcnt system fields.
    sy-subrc Meaning
    0 At least one line is inserted or changed.
    4 At least one line could not be processed since there is already a line with the same unique name secondary index in the database table.
    The MODIFY statement sets sy-dbcnt to the number of processed lines.
    Note
    The changes are transferred finally to the database table with the next database commit. Up to that point, they can be reversed using a database rollback.
    Hope it helps...
    P.S. Please award points if it helps...

  • How to read data from a router by using labview

    I am a  beginner labview. How to read data from a router by using labview ? 

    What kind of data are you trying to read?
    Does the router behave like a webserver that you log into?  If so, search the forums for threads discussing HTML.

  • A function module to add an entry to the change log of the ODS needed

    Hi all,
    I want to add an entry to the change log table of the ODS .
    Is there a Function module available for this or a work around for this.
    Regards
    Akshay

    Hi Kiran,
    You can directly add days to the date.
    Eg:
    DATA date LIKE sy-datum.
    DATA days TYPE i.
    date = sy-datum.
    days = 100.
    date = date + days.
    WRITE date.
    Regards
    Wenceslaus

  • How to Add multiple entry to the group policy security filtering

    How to Add multiple entry to the group policy security filtering
    Is there any way we can add multiple entry to the Domain group policy Security filtering tab.Currently its not allowing to add more then one entry at a time.
    Getting Error like "only one name can be entered,and the name cannot contain a semicolon.Enter a valid name"

    Hi
    Are you trying to add more users or groups through Group Policy Management Security Filtering tab?
    Try right clicking on the policy and then edit
    Then in Editor Right click on the name of the policy and Properties
    Security tab and add user or group from this tab. Just make sure if you are adding user or groups "Select this object type" has
    the correct option also "From this Location" is set to your entire directory not the local server.
    Update us with the above.
    Thanks

  • How do I add an entry to the auto correct spell check dictionary?

    How do I add an entry to the auto-correct dictionary for spell check?

    The suggestion from Encrypted11 is for adding a keyboard shortcut, if that is what you want to do. If you want to add a custom word to the keyboard dictionary ....
    The iPad Dictionary
    The iPad has a dictionary built in. As you type, it compares what you've typed against the words in that dictionary. If it finds a partial match, it displays a suggestion just beneath what you have typed.
    If you accept the suggestion by tapping the Space or full stop, great.
    If you allow the 'mistake' to stand, the second time you type the same word and reject the correction, iPad adds the new word to its custom, dynamic dictionary. From now on, it will accept the new word and will even suggest it the next time you type something like it.
    That is copied from here.
    http://www.my-iguru.com/ipad/ipad-hints-tips/ipad-keyboard-tips-tricks.php

  • How to add root entry

    Hi folks
    I'm trying to simulate an LDIF file into JNDI attribute set but cant make it
    dn: dc=fifa,dc=com
    objectclass: dcObject
    objectclass: organization
    o: Football Org
    dc: fifa
    dn: cn=Manager,dc=fifa,dc=com
    objectclass: organizationalRole
    cn: Manager
    This LDIF works fine on the command line ldapadd. Highly appreciate your help if anyone can tell me how to simulate these LDIF entries in JNDI way. I'm using openldap on solaris. I can add other entries if this entry is already created using command line ldapadd.
    Thanks in advance

    Ok i made it... there we go...
    import javax.naming.directory.*;
    import javax.naming.*;
    import java.util.*;
    public class AddEntry {
         final static String ldapServerName = "localhost";
         final static String rootdn = "cn=Manager,dc=fifa,dc=com";
         final static String rootpass = "secret";
         final static String rootContext = "dc=fifa,dc=com";
         // obtain initial directory context using the environment
         public DirContext createContext(String name)
              Properties env = new Properties();
              DirContext ctx = null;
              env.put( Context.INITIAL_CONTEXT_FACTORY, "com.sun.jndi.ldap.LdapCtxFactory" );
              env.put( Context.PROVIDER_URL, "ldap://" + ldapServerName + "/" + name);
              env.put(Context.SECURITY_AUTHENTICATION, "simple");
              env.put( Context.SECURITY_PRINCIPAL, rootdn );
              env.put( Context.SECURITY_CREDENTIALS, rootpass );
              try
                   ctx = new InitialDirContext( env );
              catch(Exception ex)
                   ex.printStackTrace();
              return ctx;
        public static void main( String[] args )
              AddEntry ae = new AddEntry();
              try
                   DirContext ctx = ae.createContext(rootContext);
                   Attributes root_Dn = null;
                   Attributes cn_Dn = null;
                   Attribute root_objclass = null;
                   Attribute oAttr = null;
                   Attribute cn_objclass = null;
                   Attribute cnAttr = null;
                   root_Dn = new BasicAttributes();
                   root_objclass = new BasicAttribute("objectclass");
                   root_objclass.add("dcObject");
                   root_objclass.add("organization");
                   root_Dn.put(root_objclass);
                   oAttr = new BasicAttribute("o");
                   oAttr.add("Fifa Company");
                   root_Dn.put(oAttr);
                   ctx.createSubcontext("", root_Dn);
                   cn_Dn = new BasicAttributes();
                   cn_objclass = new BasicAttribute("objectclass");
                   cn_objclass.add("organizationalRole");
                   cn_Dn.put(cn_objclass);
                   cnAttr = new BasicAttribute("cn");
                   cnAttr.add("Manager");
                   cn_Dn.put(cnAttr);
                   DirContext ctx1 = ae.createContext(rootdn);
                   ctx1.createSubcontext("", cn_Dn);
           catch ( NameAlreadyBoundException nabe )
                   System.err.println( rootContext + " has already been bound!" );
              } catch ( Exception e )
                   System.err.println( e );
    }

  • Add an entry in table

    hi,
    can any one please help me how to add an entry in transp.table.
    in the table TVARV table i need to add an entry .
    please any one help me how to add and what are neccessary steps to be followed while adding an entry.
    for eg
    NAME          TYPE                   NUMB                  LOW                HIGH
    ZSAMPLE        P                       001                        /FILE/
    ZSAMPLE        P                        002                      /EXTRACT/
    NOW I NEED TO ADD AN ENTRY LIKE
    ZSAMPLE      P                          003                      /TEST/
    please help me its urgent.
    thanks in advance.

    Hi ,
    Pls fellow this Steps :
       1 ) Go to se 11 u type the table name then press the display .
      2)  in that screen u click utilities , here u click the table contents .
    3) In  that table contents u click the create entires ..
    4) now u enter the values in that screen .
    5) then press save .
    now this entires are stored in TVARV table .
    <REMOVED BY MODERATOR>
    Regards ,
    Shankar GJ
    Edited by: Alvaro Tejada Galindo on Apr 11, 2008 5:44 PM

  • How to add backdated entry to calender

    I am trying to add an entry in the past and it just disappear from the screen after a couple of seconds, i have just updated my ipad and iphone could the new update have caused this clich!!
    thank you
    Simone

    Settings>Mail, Contacts, Calendar>Calendars>Sync>All Events

  • How to add environment entry in EJB3 ejb-jar.xml

    Hi,
    Is that a build in way of add environment entries in JDev for EJB 3 beans? For EJB 2 beans you can do that using properties. But the bean properties is not available in EJB 3. Please help.
    Thanks
    Kenny

    Thank you for the reply. But I need a way to enter env-entry value in ejb-jar.xml for EJB 3 in Jdev. In EJB 2, Jdev generate ejb-jar.xml for the bean and also let you add env-entry through bean's properties menu. But in there in no properties menu for EJB 3, also generated ejb-jar.xml is only a empty file doesn't contain any EJB depolyment information. That means you have to code ejb-jar.xml all manually.
    If I am wrong, can someone show me how to do this right?

  • How to add tns entry in names server

    Hi,
    Can anyone tell us, How to add tns entry in names server
    Thanks

    In the Net Manager utility, in the left-hand pane left click Oracle Names Servers, left click on your nameserver.
    Click the "+" button in the upper left, that should be enough to get you started- sorry, all our 9i installs have gone away, can't exactly recall the nix X gui version of client program, but I think* its netmgr, should be in OH/bin.
    If you're running a java OEM console that cames with 9i clients, Net Manager is available on that little Butler tab.
    And for the command line version, running the namesctl utility- you can save a tns entry with the connect string and run it in a file, just like sqlplus, with an @filename:
    vi newtns.txt
    register newtns -d (DESCRIPTION=(ADDRESS_LIST=...(SERVICE_NAME=NEWTNS.MYCO)))
    $ namesctl
    @newtns.txt
    query newtns *
    reload -- nameserver sync
    query newtns *
    exit
    $ Edited by: clcarter on Jul 7, 2011 3:26 PM
    added cmdline version

  • IPhon 4: After recently updating to version 7.1.2, all my past calendar entries disappeared and I cannot add new entries.

    After recently updating to 7.1.2, all of my past calendar entries for 22014 disappeared and I cannot add new entries??

    What account were you using to sync your Calendar?  Make sure that account is added to the device, and make sure that Calendars is turned on for that account. 
    Then, go to Settings > Mail, Contacts, Calendars, and make sure that under the Calendar section that 'Sync' is set to 'All Events'.
    Then go to the Calendar app, go to Calendars, and make sure that you have that account enabled.
    Then, close out all the running apps on your device, and restart it.
    Open up your Calendar app.  Are your entries back?

  • Routing Entry error during Inspection Plan creation in BAPI

    Hi,
    A Material has an task list created manually thorgh QP01. Am trying to created another through BAPI  BAPI_INSPECTIONPLAN_CREATE , changed the group counter to 2, but left the Task list blank. The change number field is also BLANK. Other data are populated for structures.
    While executing the BAPI   I get the error  "For further processing, the routing entry is missing", the Operation number is passed correctly. Which routing entry is it referring to ?
    Help with some pointers.
    Rgds,
    stck

    Hi,
    I could execute the BAPI BAPI_INSPECTIONPLAN_CREATE for a Material with already existing Task list.
    But i had to pass the Change Number, Set the Change Rule to 1 (With Change Number) and Change Value = 0.
    But the new created Task group counter does not allow any more changes beacause of the Change rule = 1.
    Can we not create a task for existing Material without the change number?
    Even if we create with change number how can we allow it for changes?
    What has to be the value combination for Change Rule and Change Type for allowing the change to task?
    Appreciate your inputs.
    Regds,
    stck

Maybe you are looking for