Apache and Weblogic  - Performance issue

 

Hi Anuj,
This question should be directed to the weblogic.developer.interest.plug-in
group.
Regarding this issue, this is normal -- the access.log for WebLogic shows
the requests from the proxy. But, instead of showing you the IP address of
the proxy server, it instead shows you the IP address of the client. You
can also verify that this is a different request because the connection to
the proxy server used HTTP/1.1, and the connection to WLS used HTTP/1.0 --
this is the protocol that the proxy plug-in uses to communicate with WLS.
So, in summary, there is only one request made by the client per image, and
the plug-in is in turn making a request to WLS for each image.
Dennis Munsie
Developer Relations Engineer
BEA Support
"Anuj Nijhawan" <[email protected]> wrote in message
news:3c20e890$[email protected]..
>
We have a setup with apache acting as web server and BEA as app server.But it
seems both of them are serving images to the web browser at the same time.This
is consuming lots of memory. Can anybody help rectifing this,
here's what each log file's say,
first Apache (access_log) shows that it served it up:
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET /img/divider.gif
HTTP/1.1"
304 0
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET
/img/i_user_collection.gif
HTTP/1.1" 304 0
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET
/img/sort_last_manual.gif H
Then BEA (access.log) shows it too:
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET /img/divider.gif
HTTP/1.0"
304 0
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET
/img/i_user_collection.gif
HTTP/1.0" 304 0
172.20.100.142 - - [19/Dec/2001:01:20:24 -0800] "GET
/img/sort_manual.gif HTTP/1
.0" 304 0

Similar Messages

  • How to configure apache and weblogic in windows 2000

    i am novice,
    i want to configure apache and weblogic in windows 2000
    weblogic version is 6.1
    apache version is 2.0
    how to do?

    George,
    I would take the following 'first steps'
    1)Install Apache20 on your Windows machine following the Apache online documentation
    http://httpd.apache.org/docs-2.0/misc/tutorials.html
    2)Make sure you can 'serve up' static HTML content from your Apache Server
    3)Install Weblogic Server per our online documentation
    http://edocs.bea.com/wls/docs61/install/index.html
    4)Also, make sure you can 'serve up' both static and dynamic (e.g., JSP) content
    directly from WLS server
    5)Once you have both of the above 'sanity' checks attempt to configure a simple
    proxy by ppath or mime type via our online documentation
    http://edocs.bea.com/wls/docs61/adminguide/apache.html#103803
    Chuck Nelson
    DRE
    BEA Technical Support

  • How to update this query and avoid performance issue?

    Hi, guys:
    I wonder how to update the following query to make it weekend day aware. My boss want the query to consider business days only. Below is just a portion of the query:
    select count(distinct cmv.invoicekey ) total ,'3' as type, 'VALID CALL DATE' as Category
    FROM cbwp_mv2 cmv
    where cmv.colresponse=1
    And Trunc(cmv.Invdate)  Between (Trunc(Sysdate)-1)-39 And (Trunc(Sysdate)-1)-37
    And Trunc(cmv.Whendate) Between cmv.Invdate+37 And cmv.Invdate+39the CBWP_MV2 is a materialized view to tune query. This query is written for a data warehouse application, the CBWP_MV2 will be updated every day evening. My boss wants the condition in the query to consider only business days, for example, if (Trunc(Sysdate)-1)-39 falls in weekend, I need to move the range begins from next coming business day, if (Trunc(Sysdate)-1)-37 falls in weekend, I need to move the range ends from next coming business day. but I should always keep the range within 3 business days. If there is overlap on weekend, always push to later business days.
    Question: how to implement it and avoid performance issue? I am afraid that if I use a function, it greatly reduce the performance. This view already contains more than 100K rows.
    thank you in advance!
    Sam
    Edited by: lxiscas on Dec 18, 2012 7:55 AM
    Edited by: lxiscas on Dec 18, 2012 7:56 AM

    You are already using a function, since you're using TRUNC on invdate and whendate.
    If you have indexes on those columns, then they will not be used because of the TRUNC.
    Consider omitting the TRUNC or testing with Function Based Indexes.
    Regarding business days:
    If you search this forum, you'll find lots of examples.
    Here's another 'golden oldie': http://asktom.oracle.com/pls/apex/f?p=100:11:0::::P11_QUESTION_ID:185012348071
    Regarding performance:
    Steps to take are explained from the links you find here: {message:id=9360003}
    Read them, they are more than worth it for now and future questions.

  • Apache and weblogic server

    hi all.
    i am using oracle application server 10g R2 over windows server 2003 64bit
    but now i planned to go for apache and weblogic server for this i do not have idea that
    should i do? plz what softwares are required to use apache and weblogic server with current version
    10g R2.?

    The WebLogic Server (WLS) is a Java container similar to OC4J in Application Server 10g release 2. If you want to use WLS, you will have to upgrade your Application Server 10g installation to Fusion Middleware 11g. The upgrade path typically depends on the products which you are using in 10g, e.g. the upgrade path for SOA is different than the upgrade path for Forms/Reports or Oracle Portal. The [url http://docs.oracle.com/cd/E23943_01/upgrade.1111/e10125/before_you_begin.htm]Upgrade Planning Guide is a good start.
    Thanks,
    EJ

  • What happened to PDF document 22040 – "PIX/ASA: Monitor and Troubleshoot Performance Issues"?

    Hi, does anyone knows what was happened to the following PDF notes in Cisco? The PDF file is only contains 1 page compared to the original notes in html format which is about a few pages.
    If there is alternative link for this document, please let me know. Thanks.
    Document ID: 22040
    PIX/ASA: Monitor and Troubleshoot Performance Issues
    http://www.cisco.com/image/gif/paws/22040/pixperformance.pdf <PDF Notes, but 1 page only?>
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a008009491c.shtml  < HTML Notes>

    Hi experts / marcin
    can anyone of you let me know about my question related to vpn ?
    Jayesh

  • Proxy between Apache and Weblogic

    Hi ,
    I need to configure a proxy server in between Apache and Weblogic which means not all the requests should go through proxy, only one particular request should go from apache to proxy server and proxy server to Weblogic. Can any one help me how to configure this and how it is going to work.
    Regards,
    Vamsee

    Not exactly sure.However can we use proxying by MIME type here
    http://download.oracle.com/docs/cd/E13222_01/wls/docs100/plugins/apache.html#wp132216
    Regards

  • Configuring apache and weblogic 7.1

    have anyone tried connecting apache and weblogic 7.1. which service pack can be used for this purpose

    have anyone tried connecting apache and weblogic 7.1. which service pack can be used for this purpose

  • BEA Weblogic performance issue

    Hi All,
    We are using bea weblogic 10.2.
    We have some performance issue in our production.
    We face the proble like
    1. Our bea query takes maxixmum cpu utilization in the oracle databse.
    process are content upload, update, expiry and report fetching.
    2. When we run BEA query for report it takes around 10 min to run and content count is around 70,000,
    is this OK?
    3. Some times we get Socket connection error.
    4. Sometimes we get portal datasource connection pool error, currently it is set as 30.
    5. Almost every process is slow.
    Can anyone help me for optimization?
    From BBA,
    we idetified the query which is taking high CPU utilization..
    SELECT
    DISTINCT B.NODE_ID, B.NODE_VERSION_ID, B.CM_MODIFIED_DATE, B.MODIFIED_BY,B.VERSION_COMMENT,
    B.LIFECYCLE_STATUS,A.OBJECT_CLASS_ID,A.REPOSITORY_NAME
    FROM CMV_NODE A, CMV_NODE_VERSION B,(SELECT NODE_ID, MAX(CAST(NODE_VERSION_ID AS INTEGER)) NVI
    FROM CMV_NODE_VERSION GROUP BY NODE_ID) A1, ( SELECT B.NODE_ID,B.NODE_VERSION_ID, B.CM_MODIFIED_DATE,
    B.MODIFIED_BY, B.VERSION_COMMENT, B.LIFECYCLE_STATUS, A.OBJECT_CLASS_ID, A.REPOSITORY_NAME FROM CMV_NODE A,
    CMV_NODE_VERSION B, CMV_NODE_VERSION_PROPERTY N1, CMV_PROPERTY P1, CMV_VALUE_V V1 WHERE A.NODE_ID = B.NODE_ID
    AND B.NODE_ID = N1.NODE_ID AND B.NODE_VERSION_ID = N1.NODE_VERSION_ID AND N1.PROPERTY_ID = P1.PROPERTY_ID
    AND P1.PROPERTY_ID = V1.PROPERTY_ID AND P1.PROPERTY_NAME = :1 AND (UPPER(V1.TEXT_VALUE) LIKE :2 ESCAPE :"SYS_B_0" )
    UNION
         SELECT B.NODE_ID, B.NODE_VERSION_ID, B.CM_MODIFIED_DATE, B.MODIFIED_BY, B.VERSION_COMMENT,
    B.LIFECYCLE_STATUS, A.OBJECT_CLASS_ID, A.REPOSITORY_NAME FROM CMV_NODE A, CMV_NODE_VERSION B, CMV_NODE_
    Edited by: Arvind Rai on Apr 13, 2010 12:49 PM

    If your DB CPU is pegged, then anything that does db operations will take time (including some portal operations). If you take a thread dump you should be able to see them waiting on the DB
    When we run BEA query for report it takes around 10 min to run and content count is around 70,000,No. If it causes your CPU to max out it isnt. However your content items arent that much, so what query are you running? You could always export and import just the content tables and run your queries on some other machine (Assuming this is the cause)
    3. Some times we get Socket connection error.More information needed
    4. Sometimes we get portal datasource connection pool error, currently it is set as 30.What is the error?
    5. Almost every process is slow.If the DB is maxed this is what you should expect.
    When is the query fired? Are your indexes created? I assume caching is not much good to you since these are reporting queries?

  • Apache and webLogic Communication

    Hi
    we are deploying new application and client want to have Apache on one server and weblogic on another server.
    Can you pls point to any notes/docs which tells how to configure Apache to have as fronend for applications in weblogic.
    Thanks
    Sree

    Hi
    Thanks for the info.
    Since we are hosting team we amy not be able to allow/to code. We have existing setup where Oracle HTTP server in DMZ communicates with other report server oc4j using ajp protocol. We are also NOT allowed to use proxy pass.
    For a new project we will be using Apache web server in DMZ and weblogic application server inside.
    Can you Pls let me know how we can trasfer requestes thru Apache using other protocols like ajp other than proxy.
    Thanks

  • CAT4900M and NetApp - Performance issue

    Hi,
    I'm struggling with a performance issue between our two NetApp Fas3170-devices.
    The setup is quite simple: Each NetApp is connected via two TenGig interfaces to a CAT4900M. The 4900M's are also connected via two TenGig interfaces. Each pair of connections are bundled into an Layer2-etherchannel, configured as a dot.1q trunk. Mode is set to 'ON' on both the 4900 and the NetApp. According to NetApp documentation, this configuration is supported. Across each etherchannel, the vlans 219 and 220 are allowed. Two partitions are configured on the NetApp's, one being active in our primary datacenter and another in our secondary datacenter. Vlan219 and Vlan220 are configured for each the two partitions, using HSRP for gateway redundancy.
    None of the interfaces nor the etherchannels shows any signs of misconfiguration. All links are up and etherchannels working as expected, well almost. Nothing indicates packet loss, crc-errors, Input/Output queue-drops or anything the would impact performance. Jumboframe is not configured, although this has been discussed.
    The problem is, that we're unable to achieve satisfactory performance, when for instance, performing a volume copy between the two NetApp partitions. Even though we have a teoretical bandwidth of 20Gbps end-to-end, we never climb above 75-80 Mbytes of actual transfer-rate between the two NetApps. So performancewise, is almost looks as if we're "scaled" down to a 1Gig link. No QoS or other kind of ratelimiting has been implemented on the 4900's, so from a network point of view, the NetApps can go full-throttle. NetApp sw has been updated and configurations for both NetApp and 4900's have been revised by NetApp engineers and given a "clean bill of health".
    The configuration for the 4900->NetApp etherchannel/interfaces is as follows:
    interface TenGigabitEthernet1/5
    description *** Trunk NetAPP DC1 ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    udld port aggressive
    channel-group 2 mode on
    spanning-tree bpdufilter enable
    interface TenGigabitEthernet1/6
    description *** Trunk NetAPP DC1 ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    udld port aggressive
    channel-group 2 mode on
    spanning-tree bpdufilter enable
    interface Port-channel2
    description *** Trunk Etherchannel DC1 ***
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    spanning-tree bpdufilter enable
    spanning-tree link-type point-to-point
    Configuration for 4900->4900 interfaces/etherchannel is as follows:
    interface TenGigabitEthernet1/1
    description *** Site-to-Site trunk ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    udld port aggressive
    channel-group 1 mode on
    interface TenGigabitEthernet1/2
    description *** Site-to-Site trunk ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    udld port aggressive
    channel-group 1 mode on
    interface Port-channel1
    description *** Site-to-Site trunk ***
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    spanning-tree link-type point-to-point
    Vlan10 used for mngt-purpose.
    Does anyone have similar experiences or suggestions as to why we're having theese performanceissues?
    Thanks
    /Ulrich
    Message was edited by: UHansen1976

    Hi,
    Thanks for your reply.
    I take it, that you mean baseline performance between the two NetApp's. Well, that's really out of my hands, as another department is responsible for the NetApp's. I'm not aware of any baseline performance, nor have I seen any benchmark tests or anything, that could give me hint.
    Just as you suggest, I've gone through the switch-setup systematically. Basically, starting with the physical layer and working my way up. So far, I've found nothing that would indicate a physical problem. The switchport/etherchannel setup has been verified by my peers and also verified by NetApp according to the configuration on the NetApps, as well as the various best-practice documentation availible. Futhermore, I haven't seen any signs of packets drops, crc-errors, massive re-transmissions or anything like not, neither on the switches nor the NetApps.
    Recently we had a status-meeting with our NetApp-partner and it looks to me like they're persuing the logical setup on the NetApps, as the're apparently a number of settings etc. that needs adjustment. Also, we're waiting for NetApp tech-support to comment on the traces, config-dump etc. we've send to them.
    /Ulrich

  • Apache and weblogic proxying not happening properly

    Hi,
    I am trying to proxy my request from my apache installation to weblogic installation.
    I am able to proxy request to the default page of my application in weblogic.
    But when trying to browse through that page I am getting error.
    Basically, It tries to listen at 7501 port of my machine(apache machine) only
    and is not trying to listen at 80 port of my machineso that it can be proxied
    to the 7501 port of weblogic machine.
    I am unable to figure out the issue. Maybe u can help me from ur experience.
    I get an exception saying:
    ###<Apr 28, 2003 9:53:47 PM IST> <Warning> <Entitlements> <blrkec09630a> <portalServer>
    <ExecuteThread: '10' for queue: 'default'> <kernel identity> <16:b7687ce40e05e9a9>
    <402716> <Missing entitlments configuration asset.>
    Exception[com.bea.p13n.rules.manager.RuleSetNotFoundException: The rule set with
    URI /entitlements/GlobalEntitlements.rls could not be located by the class named
    com.bea.p13n.rules.manager.internal.RuleSetPersistenceManager.]
    at com.bea.p13n.rules.manager.internal.RuleSetPersistenceManager.getRuleSet(RuleSetPersistenceManager.java:385)
    at com.bea.p13n.rules.manager.internal.ContextPool.<init>(ContextPool.java:156)
    at com.bea.p13n.rules.manager.internal.ContextPoolFactory.createContextPool(ContextPoolFactory.java:164)
    at com.bea.p13n.rules.manager.internal.ContextPoolFactory.getContextPool(ContextPoolFactory.java:223)
    at com.bea.p13n.rules.manager.internal.RulesManagerImpl.getContext(RulesManagerImpl.java:469)
    at com.bea.p13n.rules.manager.internal.RulesManagerImpl.evaluate(RulesManagerImpl.java:350)
    at com.bea.p13n.rules.manager.internal.RulesManagerImpl.evaluateRuleSet(RulesManagerImpl.java:148)
    at com.bea.p13n.rules.manager.internal.RulesManagerImpl_mcr6qe_EOImpl.evaluateRuleSet(RulesManagerImpl_mcr6qe_EOImpl.java:448)
    at com.bea.p13n.entitlements.rolemapper.RoleMapper.mapRoles(RoleMapper.java:179)
    at com.bea.p13n.entitlements.accesscontroller.AccessController.isAccessAllowed(AccessController.java:143)
    at com.bea.portal.entitlement.util.EntitlementHelper.isAccessAllowed(EntitlementHelper.java:285)
    at com.bea.portal.entitlement.util.EntitlementHelper.checkEntitlementInternal(EntitlementHelper.java:231)
    at com.bea.portal.entitlement.util.EntitlementHelper.checkEntitlement(EntitlementHelper.java:144)
    at com.bea.portal.manager.internal.UserPortalStatePolicy.checkPortletEntitlement(UserPortalStatePolicy.java:636)
    at com.bea.portal.manager.internal.UserPortalStatePolicy.generateUserPageState(UserPortalStatePolicy.java:567)
    at com.bea.portal.manager.internal.UserPortalStatePolicy.generateUserPortalState(UserPortalStatePolicy.java:293)
    at com.bea.portal.manager.internal.PortalManagerDelegateImpl.getUserPortalState(PortalManagerDelegateImpl.java:179)
    at com.bea.portal.manager.ejb.internal.PortalManagerBean.getUserPortalState(PortalManagerBean.java:70)
    at com.bea.portal.manager.ejb.internal.PortalManagerBean_w6xny9_EOImpl.getUserPortalState(PortalManagerBean_w6xny9_EOImpl.java:370)
    at com.bea.portal.appflow.internal.PortalRequestImpl.getPortalState(PortalRequestImpl.java:148)
    at com.bea.portal.render.servlets.jsp.PortalRenderHelper.getSelectedSkin(PortalRenderHelper.java:167)
    at jsp_servlet._framework._security.__login._jspService(login.inc:11)
    at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
    at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1058)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:401)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:445)
    at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:20)
    at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
    at weblogic.servlet.internal.RequestDispatcherImpl$ForwardAction.run(RequestDispatcherImpl.java:345)
    at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:780)
    at weblogic.servlet.internal.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:252)
    at com.bea.p13n.appflow.webflow.servlets.internal.WebflowServlet.doGet(WebflowServlet.java:178)
    at com.bea.portal.appflow.servlets.internal.PortalWebflowServlet.doGet(PortalWebflowServlet.java:235)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
    at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1058)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:401)
    at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:20)
    at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
    at com.bea.p13n.tracking.clickthrough.ClickThroughEventFilter.doFilter(ClickThroughEventFilter.java:156)
    at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:5451)
    at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:780)
    at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3105)
    at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2588)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    Regards,
    Vinod Thapliyal

    The WebLogic Server (WLS) is a Java container similar to OC4J in Application Server 10g release 2. If you want to use WLS, you will have to upgrade your Application Server 10g installation to Fusion Middleware 11g. The upgrade path typically depends on the products which you are using in 10g, e.g. the upgrade path for SOA is different than the upgrade path for Forms/Reports or Oracle Portal. The [url http://docs.oracle.com/cd/E23943_01/upgrade.1111/e10125/before_you_begin.htm]Upgrade Planning Guide is a good start.
    Thanks,
    EJ

  • SSL Connection Configuration between Apache and Weblogic 8,1

    I'm currently using Apache web server as a front end server for Weblogic server 8.1 and now i' facing some configuration problem to setting up the SSL connection between this 2 server. When i open my web application page, it shows
    Failure of Server Apache bridge
    No backend server available for connection: timed out after 10 seconds or idempotent set to OFF.
    and my proxy.log shows:
    Thu Nov 03 09:36:41 2011 <182413202842013> INFO: SSL is configured
    Thu Nov 03 09:36:41 2011 <182413202842013> INFO: SSL configured successfully
    Thu Nov 03 09:36:41 2011 <182413202842013> Using Uri /favicon.ico
    Thu Nov 03 09:36:41 2011 <182413202842013> After trimming path: '/favicon.ico'
    Thu Nov 03 09:36:41 2011 <182413202842013> The final request string is '/favicon.ico'
    Thu Nov 03 09:36:41 2011 <182413202842013> SEARCHING id=[ebwdsk298.ebworx.com:7002] from current ID=[ebwdsk298.ebworx.com:7002]
    Thu Nov 03 09:36:41 2011 <182413202842013> The two ids matched
    Thu Nov 03 09:36:41 2011 <182413202842013> @@@FOUND...id=[ebwdsk298.ebworx.com:7002], server_name=[10.122.50.218], server_port=[80]
    Thu Nov 03 09:36:41 2011 <182413202842013> attempt #0 out of a max of 5
    Thu Nov 03 09:36:41 2011 <182413202842013> general list: trying connect to '10.122.50.48'/7002/7002 at line 2696 for '/favicon.ico'
    Thu Nov 03 09:36:41 2011 <182413202842013> New SSL URL: match = 0 oid = 22
    Thu Nov 03 09:36:41 2011 <182413202842013> Connect returns -1, and error no set to 10035, msg 'Unknown error'
    Thu Nov 03 09:36:41 2011 <182413202842013> EINPROGRESS in connect() - selecting
    Thu Nov 03 09:36:41 2011 <182413202842013> Setting peerID for new SSL connection
    Thu Nov 03 09:36:41 2011 <182413202842013> 0a7a 3230 5a1b 0000 .z20Z...
    Thu Nov 03 09:36:41 2011 <182413202842013> Local Port of the socket is 2121
    Thu Nov 03 09:36:41 2011 <182413202842013> Remote Host 10.122.50.48 Remote Port 7002
    Thu Nov 03 09:36:41 2011 <182413202842013> general list: created a new connection to '10.122.50.48'/7002 for '/favicon.ico', Local port:2121
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Host]=[10.122.50.218]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Connection]=[keep-alive]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Accept]=[*/*]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[User-Agent]=[Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.163 Safari/535.1]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Accept-Encoding]=[gzip,deflate,sdch]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Accept-Language]=[en-US,en;q=0.8]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs from clnt:[Accept-Charset]=[ISO-8859-1,utf-8;q=0.7,*;q=0.3]
    Thu Nov 03 09:36:41 2011 <182413202842013> URL::sendHeaders(): meth='GET' file='/favicon.ico' protocol='HTTP/1.1'
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Host]=[10.122.50.218]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Accept]=[*/*]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[User-Agent]=[Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.163 Safari/535.1]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Accept-Encoding]=[gzip,deflate,sdch]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Accept-Language]=[en-US,en;q=0.8]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Accept-Charset]=[ISO-8859-1,utf-8;q=0.7,*;q=0.3]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Connection]=[Keep-Alive]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[WL-Proxy-SSL]=[false]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[WL-Proxy-Client-IP]=[10.122.50.48]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[Proxy-Client-IP]=[10.122.50.48]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[X-Forwarded-For]=[10.122.50.48]
    Thu Nov 03 09:36:41 2011 <182413202842013> Hdrs to WLS:[X-WebLogic-Force-JVMID]=[unset]
    Thu Nov 03 09:36:41 2011 <182413202841921> INFO: No session match found
    Thu Nov 03 09:36:41 2011 <182413202842013> INFO: No CA was trusted, validation failed
    Thu Nov 03 09:36:41 2011 <182413202841921> INFO: DeleteSessionCallback
    Thu Nov 03 09:36:41 2011 <182413202842013> ERROR: SSLWrite failed
    Thu Nov 03 09:36:41 2011 <182413202842013> SEND failed (ret=-1) at 789 of file ../nsapi/URL.cpp
    Thu Nov 03 09:36:41 2011 <182413202842013> *******Exception type [WRITE_ERROR_TO_SERVER] raised at line 790 of ../nsapi/URL.cpp
    Thu Nov 03 09:36:41 2011 <182413202842013> Marking 10.122.50.48:7002 as bad
    Thu Nov 03 09:36:41 2011 <182413202842013> got exception in sendRequest phase: WRITE_ERROR_TO_SERVER [os error=0,  line 790 of ../nsapi/URL.cpp]: at line 3078
    Thu Nov 03 09:36:41 2011 <182413202842013> INFO: Closing SSL context
    Thu Nov 03 09:36:41 2011 <182413202842013> INFO: Error after SSLClose, socket may already have been closed by peer
    Thu Nov 03 09:36:41 2011 <182413202842013> Failing over after WRITE_ERROR_TO_SERVER exception in sendRequest()
    Can anyone tell me what should i do in order to correct this error? Your help is kindly appreciate!!! Please~

    1) Is the managed server up?
    2) from apache server are you able to bind the managed server port?
    3) can you pls send the weblogic ssl configuration?

  • Can't access "Network" and other performance issues

    Hi all,
    I'm facing a catch-22 and am not sure what to do to get myself and my mac out of this downward spiral. Any help you can offer would be greatly appreciated (fyi I am admittedly not great with macs and probably don't maintain my MacBook Pro well enough).
    I've had a serious slowdown in performance starting a couple weeks ago. the system moves at a glacial pace and most of the time is spent watching the spinning rainbow.
    To add to my issues, my ISP recently performed a system upgrade which requires me to change some settings under "Network" in my system preferences. Well, when I try to access "Network", the machine thinks for a while, then an error message appears telling me that the network preferences has shut down unexpectedly. When I hit "retry" the error message eventually reappears.
    So, because of the upgrade, I can't access the internet to download any repairs for the machine, and because of the problems with the machine, I can't modify the preferences to access the internet. Obviously a vicious cycle which someone of my expertise level is struggling to solve.
    Side notes
    - I've passed the 90-day phone support period so can't call for help.
    - I'm on my work computer now. Could I download some repair/diagnostic tool here, then run it on my machine at home?
    If anyone can throw me a lifeline I would be grateful!
    MacBook Pro 15"   Mac OS X (10.4.3)  

    OZ 99,
    For logic's sake, I'm gong to take these out of order a bit:
    2) A "disk error" occurs when the "file system" (sometimes called the "disk directory") becomes damaged. This is data that is written to the HD, so yes, it could be considered a software error. Your file system is, basically, a map of your physical HD, and it indexes the location on the drive of all the other files. When it is damaged for whatever reason, your disk "forgets" where some amount of data lives. Because of this, the associated files become damaged, or "corrupt." If those files happen to be critical components of the OS, bad things can happen. At worst, the disk will become unmountable, and all of your files unrecoverable.
    1) Disk errors can be caused by several things. Sometimes, one or more "blocks" (let's call them physical locations on the disk) on your HD can become physically damaged. Whether this is because of a slight flaw in manufacturing, a scratch, magnetic particles that lose their "oomph," whatever, matters not. What is important is that some data is lost. Because the file system still believes there is data living in this location, it (the file system) is no longer reliable; it is damaged. While the initial loss of data could be considered hardware-related, the disk error is not. I'll come back to this.
    Another potential cause is some random error in the process of writing data to the disk. Again, this is a software problem, not a hardware problem. The most common cause for this occurs when your computer is shut down improperly, either a forced shutdown or a power loss. Journaling, which is the default for an OS X boot volume, goes a long way toward automatically fixing these types of disk errors, but it is not always a guarantee.
    If you have had your MBP for only a short period of time, it is not surprising that a disk error has occurred, and probably because of a bad block. Absolutely flawless drives are rare, and many computers ship with incipient disk errors. For this reason, many people like to format any new drive, even one in a new computer, right out of the box (I'll get to reasons why this is a good thing to do).
    3) Yes. Disk Utility can check or repair your file system. Any repairs must be made using Disk Utility while booted to the OS X install disk. Your HD can be "verified," however, while booted to the HD. Simply open Disk Utilty (in the "Utilities" folder), select your startup disk, then click "Verify" in the "First Aid" pane.
    4) Yes, you will have to reinstall all of your applications after formatting and reinstalling. Formatting erases everything on the volume or drive selected. Settings and data for all of those applications can be saved, however, then transferred back to the MBP after reinstalling OS X. Once the applications, themselves, have been reinstalled, you will be right back where you started. I can talk about making a comprehensive backup in another post, if you like.
    DISK UTILITY: In my first post, I recommended that you select your entire drive, then using the "Zero All Data" option. This process takes a considerably longer amount of time (as much as an hour and a half, depending on the size of your drive), but it has one big advantage. When this option is used on an entire physical drive (also called a "device"), it will scan for those pesky bad blocks, and "map out" any it finds. Since these bad spots on the disk will not be included in the new file system's list of "useable" locations, your chances of encountering another disk error in the near future is drastically reduced. So, even though a bad block could be considered a hardware error, management of them is handled by software.
    Scott

  • Apache and Weblogic authentication

    Apache 2.0 and WL 8.1 SP6;
    Apache redirects to a wl web app and the web app's front page is password protected using Apache's authentication services.
    Turns out, the users configured with Apache's 'htpasswd' have to be duplicated in weblogic. Curious to know why this is. There appears to be no documentation of this necessity that I could find.
    Any ideas about the configuration principles involved here?
    Thanks,
    Karoly

    Hi Scott,
    The only way it can work is when Apache adds another token to the request
    say
    MyToken : value
    U can create a Custom Identity Asserter to read that token and authenticate the user.
    U can find the steps to create custom identity asserter here
    http://weblogic-wonders.com/weblogic/2010/03/15/custom-identity-asserter-for-weblogic-server/
    HTH,
    Faisal

  • WHERE LIKE% and ASP Performance Issue

    Hi,
    i am facing an issue with my ASP application as i use it as front end web application to connect to a huge oracle Database.
    Basically i use my queries within the ASP pages, one of them uses Where LIKE to more than one column
    Example: i have Col1, Col2 i have created the following indexes:
    Index1 on Col1, Index2 on Col2 and Index3 on Col1,Col2
    From the ASP page i have field 1, field 2 and would like to use LIKE on both fields (Field1,Field2) but the process take so much time to get result not to mention the resources it takes.
    My ASP Query:
    sqlstr = "Select * From TABLE Where COL1 Like '"&field1&"%' And COL2 Like '"&field2&"%' ORDER BY Num ASC"
    Set Rs = Conn.Execute(Sqlstr)
    What to use instead of this query to get same result but much faster (optimized)?
    Thanks.

    if the ratio of the data returning is appropriate for index access Oracle optimizer should choose to use it, but for further commenting;
    a. I couldn't see your query in the output you provided?
    b. I need to know the data distribution; what is the ratio of the data coming over all table's data with the literals you use? you can check it by taking a count of the columns you indexed with a group by query.
    c. I assume that your indexes are in VALID status and you collected statistics with dbms_stats and cascaded to the indexes, and depending on the question above if your data is not skewed which may cause extra need for histograms,
    d. I also assume if like is starting with '%', which in this case Oracle does not use indexes and Text option is what you need to read as advised, or for another smart idea on making “like ‘%xxxx’" use index in Oracle you may check - http://oracle-unix.blogspot.com/2007/07/performance-tuning-how-to-make-like.html
    After you supply the query with literals included and the data distribution, maybe as a last resort we need to force index access with a hint and compare the statistics provided by timing and autotrace options of SQL*Plus.
    ps: Also you may produce a 10053 event trace to understand the optimizer decision - http://tonguc.wordpress.com/2007/01/20/optimizer-debug-trace-event-10053-trace-file/

Maybe you are looking for

  • How to Search strings with and without quotes

    Hello, I need to search a string with quote and without quote the same way Ex: Wendy's If user enters wendys without ' also need to return all the Wendy's..! I appreciate any help...! Thanks RG

  • Ghost java process

    Using: SunOS xxx 5.9 Generic_112233-04 sun4u sparc SUNW,Sun-Fire-280R and the stock: Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b28) Java HotSpot(TM) Client VM (build 1.4.2-b28, mixed mode) I have an app that is running, and it's s

  • Column Ambiguosly Define error

    Hi, I have a query that goes like this select * from (      select a.data1, b.data2      from table1 a, table2 b      where a.xxx = b.xxx union all           select a1.data1, b1.data2      from table11 a1, table21 b1      where a1.xxx1 = b1.xxx1 unio

  • Certain Flash Videos Will Not Play (e.g. uStream live)

    I'm having trouble getting certain videos to play. None of the live feeds on www.ustream.tv work. Nor do the videos on www.mtv.ca, nor those on www.kelbytraining.com. They all used to work just fine. Now, I just get a perpetual loading graphic. They

  • Any problems or downside with the 5K Retina iMac?

    Aside from the price, are there any known downsides or issues with the Retina iMac? Such as excessive heat or fan noise? Does the Retina display slow down the computer? Thanks.