Bandwidth Restriction

Hi,
i have got internet router cisco 1700 series, my fastethernet has got 1 public IP address eg. 10.10.10.1 connected to LAN& S0/0 as got public IP address eg. 1.1.1.1 which is connected to ISP(1 Mbps lease line). i have been using few public IP address to my LAN for FTP,Webserver,Mail Server etc... now is there any option in the router where i can restrict only 128 Kbps alone for my FTP server. where FTP server IP is 10.10.10.2, since FTP alone is occupying almost entire bandwidth, users on my LAN trying to access internet is become very very slow.

Hello,
unfortunately the config above will not work, because it does not describe FTP traffic properly.
TCP port 21 is only the control session, whereas the data transfer with active FTP is done through TCP port 20. Data transfer in general will cause your congestion problems. With passive FTP you will have dynamically assigned port numbers and then an access-list is NOT able to grab the majority of FTP transfer at all.
So you need to use NBAR for your case. The config would look like this:
ip cef
class-map match-all FTPserver
match ip address 100
match protocol ftp
policy-map Output1
class FTPserver
shape average 128000
interface Serial0
description 1Mbps to ISP
ip address 1.1.1.1 255.255.255.252
bandwidth 1024
service-policy output Output1
access-list 100 permit host 10.10.10.2 any
The class-map FTP describes traffic, which is from host 10.10.10.2 AND is FTP. This includes active and passive FTP control session and data session.
In the policy this traffic is limited to 128 kbps through shaping, i.e. there is never more than 128 kbps utilization from FTP traffic on your WAN link.
In case you would like to limit FTP only in case there is other traffic please use the following policy:
class-map match-all FTPserver
match ip address 100
match protocol ftp
class-map match-all NonFTPserver
match not class FTPserver
policy-map Output1
class NonFTPserver
bandwidth percent 75%
This will guarantee 75% of the bandwidth to traffic not being FTP from your server. This will only restrict FTP traffic when thre is no other traffic.
Cisco does recommend not to plan for more than 75% percent of interface bandwidth, because of L2 keepalives, and system messages in general.
Hope this helps! Please rate all posts.
Regards, Martin

Similar Messages

  • Bandwidth Restriction Config Check

    Hi,
    Could anyone please go over my config example for a check. I believe I've configured a bandwidth restriction for host xx.xx.xx.xx to have a Internet bandwidth restriction of 50Mbps from 8am to 6pm and a Internet bandwidth restriction of 75Mbps from 6pm to 8am.
    Thank you
    time-range REPLIWEB-8AM-6PM
     periodic daily 08:00 to 17:59
    time-range REPLIWEB-6PM-8AM
     periodic daily 18:00 to 07:59
    ip access-list extended POLICE-THIS-8AM-6PM
     remark REPLIWEB BETWEEN 8AM and 6PM
     permit tcp any eq 2837 host xx.xx.xx.xx time-range REPLIWEB-8AM-6PM
     permit tcp any eq 5745 host xx.xx.xx.xx time-range REPLIWEB-8AM-6PM
     permit tcp host xx.xx.xx.xx any eq 2837 time-range REPLIWEB-8AM-6PM
     permit tcp host xx.xx.xx.xx any eq 5745 time-range REPLIWEB-8AM-6PM
    ip access-list extended POLICE-THIS-6PM-8AM
     remark REPLIWEB BETWEEN 6PM and 8AM
     permit tcp any eq 2837 host xx.xx.xx.xx time-range REPLIWEB-6PM-8AM
     permit tcp any eq 5745 host xx.xx.xx.xx time-range REPLIWEB-6PM-8AM
     permit tcp host xx.xx.xx.xx any eq 2837 time-range REPLIWEB-6PM-8AM
     permit tcp host xx.xx.xx.xx any eq 5745 time-range REPLIWEB-6PM-8AM
    class-map match-any POLICING-CLASS-8AM-6PM
     match access-group name POLICE-THIS-8AM-6PM
    class-map match-any POLICING-CLASS-6PM-8AM
     match access-group name POLICE-THIS-6PM-8AM
    policy-map OUTBOUND
     class POLICING-CLASS-8AM-6PM
      police 50000000 conform-action transmit  exceed-action transmit  violate-action drop
    policy-map INBOUND
     class POLICING-CLASS-8AM-6PM
      police 50000000 conform-action transmit  exceed-action transmit  violate-action drop
    policy-map OUTBOUND
     class POLICING-CLASS-6PM-8AM
      police 75000000 conform-action transmit  exceed-action transmit  violate-action drop
    policy-map INBOUND
     class POLICING-CLASS-6PM-8AM
      police 75000000 conform-action transmit  exceed-action transmit  violate-action drop
    interface GigabitEthernet0/0
     description WAN LINK
     bandwidth 100000
     ip address public address
     ip access-group DID in
     no ip redirects
     ip flow ingress
     ip flow egress
     duplex full
     speed 100
     no cdp enable
     service-policy input INBOUND
     service-policy output OUTBOUND

    I think that service-policy output OUTBOUND is ok. it works in output direction.
    but service-policy input INBOUND not ok. it should be in output direction in interface connected to user host
    and in service-policy I am using class default and daughter class inside
    and dont forget to rate post

  • Network Packet Size Or Bandwidth Restriction in Database Mirroring

    Hi Everyone,
    I tried finding online but couldn't get answer to the below question.
    Is it possible to restrict the packet size for the SQL Database Mirroring? Is it possible to tell database mirroring what size packets it should send to the mirrored database? Is it possible to define the bandwidth or packets per second for mirroring? If
    yes, is it possible at the server level or database level? If yes, how to do this?
    The reason that I want to know this is because, if I have N number of databases on a server and I'm mirroring them on other server in a separate location, how will I get to know the bandwidth constraint and if there is a bandwidth constraint can I control
    the data sent through database mirroring to ensure that the bandwidth is not affected?
    Thanks
    Mayur Kashikar

    Database Mirroring has no such setting specific to "per database" or "per server" which can limit the packets sent over the wire. Remember that communication of database doesn't happen via regular port. There is a separate port use by
    database mirroring (generally 5022)
    Network packet size is setting which is for communication happening on regular connection port (i.e. TDS packets). Database mirroring doesn't use TDS packets but it uses the Service Broker network stack.
    In short, there is no such setting which can control the communication the way you want.
    If you search for Jumbo Frame, you might get some reference about performance gain but remember that if you use Jumbo frame then it has to be supported by each and every component in the network else you would have packet drop and mirroring would be
    disconnected.
    Balmukund Lakhani
    Please mark solved if I've answered your question, vote for it as helpful to help other users find a solution quicker
    This posting is provided "AS IS" with no warranties, and confers no rights.
    My Blog |
    Team Blog | @Twitter
    | Facebook
    Author: SQL Server 2012 AlwaysOn -
    Paperback, Kindle

  • Unintended bandwidth restriction?

    I have a 1.33 GHz PB G4, running Leopard. I have a current 24" iMac, running Leopard. The PB G4 connects over Wi-Fi to a current AirPort Extreme, n-spec with Gig ethernet ports and the iMac connects wired to the AP Extreme. So what I can't figure out is this: if I go to speakeasy.net/speedtest and do a check, my older, slower, wi-fi connected PB G4 can report 4000 kbps down. My iMac, on the other hand, will show an instant spike of 3500 - 3900 kbps but will, within a couple of seconds, "lock in" at 2000 - 2200 kbps. I can't find what settings might be different between the two machines that would cause this. The interesting thing is this; my service is with Comcast and when I first got hooked up, I used to be able to consistently measure 6000 kbps down with my Tiger PBG4. Somewhere along the way, I noticed that my max download capability was being "restricted" to the 2000 -2200 kbps range. I thought Comcast had done something and placed several calls to them, even found how to get into the modem interface and check signal status and they assured me and even the modem indicated that it was operating as it should. Once I got my new iMac, just a month or so prior to Leopard shipping, I set it up and noticed that it was able to pull around 4000 -4200 kbps, regularly, at the Speakeasy test site. I obviously determined that there must be some setting or something configured incorrectly within my PBG4. After much research and "tinkering" in terminal, based on forum posts across the internet about how to improve broadband speed in OS X, I got nowhere. No improvement. Once Leopard shipped, and after the infamous install issues that accompanied it, I had backed up my PBG4 docs and decided to wipe it and install Leopard, which went flawless and is still quite impressive even on 4 year old hardware. Not too surprisingly, it would now register 4000 kbps (range) at the speakeasy test site. Interestingly enough, on the Leopard install issues with the iMac, I ended up migrating my wife's account from the PBG4, which also had not given me the speed issues, which made me believe it was in my user account settings. The strangest thing began to happen. In my account on my iMac, which I did not migrate, when I go to the speakeasy test site, it now is showing the same thing that the PBG4 used to show. I can only get 2000 kbps range on downloads now. Again, I've checked and verified all the settings I know to check and am at a point where I need some other smarter people to think and give me some advice on what to check.

    Hi Akash,
    I applied policy map on tunnel inteface on server side but i am not see packets getting match. I also applied preclassify on it also.
     Service-policy output: police
        Class-map: class-default (match-any)
          172453 packets, 46115738 bytes
          5 minute offered rate 950000 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 172043/48898022
          shape (average) cir 20000000, bc 80000, be 80000
          target shape rate 20000000
          Service-policy : police-smtp
            Class-map: smtp (match-all)
              0 packets, 0 bytes
              5 minute offered rate 0 bps, drop rate 0 bps
              Match: access-group 120
              Queueing
              queue limit 64 packets
              (queue depth/total drops/no-buffer drops) 0/0/0
              (pkts output/bytes output) 0/0
              bandwidth 15000 kbps
            Class-map: class-default (match-any)
              172453 packets, 46115738 bytes
              5 minute offered rate 950000 bps, drop rate 0 bps
              Match: any
              queue limit 64 packets
              (queue depth/total drops/no-buffer drops) 0/0/0
              (pkts output/bytes output) 172043/48898022

  • Guest usage bandwidth restriction

    Is there any chance that Cisco/linksys will give owners the ability to throttle the bandwidth for guest usages?
    I have guests using my router and sucking resources dry. I'd like to be able to restrict band width and perhaps the ability to designate what can connect.. (voip, specific ports, etc...)

    If your using Cisco connect cloud then you can try to set the bandwidth under media prioritization. If you are using the classic firmware go to the QoS subtab under the Applications & Gaming tab and then set the priority.

  • Applying bandwidth restriction to a VPN

    Hello Experts,
    I have a L2L vpn configured between two sites on which we route various Intranet traffic like FTP, file copying, etc. I want to limit bandwidth between hosts. Example: 1mbps I want to allocate between Host A lying at site 1 and Host B lying at site 2. Not sure if it is possible, please suggest.
    Thanks
    Arabinda

    Here is the config example for VOIP through the VPN tunnel.
    http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008080dfa7.shtml
    you can use the same logic for your scenario.
    thanks
    -SYed

  • UK 20Mhz Bandwidth restriction on 5Ghz Band

    I understand the Airport Express Basestations for the UK market are crippled to prevent the use of 40Mhz wide channels in the 5Ghz band, and are limited to 20Mhz bandwidth per channel.
    Does anyone know if this can be circumvented via a firmware update or other hack?
    Steve

    I have both an Express and Extreme which I purchased 3 weeks ago from an apple store. The Extreme will not allow Wide channel mode but the Express allows wide channel and seems to work fine.
    Matthew

  • Bandwidth restriction ASA

    Hi Experts.
    I am running ASA 5525 ver 9.1(2). I have internet router connecting to ISP ahead of ASA. Bandwidhth of internet circuit is 45mbps. I have configured some L2L IPSec tunnel  on ASA. I want to limit bandwidht for IPSec tunnel traffic to 10mbps and rest for other traffic. Pls suggest me how could i configure this on ASA. An configuration example would be highly appreciated.

    Hi Experts.. Pls help me out of this situation. waiting for someone to reply and suggest.

  • [SOLVED] Pacman -Syu on a (very) limited bandwidth

    Hi
    I've been using Arch for about a year, and I'm still pretty new to Linux and Arch. The reason I installed Arch in the first place was because of the how much control you have over your system, since you get to build it up according to your preferences. I absolutely love Arch for this and many other reasons.
    The problem I have is that I am limited to 500mb bandwidth a month. I know this wrong, but I always avoid pacman -Syu because of the 500mb limit. I avoid any necessary upgrading, and only upgrade packages that need to be upgraded whenever I need to install a new package that I need. I know very well that this is the wrong thing to do, but seeing as I am limited to 500mb a month (which I already use alot of, if not all, on university stuff), I don't see how I could possibly carry out frequent system upgrades. Could anyone give me some advice? Should I not be using a rolling release distro because of this?
    Last edited by flyswatter (2010-06-05 19:31:54)

    @JackH79
    Hope it'll work out all right for you. Would be a shame to lose you to an 'enemy distros' , just because of bandwidth restrictions.
    Thank you. Don't worry, getting me off Arch is not gonna be easy
    @syn
    So is the public library's wifi off limits?
    hmm...getting to the public library would be troublesome. I doubt most public libraries here have wifi anyways The uni library, as well as the rest of campus, gives us access to internet via wifi, but it has a ridiculous 150mb cap. Luckily, downloads on the uni network are unlimited, and I have a good feeling the Arch mirror is on the uni network. I'll just have to wait and see.
    @mvdvarrier
    Thank you. I was thinking about using Slackware, and it really helps knowing that the updates are small. I feel that I have found the solution because of my uni's arch mirror, but if that and all other attempts to stick to Arch fails, I think that sounds like a great plan B Still gonna try my best to keep Arch, I haven't used many distro's (Ubuntu, slight tinkering on a Fedora based distro...and Puppy Linux, Slax Frodo and ttylinux if tiny live distros count), but I really do like Arch's way of doing things.
    Last edited by flyswatter (2009-12-09 16:51:39)

  • QoS - Bandwidth Control

    Hello Experts,
    we are using a couple of 4404 Controllers with software version 6.0.188.0. We would like to introduce the wifi and wired Portal to our custumers. During our testing period we discovered a little problem with the Bandwidth Control via QoS.
    These are our settings:
    Description...................................... For Portal (Background)
    Average Data Rate................................ 512
    Burst Data Rate.................................. 512
    Average Realtime Data Rate....................... 256
    Realtime Burst Data Rate......................... 256
    Maximum RF usage per AP (%)......................  50
    Queue Length.....................................  25
    protocol......................................... none
    If we download a file the bandwidth restriction works fine. We get a downstream about 62 kB/s. If we upload a file the bandwidth restricion seems not working. We get an upstream about 1660 kB/s.
    Are we missing something? Is there a setting to control the upstream behavior independent from downstream?
    Thanks a lot, best regards,
       Mathias, Michael

    The settings described are for over-the-air bandwidth. The Ap can only control downstream QoS or data that it sends. Upstream QoS will be handled by the client device and cannot be controlled by the Ap. The Ap cannot enforce QoS settings for upstream traffic.

  • Bandwidth allocation per vrf

    Hello,
    in my lab i have 3 sites each with 3 VRF's configured. A diagram ist attached. I like to configure fixed bandwidth for each vrf. the central vrf should have 768 kbps and the the other ones ones should have 256 kbps each.
    What are the options i have to achive this?
    Thanks a lot in advanced
    Alex

    Hi Alex
    Since you have already policed the bandwidth at the access, would there be any excess bandwidth that will leak from this policing.
    Besides, ideally you would configure your core with a standard llq+cbwfq config and give priority to voice. You will in production have multiple customers and you cant have sich a bandwidth restriction in place.
    Also, no you cannot police bw in core per vrf. But at the same time I can think of a non-conventional way of doing it by using TE but that is a very bad way of doing it.
    Sent from Cisco Technical Support Android App

  • How do I get to synchronise 3 videos of the same thing from 3 different Angles to play in a FLA and switch between them?

    Hi all,
    It's been a long time since I was on here... well here goes(I need a bit of technical help with a question if I may)
    This client of wants a flash video player of a model, modeling some clothes.
    They are going to set up 3 different cameras around her at the same time filming her - one from the front, one from the side and one from the back. Each clip lasts exactly 3mins and they are filming her at THE SAME TIME.
    Now after this, they want to put a FLASHPLAYER on their website with the video playing in a screen with 3 buttons underneath one saying FRONT VIEW, one saying SIDE VIEW AND one saying BACK VIEW. The three separate videos will be integrated in some way with this one flash file.
    The video player might start playing the FRONT VIEW first.
    BUT lets say 30 seconds into the clip I press the SIDE VIEW button the video switches to the side view on 30 seconds - The side view video doesn't play right from the start. Like I said before for example if the person is speaking and says "hello there", if you switch angle by clicking one of the buttons just at the point after she has said the word "hello", you switch to the angle where he is just about to say "there". If you see what I mean.
    As I said before there are 3 separate video clips:- FRONT VIEW, SIDE VIEW and BACK VIEW. Now I am not sure if these have to be embedded in the FLA file or can be contained in a separate folder on the server so that the SWF can access them. I am worry about streaming over the internet thats why I THINK Flash Media Server3 MIGHT be a solution BUT I don't know. BUT they must be seamless.
    AGAIN to reiterate...LETS say I am watching the SIDE view 30 seconds after the clip has started and the model starts scatching her head and then AT THAT POINT  I click the front view button below I see the model scratching her head from the front view at THAT precise moment.
    So all the videos seem to work at the same time to the casual viewer/user and it looks as though you are just switching views whenever you want.
    I have been looking all over the net to see if someone has produced a working example or if there is a tutorial somewhere but I have found NOTHING.
    I think there might be a problem pulling this one off as each video clip could be 4-5 MB in size and if they are streaming then there would be download problems and these videos might stop due to people with various bandwidth restrictions UNLESS all the videos were integrated into the flash library and were referenced from within by Actionscript but then the resultant SWF could be HUGE.
    I would really appreciate any help/suggestions here and any link to any working samples on the NET that I can download and disect at my leisure.
    BTW:-
    My email is [email protected]
    Cheers

    Use Flash Media Server to stream the files.......set up a timer and have all three of them play at once....and have a button switch the streams depending upon which stream you want to play.....and wallah......
    you can also capture the stream.time from the video playing and resume from that point on the other videos as well....havent done this theoretically so I dont know how smooth the transistion between streams will be....but it can be done....
    plus u may have to use double buffering techniques to make sure it starts up right away......
    thelegendaryghost

  • Is is possible to display KB Sent/sec on OLT Graphs?

    I know there is the data series for "KB Rcvd/sec" available on the standard OLT graphs, but is there an equivalent for SENT?
    Also is there a way of seeing the total packet/request size of a request in OpenScript? I'm particularly interested in a webservice request (I know the Post Data of a particularly bad example is around 21K).
    I suspect I'm hitting a bandwidth restriction on the actual requests (not the responses). At the moment I'm thinking of adding a PerfMon counter from the agent machine itself if nothing else comes to light.

    You might want to learn about .NET's Chart Control.  http://msdn.microsoft.com/en-us/library/dd489238%28v=vs.110%29.aspx

  • Lion is no longer available from the App Store, but I haven't gotten it yet.

    I purchased Lion from the App Store on October 27th, but then realized I could not download it yet due to bandwidth restrictions at school (though I did download it once, but the file corrupted and I went over the bandwidth limit, causing my Internet to be shut off).  So I'm finally home for Thanksgiving, and went to download again to install it this time.  However, the download is no longer available.  It doesn't show up as purchased, and when I tried to log in and download it, it wanted to charge me another $30.
    Is there any way that I can redownload this again without paying again?
    Thanks in advance,
    John Walsh

    Alright.  I resolved the problem.  In case anyone else has this issue, my copy of Lion got moved to 'hidden purchases'.  Unhiding it fixed the problem.

  • ASK THE EXPERTS:Branch Office Wireless Strategies

    With Jeevan Patil
    Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to ask how to consolidate your Wireless Branch Network Cisco subject matter expert Jeevan Patil. Mr. Jeevan Patil is a product manager for the Cisco Wireless Controller product portfolio. He has been involved with the wireless industry for over 12 years - since the first days of 802.11 becoming a standard through the evolution to 802.11n. Mr. Patil has been with Cisco for over 12 years. For the first 5 years he was a software engineer working on security, network management and wireless. In the past 7 years he has been the product manager on various initiatives such 802.11n standards, Access Points hardware, Client hardware, CCX, standalone (Autonomous) software, WLSE hardware and software and currently the product line manager on Wireless LAN Controllers.
    Remember to use the rating system to let Jeevan know if you have received an adequate response.  
    Jeevan might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the Other Wireless – Mobility Subjects discussion forum shortly after the event. This event lasts through August 12, 2011. Visit this forum often to view responses to your questions and the questions of other community members.

    Hi Nigel,
    Please take a look at the "WAN Requirements" section from the following Flex7500 deployment guide:
    http://www.cisco.com/en/US/products/ps11635/products_tech_note09186a0080b7f141.shtml
    It is highly recommended that the minimum bandwidth restriction remains 128 kbps with the round trip latency no greater than 300 ms for data deployments and 100 ms for data + voice deployments. The maximum transmission unit (MTU) must be at least 500 bytes.
    Deployment Type
    WAN Bandwidth (Min)
    WAN RTT Latency (Max)
    Max APs per Branch
    Max Clients per Branch
    Data
    128 kbps
    300 ms
    5
    25
    Data + Voice
    128 kbps
    100 ms
    5
    25
    Data
    128 kbps
    1 sec
    1
    1
    Monitor
    128 kbps
    2 sec
    5
    N/A
    Data
    1.44 Mbps
    300 ms
    50
    1000
    Data + Voice
    1.44 Mbps
    100 ms
    50
    1000
    Data
    1.44 Mbps
    1 sec
    50
    1000
    Monitor
    1.44 Mbps
    2 sec
    50
    N/A
    Best Regards,
    Jeevan

Maybe you are looking for

  • How to I get play count on my iphone to show up in itunes on new mac?

    I got a new macbook pro and downloaded the music from my other computer through homeshare. The play count on my phone would show up on the old computer but hasnt on the new mac even after syncing multiple times. I want the play count from the old com

  • Printing  a .pdf file by javascript?

    Is it possible to print a .pdf  file  by javascript function or Adobe javascript and how ? I hope that one expert can share me a sample javascript function. Thank you very much in advance.

  • Debit/Credit memo

    I am confused whenever i come across the term Debit/credit.... here in MM point of view where we use this Debit memo and credit memo.. I am new to this pls tell me the following steps how to do that debit/credit memo..

  • IPhoto 08 HELP!!!!

    I just upgraded my computer with iLife 08 and I love the new changes. So far my only problem happened in the iPhoto application. When I tried to upload a photo from my iPhoto library none of my photos were available for upload. I was trying to put ne

  • A simple project

    Hi All, I need to do a simple project like 1.Using DBMS_JOB package read some data from the table and output the result into a flat file at definite intervals. 2.Now submit another dbms_job to read that flat file and store the contents into another t