BGP decision algorithm nitty-gritty (relationship of locally originated routes to weight attribute)

Hello everyone, i have a question on this algorithm. Specifically the relationship between (cisco specific) WEIGHT which is right at the top of the path selection algorithm.... and routes that are ORIGINATED_LOCALLY (3rd one down, after weight and local_pref). 
Heres the relevant steps of the decision tree: 
   1/WEIGHT (highest wins)
   2/LOCAL_PREF (highest wins) 
   3/ORIGINATED LOCALLY (prefer locally originated over peer learnt) 
Whats confusing to me is that Jeff's book tells us that if a prefix is ORIGINATED_LOCALLY (ie entered into BGP on that same router - either by a network/aggregate-address statement, or from redistribution) then its WEIGHT will also be set to 32768 (as opposed to a BGP peer learnt route whose WEIGHT is set to 0). I understand this. 
My question is why??? Seems to me that if this is the case there is little purpose of having ORIGINATED_LOCALLY in the decision tree at all, as the logic will never get there on account of the the propagation of its value into (the higher up) WEIGHT decision. This also in turn means that ORIGINATED_LOCALLY has the power to override the attribute LOCAL_PREF.... so couldn't this whole logic be simplified to be: 
   1/WEIGHT or ORIGINATED LOCALLY
   2/LOCAL_PREF (highest wins) 
This very thing has confused another user on another post too, that user writes:  "I tried thinking of an example where "ORIGINATED LOCALLY" works but weight doesn't, but couldn't think of any."
looking forward to the thoughts of this community.
Thanks in advance, Keiran. 
PS> perhaps the attached diagram will help visualise this. 

Thanks for your reply shaikhkamran123, i hadn't considered the multivendor environment (where cisco specific concept of 'weight' would be irrelevant to those routers), so yes their decision would start with: 
1) Local Preference
2) Locally originated
as opposed to cisco
   1/WEIGHT (highest wins)
   2/LOCAL_PREF (highest wins) 
   3/ORIGINATED LOCALLY (prefer locally originated over peer learnt) 
but it still doesn't really explain why cisco chose to alter their inbuilt weight based on if a route was locally originated. This alters the logic of the above decision algorithm: ie if its locally originated, it will set a high weight (32768), which will be preferred.... and heres the main thing *BEFORE* local_pref is even looked at.  So in other words decision criteria#3, gets merged into #1, skipping ahead of #2.  Am i going crazy here?? 
thanks in advance all... 
K. 

Similar Messages

  • BGP decision algorithm - help needed - stumped

    Hello gurus!  hoping for a BGP expert to chime in here. Im studying for my CCIE, and there is something in Jeff Doyle's Routing TCP/IP vol2 book that I just cant seem to figure out and its really stalling my understanding of the BGP path selection algorithm.  
    Its on pg 195, example 3-57, attached as an image in this post (Ive also attached the network diagram that this output refers to). Basically its an output of "show ip bgp" and whats stumping me is simply: for the aggregate route 192.168.192.0/21, why has this router selected as best (>) the one via next hop 192.168.1.254?? I would have thought based on the presence of the LocalPref = 100 on the 192.168.1.237 route that would have been selected.  But apparently not! Heres a walk through of the path selection logic as i understand it:
    1/WEIGHT: both 0, so skipped. 
    2/LOCAL_PREF: this is my problem, .237 should win, but ignoring for now...
    3/ORIGINATED LOCALLY: neither are they are learnt from BGP peers, so skipping.
    4/AS_PATH: both identical, AS100 only, so skipping
    5/ORIGIN CODE: both are 'i' (IGP), both were created from "aggregate-address" statements on their originating routers downstream in AS100
    6/MED: both empty, so skipping
    7/PREFER [eBGP] over [confedBGP] over iBGP: so the .254 route apparently wins on this condition... which in isolation, i agree with (clearly the eBGP .254 route is better than the .237 iBGP candidate).
    .... however what about step 2/LOCAL_PREF!?  
    looking forward to some expert guidance here to help me squash this one :) 
    thank in advance, 
    Keiran

    Hello,
    Keiran are you talking about "Orgin" attribute or ORIGINATED LOCALLY as this attribute i am not able to find it...that attribute anywhere:
    http://netcerts.net/bgp-path-attributes-and-the-decision-process/
    Path Attributes:
    Attribute
    Class
    ORIGIN
    Well-know mandatory
    AS_PATH
    Well-know mandatory
    NEXT_HOP
    Well-know mandatory
    LOCAL_PREF
    Well-know discretionary
    ATOMIC_AGGREGATE
    Well-know discretionary
    AGGREGATOR
    Optional transitive
    COMMUNITY
    Optional transitive
    MULTI_EXIT_DISC (MED)
    Optional nontransitive
    ORGINATOR_ID
    Optional nontransitive
    ORGINATOR_ID
    Optional nontransitive
    CLUSTER_LIST
    Optional nontransitive
    Also there is similar question on learning forums:
    https://learningnetwork.cisco.com/thread/36845
    From the forum:
    "Locally Originated means that the local router is the one that generated the route with either a network statement, and aggregate statement, redistribution, or conditional route injection.  It's not an attribute that is included in the UPDATE messge, instead it's just used by the local process as part of the path selection, where the router will prefer its own locally originated routes over someone else's origination of the same prefix."
    Hopefully this will help.
    BTW i am reading same book and too bad Mr. Doyle did not include full configs for all routers, as i am trying to simulate his scenarios sometimes it is not working as in his book, now i have issue on next page 197 why Orgin IGP is not taking precedence over Incomplete even if one is learned via EBGP and other over iBGP...driving me nuts.
    Regards,
    Lukasz

  • Local policy route-map for policy route

    Hi 
    this is related my previous question:
    I want to set policy route on asr1004, that redirect vpn traffic. 
    my case is:
      asr1004 import a default route 0.0.0.0 from int 0 with bgp neibour address 10.100.100.100
    assume internal traffic 10.10.10.0/24 coming into asr1004 on int 1.
    assume vpn with ip address 10.2.2.2 is direct linked to asr1004 int 2, and int 2 ip address is 10.2.2.1
    assume taget network is 10.200.200.0/24
    I want internal traffic (10.10.10.0/24) go to target (10.200.200.0/24)  to be redirect to10.2.2.2 (vpn)  first, so I add  "ip route 10.200.200.0/24 10.2.2.2" on asr1004.
    Than, I want vpn (10.2.2.2) encrypt traffic and send it to one of ip in10.200.200.0/24 range again. at this point if I put local policy route-map below, is it will work?
    ip local policy route-map vpn-out
    access-list 100 permit ip 10.2.2.2 any
    route-map vpn-out permit 10
      match ip address 100
      set ip next-hop 10.100.100.100
    if not, do I have any change to do policy route for this case?
    any comment will be appreciated
    Thanks in advance
    Julxu

    hi Jon
    can I refresh the question again:
    my case is:
      asr1004 import a default route 0.0.0.0 from int 0 with bgp neibour address 10.100.100.100
    assume internal traffic 10.10.0.0/16 coming into asr1004 on int 1 with ip address 10.3.3.3
    assume vpn with ip address 10.10.2.2 is direct linked to asr1004 int 2, and int 2 ip address is 10.10.2.1
    assume taget network is 10.200.200.0/24
    I want internal traffic (10.10.0.0/16) go to target (10.200.200.0/24)  to be redirect to10.10.2.2 (vpn)  first, so I add  "ip route 10.200.200.0/24 10.10.2.2" on asr1004.
    Than, I want vpn (10.10.2.2) encrypt traffic and send it to one of ip in10.200.200.0/24 range again. at this point if I put local policy route-map below, is it will work?
    ip local policy route-map vpn-out
    access-list 100 permit ip 10.10.2.2 any
    route-map vpn-out permit 10
      match ip address 100
      set ip next-hop 10.100.100.100
    such as:
    interface TenGigabitEthernet0/0/0
     description bgp to get default
     ip address 10.100.100.100 255.255.255.252
     no ip redirects
     no ip unreachables
     no ip proxy-arp
    interface TenGigabitEthernet0/1/0
     description get internaltraffic
     ip address 10.3.3.3 255.255.255.0
     no ip redirects
     no ip unreachables
     no ip proxy-arp
    interface GigabitEthernet0/2/1
     description vpn
     ip address 10.10.2.1 255.255.255.248
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     media-type rj45
     negotiation auto
    ip local policy route-map vpn-out
    access-list 100 permit ip 10.10.2.2 any
    route-map vpn-out permit 10
      match ip address 100
      set ip next-hop 10.100.100.100
    ip route 10.200.200.0/24 10.10.2.2
    Could you please advise if it is correct?

  • PBR for a locally configured router IP address

    Hello community !
    I am trying to perform a very specific thing.
    I would like to perform a PBR for a subnet range located remotely. However one of the IP of this subnet is configured locally on the router (interface IP @) !
    I know that PBR takes precedence on a directly connected subnet, but what about if I want to perform PBR redirection for one of the IP directly configured on the router ?
    If you take a look on the network diagram, I can perform PBR and reach the IP 10.10.10.2 and 10.10.10.3, but the PbR does not work for 10.10.10.1 (loal IP @).
    I tried with 'set ip next-hop' and 'set interface' but no luck => The router (C881-K9 - 15.2.4M6a) handles the packet and answers anyway.
    If you have any idea or suggestion feel free to answer !
    Thanks in advance.
    Oliv.

    John, thanks for your inputs.
    Indeed I understand what you say. In fact the reason is simple : An error occured on subnets allocation.
    An already used range (subnets used to address some specific GRE tunnel interfaces on multiple routers [subnet in Orange on the diagram]) has been implemented elsewhere in a DC.
    PBR works well and overrides the routing table for this directly connected subnet except for the locally configured IP @ (and I perfectly understand why the router answers on its IP).
    This is problematic when a station from the LAN wants to communicate with a resource in the DC which is already used (interface detail).
    I understand the simplest solution would be to re-address but it is too much heavy at the time being.
    Any suggestion regarding this local host route overriding would be appricated !
    Thanks !

  • BGP Weight Attribute

    Guys,
    I just need some clarification on the use of the bgp weight attribute. Let us say I have this setup. If both R1 and R2 are receiving the same set of routes from R3-R6, can I use weight attribute to influence the received routes so that R1 will have the best routes? Does weight works on different AS?

    Absolutely. Cisco Freak and Jon Marshall are correct.
    Also, you cannot compare between BGP attributes if R1 and R2 are not BGP peers. If you want to take complete control of routes being advertised by R3, R4, R5 and R6, you would be in better position if you  run iBGP between R1 and R2.
    Once BGP starts to run between R1 and R2,  they both will get information about routes advertised by R3, R4, R5 and R6 and you will be able to reap many benefits of BGP protocol. 
    Peace and health,
    Ravindra

  • Windows 7: Trust Relationship Error - Local Administrator Account Locked.

    I have 2 Windows 7 Professional machines that recently locked me out citing the "Trust Relationship between this workstation and primary domain failed".
     I assumed all I would have to do is log in as local administrator and remove it from the domain and then re-add it.  When I tried to log on, it told me that I have the password was incorrect - which I knew it wasn't.  After a
    few tries I got a different message that said that the account was locked.  No idea how this could have happened.  Every other local account was locked as well.
    I checked the AD on our 2003 server and I didn't see anything out of the norm.  The computers were in the correct OU, and were not disabled in anyway.  I searched online for a solution, but they all required me to be able to log on to the local
    admin, which is disabled.  
    I tried to boot to Safe Mode with a Command Prompt and typed in: net user administrator /active:yes .
     It told me that the change had been made, but when I reboot it still shows the local account as disabled.
    Any suggestions would be greatly appreciated.  
    Edit: It is Windows 7 Professional x64 

    I have had this issue twice as well. However I have been always been able to log in with local admin rights. removing then rejoining to domain seems to never get things back to normal for me. Once it is reset and joined back to the domain all software just
    seems to be missing but still there at the same time. Like Antivirus shows its installed in c:\program files but its not running. If I go to domain users start menu everything is missing but go into c:\program files and its all there. So every time I have
    seen this error a reimage is what I do seems to work a lot better than dealing with the head aches. Sorry I was not any help but that is my two cents.

  • CRS, IOS-XR: local IGP route not installed in BGP table when learned from RR

    Hello,
    We use CRS routers in our IGP/BGP network core, some of which are acting as BGP originators and reflectors (RRs) for IPv4 unicast. We also use CRS routers as Internet PEs. The problem we have is between those PEs and the core routers.
    Premise: each Internet PE is terminating customer cisrcuits and injects those downstream routes in IGP (via redistributing static, or just learned via IGP from a downstream router). The core (P) routers then learn those routes from the PE via the IGP. Two of the P-routers act as BGP originators and install the necessary routes in BGP using the network statement. These routes are mostly supernets (i.e. summarized), but some coincide with IGP routes, as learned from the PEs. The P-routers acting as RRs then reflect all iBGP routes to all IPv4 unicast BGP speakers in the network, including the Internet PEs (we also have BGP peers on those PEs, which is why this is necessary).
    Problem: if a specific downstream route, learned on an Internet PE via IGP (i.e. from downstream), is then received by that PE from an RR via iBGP (i.e. from upstream), the route is not installed in the BGP table (the output of the show bgp x.x.x.x/xx command is: Network not in table)
    Question: does anyone know why this is happening? This is concictent on all of our CRS PEs. As far as I am aware there is no BGP rule that would explain this behavior. We don't expect the PE to prefer the iBGP route over the IGP route, but that should not prevent it from learning it and installing it in the BGP table... The only discrepancy I could think of is that the IGP route has a next-hop pointing downstream, whereas the the same route, learned over iBGP has a next-hop pointing upstream. Then again,this shouldn't prevent the route to appear in the BGP table....
    Your help would be appreciated!
    Thanks!

    Hi !
    If I am understandung you correctly then Split Horizon is the keyword
    Because if the route is learned from downstream BGP drops any same path information learned from upstream
    SPLIT-HORIZON only applies to distance-vector routing protocols.  In case of BGP,  it simply means that a prefix learned via a peer is not advertised back  to that peer.
    Split horizon will simply block out routes with the same neighbor as the next-hop for the router
    regards
    alexander

  • Need nitty-gritty help uninstalling

    My computer crashed during an iTunes upgrade... so then, I've got a/some critical file(s) missing. ITunes can't run w/o the file(s), can't uninstall (using the Windows uninstaller) without the file(s), and can't re-install because it detects a previous, undeleteable installed version.
    I want to get all remaining traces of iTunes off of my computer so that I can, well, install iTunes.
    Help? Please? I don't want to have to completely wipe my drive and reinstall everything to expunge all traces of this thing.

    Hey Kimberly Stedman,
    Try going through the steps in this article to resolve:
    http://docs.info.apple.com/article.html?artnum=93976
    There is a step to assist in "Clean up iTunes installer files on the computer" that is important to try.
    Hope this helps,
    Generik
    PowerMac G4/Dell Precision WS 370, XP Pro   Mac OS X (10.4.7)  

  • Nitty Gritty

    Okay, after carefully inspecting my logic board, I found that the previous owner had blown a power management chip (it was literally burned). I have scouted the internet and found a replacement for it, but there is now another issue. At location C383, there appears to be a part missing. I believe it is probably a capacitor. With this all in mind, I was wondering if anyone would know where I can find a schematic for the iBook Dual USB logic board, or at least a part list by board location. I know it's a pretty tricky thing to find, as I have been looking for days, but I was wondering if any of you would be able to help me. Oh, and I realize that my iBook is out of warranty, so that is why I'm doing all this work by myself.
    Thanks for your help!!!
    -Marty

    If you look on the logic board (from the bottom of the laptop) you can see where the DC board connects with the wire ribbon to the logic board. C383 is about a half an inch down and to the right (if the CD-ROM drive is up) from this connection. I appreciate the help!

  • BGP Community | Route-Map | Local Pref

    While labbing today I've ran into some strange behavior with BGP communities/route-map processing. Basically the objective was from R9, send a community for the 172.30.79.0/27 route out to R7 to 65100:90 AND send a community for the 172.30.89.0/27 route out to R8 to 65100:110. Then on R9 match community 65100:90 and set the local-pref to 90 and 65100:110 to local-pref of 110. Should be easy enough but the behavior that i'm seeing is that all is working on R7 but not on R8. The R8 inbound route-map is watching the community but not setting the local-pref for some reason... Any ideas? See below.
    Topology
    ##R9’s BGP/Route-map config setting communities for the two routes out to R7 & R8##
    R9#sh run  | s bgp|route-map
    router bgp 65100
     network 172.30.79.0 mask 255.255.255.224
     network 172.30.89.0 mask 255.255.255.224
     network 192.122.3.9 mask 255.255.255.255
     neighbor 172.30.79.7 remote-as 65006
     neighbor 172.30.79.7 send-community both
     neighbor 172.30.79.7 route-map R7-OUT out
     neighbor 172.30.89.8 remote-as 65006
     neighbor 172.30.89.8 send-community both
     neighbor 172.30.89.8 route-map R8-OUT out
    ip bgp-community new-format
    route-map R7-OUT permit 10
     match ip address prefix-list 172.30.79.0/27
     set community 65100:90
    route-map R7-OUT permit 20
    route-map R8-OUT permit 10
     match ip address prefix-list 172.30.89.0/27
     set community 65100:110
    route-map R8-OUT permit 20
    ##R7’s config##
    R7#sh run | s bgp|route-map
    router bgp 65006
     address-family ipv4 vrf VPN
      neighbor 172.30.79.9 remote-as 65100
      neighbor 172.30.79.9 activate
      neighbor 172.30.79.9 send-community both
      neighbor 172.30.79.9 as-override
      neighbor 172.30.79.9 route-map R9-IN in
    route-map R9-IN permit 10
     match community 65100:90
     set local-preference 90
    route-map R9-IN permit 20
    ##R7’s ‘show bgp’##
    R7#sh ip bgp vpnv4 vrf VPN | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65066:700 (default for vrf VPN)
     r>  172.30.79.0/27   172.30.79.9           90              0 65100 i
     *>  172.30.89.0/27   172.30.79.9              0             0 65100 i
     *>  192.122.3.9/32   172.30.79.9              0             0 65100 i
    ##R8’s config##
    router bgp 65006
     address-family ipv4 vrf VPN
      neighbor 172.30.89.9 remote-as 65100
      neighbor 172.30.89.9 activate
      neighbor 172.30.89.9 send-community both
      neighbor 172.30.89.9 as-override
      neighbor 172.30.89.9 route-map R9-INv2 in
    route-map R9-INv2 permit 10
     match community 65100:110
     set local-preference 110
    route-map R9-INv2 permit 20
    ##R8’s ‘show bgp’##
    R8#sh ip bgp vpnv4 vrf VPN | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65006:800 (default for vrf VPN)
     *>  172.30.79.0/27   172.30.89.9              0             0 65100 i
     r>  172.30.89.0/27   172.30.89.9              0             0 65100 i
     *>  192.122.3.9/32   172.30.89.9              0             0 65100 i
    R8#sh ip bgp vpnv4 vrf VPN community | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65006:800 (default for vrf VPN)
     r>  172.30.89.0/27   172.30.89.9              0             0 65100 i
    R8#sh ip bgp vpnv4 vrf VPN 172.30.89.0/27         
    BGP routing table entry for 65006:800:172.30.89.0/27, version 77
    Paths: (1 available, best #1, table VPN, RIB-failure(17))
      Not advertised to any peer
      Refresh Epoch 2
      65100
        172.30.89.9 from 172.30.89.9 (192.122.3.9)
          Origin IGP, metric 0, localpref 100, valid, external, best
          Community: 65100:110
          Extended Community: RT:910:910
          mpls labels in/out 45/nolabel
          rx pathid: 0, tx pathid: 0x0

    While labbing today I've ran into some strange behavior with BGP communities/route-map processing. Basically the objective was from R9, send a community for the 172.30.79.0/27 route out to R7 to 65100:90 AND send a community for the 172.30.89.0/27 route out to R8 to 65100:110. Then on R9 match community 65100:90 and set the local-pref to 90 and 65100:110 to local-pref of 110. Should be easy enough but the behavior that i'm seeing is that all is working on R7 but not on R8. The R8 inbound route-map is watching the community but not setting the local-pref for some reason... Any ideas? See below.
    Topology
    ##R9’s BGP/Route-map config setting communities for the two routes out to R7 & R8##
    R9#sh run  | s bgp|route-map
    router bgp 65100
     network 172.30.79.0 mask 255.255.255.224
     network 172.30.89.0 mask 255.255.255.224
     network 192.122.3.9 mask 255.255.255.255
     neighbor 172.30.79.7 remote-as 65006
     neighbor 172.30.79.7 send-community both
     neighbor 172.30.79.7 route-map R7-OUT out
     neighbor 172.30.89.8 remote-as 65006
     neighbor 172.30.89.8 send-community both
     neighbor 172.30.89.8 route-map R8-OUT out
    ip bgp-community new-format
    route-map R7-OUT permit 10
     match ip address prefix-list 172.30.79.0/27
     set community 65100:90
    route-map R7-OUT permit 20
    route-map R8-OUT permit 10
     match ip address prefix-list 172.30.89.0/27
     set community 65100:110
    route-map R8-OUT permit 20
    ##R7’s config##
    R7#sh run | s bgp|route-map
    router bgp 65006
     address-family ipv4 vrf VPN
      neighbor 172.30.79.9 remote-as 65100
      neighbor 172.30.79.9 activate
      neighbor 172.30.79.9 send-community both
      neighbor 172.30.79.9 as-override
      neighbor 172.30.79.9 route-map R9-IN in
    route-map R9-IN permit 10
     match community 65100:90
     set local-preference 90
    route-map R9-IN permit 20
    ##R7’s ‘show bgp’##
    R7#sh ip bgp vpnv4 vrf VPN | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65066:700 (default for vrf VPN)
     r>  172.30.79.0/27   172.30.79.9           90              0 65100 i
     *>  172.30.89.0/27   172.30.79.9              0             0 65100 i
     *>  192.122.3.9/32   172.30.79.9              0             0 65100 i
    ##R8’s config##
    router bgp 65006
     address-family ipv4 vrf VPN
      neighbor 172.30.89.9 remote-as 65100
      neighbor 172.30.89.9 activate
      neighbor 172.30.89.9 send-community both
      neighbor 172.30.89.9 as-override
      neighbor 172.30.89.9 route-map R9-INv2 in
    route-map R9-INv2 permit 10
     match community 65100:110
     set local-preference 110
    route-map R9-INv2 permit 20
    ##R8’s ‘show bgp’##
    R8#sh ip bgp vpnv4 vrf VPN | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65006:800 (default for vrf VPN)
     *>  172.30.79.0/27   172.30.89.9              0             0 65100 i
     r>  172.30.89.0/27   172.30.89.9              0             0 65100 i
     *>  192.122.3.9/32   172.30.89.9              0             0 65100 i
    R8#sh ip bgp vpnv4 vrf VPN community | b Network
         Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 65006:800 (default for vrf VPN)
     r>  172.30.89.0/27   172.30.89.9              0             0 65100 i
    R8#sh ip bgp vpnv4 vrf VPN 172.30.89.0/27         
    BGP routing table entry for 65006:800:172.30.89.0/27, version 77
    Paths: (1 available, best #1, table VPN, RIB-failure(17))
      Not advertised to any peer
      Refresh Epoch 2
      65100
        172.30.89.9 from 172.30.89.9 (192.122.3.9)
          Origin IGP, metric 0, localpref 100, valid, external, best
          Community: 65100:110
          Extended Community: RT:910:910
          mpls labels in/out 45/nolabel
          rx pathid: 0, tx pathid: 0x0

  • BGP RIB

    I am learning advance bgp ....having query :
    BGP uses different types of routing table..i.e 1) adj-rib-in (unprocessed routes which are received from neighbors)
    2) adj-rib-out (routes which are sent by router to its neighbors)
    3) local bgp table: (remained routes after process on adj-rib-in & rib-out) Best routes from local bgp table is forwarded to ip bgp talbe...
    Q1. is it right??
    Q2. how can i see these three table separately... is there any command to see only adj-rib-in or rib-out etc ??
    Q3. Is there any concern of command
           show ip bgp neighbors [address] advertised-routes
           show ip bgp neighbors [address] received-routes
           show ip bgp rib-failure
    S@ndy...

    Hi S@ndy,
    Ad Q1: Almost correct. I believe that looking into RFC 4271 is worth a try, and the RFC puts it very nicely:
    Adj-RIB-In
    The Adj-RIBs-In contains unprocessed routing information that has
    been advertised to the local BGP speaker by its peers.
    Adj-RIB-Out
    The Adj-RIBs-Out contains the routes for advertisement to specific
    peers by means of the local speaker's UPDATE messages.
    Loc-RIB
    The Loc-RIB contains the routes that have been selected by the
    local BGP speaker's Decision Process.
    In particular, the Loc-RIB are not "the remaining" routes but simply routes that have been selected from Adj-RIB-In and locally injected routes as the best paths. These routes would be attempted to be installed into the router's routing table and would also be candidates for advertisement to other BGP peers.
    Ad Q2: To see what routes have been received from a particular neighbor (Adj-RIB-In), use show ip bgp neighbor X.X.X.X routes. To see what routes have been sent to a particular neighbor (Adj-RIB-Out), use show ip bgp neighbor X.X.X.X advertised-routes. I am not sure if there is a command to display the Loc-RIB; I do not know of any.
    Ad Q3: The advertised-routes shows the Adj-RIB-Out for the neighbor. The received-routes is relevant to a deprecated feature called Soft Reconfiguration that is beyond the topic of this discussion. The rib-failure shows you a set of routes from Loc-RIB that could not be installed into the router's routing table, if there are any. Most often, this is caused by the same network being already present in the routing table with a better administrative distance.
    Best regards,
    Peter

  • BGP load balance

    We are big ISP, and we are peering ebgp with several International ISPs for inetrnet connectivity. My question is how to load balance between the several ISPs, I mean based on what?, we need to make sure to load balance in both ways.

    Hi,
    usually load balancing has two parts:
    1) local traffic to the internet
    2) return traffic from the internet
    As we are talking about BGP any mechanism influencing path selection can be used to load balance local traffic.
    Basically you send traffic towards some destinations through one peering point and some traffic to other destinations through other peering points. Local Preference could be a good way to achieve this.
    Be aware that you need some traffic analysis in order to influence the local traffic in the desired way.
    Regarding option 2):
    We are talking about BGP and what you want is to influence the routing decisions of other ASes. Bad news: there is no way to make SURE it will happen the way you want this to happen. They are AUTONOMOUS and therefore can also use f.e. LocPref to achieve their goals. Those might contradict yours.
    But from a technical point of view the BGP updates you send should contain "hints" as to where the return traffic should be sent. As anything can be stripped of a BGP update except well-known mandatory attributes (origin, next-hop, AS path) usually AS path prepending is the measure to make return traffic for one of your prefixes prefer one way. And traffic for other prefixes you own another way.
    Also be aware that BGP in itself was not built for Load sharing per prefix, because every BGP speaker will only announce the best path per prefix. So even in the neighbor AS after a route-reflector all BGP speakers will only learn ONE path to your AS per prefix.
    Hope this helps
    Martin
    P.S.: Do not prepend too many ASes and do not split your IP address space in to many small junks. Also look at RIPE document 229, which talks about route flap dampening ... larger prefixes are always better.

  • Weblogic-cmp-rdbms-jar.xml for One-To-Many unidirectional relationship

    hi,
    I am trying to create a simple cmp One-To-Many unidirectional relationship and deploy the same in weblogic. Can someone help me with the weblogic-cmp-rdbms-jar.xml. Am attaching the weblogic-cmp-rdbms-jar. xml tht i am using as also the corresponding ejb-jar.xml. Pls. note tht i want a unidirectional relationship here. one i am tryng However i get this error:
    Error while reading 'META-INF/weblogic-cmp-rdbms-jar.xml'. The error was: Role 'Supplier supplies Products' of relationship 'Product Supplier' contains an invalid key-column value of 'productID'. The key-column must specify a primary key column in the related bean. However, there is no primary key column named 'productID' defined in the related bean 'ProductEJB' or else 'productID' is not being recognized due to case mismatch. My weblogic-cmp-rdbms-jar
    <?xml version="1.0"?>
    <!DOCTYPE weblogic-rdbms-jar PUBLIC '-//BEA Systems, Inc.//DTD WebLogic 8.1.0 EJB RDBMS Persistence//EN' 'http://www.bea.com/servers/wls810/dtd/weblogic-rdbms-jar.dtd'>
    <weblogic-rdbms-jar>
    <weblogic-rdbms-bean>
         <ejb-name>SupplierEJB</ejb-name>
         <data-source-name>RJDataSource</data-source-name>
         <table-map>
               <table-name>AA_Supplier</table-name>
               <field-map>
                     <cmp-field>supplierID</cmp-field>
                     <dbms-column>supplierID</dbms-column>
               </field-map>
               <field-map>
                    <cmp-field>name</cmp-field>
                    <dbms-column>name</dbms-column>
               </field-map>
         </table-map>
    </weblogic-rdbms-bean>
    <weblogic-rdbms-bean>
           <ejb-name>ProductEJB</ejb-name>
           <data-source-name>RJDataSource</data-source-name>
           <table-map>
                 <table-name>AA_Product</table-name>
                 <field-map>
                      <cmp-field>productID</cmp-field>
                      <dbms-column>productid</dbms-column>
                 </field-map>
                 <field-map>
                      <cmp-field>description</cmp-field>
                      <dbms-column>description</dbms-column>
                 </field-map>
                 <field-map>
                      <cmp-field>basePrice</cmp-field>
                      <dbms-column>baseprice</dbms-column>
                 </field-map>
                <field-map>
                      <cmp-field>name</cmp-field>
                      <dbms-column>name</dbms-column>
                 </field-map>
                 <field-map>
                     <cmp-field>supplierID</cmp-field>
                       <dbms-column>supplierID</dbms-column>
                 </field-map>
            </table-map>
    </weblogic-rdbms-bean>
    <weblogic-rdbms-relation>
         <relation-name>Product Supplier</relation-name>
         <weblogic-relationship-role>
              <relationship-role-name>Supplier supplies Products</relationship-role-name>
              <relationship-role-map>
                   <column-map>
                        <foreign-key-column>supplierID</foreign-key-column>
                        <key-column>productID</key-column>
                   </column-map>
              </relationship-role-map>
         </weblogic-relationship-role>
         <weblogic-relationship-role>
              <relationship-role-name>Product supplied by Supplier</relationship-role-name>
              <relationship-role-map>
              <column-map>
                   <foreign-key-column>products</foreign-key-column>
                   <key-column>supplierID</key-column>
              </column-map>
              </relationship-role-map>
         </weblogic-relationship-role>
    </weblogic-rdbms-relation>
    </weblogic-rdbms-jar> My ejb-jar.xml
    <?xml version="1.0"?>
    <!DOCTYPE ejb-jar PUBLIC '-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN' 'http://java.sun.com/dtd/ejb-jar_2_0.dtd'>
    <ejb-jar>
         <enterprise-beans>
         <entity>
              <ejb-name>SupplierEJB</ejb-name>
              <home>com.tpt.practice.entityBeans.cmp.product.relationship.SupplierHome</home>
              <remote>com.tpt.practice.entityBeans.cmp.product.relationship.Supplier</remote>
              <ejb-class>com.tpt.practice.entityBeans.cmp.product.relationship.SupplierEJB</ejb-class>
              <persistence-type>Container</persistence-type>
              <prim-key-class>java.lang.String</prim-key-class>
              <reentrant>False</reentrant>
              <cmp-version>2.x</cmp-version>
              <abstract-schema-name>AA_Supplier</abstract-schema-name>
              <cmp-field>
                   <field-name>supplierID</field-name>
              </cmp-field>
              <cmp-field>
                   <field-name>name</field-name>
              </cmp-field>
              <primkey-field>supplierID</primkey-field>
              <ejb-ref>
                        <ejb-ref-name>ProducEJB</ejb-ref-name>
                        <ejb-ref-type>Entity</ejb-ref-type>
                        <home>com.tpt.practice.entityBeans.cmp.product.ProductHome</home>
                        <remote>com.tpt.practice.entityBeans.cmp.product.Product</remote>
                        <ejb-link>ProductEJB#ProductEJB.jar</ejb-link>
              </ejb-ref>
              <query>
                   <query-method>
                        <method-name>findByName</method-name>
                        <method-params>
                             <method-param>java.lang.String</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Supplier AS a WHERE a.name =
                        ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findAllSuppliers</method-name>
                        <method-params>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Supplier AS a WHERE a.supplierID
                        IS NOT NULL]]>
                   </ejb-ql>
              </query>
         </entity>
         <entity>
              <ejb-name>ProductEJB</ejb-name>
              <home>com.tpt.practice.entityBeans.cmp.product.relationship.ProductHome</home>
              <remote>com.tpt.practice.entityBeans.cmp.product.relationship.Product</remote>
              <local-home>com.tpt.practice.entityBeans.cmp.product.relationship.ProductLocalHome</local-home>
              <local>com.tpt.practice.entityBeans.cmp.product.relationship.ProductLocal</local>
              <ejb-class>com.tpt.practice.entityBeans.cmp.product.relationship.ProductEJB</ejb-class>
              <persistence-type>Container</persistence-type>
              <prim-key-class>com.tpt.practice.entityBeans.cmp.product.relationship.ProductPK</prim-key-class>
              <reentrant>False</reentrant>
              <cmp-version>2.x</cmp-version>
              <abstract-schema-name>AA_Product</abstract-schema-name>
              <cmp-field>
                   <field-name>productID</field-name>
              </cmp-field>
              <cmp-field>
                   <field-name>name</field-name>
              </cmp-field>
              <cmp-field>
                   <field-name>description</field-name>
              </cmp-field>
              <cmp-field>
                   <field-name>basePrice</field-name>
              </cmp-field>
              <cmp-field>
                   <field-name>supplierID</field-name>
              </cmp-field>
              <primkey-field>productID</primkey-field>
              <query>
                   <query-method>
                        <method-name>findByName</method-name>
                        <method-params>
                             <method-param>java.lang.String</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.name =
                        ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findByDescription</method-name>
                        <method-params>
                             <method-param>java.lang.String</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.description
                        = ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findByBasePrice</method-name>
                        <method-params>
                             <method-param>double</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.basePrice =
                        ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findExpensiveProducts</method-name>
                        <method-params>
                             <method-param>double</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.basePrice >
                        ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findCheapProducts</method-name>
                        <method-params>
                             <method-param>double</method-param>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.basePrice <
                        ?1]]>
                   </ejb-ql>
              </query>
              <query>
                   <query-method>
                        <method-name>findAllProducts</method-name>
                        <method-params>
                        </method-params>
                   </query-method>
                   <ejb-ql>
                        <![CDATA[SELECT OBJECT(a) FROM AA_Product AS a WHERE a.productID
                        IS NOT NULL]]>
                   </ejb-ql>
              </query>
         </entity>
         </enterprise-beans>
         <relationships>
         <ejb-relation>
              <ejb-relation-name>Product Supplier</ejb-relation-name>
              <ejb-relationship-role>
                   <ejb-relationship-role-name>Supplier supplies Products</ejb-relationship-role-name>
                   <multiplicity>One</multiplicity>
                   <relationship-role-source>
                        <ejb-name>SupplierEJB</ejb-name>
                   </relationship-role-source>
                   <cmr-field>
                        <cmr-field-name>products</cmr-field-name>
                        <cmr-field-type>java.util.Collection</cmr-field-type>
                   </cmr-field>
              </ejb-relationship-role>
              <ejb-relationship-role>
                   <ejb-relationship-role-name>Product supplied by Supplier</ejb-relationship-role-name>
                   <multiplicity>Many</multiplicity>
                   <relationship-role-source>
                        <ejb-name>ProductEJB</ejb-name>
                   </relationship-role-source>
              </ejb-relationship-role>
         </ejb-relation>
         </relationships>
         <assembly-descriptor>
              <container-transaction>
              <method>
                   <ejb-name>SupplierEJB</ejb-name>
                   <method-intf>Remote</method-intf>
                   <method-name>*</method-name>
              </method>
              <trans-attribute>Required</trans-attribute>
              </container-transaction>
         </assembly-descriptor>
    </ejb-jar>

    I think u r some confusion with productID and SuppliedID . primary key of one column( productId ) can be a foreign key of other table colum( SuppliedID). but foreign key( SuppliedID) can not be a primary key of second table .u declared SuppliedId as primary key . so ur mapping is incorrect.

  • CANNOT_LOAD_BUNDLE_ERR from remote client (same local network).

    Hello,
    We're having problems (as many other people) with remotely connecting (but on same network) Server Monitor (1.8(5)) from a 10.6.4 client to the LOM IP (or FQDN) of our Xserve (model Xserve3,1)(early 2009)(running under 10.6.4)(LOM revision 1.1.8)(Boot ROM versionXS31.0081.B06).
    Although connections of Server Monitor on that Xserve via localhost work fine, connections from the client (a Macbook Pro running 10.6.4) give the infamous CANNOTLOAD_BUNDLEERR.
    Note that connections from the client to our OTHER Xserve (early 2008)(model Xserve2,1)(LOM revision 1.1.2)(Boot ROM Version XS21.006C.B06) work fine (both via localhost and non localhost).
    Please help!
    shawn
    p.s. Here's a list of what didn't help:
    Our LOM Firmware does seem to be up-to-date on both the working Xserve (the one that does allow remote connections) and the not-willing-to-do-remote Xserve. http://support.apple.com/kb/HT3539 (trying to install a LOM updater tells us we're already up to date.. and anyway, the LOM Firmware update should only be for Early2008 Xserves).
    This unsolved archived discussion did not help:
    Server Admin/Monitor Issues (MrHoffman)
    http://discussions.apple.com/thread.jspa?threadID=2325127
    Nor did reading "LOM it up!" (MacTroll) or the discussion that followed.
    http://www.afp548.com/article.php?story=20070211101829496&query=120
    Using Network Utility > Lookup from the client machine shows that the IP address does indeed point to the correct FQDN and vice versa.
    Running, from the client, dig server2.epfl.ch showed the expected IP addresses.
    Running, from the client, dig -x with the returned IP address, showed the expected FQDN.
    Pinging the LOM's FQDN gives me successful ACKs of .200ms.
    Running changeip -checkhostname on the server shows the non-LOM ip address and correct non-LOM FQDN. How do I use changeip to check the LOM hostname and IP address (which is different) ??
    We're not mixing 10.5 and 10.6; Both server and client are using 10.6.4.
    Running ServerMonitor directly on the server (using localhost) works fine.
    ConfigureLocalMachine on the not-working Xserve (call it Xserve2) shows LOM using Ethernet PORT2 (but switching to PORT1 doesn't help). The Subnet-mask and Router values are configured identically to the working Xserve (call it Xserve1) where the config does allow remote access. The version of ServerMonitor on both Xserves and on the clientMacs is 1.8(5). Every machine is 10.6.4.
    The command "ipmitool lan print 2" on Xserve2 reveals the correct IP address and other infos. But the command "ipmitool lan print 1" says that Channel 1 is not a LAN Channel. Is this important? If so, what do I do with this info?
    Ideas from reading LOM No Workie (Faby) don't help.
    http://lists.apple.com/archives/Macos-x-server/2006/Dec/msg00620.html
    I've also uselessly read:
    Xserve User's Guide : http://www.apple.com/support/xserve/
    OS X Server Manuals : http://www.apple.com/server/macosx/resources/documentation.html
    HT2773 document - Xserve (Late 2006 and later): Configuring Lights-Out Management (LOM) : http://support.apple.com/kb/HT2773

    I'm going to skim over some details of IP and IP routing.
    My IP for that NIC on which the LOM is running is 128.178.100.87.
    If I'm reading you correctly, I should NOT have an IP for my LOM (if you say 'correct' then I'm really confused).
    Your LOM needs its own unique IP address.
    This can be a little confusing if you're looking at the hardware, but it's entirely possible to have several separate IP hosts (devices) on one network jack, and each needs its own (unique) address. You're not assigning IP addresses to cables, you're assigning addresses to hosts.
    And if I read you to say that yes 128.178.100.87 should be assigned to the LOM but not the NIC,.. then to what is the LOM attached/configured?
    Well, if two hosts (or even two network controllers on the same host) have the same address (and the LOM is a host), then (best case) the IP traffic on the second host controller to start detects the address collision and won't allow the host to go online. Worst case, traffic gets snarled.
    Finally, it seems that this setup on XserveBAD (an XServe3,1) is the same on XserveGOOD (and Xserve2,1) in terms of IPs NICs and LOMs. The only diff seems to be Xserve versions.
    There was a brief kerfuffle with the Xserve3,1 boxes and the tools back when those boxes first arrived, but that all settled down with current tools and firmware.
    *2. 2nd dual-port NIC*
    YES indeed! You're good! From the Preferences>Network panel I see we have a PCI ethernet with two ports (both XserveBAD & XserveGOOD have this) link-aggretated. To that bond, we've assigned the IP address that people use to ssh into the machines. LOM is not there. XserveBAD's LOM is configured to say +LOM uses ethernet Port 1+ and XserveGOOD's LOM is set to +uses Network1+ (the GUI looks different on the two machines).
    Two networks (also) means you'll have to consider IP routing; which NIC is used to respond to traffic. Inbound IP packet traffic might well arrive at the box, but if the box doesn't have its routing configured "correctly" then the IP packets "outbound" in response might not be sent out the expected controller; the inbound IP traffic and the IP responses don't automatically use the same controller. Those routing determinations are made separately, based on the local subnet, available local static routes, and the rest of the packets get sent to the default router to deal with.
    For both XserveBAD and XserveGOOD, the Preferences>Network panel shows the IP that we configured for the LOM to be the one on 'Ethernet 1" with subnet mask of 255.255.255.0. And in both cases the IP address used for sshing (the one used on the PCI ethernet bonded ports) is on 'Ethernet 0' with subnet mask 255.255.255.0.
    The subnet masks tells IP where the IP packet is going to be set. In the most general of terms, that mask tells IP routing where to send the packet, and that decision (and specifically with the 255.255.255.0 mask) says that if the first three bytes are the same, it's a local address and the messages get sent directly. If the first three bytes differ (and it's not an established route), it goes to the designated "gateway" router.
    p.s. FWIW, I almost went with SadLOM and HappyLOM but I'm still pretending to be a serious mac admin-wannabe here.
    Uh-huh. You'll get over that.
    p.p.s. I didn't catch your drift concerning public/private subnets.. but I'm googling, I'm googling and reading here http://articles.techrepublic.com.com/5100-10878_11-6089187.html
    Your network uses IP addresses in the public static IP space, and IP addresses in one of the private address spaces. (The same would apply if you had IP addresses in different subnets in any of the private IP address blocks, though the use of a public space implies there's a "public" LAN and a private LAN.)
    That looks reasonable as far as it goes, albeit a little stale, and it unfortunately lacks the associated discussion of routing; of why you'd be interested in subnets, and what happens with the packets. The class stuff discussed there is replaced with what's called "CIDR" - classless routing -- and is long gone. (I've been around long enough that the class A, B and C stuff is second nature and old habit, but that "classful" scheme has been replaced with the far more flexible "classless" CIDR scheme.) And the article lists 17 years for IPv4, and the last of the available IPv4 blocks are likely to be handed out within the next few years; we're all dealing with IPv6 now, and its likely that IPv4 addresses are going to get harder to get and probably also more expensive.
    when next you're in Switzerland, I owe you free beers.
    Danke. Der Ratskeller in Zürich war ziemlich gut. Quite a pretty walking area around there too, and with a beautiful view of the river.

  • BGP stuck in opensent state

    HELP! Been looking at this problem all day. Have a simple BGP config on my end (below). I have no control on the other end. Recently upgraded from 2811 to 2911.  IOS: c2900-universalk9-mz.SPA.151-4.M7.bin  Configs on old and new routers exactly the same.
    Called our ISP. They see the same debug logs, but have no clue to fix. I can ping across fine. No MTU issues. Move connections back to old 2811 BGP comes up no problem.
    interface Serial0/0/0
     ip address X.X.X.86 255.255.255.252
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     service-module t1 fdl ansi
     no cdp enable
    router bgp 65000
     bgp log-neighbor-changes
     network Y.Y.Y.0
     network Y.Y.Y.16 mask 255.255.255.240
     neighbor X.X.X.85 remote-as 2
     neighbor X.X.X.85 password 7 06252C1268715E3C5139
    debug
    Nov  5 11:07:05.493: BGP: Selected new router ID Y.Y.Y.17 for scope global
    Nov  5 11:07:05.537: BGP: Applying map to find origin for Y.Y.Y.16/28
    Nov  5 11:07:05.541: BGP: Applying map to find origin for Y.Y.Y.16/28
    Nov  5 11:07:05.541: BGP: Applying map to find origin for Y.Y.Y.16/28
    Nov  5 11:07:05.549: BGP: nbr global X.X.X.85 Active open failed - can't get active topologies
    Nov  5 11:07:05.549: BGP: nbr global X.X.X.85 Open active delayed 11264ms (35000ms max, 60% jitter)
    Nov  5 11:07:06.457: BGP: X.X.X.85 passive open to X.X.X.86
    Nov  5 11:07:06.461: BGP: X.X.X.85 passive went from Idle to Connect
    Nov  5 11:07:06.461: BGP: ses global X.X.X.85 (0x307CA074:0) pas Setting open delay timer to 60 seconds.
    Nov  5 11:07:06.461: BGP: ses global X.X.X.85 (0x307CA074:0) pas read request no-op
    Nov  5 11:07:06.521: BGP: Sched timer-wheel running slow by 8 ticks
    Nov  5 11:07:16.761: BGP: X.X.X.85 active went from Idle to Active
    Nov  5 11:07:16.761: BGP: X.X.X.85 open active, local address X.X.X.86
    Nov  5 11:07:16.773: BGP: ses global X.X.X.85 (0x30B937F4:0) act Adding topology IPv4 Unicast:base
    Nov  5 11:07:16.773: BGP: ses global X.X.X.85 (0x30B937F4:0) act Send OPEN
    Nov  5 11:07:16.773: BGP: X.X.X.85 active went from Active to OpenSent
    Nov  5 11:07:16.773: BGP: X.X.X.85 active sending OPEN, version 4, my as: 65000, holdtime 180 seconds, ID CD464511
    Nov  5 11:07:16.785: BGP: X.X.X.85 active rcv message type 3, length (excl. header) 5
    Nov  5 11:07:16.785: %BGP-3-NOTIFICATION: received from neighbor X.X.X.85 active 2/8 (no supported AFI/SAFI) 3 bytes 000000
    Nov  5 11:07:16.785: BGP: ses global X.X.X.85 (0x30B937F4:0) act Receive NOTIFICATION 2/8 (no supported AFI/SAFI) 3 bytes 000000
    Nov  5 11:07:16.785: BGP: ses global X.X.X.85 (0x30B937F4:0) act Reset (BGP Notification received).
    Nov  5 11:07:16.785: BGP: X.X.X.85 active went from OpenSent to Closing
    Nov  5 11:07:16.785: BGP: nbr_topo global X.X.X.85 IPv4 Unicast:base (0x30B937F4:0) NSF delete stale NSF not active
    Nov  5 11:07:16.785: BGP: nbr_topo global X.X.X.85 IPv4 Unicast:base (0x30B937F4:0) NSF no stale paths state is NSF not active
    Nov  5 11:07:16.785: BGP: nbr_topo global X.X.X.85 IPv4 Unicast:base (0x30B937F4:0) Resetting ALL counters.
    Nov  5 11:07:16.785: BGP: X.X.X.85 active closing
    Nov  5 11:07:16.785: BGP: ses global X.X.X.85 (0x30B937F4:0) act Session close and reset neighbor X.X.X.85 topostate
    Nov  5 11:07:16.785: BGP: nbr_topo global X.X.X.85 IPv4 Unicast:base (0x30B937F4:0) Resetting ALL counters.
    Nov  5 11:07:16.785: BGP: X.X.X.85 active went from Closing to Idle
    Nov  5 11:07:16.785: %BGP_SESSION-5-ADJCHANGE: neighbor X.X.X.85 IPv4 Unicast topology base removed from session  BGP Notification received
    Nov  5 11:07:16.785: BGP: ses global X.X.X.85 (0x30B937F4:0) act Removed topology IPv4 Unicast:base
    Nov  5 11:07:16.785: BGP: ses global X.X.X.85 (0x30B937F4:0) act Removed last topology
    Nov  5 11:07:16.785: BGP: nbr global X.X.X.85 Active open failed - existing passive session
    Nov  5 11:07:16.785: BGP: nbr global X.X.X.85 Active open failed - existing passive session

    From what I'm finding, AFI 2 is IPv6. This seems like it's expecting IPv6:
    Nov  5 11:07:16.785: %BGP-3-NOTIFICATION: received from neighbor X.X.X.85 active 2/8 (no supported AFI/SAFI) 3 bytes 000000
    I'm also seeing that SAFI 8 is multicast:
    http://www.iana.org/assignments/safi-namespace/safi-namespace.xhtml
    If this is the case, the settings that you have above simply wouldn't work. I would contact the ISP to see what your peer is running.
    http://routing-bits.com/2009/11/26/output-101-bgp-afisafi/
    HTH,
    John

Maybe you are looking for

  • How to connect my mac throgh a proxy server

    Hello. At my university there is free wifi through a proxy (as i could understand but i'm not practical of those thinghs). My computer automatically connect with the wifi but then the browser doesn't automatically ( nor manually) connect to the login

  • Using the same apple ID for syncing, my devices are confused...

    I have my daughter's, and my wife's iphones and ipads, signed into the same icloud account, so that we can all share our calendars, and contacts. However the problem is when I send a SMS or MMS to someone, it thinks that it is coming from my daughter

  • Error in GUI_down load

    hi, i am using gui_down load fm to down load the data into excel,but i need the excel sheet with headers,how to extract the data with field names. i am using following code. *& Report  ZTEST                                                       * REP

  • Recording sound for "ring tone"

    I can't figure out how to record my own voice and then use it for a ring tone. I could do it on my old phone....how do I do it on my iphone4???

  • Named query exception JPA

    Hello I wrote a simple named query in my entity class which is throwing me an exception. @NamedQueries({      @NamedQuery(name="custrecords",query="SELECT c FROM CustDetails c WHERE lower(c.customerName) = :customerName"),      @NamedQuery(name="allc