Can not pass data after while loop

Hello.
I have created a VI for my experiment and am having problem passing data outside a while loop to save on an excel file. The VI needs to first move a probe radially, take data at 1mm increment, then move axially, take data radially at 1mm increment, then move to the next axial position and repeat. It would then export these data to an excel file. The VI is a little complicated but it's the only way I know how to make it for our experiment. I have tested it and all the motion works correctly, however I can not get it to pass the data after the last while loop on the far right of the VI where I have put the arrows (Please see the attached VI ). Is it because I'm using too many sequence, case, and while loops?  If so, what other ways can I use to make it export data to the excel file?
Any help would be appreciated. 
Thank you,
Max
Attachments:
B.Dot.Probe.Exp.vi ‏66 KB

Ummmm .... gee, I'm not even sure where to begin with this one. Your VI is well .... ummmm... You have straight wires! That's always nice to see. As for everything else. Well... Your fundamental problem is lack of understanding of dataflow programming. What you've created is a text program. It would look fantastic in C. In LabVIEW it makes my heart break. For a direct answer to your question: Data will not show up outside a while loop until the while loop has completed. This means your most likely problem is that the conditions to stop that specific loop are not being met. As for what the problem is, I don't even want to start debugging this code. Of course, one way to pass data outside of loops is with local variables, and hey, you seem to be having so much fun with those, what's one more?
This may sound harsh, and perhaps be somewhat insulting, but the brutal truth is that what I would personally do is to throw it out and to start using a good architecture like a state machine. This kind of framework is easy to code, easy to modify, and easy to debug. All qualities that your code seems to lack.
Message Edited by smercurio_fc on 08-17-2009 10:00 PM

Similar Messages

  • HT4759 Hello .. I've been subscribed for ic;oud for 20$ per year and I found it useless for many reasons: that I can not disconnect my mobile while the uploading process and it takes long time for uploading my data .. Its not a reliable system that's why

    Hello .. I've been subscribed for ic;oud for 20$ per year and I found it useless for many reasons: that I can not disconnect my mobile while the uploading process and it takes long time for uploading my data .. Its not a reliable system that's why I need to deactivate the space service and take my money back .. Thanks

    The "issues" you've raised are nothing to do with the iCloud service.
    No service that uploads data allows you to disconnect the device you are uploading from while uploading data. Doing so would prevent the upload from completing. It is a basic requirement for any uploading service that you remain connected to it for uploading to be possible.
    The time it takes to upload data to iCloud is entirely dependent on how fast your Internet connection is, and how much data you are uploading. Both of these things are completely out of Apple's control. Whichever upload service you use will be affected by the speed of your Internet connection.

  • HP4275A can not pass self test after running the labview program

    I am using Labview to control HP4275A LCR meter. The Labview program is just the instrument driver for the HP4275A, and it works great. Before running the program, the instrument can pass both Open and Short test perfectly. But after running the program, it can not pass self test, neither Open nor Short. I don't know why?? Is it relative to my Labview program??
    Thanks

    Thank you so much for your help. Yes, the instrument is in Local after running the instrument driver. In normal Open self test, just choose Capactiance as the Display A, and leave the four output terminals open then press the Self Test button. The Open self test will start and "OP" will be shown in the DIsplay A window, after 2 seconds, the open test will be finished. If something abnormal, the number of the abnormal step is displayed in Display A. Similar with the Short test.
    The problem I had was: before running the instrument driver, the self tests pass; but after running the instrument driver, the Open and Short test show abnormal, Open test is abnormal at step 17, and Short test is abnormal at step 24.
    And the instrument driver is only write commands into the instrument and then read back measuring values from it. Nothing else. So I am not sure if the problem is my instrument driver.
    The weird thing is the problems happened several times and then if I do the Open and Short self test again after running the instrument driver, both pass. I am not sure whether the problem will come back or not.
    Ia there any help??
    Big thanks

  • How can I opearate indicator outside while loop?

    I do small program, I have many while loops and I want to connect wire (in my application) from each loop to AND gate then to another while loop, but how can I operate these wires to agree with the change of my application inside while loops.
    If not clear :
    In another words, suppose I want to operate indicator ouside the while loop. How can I operate indicator outside while loop, so when my application become TRUE (inside while loop) the indicator will be ON (outside while loop) and when my application become FALSE(inside while loop) the indicator will be OFF (outside while loop).
    Help me if you have any idea please..........................

    Hi Rammo,
    For the wire to carry the boolean condition from the while loop to an 'and' gate outside, the while loop must stop running
    If you want the while loop to keep on running and still pass a boolean value to a destination outside the while loop, use any one of these: property nodes, global or local variables.
    i am still not clear as to what you intend to say by this sentence
    " I want the wire that comes out from the while loop will become TRUE if it in my application is TRUE inside while loop and the opposite is true. Because I want to connect the wire that comes out from while loop to AND gate than to another application"
    plz tell me if the first part of this mail of mine answers your doubt or do you need more information?
    regards
    Dev

  • When I was talking on phone, suddenly the phone was switched off. i tried to switch it on but it gave the message....connect to itunes for set up.  when I connected it to itunes...it gave the message, itunes can not read data from this iphone, restore it

    when I was talking on phone, suddenly the phone was switched off.
    i tried to switch it on but it gave the message....connect to itunes for set up.
    when I connected it to itunes...it gave the message, itunes can not read data from this iphone, restore it to factory settings. It also said while restoring ypu will lose all media data but you can restore the contacts.
    I restored the factory settings....the phone was on recovery mode...it was verified by itunes and all that..but in the end it again said that iphone has some problem and can not function right now.
    after that when ever i connect it with itunes, it gives the message, it can not activate the iphone further, try again later or contact customer service.
    What to do now?????? Customer service people say..it is hardware problem

    If it's a hardware problem, then the phone will need to be replaced.
    There is no magic that can fix a hardware problem.

  • Can not update apps after IOS8 update on iPhone 4s

    Can not update apps after IOS8 update on iPhone 4s
    I can no longer update apps on my iPhone 4s after the IOS 8 update. The IOS 8 update took a very long time to complete, maybe 12 hours, and afterwards, it worked but updating packages were very slow. Package updates have since been problematic and about 4 days ago, it stopped being able to update any packages. I click on them to update and they never make any progress. I have 2.8 Gbytes free and I keep deleting more and more packages, pictures, etc. It seems like, from the amount of stuff that I have deleted, I should have more than 2.8 Gbytes free.
    Is anyone else having this kind of problem?

    16GB iPhone4: Go to Settings, scroll down to iTunes & App Stores and touch. At the top of the next page it shows: Apple ID. Touch this. Select Sign Out. Your Apple ID will go away. Re-enter Apple ID and password. Try App Store again.
       Other solutions were to go to Settings:General:Date&Time and turn off auto-update, then change date to next year. This didn't work for me, nor a lot of other users on the forums. It took reading a lot of threads to find the log-out, log-in solution. Even on the official Apple Website all I saw was: Make sure your connection is working, battery is charged, desktop is plugged in when you try to sync. OK I exaggerate, but with all the users posting this problem, you'd think they'd post their solutions when they work with a Tech Help call.

  • Palm TX will sync but not transfer data after installing 64bit drivers for Windows 7

    Palm TX will sync but not transfer data after installing 64bit drivers for Windows 7 using the USB cable. Does anyone have any advise?
    Post relates to: HP TouchPad (WiFi)

    @MikeNTxs - 64bit USB drivers have been available since April of 2010, and they do work. I've synced successfully to my Vista64 bit laptop many times via USB.
    See the sticky thread at the top of this section titled "64bit Palm Desktop drivers are here!"
    WyreNut
    I am a Volunteer here, not employed by HP.
    You too can become an HP Expert! Details HERE!
    If my post has helped you, click the Kudos Thumbs up!
    If it solved your issue, Click the "Accept as Solution" button so others can benefit from the question you asked!

  • Help! Help! Help! Can not reinstal vista after replacing a new hard drive

    Can not reinstal vista after replacing a new hard drive (1TB WD 10EZEX) in HP Pavilion a6658f Desktop PC with recovery disc.
    I saw in the screen:
    "Windows setup could not configure windows to run on this computer's hardware"
    Product:
    HP Pavilion a6658f Desktop PC
    OS: pre-installed window vista with sp1 
    Product number:   FK575AA
    Bought in Canada
    Thank you.

    Thank you so much Lisa27,
    win vista installed to new WD 1tb hard drive. How?
    1. use  http://support.wd.com/product/download.asp?groupid=606&lang=en
    >Data Lifeguard for Windows  , write zero and to test the new hard drive,
    2. use Acronics true image 2013 to do partition on the new HD, and then to clone from the old HD to new HD.
    3. down load Intel Rapid Storage Tech to fix the Issues with Windows Vista* and Intel® RAID  (without it, Window mail can not be opened.
    Thank you very much for all your guys again and the support form WD support team.

  • How can I validate data after writing and over reboot/powercycle?

    Hi,
    How can I validate data after writes are done? How can I validate data after reboot or powercycle of the machine is done?
    What are the options I should give while running vdbench? When should I use -v, -vq, -vt, -v -j, -vq -j, -vq -jr, -v -jr options?

    Please look for the "Data Validation and Journaling' chapter in the documentation.
    Henk.

  • I can not pass the language settings menu

    Hello,
    Since I have tried to get the latest build of Apple TV, my apple TV can not pass the language settings menu. I choose my language and then it loops back to language settings menu.
    I have restored twice from iTunes, plug and unplug from the tv, the electric network, and so on, but it does the same loop.
    Anybody has solved this problem ?
    Regards,
    F

    If you can't get past the lock screen when you slide to unlock, try rebooting your iPad and then try again.
    Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider if it appears on the screen - let go of the buttons. Let the iPad start up.

  • GRE traffic can not pass through LRT224 IPSec Tunnel

    Hi,
    We have a trouble when using Cisco Router GRE tunnel plus LRT224 IPSec Gateway-Gateway Tunnel.
    We found after reboot, GRE packets can not pass trough LRT224 IPSec tunnel. need to restart serval time then gre will back to normal.
    Besides that, GRE keepalive packets can not pass trough LRT224 IPSec Tunnel.
    please help. I had tried to upgrade to latest firmware version.
    Firmware Version : v1.0.3.09 (Dec 26 2014 14:28:46) 
    A-END:
    interface Tunnel1
    ip address 10.216.80.105 255.255.255.252
    ip mtu 1400
    ip nat outside
    ip virtual-reassembly in
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf hello-interval 3
    ip ospf cost 10000
    tunnel source 10.216.81.2
    tunnel destination 10.216.80.90
    end
    B-END:
    interface Tunnel11
    ip address 10.216.80.110 255.255.255.252
    ip mtu 1400
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf cost 10000
    ip ospf hello-interval 3
    tunnel source 10.216.80.91
    tunnel destination 10.216.81.3
    end
    CISCO2911 <> LRT224 <> INTERNET <> LRT224 <> CISCO 2621
    San

    Can you post the results from the below command for the Cisco Routers?
    IOS Command: "sh version"
    Why not static route without NAT through the LRT224 IPSec VPN?
    Just curious why did you use LRT224's for the Site to Site VPN instead of the Cisco Routers?
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • Can not refresh page after save properly(When not saving master record)

    I am using jdeveloper 11g R2 (11.1.2.3) JSF Facelet
    In some use case I have Address as master table and Person as detail table
    For some business reason I need to don't save same addresses
    eg:
    If +1 Test St+ is in database already and new user coming and adding this address with new person
    I need to use the row in database not creating a new address
    I do saving in doDML method of Address with some hashing algorithm and it is fine
    My problem is that I can not refresh page after save properly
    User coming to page think Adding a new address and a new person but in fact no new
    address added because of business I describe above
    Any ideas how I can implement this?
    Appreciate that
    Regards
    Mohsen

    Hi,
    from your description it is not clear why the page doesn't refresh. It could be a problem in your implementation code - who knows. What if you perform the address check on a command button that actually submits the new address? If the check returns true (address exists) you would call row.refresh(forget new row); and re-query the view object so the address coming from the database is displayed. If you wanted to use the doDML then yuou need to be aware that doDML doesn't help removing the row the user created. It just ignores the database update but the entity is still around, which in my suggested solution wont be the case.
    Frank

  • Can not find data in virtual cube

    Experts,
    I can not find data in virtual cube with services function module (copying Z_RS_BCT_FIGL_DATA_GET_VC10 from RS_BCT_FIGL_DATA_GET_VC10).The standard cube is maintained with data.
    Can anybody tell me what could be the reasons the data is coming through Virtua cube.
    Thanks,
    AK

    Hi,
    i_basic_infoprov is the name of the provider where the data is selected from. This must be a basic provider that contains data. What I meant was, create a copy of fm RS_BCT_FIGL_DATA_GET_VC,1 maybe as Z_BCT_FIGL_DATA_GET_VC1, and enter the name of this fm in the properties of your virtual cube. For that fm it might also be a good idea to enter a default value for i_infoprov. And this should be the name of your virtual cube.
    regards
    Siggi

  • Can not receive data 10054

    My version of Essbase is 6.5.1.4. On the server machine it self when I am adding members to outline I get "Can not receive data 10054". To resolve this problem I tried to increase the server page file size but the problem persist.Does anyone know a solution to this problem?SAK

    How exactly are you retrieving data; is it smartview, excel addin, forms, reports etc ?

  • Can not extract data into BW from SQL SERVER

    Dear All,
      I meet a problem to extract data from database(MS SQL Server 2000(sp3)) into BW now and can not extract data into BW ODS, even PSA, In the monitor, display yellow light(0 from 0 record), detail message just display message "data request arranged" "confirmed with: confirmation" in requests(message) step; "missing message: request received" in extract (message)  step; "no data" in processing(data packet) step and so on. but in fact, there are two records in my database test table and DB connection is OK. Even I can extract data from another test oracle database into BW ODS successfully.
       Our BW system has two BW applicaton server and use oracle database. the one application server locates on IBM AIX host. the another one locates on one NT server. the application server on NT server is used for data extration from MS SQL SERVER  database into BW oracle database. and MS SQL SERVER and NT platform application server locate on same one host. DBSL was installed on the NT application server already. and DB connector also was created successfully for MS SQL SERVER and datasource also was generated. DBSL type is Kernel640-WIN-IA32bit-unicode. my BW system is ECC5.0/UNICODE/ORACLE. all table/view/field name of MS SQL server is upcase and have not any specific character. for example: ZDEMO etc.
    wait your help.
    Thanks in advance.
    Billy

    Hi  Ravi,
    Could you help me to get knowledge about the followings:
    approximately how many records    extracting and transfering  from SAP R/3 to BIW  in an organisation. for that how much time  will take .
    How to extract data from  two are three source system  to BIW. Kindly help me with step by step explanation .If any screen shots with documents pls fwd to my ID. "[email protected]"
    Your help highly appreciated.
    Thanks.
    Hema

Maybe you are looking for

  • Share one iTunes library on a SMB share between PC & Mac

    Hi, Is there anyway I can share one iTunes library and the music files on a SMB share between a PC and a Mac? I assume there would be a problem with how the Mac and PC assign network drives differently would be an issue, or is there a way around this

  • Zen V Plus - Software Installat

    Hello?I bought a new ZEN V Plus Gb and installed the CD programs?on a PC with Windows XP, having no problems.Now a bought a new PC, with Windows XP Media Center 2002 and tried to install the CD programs. Tried this three times and every time the foll

  • Running Vista on Macbook Pro

    Hello, Purchased a MacBook Pro 2 weeks ago. 2.5Ghz, 4Gb ram, 15". For a piece of software called DSLR Remote I need to upgrade from Windows XP to Vista. I ran the Vista upgrade advisor and it told me that Vista would not work with the NVDIA GeForce 8

  • Double charge full month of Family Plan which only used for 7 days  and full month of individual plan

    I changed from Family Plan to Individual Plan and I got only refund back $9.99 for one line that stay with Verizon but I got charged double both Family Plan and Individual Plan for full month without any credits for 23 days of unused Family Plan. ($1

  • Video files disappear when AirDrop from Yosemite to iOS 8.1?

    Im trying to transfer a video file from my MBA running Yosemite to my 5S running 8.1.  It appears that the video transfers successfully but I can't find it in the Photos app.  I did this multiple times, and the same result each time. Photos, on the o