Cannot run the code from local machine - works after deployment!!!

Hi,
I am totally new to application server. My problem is that the application code after it is 'deployed' from JDeveloper to Oracle Application Server - it works fine. I can go to the web application from the url and do a 'Submit' of forms and it works fine. The problem comes when I try to connect to dev. environment from local machine and try to do a 'Submit' (done for debugging purposes), I get a 500 Internal Server Error. Is there a configuration file or property I file I have to change? I am clueless.
Basically addRequest can be considered as the 'Submit'.
Javax.faces.FacesException: #{newRequestItem.addRequest}: javax.faces.el.EvaluationException: java.lang.IllegalAccessError: tried to access class javax.xml.rpc.FactoryFinder from class javax.xml.rpc.ServiceFactory
At com.sun.faces.application.ActionListenerImpl.processAction(ActionListenerImpl.java:98)
My application is built on ADF and JSF and connects to BPEL workflow and DRM. So it is using WebServices.
Thanks.

Hi,
Top further pinpoint the issue, I can make the SSRS report work with the stored procedure by running
SP_recompile 'myStoredProcedure'
So, SQL Server has somehow messed up the execution plan for the sproc. But to repeat, executing the Sproc in Management Studio works just fine, I just look the exact sproc and parameters with SQL Profiler when it is not working in SSRS report, then run that
same sproc manually and it works.
After extensive debugging, it seems to raise from one specific SELECT row:
SELECT
cte.TIMEYEAR + 1 AS TIMEYEAR,
where cte.TIMEYEAR is varchar. After changing that to
SELECT
CAST(cte.TIMEYEAR + 1 AS VARCHAR) AS TIMEYEAR,
it started to work.
What will probably remain forever unclear is that WHY the original select always breaks every now and then, and always starts to work with a simple sp_recompile. I could reproduce the error easily by running
exec sp_msforeachtable @command1="EXEC sp_recompile '?'";
after which the sproc raised error: "Conversion failed when converting nvarchar value 'Q1/2000' to data type int".
..aaaand then just by running SP_recompile 'myStoredProcedure' it again started working fine. I could reproduce this break & fix pair coherently.
Still it makes no sense from SSRS report perspective, when sproc was broken in Management Studio query, it was always broken from SSRS report end as well, but sometimes when sproc was working from SSMS, it wasn't working from SSRS.

Similar Messages

  • Firefox 7.0 - Can not upload the file from local machine to server...gives "error 404 : file not found"

    firefox 7.0 - Can not upload the file from local machine to server...gives "error 404 : file not found"

    you have not understood my point
    how does this code will run on servlet when I want to upload a file from client's
    machine to server machine
    what I am doing is I am giving an option to the user that he/she can browse the file and then select any file and finally it's action is post in the jsp form for which I have sent the code
    All the computers are connected in LAN
    So how to upload a file from client's machine to server's machine
    Plz give me a solution

  • Running CLIX commands from local machine

    Hello Experts,
    We have the following requirements in terms of clix commands
    Need to know the number of files in log/archieve/report folder - Is there any clix commands for this
    Want to run the clix commands manually from local machine (Windows), the mdm server is at linux environment. We dont want to automate the script and want to run when needed from local machine. Is that possible
    Thanks & Regards,
    Antony

    HI,A.Antony
    as far as i know ,clix can not count the number of files in the loglog/archieve/report folder.but there is a way out.you can get through the path:<driver>:\usr\sap\<instance>\MDS00\log to check it out.
    to run clix locally,you need to install the mdm-clix-7.1.<sp>.<patch>-win32.exe on your windows.then run the clix in the cmd circumstance.for the clix command Syntax,please refer to the MDM console reference guide,as for MDM7.1SP12,you may goto the Clix referece guide on help.sap.com.
    hope it helps.
    best regards
    Stephen

  • View pdf from local machine

    I have requirement of selecting a pdf from local system and previewing it before uploading.
    I am able to select the file and upload it but i am not able to preview it.
    I tried using navigateToURL(urlRequest,
    "_blank"); , but it is not able to show file from local path
    Can anyone please tell how can i show the file from local machine
    TIA

    Hi,
    is your code executed in Flash runtime (web/standalone application but played in Flash runtime) or in AIR runtime (or 3rd party projector)? That's important as only AIR hosted movie would have access to "file://" protocol when defining/using URLRequest (and then navigateToURL) that are outside of your application domain:
    http://livedocs.adobe.com/flash/9.0/ActionScriptLangRefV3/flash/net/URLRequest.html
    http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/net/package.html# navigateToURL()
    regards,
    Peter

  • 11.5.10 Step by Step - Run istore from local machine for customization

    Hello,
    Does anyone have step by step instructions on using JDeveloper to run iStore JSPs on local machine with the end goal to customize JSPs? We have 11.5.10. I am using JDeveloper 9.0.3.5. Have tried following steps per lot of metalink notes but none seem to be working. Need to know exactly:
    - what Jdeveloper version to use for 11.5.10?
    - Where to download this version from?
    - Is it even possible to run iStore from local Windows machine using JDeveloper?
    - What is the main iStore page that should be run the 1st time?
    - Any expert available in USA for a 2 week paid assignment to help our team setup Jdeveloper for customization? And give intro lessons?
    Much Help...
    Thanks

    1. The Jdeveloper you use with 11.5.10 will depend on which ATG patch level you are at (see metalink note 416708.1)
    2. It will be in a metalink patch (see metalink note 4167708.1)
    3. I don't believe you can run it locally on a windows machine.
    4. Can't remember it off the top of my head but I will look back in my notes, I'm no longer working at the client site who has iStore.
    5. I know of 3 or 4 experts that I have worked with in Canada on JDeveloper/iStore/Configurator, I don't know anyone in the US but there has got to be a bunch out there looking for work.
    Edited by: mcharchu on Jul 17, 2009 9:20 PM

  • Java code to connect to remote windows machine from local machine

    Hi,
    I have developed a code to connecting remote windows M/C from local M/C by using SSH2 (ganymed-ssh2-build209.jar) API. when I run the code its giving below error. Can any one please help me how to resolve it. And also please let me know, is there any other way to connect remote windows system using java code.
    Exception.
    java.io.IOException: There was a problem while talking to <host name>:22
      at ch.ethz.ssh2.Connection.connect(Connection.java:642)
      at ch.ethz.ssh2.Connection.connect(Connection.java:460)
      at Connect.RemoteServer.ConnectWindowsServer.runCommand(ConnectWindowsServer.java:55)
      at Connect.RemoteServer.ConnectWindowsServer.main(ConnectWindowsServer.java:27)
    Caused by: java.net.ConnectException: Connection refused: connect
      at java.net.PlainSocketImpl.socketConnect(Native Method)
      at java.net.PlainSocketImpl.doConnect(Unknown Source)
      at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
      at java.net.PlainSocketImpl.connect(Unknown Source)
      at java.net.SocksSocketImpl.connect(Unknown Source)
      at java.net.Socket.connect(Unknown Source)
      at ch.ethz.ssh2.transport.TransportManager.initialize(TransportManager.java:299)
      at ch.ethz.ssh2.Connection.connect(Connection.java:591)
      ... 3 more
    JAVA Code
    import ch.ethz.ssh2.Connection;
    import ch.ethz.ssh2.Session;
    public void setAuthenticationInfo(String hostname, String username,String password) {
           this.host = hostname;
           this.userid = username;
           this.password = password;      
           this.recentCommand = "";     
           System.out.println("setting authentication info completed for host=" + host );
      public void runCommand() throws Exception {
    try{
            // Setup ssh session with endpoint
           System.out.println("starting connection with " + host);
           Connection connection = new Connection(host);
           System.out.println("connection object created..");
           connection.connect();
           System.out.println("Connect to connection");
           connection.authenticateWithPassword(userid,password);
           System.out.println(connection.isAuthenticationComplete());
           Session session = connection.openSession();
          System.out.println("connected");
      }catch (Exception e) {
      e.printStackTrace();
    Regards,
    Praveen

    Hi baftos,
    I tried to telnet remote windows machine from my local machine on port 23, its not connected and given error message like "Connect failed".
    As your response, if we can telnet to remote windows machine from local machine then we can connect from Java. Is it correct ?.
    Can you please help me to resolve this issue. And also please confirm the port (23) is correct, which I was used to connect remote machine from telnet.
    Regards,
    Praveen

  • Had to restore my iMac from Time Machine. After the restoration all programs are functioning except my Adobe Creative Suite 4 Design Premium. When I start any program in the suite the error message, "Licensing for this product has stopped working." I rest

    I had to restore my iMac from Time Machine. After the restoration all programs are functioning except my Adobe Creative Suite 4 Design Premium. When I start any program in the suite the error message, "Licensing for this product has stopped working." I restarted the computer and tried again to run Photoshop and the same error message appeared. The message was followed by a message that stated that I needed to contact Adobe technical support and mention Error: 150.30. I need Adobe technical support to provide me a solution for my problem so I can continue using my Adobe products installed on my computer.

    Unfortunately when Adobe products are restored from backup, especial CS4 and especially Mac, it breaks licensing.
    There is a python script included in the license recovery kit that should work if you are familiar with Terminal.
    If not, you must reinstall your CS4 suite.  You don't need to delete your preferences, so it should be the same as before.
    Error "Licensing has stopped working" | Mac OS
    Gene

  • HT1386 I have the iphone 5s. I cannot get the playlists from my computer to sync to iphone it will work for my 4s but not my 5s why?

    Hello can someine help before i throw this 5s in the trash please?
    I have the iphone 5s. I cannot get the playlists from my computer to sync to iphone5s but it works just fine with my 4s. I have done everything, it has even deleted my playlists that I have had to re-do 3 times. UGH!!!! Please help!

    Hey there rmflint,
    It sounds like you are wanting to update the Apps that were synced over from your computer to your new iPhone 5s. If you are clicking Updates in the App Store in the bottom right corner, would you mind clarifying what happens when you are trying to update them? 
    App Store at a glance
    http://help.apple.com/iphone/7/#/iph3dfd8c19
    Thank you for using Apple Support Communities.
    Take care,
    Sterling

  • Jabber 9.2, uploading the contact photo from local machine or PC.

    is it posssible to upload contact Photo from local machine to jabber from 'edit profile'? I did that but nothing happened! still no contact photo.
    Thanks,

    Hi Shane,
    in previous version of Jabber it was not possible, am I right? But I heard in 9.2.0 onwards we can do it.
    I will send you the problem on Monday once I get back to Customer Site.
    Thanks,

  • The Java load in database SID / hostname has not been configured yet. You cannot run an installation from the System Copy folder with this load

    Dear Gurus,
    We are facing the below issue when performing a homogeneous system copy of NW 7.0 system using backup/restore method for DB6 system.
    The Java load in database <SID>/<hostname> has not been configured yet. You cannot run an installation from the System Copy folder with this load.
    We went through the SAP Note http://service.sap.com/sap/support/notes/2049842, and followed the same but no luck.
    We updated the Kernel to the latest, but still no luck.
    Request for your quick help as we have to complete it by EOD today.
    Thanks a lot in advance.
    Best Regards,
    Anuj

    Hello Ashutosh ,
    Thanks for your reply.
    We have gone followed the below sequence:
    SCS Installation
    Database Instance Installation using backup/restore method
    CI installation. -> getting error, when we provide the Java Components DVD.
    Best Regards,
    Anuj

  • Cannot change Tax Code from the referenced sales order line

    hi,
    Has anyone ever got this error when creating Sales Order(SO): "*cannot change Tax Code from the referenced sales order line*"?
    The error occur with order type Return.
    This SO is created by copying from another SO.
    Please help.
    Regards & thanks,
    eRie

    hi,
    Has anyone ever got this error when creating Sales Order(SO): "*cannot change Tax Code from the referenced sales order line*"?
    The error occur with order type Return.
    This SO is created by copying from another SO.
    Please help.
    Regards & thanks,
    eRie

  • Ifs Connection problem from local machine to Ifs server using API

    I am trying to make an API call to connect to Ifs database server running on different machine(UNIX) from local machine. I copied all jar files and /Lib/Ifs/Settings directory to my local machine. All these files are in the classpath of weblogic 6.0 environment. A jsp on weblogic server call a bean which has a responsibibility of connecting to Ifs server to get LibrarySession.
    From Visual Cafe 4.5 everything works fine but when i start weblogic 6.0 outside the visual cafe environment i get the error
    below. I included all the jar files and /Lib/Ifs/Settings in start up script of weblogic server
    Do you know if i missing some thing????
    java.lang.UnsatisfiedLinkError: do_open
    at oracle.jdbc.oci8.OCIDBAccess.do_open(Native Method)
    at oracle.jdbc.oci8.OCIDBAccess.logon(OCIDBAccess.java:309)
    at oracle.jdbc.driver.OracleConnection.(OracleConnection.java:198)
    at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.ja
    va:251)
    at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:224)
    at java.sql.DriverManager.getConnection(DriverManager.java:517)
    at java.sql.DriverManager.getConnection(DriverManager.java:177)
    at oracle.ifs.server.LibraryConnection.(LibraryConnection.java:235
    at oracle.ifs.server.ConnectionPool.createLibraryConnection(ConnectionPo
    ol.java:576)
    at oracle.ifs.server.ConnectionPool.(ConnectionPool.java:321)
    at oracle.ifs.server.S_LibraryService.(S_LibraryService.java:912)
    at oracle.ifs.server.S_LibraryService.startService(S_LibraryService.java
    :1129)
    at oracle.ifs.beans.LibraryService.connectLocal(LibraryService.java:408)
    at oracle.ifs.beans.LibraryService.connect(LibraryService.java:280)

    Have you installed the Oracle client software on the machine where you are running WebLogic and your custom iFS application (your bean)?
    It looks like the native JDBC libraries are not available to the JVM where WebLogic is executing your code. iFS uses JDBC to access the Oracle database, and it requires "thick" (OCI8) JDBC to do so. This means that you need Oracle client software to be installed (in an ORACLE_HOME directory) on a computer where you want to use the iFS API.
    If you do have the Oracle client software installed already, then perhaps the WebLogic environment isn't configured to have access to the native JDBC libraries. Normally, as long as $ORACLE_HOME/lib is in the LD_LIBRARY_PATH (on unix) or $ORACLE_HOME/bin is in the PATH (on windows), stuff should just work.
    See if you can find any information about including native libraries (for instance, to use JNI) in the WebLogic documentation. We don't certify with WebLogic, which is why I don't know the answer offhand.

  • Error while running the page from Jdeveloper

    Hello All,
    I am running the pages from my Jdeveloper but it is throwing some exception which is related to cache on the local server.Kindly help me out as i am not able to run even old pages which were running earlier.Kindly what changes on the server has affected this.
    Below is the exception i am getting in OC4J server tab of the Jdeveloper while running the page,kindly have a look:
    [[Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693195:Thread[HttpRequestHandler-16916276,5,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:EXCEPTION:[jtf.cache.CacheManager]:CacheManager.put(): Component cache: PROFILE_OPTION_VALUE_CACHE for application: FND is not enabled. Calling put() does not add an entry to the cache
    [Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693445:Thread[HttpRequestHandler-16617866,5,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:PROCEDURE:[fnd.security.DBConnObj]:Pool.isUsable(): END: Returning true.
    [Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693445:Thread[HttpRequestHandler-16916276,5,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:EVENT:[fnd.profiles.Profiles.getProfileOptionValue.config]:name=APPL_SERVER_TRUST_LEVEL; levelID=10001; levelValue=0; levelValueApplID=0; value=2; Cache Miss
    [Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693695:Thread[HttpRequestHandler-16916276,5,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:PROCEDURE:[fnd.common.WebAppsContext]:oracle.apps.fnd.common.WebAppsContext.getJDBCConnection(oracle.apps.fnd.profiles.Profiles@c063ad,0xe4bb3c,false): : BEGIN/END
    [Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693695:Thread[Thread-12,1,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:PROCEDURE:[fnd.security.AppsConnectionManager]:makeGuestConnection(): BEGIN
    [Sep 25, 2009 11:18:13 AM GMT+05:30]:1253857693773:Thread[HttpRequestHandler-16617866,5,main]:-1:-1:XXXXXX:000.000.00.000:-1:-1:UNEXPECTED:[fnd.common.logging.DebugEventManager.handlerException]:java.lang.Exception: E:\oracle\redora\iAS\Apache\Jserv\logs\apps.log (The system cannot find the path specified)
         at oracle.apps.fnd.common.logging.FileHandler.<init>(FileHandler.java:103)
         at oracle.apps.fnd.common.logging.FileHandler.<init>(FileHandler.java:80)
         at oracle.apps.fnd.common.logging.DebugEventManager.registerHandlers(DebugEventManager.java:1239)
         at oracle.apps.fnd.common.logging.DebugEventManager.internalReinit(DebugEventManager.java:986)
         at oracle.apps.fnd.common.logging.DebugEventManager.reInitialize(DebugEventManager.java:944)
         at oracle.apps.fnd.common.logging.DebugEventManager.reInitialize(DebugEventManager.java:931)
         at oracle.apps.fnd.common.AppsLog.reInitialize(AppsLog.java:570)
         at oracle.apps.fnd.common.AppsContext.initLog(AppsContext.java:873)
         at oracle.apps.fnd.common.AppsContext.initializeContext(AppsContext.java:858)
         at oracle.apps.fnd.common.AppsContext.initializeContext(AppsContext.java:827)
         at oracle.apps.fnd.common.AppsContext.<init>(AppsContext.java:686)
         at oracle.apps.fnd.common.WebAppsContext.<init>(WebAppsContext.java:846)
         at oracle.apps.fnd.framework.server.OAUtility.getWebAppsContext(OAUtility.java:351)
         at oracle.apps.fnd.framework.webui.OAServerDelegate.getWebAppsContext(OAServerDelegate.java:1684)
         at oracle.apps.fnd.framework.webui.OAServerDelegate.getIcxCookieName(OAServerDelegate.java:568)
         at oracle.apps.fnd.framework.webui.OAJSPHelper.getIcxCookieName(OAJSPHelper.java:207)
         at oracle.apps.fnd.framework.CreateIcxSession.getEncryptedSessId(CreateIcxSession.java:167)
         at oracle.apps.fnd.framework.CreateIcxSession.createSession(CreateIcxSession.java:80)
         at runregion.jspService(runregion.jsp:96)
         at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)
         at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:317)
         at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:465)
         at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:379)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
         at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:727)
         at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:306)
         at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:767)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:259)
         at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:106)
         at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:797)
         at java.lang.Thread.run(Thread.java:534)

    Is it 9i Jdeveloper or 10G. Also check the Jdeveloper is being run on a compatible database. A Jdeveloper for 11i should run on an instance having 11i installed and same for R12. Also check the version of OA Frameworrk in the Jdeveloper you are using and the version deployed in instance.
    Regards
    Sumti

  • Problem while running the report from a form

    Hi,
    I am able to call a report from forms9i using run_report_object. This report just has a boilertext within it. I did this just to check the functionality of run_report_object built-in. This worked perfectly.
    But when I am trying to call a report based on emp table from the form, it gives me error saying that it cannot run the report.
    Can anyone please help me.
    Thanks
    Narain

    Hi Ino Laurensse ,
    Thanks for the response.
    The error code and message is as follows
    frm-41214 Unable to run report.
    I am able to call from forms9i a report with some boilertext but not a report accessing the database. Thro' out I have never changed the username.
    The following are the changes I made
    In the rwservlet.properties
    I specified the
    reportserver name = repsrv ( I created it and started from the services)
    singlesignon = no
    I am able to run the report which is accessing the emp table from the report builder with the same user as the one which I am using in forms, but, the same I am not able to call from forms.
    thanks
    Narain

  • UNABLE TO ACCESS THE INTERNET FROM LOCAL PROVIDER ON A SITE-TO-SITE VPN CONNECTION

    Dear All,
    I have a site-to-site connection  from point A to point B. From point B i am unable to access the internet from local internet provider.
    I am trying to ping from 192.168.20.1 the dns 8.8.8.8   but i receive the  message "destination net unreachable".
    When i run "show ip nat translation" i receive nothing.
    The vpn connection is working properly, i can ping the other side 192.168.10/24
    Below is the configuration of the cisco router on point B.
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.21.254
    ip dhcp pool voice
     network 192.168.21.0 255.255.255.0
     default-router 192.168.21.254 
     option 150 ip 192.168.5.10 
    ip cef
    ip domain name neocleous.ru
    ip inspect name IOS_FIREWALL tcp
    ip inspect name IOS_FIREWALL udp
    ip inspect name IOS_FIREWALL icmp
    ip inspect name IOS_FIREWALL h323
    ip inspect name IOS_FIREWALL http
    ip inspect name IOS_FIREWALL https
    ip inspect name IOS_FIREWALL skinny
    ip inspect name IOS_FIREWALL sip
    no ipv6 cef
    multilink bundle-name authenticated
    vty-async
    isdn switch-type primary-net5
    redundancy
    crypto isakmp policy 5
     hash md5
     authentication pre-share
     group 2
    crypto isakmp policy 10
     encr aes
     authentication pre-share
     group 2
     lifetime 28800
    crypto isakmp policy 50
     encr 3des
     hash md5
     authentication pre-share
     group 2
    crypto isakmp key Pb85heuvMde9Wdac5Qohha7lziIf142u address [ip address]
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 10
    crypto ipsec transform-set TRANSET esp-aes esp-sha-hmac 
    crypto ipsec transform-set TRANSET2 esp-des esp-md5-hmac 
    crypto ipsec df-bit clear
    crypto map CryptoMAP1 ipsec-isakmp 
     set peer [ip address]
     set transform-set TRANSET 
     match address CryptoACL
    interface FastEthernet0/0
     description Primary Provider
     ip address [PUBLIC IP MAIN PROVIDER] 255.255.255.252
     ip access-group outside_acl in
     ip mtu 1390
     ip nat outside
     ip virtual-reassembly in
     load-interval 30
     duplex auto
     speed auto
     crypto map CryptoCY
     crypto ipsec df-bit clear
    interface FastEthernet0/1
     description TO LAN
     no ip address
     load-interval 30
     speed 100
     full-duplex
    interface FastEthernet0/1.1
     description DATA VLAN
     encapsulation dot1Q 20
     ip address 192.168.20.254 255.255.255.0
     ip access-group inside_acl in
     ip nat inside
     ip inspect IOS_FIREWALL in
     ip virtual-reassembly in
     ip tcp adjust-mss 1379
    interface FastEthernet0/1.2
     description VOICE VLAN
     encapsulation dot1Q 21
     ip address 192.168.21.254 255.255.255.0
    interface Serial0/2/0:15
     no ip address
     encapsulation hdlc
     isdn switch-type primary-net5
     isdn incoming-voice voice
     no cdp enable
    interface FastEthernet0/3/0
     no ip address
     ip access-group outside_acl in
     ip nat outside
     ip virtual-reassembly in
     shutdown
     duplex auto
     speed auto
     crypto map CryptoCY
    ip local pool VPNPool 192.168.23.2 192.168.23.10
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip nat inside source list nat_list interface FastEthernet0/3/0 overload
    ip route 0.0.0.0 0.0.0.0 [default gateway ip]
    ip access-list standard VTY
      permit 192.168.20.0 0.0.0.255
    ip access-list extended CryptoACL
     permit ip 192.168.20.0 0.0.0.255 192.168.3.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.5.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.6.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.12.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.2.0 0.0.0.255
     permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
     permit ip host 192.168.22.1 192.168.5.0 0.0.0.255
     permit ip host 192.168.20.1 192.168.5.0 0.0.0.255
     permit ip host 192.168.22.1 192.168.6.0 0.0.0.255
    ip access-list extended DFBIT_acl
     permit tcp any any
    ip access-list extended inside_acl
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.35
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.39
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.23
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.18
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.55
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.144
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.146
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.141
     permit ip host 192.168.20.253 host 192.168.3.21
     permit ip host 192.168.20.254 host 192.168.3.21
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.10
     permit ip 192.168.20.0 0.0.0.255 host 192.168.20.254
    ip access-list extended nat_list
     deny   ip host 192.168.20.254 192.168.10.0 0.0.0.255
     deny   ip host 192.168.20.254 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.1 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.1 192.168.10.0 0.0.0.255
     deny   ip host 192.168.20.2 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.2 192.168.10.0 0.0.0.255
     permit ip host 192.168.20.1 any
     permit ip host 192.168.20.2 any
     permit ip host 192.168.20.254 any
    ip access-list extended outside_acl
     permit gre any host [ip address]
     permit esp any host [ip address]
     deny   ip any any
    ip sla 2
     icmp-echo 192.168.10.254 source-interface FastEthernet0/1.1
     frequency 180
     timeout 500
    ip sla schedule 2 life forever start-time now
    logging 192.168.3.21
    route-map DFBIT_routemap permit 10
     match ip address DFBIT_acl
     set ip df 0
    route-map ISP2 permit 10
     match ip address nat_list
     match interface FastEthernet0/3/0
    route-map nonat permit 10
     match ip address nonat_acl
    route-map ISP1 permit 10
     match ip address nat_list
     match interface FastEthernet0/0

    You cannot access internet, because all traffic is tunneled for VPN !!!!
    Please see cisco tech documentation and bypass traffic for internet.
    eg.  if lan traffic is going from site a to site b  then through vpn
          else
           lan traffic to internet (any) should be out thorugh the vpn .

Maybe you are looking for

  • Solution for a "colour picker" problem.

    Hello, I had the most annoying problem with "Colours" in DreamWeaver 8. I just couldnt seem to get DreamWeaver to select colours from the page I was working in. I could select colours from the colour popup or "swab", but trying to match colours with

  • Can i stop a order item create

    When  we create a order item , a lot of object will be created .  Orderadm_i , pricing_i ,  customer_i ...... We can use the tcode 'crmv_event'  to create own Zfunction on the system event. Can we stop the creating procedure by these zfunction. Dont

  • Site check // website intro // suggestions for dev team

    Hello, my name is XDude and I'm reliving my glory days of when I used to make long, elaborate website intros in Macromedia Flash. Just kidding. But I did make this today: http://12voltwizard.com/intro/ (Ultra rough first draft, takes a while to load,

  • Too many touch points reported: Bug ?

    Dear JavaFX community Following situation. I have a touch handler who recognizes special gestures and fires javafx.GestureEvent derivates on positive detection. the gesture event carries a list of cloned touch points for carrying the touches on start

  • Web form not updating database with stored procedure

    Hello i have a problem with the web form updating the database i have a stored procedure which i need to connect to. If i execute the procedure in the SQL it will update the database but when i run the web form i get my catch error "could not update