Cant access image, in jar, from applet

I have seen this question posted in various places but have not had any luck solvin my problem. Im using the Java Plugin 1.3
Here is my html :
<OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
width="700" height="200" align="baseline"
codebase="http://java.sun.com/products/plugin/1.3/jinstall-13-win32.cab#Version=1,3,0,0">
<PARAM NAME="code" VALUE="com.hlboyd.ImageSequenceTimer">
<PARAM NAME="archive" VALUE="ImageSequenceTimerImages.jar,ImageSequenceTimer.jar">
<PARAM NAME="type" VALUE="application/x-java-applet;version=1.3">
No Java 2 SDK, Standard Edition v 1.3 support for APPLET!!
</OBJECT>
My applet class is stored in one of the jars.
It is found and runs fine, until it trys to load an image that is found in the other jar.
The images are at the top level in their jar.
The image name is T1.gif.
InputStream in=getClass().getResourceAsStream("T1.gif");
URL url=getClass().getResource("T1.gif");
Both these methods return null.
Can anyone suggest why these methods are returning null?
Many thanks
Heather

I consolidated the jars - so that now the images and
java class files are in the same jar.
The getResouce() method still returns null.
I am really stuck - I simply cant get the applet to
see the images.
How are you attempting to get the images? If you're using Class.getResource(), then as was mentioned above, make sure the class file that has the Class.getResource() code in it, is in the same jar as the images. Then make sure you're referencing the images correctly.
For example:
Given that in the class:
mypackage.ImageLoader
you have the code:
ImageLoader.class.getResource(someVal);
If you want to load an image from the same jar called logo.gif in the same package (i.e. shows up as /mypackage/logo.gif), then someVal should be "logo.gif".
If the image is in a different directory/package then someVal should look like "/somepackage/logo.gif".
Basically, the relative path (someVal) starts from the package that the code (and class) is in. If the image is in a different package, you must start the someVal with a "/" and go from there.
I got the same thing to work this way.

Similar Messages

  • I cant access my itunes file from my WD hard drive?

    i can't access my itunes file from my WD hard drive?

    You might find this article useful: iLounge - Managing your iTunes Library on an External Hard Drive

  • Separating native JDBC driver JAR from applet JAR - best way?

    Since I want to allow the customers/users of my applet to choose their own native JDBC driver to purchase at their site, I don't bundle the JDBC driver into my applet's JAR file. During my testing, here's what I've done:
    1. Deployed my applet HTML and JAR files to a web server folder.
    2. Extracted my JDBC driver JAR file's contents to that same web server folder.
    (My applet HTML contains 2 parameters that allow the applet to use the JDBC driver -- class name and connection string template.)
    This works fine, but I'm wondering if I'm using the best techniques.
    Questions:
    1. Do the contents of the JDBC driver need to be extracted from its JAR file? If not, what do I do, if anything, to allow my applet to "see/find" the driver class within the JAR?
    2. If the JDBC JAR file DOES need to have its contents extracted, is there a way to extract them to a central folder somewhere on the web server and have a variety of applets use them? If so, what do I need to do to make my applet "see/find" the file(s) in the central folder?
    Possibly looking for this stucture on the web server:
    /WebApps/JDBCfiles
    /WebApps/MyDbApplet1
    /WebApps/MyDbApplet2
    /WebApps/MyDbApplet3
    Any advice/recommendations? Thanks.

    Is it possible for a client application to access a jarred JDBC driver? I'd like to deliver a JDBC driver packed in a jar file, however, it won't work, here is what I am tring to do
    try {
         Class.forName("mfg.jdbc.myDriver").newInstance(); //--> throw an exception
    m_Connection = DriverManager.getConnection(szURL, props);
    catch(Exception e) {/...}
    Before class myDriver and other classes from package mfg.jdbc were jarred, a client application used to get the connection just fine, now I get an exception "java.lang.ClassNotFoundException: mfg.jdbc.myDriver"
    I am using Java 2 Platform, no problem in running a jarred command like java -jar jarredclass.jar
    Any tips and hints would be gratfully received!
    Simon

  • CANT ACCESS PICTURES AND VIDEOS FROM GALLERY...573...

    Why cant i access my pictures and videos from gallery?...i can only access it when i connect using USB cord, that is when i see it in d memory card. My phone is 5730 Express Music
    Pls help..

    make sure that your folders are not made hidden by virus while connecting in mass storage mode. If it is so, hidden your phone will not show files under hidden folders, so goto property of your folder whilst your phone is connected in mass storage mode and uncheck 'hidden'

  • Accessing 3rd party jars from ear.

    I was able to create a war with the 3rd party jars in webinf/lib, register it with weblogic and access them from webapps another ear, after specifying this reference in EACH of the webapps.
    However if I want to just make the ear reference these jars, ie., all the webapps in the ear access these jars, without individually specifying the reference, then it gives me an error.
    What is different with providing a reference from an EAR ? I added it to the weblogic-application.xml as the docs suggested....

    http://www.jcp.org
    Cheers
    mbg
    "joe" <[email protected]> wrote in message news:[email protected]..
    >
    what do you mean by "to integrate this back into the specifications"? whatis the
    J2EE way to achieve it if there is one? Thanks
    "Mark Griffith" <[email protected]> wrote:
    Nope, embrace and extend. We are working to integrate this back into
    the
    specifications.
    cheers
    mbg
    "Joe" <[email protected]> wrote in message
    news:3e77c70d$[email protected]..
    Is that part of J2EE or weblogic's implementation?
    "Mark Griffith" <[email protected]> wrote:
    Upgrade to 8.1 and stick the jar's in myEar/APP-INF/lib
    cheers
    mbg
    "Jen" <[email protected]> wrote in message
    news:3e724f46$[email protected]..
    Is there a way to put in one shot instead of modifying every .jar
    and
    ..war's manifest
    file.
    Philip Strube <[email protected]> wrote:
    Hi Sudhindra,
    you can put them in your EAR (on top level or you can create a
    directory
    for them, like "libs" or sth.), and then create class-path entriesin
    the manifest files of your WAR and ejb-jars.
    Example: if myApp.war needs myUtil.jar, then write a line
    Class-Path: myUtil.jar
    in the manifest file of myApp.war. If myUtil.jar is in libs, write
    libs/myUtil.jar and so on.
    -- Philip
    Sudhindra wrote:
    Hi
    I have some common 3rd party jars and zips that are accessed
    by
    my
    WARs and EJB
    JARs. Where in my EAR structure do i place them so that these
    common
    jars like
    classes12, formulaone etc can be accessed from within my WARs
    and
    EJB
    jars?
    Regards Sudhindra

  • Cant access a DFS share from a Windows 7 computer

    I am having DFS share access issues with a Windows 7 workstation.
    My setup is I have 6 windows 7 stations accessing this DFS Share.
    All computers have the same Administrator password and another User/Password
    All but 1 are working as they should.
    The DFS share is running under Server 2008 R2 and contains files from this and another server.
    From the workstation, I can see the server under Network.
    I can open it and see the individually shared volumes and I have full read/write permissions.
    I can see the DFS share and I can map it.
    If I try to open the shared volumes within the DFS file I get a message saying I dont have permission.
    Interestingly, when I look at the properties of the DFS share form the workstation, I dont see a DFS tab.
    If I do this from a workstation is is able to connect fully to the share, I see a DFS tab in the properties.
    I tried to include everything,
    Thanks in advance

    Hi,
    Please try hotfix in the following KB,and check the result.
    You cannot access a DFS share through a mapped network drive on a computer that is running Windows 7 or Windows Server 2008 R2
    http://support.microsoft.com/kb/983620/en-us
    Some steps for troubleshooting DFS you can try
    http://technet.microsoft.com/en-us/library/cc962144.aspx
    How to troubleshoot Distributed File System Namespace access failures in Windows
    http://support.microsoft.com/kb/975440/en-us
    use command dfsutil /pktinfo to test the access to the DFS root and connectivity to the root shares
    http://blogs.technet.com/b/askds/archive/2009/06/04/the-case-of-the-random-dfs-access-denial.aspx
    Regarding to the missing dfs tab, there's a policy, locate to User Configuration\Administrative Templates\Windows Components\Windows Explorer\remove dfs tab, then users can not view or change the properties of the dfs shares
    Yolanda Zhu
    TechNet Community Support

  • Cant access image on my iphone via laptop

    I used to connect my Iphone 5s to Laptop via USB and copy my images to the laptop,but for 2 weeks when i connect Usb cable to laptop, it beep twice and just charging my phon and I cant acess to my phon via expolorer. But iTune can recognize phone. Nothing change in these 2 weeks.what's the problem?
    thanks

    On your ATV, what generation is it?

  • Cannot access image in jar

    I have created a jar file in which I fill in the client classes, one of which loads an image as below:
    try
    System.out.println("before loading the image is ...");
    url = new URL(getClass().getResource("../images/Leo.bmp"), "Leo.bmp");
    System.out.println("The url is ...=" url);
    image = ImageIO.read(url);
    System.out.println("the image is ...=" image);
    catch (Exception e) { /handled in paintComponent()/System.out.println("image loading unsuccessful..."); }
    The client works fine, that is, it loads the image fine, only when I run the program in eclipse. But when I create a jar file and try to run it, it throws the exception and doesn't load the image.
    The jar file entries are:
    - cs package which has the class files and the source files
    - images folder which has the Leo.bmp image
    - META-INF which MANIFEST.MF
    - .classpath
    - .project
    So the problem that everything works fine, but the only problem is that my JPanel class cannot load the image.

    blinkaj wrote:
    I have created a jar file in which I fill in the client classes, one of which loads an image as below:
    try
    System.out.println("before loading the image is ...");
    url = new URL(getClass().getResource("../images/Leo.bmp"), "Leo.bmp");
    System.out.println("The url is ...=" url);
    image = ImageIO.read(url);
    System.out.println("the image is ...=" image);
    catch (Exception e) { /handled in paintComponent()/System.out.println("image loading unsuccessful..."); }What a freakin' mess. How can you read that rubbish? When posting code for others to examine, please
    1) use the standard forms of indenting and bracketing code, and don't have two or more code statements per line.
    2) post it inside code tags so the formatting and indentation is preserved. To do that, select the code and click the CODE button.
    try
        System.out.println("before loading the image is ...");
        url = new URL(getClass().getResource("../images/Leo.bmp"), "Leo.bmp");
        System.out.println("The url is ...=" url);
        image = ImageIO.read(url);
        System.out.println("the image is ...=" image);
    catch (Exception e)
        /handled in paintComponent()
        /System.out.println("image loading unsuccessful...");
    }Now that I can clearly see the code:
    1) Don't swallow exceptions(3). Either throw them or at the very least report them.
    2) getClass().getResource() will return a valid URL, or null. If it is valid, the extra 'wrapper' you have for creating a URL is unnecessary, and if it is null, adding the
    new URL(null, "Leo.bmp")is pointless.
    3) Hey. Wait a second! That code should not even compile!
    import java.net.*;
    class TestCompile {
        public static void main(String[] args) {
            URL url;
            try
                System.out.println("before loading the image is ...");
                url = new URL(getClass().getResource("../images/Leo.bmp"), "Leo.bmp");
                System.out.println("The url is ...=" url);
                image = ImageIO.read(url);
                System.out.println("the image is ...=" image);
            catch (Exception e)
                /handled in paintComponent()
                /System.out.println("image loading unsuccessful...");
    Running tool: Java Compile
    /media/disk/projects/numbered/all/TestCompile.java:10: ')' expected
                  System.out.println("The url is ...=" url);
                                                      ^
    /media/disk/projects/numbered/all/TestCompile.java:10: illegal start of expression
                  System.out.println("The url is ...=" url);
                                                          ^
    /media/disk/projects/numbered/all/TestCompile.java:13: ')' expected
                  System.out.println("the image is ...=" image);
                                                        ^
    /media/disk/projects/numbered/all/TestCompile.java:13: illegal start of expression
                  System.out.println("the image is ...=" image);
                                                              ^
    /media/disk/projects/numbered/all/TestCompile.java:17: illegal start of expression
                  /handled in paintComponent()
                  ^
    /media/disk/projects/numbered/all/TestCompile.java:17: ';' expected
                  /handled in paintComponent()
                          ^
    /media/disk/projects/numbered/all/TestCompile.java:17: ';' expected
                  /handled in paintComponent()
                                            ^
    7 errors
    Why are you wasting our time by putting some 'approximate representation' of the code you are using?
    Further, your use of the '..' prefix is probably causing problems. Instead try..
    url = getClass().getResource("/images/Leo.bmp");

  • Cant access My Photo stream from macbook air.

    No direct access to My photo stream.
    I can access it fine from a PC.
    The "Web" option is not showing.
    Recent photos taken on mi iPad do get to the cloud ok.
    on latest Mavericks.

    On a Mac you access your Photo Stream in either iPhoto or Aperture. Quotes below are from iCloud: My Photo Stream FAQ
    How do I turn on My Photo Stream?
    After you update your devices and set up your iCloud account, you can easily turn on My Photo Stream on any of your devices:
    iOS devices: Go to Settings > iCloud > Photos (or Photo Stream in iOS 6), then turn on My Photo Stream.
    Mac:
    Go to Apple () > System Preferences > iCloud.
    Select the checkbox for Photos (or Photo Stream).
    Click the Options button and make sure that My Photo Stream is selected.
    Open the app that you want to use with Photo Stream (iPhoto or Aperture) and make sure that My Photo Stream is turned on in that app. You can also adjust your My Photo Stream settings in iPhoto or Aperture Preferences.
    How do I view My Photo Stream?
    iPhone, iPad, or iPod touch: Your photos will appear in the My Photo Stream album in the Photos app. If you're using iOS, you can find your photos by tapping the Photo Stream tab, then tapping the My Photo Stream album. In iOS 5, your photos are in the Photo Stream album.
    Mac: Your photos appear in the Shared albums section under iCloud in iPhoto 9.5 or Aperture 3.5. In earlier versions of iPhoto and Aperture, your photos appear in the Photo Stream section. In iPhoto 9.4 or later or in Aperture 3.4 or later, open the My Photo Stream album.
    PC using Windows 8.1: From the Start screen, click the down arrow in the lower-left corner, then click the iCloud Photos app.
    PC using Windows 8: From the Start screen, select iCloud Photos (or Photo Stream in iCloud Control Panel 2.0 to 2.12).
    PC using Windows 7: Click the Windows Start button, then click Pictures. Click iCloud Photos or Photo Stream under the Favorites menu in the panel on the left. Double-click My Photo Stream to view your photos.
    Apple TV: After signing in with your iCloud account, you can view your photos by choosing iCloud Photos or Photo Stream from the main menu (or selecting Internet > Photo Stream in Apple TV Software Update 5.0).

  • TS4036 I cant access my Itune store from my PC. I have entered my ID but still can't access the store. I have tried removing it and re-installing it but to no avail. I can access the Itunes store with Iphone and Ipad but not my PC.

    I can't access my itune store through my PC. I have tried removing and reinstalling Itunes,but to no avail. I also tried accessing trough I cloud on my pc but it say apple ID not correct but my Apple ID works on all my other devices such as Iphone 4s and Ipad 2. If I go to Icloud.com I can access my account but can't get to Itune store.
    Help
    Thanks
    Dan

    The apps I currently have are for the i phone and i pad but i would like to see this on this computer
    On the Mac Air launch iTunes. Then connect either the iPad or iPhone.
    Select the iPad or iPhone under Devices left side of the iTunes window in the source list.
    Then select Apps from the menu on the right.
    If you don't see the apps listed there, from your iTunes menu bar (top of your screen), click Store > Authorize This Computer.
    See if that makes a difference...

  • Cant access Verizon Mobile App from Iphone(s) since yesterday.....

    Can not access Verizon Email via our Iphones since yesterday (09/04)......Have deleted App multiple times and reloaded, but still does not work.....
    Can access email from laptop with no issues.....

    THIS WORKING FOR ME ...JUST CONFIRMED IT
    Tom
    Freedom Essentials, QIP 7100 1,Bose SOLO TV Sound System,,QIP 7216 P2,M1424WR Rev F, iPad 2 WiFi,iPhone 5,TV SYST INFO Release 1.9.5 Build No. 17.45
    Data Object 39.45
    Attachments:
    iPad 2 and iPhone Email settings 3 2 2014.pdf ‏108 KB

  • Simple update on itunes. now cant access.

    I simply updated iTunes to 11.1.4 and now I cant access my screen sharing from my snow leopard. I could before I updated. sometimes I want to give up on apple products and all the crazy updates.
    any suggestions???

    maybe:
    Troubleshooting iTunes installation on Mac OS X
    http://www.wikihow.com/Uninstall-iTunes MAc and Win

  • Why i cant access asa 8.4 thruogh asdm from outside interface ???

    hi all ,
    plz help e why i cant access asa asdm from outside interface
    my puclic ip on outisde is :
    x.x.55.34
    i changed  portf of asdm to 65000 because i have portforward  ,
    i tried to connect to my ip thriuogh asdm bu :
    x.x.55.34
    x.x.55.34:65000
    but no luck ,
    it succed if i try to connect locally
    here is my sh run command :
    ====================================================
    ASA5505#
    ASA5505# sh run
    : Saved
    ASA Version 8.4(2)
    hostname ASA5505
    enable password qsddsEGCCSH encrypted
    passwd 2KFsdsdbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 2
    interface Vlan1
    nameif ins
    security-level 100
    ip address 10.66.12.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 50
    ip address x.x.55.34 255.255.255.248
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network obj-0.0.0.0
    host 0.0.0.0
    object network localsubnet
    subnet 10.66.12.0 255.255.255.0
    description localsubnet
    object network HTTP-Host
    host 10.66.12.249
    description web server
    object network HTTPS-HOST
    host 10.66.12.249
    description Https
    object network RDP-Host
    host 10.66.12.122
    description RDP host
    object network citrix-host
    host 10.66.12.249
    description citrix
    object service rdp
    service tcp destination eq 3389
    object service https
    service tcp destination eq https
    object service citrix
    service tcp destination eq 2598
    object service http
    service tcp destination eq www
    object network RDP1
    host 10.66.12.249
    object network HTTPS-Host
    host 10.66.12.249
    object network CITRIX-Host
    host 10.66.12.249
    object-group network RDP-REDIRECT
    object-group network HTTP-REDIRECT
    object-group network HTTPS-REDIRECT
    object-group network CITRIX-ICA-HDX-REDIRECTION
    object-group network CITRIX-ICA-SESSION-RELIABILITY-REDIRECTION
    object-group service CITRIX-ICA-HDX
    object-group service CITRIX-SR
    object-group service RDP
    object-group network MY-insideNET
    network-object 10.66.12.0 255.255.255.0
    access-list outside_in extended permit tcp any host 10.66.12.249 eq www
    access-list outside_in extended permit tcp any host 10.66.12.249 eq https
    access-list outside_in extended permit tcp any host 10.66.12.249 eq 2598
    access-list outside_in extended permit tcp any host 10.66.12.122 eq 3389
    access-list outside_in extended permit tcp any host 10.66.12.249 eq citrix-ica
    access-list outside_in extended permit tcp any host x.x.55.34 eq 65000
    access-list outside_in extended permit tcp any host x.x.55.34 eq https
    access-list outside_in extended permit ip any any
    pager lines 24
    mtu ins 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    object network localsubnet
    nat (ins,outside) dynamic interface
    object network HTTP-Host
    nat (ins,outside) static interface service tcp www www
    object network RDP-Host
    nat (ins,outside) static interface service tcp 3389 3389
    object network HTTPS-Host
    nat (ins,outside) static interface service tcp https https
    object network CITRIX-Host
    nat (ins,outside) static interface service tcp citrix-ica citrix-ica
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 62.109.55.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable 65000
    http 10.66.12.0 255.255.255.0 ins
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
        308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
        0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
        30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
        13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
        0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
        20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
        65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
        65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
        30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
        30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
        496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
        74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
        68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
        3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
        63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
        0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
        a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
        9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
        7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
        15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
        63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
        18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
        4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
        81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
        db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
        7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
        ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
        45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
        2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
        1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
        03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
        69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
        02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
        6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
        c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
        69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
        1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
        551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
        1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
        2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
        4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
        b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
        6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
        481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
        b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
        5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
        6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
        6c2527b9 deb78458 c61f381e a4c4cb66
      quit
    telnet 0.0.0.0 0.0.0.0 outside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access outside
    dhcpd address 10.66.12.160-10.66.12.180 ins
    dhcpd dns 212.112.166.22 212.112.166.18 interface ins
    dhcpd enable ins
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username test password P4ttSdddd3SV8TYp encrypted privilege 15
    username ADMIN password 5dddd3ThngqY encrypted privilege 15
    username drvirus password p03BtCddddryePSDf encrypted privilege 15
    username cisco password edssdsdOAQcNEL encrypted privilege 15
    prompt hostname context
    call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DD
    CEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
    : end

    For access over VPN you need:
    management-access inside
    and don't forget:
    ssh inside
    http inside
    I'm guessing you forgot to grant ASDM (http/https) access to the IP addresses used by the VPN?  Can you SSH?  If not, that is your problem to solve first.

  • Images not loaded from WEB-INF/lib/images.jar

    The images are found in root/images/*.gif, but not
    when jarred up and placed in the lib folder. I've looked everywhere
    for a solution but all I've seen is suggestions of other places to put
    the folder, or to add it to the classpath.
    The jar is being loaded but the images are not found. Or at least the images are not showing up - the table where the main image is linked expands to the size of the image when the path is correct.
    Does anyone know the solution to this problem? I don't want to just leave them in the folder at root level, because this does not work if I set a default url pattern for the control servlet.
    Thanks,
    Greg

    The images are found in root/images/*.gif, but not
    when jarred up and placed in the lib folder. I've
    looked everywhere
    for a solution but all I've seen is suggestions of
    other places to put
    the folder, or to add it to the classpath.
    The jar is being loaded but the images are not found.
    Or at least the images are not showing up - the table
    where the main image is linked expands to the size of
    the image when the path is correct.
    Does anyone know the solution to this problem? I don't
    want to just leave them in the folder at root level,
    because this does not work if I set a default url
    pattern for the control servlet.
    Thanks,
    GregIf your planning to make the images accessible by normal html tags - img etc, then they cant be in a jar, and they must be in a location from which the container serves content - i.e not under WEB-INF. Unless you want to write a special servlet which does nothing but read the images and feed them to the client - but I wouldnt recommend that.
    Sounds like your using Struts, and sounds like youre not using weblogic since you wouldnt be able to serve even jsp�s (using forward) from under WEB-INF if you were. Putting jsp�s under WEB-INF sounds like such a good idea when using Struts, but in practice...

  • Problem in sending image from applet to servlet

    dear friends,
    i have a need to send an image from applet to servlet via HttpConnection and getting back that image from applet.
    i am struggling with this sice many hours and got tired by searching any post that would help me but haven't got yet.
    i tried using this code but it dosent make any execution sit right. i got NPE at ImageIcon.getDescription() line;
    at applet side
          jf.setContentPane(getJContentPane());
                     FileDialog fd=new FileDialog(jf,"hi");
                     fd.setMode(FileDialog.LOAD);
                     fd.setVisible(true);   
                     v=new Vector();
                     try{                                                
                               FileInputStream fis=new FileInputStream(new File(fd.getDirectory()+fd.getFile()));      
                               byte[] imgbuffer=new byte[fis.available()];
                               fis.read(imgbuffer);
                               ImageIcon imgdata=new ImageIcon(imgbuffer);
                               v.add(0,imgicon);
                                String strwp ="/UASProject/Storeimage";              
                                URL servletURL = new URL(getCodeBase(),strwp);             
                                HttpURLConnection servletCon = (HttpURLConnection)servletURL.openConnection();       
                                servletCon.setDoInput(true); 
                                servletCon.setDoOutput(true);
                                servletCon.setUseCaches(false);
                                servletCon.setDefaultUseCaches(false);   
                                servletCon.setRequestMethod("POST");     
                                servletCon.setRequestProperty("Content-Type", "application/octet-stream");   
                                servletCon.connect();            
                                ObjectOutputStream oboutStream = new ObjectOutputStream(servletCon.getOutputStream());                     
                                oboutStream.writeObject(v);
                                v.remove(0);
                                oboutStream.flush();      
                                oboutStream.close();  
                                //read back from servlet
                                ObjectInputStream inputStream = new ObjectInputStream(servletCon.getInputStream());
                                 v= (Vector)inputStream.readObject();                     
                                 imgicon=(ImageIcon)v.get(1);
                                 showimg.setIcon(imgicon);
                                 this.getContentPane().validate();
                                 this.validate();  
                                inputStream.close();                                                        
                             //  repaint();
                     }catch(Exception e){e.printStackTrace();}  and this is at servlet side
            try {       
                         Vector v=new Vector();                    
                         ObjectInputStream inputFromjsp = new ObjectInputStream(request.getInputStream());                                      
                          v = (Vector)inputFromjsp.readObject();                                                                                                          
                          imgicon=(ImageIcon)v.get(0);                     
                          inputFromjsp.close();            
                          System.out.println(imgicon.getDescription());                                      
                          v.remove(0);
                          v.add(1,imgicon);
    //sending back to applet
                           response.setContentType("application/octet-stream");
                          ObjectOutputStream oboutstream=new ObjectOutputStream(response.getOutputStream());            
                          oboutstream.writeObject(v);
                          oboutstream.flush();
                          oboutstream.close();
                   } catch (Exception e) {e.printStackTrace();}  i really need your help. please let me out of this headche
    thanks
    Edited by: san_4u on Nov 24, 2007 1:00 PM

    BalusC wrote:
    san_4u wrote:
    how can i made a HttpClient PostMethod using java applets? as i have experience making request using HttpURLConnection.POST method. ok first of all i am going make a search of this only after i will tell. please be onlineOnce again, see link [3] in my first reply of your former topic.
    yeah! i got the related topic at http://www.theserverside.com/tt/articles/article.tss?l=HttpClient_FileUpload. please look it, i am reading it right now and expecting to be reliable for me.
    well what i got, when request made by html code(stated above) then all the form fields and file data mixed as binary data and available in HttpServletRequest.getinputstream. and at servlet side we have to use a mutipart parser of DiskFileItemFactory class that automatically parse the file data and return a FileItem object cotaing the actual file data,right?.You can also setup the MultipartFilter in your environment and don't >care about it further. Uploaded files will be available as request attributes in the servlet.is the multipartfilter class file available in jar files(that u suggested to add in yours article) so that i can use it directly? one more thing the import org.apache.commons.httpclient package is not available in these jar files, so where can got it from?
    one mere question..
    i looked somewhere that when we request for a file from webserver using web browser then there is a server that process our request and after retrieving that file from database it sends back as response.
    now i confused that, wheather these webservers are like apache tomcat, IBM's webspher etc those processes these request or there is a unique server that always turned on and process all the request?
    because, suppose in an orgnisation made it's website using its own server then, in fact, all the time it will not turned on its server or yes it will? and a user can make a search for kind of information about this orgnisation at any time.
    hopes, you will have understand my quary, then please let me know the actual process
    thanks
    Edited by: san_4u on Nov 25, 2007 11:25 AM

Maybe you are looking for