Cardinality- Interface

Hi, what is meant by Cardinality in interfaces design? generally used values are 1:1 or 1:n. please explain the meaning of this code? thank you.

Raju,
Cardinality is a mathematical property of relationships.  When you first design a relationship, cardinality is one of the first definitions you must make.  The concept of relationships is used widely in systems designed atop relational databases (such as SAP).
In 1:1, object "A" will have a relationship only with related object "a"
In 1:n, object "A" can have a relationship with 'no object',  'object a1', 'object a2', ... 'object an'
Generally, when one designs a new interface, it is important to consider cardinality relationships between objects of the source system and any related objects of the destination system(s).  You normally assume that the internal cardinality of the objects in the existing systems has already been settled.  If the internal cardinality of an object from source system differs from the internal cardinality of the related object contained in the destination system, then these two cardinalities must be somehow brought into alignment, or otherwise accommodated in the interface design.
This question does not appear to be relevant to SAP software.  This forum is not intended to be a classroom, but for dealing with specific SAP software related issues.  I suggest that if your interest in this subject persists, you should consult a textbook about mathematical concepts.  If you have a specific question about a particular SAP interface, please post it.
Best Regards,
DB49

Similar Messages

  • External component usage with interface node

    Hi everyone,
    I have component A , which has an interface node with Input element checked:
    Nodes     
    Node Name     IF_HROBJID
    Interface Node     1
    Input Element (Ext.)     1
    Dictionary structure     ZHR_HROBJID_LIST
    Cardinality     0..n
    I have another component: Component B Where I want to bind a table to this interface node.
    In component B :
    1. I definied the Componenet Usage of component B in the componenet controller.
    2. I drag & drop the IF_HROBJID node  to the component controller's context (the node is mapped)
    But when I try to bind a table, I always get the " The Mapping to Node COMPONENTCONTROLLER.1.IF_HROBJID Has Not Been Completed. "  error.
    nd_if_hrobjid = wd_context->path_get_node( path = 'IF_HROBJID' ).
    nd_if_hrobjid->bind_table( lt_if_hrobjid ).
    Can someone tell me what is the problem, and how can I solve it?
    Thanks
    N.

    Hi,
    Here you are trying to use component A in component B right?
    Then what you need to do is:
    1. Declare the component usage of A say A_USAGE in properties tab of component B.
    2. Create a node say 'DATA' in component controller of component B. The node 'DATA' would have the same structure as the node in your component A.
    3. Fill the node 'DATA' in component controller's method.
    4. Under your webdynpro component B, you will see Component Usages -> A_USAGE. open interface controller inside that.
        Goto context tab and drag the 'DATA' node from component controller of B on to the node in interface controller.
    Hope this is clear!
    Best Regards,
    Srilatha

  • Multimapping for Synchronous interfaces.

    Hi,
    Is it possible to do multi mapping for synchronous interfaces.
    I have observed that when the cardinality of the target service  interface is changed to 0:unbounded , the response message mapping  tab disappears from operation mapping.
    Can anyone please suggest how it can be handled?
    I have a requirement to call a webservice and then write multiple files from the webservice response.

    Hi Soumya,
    i dont think so ...if you think theroitically. you are doing multimapping   where u  have a N:M relation... so it will be difficult match the respose directly.
    Since your scenario is syncrhronous, u have to rember the identity of source messgaes and then u need to reply back to those same identitiies. That means u have to use correlations  and that can be achived by BPM.

  • Cardinality changes are not reflecting inbound proxy

    Hi Experts,
    while doing a syncronous senario in BPM with inbound proxy. i was required to change the cardinality from the existing request(source)  structure in inbound service interface,
    once i did the cardinality changes in the request(source) External definition,i could able to see the changes in PI. Then proxy is regenarated to see the new changes of the cardinality. But it reflects to the both input(request) and output(response) of the inbound proxy structure cardinality.
    Please help in this regard.
    Regards,
    Sasi

    Hi Vijaya,
    Thanks for your input, i did the same,but still its not reflecting in the output structure of the inbound proxy.
    Please provide some input to solve this issue.
    Regards,
    Mahakrishnan T.

  • Web dynpro Interface context mapping

    Hi All.
    I shall tell my problem with a very simple scenario that anybody could implement in 2 min.
    Webdynpro Interface component -> Z_INTER; context node: ORDER_VALUES, cardinality 0..n; table: VBAK, select VBELN.
    That's it.
    Now, Webdynpro component : Z_COMP -> Used component -> Z_INTER.
    Inside component controller, I declare usage of Z_INTER. Then do a direct mapping of ORDER_VALUES from Z_INTER to Z_COMP.
    So the context node ORDER_VALUES is created in the Z_COMP component controller.
    That's it.
    Inside WDDOINIT() method of comp controller, read the context node's attribute VBELN.
    The line:
    elem_order_values = node_order_values->get_element( ).
    gives a dump saying that:
    The following error text was processed in the system : Error when Creating Component Z_INTER. Z_INTER Is a Component Interface, Therefore, an Instance Cannot Be Created. Name of Component May Not Be Specified. (Used Component: Z_COMP, Component Usage: USAGE1)
    Can anybody guide me how do we map interface context? I guess I am not getting the concept and am doing some fundamental mistake.
    Thanks !

    Hi Aishi,
    When you use a component interface, you cannot declare it as a component usage. You need to add it under 'Implemented interfaces' and say 'reimplement'. If you want an interface node mapping between 2 components, then you have to declare a normal component. Specify the node as an 'interface node', which means it is visible to components using this component. And then do the mapping.
    Regards
    Nithya

  • Multi_no_lead and cardinality conflict

    Hi,
    I have a problem with "multi_no_lead" and "cardinality". The node which i bind with my ALV has 0..n cardinality and 0..n selection.
    I must choose more than one rows, then i have added these codes : 
    CALL METHOD l_value->if_salv_wd_table_settings~set_selection_mode
        EXPORTING
          value = cl_wd_table=>e_selection_mode-multi_no_lead.
    With Event1 i read the selected more than one rows and change the data. It works.
    But now i want to see the details of only one selected row with a different event(Event2).This event reads just the context but it doesn't work. I take that error :
    "Adapter error in &VIEW_ELEMENT_TYPE& "PER_IN" of view "/XXX/XX_WEB.EXPENSE_DETAIL": Context binding of property VALUE cannot be resolved: Lead selection not set for context node EXPENSE_DETAIL.1.GT_MAIN"
    How can i solve it?
    Thanks...

    Hi Adi,
    Regarding your problem that you have add the alv table a column and give it "link". When you click that link,you want to show the details of selected line. But it doesn't work and gives that error.
    For this you will do one thing .
    Take the ALV event ON_CLICK and within you will get the index of row for which you click the link.
    After this you can read the context node and based on the index you can read the data from the context node.
    Suppose I hv created a employee details node EMP_DETAIL in the component controller.
    and I hv mapped to the view controller.
    Navigate to the methods tab of view  and create event handler method onClick for the On_CLICK event of the ALV component in the view.
    This ON_CLICK  is type ref of IF_SALV_WD_TABLE_CLICK interface .
    The  check this code.
    METHOD on_click .
      DATA lo_nd_emp_detail TYPE REF TO if_wd_context_node.
      DATA lo_el_emp_detail TYPE REF TO if_wd_context_element.
      DATA lt_emp_detail TYPE wd_this->elements_emp_detail.
      DATA ls_emp_detail LIKE LINE OF lt_emp_detail.
      DATA lv_index TYPE i.
      navigate from <CONTEXT> to <EMP_DETAIL> via lead selection
      lo_nd_emp_detail = wd_context->get_child_node( name = wd_this->wdctx_emp_detail ).
      @TODO handle not set lead selection
      IF lo_nd_emp_detail IS INITIAL.
      ENDIF.
      get all declared attributes
      lo_nd_emp_detail->get_static_attributes_table(
        IMPORTING
          table = lt_emp_detail ).
      lv_index = r_param->index.
      READ TABLE lt_emp_detail INTO ls_emp_detail INDEX lv_index .
    ENDMETHOD.
    You can also check this link [Using ON_CLICK Event in the ALV Table|https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/bd28494a-0801-0010-45a3-fc359d82d3e8]
    Regard
    Manoj Kumar

  • Displaying checkbox using Class interface

    Hi,
    Is it possible to display a checkbox in top-of-page for an ALV report using the class interface "cl_dd_document"?
    Note: I have already tried the method "add_icon" but it doesnt seem to be working. So the procedure along with sample coding would be more helpful.

    To get the configuration for one particular service from ConfigurationService:
    String PID_MQTT_DATA_TRANSPORT = "org.eclipse.kura.core.data.transport.mqtt.MqttDataTransport";
    ComponentConfiguration mqttConfiguration = m_configurationService.getComponentConfiguration(PID_MQTT_DATA_TRANSPORT);
    Map<String,Object> mqttConfigurationProperties = mqttConfiguration.getConfigurationProperties();
    This will get the MqttDataTransportService configuration, you can ask the configuration of any service registered providing its PID.
    This means you need the ConfigurationService available in your service. Just ask OSGi to inject it.
    public class YourService implements ConfigurableComponent {
    private ConfigurationService m_configurationService;
    public void setConfigurationService(ConfigurationService configurationService) {
    m_configurationService = configurationService;
    public void unsetConfigurationService(ConfigurationService configurationService) {
    m_configurationService = null;
    // Your methods here ...
    In your OSGI-INF/yourservice.xml
    <scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0"
    name="your.Service"
    activate="activate"
    deactivate="deactivate"
    enabled="true"
    immediate="true"
    configuration-policy="ignore">
    <implementation class="your.ServiceImpl"/>
    <property name="service.pid" type="String" value="your.Service"/>
    <service>
    <provide interface="your.Service"/>
    </service>
    <reference name="ConfigurationService"
    policy="static"
    bind="setConfigurationService"
    unbind="unsetConfigurationService"
    cardinality="1..1"
    interface="org.eclipse.kura.configuration.ConfigurationService"/>
    </scr:component>
    Hope this small example will be helpful.

  • Changing Node's cardinality

    Hi guys,
    Is it possible to code and change the cardinality of the node at runtime e.g. NodeA which has the structure below? Does anyone know the code to change it?
    Context
    - NodeA

    Zhenmin,
    As far as I know, it is not possible to change the node's cardinality at runtime. By the way, What is your reason for changing an existing node's cardinality?
    A Node's cardinality consists of a pair of values (0,1 / 1,1 / 0,n / 1,n). First value is represented internally as a Boolean value 'Mandatory' and second value is represented as Boolean value 'Multiple'. You can read these values with
    IWDNodeInfo.isMandatory()
    and
    IWDNodeInfo.isMultiple()
    methods but there are no methods to change them at runtime.
    You can however, create a node at runtime and define its cardinality too.
    use interface [IWDNodeInfo's method addchild|http://help.sap.com/javadocs/NW04s/current/wd/com/sap/tc/webdynpro/progmodel/api/IWDNodeInfo.html#addChild(java.lang.String,%20java.lang.Class,%20boolean,%20boolean,%20boolean,%20boolean,%20boolean,%20boolean,%20java.lang.Object,%20com.sap.tc.webdynpro.progmodel.api.IWDNodeCollectionSupplier,%20com.sap.tc.webdynpro.progmodel.api.IWDNodeCollectionDisposer)] to do so. 
    public IWDNodeInfo addChild(String name,
                                Class elementClass,
                                boolean singleton,
                                boolean mandatory,
                                boolean multiple,
                                boolean mandatorySelection,
                                boolean multipleSelection,
                                boolean initializeLeadSelection,
                                String dataType,
                                IWDNodeCollectionSupplier supplier,
                                IWDNodeCollectionDisposer disposer)
    Hope this helps.
    Vishwas.

  • Cardinality & singleton

    HI Friends
    Can anyone explain me regarding "cardinality&Singleton"
    with a small example
    I have gone through some of the blogs but I am not getting that much clarity regarding these terms
    Thanks in advance

    Hi,
    The cardinality property
    The cardinality property is composed of a pair of values that control the maximum and minimum number of elements may contain at runtime.
    The cardinality property may have four possible values:
    •     0..1     Zero or one
    •     0..n     Zero or more
    •     1..1     One and only one
    •     1..n     One or more
    The first part of the cardinality describes the minimum number of element ’s element collection may contain.  This value is either zero or one, and is stored as a Boolean value.  This value can be obtained at runtime by calling the method node.getNodeInfo().isMandatory().
    The second part of the cardinality describes the maximum number of elements ’s element collection may contain.  This value is either a 1 or an n (meaning many) and is stored as a Boolean value (false = 1, true = n).  This value can be obtained at runtime by calling method node.getNodeInfo().isMultiple().
    If has a cardinality of 1..<something>, then it can be assumed that after the context has been initialised, there will be at least one element present in the node collection.  This element is known as the default element and cannot be deleted!
    If you attempt to perform some action on a node that would violate the constraints of the cardinality, then you will get a runtime exception in the context.  E.G., trying to add a second element to a node of cardinality 0..1, or trying to delete the last element from a node of cardinality 1..n.
    The singleton property
    The singleton property critically affects the relationship between the child node and its parent node .
    If is declared at design time, then the generated interface for this node will vary depending on whether it is a singleton or non-singleton node.
    Important:
    •     All non-singleton child nodes are associated with their parent node on a per parent element basis
    There is a one-to-one relationship between each element in the parent node’s element collection and the corresponding child node.
    If has n elements in its element collection, then you will have n distinct instances of the non-singleton child node .
    Non-singleton child nodes can be created by their respective parent element.
    •     Singleton child nodes however, are associated with their parent node on a per node basis.
    Irrespective of the number of elements in the parent node’s element collection, there will only ever be one instance of the singleton child node .
    The singleton child node holds the data relevant for the element at the lead selection in the parent node’s element collection.
    Singleton child nodes must be created by their parent node.  Since there can only ever be one instance of a singleton child node, it is impossible for an element in a parent node collection to create a singleton child node.
    From Inside Webdynro For Java
    Regards
    Ayyapparaj

  • Open Interface Rejects - SQL Report

    Hi guys, I'm trying to help out some folks in AP with an easier access to view Open Interface rejects. I already knew the relation between AP_INVOICES_INTERFACE and AP_INTERFACE_REJECTIONS was INVOICE_ID AND PARENT_ID (respectively). Now I've seen that some invoices also have a relation between AP_INVOICE_LINES_INTERFACE and AP_INTERFACE_REJECTIONS, same columns related (INVOICE_ID AND PARENT_ID respectively).
    What I'm having a problem with, maybe I've just been sitting here too long, but I cannot get it all into one report.
    I tried this, but it's giving me way more records than it should:
    SELECT AIR.CREATION_DATE
    , AIR.REJECT_LOOKUP_CODE
    , AII.PO_NUMBER
    , AII.GROUP_ID
    , AII.VENDOR_NUM
    , AII.INVOICE_NUM
    , AII.INVOICE_DATE
    , AII.INVOICE_AMOUNT
    , AII.SOURCE
    FROM AP.AP_INTERFACE_REJECTIONS AIR
    , AP.AP_INVOICES_INTERFACE AII
    , AP.AP_INVOICE_LINES_INTERFACE AILI
    WHERE (AII.INVOICE_ID = AIR.PARENT_ID AND AII.ORG_ID = 162)
    OR (AILI.INVOICE_ID = AIR.PARENT_ID AND AILI.ORG_ID = 162)
    Any thoughts on where I mucked it up or how I could actually go about this? What shows in the actual Open Interface app is a good start, it's just missing some fields like vendor name and reject lookup code.
    Thanks for any help!

    945273 wrote:
    Hi guys, I'm trying to help out some folks in AP with an easier access to view Open Interface rejects. I already knew the relation between AP_INVOICES_INTERFACE and AP_INTERFACE_REJECTIONS was INVOICE_ID AND PARENT_ID (respectively). Now I've seen that some invoices also have a relation between AP_INVOICE_LINES_INTERFACE and AP_INTERFACE_REJECTIONS, same columns related (INVOICE_ID AND PARENT_ID respectively).
    What I'm having a problem with, maybe I've just been sitting here too long, but I cannot get it all into one report.
    I tried this, but it's giving me way more records than it should:
    SELECT AIR.CREATION_DATE
    , AIR.REJECT_LOOKUP_CODE
    , AII.PO_NUMBER
    , AII.GROUP_ID
    , AII.VENDOR_NUM
    , AII.INVOICE_NUM
    , AII.INVOICE_DATE
    , AII.INVOICE_AMOUNT
    , AII.SOURCE
    FROM AP.AP_INTERFACE_REJECTIONS AIR
    , AP.AP_INVOICES_INTERFACE AII
    , AP.AP_INVOICE_LINES_INTERFACE AILI
    WHERE (AII.INVOICE_ID = AIR.PARENT_ID AND AII.ORG_ID = 162)
    OR (AILI.INVOICE_ID = AIR.PARENT_ID AND AILI.ORG_ID = 162)
    Any thoughts on where I mucked it up or how I could actually go about this? What shows in the actual Open Interface app is a good start, it's just missing some fields like vendor name and reject lookup code.
    Thanks for any help!I don't know the table strructures or relationships, but based on what you said, I think you want something more like:
    SELECT air.creation_date, air.reject_lookup_code, aii.po_number, aii.group_id,
           aii.vendor_num, aii.invoice_num, aii.invoice_date, aii.invoice_amount,
           aii.source
    FROM ap.ap_interface_rejections air, ap.ap_invoices_interface aii,
         ap.ap_invoice_lines_interface aili
    WHERE ali.invoice_id = alii.invoice_id and
          ali.invoice_id = air.parent_id and
          aii.org_id = 162You may need/want to add the org_cd predicate to the interfact lines as well, depending if there could be invoices with the same id in multiple orgs.
    Assuming you have the relations correct, this should give you a row for every line on every invoice that has a row in the ap_interface_rejections table. It might be worthwhile to look at the ap_interface_rejections table to see if it has an analog for the invoice line number, which could also be used in the join, to get a more specific result set.
    John

  • Logical interface in solaris 10

    Hi there,
    I need to configure logical interface in a solaris 10 3/05 server. After reading the Solaris 10 IP services manual, I am not quite sure what to do. All the examples and explanation are about using the new subcommand addif of ifconfig. It was not clear in the documentation if the setting logical interfaces via addif will persist across boot.
    Can one still configure logical interface in Solaris 10 in a more traditional way like in Solaris 8? In an Solaris 8 server I will do the following.
    Let's assume I want to configure in a solaris 8 server a logical interface named hme0:1 with IP address 192.168.20.28 with netmask 255.255.255.0 for hostname host001
    # cat /etc/hostname.hme0:1
    host001
    ^D
    # echo "192.168.20.28 host001" >> /etc/inet/hosts
    # echo "192.168.20.0 255.255.255.0" >> /etc/inet/netmasks
    # reboot -- -r
    Can one still do that in solaris 10 3/05 server?

    Hi there,
    I need to configure logical interface in a solaris 10
    3/05 server. After reading the Solaris 10 IP services
    manual, I am not quite sure what to do. All the
    examples and explanation are about using the new
    subcommand addif of ifconfig. It was not clear in the
    documentation if the setting logical interfaces via
    addif will persist across boot.No. No 'ifconfig' command is persistent.
    Can one still configure logical interface in Solaris
    10 in a more traditional way like in Solaris 8? In an
    Solaris 8 server I will do the following.
    Let's assume I want to configure in a solaris 8
    server a logical interface named hme0:1 with IP
    address 192.168.20.28 with netmask 255.255.255.0 for
    hostname host001
    # cat /etc/hostname.hme0:1
    host001
    ^D
    # echo "192.168.20.28 host001" >> /etc/inet/hosts
    # echo "192.168.20.0 255.255.255.0" >>
    /etc/inet/netmasks
    # reboot -- -r
    Can one still do that in solaris 10 3/05 server?Absolutely.
    You don't need to reboot (you can run ifconfig for this boot and let the files do the work next time) and the -r doesn't do anything with interfaces (expecially virtual interfaces) anyway.
    Darren

  • Unable to see interface on ASA 5510 Firewall

    Hi All,
    I am unable to see 4th interface on my firewall i.e fastether0/3 on my firewall ASA 5510.
    Below is the output.
    ciscoasa# sh int ip br
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                x.x.x.x           YES CONFIG up                    up
    Ethernet0/1                x.x.x.x           YES CONFIG up                    up
    Ethernet0/2                unassigned      YES unset  administratively down down
    Internal-Control0/0        127.0.1.1       YES unset  up                    up
    Internal-Data0/0           unassigned      YES unset  up                    up
    Management0/0              192.168.1.1     YES CONFIG up                    up
    Please suggest what could be the reason.
    Regards
    Pankaj

    Hi Ramraj,
    Even i have the base license for my ASA 5510 which is showing all the 4 interfaces in sh ver. I don't think so license would be an issue. There should be some IOS code bug that needs to be upgraded. If this goes for an OS upgrade it should get resolved.
    Its not showing up in sh ver . As Karsten said he might be running on old IOS version.
    fy-a# sh ver
    Cisco Adaptive Security Appliance Software Version 8.4(4)1
    Device Manager Version 6.4(5)
    Compiled on Thu 14-Jun-12 11:20 by builders
    System image file is "disk0:/asa844-1-k8.bin"
    Config file at boot was "startup-config"
    fy-a up 1 day 1 hour
    Hardware:   ASA5510, 1024 MB RAM, CPU Pentium 4 Celeron 1600 MHz
    Internal ATA Compact Flash, 256MB
    BIOS Flash M50FW016 @ 0xfff00000, 2048KB
    Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
                                 Boot microcode   : CN1000-MC-BOOT-2.00
                                 SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
                                 IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.06
                                 Number of accelerators: 1
    0: Ext: Ethernet0/0         : address is 2c54.2d0c.8f1a, irq 9
    1: Ext: Ethernet0/1         : address is 2c54.2d0c.8f1b, irq 9
    2: Ext: Ethernet0/2         : address is 2c54.2d0c.8f1c, irq 9
    3: Ext: Ethernet0/3         : address is 2c54.2d0c.8f1d, irq 9
    4: Ext: Management0/0       : address is 2c54.2d0c.8f1e, irq 11
    5: Int: Not used            : irq 11
    6: Int: Not used            : irq 5
    Licensed features for this platform:
    Maximum Physical Interfaces       : Unlimited      perpetual
    Maximum VLANs                     : 50             perpetual
    Inside Hosts                      : Unlimited      perpetual
    Failover                          : Disabled       perpetual
    VPN-DES                           : Enabled        perpetual
    VPN-3DES-AES                      : Enabled        perpetual
    Security Contexts                 : 0              perpetual
    GTP/GPRS                          : Disabled       perpetual
    AnyConnect Premium Peers          : 2              perpetual
    AnyConnect Essentials             : Disabled       perpetual
    Other VPN Peers                   : 250            perpetual
    Total VPN Peers                   : 250            perpetual
    Shared License                    : Disabled       perpetual
    AnyConnect for Mobile             : Disabled       perpetual
    AnyConnect for Cisco VPN Phone    : Disabled       perpetual
    Advanced Endpoint Assessment      : Disabled       perpetual
    UC Phone Proxy Sessions           : 2              perpetual
    Total UC Proxy Sessions           : 2              perpetual
    Botnet Traffic Filter             : Disabled       perpetual
    Intercompany Media Engine         : Disabled       perpetual
    This platform has a Base license.
    Serial Number: JMX1AXXXXX
    Running Permanent Activation Key: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Configuration register is 0x1
    Configuration has not been modified since last system restart.
    fy-a#
    Ramraj please do correct me if am wrong.
    Please do rate if the given information helps.
    By
    Karthik

  • ASA 5505 backup interface

    Hello,
    I have setup ASA 5505 with 2 ISP, named outside (primary)  and backup, the scenario is if outside down, then backup will take over, it works now.
    But it is not working when the primary connection cannot reach the gateway with the interface still up.
    Is it possible when the primary connection cannot reach the gateway then backup automatically take over?
    Thanks before..
    My configuration is:
    ASA Version 8.2(1)
    hostname cisco
    domain-name default_domain
    enable password ********* encrypted
    passwd ********* encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 172.10.10.10 255.255.255.0
    interface Vlan3
    no forward interface Vlan2
    nameif backup
    security-level 0
    ip address 172.20.10.10 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 1
    interface Ethernet0/1
    switchport access vlan 2
    interface Ethernet0/2
    switchport access vlan 3
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default domain
    same-security-traffic permit intra-interface
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu backup 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (inside) 1 interface
    global (outside) 1 interface
    global (backup) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    access-group inside_out in interface inside
    access-group outside_in in interface outside
    access-group backup_in in interface backup
    route outside 0.0.0.0 0.0.0.0 172.10.10.1 1
    route backup 0.0.0.0 0.0.0.0 172.20.10.1 254
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd lease 1048575
    dhcpd auto_config outside
    dhcpd address 192.168.1.100-192.168.1.200 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:24af050f332deab3e38eb578f8081d05
    : end

    Hi Amrin,
    you can configure SLA monitoring on ASA and that woudl work fine for you:
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806e880b.shtml
    Hope that helps.
    Thanks,
    Varun

  • Run SAP PI Interfaces 24X7. How

    How I can run PI Interfaces 24X7 to achieve Business Continuity.
    The solution provided as u2013
         Install Separate additional PI System u2013 called as Federation PI.
    Is this solution really applicable?
    Details:
    1.     Our Current Production Landscape holds only One PI System
    2.     These interfaces hold Critical, Sensitive Finance, employee Data posting to ECC etc.
    3.     HA options are available and Planned Outages are communicated with Non-SAP Process teams.
    4.     No performance issues.
    5.     PI Scaling is in progress to balance load on PI System.
    Requirement: We seek PI Production System up and running 24X7 for all above interfaces with out any interruption.
    Below Issues: Makes our PI Production System Shut-down for certain period
    1.     Planned outages
    2.     Un-planned outages
    3.     Upgrades
    4.     Allowed Down-time
    5.     SPOF
    Solution: Federation of SAP PI
    1.     A very good solution u2013 so that we can switch to another PI System when first PI system is down for any reason.
    2.     We need to maintain IR, ID objects of interfaces that we planned for 24X7 in both PI Systems.
    3.     Communication Channels are active in only One PI system.
    4.     Manual activation of Communication Channels is required when we plan to switch Second PI Server.
    That Implies
    5.     There is minimum amount of downtime is present.
    6.     So, 24X7 of runtime is not achievable.
    My Only one Question:
    Is there any automated procedure for this runtime procedure..!!?
    Switching in between PI Systems might be possible.
    But, how we can implement activation of CC in Second PI System with out manual interaction?

    Hi,
    Currently we are about to start the POC for my client, and the scenarion is like this
    We have a ECC system( which will send the IDOC ) and it will be received by my central PI system.( which is is in UK).
    The client is present in multiple locations( UK,AUS,US), they want to install the additional PI boxes in AUS and US and they want to have a federation with central PI system which present in UK.
    we have two scenarios.
    1) The IDOC will trigger from ECC and then it will go to central PI system and then it has to go to local PI system and then to the third party system.
    2) The IDOC will trigger from ECC system and then it has to go to the local PI and then to the central PI box and then to the third party system.
    Can you please let me know how can achieve these two scenarios and how to install local PI boxes in federation with the central PI box.
    Regards,
    Pradeep J

  • I am trying to transfer sound created on a Fantom X7 to my mac and garage band and have gotten so many different directions from others regarding the mode of connection - I am trying to use an interface and usb connection - anybody have advice?

    Good morning!
    I am trying to transfer sound from a FantomX7 keyboard synthesizer to garageband  through an interface (MAudio) and with a usb cable.  I see the image of the sound being recorded but I cannot hear anything - I know that there is a speaker button somewhere that must be muted - but I can't find it .  Can anyone tell me what I am doing wrong.  thanks, Musicmimi.

    Good morning!
    I am trying to transfer sound from a FantomX7 keyboard synthesizer to garageband  through an interface (MAudio) and with a usb cable.  I see the image of the sound being recorded but I cannot hear anything - I know that there is a speaker button somewhere that must be muted - but I can't find it .  Can anyone tell me what I am doing wrong.  thanks, Musicmimi.

Maybe you are looking for