Client's download speed

Hi, i have a 1TB Time capsule (not the newest model), and me and my father are connected to it.
The problem is, when i start downloading something (we have a megaupload premium account),i get around 900kbps and when my father starts downloading too, he gets around 700kbps and i go down to 200kbps.
I have a macbook white with os x 10.5.8, and he has a toshiba satellite with ubuntu 10.04
Why does this happens, even when i started downloading first? what can i do to at least "balance" the download speed?
Thanks in advance,
Message was edited by: Kyriuu
Message was edited by: Kyriuu

Here's a more complete example inferred from the code snippet you provided.  Note the changes to your code in order to provide what appear to be the intended results (convert bytes to megabytes, calculate rate with seconds instead of milliseconds). 
The implementation of the "lastUpdate" variable demonstrates the suggestion from my previous post.
Public Class Form1
Private WithEvents client As New System.Net.WebClient
Private sw As New Stopwatch
Private lastUpdate As Date
Private Async Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
sw.Restart()
Await client.DownloadFileTaskAsync("https://code.msdn.microsoft.com/Simple-Multi-User-TCPIP-1ff0da41/file/135320/5/Simple%20Multi-User%20TCPIP%20Client%20%26%20Server%20using%20TAP.zip", "d:\test\project.zip")
sw.Stop()
End Sub
Private Sub client_DownloadProgressChanged(sender As Object, e As Net.DownloadProgressChangedEventArgs) Handles client.DownloadProgressChanged
If Now.Subtract(lastUpdate).TotalMilliseconds >= 250 OrElse e.ProgressPercentage = 100 Then 'throttle to 4 updates per second
txtDown.Text = "Downloading (" & e.ProgressPercentage.ToString & "%)... (" & (e.TotalBytesToReceive / 1000000).ToString("N2") & " MB) at " & (e.BytesReceived / sw.Elapsed.TotalSeconds).ToString("N2") + " bytes/sec"
lastUpdate = Now
End If
End Sub
End Class
-EDITS-
Sorry, first I miscalculated the download rate, then I cleaned up the progress percentage, and finally I added a check to make sure that the text still displays the final update even if the throttle time hasn't been hit yet.
Reed Kimble - "When you do things right, people won't be sure you've done anything at all"

Similar Messages

  • ASA 5505 Slow download speed

    Hello, as the title states, I have an ASA 5505 at one facility that is only getting around 16mb down on a 100mb circuit. No errors on either interface, and we've tried manually setting port speed and duplex, and auto, (both sides show it negotiating at 100 / full).
    Here is the sanitized config:
    : Saved
    : Written by mlsysadmin at 05:43:12.139 CST Fri Mar 6 2015
    ASA Version 8.2(5) 
    hostname fw01
    domain-name domain.com
    enable password xxxxxxxx encrypted
    passwd xxxxxxxx encrypted
    names
    name x.x.x.x WindStream-External-3100
    interface Ethernet0/0
     switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
     nameif inside
     security-level 100
     ip address 172.16.5.254 255.255.255.0 
    interface Vlan2
     nameif outside
     security-level 0
     ip address WindStream-External-3100 255.255.255.248 
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    dns server-group DefaultDNS
     domain-name materialogic.com
    same-security-traffic permit intra-interface
    object-group network obj-SrcNet
    object-group network obj-amzn
    access-list inside_access_in extended permit ip any any 
    access-list inside_access_in extended permit tcp any any 
    access-list inside_access_in extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list outside_access_in extended permit ip x.x.x.x 255.255.255.248 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit icmp any any 
    access-list outside_access_in extended permit ip 10.10.200.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit icmp 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list outside_access_in extended permit tcp interface outside 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip any 10.10.0.0 255.255.0.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.3.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.4.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.3.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.4.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.2.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.2.0 255.255.255.0 
    access-list amzn-filter extended permit ip 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list amzn-filter extended permit icmp 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list amzn-filter extended permit ip any any 
    access-list <outside_access_in> extended permit ip host 54.240.217.164 host WindStream-External-3100 
    access-list <outside_access_in> extended permit ip host 72.21.209.193 host WindStream-External-3100 
    access-list inside_mpc extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0 
    access-list NORAND extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0 
    access-list outside_cryptomap extended permit ip any 10.10.0.0 255.255.0.0 
    access-list outside_cryptomap extended permit ip 172.16.5.0 255.255.255.0 172.16.4.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.4.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.3.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.5.0 255.255.255.0 172.16.3.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit ip 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit ip 172.17.5.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit tcp 172.17.5.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    pager lines 24
    logging enable
    logging timestamp
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    no asdm history enable
    arp timeout 14400
    nat-control
    global (outside) 1 interface
    nat (inside) 0 access-list acl-amzn
    nat (inside) 1 0.0.0.0 0.0.0.0
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 40.139.91.233 1
    route inside 172.16.2.0 255.255.255.0 172.16.5.1 1
    route inside 172.16.3.0 255.255.255.0 172.16.5.1 1
    route inside 172.16.4.0 255.255.255.0 172.16.5.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL 
    aaa authentication http console LOCAL 
    http server enable
    http server idle-timeout 1440
    http 192.168.1.0 255.255.255.0 inside
    http 172.16.0.0 255.255.0.0 inside
    http 216.43.24.82 255.255.255.255 outside
    http 64.199.141.26 255.255.255.255 outside
    snmp-server host inside 10.10.10.20 community mlogic
    snmp-server location 3100 Communications room
    no snmp-server contact
    snmp-server community mlogic
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt connection timewait
    sysopt connection tcpmss 1387
    sla monitor 1
     type echo protocol ipIcmpEcho 10.10.0.1 interface outside
     frequency 5
    sla monitor schedule 1 life forever start-time now
    crypto ipsec transform-set transform-amzn esp-aes esp-sha-hmac 
    crypto ipsec security-association lifetime seconds 3600
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ipsec security-association replay window-size 128
    crypto ipsec df-bit clear-df outside
    crypto map amzn_vpn_map 1 match address acl-amzn
    crypto map amzn_vpn_map 1 set pfs 
    crypto map amzn_vpn_map 1 set peer 54.240.217.164 72.21.209.193 
    crypto map <amzn_vpn_map> 1 match address acl-amzn
    crypto map <amzn_vpn_map> 1 set pfs 
    crypto map <amzn_vpn_map> 1 set peer 54.240.217.164 72.21.209.193 
    crypto map <amzn_vpn_map> 1 set transform-set transform-amzn
    crypto map <amzn_vpn_map> interface outside
    crypto isakmp identity address 
    crypto isakmp enable outside
    crypto isakmp policy 201
     authentication pre-share
     encryption aes
     hash sha
     group 2
     lifetime 28800
    telnet timeout 5
    ssh 172.16.0.0 255.255.0.0 inside
    ssh x.x.x.x 255.255.255.255 outside
    ssh x.x.x.x 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 216.171.120.36 source outside
    webvpn
    group-policy filter internal
    group-policy filter attributes
     vpn-filter value amzn-filter
    username mlsysadmin password E9OpTNVP3nVbSPSb encrypted privilege 15
    username mlsysadmin attributes
     vpn-group-policy DfltGrpPolicy
     vpn-access-hours none
     vpn-simultaneous-logins 3
     vpn-idle-timeout 30
     vpn-session-timeout none
     vpn-filter none
     ipv6-vpn-filter none
     vpn-tunnel-protocol IPSec l2tp-ipsec svc 
     password-storage disable
     group-lock none
    tunnel-group 54.240.217.164 type ipsec-l2l
    tunnel-group 54.240.217.164 general-attributes
     default-group-policy filter
    tunnel-group 54.240.217.164 ipsec-attributes
     pre-shared-key IySxccNmUch6G3dVSgEwBjjGX7bOAcO3
     isakmp keepalive threshold 10 retry 3
    tunnel-group 72.21.209.193 type ipsec-l2l
    tunnel-group 72.21.209.193 general-attributes
     default-group-policy filter
    tunnel-group 72.21.209.193 ipsec-attributes
     pre-shared-key vy.pOkCV01pEtmxe.QNk96xK6Uo_2tD.
     isakmp keepalive threshold 10 retry 3
    class-map NORAND
     match access-list inside_mpc
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map 
      inspect ftp 
      inspect h323 h225 
      inspect h323 ras 
      inspect rsh 
      inspect rtsp 
      inspect esmtp 
      inspect sqlnet 
      inspect skinny  
      inspect sunrpc 
      inspect xdmcp 
      inspect sip  
      inspect netbios 
      inspect tftp 
      inspect ip-options 
    policy-map NORAND
     class NORAND
      set connection random-sequence-number disable
      set connection advanced-options tcp-state-bypass
    policy-map TRAFFIC_SHAPING
     class class-default
      shape average 100000000
    service-policy global_policy global
    service-policy NORAND interface inside
    service-policy TRAFFIC_SHAPING interface outside
    smtp-server 206.225.164.242
    prompt hostname context 
    no call-home reporting anonymous
    : end
    Here are show interface command outputs:
    fw01# show interface ethernet 0/0
    Interface Ethernet0/0 "", is up, line protocol is up
      Hardware is 88E6095, BW 100 Mbps, DLY 100 usec
            Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
            Input flow control is unsupported, output flow control is unsupported
            Available but not configured via nameif
            MAC address fc5b.397f.dbd5, MTU not set
            IP address unassigned
            23888810 packets input, 6278082364 bytes, 0 no buffer
            Received 7728 broadcasts, 0 runts, 0 giants
            0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
            0 pause input, 0 resume input
            0 L2 decode drops
            35886 switch ingress policy drops
            42947220 packets output, 57958727970 bytes, 0 underruns
            0 pause output, 0 resume output
            0 output errors, 0 collisions, 0 interface resets
            0 late collisions, 0 deferred
            0 rate limit drops
            0 switch egress policy drops
            0 input reset drops, 0 output reset drops
    fw01# show interface ethernet 0/1
    Interface Ethernet0/1 "", is up, line protocol is up
      Hardware is 88E6095, BW 100 Mbps, DLY 100 usec
            Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
            Input flow control is unsupported, output flow control is unsupported
            Available but not configured via nameif
            MAC address fc5b.397f.dbd6, MTU not set
            IP address unassigned
            59448427 packets input, 58925402473 bytes, 0 no buffer
            Received 547758 broadcasts, 0 runts, 0 giants
            0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
            0 pause input, 0 resume input
            0 L2 decode drops
            58718 switch ingress policy drops
            37419921 packets output, 8188660665 bytes, 0 underruns
            0 pause output, 0 resume output
            0 output errors, 0 collisions, 0 interface resets
            0 late collisions, 0 deferred
            0 rate limit drops
            0 switch egress policy drops
            0 input reset drops, 0 output reset drops
    When we connect a laptop to the router directly, we are able to get the expected speeds. When we connect through the ASA, download speed is topping out around 16mb, while upload is a consistent 75mb+

    Have you tried running without the "service-policy TRAFFIC_SHAPING interface outside" ? Just to check.

  • AirPort slowing download speeds, from 99.6 mbps direct connect to 32 mbps through AirPort.  Any ideas?

    Has anyone experience their Airport slowing the download speeds?

    You need to spell out the whole thing.
    nytoaz72 wrote:
    Has anyone experience their Airport slowing the download speeds?
    How are you measuring.. by wireless yes, you will experience some reduction.. maybe a lot depending on range of client and wireless type.. is this AC version or earlier airport? What is the link speed of the wireless.. and are multiple devices connected??
    If this is purely ethernet, then something is wrong.. we need to know exactly what model airport you are talking about.. A1xxx from the side or base please??

  • 8x slower download speed than Windows laptop on cable

    I have cable internet (in Luxembourg). The provider uses Scientific Atlanta EPC2100R2 modems. Download speed is around 1 Mbps, rather than the 8 Mbps advertised. When technicians come to investigate, the connection is 8 Mbps on their Windows laptop. They claim to have several clients on Macs, and none have the problem.
    My modems also get fried very often. The provider had to replace my modem twice in four months.
    The problem persisted after I replaced my iMac. It may be a software issue, though, as I migrated my old Mac to the new one.
    My Mac works fine with ADSL. I haven't tried it with other cable providers.
    What can I do? I tried creating new locations in Network preferences, to no avail. Always the same result.

    wireless is unreliable for the speedtest as it varies depending on home conditions so only way accpeted is by cable.  if that also shows a problem then you can take it from there
    If you like a post, or want to say thanks for a helpful answer, please click on the Ratings star on the left-hand side of the post.
    If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.

  • Very slow download speed with intermittent halts

    Need some help.
    I run Apple os/x latest version and have since yesterday begun to experience constant very slow download speeds.
    I have rebooted the router and I have reset it. I have tested with wireless and wired into router. No real change.
    The results are below and are pretty consistent no matter when or with what computer I test it with.
    This is very frustrating and I would like to know if anyone has experienced this and if there is anything I can do before calling for service.
    Thank you in advance.
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    SendBufferSize set to [131768]
    running 10s outbound test (client to server) . . . . . 5.44Mb/s
    running 10s inbound test (server to client) . . . . . . 1.94Mb/s
    ------ Client System Details ------
    OS data&colon; Name = Mac OS X, Architecture = x86_64, Version = 10.8.2
    Java data&colon; Vendor = Apple Inc., Version = 1.6.0_37
    ------ Web100 Detailed Analysis ------
    Client Receive Window detected at 359104 bytes.
    10 Mbps Ethernet link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.
    Web100 reports the Round trip time = 22.89 msec; the Packet size = 1448 Bytes; and
    There were 159 packets retransmitted, 288 duplicate acks received, and 394 SACK blocks received
    The connection stalled 9 times due to packet loss
    The connection was idle 2.01 seconds (16.75%) of the time
    This connection is sender limited 35.49% of the time.
    This connection is network limited 64.51% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch
    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: ON
    RFC 1323 Window Scaling: ON
    Information: Network Middlebox is modifying MSS variable
    Server IP addresses are preserved End-to-End
    Information: Network Address Translation (NAT) box is modifying the Client's IP address
    Server says [71.100.xxx.xxx] but Client says [192.168.1.9]

    Both wired or wireless.
    auto - negotiate 
    Thank you.

  • Can a N router provide faster speed to client than modem speed?

    Excuse my off-thread basis, but the knowledge I need will be here I felt.
    I have a 2.5m download speed from my DSL modem and am using an 802 -G router to serve 2 clients. If I bought a 802 - N router could it actually server the clients faster than the incoming speed my DSL modem provides?
    Thanks

    Bob Timmons wrote:
    By "2.5m", I assume that you mean 2.5 Mbps. An 802.11g router is capable of 54 Mbps. An 802.11n wireless router is capable of 130 Mbps at 2.4 GHz and up to 300 Mbps at 5 GHz.
    The the speed on your local network is much faster than your download speed from the internet.
    Hi Bob, thanks for taking the time.
    Yes, I did mean 2.5mbps. And I understand that the link/speed from router to client is faster than from modem to router.
    What I'm trying to understand is at what point in modem download speed does it make sense to upgrade to an N router? Can you explain this, keeping all numbers in a laymen's context? I don't understand the Mbps at x gigahertz ratios, or their meaning. Thanks
    I don't understand why one would need an N router, even with a 10Mbps modem download speed? If the bottle neck is 10Mbps, what does it matter what the router serves to the client?
    ( I don't need wider wireless coverage, so I'm only talking in terms of how fast a web page will load, for example. )
    Thanks

  • 3meg DSL Download speed running at dial-up speed

    Since last week I’ve been getting DSL download speeds that are basically dial-up speeds.  I have the 3 meg plan and for the past 10 years or so, I came close to a 2 meg download connection speed regularly.
    Last week my download speed basically disappeared.  I spent hours on the phone with Verizon Tech Support during the week.  (Their standared 72 hours to assign a service call after creating a service ticket is bogus.) A Verizon DSL tech spent 5 hours at my house on Saturday and said the problem is on VERIZON’S END with their servers.  He did it all, replaced internal wires, used his modem for the tests, checked speeds at the NID, took the router out of play, tried to get new wires from the service on the street, and still could not resolve the issue. 
    I show the correct 3360/864kbs connection on my DSL Modem (Actiontec GT701D) but my download speed is averaging 33K to 60K using 4 different speed tests.  DSL disconnects at random also. My upload speed is typically around 700kbs – where it should be.
    My most recent test is from this morning:
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    SendBufferSize set to [8192]
    running 10s outbound test (client to server) . . . . . 591.76Kb/s
    running 10s inbound test (server to client) . . . . . . 60.33kb/s
    ------ Client System Details ------
    OS data: Name = Windows Vista, Architecture = x86, Version = 6.0
    Java data: Vendor = Sun Microsystems Inc., Version = 1.6.0_24
    ------ Web100 Detailed Analysis ------
    Client Receive Window detected at 17424 bytes.
    Cable modem/DSL/T1 link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.
    Web100 reports the Round trip time = 106.05 msec; the Packet size = 1452 Bytes; and
    There were 33 packets retransmitted, 59 duplicate acks received, and 63 SACK blocks received
    The connection stalled 4 times due to packet loss
    The connection was idle 1.36 seconds (5.03%) of the time
    This connection is network limited 99.9% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch
    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: OFF
    RFC 1323 Window Scaling: ON
    Information: Network Middlebox is modifying MSS variable
    Server IP addresses are preserved End-to-End
    Information: Network Address Translation (NAT) box is modifying the Client's IP address
    Server says [{edited for privacy}] but Client says [192.168.1.100]
    My DSL STATUS from this morning is:
    DSL Status
    VPI: 0
    VCI: 35
    DSL Mode Setting : MMODE
    DSL Negotiated Mode: G.DMT
    Connection Status: Showtime
    Speed (down/up): 3360/864kps
    ATM WoS Class:  UBR
    Near End CRC Errors: 0/0
    Far End CRC Errors: 0/73045
    Near End CRC (Within Last 30 mins): 0/0
    Far End CRC (Within Last 30 mins): 0/0
    Near End RS FEC: 0/68
    Far End RS FEC: 0/0
    Near End FEC (Within Last 30 mins): 0/0
    Far End FEC (Within Last 30 mins): 0/0
    Discarded Packets(Within last 30 mins): 0/0
    SNR Margin (Downstream/Upstream): 0/14
    Attenuation (Downstream/Upstream): 119/30
    This performance drop off is totally unacceptable.  What’s really interesting is that my service call has been closed out as “resolved”.  Which is obviously has not.  I am now being forced to go through support again to “diagnose” my problem.
    I’ve been researching (painfully) these speed issues and have determined they are a chronic problem going back to at least 2006 for many DSL customers.  The issue seems to be they have oversold DSL services and overcrowd their local Central Office servers and routers.  There is supposed to be some performance issue regarding Redbank and Juniper switches.  Redbank is supposed to be more reliable and Juniper aren't so.  I also believe their latest “optimizing” software may also be part of the problem.
    For the first time EVER, I am seriously considering converting to COMCAST because no one at Verizon (other than the DSL tech) will acknowledge they are the cause of my issue.
    Anyone have a realistic idea as to what needs to be done at the Central Office to correct this issue? 
    Thanks for your time.

    Consider yourself lucky. I have had the 3Mb plan for over ten years and initially had regular speeds of 1.5 to 3.0...until a new development was put in a block away, they were connected to Verizon, and my speeds dropped to 205 kbps down/805 kbps up at the copper drop in my basement. Many calls to Verizon resulted in modem upgrades (currently the Westell 6100) and reassurances from Verizons foreign help desk that my service was performing normally. Promises of FIOS soon being available in my area (Cedar Brook, NJ) have kept me hanging on but I stopped holding my breath a few years ago.  Hopefully your service will be restored - mine most likely never will.

  • Super-slow FTP download speed

    I recently switched from Time Warner to Verizon FiOS and it's been a whole lot better in terms of service except for one thing: FTP speed. When I log into Filezilla and try to download something, my download speed plummets to 30 kb/s and slower. I've tried switching FTP clients and saw no change, and tried accessing my ftp via Firefox and Chrome; neither option changed my slow as molasses FTP speeds. There's no problem with my connection (I'm wired, not wireless) and my speeds are reading as higher than advertised.
    Is there something I'm not checking for or is Verizon simply throttling my FTP DL speed?

    I use FireZilla all the time and have no problems with transfer speeds.
    Some FTP sites run slower than others, but I chalk that up to slower links between "here" and "there."
    I've never seen any real evidence of throttling by Verizon on any service.
    Good Luck.
    If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.

  • Upload/Download speed of files using Java

    Hey All,
    I have created a signed Java applet which, among various other things, allows uploading and downloading of files between the server and client. Both Upload and Download is handled through HTTP. For Upload I create a multi-part POST request to transfer the data to a script on the server which intercepts it. For download I craft a URL to http://myserver.com/filedirectory/file.extension. From that I form a HttpURLConnection and read from the stream to the file system of the client. This applet is only run on an internal network, which currently has 100mbit connection. However, I am noticing upload/download speeds of less than 1MB/s (I believe 100mbit = 12MB/s approx). I am currently using a buffer size of 8kb.
    Can anyone think of any ways to increase download speed? Would it help to increase the buffer size, knowing we will always be on a closed network? Here Is my upload code, and my download is similar but in the opposite direction.
    int bytesRead = 0;
    byte b[] = new byte[BUFFER_SIZE];
    BufferedInputStream bufin =  new BufferedInputStream(new FileInputStream(f));
    while ((bytesRead = bufin.read(b)) != -1)  {
            * write output
         out.write(b, 0, bytesRead);
         out.flush();
    out.close();
    bufin.close();I have not included the rest of the code which creates the POST request because the upload is otherwise working perfectly despite the speed, and I have confined the bottleneck to this part using debug output.
    Thanks much

    Will removing the flush after every loop somehow decrease accuracy?No.
    Ideally, files should be the same exact size on the server as the client after upload has finished.Deferring the flush() can't change that. It just lets you write in larger chunks, which is always good.
    Which one is the socket receive buffer?The buffer whose size is set by Socket.setReceiveBufferSize().
    Currently the size of BUFFER_SIZE in the example above is set to 8k.That's the application buffer. Good size.

  • WRT54GL Slowed Download Speeds (only 30Mbs down when old BEFSR41 got 50Mbs).

    I just replaced my BEFSR41 with a new WRT54GL (to get WiFi support in addition to Wired Support). With the BEFSR41 I was getting 50/8 speeds. As soon as I swaped with the WRT54GL my download speed dropped to 30Mbs. Is the WRT54GL unable to get 50Mbs unlike the BEFSR41 or is there something I have miss configured? I am using the same computer settings as I used to and reconecting the BEFSR41 restored my 50Mbs Download Speed. This is with wired connections with the WiFi turned off (to eliminate any question of the WiFi stealing any of the processing power).

    The BEF is a wired router which was designed for higher speeds than 50 Mbit/s.
    The WRT54GLv1.1 can do 50 Mbps at most under ideal test circumstances. See here:
    http://www.smallnetbuilder.com/wireless/wireless-reviews/26843-linksyswrt54gv5reallyisalousyrouter?s...
    Now, unfortunately real internet is not ideal, shows more packet delays, packet loss, and often ISPs use some round-robin or similar algorithm to their clients. Exaggerated example: your ISP sends you packets at 100 Mbit/s for 0.5s and then another 0.5s nothing. Makes 50 Mbps overall, if and only if your router is capable often dealing with 100 Mbit/s traffic.
    If you use the WRT only as access point, i.e. you connect it LAN-LAN to your BEF you have to make sure to disable the DHCP server on the WRT. Otherwise the DHCP server on the WRT will assign incorrect default gateways to your clients.
    Disable the DHCP server on the WRT if it's connected LAN-LAN (and disable RIP, too, otherwise you start again to route traffic through the WRT which you don't want to do)

  • Varying download speeds

    when i download off of software update i get a really fast download speed, but when i download the doom 3 demo it is really slow (at the beggining it starts off at around 60KBps and drops really low, lower than 10KBps sometimes, and it wont go back up. and it tries to mount too early causing the mounting to fail. i do not know why it does it (10MB of 465MB it mounts unless i have a fast download speed) whats up with airport? i also have AirTrafficControll widget and i can connect to networks that way too. Also do i need airport 4.2 if i have airport Extreme?

    Thanks for the info.
    When you have a chance, you might want to recheck your settings for the Time Capsule base station and Express remotes, as it's easy to miss a step during configuration.
    AirPort Utility is used to configure all devices and you can click the Manual Setup button to save time and access the settings.
    For the Time Capsule, click the Wireless tab just below the row of icons at the top of the setup page. On the wireless settings page, the Wireless Mode would be "Create a wireless network" and there should be a check mark next to "Allow this network to be extended". That's it for the TC.
    For both of the Expresses, click the Wireless tab as above. On the wireless page, the Wireless Mode should be set to "Extend a wireless network". The network created by the TC should be displayed. Also make sure there is a check mark next to "Allow wireless clients". That's it for the Expresses.
    I believe that you could also configure the Express that you have set to "Join" to "extend" as well. This setting seemed to work for AirTunes when I tried it a few weeks ago. If that's the case, you will also have a 3rd Express "extending" the wireless network.
    As a frame of reference, I have 2 Express units that I normally use to extend and the speed remains constant within 5-10% in virtually all locations within the house and even out on the patio. Unless you do have some interference issues, (use iStumbler, www.istumbler.net to check), I think you should expect very good wireless performance.
    One note to point out if you are using 802.11n 5 GHz. The higher frequencies of this band are absorbed much more quickly than the 2.4 GHz band, so you will see a much steeper drop off in speed with distance and any minor obstructions on 5 GHz.

  • Download speeds very low =ftp tests

    Hey ,, i ran into a issue here,
    few servers are connected directly to 6509 to gig ports with a speeds of 1000 full on either side and they are having a slow download speeds of 11 Mbps
    if i try to download an ftp from any of these servers ,,,download speeds are at 11Mbps.
    in the same switch speed is good between two servers and rest of the servers operate at low sppeds.
    If i try to involve another server connected to another switch,,, it is 28Mbps.
    can any one help me out figure out the issue.
    I am not able to figure out the issue
    Thnx

    ok. if L1 is clear, try tcpdump on server and client side. maybe there are some errors in tcp communication, or something like this.

  • In Firefox can not see the Downloads window, in the jump in the boot to be seen - the download speed Downloaded much and now can not see how to fix it?

    in Firefox can not see the Downloads window, in the jump in the boot to be seen - the download speed
    Downloaded much and now can not see how to fix it?

    I hate the new downloads-in-a-tab scheme. This was an unnecessary change in my book (if it aint broke, don't "fix it").
    So in order to get it back, I performed the about:config browser.download.useToolkitUI change, but now all I get is a blank download window that pops up every time I download something.
    Is there something else that I need to do? I've checked the change and it was saved, but it didn't resolve my issue as much as it just caused me a new issue.

  • WRT310N Playstation 3 Slow Download speed and general lag

    Hey guys, I just recently bought the WRT310N and got both of my computers working with it. One is wired directly into the router, while the other is running off wireless. My Playstation 3 is able to connect to the router but I am getting an extremely slow connection speed.
    Right now, both PC's get about 6.4-6.5 Mbps download speed while my Playstation is anywhere from 600 Kbs to 1.2 Mbps. I have plugged in my Playstation 3 directly into the modem and got a speed of 3.2 Mbps and was downloaded a demo very fast, but I do not recieve anywhere near those results when using it wireless.
    Any advice? I have tried opening the ports, but that only seemed to slow it down. A couple of days ago I opened the ports specific to the game NHL 10 and for two days I was getting such a good speed in the game that it felt like I was playing offline, which was great! Then this morning, it just seemed do a complete 180. Now when I play the game I get an extreme amount of lag, and my other games like CoD4 get random lag spikes. Like, I'll be running and I get a lag spike which seems to happen fairly consistently every minute or so.
    Any advice? Should I try opening the ports again or what?
    Message Edited by Nimer on 10-02-2009 03:58 PM

    I think you need to adjust the wireless settings of your Router, The wireless settings on your Router must have been setup to its default that's the reason you are receiving low signal strength on your PS3.
     Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - 192.168.1.1 and press Enter...Leave Username blank & in Password use admin in lower case...
    For Wireless Settings, please do the following : -
    Click on the Wireless tab
    - Here select manual configuration...Wireless Network mode should be mixed...
    - Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...
    - Set the Radio Band to Standard-20MHz and change the Standard channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on Save Settings...
    Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
    For Wireless Security : -
    Click on the Sub tab under Wireless > Wireless Security...
    Change the Wireless security mode to WPA, For Encryption, select TKIP...For Passphrase input your desired WPA Key. For example , MySecretKey , This will serve as your network key whenever you connect to your wireless network. Do NOT give this key to anyone and remember the key.
    NOTE : Passphrase should be more that 8 characters...
    Click on Advanced Wireless Settings
    Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304, Change the RTS Threshold to 2304 >>Click on "Save Settings"...
    Now see if you can locate your Wireless Network and attempt to connect...

  • Clients cannot download updates from DP

    Dear Friends,
    I need your help,
    After I configured everything and I am ready to patch my first cycle I have problem with my clients.
    I download all the updates and create my deployment package. I sent it to the DP. 
    The clients cannot download the updates from their DP. I checked the boundary and everything is ok.
    I noticed that all pcs have the following error in the FSPstatemessage.log.
    Failed in WinHttpSendRequest API, ErrorCode = 0x2ee7 FSPStateMessage 4/5/2015 1:53:36 AM 4844 (0x12EC)
    [CCMHTTP] ERROR: URL=HTTP://SCCM01.XXX.YYYYY/SMS_FSP/.sms_fsp, Port=80, Options=224, Code=12007, Text=ERROR_WINHTTP_NAME_NOT_RESOLVED FSPStateMessage 4/5/2015 1:53:36 AM 4844 (0x12EC)
    Successfully sent location services HTTP failure message.
    Does the error above have to do with the client when tries to download the updates from the dp ?
    How to solve the problem above ?
    I forgot to mention that I have only one Site.
    Please help
    Nikkoscy

    The client falls in a boundary that is assigned to a boundary group which gives access to the DP with the content and the deployment package is distributed on the server.
    Please see below the ContentTransferManager.log, CAS.log, LocationServices.log .
    any idea what is wrong ?
     I can resolve the FQDN of the DP from the client. The DP is the server of the branch where the client locates.
    Nikkoscy

Maybe you are looking for

  • Sleep problem plus Skype

    I have a similar problem. The machine just turns itself off at night. This only happened after the 10.7.5 upgrade. Does anyone know how to get skype working with this upgrade?

  • How to put smileys in my e-mails ?

    how to put smileys in my e-mails ?

  • Mile stone billing plan - issue

    Hi sap experts i have a probleme in creating mile stone billing plan. in MS Bill plant if my billplan exceeds my order quantity system is accepting without showing any error message or bloking the billing. i.e if my plan exceeds more than 100 % syste

  • Logic 7.1.1 Crashing whilst saving!!

    Hi I was hoping this problem might have been fixed with the latest update, but ever since upgrading my system to tiger, logic has been crashing frequently whilst saving! I obviously loose all the work I have done up until this point!! Is anyone else

  • Period wise capex, capitalisation plan and actual capitalisation report

    Dear PS gurus! I am new to the SAP, can some one help in identifying the reports which can give me following informations. Period wise capitalisation plan for any WBS or Multiple WBS Period wise Actual Capitalisation for any WBS Period wise Capex Act