Completing jsp using web pages from outside war

I have a .jsp called Welcome Page. On it, I wish to include the content of another web page that is located outside of the context root. I know the file's location on the server and I know the real URL of the file (it's an html file).
Before I go through any heartache of reinventing the wheel, what, if any, method can I use to accomplsh this? I have already tried
jsp:include...
pageContext.include...
getResourceAsStream...Your help is appreciated.

I am using webSphere server, so this does not directly relate to what I need, but it did offer me a line of thought. Even after reading this, though, I noticed that it was only good for web apps running within the same virtual host.
To give an example, say I have a web page at www.mycompany.com and wish to include the page www.someothercompletelydifferentcompnay.com/info.html
Is there a way to do this?

Similar Messages

  • Create web pages from xml files using Servets or JSP

    I�m new in this tecnology and I have to create a web pages from information that I get from a XML files. I would like to know if there is a place where I can find examples of code or any book that could help me.

    Two places with loads of information on this:
    http://xml.apache.org
    Look at Xalan or Cocoon.
    Also, there was an article on http://www.javaworld.com on XML with JSP.

  • Can I print web pages from firefox using adobe pro 9 (Not using PDF download) and if so how

    Can I print web pages from Firefox 3.6.12 using adobe pro 9 (not using PDF Download) and if so how.

    {Ctrl + P} - do you have a PDF Printer listed in the Printer - Name drop-down?

  • Opening a secure web page from oracle forms for credit card validation

    Hi All,
    I searched for the topic in the forms forum but couldn't find a solution.
    Requirement: As per some compliance, our application cannot do a credit card validation from our forms application, instead we need to use a java code which a third party will provide ,it's an iframe (they say, i am layman when it comes to Java, don't know what is it), but they say that, within your forms application you call our iframe do the credit card validation over there get a token of response back from us and use this token as a confirmation in your application.
    Problem: I could not find a solution anywhere wherein i can call a web page from forms. Now, this web page should be modal, i.e. unless i close this page i cannot access my forms application. Please guide me if anyone has done that.
    Secondly if i could make it work, how will i communicate with this external web page, like getting back some token value and use it back in my forms application. I am completely clueless.
    As we are using Oracle designer for generating forms, we cannot use a bean type thing as designer does not have the bean-item type defined!
    Appreciate if anyone could provide me pointers for a solution to this problem statement.
    We are on forms 9i -- Version 9.0.2.11.0
    Edited by: the_wing_rider on Jul 8, 2011 5:10 AM

    The simple way to do it is to use a PJC (java bean) + apache httpclient library..
    If you have a webservice than you can use Axis library and wsdl2java to create java classes from wsdl.
    also you can use httpclient library to simulate http protocol (request/response actions)..
    (for example.. you have a credit card number.. you post this number to specified URL and then you parse the response from credit card validation server)..
    Post here some documentation (specification) on how to call the credit card validation .. (maybe it's a secure webservice?)
    Here you have a httpclient library documentation:
    http://hc.apache.org/httpcomponents-client-ga/tutorial/html/index.html
    Also you can implement bean area in designer.. If you need help I can post here how we do it in our project..
    also look here: Call webservice from PJC over https protocol
    regards
    Peter
    Edited by: Peterv6i on Jul 8, 2011 3:35 PM

  • Can display Web pages from servlet but not applet?

    I have been able to display real-world Web pages from a simple servlet using JDeveloper 3.0, but can't figure out how to do the same from an applet. Any hints?

    My previous post had the detail...Probably a simple question from a relative novice. I'm having a problem just viewing web pages by calling them from a "list" of URLs in an applet. I built an applet with a split pane that has a JTree on one side and an "HTML viewing pane" on the other. I can click JTree nodes to display local html files, but I don't understand how to display web pages from the Internet. Do I need something like HyperlinkListener to make the jump to "hyper-world"???

  • TS3276 i am unable to open web pages from email links on my ipad

    I am unable to open web pages from email links on my ipad

    A few more details might help, if nobody else recognizes this.   
    What happens when you try to open the links?
    Can you post an example of a link that doesn't work?
    Is there any particular source for the mail with the (bad) links, or is mail from all sources failing?
    If you happen to know it, what's the format of the mail message?  (Maybe the message is an image?)
    Do the embedded links work as expected from an OS X system running Mail.app, or some system and some other other mail client?
    To view the link in iOS: if you press on and hold your finger on an embedded link in most contexts, iOS will show a pop-up with the link contents, and will offer to copy it.  You can use that to acquire and post the link.  If pressing and holding on the link doesn't offer the pop-up, the format of the link itself may not be valid, or it might not really be a link.

  • Opening a WEB page from FORMS CS & WebForms

    Hi,
    We would like to open a Web Page from a forms running in
    client/server as well as from a form runningover the web.
    Over the web, we plan to use SHOW_DOWUMENT (Even tough it seems
    broken, on forms 6.0, the only way we have got it working was by
    using the parameter that overwrites the current page (the form),
    we cannot have it open an URL in another window)
    In C/S mode, the SHOW DOCUMENT does not work. What is the proper
    way to lauch an URL in a browser in C/S mode ?
    Is there a way to determine if we're running in CS mode or Web
    Mode ? We would like to use the same code both on the web and in
    C/S
    Example pseudo code:
    if (Running in CS Mode) then
    open the URL using C/S method
    else
    open the URL with show dowument
    fi
    Thanks
    null

    use '_blank' as parameter, not '_self'.
    Guy Dallaire (guest) wrote:
    : Hi,
    : We would like to open a Web Page from a forms running in
    : client/server as well as from a form runningover the web.
    : Over the web, we plan to use SHOW_DOWUMENT (Even tough it
    seems
    : broken, on forms 6.0, the only way we have got it working was
    by
    : using the parameter that overwrites the current page (the
    form),
    : we cannot have it open an URL in another window)
    : In C/S mode, the SHOW DOCUMENT does not work. What is the
    proper
    : way to lauch an URL in a browser in C/S mode ?
    : Is there a way to determine if we're running in CS mode or Web
    : Mode ? We would like to use the same code both on the web and
    in
    : C/S
    : Example pseudo code:
    : if (Running in CS Mode) then
    : open the URL using C/S method
    : else
    : open the URL with show dowument
    : fi
    : Thanks
    null

  • How do i Hyperlink to a web page from a java application?

    How do i Hyperlink to a web page from a java application using internet explorer as my default web browser?

    It's very simple.You can start any Application with the class Runtime. The command is an array consisting of the path of .exe and the file to be open.
    String [] cmd={path of IE+Filename.exe,"URL of your website"}
    try
    Runtime.getRuntime().exec(cmd);
    catch (Exception e)
    System.err.println(e.toString());
    }

  • Captivate 6: Can I hyperink to a web page from an image?

    In Captivate 6, can I hyperlink to a web page from an image?

    You can fill a smart shape with the image using the Texture button, but beware: choose a shape with the same size as the image. Maybe Sreekanth is telling the same, but I didn't get his 'assign custom image to it'? And if you want to have a pause for a shape button, you have to check it in the Timing accordion.
    Another approach is to put a click box on top of the image. You can open the URL in another window using the small triangle drop down list, and be sure to uncheck Continue Project to avoid that the playhead will continue.
    Lilybiri

  • 866VAE - cant acces web pages from LAN

    Hi everyone,
    im fighting with Cisco 866VAE-K9 for few days. I have got ADSL2+ line in Cisco, i can ping anything from router (like 8.8.8.8 or www.google.com), test of connection in CCP runs successfully, but i cant acces web pages from LAN computers. From LAN i can ping to any IP adress in internet (like 8.8.8.8), but i cant ping or access domain names of web pages (like www.google.com). I know there is probably something wrong in my config, but after 2 days of googling i cant find where the problem is. Can anybody help?
    Here is my running config:
    Building configuration...
    Current configuration : 8181 bytes
    ! Last configuration change at 11:31:15 UTC Fri Mar 6 2015 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname cisco_866vae
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 5 xx
    enable password xx
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local 
    aaa session-id common
    wan mode dsl
    ip port-map user-protocol--1 port tcp 3500
    ip name-server 8.8.8.8
    ip cef
    no ipv6 cef
    parameter-map type protocol-info yahoo-servers
     server name scs.msg.yahoo.com
     server name scsa.msg.yahoo.com
     server name scsb.msg.yahoo.com
     server name scsc.msg.yahoo.com
     server name scsd.msg.yahoo.com
     server name cs16.msg.dcn.yahoo.com
     server name cs19.msg.dcn.yahoo.com
     server name cs42.msg.dcn.yahoo.com
     server name cs53.msg.dcn.yahoo.com
     server name cs54.msg.dcn.yahoo.com
     server name ads1.vip.scd.yahoo.com
     server name radio1.launch.vip.dal.yahoo.com
     server name in1.msg.vip.re2.yahoo.com
     server name data1.my.vip.sc5.yahoo.com
     server name address1.pim.vip.mud.yahoo.com
     server name edit.messenger.yahoo.com
     server name messenger.yahoo.com
     server name http.pager.yahoo.com
     server name privacy.yahoo.com
     server name csa.yahoo.com
     server name csb.yahoo.com
     server name csc.yahoo.com
    parameter-map type protocol-info msn-servers
     server name messenger.hotmail.com
     server name gateway.messenger.hotmail.com
     server name webmessenger.msn.com
    parameter-map type protocol-info aol-servers
     server name login.oscar.aol.com
     server name toc.oscar.aol.com
     server name oam-d09a.blue.aol.com
    crypto pki trustpoint TP-self-signed-2886901321
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2886901321
     revocation-check none
     rsakeypair TP-self-signed-2886901321
    crypto pki certificate chain TP-self-signed-2886901321
     certificate self-signed 01
    controller VDSL 0
    class-map type inspect match-any SDM_BOOTPC
     match access-group name SDM_BOOTPC
    class-map type inspect match-any ccp-cls-protocol-p2p
     match protocol edonkey signature
     match protocol gnutella signature
     match protocol kazaa2 signature
     match protocol fasttrack signature
     match protocol bittorrent signature
    class-map type inspect match-all ccp-cls--1
     match access-group name all
    class-map type inspect match-all ccp-cls--2
     match access-group name all1
    class-map type inspect match-any ccp-cls-protocol-im
     match protocol ymsgr yahoo-servers
     match protocol msnmsgr msn-servers
     match protocol aol aol-servers
    class-map type inspect match-any SDM_SSH
     match access-group name SDM_SSH
    class-map type inspect match-any SDM_HTTPS
     match access-group name SDM_HTTPS
    class-map type inspect match-all SDM_GRE
     match access-group name SDM_GRE
    class-map type inspect match-any SDM_SHELL
     match access-group name SDM_SHELL
    class-map type inspect match-any sdm-cls-access
     match class-map SDM_HTTPS
     match class-map SDM_SSH
     match class-map SDM_SHELL
    class-map type inspect match-all sdm-access
     match class-map sdm-cls-access
     match access-group 101
    policy-map type inspect ccp-policy-ccp-cls--1
     class type inspect ccp-cls--1
      pass
     class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
     class type inspect ccp-cls--2
      pass
     class class-default
      drop
    zone security out
    zone security in
    zone-pair security sdm-zp-in-out source in destination out
     service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-out-in source out destination in
     service-policy type inspect ccp-policy-ccp-cls--2
    interface Loopback0
     ip address 192.168.100.1 255.255.255.0
     zone-member security in
    interface ATM0
     no ip address
     no atm ilmi-keepalive
    interface ATM0.1 point-to-point
     pvc 8/48 
      oam-pvc manage
      pppoe-client dial-pool-number 1
    interface Ethernet0
     description $ETH-WAN$
     no ip address
     shutdown
     pppoe-client dial-pool-number 2
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     no ip address
    interface FastEthernet3
     no ip address
    interface GigabitEthernet0
     no ip address
    interface GigabitEthernet1
     description $ETH-WAN$$FW_OUTSIDE$
     ip address dhcp client-id GigabitEthernet1
     ip tcp adjust-mss 1412
     shutdown
     duplex auto
     speed auto
    interface Vlan1
     description $FW_INSIDE$
     ip address 192.168.7.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     zone-member security in
     ip tcp adjust-mss 1412
    interface Dialer1
     no ip address
    interface Dialer2
     description $FW_OUTSIDE$
     ip address negotiated
     ip mtu 1452
     ip nat outside
     ip virtual-reassembly in
     zone-member security out
     encapsulation ppp
     dialer pool 1
     dialer-group 3
     ppp authentication chap pap callin
     ppp chap hostname o2
     ppp chap password 0 o2
     ppp pap sent-username o2 password 0 o2
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat source list 101 interface Dialer2 overload
    ip nat inside source static tcp 192.168.7.39 3500 interface Dialer2 3500
    ip nat inside source list 101 interface Dialer2 overload
    ip nat inside source route-map MAP_ACL interface Dialer2 overload
    ip route 0.0.0.0 0.0.0.0 Dialer2 permanent
    ip route 192.168.2.0 255.255.255.0 192.168.7.3 permanent
    ip access-list extended NAT_ACL
     deny   ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.255.255
     permit ip 192.168.0.0 0.0.0.255 any
    ip access-list extended SDM_BOOTPC
     remark CCP_ACL Category=0
     permit udp any any eq bootpc
    ip access-list extended SDM_GRE
     remark CCP_ACL Category=1
     permit gre any any
    ip access-list extended SDM_HTTPS
     remark CCP_ACL Category=1
     permit tcp any any eq 443
    ip access-list extended SDM_SHELL
     remark CCP_ACL Category=1
     permit tcp any any eq cmd
    ip access-list extended SDM_SSH
     remark CCP_ACL Category=1
     permit tcp any any eq 22
    ip access-list extended all
     remark CCP_ACL Category=128
     permit ip any any
    ip access-list extended all1
     remark CCP_ACL Category=128
     permit ip any any
    access-list 2 remark CCP_ACL Category=2
    access-list 2 permit 192.168.7.0 0.0.0.255
    access-list 101 remark CCP_ACL Category=128
    access-list 101 permit ip any any
    access-list 101 permit udp any any eq domain
    access-list 101 permit udp any eq domain any
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    dialer-list 3 protocol ip permit
    mac-address-table aging-time 15
    route-map MAP_ACL permit 10
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     exec-timeout 40 0
     password xxxxxxx
     transport input telnet ssh
     transport output telnet ssh
    scheduler allocate 60000 1000
    end

    Hi,
    I would be happy to help but I have one question first: Your configuration contains a lot of cruft generated from SDM/CCP and I am not sure if any of that is really required by you. Do you believe you would be fine with having this entire configuration trimmed down and do just what's supposed to do (routing and NAT), and we had security measures added in later? Just by the way, I do not believe you need the zone-based firewall. In your simple setup with just a few inside/outside interfaces, it does not add any real value apart from making the configuration virtually unreadable. We can easily do the same with IP Inspect.
    Best regards,
    Peter

  • Removing links in a web page created using web page composer

    Hi there,
    I am creating web pages using Web page composer. I would like to remove the links Send Feedback, E-mail, Print, Add to Favorites, RSS. How can i achieve this?
    Your comments are highly appreciated.
    Regards,
    Ponraj M

    To configure the functions of the page header you will have to wait for SP14.
    I guess to change the header for an SP13 you have to modify the pageheader.jsp. The page is part of the com.sap.nw.wpc.runtime.PageHeaderComponent.
    Please note that this modification is not supported by SAP!

  • Nested site navigation using Web Page Composer (WPC)

    Is it possible to nest navigation nodes using Web Page Composer?
    I have created a WPC site and added pages, but I am required to create a node with sub-pages (similar to adding a folder to a workset) for a site.
    Has anyone done this or know how to easily do this?  I do not want to maintain a separate WPC site (and corresponding workset folder) for each navigation node/group in the structure hierarchy.
    This is an example of what we are trying to accomplish in our navigation structure using a single WPC site:
    * Page 1
    * Page 2
    + Group 1
        * Page 3
        * Page 4
    + Group 2
        * Page 5
        * Page 6
    * Page 7
    Thanks in advance...
    Points will be awarded for helpful answers.

    Hi Angie,
    Could you please guide how to make the RSS link lists work in WPC, we do not receive any updates from external websites.
    Thanks,
    Shravs

  • Web pages from scratch

    Is there a way to build web pages from scratch and upload them via LOADPSP.EXE, similarly to the way you can do it witht the web toolkit?
    For example:
    <html>
    <body>
    <% some plsql code here %>
    show output here: <%=variable%>
    </body>
    </html>
    Thanks,
    Christoph

    Thanks for the reply.
    I found a little workaround that gives me what i need:
    1. I create the psp page in Dreamweaver
    2. Load it in to my test database with loadpsp.
    3. Copy the procedure body from the test database into a PL/SQL Dynamic Content region.
    The only changes i have to make are changing the procedure parameters to use htmldb bind variables.
    Christoph

  • Creating an Aperture web page from photos the page goes white and nothing displays. Is this a RAM issue?

    I have just purchased an iMac 27" 2.7GHZ running OSX 10.7.4 with 4GB RAM (16 GB has been ordered). I am using Aperture 3.3.2. When I attempt to create a web page from photos the page goes white and nothing displays. Is this a RAM issue?

    I have resolved the issue....turns out that, in my case, running OSX 10.8.1 with Aperture 3.3.2 was what was required! I was running Aperture 3.3.2 with OSX 10.7.x and had this issue.
    I hope this helps someone else as well.

  • Access existing web pages from '08?

    Here's the deal - I have had web pages set up with iWeb '06 w/Tiger, no problem. I installed (on a separate disk) Leopard, and iLife 08. So, if I boot from my Tiger disk, all is well, I can edit my web pages using iWeb '06.
    When I boot to my Leopard drive, and use iWeb '08, it just comes up to the default 'choose your layout' - it knows nothing about my existing .Mac web pages.
    How do I open my existing web pages from a different drive / partition using iWeb '08, that was created from iWeb '06 on a different boot drive?
    Many free beers await the first person to help me out on this. Thanks,
    John F

    Hi John,
    Have a look at the following page
    http://transfer.iwebfaq.org
    The only thing that changes for you is that you're transferring it from one drive to the other instead of from one computer to another.
    Please make a backup of the file before getting your site into iWeb '08 (and after if it was successful). Be sure to update the iWeb application before opening your website with it (get it to version 2.0.2)
    And note that once you updated the site to iWeb 2.0 it can't be edited in iWeb '06 anymore.
    I don't drink beer sorry...
    Regards,
    Cédric
    "I don't receive any form of compensation, financial or otherwise, from my recommendation or link"

Maybe you are looking for

  • Function Module for getting J1IEX Data

    Dear All, Is there any F.M available for getting details whatever is posted in  J1IEX, like ED, Ecess, HEcess etc. regards, paras Point Assured.

  • How to change an "answered question" icon to and "open" one

    An hour ago this morning, I re-opened a thread of mine that had already been answered. Unfortunately, I could not easily locate the instruction or button that allows me to convert the "answered question" icon to an "open question" icon. I want to cha

  • How do I recover a purchased app that is now missing from home page?

    Had not synced iPod to computer since app purchase, so app did not show up in iTunes library on computer. Since I purchased this app (but the icon perhaps was deleted) how do I get it back?  Surely the purchase is documented and there is a way to rec

  • Bluetooth reception issue

    Usually bluetooth works ok; but recently; when using my Sony BT22 headphones on my iphone 4 for simple bluetooth reception; the signal would cut out every time I put the phone in my back pocket. I traced it to a weak signal would I could interrupt wh

  • Connection JDeveloper to Oracle 8i

    How to make a connection in Jdeveloper 3.0 to Oracle Personal 8i local Database on a Windows 98 Machine. Oracle Database 8.1.5 and Jdeveloper 3.0 are in the same computer Win/98. Which JDBC Driver and connection method must be used? I need a complete