Design of reusable data persistence layer with single container

Hi,
I am designing an 3-tier application using cmp for my data persistence layer (DPL). The customer now wants to run multiple versions of the application on one server using different data sets for each application. One solution I see, but don't like very much, is to add an application ID to each enity bean in my DPL. However, I would rather run multiple DPL's on different databases and reuse my business logic layer and my presentation layer. Has anybody solved this problem or see the obvious solution that I am missing here?
Thanks a lot,
Sandigo.

Hi KPSeal,
there is absolutely no relation between the different versions of the application. Although I would prefer to run a single business logic layer it is very much an option to have different versions of the entire application. Could you elaborate on how I would achieve these different versions? Would I have to rewrite the deployment descriptors so that each bean can exist twice or would that give me two instances?
Thanks,
S.

Similar Messages

  • Dynamic SQL and Data with Single Quotes in it.

    Hi There,
    I have a problem in that I am using dynamic SQL and it happens that one of the columns does contain single quotes (') in it as part of the data. This causes the resultant dynamic SQL to get confused as the single quote that is part of the data is taken to mean end of sting, when in fact its part of the data. This leaves out a dangling single quote that was meant to enclose the string. Here is my dynamic SQL and the result of the parsed SQL that I have captured:
    ****Dynamic SQL*****
    l_sql:='select NOTE_TEMPLATE_ID '||
    'FROM TMP_NOTE_TEMPLATE_VALUES '||
    'where TRIM(LEGACY_NOTE_CODE)='''||trim(fp_note_code)||''' '||
    'and TRIM(DISPLAY_VALUE)='''||trim(fp_note_text)||''' ';
    execute immediate l_sql INTO l_note_template_id;
    Because the column DISPLAY_VALUE contains data with single quotes, the resultant SQL is:
    ******PARSED SQL************
    select NOTE_TEMPLATE_ID
    FROM TMP_NOTE_TEMPLATE_VALUES
    where TRIM(LEGACY_NOTE_CODE)='INQ' and TRIM(DISPLAY_VALUE)='Cont'd'
    And the problem lies with the single quote between teh characters t and d in the data field for DISPLAY_ITEM. How can I handle this?
    Many thanks,

    I have been reliably informed that if one doesn't enclose char/varchar2 data items in quotes, the right indices may not be usedI am into oracle for past 4 years and for the first time i am hearing this.
    Your reliable source is just wrong. Bind variables are variables that store your value and which are used in SQL. They are the proper way to use values in your SQL. By default all variables in PL/SQL is bind variable.
    When you can do some thing in just straight SQL just do it. Dynamic SQL does not make any sense to me here.
    Thanks,
    Karthick.

  • How to Restrict Single Delivery Date for PO with Multiple Line Items

    Dear Experts,
    How to Restrict Single Delivery Date for PO with Multiple Line Items.
    System needs to through Error Message if User Inputs Different Delivery Dates for PO with Multiple Line Items in ME21N Tcode.
    Can we achive this by Some Enhancement in SAP or Not ???
    If so how to do it.
    Any Inputs is highly appreciated.
    Thanks and Regards,
    Selvakumar. M

    Hi Selvakumar,
    we can resrict the PO to have a single delivery date in all the line items by means of giving a error message or overwiting the delivery date keyed/determined in the line item.
    You can use the BADI -> ME_PROCESS_PO_CUST. In which you need to implement the method PROCESS_SCHEDULE.
    (for technical aid - This method will be called for each and every PO line item, From the imporing parameter im_schedule we can get all the details of current PO line, even we can change the data in the current PO line. )
    Regards,
    Madhu.

  • How to delete multiple data domains with single step ?

    how to delete multiple data domains with single step ?

    You can go to your Endeca-Server domain home e.g.($WEBLOGIC-HOME$/user_projects/domains/endeca_server_domain/EndecaServer/bin)
    run
    [HOST]$ ./endeca-cmd.sh list-dd
    default is enabled.
    GettingStarted is enabled.
    endeca is enabled.
    BikeStoreTest is enabled.
    create a new file from the output just with the domains that you want to delete and then create a loop
    [HOST]$ vi delete-dd.list
    default
    GettingStarted
    endeca
    BikeStoreTest
    [HOST]$ for i in $(cat delete-dd.list); do; ./endeca-cmd.sh delete-dd $i; done
    Remember that this can not be undone, unless you have a backup.

  • New client/instance with single company data

    Hello,
    Having to acquire a new company, the problem comes up when the actual SAP client contains more than one society.
    Is it possible to have a new client or instance with data belonging to a single one of these managed companies?
    How can it be copied/extracted, if possible?
    Thanks

    solved

  • Persistence Layer.

    Hi All,
    Currently, the sql query is inside the Business Object in my program. I would like to separate out the query (or persistence part) to a different layer. I need some help in the best way to design this. I like to have a 5 Tier Arch.
    User Interface (JSPs) + Front Side Controller (Servlet) + Business Objects + Back Side Controller (???) + Persistence Layer (???).
    Please help me with how to separate Business Objects from Persistence. This should also support connecting to different databases.
    Manjunath

    Create a new package, design classes that do all your database work( retrieve insert etc. ) in the new package. The requirement is this package should compile without any other classes from Front Side Controller (Servlet) + Business Objects + Back Side Controller (???).
    This package is your Persistence Layer fully decoupled from the rest. Use your judgement in the decoupling.

  • Flex/Coldfusion data access layer

    Hi
    I'm researching ways to achieve a data access layer using flex/coldfusion.
    Currently it seems that I would need a RemoteObject on each flex component that will access ColdFusion (a cfc that will access a database).
    I'm not sure if it's possible to have a data access class, which will contain a single RemoteObject, and somehow I will be able to request data from a component and somehow retrieve it again. I have the feeling I'd have to dispatch events at the component level, and also include the result handling here too, which I'm not sure is ideal. I haven't been able to decide on a strategy yet.
    So far I've only found articles describing a need to have a layered structure when building a large data-centric application, however no examples of how this is actually acheived.
    If anyone has seen any examples of this please could you share them here.
    Thanks.

    I am looking for something similar, but I am not too
    sure how it would work.
    I have tried developing one myself, using the
    underlying interface classes, but I am unsure how to
    overcome the differences between SQL Server and
    Oracle when returning result sets. SQL Server is
    happy to return a DataSet from a stored procedure,
    but Oracle must be given a Ref Cursor variable
    parameter for each DataTable returned.
    This means that the calling code must differ between
    SQL Server and Oracle.
    If anyone can suggest a neat way to get over this,
    I'd appreciate it.
    Check out the DAABv3 from GotDotNet. It implements an abstract factory pattern for data providers. It works with Oracle, but not, I think, with ODP.NET. It's extensible, though, so ODP.NET support could be added.
    In addition the V2 of the .NET framework will have an abstract factory pattern for data providers built in.
    On the particular question of ref cursors and Sql Server, here's what I do. My Oracle procedures which return result sets always return only one, and, by convention, the ref cursor parameter is the last one. Then I use a helper method like FillDataTable, or ExecuteReader to interface with the database. The application is bound the SqlServer definition of the procedure, but in the Oracle version of the helper function I simply add another parameter to the end of the command parameters to receive the ref cursor.
    David

  • Persistence Layer return convention issue and question - null vs. exception

    I'm writing a position paper on persistence layer query returns. It deals with querying for a single object or a collection of objects and what to do if the object or collection of objects are not found in the database. I've googled many different search terms and have not come up with any authoritative references for this scenario. Do any of you know of any sources that have discussed this before?
    My current logic is that when searching for a single object in a persistence layer that the persistence layer should return a simple null if the object isn't found. If searching for a collection of objects then the PL should return an empty collection object.
    1.
    /** Returns a list of objects that match the non-null fields in the provided example object.
    This will return an empty Collection if no matching objects are found */
    public Collection retrieveByExample(MyBO example);2. /** Returns a business object.  This will return a null if no matching object is found */
    public MyBusObject retrieveById(int aMyBusObjectId);These two methods would not return a "checked or unchecked" exception if the object(s) are not found. I think that they are the simplest to implement and do not break the convention of not using exceptions in non exceptional situations. I don't feel that it is the persistence layer's responsibility to make a business decision on an object's existence being an exception. There are many times where applications search for an object to see if it exists or not and then proceed to create the object or use the object if it exists or doesn't. These two methods also don't force using application layers to catch or throw any declared exceptions.
    Notes on scenario 1: program control flow is simple by using an iterator and hasNext(), if the collection is empty then any code that needs the objects can be skipped.
    Notes on scenario 2: program control flow is simple in this case with a " != null or == null check. If the method returned an uninitialized object instead of null then the calling application would have to have additional business logic to tell whether the object was truly uninitialized or not. I can see the method having a UnexpectedMultipleBusinessObjectsFoundException if more than 1 object is found since the method is looking by primary key, but would this ever happen if searching by primary key. However in a similiar method that searches on non primary key then the UMBOFE would be warrented. Any thoughts?
    Others have brought up some additional scenarios.
    3. /** Returns one and only one business object from persistence with a matching primary id. 
    If one and only one match is not found, null is returned if isLenient is true, otherwise an exception is thrown. */
    public MyBusObject retrieveById(int aMyBusObjectId, boolean isLenient) throws BusinessObjectNotFoundException;I feel this option is bad in that it forces the calling or using application layer to still declare the BusinessObjectNotFoundException. It adds bulk and unneeded complexity to the the code.
    While looking at it I can see that since a caller is searching for exactly 1 object then if the query finds more than one object then a UnexpectedMultipleBusinessObjectsFoundException could be thrown. But I don't believe an NotFoundException is warranted. What are your thoughts?
    Message was edited by:
    smalltalk

    Hibernate (for example) actually does both.
    public Object get(Class clazz, Serializable id) throws HibernateException - "Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. (If the instance, or a proxy for the instance, is already associated with the session, return that instance or proxy.)"
    public Object load(Class theClass, Serializable id) throws HibernateException: "Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.You should not use this method to determine if an instance exists (use get() instead). Use this only to retrieve an instance that you assume exists, where non-existence would be an actual error."
    Certainly get is the more commonly used of these methods.
    If you are returning something like an array I believe it is always preferable to return a zero length array rather than null to save the extra client code.

  • Accessing LCDS Persistence Layer for use in Server-Side Business Logic

    Within server-side business logic, I want to be able to get a persisted object from LCDS, manipulate  that object, and then use LCDS to persist those changes to the database  as well as send those changes to the client.
    Is it possible to access LCDS' persistence layer (Hibernate) to be used by server-side business logic?
    I have attempted to use DataServiceTransaction.getItem(...).  However, for objects that contain a collection of other objects I get this error:
    [LCDS] Runtime exception while trying to fetch a property from hibernate: flex.data.DataServiceException: There is no current message broker to return.
    When calling DataServiceTransaction.updateItem(...) for objects that contain a collection of other objects, I get this error:
    org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: com.sd.pojo.Book.chapters, no session or session was closed
    Also, it appears that DataServiceTransaction.updateItem does NOT update the database?
    I have resorted to building my own Hibernate SessionFactory, but that seems unnecessary.
    One other piece of information is that I am using the Fiber modeling tool to build and deploy the model to the server.  I am generating the Java classes with Fiber and making them available to be used on the server.
    Thanks,
    Collin

    Thanks for the help guys.
    I guess what I'm really trying to get straight in my own mind is whether supporting interraction and control of eJB database interraction is still using the same functionality as having a stand alone app interracting with a db.
    I'm thinking about; the implications of using eJBs specific query language and the different way in which eJBs use db connections (either for the period of their lifetime or just for the duration of one interaction) compared with a stand alone app, which would maintain a connection to the database(s) while it is open.
    Connection pooling and caching of DB objects is often quoted as being a middle tier activity, but what does this mean when all 3 tiers reside on the same machine?
    Once again thanks for your comments and advice.
    Mark

  • Integrating Flex and Persistence Layer like Hibernate3

    How we can integrate Flex with any Persistence layer like
    Hibernate 3 ?
    any link, resource ?

    Hibernate is an open source implementation of the Java
    Persistence spec. Though it preceded JPA, and in fact influenced
    the final design, it has been retrofitted to implement the full
    spec (along with some extensions that I won't cover here).
    Hibernate is one of several implementations available, but because
    it is complete, mature, and freely available. Much like JDBC, if
    you stick to the spec and don't use any of Hibernate's extensions,
    you will be able to switch implementations as your needs change in
    the future.

  • SIP Trunk - No voice with Single Number Reach

    Hi Community.
    I setup SIP Trunk with the CCA. Everything is working Call In and Call Out. Call Forward and so on.
    But with Single Number reach is something wrong. The mobile phone is ringing and I can get the call, but I hear not any voice.
    Can someone please help me out? Below the config.
    version 15.1
    parser config cache interface
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service internal
    service compress-config
    service sequence-numbers
    dot11 ssid cisco-data
     vlan 1
     authentication open
    dot11 ssid cisco-voice
     vlan 100
     authentication open
    ip source-route
    ip cef
    ip dhcp relay information trust-all
    ip dhcp excluded-address 10.1.1.1 10.1.1.9
    ip dhcp excluded-address 10.1.1.241 10.1.1.255
    ip dhcp pool phone
     network 10.1.1.0 255.255.255.0
     default-router 10.1.1.1
     option 150 ip 10.1.1.1
    ip domain name site1.365873.trk.ipvoip.ch
    ip name-server 8.8.8.8
    ip inspect WAAS flush-timeout 10
    ip inspect name SDM_LOW dns
    ip inspect name SDM_LOW ftp
    ip inspect name SDM_LOW h323
    ip inspect name SDM_LOW https
    ip inspect name SDM_LOW icmp
    ip inspect name SDM_LOW imap
    ip inspect name SDM_LOW pop3
    ip inspect name SDM_LOW netshow
    ip inspect name SDM_LOW rcmd
    ip inspect name SDM_LOW realaudio
    ip inspect name SDM_LOW rtsp
    ip inspect name SDM_LOW esmtp
    ip inspect name SDM_LOW sqlnet
    ip inspect name SDM_LOW streamworks
    ip inspect name SDM_LOW tftp
    ip inspect name SDM_LOW tcp router-traffic
    ip inspect name SDM_LOW udp router-traffic
    ip inspect name SDM_LOW vdolive
    no ipv6 cef
    multilink bundle-name authenticated
    stcapp ccm-group 1
    stcapp
    isdn switch-type basic-net3
    voice call send-alert
    voice rtp send-recv
    voice service voip
     ip address trusted list
      ipv4 0.0.0.0 0.0.0.0
     allow-connections h323 to h323
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     supplementary-service h450.12
     no supplementary-service sip refer
     fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
     sip
      registrar server expires max 3600 min 3600
      localhost dns:site1.365873.trk.ipvoip.ch
      no update-callerid
    voice class codec 1
     codec preference 1 g711alaw
    voice register global
     mode cme
     source-address 10.1.1.1 port 5060
     load 9971 sip9971.9-2-2
     load 9951 sip9951.9-2-2
     load 8961 sip8961.9-2-2
     timezone 23
    voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
     access-list 2
     translation-profile incoming SIP_Incoming
    voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
     access-list 3
    voice translation-rule 9
     rule 1 /0041449475090/ /90/
     rule 2 /0041449475091/ /91/
     rule 3 /0041449475092/ /92/
     rule 4 /0041449475093/ /93/
     rule 5 /0041449475094/ /94/
     rule 6 /0041449475095/ /95/
     rule 7 /0041449475096/ /96/
     rule 8 /0041449475097/ /97/
     rule 9 /0041449475098/ /98/
     rule 10 /0041449475099/ /99/
    voice translation-rule 410
     rule 1 /^0\(.*\)/ /\1/
     rule 15 /^..$/ /0041449475090/
    voice translation-rule 411
     rule 1 /^0\(.*\)/ /ABCD0\1/
    voice translation-rule 412
     rule 1 /^ABCD\(.*\)/ /\1/
    voice translation-rule 422
     rule 15 /^ABCD\(.*\)/ /\1/
    voice translation-rule 1000
     rule 1 /.*/ //
    voice translation-rule 1111
     rule 1 /^9\([1-9]\)$/ /004144947509\1/
     rule 15 /^..$/ /0041449475090/
    voice translation-rule 1112
     rule 1 /^0/ //
    voice translation-rule 2000
     rule 1 /0041449475098/ /98/
    voice translation-rule 2001
     rule 1 /0041449475097/ /97/
    voice translation-rule 2002
     rule 1 /^6/ //
    voice translation-rule 2222
    voice translation-profile AA_Profile
     translate called 2001
    voice translation-profile CALLER_ID_TRANSLATION_PROFILE
     translate calling 1111
    voice translation-profile CallBlocking
     translate called 2222
    voice translation-profile OUTGOING_TRANSLATION_PROFILE
     translate called 1112
    voice translation-profile PSTN_CallForwarding
     translate redirect-target 410
     translate redirect-called 410
    voice translation-profile PSTN_Outgoing
     translate calling 1111
     translate called 1112
     translate redirect-target 410
     translate redirect-called 410
    voice translation-profile SIP_Called_9
     translate calling 3265
     translate called 9
    voice translation-profile SIP_Incoming
     translate called 411
    voice translation-profile SIP_Passthrough
     translate called 412
    voice translation-profile SIP_Passthrough_CallBlocking
     translate called 422
    voice translation-profile VM_Profile
     translate called 2000
    voice translation-profile XFER_TO_VM_PROFILE
     translate redirect-called 2002
    voice translation-profile nondialable
     translate called 1000
    voice-card 0
     dspfarm
     dsp services dspfarm
    fax interface-type fax-mail
    license udi pid UC540W-BRI-K9 sn FGL163220SL
    archive
     log config
      logging enable
      logging size 600
      hidekeys
    username admin privilege 15 secret xxx
    username xxx password 0 ""
    username xxx password 0 ""
    ip tftp source-interface Loopback0
    bridge irb
    interface Loopback0
     description $FW_INSIDE$
     ip address 10.1.10.2 255.255.255.252
     ip access-group 101 in
     ip nat inside
     ip virtual-reassembly in
    interface FastEthernet0/0
     description $FW_OUTSIDE$
     no ip address
     ip inspect SDM_LOW out
     ip virtual-reassembly in
     ip verify unicast reverse-path
     load-interval 30
     shutdown
     duplex auto
     speed auto
    interface Integrated-Service-Engine0/0
     description cue is initialized with default IMAP group
     ip unnumbered Loopback0
     ip nat inside
     ip virtual-reassembly in
     service-module ip address 10.1.10.1 255.255.255.252
     service-module ip default-gateway 10.1.10.2
    interface FastEthernet0/1/0
     no ip address
     macro description cisco-desktop
     spanning-tree portfast
    interface FastEthernet0/1/1
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/2
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/3
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/4
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/5
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/6
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/7
     switchport voice vlan 100
     no ip address
     macro description cisco-phone
     spanning-tree portfast
    interface FastEthernet0/1/8
     no ip address
     macro description cisco-desktop
     spanning-tree portfast
    interface BRI0/1/0
     no ip address
     isdn switch-type basic-net3
     isdn point-to-point-setup
     isdn incoming-voice voice
     isdn sending-complete
     isdn static-tei 0
    interface BRI0/1/1
     no ip address
     shutdown
     isdn switch-type basic-net3
     isdn point-to-point-setup
     isdn incoming-voice voice
     isdn sending-complete
     isdn static-tei 0
    interface Dot11Radio0/5/0
     no ip address
     ssid cisco-data
     ssid cisco-voice
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
     station-role root
     antenna receive right
     antenna transmit right
    interface Dot11Radio0/5/0.1
     encapsulation dot1Q 1 native
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio0/5/0.100
     encapsulation dot1Q 100
     bridge-group 100
     bridge-group 100 subscriber-loop-control
     bridge-group 100 spanning-disabled
     bridge-group 100 block-unknown-source
     no bridge-group 100 source-learning
     no bridge-group 100 unicast-flooding
    interface Vlan1
     no ip address
     bridge-group 1
     bridge-group 1 spanning-disabled
    interface Vlan100
     no ip address
     bridge-group 100
     bridge-group 100 spanning-disabled
    interface BVI1
     description $FW_INSIDE$
     ip address 192.168.10.2 255.255.255.0
     ip access-group 102 in
     ip nat inside
     ip virtual-reassembly in
    interface BVI100
     description $FW_INSIDE$
     ip address 10.1.1.1 255.255.255.0
     ip access-group 103 in
     ip nat inside
     ip virtual-reassembly in
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/gui
    ip dns server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.10.1
    ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.1.1.0 0.0.0.255
    access-list 1 permit 192.168.10.0 0.0.0.255
    access-list 1 permit 10.1.10.0 0.0.0.3
    access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
    access-list 2 remark SDM_ACL Category=1
    access-list 2 permit 192.168.10.2
    access-list 2 permit 10.1.10.0 0.0.0.3
    access-list 2 permit 192.168.10.0 0.0.0.255
    access-list 2 permit 10.1.1.0 0.0.0.255
    access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
    access-list 3 remark SDM_ACL Category=1
    access-list 3 permit 212.147.47.216
    access-list 3 deny   any
    access-list 100 remark auto generated by SDM firewall configuration
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
    access-list 100 deny   ip host 255.255.255.255 any
    access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_8##
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
    access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
    access-list 101 deny   ip 10.1.1.0 0.0.0.255 any
    access-list 101 deny   ip 192.168.10.0 0.0.0.255 any
    access-list 101 deny   ip 192.168.1.0 0.0.0.255 any
    access-list 101 deny   ip host 255.255.255.255 any
    access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 101 permit ip any any
    access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_6##
    access-list 102 remark SDM_ACL Category=1
    access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
    access-list 102 deny   ip 10.1.1.0 0.0.0.255 any
    access-list 102 deny   ip 192.168.1.0 0.0.0.255 any
    access-list 102 deny   ip host 255.255.255.255 any
    access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 102 permit ip any any
    access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_8##
    access-list 103 remark SDM_ACL Category=1
    access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
    access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
    access-list 103 deny   ip 10.1.10.0 0.0.0.3 any
    access-list 103 deny   ip 192.168.10.0 0.0.0.255 any
    access-list 103 deny   ip 192.168.1.0 0.0.0.255 any
    access-list 103 deny   ip host 255.255.255.255 any
    access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 103 permit ip any any
    access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_14##
    access-list 104 remark SDM_ACL Category=1
    access-list 104 deny   ip 10.1.10.0 0.0.0.3 any
    access-list 104 deny   ip 10.1.1.0 0.0.0.255 any
    access-list 104 permit ip any any
    access-list 104 permit udp host 8.8.8.8 eq domain any
    access-list 104 permit icmp any any echo-reply
    access-list 104 permit icmp any any time-exceeded
    access-list 104 permit icmp any any unreachable
    access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
    access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 104 deny   ip 192.168.0.0 0.0.255.255 any
    access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 104 deny   ip host 255.255.255.255 any
    access-list 104 deny   ip host 0.0.0.0 any
    access-list 104 deny   ip any any
    control-plane
    bridge 1 route ip
    bridge 100 route ip
    voice-port 0/0/0
     cptone CH
     station-id name FAX
     station-id number 99
     caller-id enable
    voice-port 0/0/1
     cptone CH
     shutdown
     caller-id enable
    voice-port 0/0/2
     cptone CH
     shutdown
     caller-id enable
    voice-port 0/0/3
     cptone CH
     shutdown
     caller-id enable
    voice-port 0/1/0
     compand-type a-law
     cptone CH
     bearer-cap Speech
    voice-port 0/1/1
     compand-type a-law
     cptone CH
     bearer-cap Speech
    voice-port 0/4/0
     auto-cut-through
     signal immediate
     input gain auto-control -15
     description Music On Hold Port
    sccp local Loopback0
    sccp ccm 10.1.1.1 identifier 1 version 4.0
    sccp
    sccp ccm group 1
     associate ccm 1 priority 1
     associate profile 2 register mtpa4934c6ee4e0
    dspfarm profile 2 transcode
     description CCA transcoding for SIP Trunk VTX
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     maximum sessions 10
     associate application SCCP
    dial-peer cor custom
     name internal
     name local
     name local-plus
     name international
     name national
     name national-plus
     name emergency
     name toll-free
    dial-peer cor list call-internal
     member internal
    dial-peer cor list call-local
     member local
    dial-peer cor list call-local-plus
     member local-plus
    dial-peer cor list call-national
     member national
    dial-peer cor list call-national-plus
     member national-plus
    dial-peer cor list call-international
     member international
    dial-peer cor list call-emergency
     member emergency
    dial-peer cor list call-toll-free
     member toll-free
    dial-peer cor list user-internal
     member internal
     member emergency
    dial-peer cor list user-local
     member internal
     member local
     member emergency
     member toll-free
    dial-peer cor list user-local-plus
     member internal
     member local
     member local-plus
     member emergency
     member toll-free
    dial-peer cor list user-national
     member internal
     member local
     member local-plus
     member national
     member emergency
     member toll-free
    dial-peer cor list user-national-plus
     member internal
     member local
     member local-plus
     member national
     member national-plus
     member emergency
     member toll-free
    dial-peer cor list user-international
     member internal
     member local
     member local-plus
     member international
     member national
     member national-plus
     member emergency
     member toll-free
    dial-peer voice 1 pots
     destination-pattern 99
     port 0/0/0
     no sip-register
    dial-peer voice 2 pots
     port 0/0/1
     no sip-register
    dial-peer voice 3 pots
     port 0/0/2
     no sip-register
    dial-peer voice 4 pots
     port 0/0/3
     no sip-register
    dial-peer voice 5 pots
     description ** MOH Port **
     destination-pattern ABC
     port 0/4/0
     no sip-register
    dial-peer voice 6 pots
     description tcatch all dial peer for BRI/PRIv
     translation-profile incoming nondialable
     incoming called-number .%
     direct-inward-dial
    dial-peer voice 50 pots
     description ** incoming dial peer **
     incoming called-number ^AAAA$
     direct-inward-dial
     port 0/1/0
    dial-peer voice 51 pots
     description ** incoming dial peer **
     incoming called-number ^AAAA$
     direct-inward-dial
     port 0/1/1
    dial-peer voice 2000 voip
     description ** cue voicemail pilot number **
     translation-profile outgoing XFER_TO_VM_PROFILE
     destination-pattern 98
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     voice-class sip outbound-proxy ipv4:10.1.10.1
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 2001 voip
     description ** cue auto attendant number **
     translation-profile outgoing PSTN_CallForwarding
     destination-pattern 97
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     voice-class sip outbound-proxy ipv4:10.1.10.1
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 2012 voip
     description ** cue prompt manager number **
     translation-profile outgoing PSTN_CallForwarding
     destination-pattern 96
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     voice-class sip outbound-proxy ipv4:10.1.10.1
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 1000 voip
     permission term
     description ** Incoming call from SIP trunk (VTX) **
     session protocol sipv2
     session target sip-server
     incoming called-number .%
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     fax rate 14400
     fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1001 voip
     corlist outgoing call-local
     description ** star code to SIP trunk (VTX) **
     destination-pattern *..
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     fax rate 14400
     fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1003 voip
     description ** Passthrough Inbound Calls for PSTN from CUE **
     translation-profile incoming SIP_Passthrough
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     incoming called-number ABCDT
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 1005 voip
     description ** Passthrough Inbound Calls for MWI from CUE **
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     incoming called-number A80T
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 1009 voip
     description ** Passthrough Inbound Calls for Internal Extensions from CUE **
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     incoming called-number ^..$
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 1033 voip
     corlist outgoing call-local
     description **CCA*Switzerland*Short Code Services**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 0187
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1042 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*Ambulance / Poisioning**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 0014[45]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1041 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*REGA Air Rescue**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 00333333333
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1025 voip
     corlist outgoing call-national
     description **CCA*Switzerland*National Destination Numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00[789]1.......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1020 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Regional Announcement VM**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 01600
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1040 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*REGA Air Rescue**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 000333333333
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1043 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*Ambulance / Poisioning**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 014[45]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1035 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Mobile Numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 007[46789].......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1024 voip
     corlist outgoing call-national-plus
     description **CCA*Switzerland*Personal Numbering**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00878......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1029 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Voicemail Access**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00860.........
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1036 voip
     corlist outgoing call-national
     description **CCA*Switzerland*VPN Access**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00869.............
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1027 voip
     corlist outgoing call-national-plus
     description **CCA*Switzerland*Premium Rate (Business)**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00900......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1026 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Test Numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00868T
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1034 voip
     corlist outgoing call-national-plus
     description **CCA*Switzerland*Shared Cost numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 0084[0248]......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1038 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*Emergency**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 0011[278]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1037 voip
     corlist outgoing call-toll-free
     description **CCA*Switzerland*Toll Free Numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00800......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1039 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*Emergency**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 011[278]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1032 voip
     corlist outgoing call-national
     description **CCA*Switzerland*National Destination Numbers**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 00[23456]........
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1023 voip
     corlist outgoing call-international
     description **CCA*Switzerland*International Calls**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 000T
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1031 voip
     description **CCA*Switzerland*Premium Rate (Social)**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 0090[16]......
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1030 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Short Code**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 014[0357]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1045 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*REGA/Glaciers Air Rescue**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 0141[45]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1028 voip
     corlist outgoing call-national-plus
     description **CCA*Switzerland*Directory Enquiries**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 018[15].
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1021 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Short Code**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 011[45].
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1022 voip
     corlist outgoing call-national
     description **CCA*Switzerland*Short Code Services**
     translation-profile outgoing PSTN_Outgoing
     preference 1
     destination-pattern 01[67].
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 1044 voip
     corlist outgoing call-emergency
     description **CCA*Switzerland*REGA/Glaciers Air Rescue**
     translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
     preference 1
     destination-pattern 00141[45]
     session protocol sipv2
     session target sip-server
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    dial-peer voice 2002 voip
     description ** cue voicemail PSTN number **
     translation-profile outgoing VM_Profile
     destination-pattern xxx$
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     voice-class sip outbound-proxy ipv4:10.1.10.1
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 2003 voip
     description ** cue auto attendant PSTN number **
     translation-profile outgoing AA_Profile
     destination-pattern xxx$
     b2bua
     session protocol sipv2
     session target ipv4:10.1.10.1
     voice-class sip outbound-proxy ipv4:10.1.10.1
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    dial-peer voice 1110 pots
     preference 9
     destination-pattern xxx
     port 0/0/0
     no sip-register
    dial-peer voice 3006 voip
     description SIP
     translation-profile incoming SIP_Called_9
     session protocol sipv2
     session target sip-server
     incoming called-number xxx.
     voice-class codec 1
     voice-class sip dtmf-relay force rtp-nte
     dtmf-relay rtp-nte
     ip qos dscp cs5 media
     ip qos dscp cs4 signaling
     no vad
    no dial-peer outbound status-check pots
    sip-ua
     keepalive target dns:site1.365873.trk.ipvoip.ch
     authentication username xxx password 7 xxx
     no remote-party-id
     retry invite 2
     retry register 10
     timers connect 100
     timers keepalive active 100
     registrar dns:site1.365873.trk.ipvoip.ch expires 3600
     sip-server dns:site1.365873.trk.ipvoip.ch
     host-registrar
    telephony-service
     sdspfarm units 5
     sdspfarm transcode sessions 10
     sdspfarm tag 2 mtpa4934c6ee4e0
     video
     fxo hook-flash
     max-ephones 40
     max-dn 300
     ip source-address 10.1.1.1 port 2000
     auto assign 1 to 1 type bri
     calling-number initiator
     service phone videoCapability 1
     service phone ehookenable 1
     service phone ehookEnable 1
     service dnis overlay
     service dnis dir-lookup
     service dss
     timeouts interdigit 5
     system message SwissT.Net
     url services http://10.1.10.1/voiceview/common/login.do
     url authentication http://10.1.10.1/voiceview/authentication/authenticate.do
     cnf-file location flash:
     cnf-file perphone
     user-locale U4 load CME-locale-de_DE-German-8.1.2.2.tar
     network-locale U4
     load 521G-524G cp524g-8-1-17
     load 525G spa525g-7-5-4
     load 501G spa50x-30x-7-5-2b
     load 502G spa50x-30x-7-5-2b
     load 504G spa50x-30x-7-5-2b
     load 508G spa50x-30x-7-5-2b
     load 509G spa50x-30x-7-5-2b
     load 525G2 spa525g-7-5-4
     load 301 spa50x-30x-7-5-2b
     load 303 spa50x-30x-7-5-2b
     time-zone 23
     time-format 24
     date-format dd-mm-yy
     keepalive 30 auxiliary 4
     voicemail 98
     max-conferences 8 gain -6
     call-forward pattern .T
     call-forward system redirecting-expanded
     hunt-group logout HLog
     moh flash:/media/music-on-hold.au
     multicast moh 239.10.16.16 port 2000
     web admin system name cisco secret 5 xxx
     dn-webedit
     time-webedit
     transfer-system full-consult dss
     transfer-pattern .T
     transfer-pattern 0.T
     transfer-pattern 6.. blind
     secondary-dialtone 0
     night-service day Sun 17:00 09:00
     night-service day Mon 17:00 09:00
     night-service day Tue 17:00 09:00
     night-service day Wed 17:00 09:00
     night-service day Thu 17:00 09:00
     night-service day Fri 17:00 09:00
     night-service day Sat 17:00 09:00
     fac standard
     create cnf-files version-stamp Jan 01 2002 00:00:00
    ephone-template  1
     url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
     service phone webAccess 0
     softkeys remote-in-use  Newcall
     softkeys idle  Redial Pickup Mobility Newcall Cfwdall Gpickup Dnd Login
     softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
     softkeys connected  Hold Endcall Trnsfer Mobility TrnsfVM Confrn Acct Park
     button-layout 7931 2
    ephone-template  15
     url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
     softkeys remote-in-use  Newcall
     softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
     softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
     softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
     button-layout 7931 2
    ephone-template  16
     url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
     softkeys remote-in-use  Newcall
     softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
     softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
     softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  17
     url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
     softkeys remote-in-use  CBarge Newcall
     softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
     softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
     softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  18
     url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
     softkeys remote-in-use  CBarge Newcall
     softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
     softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
     softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
     button-layout 7931 2
    ephone-dn  9
     number BCD no-reg primary
     description MoH
     moh out-call ABC
    ephone-dn  292
     number xxx
     description SIP Main Number registration
     preference 10
    ephone-dn  293  dual-line
     number 90 secondary xxx no-reg both
     label Zentrale
     description 90
     name Zentrale
     call-forward busy 98
     call-forward noan 98 timeout 20
    ephone-dn  294  dual-line
     number 94 secondary xxx no-reg both
     label LL
     description Lehrling Lehrnende
     name Lehrling Lehrnende
     mobility
     snr xxx delay 1 timeout 30 cfwd-noan 98
     snr ring-stop
     call-forward busy 98
     call-forward noan 98 timeout 20
    ephone-dn  295  dual-line
     number 93 secondary xxx no-reg both
     label CM
     description
     name
     snr xxx delay 1 timeout 30 cfwd-noan 98
     snr ring-stop
     call-forward busy 98
     call-forward noan 98 timeout 10
    ephone-dn  296  dual-line
     number 92 secondary xxx no-reg both
     label EE
     description
     name
     mobility
     call-forward busy 98
     call-forward noan 98 timeout 20
    ephone-dn  297  dual-line
     number 91 secondary xxx no-reg both
     label RS
     description
     name
     mobility
     snr xxx delay 1 timeout 30 cfwd-noan 98
     snr ring-stop
     call-forward busy 98
     call-forward noan 98 timeout 10
    ephone-dn  298
     number 6.. no-reg primary
     description ***CCA XFER TO VM EXTENSION***
     call-forward all 98
    ephone-dn  299
     number A801.. no-reg primary
     mwi off
    ephone-dn  300
     number A800.. no-reg primary
     mwi on
    ephone  1
     device-security-mode none
     mac-address A44C.11A0.B648
     ephone-template 1
     max-calls-per-button 2
     username "xxx" password xxx
     type 525G2
     button  1:296 2:293 3m297 4m295
     button  5m294
    ephone  2
     device-security-mode none
     mac-address A44C.11A0.B566
     ephone-template 1
     max-calls-per-button 2
     username "xxx" password xxx
     type 525G2
     button  1:297 2:293 3m296 4m295
     button  5m294
    ephone  3
     device-security-mode none
     mac-address A44C.11A0.B5C4
     ephone-template 1
     max-calls-per-button 2
     username "xxx" password xxx
     type 525G2
     button  1:295 2:293 3m297 4m296
     button  5m294
    ephone  4
     device-security-mode none
     mac-address A44C.11A0.B67A
     ephone-template 1
     max-calls-per-button 2
     username "xxx" password xxx
     type 525G2
     button  1:294 2:293 3m297 4m296
     button  5m295
    alias exec cca_voice_mode PBX
    alias exec cca_vm_notification schedule from_time=00 to_time=24
    alias exec clid-ALL_BRI ;1:0-4;1:0-9;1:0-9;1:1-9
    alias exec clid-SIP ;1:1-9;1:1-9;1:1-9
    banner login ^CCisco Configuration Assistant. Version: 3.2 (3). Fri Jul 04 13:18:33 CEST 2014^C
    line con 0
     no modem enable
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport input all
    line vty 0 4
     transport preferred none
     transport input all
    line vty 5 100
     transport preferred none
     transport input all
    ntp master
    ntp server 91.240.0.5 prefer
    en

    Hi Patrick
    I am working on this one as well. I have a UC560 with SIP Trunk provider Les.NET.
    It was working fine until a few weeks ago when something changed on the provider end and broke it. My hunch it is something to do with the SIP REFER.
    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-communications-manager-express/91535-cme-sip-trunking-config.html
    Here is an excerpt from the above page:
    Call Transfer
    When a call comes in on an SIP trunk to an SCCP Phone or CUE AutoAttendant (AA) and is transferred, the CME by default will send a SIP REFER message to the SP proxy. Most SP Proxy Servers do not support the REFER method. This needs to be configured in order to force the CME to hairpin the call:
    Router(config)#voice service voip
    Router(conf-voi-serv)#no supplementary-service sip refer
    Figure 3 shows the behavior of the CME system with the REFER method disabled.

  • Problem with Set/Get volume of input device with single channel

    from Symadept <[email protected]>
    to Cocoa Developers <[email protected]>,
    coreaudio-api <[email protected]>
    date Thu, Dec 10, 2009 at 2:45 PM
    subject Problem with Set/Get volume of input device with single channel
    mailed-by gmail.com
    hide details 2:45 PM (2 hours ago)
    Hi,
    I am trying to Set/Get Volume level of Input device which has only single channel but no master channel, then it fails to retrieve the kAudioDevicePropertyPreferredChannelsForStereo and intermittently kAudioDevicePropertyVolumeScalar for each channel. But this works well for Output device.
    So is there any difference in setting/getting the volume of input channels?
    I am pasting the downloadable link to sample.
    http://www.4shared.com/file/169494513/f53ed27/VolumeManagerTest.html
    Thanks in advance.
    Regards
    Mustafa
    Tags: MacOSX, CoreAudio, Objective C.

    That works but the the game will not be in full screen, it will have an empty strip at the bottom.
    I actually found out what's the problem. I traced the stageWidth and stageHeight during resizing event. I found out that when it first resized, the stage width and height were the size with the notification bar. So when I pass the stage into startling, myStarling = new Starling(Game,stage), the stage is in the wrong size. For some reason, I can only get the correct stage width and height after the third resizing event.
    So now I need to restart Starling everytime a resizing event happened. It gives me the right result but I am not sure it is a good idea to do that.
    And thanks a lot for your time kglad~I really appriciate your help.

  • How to configure optimal data connections to allow excel to retrieve multiple data sets form a single data source

    Hi all,
    I would like to have a data connection file used by excel to extract data form a SQL Server DB (so that change in location of the DB needs only a change to the  single data connection file). The excel file will retrieve data from only a single database,
    but there are multiple queries (30+) stored on SQL server that are used - each SQL server views' data is returned to a pivot table in an excel worksheet, which has an associated chart with various slicers on the main dashboard worksheet.
    Do I need a seperate data conenction file for each SQL server query being retrieved, or can a single connection file be created as all data comes from a single database?
    (all my attempts and research on the net have led me to believe that a seperate file is needed for each view, but this seems unnecessary)

    Hi, im learning my way with this, so apologies if I am providing too much or too little info.
    There are 8 source files which are very loosely related in that they capture infromation regarding what has happened within a metro railway over a day. However there are only a few relationships between the contents of tehse files.
    These tables are imported into SQL Server using SSIS where I have developed a number of views that query these 8 source tables to generate a number of metrics to provide insight into the service provided to the passengers. Some examples of metrics are: Number
    of passengers in transit at any given time, time taken to travel between adjacent stations, how much power was used during the day, what distance did the trains travel during the day, etc. Some views provide only a handful of rows, some provide 1M plus. There
    are now approx 40 seperate views created.
    I have then used a spreadsheet with a worksheet associated with each SQL server view. Each worksheet is set up as a pivot table, which allows the related chart on the main dashboard worksheet to use standard excel capability to slice and present the data
    in different ways.
    At the moment if the server on which teh database is stored moves, I have had to recreate the spreadsheet from scratch as I dont know how to change the connection information in any other way. Ideally I would like to have connection info in a single place
    to reduce ongoing maintenance, particularly as I would like to place the spreadsheet on a SharePoint server to distribute it to other users.
    Thanks

  • List of Values in Data foundation Layer Bi 4.0 Issues?

    I have an issue surrounding list of values’ created in the data foundation layer created using SQL. 
    The LOV can be associated with an object within the business layer. The business layer is then saved and closed, however on re-opening the association with the LOV is now displaying an error.
    We are currently on patch 15 of sp2,  are you aware of any issues using LOV from the data foundation layer. 

    This has now been fixed in sp4.

  • Create data merged document with data on every second page?

    Is it possible to create a data merged document with the variable data only on every second page?
    I have set up the pages with the variable data as a master page (on every odd page) with the text box and paragraph style all set up, and I have set 'override master page items' so the data can be placed, but InDesign seems to freeze up when I try to create the merged document?

    There should be no problem doing the merge with a two-page master and a two-page template document with fields only on one page (and off the top of my head there's no reason to move them off the master page if that's where you put them). I think the problem here is that rachrachm already has a file of 500 pages (based on another thread asking how to apply masters to every other page).
    It's potentially possible to simply place the data file (without the header row) as a text file and auto-flow through the master page frames (can't say for sure without seeing the files), or if the pages without the merge fields are the same just, remove all but the first two pages from the template and do the merge.
    As I metioned earlier, though, this is a very inefficient method of producing that sort of document. A true variable data print flow would be better (you'd need to find a commercial printer who can do it with your data file), or the home version would be to make one single page file for the static content, print 250 copies (plus a few extras, just in case), then make a single page merge template, do the merge, and print that on the back of the already printed pages, or as a separate page. It is immeasurably faster to print multiple copies of a document than it is to print a document that has multiple identical pages.

Maybe you are looking for