Distrubiting Server Function Loads and some random other questions...

This quesition is for anyone who has more experience and advice to give. I have often heard that you shouldn't have an all in one server-meaning, don't have a server that runs host your main sharepoints, is your filemaker server and runs your backups as well.
Logically this makes complete sense to me, but on the other hand it isn't happening in my environment. Perhaps its because I'm still very new to this. Allow me to give my setup as an example. An XServe G4 DP 1.33GHz with 1 GB of RAM. The four internal drives are set up as follow. Drive 1 is system. Drives 2-4 are striped. Attached to it we have a XRaid with the left 7 drives (1.3TB) mirrored to the right side. (I know this may sound like an utter waste but authority dicates I keep it this way.) In addition to the XRaid there are two firewire 800 drives attached for backup purposes as well as an Sony AIT3 Lib-81 Tape Library which is also for backup purposes.
This is what the server does. Its a filesever for the 20-30 staff. The only services that are active on it are AFP, Open Directory, Windows. No user accounts are stored on the server everyone here is a happy community that logs in as guest. (scary-I know). Filemaker runs on the server (only 2-3 ppl access the project managing database at any time), and Now Contact/Calendar run on the server as well. Retrospect runs incremental backups nightly and heavier backups on the weekend. That is what the server does, it does a good job of it despite Retrospect hiccuping every once in a while.
1. Is there better way to distrubute tasks? Is there a need to getting another server for the environment above?
2. I suspect that since I will have to be opening up a VPN to the server our happy no-password community will become all passworded logins. Correct?
3. The Xserve RAID, it has copper fibre channel connectivity to the Xserve. It also has and ethernet connection for each of the Network controllers. This is something I have often wondered. When a user requests a file that resides on the Xserve, what is the path that file takes in getting to user. Eventually either way its going through ethernet, but is it directly from the Xraid across ethernet or through the fibre-channel to the Xserve and then through ethernet. I guess I'm asking this because the way the Xserve/Raid are set up currently only the Lower Controller has an ethernet cable hooked up to it, I was wondering if it would benefit me at all to have the upper controller hooked up as well.
Right now everything works as it should and it doesn't seem like anything is too taxed. My plans in order are to upgrade from panther to tiger, open up vpn to the server, and upgrade our internal network to gigabit!
I look forward to anyones feedback...
thanks for your time
  Mac OS X (10.4.3)  

NetStream.send() should usually be faster than NetGroup.post(), especially when using 1:1 NetStreams (vs Group NetStreams).
when groups are large, there's no passive way to tell when members join or leave.  however, for small groups (less than about 15 members), they will be "fully meshed", meaning every member has a direct connection to every other member.  when that's the case, you can see the NetGroup.Neighbor.Connect/Disconnect events on a NetGroup.  to receive those, you must create a NetGroup with the same groupspec as your NetStream and listen for NetStatusEvent.NET_STATUS events.
your function "msg" must be a method on the subscribing NetStream's "client" object to receive NetStream.send()s from the publisher.
this is all generic ActionScript stuff.  i don't know how to use Flash CS5 but this stuff should all be the same in Flash and Flash Builder.
-mike

Similar Messages

  • Occasionally,  some of the image borders turn dark grey (medium grey is the default) and then random other  images cannot be opened with a double click.  They only open when selected using the arrows on the keyboard.  They also cannot be moved to collecti

    Occasionally,  some of the image borders turn dark grey (medium grey is the default) and then random other  images cannot be opened with a double click.  They only open when selected using the arrows on the keyboard.  They also cannot be moved to collections.  Anyone have a solution for this?

    When you say  "could not be opened"- what are you referring to?  A double click of the mouse should view the clicked image in Loupe view- the same as pressing [E] on the keyboard for an enlarged view. (And a second double-click will take you back to library grid view.)
    To "open" an image in the Development module requires you to select the image then press [D] or click on the [Develop] button.
    When you say "could not be ...moved" -what are you referring to?  Are you trying to move an image file from its place in a folder to another folder? Are you just wanting it in a collection? When you drag an image to a collection you are only placing a link to the image in the collection- not actually moving any file. The image will stay exactly where it is in its original folder and will remain as a thumbnail preview in the Library Grid view.
    Are you having any "mouse" problems that may be changing its actions in LR ?
    Do you see an exclamation mark on any image borders ?
    Let's keep working on this. I am curious to see you find an answer.
    Rob

  • How to load and replace random swfs into same loader on stage?

    Hi...this is very simple, but, for some reason escapes me: using AS3 how can a swf load another swf to replace itself in the same loader on the stage, while simultaneously calling a randomizing function in the first frame of the main timeline, to randomize the next swf?
    At the end of each swf (called "koan_#.swf") there is the following old AS2 code...it was used to randomly select and then play a swf from koan array:
    _root.index++
    if(_root.index>_root.koan.length-1){
    _root.index=0;
    _root.koan.shuffle();
    _root.koan_loader_mc.loadMovie(_root.koan[_root.index]);
    This code on the first frame of the main timeline loads a random koan swf properly, but, after the koan plays I would like to load a new random koan swf.
    function shuffle(a:Array):Array {
    var len:Number = a.length-1;
    for (var ivar:Number = len; ivar>=0; ivar--) {
      var p:Number = Math.floor(Math.random()*(ivar+1));
      var t = a[ivar];
      a[ivar] = a[p];
      a[p] = t;
    return a;
    var index:uint = 0;
    var koan_loader:Loader = new Loader();
    var koan:Array =["swfs/koans/koan_1.swf","swfs/koans/koan_2.swf", "swfs/koans/koan_3.swf", "swfs/koans/koan_4.swf", "swfs/koans/koan_5.swf", "swfs/koans/koan_6.swf", "swfs/koans/koan_7.swf", "swfs/koans/koan_8.swf", "swfs/koans/koan_9.swf", "swfs/koans/koan_10.swf", "swfs/koans/koan_11.swf", "swfs/koans/koan_12.swf"];
    koan = shuffle(koan);
    koan_loader.load(new URLRequest(koan[index]));
    MovieClip(this).koan_loader_mc.addChild(koan_loader);
    Thank you very much.  I've tried multiple variations of updated AS2 code but am at my wits end. 

    Alright, the bloody forums won't attach the file for some reason, so here is the code:
    Copy and paste this code into a text file and save it as InterfaceEvent.as
    package {
         import flash.events.Event;
         public class InterfaceEvent extends Event {
              public static const KOAN_FINISHED:String = "koanFinished";
              public function InterfaceEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, index:int = -1, item:Object = null) {
                   super(type, bubbles, cancelable);
                   this.index = index;
                   this.item = item;
              public var index:int = -1;
              public var item:Object = null;
              override public function clone():Event {
                   return new InterfaceEvent(this.type, this.bubbles, this.cancelable, this.index, this.item);

  • Calling java function load and stored in database

    Hi ,
    I try to call a java fonction loaded and published in database (Oracle 8.1.7.4ee). this function call an OS command ... the PL/SQL call is completed but de command set in parameters function is not execute ... next is the code :
    import java.lang.*;
    import java.io.*;
    public class JShell {
    public static void execute (String command) throws IOException {
    try {
    Process child = Runtime.getRuntime().exec(command);
    } catch (IOException e) {
    calling this function with java main is OK
    import java.lang.*;
    import java.io.*;
    public class TestJShell {
    static public void main(String args[]) throws Exception
    JShell.execute(args[0].toString());
    java TestJShell 'cp /test/myfile.txt /test/myfile.sav'
    copy is donethen when the fuction is loaded and published in database
    as
    loadjava -user ../.. JShell.class
    CREATE OR REPLACE PROCEDURE JShell_exe (Commande in VARCHAR2) AS LANGUAGE JAVA NAME 'JShell.execute(java.lang.String)';run is
    CALL ell_exe ('cp /test/myfile.txt /test/myfile.sav');
    call is completed but no copy is doneCan somebody help me ? thanking you in anticipation;

    Firs things first:
    1)Which copy of your class is loaded in the DB ( it seems that you have two different classes JShell and TestJShell ).
    2)Do you have permisions for file manipulation ?
    3)Do you get any errors ?

  • IPad crashes on iTunes Store and some random Safari site.  Frequency seems to be increasing.  Anyone else having problem or have thoughts re: causes?

    iPad crashes on iTunes Sore and some randon Safari site.  Frequency seems to be increasing.  Any thought, ideas, suggestions, please?

    Start with a system reset.  It cures many ills and it's quick, easy and harmless...
    Hold down the on/off switch and the Home button simultaneously until the screen blacks out or you see the Apple logo.  Ignore the "Slide to power off" text if it appears.  You will not lose any apps, data, music, movies, settings, etc.
    Others have had difficulty with this issue.  There are other things that you can try but you may well end up at the local Apple Store with the resident "Genius."

  • Class load and instance memory footprint questions

    Lets say I have CLASS_A that has three members:
    private int a;
    private int b;
    private int c;
    but lets say Class_A has 32 methods manipulating the state of the object.
    For argument sake lets say when CLASS_A is compiled this class (Bytecode) file comes out to be 32Kilobytes.
    Now when my compiler has to load this class it loads the whole 32 kilo class file. but for subsequent instances of CLASS_A will the footprint for each instance be 32 Kilobytes or will it be the 12 (4X3)bytes that are needed to represent the member variables (+ some more bytes to refer to classname or something)?
    I guess my question is does each instance take up 32 Kilobytes?
    Thanks for all replies !

    No, each instance (within the same JVM process) will take up the amount that the instance variables take up, not that plus the instance methods. The implementation code won't get loaded multiple times.

  • Hard Drive on iPhone? How to delete it..and a few other questions

    Hello!
    I'm a fairly new iPhone user so I apologize in advance if this is a stupid question. Is there a hard drive on my iPhone? If so, how can I delete the info on it? Will it delete my contacts and things like that? How do I do it?
    Thanks so much!
    I have the iPhone 4 version 4.2.1

    The iPhone does not have a hard drive. It has a flash drive or flash storage.
    If you wipe the entire flash drive, everything will be deleted except for the firmware/OS and all included apps.
    You can erase all content and settings direct on the iPhone at Settings > General > Reset, which is a secure erase, or you can restore your iPhone with iTunes as a new iPhone or not from your iPhone's backup which is not a secure erase of all data and settings.

  • Lightroom 5.4 64-bit crashes when switching to develop module (and during random other functions)

    This seems to be a new issue that has developed over the past few days. I have been using Lightroom for multiple years without too many issues. Within the last 90 days I have upgraded to Lightroom 5. Today, upon loading up Lightroom (either 3.6 or 5.2) they both crash upon switching over to the develop module. I have upgraded 5.2 to 5.4, uninstalled 3.6, restarted my computer; still crashes with error message: "Adobe Photoshop Lightroom 64-bit has stopped working - A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." Which upon clicking "Close Program" it simply closes the program. Any ideas as to why this is happening and a possible fix? This is greatly impacting workflow. Following is a copy of my System info from Lightroom.
    Lightroom version: 5.4 [955652]
    Operating system: Windows 8.1 Home Premium Edition
    Version: 6.3 [9600]
    Application architecture: x64
    System architecture: x64
    Logical processor count: 8
    Processor speed: 2.3 GHz
    Built-in memory: 7944.2 MB
    Real memory available to Lightroom: 7944.2 MB
    Real memory used by Lightroom: 298.6 MB (3.7%)
    Virtual memory used by Lightroom: 268.0 MB
    Memory cache size: 103.5 MB
    Maximum thread count used by Camera Raw: 4
    System DPI setting: 96 DPI
    Desktop composition enabled: Yes
    Displays: 1) 1920x1080
    Application folder: C:\Program Files\Adobe\Adobe Photoshop Lightroom 5.4
    Library Path: C:\Users\Joshuah\Pictures\Lightroom\Lightroom 5 Catalog.lrcat
    Settings Folder: C:\Users\Joshuah\AppData\Roaming\Adobe\Lightroom
    Installed Plugins:
    1) Behance
    2) Canon Tether Plugin
    3) Facebook
    4) Flickr
    5) Leica Tether Plugin
    6) Nikon Tether Plugin
    Config.lua flags: None
    Adapter #1: Vendor : 8086
        Device : 416
        Subsystem : fa721179
        Revision : 6
        Video Memory : 0
    Adapter #2: Vendor : 1414
        Device : 8c
        Subsystem : 0
        Revision : 0
        Video Memory : 0
    AudioDeviceIOBlockSize: 1024
    AudioDeviceName: Speakers (Conexant SmartAudio HD)
    AudioDeviceNumberOfChannels: 2
    AudioDeviceSampleRate: 44100
    Build: Uninitialized
    CardID: 1046
    Direct2DEnabled: false
    GPUDevice: D3D
    MaxTexture2DSize: 8192
    OGLEnabled: true
    Renderer: Intel(R) HD Graphics 4600
    ShaderModel: 11.1
    Vendor: Intel
    VendorID: 32902
    Version: 8086:0416:fa721179:0006

    I have had this same issue now. I have been away from my pc for a week or so and now i cannot use the Develop button
    Lightroom version: 5.4 [955652]
    Operating system: Windows 7 Business Edition
    Version: 6.1 [7601]
    Application architecture: x64
    System architecture: x64
    Logical processor count: 8
    Processor speed: 3.5 GHz
    Built-in memory: 32651.3 MB
    Real memory available to Lightroom: 32651.3 MB
    Real memory used by Lightroom: 366.3 MB (1.1%)
    Virtual memory used by Lightroom: 328.1 MB
    Memory cache size: 205.9 MB
    Maximum thread count used by Camera Raw: 4
    System DPI setting: 96 DPI
    Desktop composition enabled: Yes
    Displays: 1) 1920x1080, 2) 1920x1080, 3) 1920x1080
    Seeming this seems to have stopped around the 21st of May and its now the 9th of June, does this mean we just do nothing about it and hope and pray that one day Adobe, who are very quick to take our money every month, can resolve this ? Has there been a fix noted for this yet ?

  • AS3 array used to load and play random swfs?

    Hi, I'm trying to use an array adapted from AS2 script to load random swfs called "koan_1.swf" or "koan_2.swf" etc into a "koan_loader_mc" on the stage.  Each "koan_#.swf" has code in its last frame to both advance the "shuffle" array in the action script in the first frame of the stage and to load the next koan swf.  The code below -- almost -- works, but....?
    Frame on main stage:
    // creates function called at the end of koan_#.swfs
    function shuffle(a:Array) {
    for (var ivar = a.length-1; ivar>=0; ivar--) {
    var p = Math.floor(Math.random())(ivar+1);
    var t = a[ivar];
    a[ivar] = a[p];
    a[p] = t;
    // loads koans into koan_loader_mc
    var index:uint = 0;
    var koan_loader:Loader = new Loader();
    var koan:Array =["swfs/koans/koan_1.swf","swfs/koans/koan_2.swf", "swfs/koans/koan_3.swf", "swfs/koans/koan_4.swf", "swfs/koans/koan_5.swf", "swfs/koans/koan_6.swf", "swfs/koans/koan_7.swf", "swfs/koans/koan_8.swf", "swfs/koans/koan_9.swf", "swfs/koans/koan_10.swf", "swfs/koans/koan_11.swf", "swfs/koans/koan_12.swf"];
    koan.shuffle();
    koan_loader.load(new URLRequest(koan[index]));
    MovieClip(this).koan_loader_mc.addChild(koan_loader);
    MovieClip(this).stop();
    Code is on the last frame of the loaded koan swfs:
    MovieClip(stage).index++
    if(MovieClip(stage).index>MovieClip(stage).koan.length-1){
    MovieClip(stage).index=0;
    MovieClip(stage).koan.shuffle();
    MovieClip(stage).koan_loader.load(new URLRequest(koan[MovieClip(stage).index]));
    MovieClip(stage).koan_loader_mc.addChild(koan_loader);
    Thanks for -- any -- guidance and suggestions...at my wit's end...

    Thank you for taking the time to help, but......unfortunately it still isn't working.  When the "koan.shuffle():" segment of code on the first frame of the stage timeline, below, is commented out, everything else in the movie (except randomizing of swfs) works fine.
    This code loads swfs (but they are not randomized/shuffled):
    // loads koans into koan_loader_mc
    var index:uint = 0;
    var koan_loader:Loader = new Loader();
    var koan:Array =["swfs/koans/koan_1.swf","swfs/koans/koan_2.swf", "swfs/koans/koan_3.swf", "swfs/koans/koan_4.swf", "swfs/koans/koan_5.swf", "swfs/koans/koan_6.swf", "swfs/koans/koan_7.swf", "swfs/koans/koan_8.swf", "swfs/koans/koan_9.swf", "swfs/koans/koan_10.swf", "swfs/koans/koan_11.swf", "swfs/koans/koan_12.swf"];
    //koan.shuffle(); 
    koan_loader.load(new URLRequest(koan[index]));
    MovieClip(this).koan_loader_mc.addChild(koan_loader);
    Thanks again for your help....

  • After downloading OS X Yosemite some websites won't load and some will

    I recently installed Yosemite on my Macbook (mid 2010), The update went fine, except some issues with iPhoto but that is solved now, the main issue is since the update some websites on Safari and Google Chrome will not load anymore. Some will( e.g. Bing) but most won't anymore. I have looked at system preferences and my internet connection and everything works fine. It is not just Safari and Chrome also the Appstore can't seem to connect to the internet either but Skype can. I do not know how to fix this issue.
    I have another account on my laptop which works fine, this obviously also has Yosemite, internet works fine, App Store works fine etc. and it seems to me that the settings are the same.  But this is not an account i normally use and i would like to be able to use my normal one again.

    HI I am having the same problem.
    1. The Activity window on Safari doesn't show anything. Sometimes it shows a ?.
    2. Booted on Safe Mode and the same thing.
    3. Connected wired to the Time Capsule, Wired to the Modem and same problem but connected Wireless with Airport and it works.
    4. No software PeerGuardian or Firewall installed.
    5. Network utility was unable to Ping apple.com or me.com.
    6. Put the OpenDNS settings and I am still not able to go to Apple.com or me.com but I am able to ping with Network Utility and if I enter the IP of Apple.com it loads. However, Me.com doesn't.
    7. Tried creating another account and problem is the same.
    8. With any other computer the problem is not there.
    9. Direct connection with ethernet to a computer works fine for data transfer or any other DL works also fine without interruption.
    I have been using Airport up until now but now I am setting a Server and I need the Ethernet working fine.
    Thank you,

  • Some new messages or some that I respond to do not go out, and some from others do not arrive. This seems to be a new problem.

    I have sent test messages to my self several times today to and from from each of my addresses and they show in my sent folder but do not arrive. Others that I know were sent to me did not arrive. In one case, the same message sent again did arrive. Other mail does arrive, but I now wonder how much I'm missing. I need some help?

    if Mail goes to your sent folder without error, Thunderbird has received a "sent ok" from the outgoing server. Your mail is not arriving, time to talk to your service provider. They probably have spam rules and are quarantining your mail somewhere or are simply dropping it as SPAM. There is no guarantee of delivery or of notification of failure in the email protocols and the larger ISPs in the US especially make significant use of that absence in their cavalier spam policies.

  • ACE: if one server is loaded and it want to use the server not loaded? how?

    Hello,
    I have 2 real Servers (10.24.8.200 and 10.24.8.201) in loadbalance (HTTP and HTTPS) with VIP 10.24.16.10, and the type of loadbalance is round robin, but when the server (10.24.8.200) has high proccessing for example memory or hard disk and users try to access to server (10.24.8.200) this is more slow. if this server is too loaded? how can the ACE switch to another real server? in 10 seconds for example?
    Best Regards
    My configuration is:
    ACE-MOD6/integracion1# sh runn
    Generating configuration....
    access-list anyone line 8 extended permit ip any any
    probe http get-index
    interval 4
    open 2
    recieve 2
    faildetect 2
    passdetect interval 10
    expect status 200 200
    rserver host Srv1
    ip address 10.24.8.200
    probe get-index
    inservice
    rserver host Srv2
    ip address 10.24.8.201
    probe get-index
    inservice
    serverfarm host servers
    rserver Srv1
    inservice
    rserver Srv2
    inservice
    class-map type management match-any ADM-CONTEX-SERV1
    2 match protocol telnet any
    3 match protocol ssh any
    4 match protocol icmp any
    class-map type http loadbalance match-all Check-Headers
    2 match http url .*
    3 match http header Host header-value "10.24.16.*"
    4 match http header User-Agent header-value ".*MSIE.*"
    class-map match-all VIP-10-HTTP
    2 match virtual-address 10.24.16.10 tcp eq www
    class-map type http loadbalance match-all other-HTTP
    2 match http url .*
    policy-map type management first-match ADM-CTX-SERV1
    class ADM-CONTEX-SERV1
    permit
    policy-map type loadbalance first-match L7-logic
    class Check-Headers
    serverfarm servers
    class other-HTTP
    serverfarm servers
    policy-map type loadbalance first-match lb-logic
    class class-default
    serverfarm servers
    policy-map multi-match client-vips
    class VIP-10-HTTP
    loadbalance vip inservice
    loadbalance policy L7-logic
    loadbalance vip icmp-reply active
    interface vlan 60
    description inside
    ip address 10.24.8.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    no shutdown
    interface vlan 233
    description outside
    ip address 10.24.16.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    service-policy input client-vips
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.24.16.1

    If your server is running an SNMP agent, the ACE can use SNMP to pull stats from the server. You'll just need the correct OID. For instance, if you were using Linux, you might use something like the following as a probe:
    probe snmp linux-stats
    interval 10
    community public
    oid .1.3.6.1.4.1.2021.10.1.5.1
    threshold 75
    .1.3.6.1.4.1.2021.10.1.5.1 is the OID for CPU load average (for Linux, Windows would have a different OID). If it goes above 75, the server is marked as out. When used with the least-loaded predictor, it will also divert more traffic to the least loaded server, as defined by that OID. You can use multiple OIDs in conjunctions and give them different weights.
    However, judging from your timeout value of your get-http health check, I would check to see if the issue isn't that your servers are flapping because of a too-low receive threshold. Each server has 2 seconds to respond to the ACE, which may not enough time given that the servers may be getting a lot of traffic and you're doing these checks every 4 seconds.
    If one fails, the other gets all the traffic, until it is overloaded, and it fails. By this time, your other servers has calmed down, and gets all the traffic, and the cycle repeats itself. Check SNMP traps or SYSLOG to see if this is the case.
    Either way, you might want to change the timeout to 5 or 10, to give them more breathing room.

  • I have just done a c drive clean and now i have a problem with wed site, the background will not load and some web i get error massages

    Im using explorer to ask this question
    here a screen shot of ninemsn web site
    [http://example.com http://imageshack.us/photo/my-images/830/screenshot019ez.jpg/]
    one of the error massage i get,
    File not found
    Firefox can't find the file at http://www.raafsquad.com/welcome.htm.
    Check the file name for capitalization or other typing errors.
    Check to see if the file was moved, renamed or deleted.

    Clear the cache and the cookies from sites that cause problems.
    "Clear the Cache":
    * Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
    "Remove Cookies" from sites causing problems:
    * Tools > Options > Privacy > Cookies: "Show Cookies"

  • My e-mail is not loading and some plug-in are not working after upgrade.

    My e-mail does not load, but I can load it in Internet explorer
    my wed site does not show my talking characters after the firefox up-grade

    you should visit apple genius at apple sotre .

  • My E-mail takes for ever to load and some times freezes to open e-mail messages

    Ever since I changed to Firefox, it takes for ever to download my email. When I click to open e-mail messages, it freezes up and have to refresh or reload. Does not happen all the time but most frequently I am having a problem. All other features with Firefox are faster than Internet Explorer.

    Firefox doesn't do email, it's a web browser.
    If you are using Firefox to access web mail, you need to seek support from your service provider or a forum for that service.
    If your problem is with Thunderbird, see this forum for support. <br />
    [http://www.mozillamessaging.com/en-US/support/] <br />
    or this one <br />
    [http://forums.mozillazine.org/viewforum.php?f=39]

Maybe you are looking for