ACE: if one server is loaded and it want to use the server not loaded? how?

Hello,
I have 2 real Servers (10.24.8.200 and 10.24.8.201) in loadbalance (HTTP and HTTPS) with VIP 10.24.16.10, and the type of loadbalance is round robin, but when the server (10.24.8.200) has high proccessing for example memory or hard disk and users try to access to server (10.24.8.200) this is more slow. if this server is too loaded? how can the ACE switch to another real server? in 10 seconds for example?
Best Regards
My configuration is:
ACE-MOD6/integracion1# sh runn
Generating configuration....
access-list anyone line 8 extended permit ip any any
probe http get-index
interval 4
open 2
recieve 2
faildetect 2
passdetect interval 10
expect status 200 200
rserver host Srv1
ip address 10.24.8.200
probe get-index
inservice
rserver host Srv2
ip address 10.24.8.201
probe get-index
inservice
serverfarm host servers
rserver Srv1
inservice
rserver Srv2
inservice
class-map type management match-any ADM-CONTEX-SERV1
2 match protocol telnet any
3 match protocol ssh any
4 match protocol icmp any
class-map type http loadbalance match-all Check-Headers
2 match http url .*
3 match http header Host header-value "10.24.16.*"
4 match http header User-Agent header-value ".*MSIE.*"
class-map match-all VIP-10-HTTP
2 match virtual-address 10.24.16.10 tcp eq www
class-map type http loadbalance match-all other-HTTP
2 match http url .*
policy-map type management first-match ADM-CTX-SERV1
class ADM-CONTEX-SERV1
permit
policy-map type loadbalance first-match L7-logic
class Check-Headers
serverfarm servers
class other-HTTP
serverfarm servers
policy-map type loadbalance first-match lb-logic
class class-default
serverfarm servers
policy-map multi-match client-vips
class VIP-10-HTTP
loadbalance vip inservice
loadbalance policy L7-logic
loadbalance vip icmp-reply active
interface vlan 60
description inside
ip address 10.24.8.5 255.255.255.0
access-group input anyone
access-group output anyone
service-policy input ADM-CTX-SERV1
no shutdown
interface vlan 233
description outside
ip address 10.24.16.5 255.255.255.0
access-group input anyone
access-group output anyone
service-policy input ADM-CTX-SERV1
service-policy input client-vips
no shutdown
ip route 0.0.0.0 0.0.0.0 10.24.16.1

If your server is running an SNMP agent, the ACE can use SNMP to pull stats from the server. You'll just need the correct OID. For instance, if you were using Linux, you might use something like the following as a probe:
probe snmp linux-stats
interval 10
community public
oid .1.3.6.1.4.1.2021.10.1.5.1
threshold 75
.1.3.6.1.4.1.2021.10.1.5.1 is the OID for CPU load average (for Linux, Windows would have a different OID). If it goes above 75, the server is marked as out. When used with the least-loaded predictor, it will also divert more traffic to the least loaded server, as defined by that OID. You can use multiple OIDs in conjunctions and give them different weights.
However, judging from your timeout value of your get-http health check, I would check to see if the issue isn't that your servers are flapping because of a too-low receive threshold. Each server has 2 seconds to respond to the ACE, which may not enough time given that the servers may be getting a lot of traffic and you're doing these checks every 4 seconds.
If one fails, the other gets all the traffic, until it is overloaded, and it fails. By this time, your other servers has calmed down, and gets all the traffic, and the cycle repeats itself. Check SNMP traps or SYSLOG to see if this is the case.
Either way, you might want to change the timeout to 5 or 10, to give them more breathing room.

Similar Messages

  • I have a new computer and I want to use the "MasterPassword" again. How do I import all of the saved website passwords/logins from my old FireFox computer?

    I have a new computer and I want to use the "MasterPassword" again. How do I import all of the saved website passwords/logins from my old FireFox computer?

    A couple of methods.
    The first is to copy 2 files, key3,db and signons.sqlite from the profile folder of the old computer t the profile folder of the new computer. For details of how to find the profile folder see the [[profiles]] article.
    The second method is to install the [https://addons.mozilla.org/en-US/firefox/addon/2848/ Password Exporter] add-on on both computers and use that to export/import the passwords.

  • I have a rather old iMac 20" (mid 2007) and I want to upgrade the Hard drive. How do I change it? How do I transfer all my applications? May I just copy the old hd into the new one? Thanks.

    I have a rather old iMac 20" (mid 2007) and I want to upgrade the Hard drive. How do I change it? How do I transfer all my applications? May I just copy the old hd into the new one? Thanks.

    There are many online tutorials on how to change out the HD on a mid 2007 iMac. One of the originals is from 2007 and is Upgrade your iMac 20" or iMac 24" aluminum (mid 2007) to 1TB Hard Drive and 4 GB RAM - DIY Guide. As far as migrating your system Apple helps out with that in Setup Assistant which automatically starts when you turn on a new Mac for the first time. After you have installed the new HD you will have to format the new HD to Mac OS Extended (Journaled) and then you will have to install OS X. The first time you turn it on Setup Assistant will start. Follow the directions and you will be fine. In order to restore your information you will need to backup what is on the current internal HD first. I'd recommend using Time Machine (Assuming you are using Leopard or later) AND also creating a bootable clone using either SuperDuper or Carbon Copy Cloner.
    Please complete your profile so at the very least we know what version of OS X your machine has installed.

  • Ive lost my apple ID for my ipod, now i have an iphone and i want to use the same apple ID for both can someone tell me how to do this

    I have lost my apple ID for my ipod, now ive got a new iphone and i want to use the same ID for both, can anyone one tell me how to do this? ( i no my ID for the iphone)

    Just use the same ID.
    These may alos help:
    How to use multiple iPods, iPads, or iPhones with one computer
    What is the best way to manage multiple...: Apple Support Communities

  • My mobile me expired and I want to use the same username for icloud. How?

    My mobile me expired and I want to use the same username for icloud. How?
    When I registered for me.com, they kept saying the my username is already taken which is true since I registered for [email protected] previously and the subscription has expired.
    How can I get apple to delete my mobile me account completely?

    http://howto.cnet.com/8301-11310_39-20119371-285/how-to-transfer-your-mobileme-a ccount-to-icloud/
    and
    http://www.apple.com/mobileme/transition.html
    should assist you in questions

  • My ipod went to the ''connect to itunes mode'' and i want to use my itunes backup but how can i do that. also when the ''recover your ipod screen'' appeared i accidentally chose not to show it anymore.

    My ipod went to the ''connect to itunes mode'' and i want to use my itunes backup but how can i do that. also when the ''recover your ipod screen'' appeared i accidentally chose not to show it anymore. please help i just had it for half a day.

    See Here  >  http://support.apple.com/kb/HT1808
    You may need to try this More than Once...  Be sure to Follow ALL the Steps...
    Take your time... Pay particular attention to Steps 3 and 4.
    Some users have reported as many as 8 or 9 attempts were necessary before success.
    If the issue persists...
    Then a Visit to an Apple Store or AASP (Authorized Apple Service Provider) is the Next Step...
    Be sure to make an appointment first...

  • OK so I just made a wireless network and using the apple box or whatever. And I want to change the network name. How do I do that?

    OK so I just made a wireless network and using the apple box or whatever. And I want to change the network name. How do I do that?

    Just want to confirm that I am also having this issue, The connection is fine, and it is in fact charging (@ 100%)
    Everything Rick has said is like an echo to what is happening to me.
    I have tried re-installing iTunes, and restarting the Bonjour service, sadly there is no change.
    earlier before i updated iTunes it recognised my iPod but said that I had to update iTunes in order for it to work.
    So i updated iTunes but now it's not even showing the device anywhere.
    In case this helps:
    OS: Windows 8.1
    iTunes version: 11.3.1.8
    Device: 5th generation iPod touch 16GB with ios 7

  • HT1752 I have an IMac OSX and a 2013 MacBook air and I want to use the screen on my IMac.  I have connected the cable but I can't get the IMac screen to connect to my MacBook

    I have an IMac OSX and a 2013 MacBook Air and I want to use the screen on my IMac.  I have purchased the cable and connected, but the IMac will not connect to my MacBook.  I have tried the Command/F2 but it does not work.  Any help would be appreciated.

    Target Display Mode 2009 & 2010 iMacs
    Target Display Mode 2011 & Later iMacs
    iMac- How to use your iMac as a Target Display Mode display
    Target Display Mode- Frequently Asked Questions (FAQ)

  • TS4006 We thought my wife lost her phone and I initiated the erase feature.  She has now found it, and I want to cancel the erase instruction.  How do I do it?

    We tghought my wife lost her Iphone 4, and I initiated the erase feature.  We have now found it and I want to cancel the erase instruction.  How do I  do it.

    You can't cancel it.  What you can do is put it in airplane mode so it doesn't connect to the internet and start to erase, then back it up in iTunes (connect it to your computer, open iTunes, click on the name of the phone in iTunes, go to the Summary tab and click Back Up Now, then go to File>Devices>Transfer Purchases).  Then you can turn off airplane mode and let it erase; when it finishes, restore the backup you made earlier and sync it with iTunes.

  • My friends's ipad dropped and the screen cracked and he wants to use the warranty. So does the warranties for apple cover those stuff.

    My friend's ipad dropped and the screen cracked and he wants to use the warrranty. So does the warranties for apple cover this

    AppleCare+ provides repair or replacement coverage, both parts and labor, from Apple-authorized technicians. Service coverage includes the following:
    Your iPad
    Battery1
    Time Capsule or AirPort device4
    Included USB cable and power adapter
    Coverage for up to two incidents of accidental damage from handling of your iPad, each subject to a $49 service fee1
    http://www.apple.com/support/products/ipad.html

  • What is the difference between OSX 10.6 and 10.6 server? I need to install Snow Leopard in a Parallels VM and it only allows 10.6 server. Will Rosetta work if I use the server edition?

    I MUST use an app that was discontinued which requires Rosetta, yet I also want to upgrade to Mavericks. I was told that Parallels and VMWare Fusion both support running Snow Leopard SERVER, but not Snow Leopard. Two questions: Will Rosetta run on Snow Leopard Server when it is running inside the Parallels/Fusion/whatever virtual machine which is running under Mavericks? The second question is: Is there any problem with running any specific software in Snow Leopard Server when it is set up this way?

    Richard Cartledge wrote:
    The problem with client as virtualised OS is the Apple EULA, not a technical one.
    I don't know if it works, or you're just not meant to do it.
    PS. If you download or have Snow Leopard DVD, you can install Rosetta in later OSs, certainly Lion and Mountain Lion and Mavericks.
    insert your Snow Leopard disc, open the Optional Installs folder on that disc, and double-click the Optional Installs.mpkg package. The Installer will open and you’ll be prompted to click Continue a couple of times and then choose a destination for the installation. Choose your startup volume and click Continue yet again.
    In the Custom Install on “nameofvolume” window that appears, enable the Rosetta option and click Continue. In the next window click Install to do just that.
    NB/ I don't have any old software to test to see if it actually makes it work!
    WRONG TWICE!
    Bad idea to attempt to install Rosetta into Lion, Mt. Lion or Mavericks and good luck trying to remove it after that attempt.  Result: NO powerpc app will run after that installation and you will have to complete a wipe of your hard drive and a complete pre-Rosetta install to get rid of Rosetta!
    It was a common Urban Myth that the Snow Leopard EULA prohibited its virtualization in Lion or Mt. Lion on a Mac.  That myth has been largely debunked over the last two years.
    In addition, Apple's release of Snow Leopard Server at a 95% discount ($20) has rendered the issue largely moot!
    OP: what application are we talking about here?
    For example here is the long beloved powerpc application Appleworks running in Snow Leopard Server installed in Parallels for use in a post Lion world:
                                  [click on image to enlarge]
    More information here:
    http://forums.macrumors.com/showthread.php?t=1365439

  • My mom and me want to use the iPod on two computers, one Mac and one Windows. Is that possible or will it destroy the iPod?

    My mom has a Windows computer, I have a Mac, and we have an iPod nano 6th generation. Is it possible to use the iPod with both the Windows and the Mac? And does it add the music and playlists but not delete?
    Thank you,
    Jan

    Hey, thank you so much.
    But now: I can add Musik, but it won't load the Cs-covers and the play lists on the iPod. I did it the way they tell me to do it. I just grabbed it and put it into the iPod. I can see the lists on the computer, but not on hte iPod in the menu.
    how can I get the play lists?
    Thank you.
    Jan

  • I have a new account and I want to use the reward points

    hi
    I just created a new account on Toshiba and deleted the older
    the old account: (radumuresan) http://forums.computers.toshiba-europe.com/forums/profile.jspa?userID=538172580
    the new one: (akhenaton) http://forums.computers.toshiba-europe.com/forums/profile.jspa?userID=538318254
    I did that because I couldn't post on a thread ( http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=22110 ) and I thought that it is a problem with my account
    now I want to use my 10 reward points (which were not used with the previous account - "radumuresan"), and also, if possible, to transfer (add to the current account - "akhenaton") the 3 reward points earned; it's annoying - my new account ("akhenaton") has no "Reward Points to Assign" (from the beginning) even though I haven't used the 10 reward points in my old account :|
    I, also, would like to thank moderator if he/she contacted Toshiba technicians in the problem regarding the XD-bit ( http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=19857 )
    I had no chance to do this before the thread was closed (I only got to thank Toshiba Support Team as I was very anxious to run some tests on my "shiny new laptop" with the new BIOS update; later when I tried to edit my post the thread was already closed)
    thank you!
    L.E.: now the 10 "Reward Points to Assign" just appeared on my account; 10x (but I still don't see the 3 earned points added too)
    Message was edited by: akhenaton

    Hi akhenaton. I am writing a bit off topic, but there i have an opportunity to write you something, because both topics, where you adviced me, are now closed.
    I was trying to write you something in the topic about the RAM modules, where you reacted and answer my question. This topic is already closed, so i am not able to add there any post. I just wanted to say you thanks :) I have also problems posting the message in topic about NVIDIA GeForce GO 7600, it wrote me the same, that it has to be approved by moderator or something like that. So i waited for some time and the post finally apeeared the next day. I don't know, when the post has to be approved by moderator and when it is posted automatically. And something about reward points, I think, that you have 10 reward points at your disposal in every topic you created, don't you? Greetings.

  • My firefox display and appearrance suddenly changed to a huge size and I WANT TO CHANgE THE HUGE LAYOUT. How?

    My Firefox homepage used to appear as a one page size when I opened the homepage. One day I signed onto the computer and the homepage size and layout had changed to a '''huge large print version that does not even fit on my whole computer screen.''' I have to scroll from side to side to see one end of the open page to the other. It is terrible and unusable. The font size changed from this to a 60 font size. I did not choose this change and do not know how to undo this problem. Please help.

    Hi,
    Please try pressing '''Ctrl''' + '''0''' (zero) on the keyboard. Alternatively '''View''' ('''Alt''' + '''V''') > '''Zoom''' > '''Reset'''.
    [https://support.mozilla.com/en-US/kb/how-do-i-use-zoom?s=zoom+feature&r=0&as=s Zoom Feature]
    [https://support.mozilla.com/en-US/kb/Keyboard%20shortcuts Keyboard Shortcuts]
    Useful links:
    [https://support.mozilla.com/en-US/kb/Options%20window All about Tools > Options]
    [http://kb.mozillazine.org/About:config Going beyond Tools > Options - about:config]
    [http://kb.mozillazine.org/About:config_entries about:config Entries]
    [https://addons.mozilla.org/en-US/firefox/addon/whats-that-preference/ What's That Preference? add-on] - Quickly decode about:config entries - After installation, go inside about:config, right-click any preference, enable (tick) MozillaZine Results to Panel and again right-click a pref and choose MozillaZine Reference to begin with.
    [https://support.mozilla.com/en-US/kb/Keyboard%20shortcuts Keyboard Shortcuts]
    [https://support.mozilla.com/en-US/kb/Viewing%20video%20in%20Firefox%20without%20a%20plugin Viewing video in Firefox without a plugin]
    [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder & Files]
    [https://support.mozilla.com/en-US/kb/Safe%20Mode Safe Mode]
    [https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting Basic Troubleshooting]
    [http://kb.mozillazine.org/Problematic_extensions Problematic Extensions]
    [https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Troubleshooting Extensions and Themes]
    [http://kb.mozillazine.org/Testing_plugins Testing Plugins]
    [https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins Troubleshooting Plugins]

  • I downloaded some music on my iPhone through iCloud and I want them off the phone now. How can I get rid of the songs??

    I just got the iPhone 4 and decided to put some music on it so i used the iCloud system. when they were downloading i decided i didnt want some of themso i stopped the sync. Now the songs are stuck onthe phone but they are greyed out and wont play... i cant figure out how to remove them! help please!!
    P.s. i tried to redownload them and it didnt work either.. just made duplicates.

    In the iTunes Store click Purchased in the Quick Links section on the right.

Maybe you are looking for