Dynamic port configured for FILE adapter is not working

Hi,
I have a simple dynamic port in an orchestration that writes a file to a file location. Here is the configuration
================
FilePort(Microsoft.XLANGs.BaseTypes.Address) = "FILE://c:\\TestFolder\\Out";
FilePort(Microsoft.XLANGs.BaseTypes.TransportType) = "FILE";
================
When I run this orchestration, the dynamic port does not write the file to the folder, however I does not show any error either. It is always in "Ready to Run" state where the message is "Queued Awaiting".
I tried all sorts of combinations like FILE:// FILE:\\ File: file:// file:\\ etc... and also without the moniker, just c:\.... I get the same problem.
when I use a static port(subscribed to the same message) it works fine. When I use a static port ALONGWITH this dynamic port then both works fine !!! I receive 2 files.
but when I use only dynamic port it does not work!!
Anybody knows how to solve it.
THANKS IN AVANCE
PLEASE HELP
Surya

It could be becasue you 're not passing in the file name, Try something like this..
SndPort_Dynamic(Microsoft.XLANGs.BaseTypes.Address)=@"file://C:\Test\Try\Out\Test1.xml";
But even when you don't pass the file name, i was expecting the erro to be like:
The FILE send adapter cannot open file C:\TestFolder\Out\ for writing.
Details: The system cannot find the path specified.
But try with File Name and restart the host instance after the change.
Or use somehting like this:
FilePort(Microsoft.XLANGs.BaseTypes.Address)=@"file://C:\Test\Try\Out\\%MessageID%.xml";
FilePort(Microsoft.XLANGs.BaseTypes.TransportType) = "File";
If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

Similar Messages

  • Dynamic UserID/Password for file Adapter

    Hi,
    How to use dynamic UserId/Password for file adapter ?
    (Sender/Receiver)
    In our case the Id/Pwd of FTP Site changes freguently.
    Can anyone help.
    Thanks in Advance
    Regards
    Chemmanz

    Hi Chemmanz,
    >>>>In our case the Id/Pwd of FTP Site changes freguently.
    but do you have those passwords in the message payload?
    if not then you will still have to fill it somewhere right?
    BTW
    the only way would be to use java proxies and write a simple ftp adapter inside it (or your own adapter)
    but this is not possible in standard I believe
    Regards,
    michal

  • Port Forwarding for RDP 3389 is not working

    Hi,
    I am having trouble getting rdp (port 3389) to forward to my server (10.20.30.20).  I have made sure it is not an issue with the servers firewall, its just the cisco.  I highlighted in red to what i thought I need in my config to get this  to work.  I have removed the last 2 octets of the public IP info for security .Here is the configuration below:
    TAMSATR1#show run
    Building configuration...
    Current configuration : 11082 bytes
    version 15.2
    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    hostname TAMSATR1
    boot-start-marker
    boot system flash:/c880data-universalk9-mz.152-1.T.bin
    boot-end-marker
    logging count
    logging buffered 16384
    enable secret
    aaa new-model
    aaa authentication login default local
    aaa authentication login ipsec-vpn local
    aaa authentication login ciscocp_vpn_xauth_ml_1 local
    aaa authorization console
    aaa authorization exec default local
    aaa authorization network groupauthor local
    aaa session-id common
    memory-size iomem 10
    clock timezone CST -6 0
    clock summer-time CDT recurring
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1879941380
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1879941380
    revocation-check none
    rsakeypair TP-self-signed-1879941380
    crypto pki certificate chain TP-self-signed-1879941380
    certificate self-signed 01
      3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31383739 39343133 3830301E 170D3131 30393136 31393035
      32305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38373939
      34313338 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100BD7E 754A0A89 33AFD729 7035E8E1 C29A6806 04A31923 5AE2D53E 9181F76C
      ED17D130 FC9B5767 6FD1F58B 87B3A96D FA74E919 8A87376A FF38A712 BD88DB31
      88042B9C CCA8F3A6 39DC2448 CD749FC7 08805AF6 D3CDFFCB 1FE8B9A5 5466B2A4
      E5DFA69E 636B83E4 3A2C02F9 D806A277 E6379EB8 76186B69 EA94D657 70E25B03
      542D0203 010001A3 73307130 0F060355 1D130101 FF040530 030101FF 301E0603
    ip dhcp excluded-address 10.20.30.1 10.20.30.99
    ip dhcp excluded-address 10.20.30.201 10.20.30.254
    ip dhcp excluded-address 10.20.30.250
    ip dhcp pool tamDHCPpool
    import all
    network 10.20.30.0 255.255.255.0
    default-router 10.20.30.1
    domain-name domain.com
    dns-server 10.20.30.20 8.8.8.8
    ip domain name domain.com
    ip name-server 10.20.30.20
    ip cef
    no ipv6 cef
    license udi pid CISCO881W-GN-A-K9 sn
    crypto vpn anyconnect flash:/webvpn/anyconnect-dart-win-2.5.3054-k9.pkg sequence 1
    ip tftp source-interface Vlan1
    class-map type inspect match-all CCP_SSLVPN
    match access-group name CCP_IP
    policy-map type inspect ccp-sslvpn-pol
    class type inspect CCP_SSLVPN
      pass
    zone security sslvpn-zone
    crypto isakmp policy 10
    encr aes 256
    authentication pre-share
    group 2
    crypto isakmp policy 20
    encr aes 192
    authentication pre-share
    group 2
    crypto isakmp key password
    crypto isakmp client configuration group ipsec-ra
    key password
    dns 10.20.30.20
    domain tamgmt.com
    pool sat-ipsec-vpn-pool
    netmask 255.255.255.0
    crypto ipsec transform-set ipsec-ra esp-aes esp-sha-hmac
    crypto ipsec transform-set TSET esp-aes esp-sha-hmac
    crypto ipsec profile VTI
    set security-association replay window-size 512
    set transform-set TSET
    crypto dynamic-map dynmap 10
    set transform-set ipsec-ra
    reverse-route
    crypto map clientmap client authentication list ipsec-vpn
    crypto map clientmap isakmp authorization list groupauthor
    crypto map clientmap client configuration address respond
    crypto map clientmap 10 ipsec-isakmp dynamic dynmap
    interface Loopback0
    ip address 10.20.250.1 255.255.255.252
    ip nat inside
    ip virtual-reassembly in
    interface Tunnel0
    description To AUS
    ip address 192.168.10.1 255.255.255.252
    load-interval 30
    tunnel source
    tunnel mode ipsec ipv4
    tunnel destination
    tunnel protection ipsec profile VTI
    interface FastEthernet0
    no ip address
    interface FastEthernet1
    no ip address
    interface FastEthernet2
    no ip address
    interface FastEthernet3
    no ip address
    interface FastEthernet4
    ip address 1.2.3.4
    ip access-group INTERNET_IN in
    ip access-group INTERNET_OUT out
    ip nat outside
    ip virtual-reassembly in
    no ip route-cache cef
    ip route-cache policy
    ip policy route-map IPSEC-RA-ROUTE-MAP
    duplex auto
    speed auto
    crypto map clientmap
    interface Virtual-Template1
    ip unnumbered Vlan1
    zone-member security sslvpn-zone
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan1
    arp timeout 0
    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    no ip address
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.20.30.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    ip tcp adjust-mss 1452
    ip local pool sat-ipsec-vpn-pool 10.20.30.209 10.20.30.239
    ip default-gateway 71.41.20.129
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip dns server
    ip nat inside source list ACL-POLICY-NAT interface FastEthernet4 overload
    ip nat inside source static tcp 10.20.30.20 3389 interface FastEthernet4 3389
    ip nat inside source static 10.20.30.20 (public ip)
    ip route 0.0.0.0 0.0.0.0 public ip
    ip route 10.20.40.0 255.255.255.0 192.168.10.2 name AUS_LAN
    ip access-list extended ACL-POLICY-NAT
    deny   ip 10.0.0.0 0.255.255.255 10.20.30.208 0.0.0.15
    deny   ip 172.16.0.0 0.15.255.255 10.20.30.208 0.0.0.15
    deny   ip 192.168.0.0 0.0.255.255 10.20.30.208 0.0.0.15
    permit ip 10.20.30.0 0.0.0.255 any
    permit ip 10.20.31.208 0.0.0.15 any
    ip access-list extended CCP_IP
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended INTERNET_IN
    permit icmp any any echo
    permit icmp any any echo-reply
    permit icmp any any unreachable
    permit icmp any any time-exceeded
    permit esp host 24.153. host 66.196
    permit udp host 24.153 host 71.41.eq isakmp
    permit tcp host 70.123. host 71.41 eq 22
    permit tcp host 72.177. host 71.41 eq 22
    permit tcp host 70.123. host 71.41. eq 22
    permit tcp any host 71..134 eq 443
    permit tcp host 70.123. host 71.41 eq 443
    permit tcp host 72.177. host 71.41. eq 443
    permit udp host 198.82. host 71.41 eq ntp
    permit udp any host 71.41. eq isakmp
    permit udp any host 71.41eq non500-isakmp
    permit tcp host 192.223. host 71.41. eq 4022
    permit tcp host 155.199. host 71.41 eq 4022
    permit tcp host 155.199. host 71.41. eq 4022
    permit udp host 192.223. host 71.41. eq 4022
    permit udp host 155.199. host 71.41. eq 4022
    permit udp host 155.199. host 71.41. eq 4022
    permit tcp any host 10.20.30.20 eq 3389
    evaluate INTERNET_REFLECTED
    deny   ip any any
    ip access-list extended INTERNET_OUT
    permit ip any any reflect INTERNET_REFLECTED timeout 300
    ip access-list extended IPSEC-RA-ROUTE-MAP
    deny   ip 10.20.30.208 0.0.0.15 10.0.0.0 0.255.255.255
    deny   ip 10.20.30.224 0.0.0.15 10.0.0.0 0.255.255.255
    deny   ip 10.20.30.208 0.0.0.15 172.16.0.0 0.15.255.255
    deny   ip 10.20.30.224 0.0.0.15 172.16.0.0 0.15.255.255
    deny   ip 10.20.30.208 0.0.0.15 192.168.0.0 0.0.255.255
    deny   ip 10.20.30.224 0.0.0.15 192.168.0.0 0.0.255.255
    permit ip 10.20.30.208 0.0.0.15 any
    deny   ip any any
    access-list 23 permit 70.123.
    access-list 23 permit 10.20.30.0 0.0.0.255
    access-list 24 permit 72.177.
    no cdp run
    route-map IPSEC-RA-ROUTE-MAP permit 10
    match ip address IPSEC-RA-ROUTE-MAP
    set ip next-hop 10.20.250.2
    banner motd ^C
    UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED.
    You must have explicit permission to access or configure this device.  All activities performed on this device are logged and violations of this policy may result in disciplinary and/or legal action.
    ^C
    line con 0
    logging synchronous
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0
    access-class 23 in
    privilege level 15
    logging synchronous
    transport input telnet ssh
    line vty 1 4
    access-class 23 in
    exec-timeout 5 0
    privilege level 15
    logging synchronous
    transport input telnet ssh
    scheduler max-task-time 5000
    ntp server 198.82.1.201
    webvpn gateway gateway_1
    ip address 71.41. port 443
    http-redirect port 80
    ssl encryption rc4-md5
    ssl trustpoint TP-self-signed-1879941380
    inservice
    webvpn context TAM-SSL-VPN
    title "title"
    logo file titleist_logo.jpg
    secondary-color white
    title-color #CCCC66
    text-color black
    login-message "RESTRICTED ACCESS"
    policy group policy_1
       functions svc-enabled
       svc address-pool "sat-ipsec-vpn-pool"
       svc default-domain "domain.com"
       svc keep-client-installed
       svc split dns "domain.com"
       svc split include 10.0.0.0 255.0.0.0
       svc split include 192.168.0.0 255.255.0.0
       svc split include 172.16.0.0 255.240.0.0
       svc dns-server primary 10.20.30.20
       svc dns-server secondary 66.196.216.10
    default-group-policy policy_1
    aaa authentication list ciscocp_vpn_xauth_ml_1
    gateway gateway_1
    ssl authenticate verify all
    inservice
    end

    Hi,
    I didnt see anything marked with red in the above? (Atleast when I was reading)
    I have not really had to deal with Routers at all since we all access control and NAT with firewalls.
    But to me it seems you have allowed the traffic to the actual IP address of the internal server rather than the public IP NAT IP address which in this case seems to be configured to use your FastEthernet4 interfaces public IP address.
    There also seems to be a Static NAT configured for the same internal host so I am wondering why the Static PAT (Port Forward) is used?
    - Jouni

  • File Adapter Read not working

    Hi All,
    I have a file adapter service,which has to read a CSV file.
    The configurations i have done is
    1)Gave the incming diretory path,delete option is checked
    2)Polling frequency - 5 secs
    3) gave the xsd.
    But the process is not picking up the file,and i dont see any errors in domain.log
    Please help.
    Regards
    Ashwini

    Hi Anirudh,
    Thanks for the reply.
    IS there no solution other than restarting the server ??
    below is the xsd i am using.please let me know the modifications that i can do to reject the second invoice if there are any errors in that and proceed further.
    <?xml version="1.0" encoding="UTF-8" ?>
    <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:nxsd="http://xmlns.oracle.com/pcbpel/nxsd"
    targetNamespace="http://antony.blog.com/ReadStructuredMasterDetailService"
    xmlns:tns="http://antony.blog.com/ReadStructuredMasterDetailService"
    elementFormDefault="qualified" attributeFormDefault="unqualified"
    nxsd:encoding="ASCII" nxsd:stream="chars" nxsd:version="NXSD">
    <xsd:element name="Invoice">
    <xsd:complexType>
    <xsd:sequence>
    <xsd:element name="InvoiceHeader" nxsd:startsWith="$H$" maxOccurs="unbounded">
    <xsd:complexType>
    <xsd:sequence>
    <xsd:element name="Supplier_name" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Supplier_Site" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Inv_No" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Invoice_Date" type="xsd:date" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Invoice_Currency" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Invoice_gross_Amount" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Total_Ex_VAT" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," nxsd:quotedBy="&quot;"/>
    <xsd:element name="Total_VAT_Amount" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Scanned_image_Reference_URL" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="${eol}" />
    <xsd:element name="InvoiceDtail" maxOccurs="1">
    <xsd:complexType>
    <xsd:sequence>
    <xsd:element name="InvoiceDTL" nxsd:startsWith="$D$"
    maxOccurs="unbounded">
    <xsd:complexType>
    <xsd:sequence>
    <xsd:element name="Business_Unit" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="location" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Store_Name" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Department" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Natural_Account" type="xsd:string" nxsd:style="terminated" nxsd:terminatedBy=","/>
    <xsd:element name="Inc_VAT" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="Ex_VAT" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="VAT_Amount" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="," />
    <xsd:element name="VAT_Rate" type="xsd:int" nxsd:style="terminated" nxsd:terminatedBy="${eol}"/>
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
    </xsd:schema>
    Regards
    Ashwini

  • File Adapter is not working and create client copy in NW 7.0?

    hi,
    this is sreeram.i installed and configured PI 7.0 SR2 but file was not picking up from the input folder.i can able to select file adapter when i am creating communication channel.i gone throw RWB component monitoring->Adaptor monitoring there i seen all adaptors are in faded color not in green.can any one help to resolve the proble?
    one more question is i created 3 clients from 000 client using tcode scc4.when i am entering with SAP* and password is: pass it's not entering into that client.i also tried username: SAP* password as : password pls tell me SAP* password in NW 7.o?

    Hi,
    Take a look at the forum links looks like same problem
    HTTP Response: 500  internal server error
    HTTP adapter - 500 Internal server error
    Message mapping-Urgent
    Can you go through the below urls:
    calling soap error
    SOAP  - XI - SOAP Error
    Error while Testing SOAP Adapter In XI
    Please reward points if it helps
    Thanks
    Vikranth

  • FCC Send File Adapter - missingLastFields not working

    Hi
    I have a flat file to capture using the sender File adapter
    Parameter as follows:
    Header_fieldNames : Key,Name,StaffID,Telephone
    Header_fieldFixedLengths :  2,12,10,8
    Header_endSeparator : 'nl'
    Line_fieldNames : Key,Address,Company,LineText
    Line_fieldFixedLengths :  2,20,20,40
    However there are times where last field come in missing.
    Hence I use the Header_missingLastFields : error
                              Line_missingLastFields : error
    However it does not seem to be working as the adapter fails to pick the file from the FTP folder
    but if I  replace error with ignore, the sender adapter picked the files and process and send to the receiver adapter.
    I need to flagged error in sxmb_moni if last field or last few fields are missing....any advise how could this be achieve ?
    Regards
    Fred

    Hi Freddy,
    I think you might like to specify missingLastFields = add. then it will add the missing fields as empty. you can further check if these are empty in mapping and then fail the message or create an alert.
    If you specify "ignore" then you will not get those fields in your structure and if you specify "error" then the file will not be picked up.
    have a look here
    http://help.sap.com/saphelp_nw04/helpdata/en/2c/181077dd7d6b4ea6a8029b20bf7e55/content.htm
    missingLastfields
    If the inbound structure has less fields than specified in the configuration then the XML outbound structure is created as follows:
    ○       ignore
    Outbound structure only contains the fields in the inbound structure
    ○       add
    Outbound structure contains all fields from the configuration; the fields missing in the inbound structure are empty.
    ○       error
    Conversion is terminated due to the incomplete inbound structure. An error message is displayed
    regards,
    francis

  • File adapter - APPEND not working

    Hi Everyone,
    I want to append a text file on the target side. I am using FCC on the receiver side and the file construction mode is "APPEND" and file type is "TEXT". When i test my scenario, the file gets created for the first time and for the next time onwards, I get an error : "Target file already exists and must not be overwritten".
    Kindly help me to solve this issue.
    Thanks,
    Laawanya

    Check the below thread for the same:
    Have you checked overwrite box?
    It should be checked as well, and also check for necessary authorizations for this.
    Appending data in receiver file adapter
    Divyesh Vasani

  • Search in Finder and Mail for files in 2011 not working

    I do get search results just not for anything created after December 31st 2010. Nothing exists in the search for 2011. I have updated all software and nothing seems to work. My date and time are correct. I can have a file on the desktop or in my inbox and the system can not find it. I do search every day and it is getting labor intensive to do it all by hand. Any ideas?

    I figured out a fix for my machine. I went into the system preferences, to the spotlight. Went to the privacy settings added my drive and closed to save the settings then reopened it and I removed it from Privacy. This caused it to re-indexed all my files (it took over an hour) but I even created new files and was able to find them in spotlight and in my email.

  • Open dataset for file output does not work

    I have the following code
    OPEN DATASET MY_FILE FOR OUTPUT IN TEXT MODE ENCODING NON-UNICODE.
    MY_FILE is a selection parameter for the filename but when I put any file name, say C:\tmp\test.txt, the code does not create the file for writing. If I create the file manually from windows so that I am sure it exists (Right click-> New -> Text File -> test.txt), SAP still does not open the file for writing.
    Am I doing something wrong?
    I have searched the net and the forums but I can't seem to get a useful answer...
    Thanks in advance!
    Kyle

    Hey Prabhu,
    Thanks. I kinda missed this from the documentation:
    The file must be accessible from the application server. You cannot use OPEN DATASET to process files on the current presentation server (whether PC or workstation). The function modules WS_DOWNLOAD and WS_UPLOAD exist for this purpose.
    [http://help.sap.com/saphelp_40b/helpdata/en/34/55cad198482bc0e10000009b38f91f/content.htm]
    Points have been awarded. Thank you.
    Kyle

  • Hp lj1102w - can't configure for Wifi (HTML Config not working in printer utility)

    I've got an HP LJ 1102w and have never been able to get the Print Utility to work.  I had to set it up for WiFi with a Windows machine, which wasn't too bad, but the network just changed and I don't have the Windows machine available any more.   I've looked at numerous discussions but can't find the right solution.    I've downloaded the driver a number of times , then went to the configuration page for the printer, clicked Utility, but when I click "Open Printer Utility", nothing happens.   Any ideas?
    Thank you!  Ron

    Thank you for the article, HerelsMartin, but that still didn't change anything.  To summarize, I did all of this:
    - Deleted old printer from the MacBook
    - Reset the printer, confirmed old network was gone
    - Set up Java 8.latest, 64-bit, made sure Chrome was updated
    - Set Safari as default browser
    - Rebooted computer just for kicks
    - Went to the new printer, clicked Options, Printer Utility , and got the same result: the "Ok" button got highlighted momentarily and then nothing happened.
    I then tried this step at the bottom of the article (see my comments in [..]):
    On the Apple menu bar, click Go [there was no "Go" in the Apple bar so I did this through Finder], computer, MAC harddrive, Library, Printers, HP [there was no HP folder, just my 4 printers], LaserJet, click on folder for your printer [there was no folder so I double-clicked the printer and it brought me back to the Printer Utility, and I got the same result as above - nothing - so the rest of this doesn't apply], click on EWS browser or HTML config, click the Networking tab, click wireless on the left and fill out your information. (make sure infrastructure is selected) Apply settings."
    I'm used to Mac doing EVERYTHING for me but this has been extremely time-consuming and frustrating; I'm ready to just go buy another printer.  There must be something that can fix this??
    Thank you, r

  • Time stamp is not getting updated for File Adapter in communication channel

    Hi All,
    Since yesterday, I am observing that the time stamp of communication channel for File adapter is not gettingupdated some times.
    I had to stop and start the communication channel to update the time stamp.Please let me know if anyone has come across such issue or any useful notes on this.I could not find any related notes on Market place.
    Regards,
    Dinakar

    Hi,
    This is happening only with one communication channel which is sender in derection.Any reason why it is happening like this?since the restart of the communication channel it is getting update now.I really do not know how to delete/create the communication channels as this was done our PI consultants.Pls guide me.
    Regards,
    Dinakar

  • Configuring Receiver File Adapter for J2SE

    Hi All,
    I have a scenario in which i need to convert the IDOC data into a fixed length file.
    I did mapping according to the output structure of the file.
    My Output file format is as follows...
    Document1          document2      document3      etc
    Each document contains different fields with different lengths
    In XI-FIle adapter we give Recordset structure : Document1,Document2,Document3.
    But while configuring Receiver File adapter in J2SE.
    There is no option mentioned in J2SE Adapter.
    <b>http://saphelp.border-states.com/EN/95/bb623c6369f454e10000000a114084/content.htm</b>
    Please throw some light on the same.
    Thank You
    Regards,
    Reehan

    as far as i read the document, what i understood is that the J2SE adapter has a limitation.
    your XML structure should be as mention in the link;
    <i>To convert a table in XML format to pure text format, the document format must be the same as that which is generated by the sender file/FTP adapter in mode FILE2XMBWITHROWCONVERSION <i>(with the default value <row> for the structure)</i> and the sender JDBC adapter. This means that the document structure looks like this:
    <resultset>
    <row>
    <column-name1>column-value</column-name1>
    <column-name2>column-value</column-name2>
    <column-name3>column-value</column-name3>
    </row>
    <row>
    <column-name1>column-value</column-name1>
    <column-name2>column-value</column-name2>
    <column-name3>column-value</column-name3>
    </row>
    </resultset>
    This is an example for 3 columns and 2 lines. The number of lines and columns is, of course, unlimited. <b>The XML elements in italics can be defined by the user and the elements of a line must be grouped within an element of type <row> … </row></b>.</i>
    So cannot take the <b>recordset structure</b> as we have for the normal File adapter.

  • File Adapter is not polling File.

    Hi All,
    I am using file adapter to poll a file. When I am restarting server then it is picking file. After then when I am dropping a file then File Adapter is not picking File.
    Can any one guide me what si problem?
    I am using SOA SUITE 10.1.3.4
    Thanks in Advance.

    First clusterGroupId is a unique value. Do not use the same clusterGroupId across different adapters even in different process.
    Once clusterGroupId is defined, the multiple activations of the same adapter Activation Agent is to be detected implicitly and automatically by all the instances of the adapter framework active in that cluster. The cluster will allow onlye one node activation to start the reading the files/messages. The adapter framework instances chooses one among multiple nodes, randomly to assume the Primary Activation responsibility. The other activations (instances) in the cluster will initiate to a hot stand-by state, without actually invoking EndpointActivation on the JCA resource adapter.
    If a primary activation at some point becomes unresponsive, is deactivated manually or if it crashes/exits, then any one of the remaining adapter framework members of the cluster group will immediately detect this, and reassign the primary activation responsibility to one of activation agents standing by.
    This feature uses JGroups underneath for the implementation, hence the clusterGroupId property. These features require cluster and JGroups configuration in collaxa-config.xml and jgroups-protocol.xml. All BPEL instances participating in the cluster must share the same cluster name in collaxa-config.xml,and the same multicast address and port in jgroups-protocol.xml.
    As far as for this issue, I too face the same across diff environments and searching for the exact reason. I believe this happens when primary activation agent crashes, the hand-over to the other node is not happening properly through jgroups.
    Nirav

  • How to set DEBUG severity for File adapter in J2SE AE

    Hi,
    Can anyone help me in setting the severity level to DEBUG for file adapter?
    I have tried to set in logging.properties file as given below,
    formatter[Trace]         = TraceFormatter
    formatter[Trace].pattern =%24d [%t] %-6s %l - %m
    log[Trace] = FileLog
    log[Trace].pattern     = swb_%g.log
    log[Trace].limit     = 2000000
    log[Trace].cnt          = 5
    log[Trace].formatter     = formatter[Trace]
    com.sap.aii.messaging.adapter.severity = DEBUG
    logging components
    #com.sap.aii.axis.logs = +log[Trace]
    #com.sap.aii.axis.severity = DEBUG
    #org.apache.axis.logs = +log[Trace]
    #org.apache.axis.severity = DEBUG
    Please correct me if I have did anything wrong and sugest me hot to set the DEBUG level as soon as possible.
    Best Regards,
    Soorya

    Hi Sejoon,
    when we changed the host of XI server in one of our projects one of the things we had to change was the exchange profile entries
    http://server:port/exchangeProfile/index.html
    to see how your adapter engine is configured
    http://server:port/sld
    SLD -> Content Maintenance
    then
    Subset: landscape description
    Class: XI Adapter Framework
    buth check the exchange profile entries first
    Regards,
    michal

  • Configuration for JMS Adapter Sensor action and JMS Queue sensor action..!!

    Hi,
    Id like my BPEL process to send an XML message to JMS on Websphere,I was able to do this through a JMS adapter.But I would more like to add sensors into my process which would really do the same thing - send an XML message to JMS Q.
    Now I understand that there are two ways to do this,JMS Queue and JMS Adapter - thorugh bpel sensor action.
    I am able to use JMS Queue and it works fine , but adds its own xml tags to the message,Is there any way I could send only my xml payload as a message to the queue??
    Also could any1 tell me what is the configuration for JMS Adapter sensor action?
    Any suggestions how do I go about it??

    Hey Anirudh,
    Thanx for the response :-)
    All these hold good when I have an AQ adaptor right,But the thing is I want to send a message to a 'JMS' queue with out actually using an adapter configuration wizard and everythng..So I resolved to JMS queue Sensor action..Heres the xml snippet from the sensorAction.xml files which is generated..
    <actions targetNamespace="http://xmlns.oracle.com/Test_JMS_Logging" xmlns="http://xmlns.oracle.com/bpel/sensor" xmlns:tns="http://xmlns.oracle.com/Test_JMS_Logging" xmlns:pc="http://xmlns.oracle.com/bpel/sensor">
    <action name="JMS_LogEntry" publishName="" publishType="JMSQueue" enabled="true" filter="" publishTarget="jms/L_Queue">
    <property name="JMSConnectionFactory">jms/L_QueueCF</property>
    <sensorName>ActivitySensor_JMS</sensorName>
    </action>
    </actions>
    This works grt and adds messages to the queue..But adds its own header info according to the sensor.xsd loacted at the Oracle_home\bpel\system\xmllib\ folder.
    Right now the XML message added to the Queue is:-
    <actionData xmlns="http://xmlns.oracle.com/bpel/sensor">
    <header>
    <sensor sensorName="ActivitySensor_JMS" classname="oracle.tip.pc.services.reports.dca.agents.BpelActivitySensorAgent" kind="activity" target="AddLEntr
    y" xmlns:pc="http://xmlns.oracle.com/bpel/sensor" xmlns:ns2="http://www.ulrhome.com/2008/10/L_Entry" xmlns:tns="http://xmlns.oracle.com/Test_JMS">
    <activityConfig evalTime="completion">
    <variable outputDataType="string" outputNamespace="http://www.w3.org/2001/XMLSchema" target="$WriteL_Produce_Message_InputVariable/L_Entry/ns2:L_Entry/ns2:LCName"/>
    </activityConfig>
    </sensor>
    <instanceId>950016</instanceId>
    <processName>Test_JMS</processName>
    <processRevision>v2009_04_15__40833</processRevision>
    <domain>default</domain>
    <timestamp>2009-04-15T11:21:23.596-04:00</timestamp>
    <midTierInstance>app01.ulrhome.com:9700</midTierInstance>
    </header>
    <payload>
    <activityData>
    <activityType>scope</activityType>
    <evalPoint>completion</evalPoint>
    <durationInSeconds>0.011</durationInSeconds>
    <duration>PT0.011S</duration>
    </activityData>
    <variableData>
    <dataType>12</dataType>
    <data>
    <ns0:LCName xmlns:ns0="LC_Test1http://www.ulrhome.com/2008/10/L_Entry">LC_Test1</ns0:LCName>
    </data>
    <queryName/>
    <target>$WriteL_Produce_Message_InputVariable/L_Entry/ns2:L_Entry/ns2:LCName</target>
    <updaterName>AddL_Entry</updaterName>
    <updaterType>scope</updaterType>
    </variableData>
    </payload>
    </actionData>
    My requirement is that I need to add a sensor to the BPEL process which posts 'Only my payload message to the JMS queue'..
    What I would want the message in the Queue to be is : -
    <data>
    <ns0:LCName xmlns:ns0="LC_Test1http://www.ulrhome.com/2008/10/L_Entry">LC_Test1</ns0:LCName>
    </data>
    Also while creating a Sensor action I get another option as JMS Adaptor,I am not sure of what value to type in this wizard..Heres what I keyed in..M sure this is not right..Cos it dosnt work :-)
    <action name="SensorAction_JMS" publishName="" publishType="JMSAdapter" enabled="true" filter="" publishTarget="jms/LoggingQueue">
    <property name="JMSConnectionName">Log</property>
    </action>
    </actions>
    Could any 1 tel me what values are the right values..And does JMS Adapter mean that I have to create a JMS Apator in the project and give that connection name as a Value..
    I am not finding sufficiant Documentation for 'JMS Adapter' so M clueless and right now any help will be appriciated :-)
    Regards,
    Akshatha.

Maybe you are looking for