Easy question for any over-critical java tech!

hi over-critical java tech man/woman. i have this class library for org.apache.poi.* .. which i will be using to manipulate .xls and .doc type files. i need help installing it. i havnt tried any command-line stuff yet, which im sure is the right way to go. ive been dragging and dropping into the src.zip file .. which could be harmful .. yes? oh boy im in for some scrazy responses

thanks for the reply duffy,
I looked through the .jar file I was using and it contained all the necessary classes I needed to compile my java file. In my java file, I have included the line:
import org.apache.poi.*;
as a package to try and obtain all the necessary classes needed to compile my file.
In the jar file the folders are ordered in that exact order:
org/apache/poi/'all class folders here'.
when I type the following into the command prompt and press enter:
java -cp ;c:\poitools\poi-2.5.1-final-20040804.jar
i get the following message:
Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)
where options include:
-client to select the "client" VM
-server to select the "server" VM
-hotspot is a synonym for the "client" VM [deprecated]
The default VM is client.
-cp <class search path of directories and zip/jar files>
-classpath <class search path of directories and zip/jar files>
A ; separated list of directories, JAR archives,
and ZIP archives to search for class files.
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and exit
-version:<value>
require the specified version to run
-showversion print product version and continue
-jre-restrict-search | -jre-no-restrict-search
include/exclude user private JREs in the version search
-? -help print this help message
-X print help on non-standard options
-ea[:<packagename>...|:<classname>]
-enableassertions[:<packagename>...|:<classname>]
enable assertions
-da[:<packagename>...|:<classname>]
-disableassertions[:<packagename>...|:<classname>]
disable assertions
-esa | -enablesystemassertions
enable system assertions
-dsa | -disablesystemassertions
disable system assertions
-agentlib:<libname>[=<options>]
load native agent library <libname>, e.g. -agentlib:hprof
see also, -agentlib:jdwp=help and -agentlib:hprof=help
-agentpath:<pathname>[=<options>]
load native agent library by full pathname
-javaagent:<jarpath>[=<options>]
load Java programming language agent, see java.lang.instrument
But I'm confused, because I'm following the steps found on a 'java classpath website'. I guess I'll keep trying, but I'm exhausted from doing the same thing over and over again.

Similar Messages

  • Easy question for the MODS

    Unlike more difficult questions like CRC problems, ps problems, etc, this is rather an easy question.
    The KT4V manual (page 3-8) lists the onboard NIC as a "boot device" option.  This "feature" is available in Bios 1.1, 1.2 but not available in Bios 1.4 and later.  
    Any reason why this feature was mutilated and not available anymore in the later bioses?
    Are there two different bioses for KT4V and KT4V-L?  If yes where can one find the bios for KT4V-L?
    I know this feature is not very popular with the majority of users, and I'm not trying to bust anyone's balls for removing un-popular features, but the "boot from NIC"  was one of the features/reasons why I got this mb, and I would rather use a much newer bios than 1.2 (for known reasons).
    Also, while on this topic, boot-from-usb (especially thumb drives) feature would also be greatly appreciated - I think it is also listed in the manual.
    TIA

    Hi,
    Quote
    Please suggest him to update the BIOS Ver1.9 which can support Boot from LAN and boot from USB devices.
    AMI BIOS can boot from the devices which support BIOS Boot specifications (BBS, you can refer to the attached file for the information).
    Email me, so I can send you the BIOS PDF.

  • SAP audio language not working for *any* channels. Useless tech already came out!

    Just got the FIOS service this Friday.
    I'm very happy with the internet. Very fast!
    The TV, I'm not so happy about.
    Having come from AT&T U-Verse, and Time Warner Cable before that, I've gotten used to having the HBO channel lineup (or any premium channels like Showtime/Cinemax/etc) and being able to easily switch between English and Spanish audio. So far, between 6 calls to customer service (each one of them telling me it's possible), and one extremely clueless tech that just left my home after only 5 minutes, I've not been able to do this.
    I can SEE the option for SAP! I KNOW HBO offers Spanish audio for its' non-HBO Latino channels. I also know that not all movies have Spanish audio, but the majority of new HBO movies do.
    A guy on the phone on Saturday had me convinced that to watch HBO channels with Spanish audio, I had to purchase your Spanish package that comes with extra Spanish channels. I thought this was ridiculous -- since I've already got a PREMIUM package, why in the world would I need to get another package to listen to that premium one in Spanish?! Anyways, I got the package and still no Spanish HBO.
    The tech that came and left in 5 minutes changed the channel to HBO Latino and said, "Here, it's working". I pointed out that HBO Latino is not what I meant - none of the other HBO channels have Spanish, althought we could see they said SAP.
    What gives, Verizon? This, coupled with the fact that I can't set my main DVR to record a show we're watching on an HD receiver in another room without physically going to the DVR itself (or using a cellphone app!) and that apparently I can only record 1 show on the DVR at a time, has me pining for AT&T... which I never thought would happen.
    Hell, even Time Warner Cable's HBO lineup has Spanish.
    Sounds to me like your all-fiber network isn't up to snuff on some very basic things.

    skohly wrote:
    Chill man
    On your remote push the option button. Then click on audio language and change to spanish. You will be all set
    We've been through that appx. 50 times with tech support - not working. Tech guy that came out today said Verizon doesn't offer SAP ... so I don't know what to think now.

  • Image question for mouse over.

    I hope this is a simple question.  Can I place a 150px wide image on my page and when you mouse over have the same photo pop up that is 300 px wide?  I know I can swap the images if they are both 150 px.  But I want to see the larger photo with the mouseover can someone explain or show me where to learn how to do this if I can even do it? Maybe it is not mouseover image swap and it is called something else? Thanks in advance.

    tl1_mc.visible=tl2_mc.visible=tl3_mc.visible=false;
    for(var i:int=1;i<4;i++){
       this["tl"+i+"_mc"].addEventListener(MouseEvent.MOUSE_OVER,overtl);
       this["tl"+i+"_mc"].addEventListener(MouseEvent.MOUSE_OUT,offtl);
    function overtl(e:MouseEvent=null):void{
       var n:int=int(e.currentTarget.name.substr(2,1));
       this["tl"+n+"_mc"].visible=true;
    function offtl(e:MouseEvent=null):void{
       var n:int=int(e.currentTarget.name.substr(2,1));
       this["tl"+n+"_mc"].visible=false;

  • DMZ config! How to do? Easy question for experts! (ASA 5510

    Dear All
    I would like to add a DMZ and VPN to inside network to my ASA5510 configuration, but I'm not sure about the correct way to achieve my goal (I'm a newbie).
    I'll rate your post and promise to send to the best answer a traditional Christmas gift from my country, I'm sure that you will be pleased with it!:)
    Goal:
    1- I want to put a Microsoft Exchange Server 2007 (EDGE Role- Front-Side e-mail server) on a new DMZ.
    2- VPN access to inside network.
    1.1 This e-mail server (name EDGESRV) in the DMZ needs the following configurations:
    Access to EDGESRV from Internet (SMTP)
     Access from EDGESRV to internet (SMTP)
     Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    ROUTER :
    Interface Serial IP: 195.22.12.46/30
    IP route 0.0.0.0 0.0.0.0 195.22.12.45
    Interface Ethernet f0/0: IP 195.22.26.17/29 (connect to router)
    ASA NETWORK
    Interface External e0/0 :IP 195.22.26.18/29 (connect to router)
    Interface internal: e0/1: IP 10.10.100.1 mask 255.255.252.0
    Interface DMZ: e0/2 : IP 10.10.150.1 mask 255.255.255.0 (not implemented yet)
    ASA Configuration (actual)
    ASA Version 8.0(2)
    interface Ethernet0/0
    nameif Interface_to_cisco_router
    security-level 0
    ip address 195.22.26.18 255.255.255.248
    interface Ethernet0/1
    nameif Int_Internal_domain
    security-level 100
    ip address 10.10.100.1 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    passwd xxxxxxxxxxxxx encrypted
    boot system disk0:/asa802-k8.bin
    ftp mode passive
    clock timezone WEST 0
    clock summer-time WEDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    dns domain-lookup Interface_to_cisco_router
    dns domain-lookup Int_Internal_domain.com
    dns server-group DefaultDNS
    name-server 195.22.0.136
    name-server 195.22.0.33
    domain-name domain.com
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list Interface_to_router_Cisco_access_in extended permit object-group TCPUDP any any eq domain
    access-list Interface_to_router_Cisco_access_in extended permit tcp any any eq www
    pager lines 24
    logging list Registo_eventos_william level emergencies
    logging list Registo_eventos_william level emergencies class vpn
    logging asdm informational
    logging recipient-address [email protected] level critical
    mtu management 1500
    mtu Interface_to_router_Cisco 1500
    mtu Int_Internal_domain 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-602.bin
    no asdm history enable
    arp timeout 14400
    global (Interface_to_router_Cisco) 101 interface
    nat (Int_Internal) 101 10.10.100.0 255.255.255.0
    nat (Int_Internal) 101 0.0.0.0 0.0.0.0
    nat (management) 101 0.0.0.0 0.0.0.0
    access-group Interface_to_router_Cisco_access_in in interface Interface_to_router_Cisco
    route Interface_to_router_Cisco 0.0.0.0 0.0.0.0 195.22.26.17 1
    access-list Int_Internal_access_in extended permit tcp any any
    access-list Int_Internal_access_in extended permit udp any any
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 10.10.100.0 255.255.255.0 Int_Internal_domain
    http 10.10.10.0 255.255.255.0 management
    http 195.22.26.16 255.255.255.248 Interface_to_router_Cisco
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    no crypto isakmp nat-traversal
    Kind Regards
    MP

    Mario,
    I think you have much more to go but this is a start, I don't think I have cover everything .. others in netpro may add to this.
    1- I want to put a Microsoft Exchange Server 2007 (EDGE Role- Front-Side e-mail server) on a new DMZ.
    Use this example, Configuring Mail server on DMZ http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806745b8.shtml
    2- VPN access to inside network.
    You can configure RA VPN server using/creating in ASA5510 Local user database
    http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008060f25c.shtml
    or configure RA VPN server using IAS RADIUS-Windows AD for authentication
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806de37e.shtml
    1.1 This e-mail server (name EDGESRV) in the DMZ needs the following configurations:
    Access to EDGESRV from Internet (SMTP)
     Access from EDGESRV to internet (SMTP)
     Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    -Access to EDGESRV from internet on port smtp if you have spare public IP you can create a one-to-one NAT for this server and create
    inbound access rules to allow access on SMPT from outside internet.
    If you do not have spare public IPs for a one-to-one nat on this server you can use ASA outside interface static PAT.
    Example : static (dmz,outside) tcp interface smtp netmask 255.255.255.255
    -Access from EDGESRV to internet (SMTP)
    You need to PAT DMZ network, if EDGESRV does not have one-to-one static NAT
    typical scenario
    global (outside ) 101 interface
    nat (dmz ) 101 0 0
    or
    nat (dmz) 101 <255.255.255.255>
    also for the MAIL Server, if you are using DNS server from your inside network you need acl to allow traffic from MAILserver DMZ to DNS in inside network.
    -Access from internal network to EDGSRV ports: 25(SMTP), 50389 (Ldap), 50636(Secure Ldap) and port 3389 (TCP for terminal services)
    from low sec level 0 to high sec level access is permited by default, you do however need to create static nat to allow comm between inside and dmz
    in your scenario if you have 192.168.1.0/24 for inside interface network you would then create something like this.
    static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
    Observation -
    I see you have interface Ethernet0/2 free, I assume you will probably be using this interface for your DMZ, I would advice to use subinterfaces and use dot1q in order to scale your DMZs in the future.
    Look this link for reference on working with subinterfaces
    http://www.cisco.com/en/US/docs/security/asa/asa80/configuration/guide/intrface.html
    Rgds
    Jorge

  • Tool to make easy code for making pictures in java

    e.g.
    g.drawLine(10,10,50,100)
    Is there a simple tool where I can draw a line on a screen and that that tool gives me then the right coordinates to put it in the java code?
    Of course this simple line is just an example.
    I want to use this to create advanced pictures in a Java applet.
    I hope you guys understand what I mean. I'm from Belgium and my English is not very very good.
    thx for reading this!

    I'm searching just for a more simple tool with interface of Paint for example where I can make pictures. That tool gives than the right code in java.
    Just like when you in eg Dreamweaver make a webpage and then gereates the html code.
    I'm almost sure this must exist but I can't find a tool like that... :-(

  • Real easy question about defining objects in java

    hey guys here is my problem. I am trying to implement an insert() method for my binary tree. i have my node class defined to contain
    public T element() {
              return _data;
    and then my actual tree class has an instance of this declared to be called runner.
    BTreeNode runner;
    runner = _root;
    The problem occurs when i try to compare what i am inserting (obj) with what i have (runner.element) The actual line of code is
    ( obj.compareTo(runner.element) < 0 )
    i get an error that says "runner.element cannot be resolved or is not a field".
    I believe the error comes because i didnt adequately define runner but im not sure how to take care of that. Any suggestions would be most appreciated.
    -peter

    this is all of the code that has a relation to the error I am getting. The error is found in the BasicBTree class and says
    "The method compareTo(T) in the type Comparable<T> is not applicable for the arguments
    (Comparable)"
    Basic Binary Tree Node class
    public class BTreeNode<T extends Comparable<T>> implements Position<T> {
         private BTreeNode<T> _left;
         private BTreeNode<T> _right;
         private BTreeNode<T> _parent;
         private T            _data;
         public T element() {
              return _data;
         }Basic Binary Tree class
    public class BasicBTree<T extends Comparable<T>> implements BinaryTree<T> {
    public void insert(T obj) {
              BTreeNode runner;
              runner = _root;
              if (obj.compareTo (runner.element()) = null) { // ERROR OCCURS HERE
                   _root = new BTreeNode(obj);
              return;   
    }the interface posistion
    public interface Position<T> {
         public T element();
    }

  • Easy question for all you ActionScript wizzkids!

    I have created the following Actionscript to control a 'Next
    Question' button. The idea is that it will choose a random frame to
    link to in the current scene (Part2).
    nextQ_btn.onRelease = function (){
    gotoAndStop("Part2", n);
    n = Math.random()*1+3;
    At the moment, when I click the 'Next Question' button,
    nothing happens. What's up with my script? My programming knowledge
    is very limited and this is just about all that it can manage!
    The button works when I take out the n variable and put in a
    frame number manually.

    monkee,
    There appear to be two issues with your code:
    1. you're calling n before you have defined it
    2. you need to generate a random whole number and the random
    number generator will have decimals
    The solution is
    1. call for n after you define it
    2. use a rounding action to make the random number a whole
    number
    So:
    nextQ_btn.onRelease = function (){
    // generate a rounded random number between 0 and 4
    n = Math.round(Math.random() * 4);
    trace (n)
    // go to the random number +1, making the range 1-5
    gotoAndStop(n+1);
    As you may already know, the trace action helps solve these
    types of issues by letting you know the value of n if it is
    defined... when you test movie, the results of the trace statement
    show n has a value in the output window. In your original code, it
    would show undefined.
    Hope this helps. One other thing you may face is figuring out
    a way not to ask the same question twice. You probably will want to
    use an array of eligible questions before long.

  • Easy Question for you:

    I have two JcomboBoxes, if the user selects the text "Newspaper" rom the first JComboBox then the second JcomboBox must be invisible, if the user selects anything else then the second JCOmboBox can remain visible.
    I am not sure about how to get the text of the first comboBox and also how to hide the second, I am new to Java.
    Any one Help??
    Cheers

    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    public class Test3 extends JFrame {
      JComboBox jcb1 = new JComboBox(new String[] {"Magazine","Newspaper","Book"});
      JComboBox jcb2 = new JComboBox(new String[] {"Times","Tribune","Examiner"});
      public Test3() {
        setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
        Container content = getContentPane();
        content.setLayout(new FlowLayout());
        jcb2.setVisible(false);
        content.add(jcb1);
        content.add(jcb2);
        jcb1.addActionListener(new ActionListener() {
          public void actionPerformed(ActionEvent ae) {
            jcb2.setVisible("Newspaper".equals(jcb1.getSelectedItem().toString()));
        setSize(300,300);
        setVisible(true);
      public static void main(String[] args) { new Test3(); }
    }

  • Easy Question for you hard programmers

    Do I have to do something special to read from a file using Fort�? My program compiles fine, and it'll even run at a prompt or in TextPad, but when I run it in Fort�, it throws a FileNotFoundException.
    Help Appreciated.

    You do have to look in the correct directory for the
    file, but that's true whether you are using Forte or
    not. Perhaps you are not specifying any directory
    path and you don't know what Forte uses as its current
    directory?I've run into the same problem with Forte when I try to use ClassLoader.findResource to find a file. I never did figure out where it's supposed to be, even if I modifed the classpath. However, it worked when I specified a specific file path, i.e. starting with C:\ etc etc. What's annoying is that you of course have to escape the backslashes. C:\\dir\\subdir.... etc. yuck.

  • Ingest question for any Red users

    Hi there,
    just wanted to get a rough idea on which of the following Red cutters prefer as their ingest method.
    (I'm going back to R3D files for main post but all ingest is to Pro res for cutting now)
    1. use FCP log & transfer tool
    2. use Redcine-x
    3. use Rocket cinex
    I'm using an octo core 2.93w 16gb ram running os 10.6.2 and FCP 7.0.1, I have searched the forum and am asking over at redforum but just wanted to know what the good people here thought
    many thanks
    Andy

    Not that I'm aware of, and I'm a paying customer.

  • Easy questions for Pro about ASM block size

    hi
    how can we change DB_BLOCK_SIZE in ASM (while instalation)
    we have a default of 4096

    As for databases 'later' is not possible. I'm not sure what happens when you choose another blocksize at creation time. ASM blocksize is only for metadata,it's not related to the actual database data (having the database blocksize) stored in ASM diskgroups.
    These are the blocks which are used for extent maps in shared pool.o you dont need to worry about this blocksize difference.
    here is the actul link that i copied over from(above)
    ASM instance's block size

  • 2 Easy Questions for - Safari 1.3.2

    Since I can no longer make FireFox work (QT/?), I am returning to Safari, once my first choice, but Safari wouldn't open certain sites, there for so I went to FireFox.
    I am still using Safari 1.3.2 - I've searched the discussions and am not sure if the next update from 1.3.2 is without problems. Any opinions on this whether or not it's safe to update if 1.3.2 isn't broken?
    Is there a way to automatically alphabetize the bookmarks? At this time, I drag them into the correct order.

    You're welcome Patt. Glad to help.
    Older version of Firefox is compatible with OS X Jaguar, Panther and Tiger, as it uses its own internal engine for web site rendering (if it suits you, upgrade to the most recent version by going to Firefox>Help Menu>Check for updates).
    By contrast, Safari uses an engine called "WebKit", which is also found in other Apple applications such as iTunes. As these various applications evolve, the older versions of OS X become incompatible. For example, Panther's WebKit engine is quite different than Tigers. Same will hold true for OS X Leopard because of product enhancements and new features.
    Sometimes it's hard to keep up with the technology given how quickly it changes!
    Mahalo for the and Aloha from Big Island.

  • Easy question for someone...I hope

    I have an Edirol FA-66 interface. It's connected through fire wire to GB, GB recognizes this yet no levels come through a basic track...any thoughts?

    Nevermind...

  • SQLPLUS multiple data entry. Very easy question for experts.

    Hi sorry to bother you again but is it the same method as in MySQL to enter multiple data at once?
    I am trying to save time by entering all the contents of a table all at once,
    For example;
    INSERT INTO Borrower (BorId, BorName, BorMaxBooks) VALUES (
    (001, 'Bob', 4),
    (002, 'James', 5),
    (003, 'Dave', 6);
    Please can you tell me where I cam going wrong and I promise I will shut up and go away.
    Thanks.

    i can! :)
    SQL> create table T
      2  (BorId varchar2(64),
      3  BorName varchar2(64),
      4  BorMaxBooks number)
      5  /
    Table created
    SQL> insert into t
      2  select '001', 'Bob', 4 from dual
      3  union all
      4  select '002', 'James', 5 from dual
      5  union all
      6  select '003', 'Dave', 6 from dual
      7  /
    3 rows inserted
    SQL> select * from t
      2  /
    BORID                                                            BORNAME                                                          BORMAXBOOKS
    001                                                              Bob                                                                        4
    002                                                              James                                                                      5
    003                                                              Dave                                                                       6
    SQL>

Maybe you are looking for