EJB Client giving error

Hi All,
I am new to EJB programming. I am trying to use EJB3 and Weblogic12c.
and would like to know why I am getting this error:
run:
[echo] Executing client class
[java] java.lang.NoClassDefFoundError: com/saurabh/demo/HelloWorldClient
[java] Caused by: java.lang.ClassNotFoundException: com.saurabh.demo.HelloW
orldClient
[java] at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
[java] at java.security.AccessController.doPrivileged(Native Method)
[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
[java] Could not find the main class: com.saurabh.demo.HelloWorldClient. P
rogram will exit.
[java] Exception in thread "main"
[java] Java Result: 1
I am posting my code so that its more easy to debug...
1. HelloWorld.java -
package com.saurabh.demo;
import javax.ejb.Remote;
@Remote
public interface HelloWorld
     public void sayHello(String name);
2. HelloWorldBean.java
package com.saurabh.demo;
import javax.ejb.Stateless;
@Stateless(mappedName="HelloWorld")
public class HelloWorldBean implements HelloWorld
     public void sayHello(String name)
          System.out.println("Hello "+name+ " Its Working");
3.
package com.saurabh.demo;
import java.util.Hashtable;
import javax.naming.Context;
import javax.naming.InitialContext;
public class HelloWorldClient{
     private static HelloWorld helloworld;
     public static void main(String[] args)
     try{
          Hashtable<String, String> env = new Hashtable<String,String>();
          env.put(Context.INITIAL_CONTEXT_FACTORY,"weblogic.jndi.WLInitialContextFactory");
          env.put(Context.SECURITY_PRINCIPAL,"username of my weblogic");
          env.put(Context.SECURITY_CREDENTIALS,"password of my weblogic");
          env.put(Context.PROVIDER_URL,"t3://localhost:7001");
          Context ctx=new InitialContext(env);
          System.out.println("Initial Context created");
          helloworld =(HelloWorld)ctx.lookup("HelloWorld#com.saurabh.demo.HelloWorld");
          System.out.println("lookup Successful");
          System.out.println("Calling EJB method...");
          helloworld.sayHello("Saurabh");
          System.out.println("Output will be in Managed Server Console");
     catch(Exception e)
          e.printStackTrace();
4. build.xml
<?xml version="1.0" encoding="iso-8859-1"?>
<project name="Ejb_HelloWorld" basedir="." default="buildEar">
<property file="${basedir}/developer.properties"/>
<property name="jarname" value="HelloWorld-ejb"/>
<property name="appname" value="HelloWorld"/>
<property name="src" value="${basedir}/src"/>
<property name="build" value="${basedir}/build"/>
<property name="dist" value="${basedir}/dist"/>
<property name="lib" value="${basedir}/lib"/>
<property name="src.server" value="${src}/server"/>
<property name="src.client" value="${src}/client"/>
<property name="build.server" value="${build}/server"/>
<property name="build.client" value="${build}/client"/>
<property name="dist.server" value="${dist}/server"/>
<property name="dist.client" value="${dist}/client"/>
<path id="dependencies">
     <pathelement location="${lib}/javax.ejb_3.1.0.jar"/>
     <pathelement location="${lib}/weblogic.jar"/>
</path>
<target name="clean">
     <echo>"Cleaning the directories"</echo>
     <delete dir="${build}"/>
     <delete dir="${dist}"/>
</target>
<target name="compile" depends="clean">
     <echo>"Compiling EJB"</echo>
     <echo message="BEA_HOME:${BEA_HOME}"/>
     <echo message="WLS_HOME:${WLS_HOME}"/>
     <mkdir dir="${build}/server/classes"/>
     <echo message="Source directory : ${src.server}"/>
     <javac includeantruntime="false" srcdir="${src.server}" destdir="${build.server}/classes" debug="on">
     <classpath refid="dependencies"/>
     </javac>
</target>
<target name="compileClient">
     <echo>"Compiling Client class"</echo>
     <mkdir dir="${build.client}/classes"/>
     <javac includeantruntime="false" srcdir="${src.client}" destdir="${build.client}/classes" debug="on">
     <classpath refid="dependencies"/>
     <classpath location="${build.server}/classes"/>
     </javac>
</target>
<target name="buildEar" depends="compile">
     <echo>"Building EJB EAR"</echo>
     <mkdir dir="${dist.server}"/>
     <jar jarfile="${dist.server}/${jarname}.jar" basedir="${build}/server/classes"/>
     <jar jarfile="${dist.server}/${appname}.ear" basedir="${dist.server}"/>
</target>
<target name="run" depends="compileClient">
     <echo message="Executing client class"></echo>
     <java classname="com.saurabh.demo.HelloWorldClient" fork="yes">
     <classpath>
     <pathelement location="{build.client}/classes"/>
     <pathelement location="{dist.server}/HelloWorld-ejb.jar"/>
     <pathelement location="{lib}/wlfullclient.jar"/>
     </classpath>
     </java>
</target>
</project>
5. developer.properties- This property file is being used to set the needed paths.
BEA_HOME=C:\SG_Installs\wls1211_dev
JAVA_HOME=C:\SG_Installs\Java
WLS_HOME=C:\SG_Installs\wls1211_dev\wlserver
project.home=C:\Saurabh Data\WebDev\EJB-HelloWorld
wls.domain.path=C:\SG_Installs\BEA_Domain\BEA_Domain
wls.application.path=C:\SG_Installs\BEA_Domain\BEA_Domain\applications
There is no deployment descriptors since there is no need for that in EJB3 as I know.
I have been trying to resolve this issue but with no luck... Please help....
Edited by: 919201 on Mar 6, 2012 4:31 PM
Edited by: 919201 on Mar 6, 2012 5:54 PM
Edited by: Passionate on Mar 8, 2012 9:35 PM

java.lang.NoClassDefFoundError: com/saurabh/demo/HelloWorldClient
+[java] Caused by: java.lang.ClassNotFoundException: com.saurabh.demo.HelloW+
orldClient
Does {build.client}/classes include the com/saurabh/demo/HelloWorldClient class?

Similar Messages

  • EJB - Tutorial giving error in Weblogic 8.1 Deployment - Help

    I am a EJB newbie, i tried deploying the Demo.jar and i get the following error on deployment
    Please help
    Thanks in Advance
    drg
    Exception:weblogic.management.ApplicationException: prepare failed for Demo Module: Demo Error: Exception preparing module: EJBModule(Demo,status=NEW) Unable to deploy EJB: Demo.jar from Demo.jar: In EJB DemoBean, references to javax.ejb.EJBContext, javax.ejb.SessionContext, or javax.ejb.EntityContext must not be transient. at weblogic.ejb20.compliance.EJBComplianceChecker.check(EJBComplianceChecker.java:268) at weblogic.ejb20.compliance.EJBComplianceChecker.checkDeploymentInfo(EJBComplianceChecker.java:232) at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar(EJBCompiler.java:810) at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJBCompiler.java:766) at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompiler.java:200) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:476) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:407) at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDeployer.java:493) at weblogic.ejb20.deployer.EJBDeployer.compileJar(EJBDeployer.java:784) at weblogic.ejb20.deployer.EJBDeployer.compileIfNecessary(EJBDeployer.java:700) at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDeployer.java:1339) at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:498) at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:3142) at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1583) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1227) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1070) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2513) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2463) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2379) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:866) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:594) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:508) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178) weblogic.ejb20.compliance.ComplianceException: In EJB DemoBean, references to javax.ejb.EJBContext, javax.ejb.SessionContext, or javax.ejb.EntityContext must not be transient. at weblogic.ejb20.compliance.SessionBeanClassChecker.checkEJBContextIsNotTransient(SessionBeanClassChecker.java:69) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at weblogic.ejb20.compliance.EJBComplianceChecker.check(EJBComplianceChecker.java:278) at weblogic.ejb20.compliance.EJBComplianceChecker.checkDeploymentInfo(EJBComplianceChecker.java:232) at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar(EJBCompiler.java:810) at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJBCompiler.java:766) at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompiler.java:200) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:476) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:407) at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDeployer.java:493) at weblogic.ejb20.deployer.EJBDeployer.compileJar(EJBDeployer.java:784) at weblogic.ejb20.deployer.EJBDeployer.compileIfNecessary(EJBDeployer.java:700) at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDeployer.java:1339) at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:498) at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:3142) at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1583) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1227) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1070) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2513) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2463) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2379) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:866) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:594) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:508) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
    [Deployer:149033]preparing application Demo on cosmosserver
    [Deployer:149033]failed application Demo on cosmosserver
    [Deployer:149034]An exception occurred for task [Deployer:149026]Deploy application Demo on cosmosserver.: Exception:weblogic.management.ApplicationException: prepare failed for Demo Module: Demo Error: Exception preparing module: EJBModule(Demo,status=NEW) Unable to deploy EJB: Demo.jar from Demo.jar: In EJB DemoBean, references to javax.ejb.EJBContext, javax.ejb.SessionContext, or javax.ejb.EntityContext must not be transient. at weblogic.ejb20.compliance.EJBComplianceChecker.check(EJBComplianceChecker.java:268) at weblogic.ejb20.compliance.EJBComplianceChecker.checkDeploymentInfo(EJBComplianceChecker.java:232) at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar(EJBCompiler.java:810) at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJBCompiler.java:766) at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompiler.java:200) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:476) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:407) at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDeployer.java:493) at weblogic.ejb20.deployer.EJBDeployer.compileJar(EJBDeployer.java:784) at weblogic.ejb20.deployer.EJBDeployer.compileIfNecessary(EJBDeployer.java:700) at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDeployer.java:1339) at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:498) at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:3142) at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1583) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1227) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1070) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2513) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2463) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2379) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:866) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:594) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:508) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178) weblogic.ejb20.compliance.ComplianceException: In EJB DemoBean, references to javax.ejb.EJBContext, javax.ejb.SessionContext, or javax.ejb.EntityContext must not be transient. at weblogic.ejb20.compliance.SessionBeanClassChecker.checkEJBContextIsNotTransient(SessionBeanClassChecker.java:69) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at weblogic.ejb20.compliance.EJBComplianceChecker.check(EJBComplianceChecker.java:278) at weblogic.ejb20.compliance.EJBComplianceChecker.checkDeploymentInfo(EJBComplianceChecker.java:232) at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar(EJBCompiler.java:810) at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJBCompiler.java:766) at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompiler.java:200) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:476) at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:407) at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDeployer.java:493) at weblogic.ejb20.deployer.EJBDeployer.compileJar(EJBDeployer.java:784) at weblogic.ejb20.deployer.EJBDeployer.compileIfNecessary(EJBDeployer.java:700) at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDeployer.java:1339) at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:498) at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:3142) at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1583) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1227) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1070) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2513) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2463) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2379) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:866) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:594) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:508) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)

    Could you post the code for your DemoBean?
    I suspect that you are using a really old tutorial on EJB where the EJBContext, SessionContext or EntityContext were declared transient. This was, I believe, the case with EJB 1.0. You would need to remove the transient from the context declaration, if that is the case.

  • IPSec remote VPN with VPN client giving error

    Hi ,
    ASA 5505 current configuration is : (setup using ASDM)
    esult of the command: "show running-config"
    : Saved
    ASA Version 8.2(5)
    hostname TEST
    enable password ___________ encrypted
    passwd __________ encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    ftp mode passive
    access-list sap_vpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.224
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool test_pool 192.168.10.0-192.168.10.20 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.1.5-192.168.1.132 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy sap_vpn internal
    group-policy sap_vpn attributes
    dns-server value 192.168.2.1
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value sap_vpn_splitTunnelAcl
    username test password ____________ encrypted privilege 0
    username test attributes
    vpn-group-policy sap_vpn
    username TEST password ________________ encrypted privilege 15
    tunnel-group sap_vpn type remote-access
    tunnel-group sap_vpn general-attributes
    address-pool test_pool
    default-group-policy sap_vpn
    tunnel-group sap_vpn ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:b67cdffbb9567f754052e72f69ef95f1
    : end
    I am using VPN client with host IP 192.168.2.20 and group authentication with username:sap_vpn and preshared key as password but could not connect to vpn and getting attached error message.
    ASA set up with ASDM initial wizard: inside interface (VLAN1) IP 192.168.1.1 and outside (VLAN2) IP 192.168.2.20 assigned using DHCP. I am using outside interface IP 192.168.2.20 for HOST IP in VPN client for remote connection??? is it right??
    please advise for this.

    Hi,
    current configuration for ASA 5505 for IPSec remote VPN as below:
    ASA Version 8.2(5)
    hostname _________
    domain-name ________
    enable password ___________ encrypted
    passwd _________ encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.7 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address ______________(public IP)
    ftp mode passive
    dns server-group DefaultDNS
    domain-name ________
    access-list inside_nat0_outbound extended permit ip any 172.16.0.0 255.255.224.0
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool test_pool 172.16.10.0-172.16.16.20 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd auto_config outside
    dhcpd address 192.168.0.11-192.168.0.138 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy dyt_vpn internal
    group-policy dyt_vpn attributes
    vpn-tunnel-protocol IPSec
    default-domain value _______
    username test password _________ encrypted privilege 0
    username test attributes
    vpn-group-policy dyt_vpn
    username ________ password ______________encrypted privilege 15
    tunnel-group dyt_vpn type remote-access
    tunnel-group dyt_vpn general-attributes
    address-pool test_pool
    default-group-policy dyt_vpn
    tunnel-group dyt_vpn ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:eb0f7a5c2385b7400e9b9432fb2df9d1
    : end
    when I am assigning PUblic IP to outisde interface of ASA, it is showing outside interface down.
    can anybody please help me for that.
    Thanks,
    Sap

  • Error in running EJB Client on a remote machine

    I delploy my beans and can run the EJB Client locally. However when I try to run the Client on another machine, there are errors.
    Here is the errors
    Syntax error
    Out of environment space
    Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/appclient/Main
    I have follow the step in the j2ee tutorial and set the env variables according. Here is the bat file I write
    set APPCPATH=CBSAppClient.jar
    set VMARGS=-Dj2eelogin.name=guest -Dj2eelogin.password=guest123 -Dorg.omg.CORBA.ORBInitialHost=192.168.0.2
    runclient -client CBSApp.ear -name CBSClient -textauth
    Do anyone facing the same problem with me?
    And how can I solve the problems?
    This is really URGENT, please help

    You are running on Windows 9x or Me, right? The darn OS has 300 or so bytes allocated for environment by default.
    Try setting the Initial environment to 4096 in the Properties|Memory tab for the batch file. That will get rid of "Out of environment space". The syntax error is another matter; Windows (except NT and derivatives) shells do not allow '=' in an environment variables value. You cannot overcome that. Some software (Sybase for instance) interprets # as = just because of that. Unfortunately, the JVM doesn't take such an approach.
    Better, grab copies of Unix utilities for Windows (www.gnu.org) including the wonderful shell 'bash' and write .sh scripts, which are inherently more powerful.

  • Ejb client error

    Hi, I use jdev 10g. I created a session bean with wizards and after that I created I Ejb client for that bean. When I start the embedded server and run the client java file I get the following error :
    com.evermind.server.rmi.OrionRemoteException: jazn.com/admin is not allowed to call this EJB method, check your security settings (method-permission in ejb-jar.xml and security-role-mapping in orion-application.xml).
         at denemeSessionHome_StatelessSessionHomeWrapper1.create(denemeSessionHome_StatelessSessionHomeWrapper1.java:41)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:324)
         at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.java:124)
         at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.java:48)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)
         at java.lang.Thread.run(Thread.java:534)
    at connection to localhost/127.0.0.1 as admin
         at com.evermind.server.rmi.RMIConnection.EXCEPTION_ORIGINATES_FROM_THE_REMOTE_SERVER(RMIConnection.java:1527)
         at com.evermind.server.rmi.RMIConnection.invokeMethod(RMIConnection.java:1480)
         at com.evermind.server.rmi.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:55)
         at com.evermind.server.rmi.RecoverableRemoteInvocationHandler.invoke(RecoverableRemoteInvocationHandler.java:22)
         at __Proxy0.create(Unknown Source)
         at ejbpackage.denemeSessionClient.main(denemeSessionClient.java:21)
    Process exited with exit code 0.
    all settings are the default ones.
    Anyone has any idea???

    hi
    There was no problem with that... the AdviceClient is not in the package... I needed j2ee.jar and AdviceAppClient.jar to run the client and hte AdviceClient is in C\java\Projects\Advice directory.... can anyone help me with what is wrong with my first command which didnt work ...
    java -classpath c:\Sun\AppServer\lib\j2ee.jar;c:\java\Projects\Advice;c:\java\Projects\AdviceAppClient.jar AdviceClient
    This one worked though....
    java -cp {$CLASSPATH}:"C:\java\Projects\Advice";AdviceAppClient.jar;c:\Sun\AppServer\lib\j2ee.jar; AdviceClient
    I dont know what makes the difference...
    vidhya

  • Java EJB client "Can't connect to ORB" errors...

    I'm writing an application that is a Java EJB client application (no web
    stuff at all). Needless to say there are no examples of such an app in
    the samples dir, they are all web-based.
    My problem is that when I try to run my application (client calls a
    stateless session bean on the server and gets a "hello world" string
    back) I get a "Could not create the TestService bean:
    javax.naming.CommunicationException: Cannot connect to ORB [Root
    exception is org.omg.CORBA.COMM_FAILURE:   minor code: 1 completed:
    Maybe]" error.
    This is a very simple test, and I'm getting quite frustrated in trying
    to figure out what's actually wrong.
    Here's the client code (the bean on the server has been deployed into a
    module called achptestEjb, the bean name is TestService)
    TestService service = null;
    TestServiceHome home=null;
    String host = "localhost";
    String port = "12345";
    try {
    Properties env = new Properties();
    Context context=null;
    String jndiName="ejb/achptestEjb/TestService";
    System.out.println("JNDI name is "+jndiName);
    env.put
    ("java.naming.factory.initial","com.sun.jndi.cosnaming.CNCtxFactory");
    env.put("java.naming.provider.url", "iiop://"+host+":"+port);
    context = new InitialContext(env);
    The error comes when the new InitialContext is set with the properties
    in the env object.
    Any ideas what I'm doing wrong?
    It would be a BIG help if iPlanet included one simple pure EJB client
    example. There are some of us out here who feel HTML is too limiting
    for complicated applications.
    Douglas Bullard

    I finally found the answer to my problem.... in the Ant script I had
    copied from another example, the "-iiop" was lacking in the ejbc
    arguments - almost all of the examples assume you'll be calling EJBs
    from within the container, instead of a stand-alone client, so they
    don't use that flag.
    Putting that "-iiop" flag into the ejbc arguments fixed everything.
    Thanks, Shivani, for pointing out what is now obvious but was
    mysterious.
    Douglas Bullard
    In article <[email protected]>,
    [email protected] says...
    I'm writing an application that is a Java EJB client application (no web
    stuff at all). Needless to say there are no examples of such an app in
    the samples dir, they are all web-based.
    My problem is that when I try to run my application (client calls a
    stateless session bean on the server and gets a "hello world" string
    back) I get a "Could not create the TestService bean:
    javax.naming.CommunicationException: Cannot connect to ORB [Root
    exception is org.omg.CORBA.COMM_FAILURE:   minor code: 1 completed:
    Maybe]" error.
    This is a very simple test, and I'm getting quite frustrated in trying
    to figure out what's actually wrong.
    Here's the client code (the bean on the server has been deployed into a
    module called achptestEjb, the bean name is TestService)
    TestService service = null;
    TestServiceHome home=null;
    String host = "localhost";
    String port = "12345";
    try {
    Properties env = new Properties();
    Context context=null;
    String jndiName="ejb/achptestEjb/TestService";
    System.out.println("JNDI name is "+jndiName);
    env.put
    ("java.naming.factory.initial","com.sun.jndi.cosnaming.CNCtxFactory");
    env.put("java.naming.provider.url", "iiop://"+host+":"+port);
    context = new InitialContext(env);
    The error comes when the new InitialContext is set with the properties
    in the env object.
    Any ideas what I'm doing wrong?
    It would be a BIG help if iPlanet included one simple pure EJB client
    example. There are some of us out here who feel HTML is too limiting
    for complicated applications.
    Douglas Bullard

  • The server deploy EJB but I run EJB Client program,The error msg is can't find JNDI

    Hi all:
    I am using Weblogic 6.1/SP2. I use the console to start
    server and deploy EJB jar,from the msg I see my EJB jar
    been deployed. When I run EJB Client program, the error
    msg is can't find JNDI name t3://URL:11003.....
    I check my ejb-jar.xml amd weblogic-ejb-jar.xml are fine.
    Last week I did deploy EJB and ran the client both
    suceessful. Any ideas, Thank you.

    Sabha:
    Thank you for your help info, I soloved the problem.
    The problem is the ejb jar was deleted(I don't why)
    then System Admin to deploy EJB jar from Admin console.
    After that everything is fine.
    "Sabha" <[email protected]> wrote:
    Run weblogic.Admin -url ... LIST to see whether the JNDI name is there
    . or
    you can view the jndi tree of the server from the console (right click
    on
    server name) and check whether the ejb home is bound to the correct jndi
    name.
    -Sabha
    "Matthew Shinn" <[email protected]> wrote in message
    news:[email protected]..
    Hi Albert,
    I would double check to make sure the EJB was indeed deployed (check
    server log). What message did you see that leads you to believe itwas
    successfully deployed? Also, verify the JNDI name you are lookingup in
    your client matches the JNDI name for the EJB. If this doesn't solve
    the problem, please post the error message and stack trace you are
    seeing on the client.
    - Matt
    Albert Pi wrote:
    Hi all:
    I am using Weblogic 6.1/SP2. I use the console to start
    server and deploy EJB jar,from the msg I see my EJB jar
    been deployed. When I run EJB Client program, the error
    msg is can't find JNDI name t3://URL:11003.....
    I check my ejb-jar.xml amd weblogic-ejb-jar.xml are fine.
    Last week I did deploy EJB and ran the client both
    suceessful. Any ideas, Thank you.

  • Error Catching Exceptions on EJB Clients

    I'm trying to throw an owm exception from an EJB Session to my EJB
    client. I can catch the exception but when i use the getMessage()
    method the String I receive is not the message I used to create the
    exception. The result of the getMessage() call is the same that them
    call to printStackTrace().
    does anybody knows if weblogic in change the message of the
    exception for the printStackTrace before throws the exception to the
    client?
    Thanks.

    David,
    Refer to the following link for best practices concerning EJB exception handling:
    http://dev2dev.bea.com/articles/Rong.jsp
    Best regards,
    Ryan LeCompte
    [email protected]
    http://www.louisiana.edu/~rml7669
    "Cata" <[email protected]> wrote:
    >
    I'm trying to throw an owm exception from an EJB Session to my EJB
    client. I can catch the exception but when i use the getMessage()
    method the String I receive is not the message I used to create the
    exception. The result of the getMessage() call is the same that them
    call to printStackTrace().
    does anybody knows if weblogic in change the message of the
    exception for the printStackTrace before throws the exception to the
    client?
    Thanks.

  • EJB Client Access From JDeveloper9iR2

    I seem to be running into a lot of problems when trying to get a simple EJB client to talk to an EJB on our 9IAS platform. I have developed a simple session bean (just to test) which simply returns a string. When I create the default client code this works fine using the embedded OC4J server in Jdeveloper but I can't run a similar client against 9IAS when I deploy the code. When I go through the client wizard it seems to produce the same code as the standalone EJB OC4J client. I simply changed the name of the server (Context.PROVIDER_URL, "ormi://pe2500/). This is the parameter code I use:
    Hashtable env = new Hashtable();
    env.put(Context.INITIAL_CONTEXT_FACTORY, "com.evermind.server.rmi.RMIInitialContextFactory");
    env.put(Context.SECURITY_PRINCIPAL, "admin");
    env.put(Context.SECURITY_CREDENTIALS, "welcome");
    env.put(Context.PROVIDER_URL, "ormi://pe2500:23891/MyEJBs");
    This is the output I receive:
    D:\jdeveloper9ir2\jdk\bin\javaw.exe -ojvm -classpath D:\javadev\ejbservlet\ejbservlet\WEB-INF\classes;D:\jdeveloper9ir2\jdev\lib\jdev-rt.jar;D:\jdeveloper9ir2\j2ee\home\lib\ojsp.jar;D:\jdeveloper9ir2\j2ee\home\jsp\lib\taglib\ojsputil.jar;D:\jdeveloper9ir2\j2ee\home\oc4j.jar;D:\jdeveloper9ir2\j2ee\home\lib\servlet.jar;D:\jdeveloper9ir2\jdev\lib\ojc.jar;D:\jdeveloper9ir2\j2ee\home\lib\activation.jar;D:\jdeveloper9ir2\j2ee\home\lib\ejb.jar;D:\jdeveloper9ir2\j2ee\home\lib\jaas.jar;D:\jdeveloper9ir2\j2ee\home\lib\jaxp.jar;D:\jdeveloper9ir2\j2ee\home\lib\jcert.jar;D:\jdeveloper9ir2\j2ee\home\lib\jdbc.jar;D:\jdeveloper9ir2\j2ee\home\lib\jms.jar;D:\jdeveloper9ir2\j2ee\home\lib\jndi.jar;D:\jdeveloper9ir2\j2ee\home\lib\jnet.jar;D:\jdeveloper9ir2\j2ee\home\lib\jsse.jar;D:\jdeveloper9ir2\j2ee\home\lib\jta.jar;D:\jdeveloper9ir2\j2ee\home\lib\mail.jar;D:\jdeveloper9ir2\j2ee\home\oc4j.jar;D:\jdeveloper9ir2\lib\xmlparserv2.jar;D:\jdeveloper9ir2\lib\xmlcomp.jar;D:\jdeveloper9ir2\j2ee\home\oc4j.jar;D:\jdeveloper9ir2\j2ee\home\lib\servlet.jar Samplemypackage6.ctejb1Client3
    javax.naming.NamingException: Lookup error: java.net.ConnectException: Connection refused: connect; nested exception is:
         java.net.ConnectException: Connection refused: connect
         java.lang.Object com.evermind.server.rmi.RMIContext.lookup(java.lang.String)
              RMIContext.java:134
         java.lang.Object javax.naming.InitialContext.lookup(java.lang.String)
              InitialContext.java:350
         void Samplemypackage6.ctejb1Client3.main(java.lang.String[])
              ctejb1Client3.java:18
    Process exited with exit code 0.
    Can anyone tell me if this is the correct communication method for client EJB's talking to the 9IAS server?
    Any help really appreciated.
    Chris Taylor

    hi Chris Taylor, did you find the solution for this error. i too get this error and i am looking for the answer. if you find any answer please share with me too. if i get any answer for this i will reply you too.

  • EJB CBS Build Error: No folder found for attribute meta-inf

    I'm trying to activate my EJB DC that works properly when built and executed/deployed in the portal.
    But in CBS it fails to build and we got the following error trace:
    This is the error trace:
      [pppacker] Packing public part 'client'
      [pppacker] ERROR: Failed to pack public part: No folder found for attribute meta-inf
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPackTask._execute(PPPackTask.java:295)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.techdev.ant.util.BPTask.execute(BPTask.java:20)
      [pppacker] ERROR:       at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      [pppacker] ERROR:       at org.apache.tools.ant.Task.perform(Task.java:364)
      [pppacker] ERROR:       at org.apache.tools.ant.Target.execute(Target.java:341)
      [pppacker] ERROR:       at org.apache.tools.ant.Target.performTasks(Target.java:369)
      [pppacker] ERROR:       at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
    [pppacker] ERROR: Caused by: com.sap.tc.buildplugin.pp.PackException: No folder found for attribute meta-inf
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.entity.EHEjbClientJar.findSpecialFolderContaining(EHEjbClientJar.java:126)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.entity.EHEjbClientJar.determineFileList(EHEjbClientJar.java:64)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPacker.packEntity(PPPacker.java:697)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPacker.packPublicPartContent(PPPacker.java:585)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPacker.packPublicPart(PPPacker.java:532)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPacker.pack(PPPacker.java:460)
      [pppacker] ERROR:       at com.sap.tc.buildplugin.pp.PPPackTask._execute(PPPackTask.java:293)
      [pppacker] ERROR:       ... 29 more
    Ant runtime 0.032 seconds
    Ant build finished with ERRORS
    Failed to pack public part: No folder found for attribute meta-inf
    I'm not sure if this means anything:
    Preparing data context..
    No public part descriptor found for component "ejb20" (vendor "sap.com"), public part "default", using legacy mode.
    No public part descriptor found for component "jdbc20" (vendor "sap.com"), public part "default", using legacy mode.
    No public part descriptor found for component "jms" (vendor "sap.com"), public part "default", using legacy mode.
    No 'default' JDK defined, will use running VM.
    Data context preparation finished in 0.017 seconds
    How do I resolve this issue?
    Thank you in advance.

    TRY TO DO ITSELF.

  • Time to time its giving error in the FTP connection

    Hi Gurus,
    Im doing File to File Interface. Im using FTP for File transfer and the message protocol is 'File'.  Im using the connection security as 'FTPS(FTP Using SSL/TLS) for control and data connection' and set the default command order.
        I have uploaded the required certificate in the FTP server and the XI server also. I can view the certificate in the keystore of visual Administrator. Its working fine. But the problem is time to time its giveing this error "Error occurred while connecting to the FTP server "170.135.128.149:20021": iaik.security.ssl.SSLCertificateException: Peer certificate rejected by ChainVerifier"
    Can anyone please help to resolve this issue. i need to fix it as soon as possible.
    Regards,
    Rama

    Hi All,
      I m facing one peculiar problem with FTP server. I have desinged one R3 to FTP interface. I m trying to connect to FTP with secure SSL connection. For that we uploaded the certificate in the FTP as well as in the Visual administartor in the XI box. I didnt create any SSL socket for this. Our basis team told like we dont need this SSL socket stuff because here we are using FTP as a client. So just they uploaded the certificate in the trusted CA of Visual administartor. Our certificate is obtained from verisign. So the CN name in the certificate is Verisign. I didnt find any thing in the certificate other then this. In our communication channel we gave the hostname instead of IP address.  But here my problem is, When i send the file to FTP its giving error in the first attempt. After that the message retiried itslef, the file has been sent successfull in the retry process. Why it is always fails in the first attempt.
    Can anyone please help me to resolve this. I need to be fix today itself.
    Regards,
    Rama

  • IW32- order-print is giving error for particular User.

    Dear Friends,
    IW32- order-print is giving error for particular User and output type.  Debugging authorization restricted on the system, hence I canu2019t trace out the problem. If anybody comes across such issues, please reply to the post.
    Thanks In Advance for your reply.
    Anil Dasari
    Thanks In Advance.

    Hi,
    Information about dump:
    1. User and Transaction:
    Runtime Errors         MESSAGE_TYPE_X
    Date and Time          06.05.2011 10:47:40
         MM Used. 13116304
         MM Free. 3639760
    User and Transaction
         Client.............. 700
         User................ "BLADEF01"
         Language key........ "N"
         Transaction......... "IW32 "
         Transactions ID..... "4DC387ECA12B684DE10000001A5B1803"
         Program............. "/MRSS/SAPLRSG_PM_ORDER"
         Screen.............. "SAPLCOIH 3000"
         Screen line......... 33
    Information on where terminated
         Termination occurred in the ABAP program "/MRSS/SAPLRSG_PM_ORDER" - in
          "/MRSS/RSG_MAINTAIN_MRS".
         The main program was "SAPLCOIH ".
         In the source code you have the termination point in line 441
         of the (Include) program "/MRSS/LRSG_PM_ORDERU04".
    2. Info. Where it got terminated.
    Information on where terminated
        Termination occurred in the ABAP program "/MRSS/SAPLRSG_PM_ORDER" - in
         "/MRSS/RSG_MAINTAIN_MRS".
        The main program was "SAPLCOIH ".
        In the source code you have the termination point in line 441
        of the (Include) program "/MRSS/LRSG_PM_ORDERU04".
    3. How to correct the error.
    How to correct the error
        Probably the only way to eliminate the error is to correct the program.
        If the error occures in a non-modified SAP program, you may be able to
        find an interim solution in an SAP Note.
        If you have access to SAP Notes, carry out a search with the following
        keywords:
        "MESSAGE_TYPE_X" " "
        "/MRSS/SAPLRSG_PM_ORDER" or "/MRSS/LRSG_PM_ORDERU04"
        "/MRSS/RSG_MAINTAIN_MRS"
        If you cannot solve the problem yourself and want to send an error
        notification to SAP, include the following information:
        1.1. The description of the current problem (short dump)
           To save the description, choose "System->List->Save->Local File
        (Unconverted)".
        2.2. Corresponding system log
           Display the system log by calling transaction SM21.
           Restrict the time interval to 10 minutes before and five minutes
        after the short dump. Then choose "System->List->Save->Local File
        (Unconverted)".
        3.3. If the problem occurs in a problem of your own or a modified SAP.
    I have been searching for notes recently implemented for IW32.
    Thanks and Regards,
    ANIL DASARI

  • URGENT : ejb client in Oracle 8

    We developed a EJB client. This client should be called from an Oracle Database 8.1 (ejb compliant). But, each time we tried to load weblogic.jar, we have several errors into Oracle (ie : ORA-29534 NamingContext could not be resolved)
    Do you have an idea why ? Someone already developed an ejb client into Oracle 8.1 ?

    They are reccomended because the next step going from your simple single EJB
    to anything interesting, like adding more EJB's adding web-apps, adding
    web-services etc etc involves ears. If the setup and overhead for an EAR is
    easy, then just start there.
    But no if you just doing helloworld you of course dont have to ears.
    cheers
    mbg
    "Christopher R. Gardner" <[email protected]> wrote in message
    news:3fc0560e$[email protected]..
    >
    "Mark Griffith" <[email protected]> wrote:
    You can still run ejbc from the command line its still there. And you
    can
    still run weblogic.Deployer. (I dont ever reccomend jaring up in dev,
    it
    just takes longer, do exploded its easier and faster).
    But ear's are easy, see:So ears are recommended even if you're just doing EJBs (e.g., a simpleHello World)
    and no web apps (none needed for the Hello World or a PC client)?
    http://www.niffgurd.com/mark/work/blog/
    Cheers
    mbg
    "Christopher R. Gardner" <[email protected]> wrote in message
    news:3fbfd6c6$[email protected]..
    My understanding is ejbc has been deprecated and replaced with appc.Moreover,
    BEA is encourgaging developers to deploy ear files. All I want todo is
    to use
    ant to deploy a jar file with a single EJB in it. I'm not findingthe WL
    documentation
    very helpful. Hopefully, you'll have better luck than I.
    "skmurali" <[email protected]> wrote:
    Hi
    In order deploy EJB application in Weblogic 8.1, is it necessary
    to compile
    the application in WebLogic.ejbc. I did not find such files in
    WebLogic
    8.1
    In weblogic 7.0 versiion has such files.
    The present procedure is as follows.
    1. Create a jar file contains all class files.
    2. Create a jar file contains class jar files, plus .xml files
    3. Deploy into weblogic 8.1 server EJB Deployment utility.
    ==================
    Please help me.
    Murali

  • Ejb Client

    I'm getting the following error in EJB CLient
    plz telle me some solutions ..
    NamingException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
    Thanks in Adv
    Srini

    Please see the documentation
    Oracle Application Server Containers for J2EE Enterprise JavaBeans Developer's Guide 10g (9.0.4) Part Number B10324-01
    http://download-uk.oracle.com/docs/cd/B10464_04/web.904/b10324/primer.htm#1020065
    Example 2-6 A Servlet Acting as a Local Client
    Example 2-7 A Java Client as a Remote Client
    Hope that helps.

  • Ejb ref resolution error

    Dear all,
    I try to set up a simple ejb environment. I managed to run the converter example from the JEE tutorial bundle in the NetBeans / Glassfish environment.
    Then I tried to write a standalone java client. The code consists in essential of the statements
    Context ctx = new InitialContext();
    ctx.lookup("converter.ejb.Converter");Unfortunately, running this program from a windows command line by the "java" command (plus some classpath settings) results in:
    NamingException: ejb ref resolution error for remote business interface converter.ejb.ConverterThe jndi entries of the app server are
    jndi root
      |
      |--  converter.ejb.Converter#converter.ejb.Converter
      |--  converter.ejb.Converter__3_x_Internal_RemoteBusinessHome__
      |
      |--ejb
          |-- converter.ejb.Converter All environment settings are the standard ones.
    Has anybody an idea, what the problem could be ? Thank you very much for your help.
    Ralph

    Hi,
    thanks for your interest. The client code is
    // file ConverterClient
    package ejb.clients;
    import javax.naming.*;
    import java.util.*;
    public class ConverterClient
      public static void main(String[] args)
        try
          Context ctx = new InitialContext();
          ctx.lookup("converter.ejb.Converter");
          Enumeration e = ctx.list("");
          while (e.hasMoreElements())
            System.out.println(e.nextElement());
        catch(NamingException ex)
          ex.printStackTrace();
    }The interface:
    // file Converter
    package converter.ejb;
    import java.math.BigDecimal;
    import javax.ejb.Remote;
    @Remote
    public interface Converter {
        public BigDecimal dollarToYen(BigDecimal dollars);
        public BigDecimal yenToEuro(BigDecimal yen);
    }The bean code is
    // file ConverterBean
    package converter.ejb;
    import java.math.BigDecimal;
    import javax.ejb.Stateless;
    @Stateless
    public class ConverterBean implements converter.ejb.Converter {
        private BigDecimal euroRate = new BigDecimal("0.0070");
        private BigDecimal yenRate = new BigDecimal("112.58");
        public BigDecimal dollarToYen(BigDecimal dollars) {
            BigDecimal result = dollars.multiply(yenRate);
            return result.setScale(2, BigDecimal.ROUND_UP);
        public BigDecimal yenToEuro(BigDecimal yen) {
            BigDecimal result = yen.multiply(euroRate);
            return result.setScale(2, BigDecimal.ROUND_UP);
    }It's been deployed successfully with NetBeans on Glassfish app server.
    The commands for compiling and running the client. "c:\java\JEE" is the installation dir for jee.
    c:\java\programs\src javac -d ..  -cp c:\java\JEE\lib\javaee.jar;c:\java\JEE\lib\appserv-rt.jar   ConverterClient.java
    c:\java\programs java -cp c:\java\JEE\lib\javaee.jar;c:\java\JEE\lib\appserv-rt.jar;.  ejb.clients.ConverterClient

Maybe you are looking for

  • No sound on TV with mini DVI to HDMI cable.  Macbook, white, 2008-9 13"

    Picture is fine, mirroring turned on, using mini dvi converter into HDMI on a new Samsung flat screen.  Want to avoid using additional cable from earhone plug to RCA plug in TV.  Thanks

  • Purchase Order Delivery Tolerances

    Hi All, I have question. On  Purchase Orders we have "Underdelivery Tolerance and over derdelivery Tolerance " defaulted in the PO detail.  This is coming from Info record and it is not maintained then materail master. In materail master this detail

  • 8.1.7 R3 Download site not working.

    The link to the 8.1.7 R3 download leads you to http://quote.yahoo.com instead of the usuall download page. This occurs both in http://download.oracle.com and in the standard 8i download page. No, I am NOT kidding ;-) null

  • Problem with jsp 2.0

    Hi, I know this has been discussed before, but after trying out the solutions, I still can't get it to work. When trying to use the uri http://java.sun.com/jsp/jstl/core for the core library, I get this error message: org.apache.jasper.JasperExceptio

  • Reposting: Question regarding iteration over synchronized list

    [added proper markup] I've got an A-Life program I work on for fun. I thought I understood (sorta) synchronized collections, but this puzzles me. The method body is as follows:      * Create new animals from existing animals      * @return The cohort