Fail over when queue manager is down

Hi,
I am implementing the MessageListener interface to receive messages from MQ. How will the JMS notify if the queue manager goes down for some reason. I need to capture the exception so that I can fail over to the secondary queue manager.
Please reply back if you have any pointers. Your help would be much appreciated.
Regards,
Sunil

If you register an ExceptionListener, you will be notified when connection to the JMS server is lost by a call to the onException() method.
http://java.sun.com/j2ee/1.4/docs/api/javax/jms/ExceptionListener.html
I've used this previously to attempt reconnection on a time interval for a specified number of retries.
-Scott
http://www.swiftradius.com

Similar Messages

  • ASA has to be failed over when primary ISP goes down.

    I have an outside 7206 router that is configured with BGP.  Behind that I have an ASA 5520 with a failover.  Everytime my primary ISP goes down I have to failover the ASA to restablish a connection to the secondary ISP.  When the primary comes back on line I have to fail it over again.  I have had Cisco TAC look at the ASA and they didn't see anything misconfigured on the ASA.  Doesn't seem to be any problems with the router config either. Any Ideas on what could be causing this?

    Thanks for your responses. Sorry, I'm new to this. Here are the configs and a simple pic of the primary asa and router the way thery are deployed. I've been dealing with issue for a while.  Hoping to get some help here.
    7206 router:
    show runn
    Building configuration...
    Current configuration : 4678 bytes
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname lee-border
    boot-start-marker
    boot-end-marker
    enable secret 5 **********************
    no aaa new-model
    ip subnet-zero
    ip cef
    ip name-server 206.77.62.152
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    interface GigabitEthernet0/1
    description Univ. of Texas OTS for ISP and Inet2
    no ip address
    duplex full
    speed 100
    media-type rj45
    negotiation auto
    interface GigabitEthernet0/1.7
    description Internet2 Access
    encapsulation dot1Q 7
    ip address 192.88.12.238 255.255.255.252
    interface GigabitEthernet0/1.16
    description THENet-Access
    encapsulation dot1Q 16
    ip address 207.80.110.134 255.255.255.252
    interface GigabitEthernet0/1.743
    description UT OTS TX-BB Peering
    encapsulation dot1Q 743
    ip address 192.124.228.114 255.255.255.252
    interface GigabitEthernet0/2
    description Phonoscope ISP Service
    ip address 66.60.235.146 255.255.255.248
    duplex full
    speed 100
    media-type rj45
    negotiation auto
    interface GigabitEthernet0/3
    description Lee College Internal LANs
    ip address 68.232.208.241 255.255.255.240 secondary
    ip address 68.232.208.1 255.255.255.248
    duplex full
    speed auto
    media-type rj45
    negotiation auto
    interface ATM1/0
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/1
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/2
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/3
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/4
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/5
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/6
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface ATM1/7
    no ip address
    shutdown
    no ima-group
    no atm ilmi-keepalive
    interface FastEthernet2/0
    no ip address
    shutdown
    duplex half
    interface FastEthernet4/0
    no ip address
    duplex auto
    speed auto
    interface FastEthernet4/1
    no ip address
    shutdown
    duplex auto
    speed auto
    router bgp 46094
    no synchronization
    bgp log-neighbor-changes
    network 68.232.208.0 mask 255.255.240.0
    network 198.216.112.0 mask 255.255.252.0
    network 207.80.120.0 mask 255.255.252.0
    neighbor 66.60.235.145 remote-as 22442
    neighbor 66.60.235.145 description Phonoscope
    neighbor 66.60.235.145 next-hop-self
    neighbor 66.60.235.145 send-community
    neighbor 66.60.235.145 version 4
    neighbor 66.60.235.145 soft-reconfiguration inbound
    neighbor 66.60.235.145 route-map Lee-out out
    neighbor 192.88.12.237 remote-as 276
    neighbor 192.88.12.237 description Internet2 Peering
    neighbor 192.88.12.237 send-community
    neighbor 192.88.12.237 version 4
    neighbor 192.88.12.237 route-map I2-in in
    neighbor 192.88.12.237 route-map Lee-I2-out out
    neighbor 192.88.12.237 password 7 132C4546070901
    neighbor 192.124.228.113 remote-as 6922
    neighbor 192.124.228.113 description UT-Commodity
    neighbor 192.124.228.113 send-community
    neighbor 192.124.228.113 soft-reconfiguration inbound
    neighbor 192.124.228.113 route-map OTS-in in
    neighbor 192.124.228.113 route-map OTS-out out
    no auto-summary
    ip default-gateway 192.124.228.113
    ip classless
    ip route 68.232.208.0 255.255.240.0 Null0 250
    ip route 68.232.209.0 255.255.255.0 68.232.208.2
    ip route 68.232.211.0 255.255.255.0 68.232.208.2
    ip route 68.232.212.0 255.255.252.0 68.232.208.2
    ip route 68.232.216.0 255.255.248.0 68.232.208.2
    ip route 198.216.112.0 255.255.252.0 Null0 250
    ip route 198.216.113.0 255.255.255.0 198.216.115.1
    ip route 198.216.114.0 255.255.255.0 198.216.115.1
    ip route 207.80.8.0 255.255.255.0 198.216.115.1
    ip route 207.80.120.0 255.255.252.0 Null0 250
    ip route 207.80.120.0 255.255.255.0 198.216.115.1
    ip route 207.80.121.0 255.255.255.0 198.216.115.1
    ip route 207.80.122.0 255.255.255.0 198.216.115.1
    ip route 207.80.123.0 255.255.255.0 198.216.115.1
    no ip http server
    access-list 90 permit 68.232.208.0 0.0.15.255
    access-list 90 deny   any
    access-list 91 permit 198.216.112.0 0.0.3.255
    access-list 91 permit 207.80.112.0 0.0.15.255
    access-list 91 deny   any
    route-map OTS-out permit 10
    match ip address 90
    route-map Lee-out permit 10
    match ip address 90
    route-map I2-in permit 10
    set local-preference 200
    route-map Lee-I2-out permit 10
    match ip address 90
    route-map Lee-I2-out permit 20
    match ip address 91
    route-map OTS-in permit 10
    set local-preference 150
    line con 0
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    password 7 *****************
    login
    end
    ASA (Primary)
    logging permit-hostdown
    mtu Outside 1500
    mtu inside 1500
    mtu LeeDMZ 1500
    mtu management 1500
    failover
    failover lan unit secondary
    failover lan interface failover GigabitEthernet0/3
    failover link failover GigabitEthernet0/3
    failover interface ip failover 172.16.1.1 255.255.255.0 standby 172.16.1.2
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any LeeDMZ
    asdm image disk0:/asdm-623.bin
    no asdm history enable
    arp timeout 14400
    global (Outside) 1 68.232.211.1-68.232.223.253
    global (Outside) 1 interface
    global (Outside) 1 68.232.223.254
    global (Outside) 2 68.232.209.25
    global (LeeDMZ) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0 tcp 16384 12000
    nat (LeeDMZ) 2 access-list NAT_NEW_ISA
    nat (LeeDMZ) 1 192.168.10.0 255.255.255.0
    static (inside,Outside) 68.232.209.10 10.1.200.253 netmask 255.255.255.255
    static (inside,LeeDMZ) 10.1.0.0 10.1.0.0 netmask 255.255.0.0
    static (inside,LeeDMZ) 192.168.3.0 192.168.3.0 netmask 255.255.255.0
    static (inside,Outside) 68.232.209.53 10.1.254.3 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.5 192.168.10.5 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.6 192.168.10.6 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.51 192.168.10.51 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.37 192.168.10.37 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.75 192.168.10.75 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.101 192.168.10.101 netmask 255.255.255.255
    static (inside,LeeDMZ) 192.168.2.0 192.168.2.0 netmask 255.255.255.0
    static (LeeDMZ,Outside) 68.232.209.102 192.168.10.102 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.38 192.168.10.38 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.23 192.168.10.23 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.136 10.1.7.37 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.111 192.168.10.111 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.8 10.1.13.8 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.103 192.168.10.103 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.92 192.168.10.92 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.4 10.1.6.2 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.219 192.168.10.219 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.217 192.168.10.217 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.206 192.168.10.206 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.234 192.168.10.234 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.33 192.168.10.33 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.246 10.1.1.246 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.11 192.168.10.11 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.100 192.168.10.100 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.120 192.168.10.120 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.70 192.168.10.70 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.36 192.168.10.36 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.50 192.168.10.50 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.22 192.168.10.22 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.121 10.1.1.121 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.20 192.168.10.20 netmask 255.255.255.255
    static (inside,Outside) 68.232.209.203 10.1.55.203 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.15 192.168.10.15 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.25 192.168.10.25 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.55 192.168.10.55 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.143 192.168.10.143 netmask 255.255.255.255
    static (LeeDMZ,Outside) 68.232.209.34 192.168.10.34 netmask 255.255.255.255
    access-group out-in in interface Outside
    access-group 170 in interface inside
    access-group dmz in interface LeeDMZ
    route Outside 0.0.0.0 0.0.0.0 68.232.208.1 1
    route inside 10.1.0.0 255.255.0.0 10.1.200.1 1
    route inside 192.168.2.0 255.255.255.0 10.1.200.254 1
    route inside 192.168.3.0 255.255.255.0 10.1.200.254 1
    route inside 192.168.5.0 255.255.255.0 10.1.200.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    url-server (inside) vendor websense host 10.1.1.66 timeout 10 protocol TCP version 1 connections 5
    aaa authentication ssh console LOCAL
    filter url except 10.1.4.4 255.255.255.255 0.0.0.0 0.0.0.0
    filter url except 10.1.4.136 255.255.255.255 0.0.0.0 0.0.0.0
    filter url except 10.1.4.30 255.255.255.255 0.0.0.0 0.0.0.0
    filter url except 0.0.0.0 0.0.0.0 192.168.10.36 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 192.168.10.22 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 192.168.10.100 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.1.27 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.1.30 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.89.2 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.1.11 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.1.61 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.1.7 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 192.168.10.38 255.255.255.255 allow
    filter url except 0.0.0.0 0.0.0.0 10.1.89.10 255.255.255.255 allow
    filter url except 10.1.56.189 255.255.255.255 0.0.0.0 0.0.0.0
    filter url except 10.1.4.15 255.255.255.255 0.0.0.0 0.0.0.0
    filter https except 10.1.4.30 255.255.255.255 0.0.0.0 0.0.0.0
    filter url except 10.1.1.0 255.255.255.0 0.0.0.0 0.0.0.0
    filter url http 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow
    filter https 443 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow
    filter ftp 21 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 10.1.4.29 255.255.255.255 management
    http 10.1.4.30 255.255.255.255 management
    http 10.1.4.31 255.255.255.255 management
    http 10.1.4.4 255.255.255.255 management
    snmp-server host inside 10.1.1.215 community *****
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    service resetoutside
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map Outside_map 1 match address Outside_1_cryptomap
    crypto map Outside_map 1 set peer 216.168.57.82
    crypto map Outside_map 1 set transform-set ESP-3DES-SHA
    crypto map Outside_map interface Outside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=LEE-ASA
    crl configure
    crypto ca trustpoint ASDM_Lee
    enrollment self
    subject-name CN=LEE-ASA
    crl configure
    crypto isakmp enable Outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 10.1.4.29 255.255.255.255 management
    telnet 10.1.4.30 255.255.255.255 management
    telnet 10.1.4.31 255.255.255.255 management
    telnet 10.1.4.4 255.255.255.255 management
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 LeeDMZ
    ssh 0.0.0.0 0.0.0.0 management
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection scanning-threat shun except ip-address 10.1.4.0 255.255.255.0
    threat-detection scanning-threat shun duration 3600
    threat-detection statistics host
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    url-block url-mempool 2500
    url-block url-size 4
    dynamic-filter updater-client enable
    dynamic-filter use-database
    dynamic-filter enable interface Outside
    dynamic-filter drop blacklist interface Outside
    dynamic-filter whitelist
    address 192.168.10.0 255.255.255.0
    address 10.1.1.6 255.255.255.255
    address 10.1.1.2 255.255.255.255
    dynamic-filter blacklist
    address 46.249.59.47 255.255.255.255
    address 95.215.2.8 255.255.255.255
    address 94.75.201.36 255.255.255.255
    ntp server 64.250.229.100 source Outside
    ntp server 24.56.178.140 source Outside prefer
    webvpn
    username **********************************
    username **************************************
    username ************************************
    tunnel-group 216.168.57.82 type ipsec-l2l
    tunnel-group 216.168.57.82 ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
      inspect dns migrated_dns_map_1 dynamic-filter-snoop
      inspect rtsp
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:************************************: end

  • Health Service Heartbeat Failure Alert for Generated when one Management Server Down,

    Hi,
    I have Two Management Server, every one manage about 100 server, when one Management Server goes down unexpected, I receive 100 Alert for 100 Server Health Service Heartbeat Failure.
    My Question, why when the Management Server down, it send that all Managed agent Health Service Heartbeat Failure?
    Is there a way to change this?

    SCOM 2012 agent will autofailover when primary server is down. You can check the failover management server by using the following powershell cmdlet:
    #Verify Failover for Agents reporting to MS1
    $Agents = Get-SCOMAgent | where {$_.PrimaryManagementServerName -eq 'MS1.DOMAIN.COM'}
    $Agents | sort | foreach {
    Write-Host "";
    "Agent :: " + $_.Name;
    "--Primary MS :: " + ($_.GetPrimaryManagementServer()).ComputerName;
    $failoverServers = $_.getFailoverManagementServers();
    foreach ($managementServer in $failoverServers) {
    "--Failover MS :: " + ($managementServer.ComputerName);
    Write-Host "";
    http://www.systemcentercentral.com/how-does-the-failover-process-work-in-opsmgr-2012-scom-sysctr/

  • Http cluster servlet not failing over when no answer received from server

              I am using weblogic 510 sp9. I have a weblogic server proxying all requests to
              a weblogic cluster using the httpclusterservlet.
              When I kill the weblogic process servicing my request, I see the next request
              get failed over to the secondary server and all my session information has been
              replicated. In short I see the behavior I expect.
              r.troon
              However, when I either disconnect the primary server from the network or just
              switch this server off, I just get a message back
              to the browser - "unable to connect to servers".
              I don't really understand why the behaviour should be different . I would expect
              both to failover in the same manner. Does the cluster servlet only handle tcp
              reset failures?
              Has anybody else experience this or have any ideas.
              Thanks
              

    I think I might have found the answer......
    The AD objects for the clusters had been moved from the Computers OU into a newly created OU. I'm suspecting that the cluster node computer objects didn't have perms to the cluster object within that OU and that was causing the issue. I know I've seen cluster
    object issues before when moving to a new OU.
    All has started working again for the moment so I now just need to investigate what permissions I need on the new OU so that I can move the cluster object in.

  • Firewall keeps failing over when IPS fails

    Is there a way to prevent the firewall from failing over if the IPS fails, I do not have it selected as a critera but I've been having some issues with the IPS module and the firewall keeps failing over.

    Hello Matt,
    There is an enhancement request for this:
    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsm81086
    But there isn't an ETA yet. You can save the bug to get updates.
    Regards,
    Felipe
    Security Team.

  • 2012 R2 iSCSI CSV not failing over when storage NICs disabled (no redirected access)

    We have a couple of simple two node Hyper-V clusters. They are fresh installs with 2012R2 (running on Cisco UCS blades).
    They are configured with dedicated NIC for Management, 2x dedicated NICs for storage (using MPIO and NetApp DSM) and then a trunk for VM traffic with virtual adapters for CSV, Live Migration and Heartbeat. Binding orders all set and priorities.
    With storage, we have a 1GB Quorum disk and then a temporary 500GB CSV.
    All is healthy and happy, I can move VMs around, move the CSV around, fail hosts etc and all works fine.
    HOWEVER..... If I disable BOTH of the iSCSI NICs on one of the host (the host that currently owns the CSV), then all hell breaks out. I would have expected that the CSV would go into redirected mode and use the connection from the other node? The CSV disappears
    from FCM temporarily, then comes back and goes red (Offline). It doesn't even try to failover to the other node. If I manually move it over to the other node then the CSV comes straight back online.
    Watching in Disk Manager on both nodes I can see on the effected host that the volumes do not disappear once it looses the iSCSI connection. I'm pretty sure that with the iSCSI disconnected (iscsicpl showing "reconnecting" state) that those disks
    should disappear? But perhaps that is my problem here.
    Is the expected behavior or does it sound wrong? If so, any ideas?
    Also - I've noticed that in FCM, my cluster networks all go to a state of showing a red question mark over them with the exception of the management NIC. It feels like the cluster is having a fit and failing to communicate properly once I disable the iSCSI
    NICs.
    Any input greatly appreciated!

    I think I might have found the answer......
    The AD objects for the clusters had been moved from the Computers OU into a newly created OU. I'm suspecting that the cluster node computer objects didn't have perms to the cluster object within that OU and that was causing the issue. I know I've seen cluster
    object issues before when moving to a new OU.
    All has started working again for the moment so I now just need to investigate what permissions I need on the new OU so that I can move the cluster object in.

  • Failing over Oracle connections in a pool

              Hi,
              This message is probably a bit out of context (I've already posted
              it to the JDBC group). I post here as well, since I guess it's
              the place where people have the most experience with clustering
              and HA. Original posting below...
              Could you please tell me whether, yes or no, connections to an
              Oracle database should fail over (when the database fails over
              to another machine)? I use Oracle's Transparent Application Failover
              (configured via Net8) with Weblogic 6 on Linux and Oracle 8.1.7
              on Solaris/SPARC.
              If this doesn't work in my configuration, is there any configuration
              where it should work? (Another version of Oracle, WLS, OS, ...)
              When I try TAF using the PetStore application, I get exceptions
              related to no being connected to the database.
              If TAF doesn't work with WebLogic, is there a way to work around
              the problem? Can I catch these exceptions and renew the connections
              in the pool? Or, what else is possible...?
              I'd appreciate any help. I'd like to demonstrate our HA product
              with WLS. If it doesn't work, I'll turn to iPlanet instead. Pity,
              I really like WLS!
              Thanks in advance for any help or advice!
              Regards, Frank Olsen
              

              Hi (Frank ;-)
              I got carried away a bit too fast...
              Some more testing shows that it doesn't work in all cases:
              - when someone is trying to check out the shopping cart when the
              the database fails (and fails over), I get exceptions once the
              databses has restarted on the backup node
              - the exceptions are related to some transactions being rolled
              back and Oracle stating that it couldn't safely replay the transactions
              - browsing the categories still works fine
              - all access to the shopping cart and sign-in/sign-out causes time-outs
              and exceptions
              Any ideas what may cause this problem, please?
              Regards,
              Frank Olsen
              "Frank Olsen" <[email protected]> wrote:
              >
              >Hi,
              >
              >TAF worked with WLS 6 on NT with the Oracle 8.1.7 client!
              >
              >Has anyone tested it on Solaris/SPARC?
              >
              >Regards,
              >Frank Olsen
              >
              >
              >
              >"Frank Olsen" <[email protected]> wrote:
              >>
              >>Hi,
              >>
              >>Most of my question below is still valid (in particular
              >>concerning
              >>whether TAF should work with WLS on some or all platforms
              >>and
              >>versions).
              >>
              >>However, when I tested TAF with the Oracle client (sqlplus)
              >>there
              >>also was no failover of the (one) connection. I then
              >checked
              >>the
              >>`V$SESSION' view and the colums related to failover showed
              >>that
              >>TAF was not correctly configured. Strange because I copied
              >>the
              >>`tnsnames.ora' parameters from the Oracle documentation
              >>for TAF.
              >>
              >>Has anyone managed to configure and use TAF, with or
              >without
              >>WLS?!
              >>
              >>Thanks in advance for your help!
              >>
              >>Regards,
              >>Frank Olsen
              >>
              >>
              >>"Frank Olsen" <[email protected]> wrote:
              >>>
              >>>Hi,
              >>>
              >>>This message is probably a bit out of context (I've
              >already
              >>>posted
              >>>it to the JDBC group). I post here as well, since I
              >guess
              >>>it's
              >>>the place where people have the most experience with
              >>clustering
              >>>and HA. Original posting below...
              >>>
              >>>----
              >>>
              >>>Could you please tell me whether, yes or no, connections
              >>>to an
              >>>Oracle database should fail over (when the database
              >fails
              >>>over
              >>>to another machine)? I use Oracle's Transparent Application
              >>>Failover
              >>>(configured via Net8) with Weblogic 6 on Linux and Oracle
              >>>8.1.7
              >>>on Solaris/SPARC.
              >>>
              >>>If this doesn't work in my configuration, is there any
              >>>configuration
              >>>where it should work? (Another version of Oracle,
              >WLS,
              >>>OS, ...)
              >>>
              >>>
              >>>When I try TAF using the PetStore application, I get
              >>exceptions
              >>>related to no being connected to the database.
              >>>
              >>>If TAF doesn't work with WebLogic, is there a way to
              >>work
              >>>around
              >>>the problem? Can I catch these exceptions and renew
              >the
              >>>connections
              >>>in the pool? Or, what else is possible...?
              >>>
              >>>I'd appreciate any help. I'd like to demonstrate our
              >>HA
              >>>product
              >>>with WLS. If it doesn't work, I'll turn to iPlanet instead.
              >>>Pity,
              >>>I really like WLS!
              >>>
              >>>Thanks in advance for any help or advice!
              >>>
              >>>Regards, Frank Olsen
              >>>
              >>
              >
              

  • How to do I prevent fail over

    This is actually a two part question.
    First - I need to upgrade a wireless controller 4402 and I need update boot loader and software. Can I do both at the same time?
    Second - How can I prevent the APS from failing over when I reboot with out having to go into each AP and take off secondary controller.

    Specific to the AP failover. Why dont you deploy AP FALLBACK? When a controller falls offline for
    any reason the APs join other controllers. HOWEVER when the controller comes online they will fallback to the controllers
    you want with NO intervention from you.
    fyi
    NoteWhen an access point’s primary controller comes back online, the access point disassociates from the backup controller and reconnects to its primary controller. The access point falls back to its primary controller and not to any secondary controller for which it is configured. For example, if an access point is configured with primary, secondary, and tertiary controllers, it fails over to the tertiary controller when the primary and secondary controllers become unresponsive and waits for the primary controller to come back online so that it can fall back to the primary controller. The access point does not fall back from the tertiary controller to the secondary controller if the secondary controller comes back online; it stays connected to the tertiary controller until the primary controller comes back up.

  • Forms load balancing and fail-over

    Using cisco context switches instead of metric server/metric client. Having trouble making forms fail-over when a 9ias server fails. Has anybody done this?
    If so, how?

    Using cisco context switches instead of metric server/metric client. Having trouble making forms fail-over when a 9ias server fails. Has anybody done this?
    If so, how?

  • Failover cluster server - File Server role is clustered - Shadow copies do not seem to travel to other node when failing over

    Hi,
    New to 2012 and implementing a clustered environment for our File Services role.  Have got to a point where I have successfully configured the Shadow copy settings.
    Have a large (15tb) disk.  S:
    Have a VSS drive (volume shadow copy drive) V:
    Have successfully configured through Windows Explorer the Shadow copy settings.
    Created dependencies in Failcover Cluster Server console whereby S: depends on V:
    However, when I failover the resource and browse the Client Access Point share there are no entries under the "Previous Versions" tab. 
    When I visit the S: drive in windows explorer and open the Shadow copy dialogue box, there are entries showing the times and dates of the shadow copies ran when on the original node.  So the disk knows about the shadow copies that were ran on the
    original node but the "previous versions" tab has no entries to display.
    This is in a 2012 server (NOT R2 version).
    Can anyone explain what might be the reason?  Do I have an "issue" or is this by design?
    All help apprecieated!
    Kathy
    Kathleen Hayhurst Senior IT Support Analyst

    Hi,
    Please first check the requirements in following article:
    Using Shadow Copies of Shared Folders in a server cluster
    http://technet.microsoft.com/en-us/library/cc779378(v=ws.10).aspx
    Cluster-managed shadow copies can only be created in a single quorum device cluster on a disk with a Physical Disk resource. In a single node cluster or majority node set cluster without a shared cluster disk, shadow copies can only be created and managed
    locally.
    You cannot enable Shadow Copies of Shared Folders for the quorum resource, although you can enable Shadow Copies of Shared Folders for a File Share resource.
    The recurring scheduled task that generates volume shadow copies must run on the same node that currently owns the storage volume.
    The cluster resource that manages the scheduled task must be able to fail over with the Physical Disk resource that manages the storage volume.
    If you have any feedback on our support, please send to [email protected]

  • How to 'fail-over' CSS11503-AC when ALL 5 Reals Servers (Services) die

    Hi all,
    Could anyone out there possibly provide an idea/config, of how it is possible to'fail-over' a CSS11503 set-up in Active/Standby mode with "ASR" enabled when:-
    - ALL your real servers(Services) for a particular VIP 'die'/OR nic is faulty.
    - So NOT just 1 of the real servers, but when ALL 5 are not reachable, I need to 'failover'
    My initial thought are to use the "critical reporter" or "critical service" to report back to the 'active' CSS.
    Anyone who has done this scenario before , please advise..
    thanks

    Thanks very much Syed fo rthis.I was thiking that no-one could answer this query.
    After a little tsting, I set the following config in the lab and it works but is different to yours. I cannot seem to configure the servive as "type local". When I input 'type ?; I get options such as nci-direct-return, nci-info-only, proxy-cache, redirect etc...etc..NO 'local'...!!
    Please advise..Thanks in advance
    ************************* INTERFACE ************************* interface 1/1 bridge vlan 800 phy 1Gbits-FD-no-pause
    nterface 1/2
    phy 1Gbits-FD-no-pause
    bridge vlan 20
    nterface Ethernet-Mgmt
    description "Management Interface"
    nterface 2/1
    description "1st ASR Link"
    isc-port-one
    nterface 2/3
    description "2nd ASR Link"
    isc-port-two
    ************************** CIRCUIT ************************** circuit VLAN800
    description "FE_CORE"
    ip address 192.168.83.249 255.255.255.0
    ip virtual-router 1 priority 110
    ip redundant-vip 1 192.168.83.148
    ip redundant-vip 1 192.168.83.158
    ip critical-service 1 DTSFE01
    ip critical-service 1 DTSFE02
    ip critical-service 1 DTSFE03
    ip critical-service 1 DTSFE04
    ip critical-service 1 DTSFE05
    ip critical-reporter 1 Physical_if_DWN
    ip critical-reporter 1 r1
    ircuit VLAN20
    description "LBAL"
    ip address 192.168.20.1 255.255.255.0
    ip virtual-router 2 priority 110
    ip redundant-interface 2 192.168.20.3
    ip critical-service 2 DTSFE01
    ip critical-service 2 DTSFE02
    ip critical-service 2 DTSFE03
    ip critical-service 2 DTSFE04
    ip critical-service 2 DTSFE05
    ip critical-reporter 2 Physical_if_DWN
    ip critical-reporter 2 r1
    ************************** REPORTER **************************
    reporter Physical_if_DWN
    type critical-phy-all-up
    phy 1/1
    phy 1/2
    active
    reporter r1
    type vrid-peering
    vrid 192.168.83.249 1
    vrid 192.168.20.1 2
    active
    ************************** SERVICE **************************
    service FE01
    ip address 192.168.20.183
    keepalive frequency 2
    keepalive retryperiod 2
    keepalive maxfailure 2
    redundant-index 4
    service FE02
    ip address 192.168.20.184
    keepalive frequency 2
    keepalive retryperiod 2
    keepalive maxfailure 2
    redundant-index 5
    service FE03
    ip address 192.168.20.185
    keepalive frequency 2
    keepalive retryperiod 2
    keepalive maxfailure 2
    redundant-index 6
    service FE04
    ip address 192.168.20.186
    keepalive frequency 2
    keepalive retryperiod 2
    keepalive maxfailure 2
    redundant-index 7
    service NWFE02
    ip address 192.168.20.204
    keepalive frequency 2
    keepalive retryperiod 2
    keepalive maxfailure 2
    redundant-index 10
    active
    !*************************** OWNER *************************** owner SERVICES
    content DTS_192.168.83.148_443
    add service DTSFE01
    add service DTSFE02
    add service DTSFE03
    add service DTSFE04
    add service DTSFE05
    vip address 192.168.83.148
    port 443
    protocol tcp
    advanced-balance sticky-srcip
    redundant-index 1
    sticky-inact-timeout 5
    owner NW_SERVICES
    content NWCS_192.168.83.158_443
    add service NWCSFE01
    add service NWCSFE02
    vip address 192.168.83.158
    protocol tcp
    port 443
    sticky-inact-timeout 5
    redundant-index 2
    advanced-balance sticky-srcip
    active

  • TS1424 Secure Link to iTunes Store failed, and when I click on Help, the help box is blank.  I have a 25Mbit up and down. 64 bit PC running window 7 home premium

    Secure Link to iTunes Store Failed.  When I click on the help button to the right, and the new help window pops up, it is blank with zero infomation on how to correct the "Secure Link to iTunes Store"

    A few things may resulted in this. Did it just happen over night?
    Can you make sure your date, and time including time zone settings are correct?
    What are you using to correct from?

  • Is Replica aware stubs are in infinite loop when fail over????

              Hi
              Any help on this Appreciated
              See in this senario, where there is four weblogic instance runs in the cluster
              and a replica aware stub(stateless bean with idempodent methods) finds a particular
              method fails on a server and it redircets the request to another one server but the
              same method fails on all the server, then what is goin to happen?? is it going to
              throw some exception or gonna be in a loop to keep on redirecting the method request
              to all servers in Round???
              Regards
              Aruna
              

              Aruna,
              A stateless session bean whose methods have been declared idempotent will automatically
              retry on another service provider in a fail-over situation. When a fail-over situation
              occurs, the stub refreshes its list of service providers. Note: Just because your
              method call fails, doesn't mean it's a fail-over situation.
              Jane
              "Aruna" <[email protected]> wrote:
              >
              >Hi
              >
              > Any help on this Appreciated
              >
              > See in this senario, where there is four weblogic instance runs in
              >the cluster
              >and a replica aware stub(stateless bean with idempodent methods) finds a
              >particular
              >method fails on a server and it redircets the request to another one server
              >but the
              >same method fails on all the server, then what is goin to happen?? is it
              >going to
              >throw some exception or gonna be in a loop to keep on redirecting the method
              >request
              >to all servers in Round???
              >
              >
              >Regards
              >Aruna
              

  • SQL 2005 cluster rejects SQL logins when in failed over state

    When SQL 2005 SP4 on Windows 2003 server cluster is failed over from Server_A to Server_B, it rejects all SQL Server logins. domain logins are OK. The message is "user is not associated with a trusted server connection", then the IP of the
    client. This is error 18452. Anyone know how to fix this? They should work fine from both servers. We think this started just after installing SP4.
    DaveK

    Hello,
    The connection string is good, you're definitely using sql auth.
    LoginMode on Server_B is REG_DWORD 0x00000001 (1) LoginMode on Server_A is REG_DWORD 0x00000002 (2) Looks like you are on to something. I will schedule another test failover. I assume a 2 is mixed mode? If so, why would SQL allow two different modes
    on each side of a cluster?
    You definitely have a registry replication issue, or at the very least a registry that isn't in sync with the cluster. This could happen for various reasons, none of which we'll probably find out about now, but never the less...
    A good test would be to set it to windows only on Node A, wait a minute and then set it to Windows Auth and see if that replicates the registry setting across nodes correctly - this is actually the windows level and doesn't have anything to do with SQL Server.
    SQL Server reads this value from the registry and it is not stored inside any databases (read, nothing stored in the master database) as such it's a per machine setting. Since it's not set correctly on Node B, when SQL server starts up it correctly reads
    that registry key and acts on it as it should. The culprit isn't SQL Server, it's Windows Clustering.
    Hopefully this makes a little more sense now. You can actually just edit the registry setting to match Node A and fail over to B, everything should work correctly. It doesn't help you with a root cause analysis which definitely needs to be done as who knows
    what else may not be correctly in sync.
    Sean Gallardy | Blog |
    Twitter

  • Deployment of Web Application when the managed Server is down .....

    Part of our installation, we want to deploy our web application on to a managed server.
    So, we use the JMX API calls to deploy the web application. But, at the time of this deployment the managed server is not brought up. So, our expectation was that when the managed server is brought up later, it will automatically STAGE the web application from Admin Server and then, deploy it in the managed server.
    But, what is happending is that the web application is not being deployed to the managed server (even though the web application is configured to be deployed in the specified managed server in the config.xml and it is set as the default application of the managed server application).
    We are using WebLogic 7.0 SP2 on RedHat Linux 7.2.
    Can anyone help to deploy web application on to a managed server when the managed server is down ?
    Thanks,
    Selva-
    [att1.html]

    This is currently being fixed in 7.0 line, contact [email protected] and reference
    CR110687
    Cheers
    mbg
    "Selvamohan Neethiraj" <[email protected]> wrote in message news:[email protected]..
    Part of our installation, we want to deploy our web application on to a managed server.
    So, we use the JMX API calls to deploy the web application. But, at the time of this deployment the managed server is not brought up. So, our expectation was that when the managed server is brought up later, it will automatically STAGE the web application from Admin Server and then, deploy it in the managed server.
    But, what is happending is that the web application is not being deployed to the managed server (even though the web application is configured to be deployed in the specified managed server in the config.xml and it is set as the default application of the managed server application).
    We are using WebLogic 7.0 SP2 on RedHat Linux 7.2.
    Can anyone help to deploy web application on to a managed server when the managed server is down ?
    Thanks,
    Selva-
    [att1.html]

Maybe you are looking for

  • Recovery error....

    Hi sir, I have encountered a very serious problem in the recovery. I have been sent a mail from a friend who is having a DSS system without a backup and in NoARch mode. I agree that its not at all a right thing but that’s what is in there. 3 days pri

  • Is it possible to load an html file on a frame

    Is it possible to make a java applet refresh(load) an html file which is loaded on different frame in the same browser window. In other words a web page is divided into 2 frames. One has the applet and the other is refreshed when the applet request i

  • File T3 in Weblogic 6.0

    Hi, I am trying to use the File T3 service in weblogic 6.0 and have created a file system named 'myFileSystem' and assigned the path './config/mydomain/logs'. This file system is used by a class (works fine in weblogic 5.1). I am including the code s

  • Anyone know how to get current time using Java?

    Hi, do anyone know how to use system.currentTimeMillis() to get the current time? I know that system.currentTimeMillis() get the time between current time and midnight, January 1, 1970 UTC. but how to use it to get the current time format? Thank you

  • Adobe Flash Player Download - Partial success.

    Followed instructions on Adobe Site for Mac_ Successful up to clicking "open" for Installer_ Next input window gave unrecognized name_ Asked me to input 'password' for name given_ Did not accept any of my passwords enterred...