Ftp_connect with specific port

Hi All,
Any help using FTP_CONNECT function, Doing connection to ftp server with specifi port (not port 21) will be greatly appreciated. Any one?
thanks
supriatna

Hi Supriatna,
sample code may be useful to you:
FTP Connect
  CALL FUNCTION 'FTP_CONNECT'
    EXPORTING
      USER                   = P_USER
      PASSWORD               = P_PWD
      ACCOUNT                =
      HOST                   = P_HOST
      RFC_DESTINATION        = 'SAPFTPA'
      GATEWAY_USER           =
      GATEWAY_PASSWORD       =
      GATEWAY_HOST           =
    IMPORTING
      HANDLE                 = HDL
    EXCEPTIONS
      NOT_CONNECTED          = 1
      OTHERS                 = 2.
If sy-subrc = 0.
        CALL FUNCTION 'FTP_COMMAND'
             EXPORTING
                  HANDLE        = HDL
                  COMMAND       = V_PATH
             TABLES
                  DATA          = IT_RESULT
             EXCEPTIONS
                  TCPIP_ERROR   = 1
                  COMMAND_ERROR = 2
                  DATA_ERROR    = 3
                  OTHERS        = 4.
Endif.
Lanka

Similar Messages

  • Enabling BW reports for a specific port

    Hi All,
    How to enable BW reports for a specific prot?.
    Our requirement is Report should run FIRST, if I type the URL manually with the port we configure in SICF.
    Thanks in Advance.
    Regards,
    Ravi Chelikani.

    Ravi,
    the port is configured per protocol (HTTP, HTTPS, etc) in transaction SMICM.
    Regards,
    Marc
    SAP NetWeaver RIG, US BI

  • WRT54G: How do I limit access to specific ports, only to local IP's

    Using a WRT54G with Windows XP, and I've setup a web server that I'm still testing. Until I understand the security better, I want to limit access from outside IP's to the port that it's running on, but NOT limit access from the outside to services running on other ports. Is there a way to block a range of IP addresses (or conversely, only permit access for a limited range of IP addresses) to a specific port? So for example (assuming server's on Port 99, and IP address to the outside world is 99.99.99.99: Port 99: Blocked IP Range: 0.0.0.0-99.99.99.98, and 99.99.99.100-255.255.255.255 - OR Port 99: Allowed IP Range: 99.99.99.99 Alternatively, I would be interested to permit access to the web server port, only for certain MAC addresses. Is this pretty secure, and if so, how can this be done? I've poked around the router settings and spent a good deal of time researching this; any help would be greatly appreciated...

    Why do you want to block IP addresses:  "IP Range: 0.0.0.0-99.99.99.98, and 99.99.99.100-255.255.255.255" ?   This is everybody on the web, except your router!    If you really want to block all these people, just unplug your router from your Internet connection.  That is a block that cannot be hacked!
    Normally a server is assigned a fixed LAN IP address.  This address must be outside the DHCP server range of your router, and it cannot end in 0, 1, or 255.
    Next you forward a port (for example, 99) to the server's fixed LAN IP address.
    Data arriving at the Internet port of your WRT54G for port 99 will then be forwarded to your server.  If you have other Internet services (i.e. server B) running on port 1297, then data that arrives at the Internet port of your WRT54G for port 1297 will be directed to server B.   Assuming that you only have port 99 and port 1297 open, then any other unrequested data (for any other port) that arrives at the Internet port of your WRT54G will simply be ignored (and thereby blocked).    If you connect another computer to a LAN port of the WRT54G, connect to the Internet, and request data, then when that data arrives at the Internet port of the WRT54G, it will be allowed to pass, and it will be routed to your computer.
    In summary, by default, all router ports are closed.  The only way to get data through the router is either to open a port (using port forwarding, or alternatively, the UPnP function), or for someone (or some program) on the LAN to request data from the web.
    The router cannot limit the use of a port by MAC address.    When you open a port on your router, you are opening your server to invasion from anyone on the Internet.  So, your server must be setup to protect itself.   Rather than limiting server use by MAC address (which can be faked), your server should be setup to require a user name and password. 

  • Network ACL for two specific ports

    As far as I can tell there is no way to set Network ACLs such that only two specific ports are available. I'm using Oracle 11gR2.
    I'd like a HTTP port and an SMTP port open for the local loopback address. These are ports 7777 and 25. It's my understanding that you can have only one ACL per host. While it seems you can create more, any additional ACL's for the same host don't always work as expected. So does anyone have any advice as how I can do this? I'd rather not have every port between 7777 and 25 available but this is what I currently have...
    DBMS_NETWORK_ACL_ADMIN.ASSIGN_ACL(
    acl => 'local_loopback.xml'
    , host => '127.0.0.1'
    , lower_port => 25
    , upper_port => 7777
    );

    Billy  Verreynne  wrote:
    As far as I can tell there is no way to set Network ACLs such that only two specific ports are available. I'm using Oracle 11gR2.>Not so in my experience. An ACL can be for a specific target, but contain multiple ports for that target.
    E.g. I assign ports 80, 7777, 8080, and a few others, in a single web-acl.xml, to a network target (host or domain).
    Read the usage notes in Oracle® Database PL/SQL Packages and Types Reference.>Thanks I'll try that. I think we had problems in the past with separate ACL's containing rules for the same host, the response we got back from support was not to do that. This way didn't occur to me.

  • How do I ping a specific port (from a specific por...

    Does anyone know of any software that will allow me to measure the bandwidth/throughput/travel time/etc of packets from a specific port to a specific port on another network? Ping gives the travel time, but doesn't allow specified ports. Iperf allows you to specify the port you connect to, but not the port you connect from. Wireshark doesn't send packets, though I think it does record traffic by port. Pathping is the same as ping in that it doesn't "do" ports & neither does tracert (and ping/pathping/tracert traffic may well be blocked where normal traffic isn't). So, does anyone have any ideas (or is friendly with their comapny's network admin)?

    Llama8
    did a quick google and came up with this:-
    http://www.elifulkerson.com/projects/tcping.php
    seems to do the trick but not sure you can specify the source port on the pinging machine
    its a start though
    Never tried this so caveat emptor
    banz

  • Show mac command...to tell me the MAC adress of a specific port - Linksys SGE 2010

    Hello together,
    we are using a Linksys SGE 2010 in our small business. I would like to know which devices (MAC-Address) is behind a specific port. Does the switch have this function? I can't type commands, because the SSH or telnet interface is a menu (see screenshot). Because I want to document which PC is on which port...therefore  I need the MAC behind every specific port.
    Thank You in advance.
    Kind regards,
    Manuel Zeiler

    Manuel
    Try this forum where they have experience with your switches -
    https://supportforums.cisco.com/community/5976/small-business-switches
    you should be able to move this post there.
    Jon

  • No weblogic server was found running on the specific port.

    Hello,
    While trying to target/connect to the weblogic server from Grid control 10.2.0.5,I'm getting the below error.
    1.Added the connection filter in the weblogic console to allow connections only from the grid control's host
    2.But while trying to connect from the grid control to the weblogic server for monitoring,its failed with the below exception,
    "No weblogic server was found running on the specific port.if the administration port is SSL enabled,specify the keystore and try again"
    3.However,I can able to connect to the weblogic if I dont give any connection filter arguments.
    "No weblogic server was found running on the specific port.if the administration port is SSL enabled,specify the keystore and try again"
    Appreciate for any pointers/help to resolve the issue.

    Hi,
    Next thing to do is to make sure that the parent paths issue is out of the way:
    Create a new asp file at the location: d:\inetpub\wwwroot\SAP NetWeaver Visual Composer\server\bin\test.asp
    with the following content:
    <%@ Language="JScript" %>
    <!-- #include file="..~server.ini" -->
    <%
       Response.write("Success");
    %>
    If you do not see the "Success" string printed out when you call your asp in the following way:
    http://server:port/VCServer/server/bin/test.asp
    then you still don't have this parent paths configured correctly.
    If you do then you should open an OSS message and let dev support have a look at your installation.
    Regards,
    Yaniv.

  • Password Protect a specific port

    I'm familiar with pw protecting a page or directory, but can I do it to a specific port? Say I've got a page at www.myawesomeserver.com:2920, how can I put a pw on that when brought up on a browser?
    Using Server X.3.9

    DOH!! I r teh noob. Heh.. ya, easy. Thanks!
    That all works fine, but found a little glitch. I'm using a 3rd party app to generate a "page" via the port of my choosing, say 2920. I mention "page" like that since physical html is not being generated, the app is simply using that port to display data from it's database. When I use a realm and point to that port, it's being overridden by the apps port privileges, if I change the port on the app or just quit the app, then the realm works fine. Got that?
    This is probably an issue with my app and NOT the server. Unless there is a way around this.

  • Issue with cisco ONS 15310. Slot with Ethernet ports, designed for bridging.

    Hi, guys. I’ve got an issue with cisco ONS 15310 sdh optical network. I’ve got a special slot with Ethernet ports, designed for bridging. Assume, we’ve got to multiplexers, named A and B with ports A0 and B0 respectively. The ios console of these slots says, the configuration is as follows:
    no ip address set on these ports
    Ports are administratively up
    Auto mdix
    Bridge groups are the same on these ports.
    Dot1q tunnel.
    I’m trying to monitor a device with an ip-address connected to port B0. It answers ping if I connect the notebook directly to a device. But if I connect the notebook to port A0 and ping the device pluged in port B0 through the optical network, it doesn’t answer. I tried connections with straight and cross cable.
    Guys, who set the network said, it should work as a point to point bridge with no extra configuration. But it doesn’t. I used wireshark sniffer to lookup what’s happening on port A0. All I see is cdp-s from port A0 and self-announcements of the notebook.
    Any suggestions? Thank you in advance.

    B
    Building configuration...
    Current configuration : 3712 bytes
    ! Last configuration change at
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname B
    boot-start-marker
    boot-end-marker
    enable password -
    clock timezone -
    ip subnet-zero
    no ip domain-lookup
    no mpls traffic-eng auto-bw timers frequency 0
    bridge 100 protocol ieee
    bridge 140 protocol ieee
    bridge 141 protocol ieee
    bridge 142 protocol ieee
    bridge 143 protocol ieee
    bridge 144 protocol ieee
    interface Loopback0
    ip address 192.x.0.x 255.255.255.255
    interface FastEthernet0
    description -
    no ip address
    mode dot1q-tunnel
    bridge-group 140
    bridge-group 140 spanning-disabled
    interface FastEthernet1
    description --- B0 ---
    no ip address
    mode dot1q-tunnel
    bridge-group 141
    bridge-group 141 spanning-disabled
    interface FastEthernet2
    description -
    no ip address
    mode dot1q-tunnel
    bridge-group 142
    bridge-group 142 spanning-disabled
    interface FastEthernet3
    description -
    no ip address
    mode dot1q-tunnel
    bridge-group 143
    bridge-group 143 spanning-disabled
    interface FastEthernet4
    description -
    no ip address
    mode dot1q-tunnel
    bridge-group 144
    bridge-group 144 spanning-disabled
    interface FastEthernet5
    no ip address
    shutdown
    interface FastEthernet6
    no ip address
    shutdown
    interface FastEthernet7
    description -
    no ip address
    shutdown
    mode dot1q-tunnel
    bridge-group 100
    bridge-group 100 spanning-disabled
    interface POS0
    description -
    no ip address
    crc 32
    interface POS0.1
    encapsulation dot1Q 141
    no snmp trap link-status
    bridge-group 141
    interface POS0.2
    encapsulation dot1Q 142
    no snmp trap link-status
    bridge-group 142
    interface POS0.3
    encapsulation dot1Q 143
    no snmp trap link-status
    bridge-group 143
    interface POS0.4
    encapsulation dot1Q 144
    no snmp trap link-status
    bridge-group 144
    interface POS0.5
    description -
    encapsulation dot1Q 140
    no snmp trap link-status
    bridge-group 140
    interface POS1
    no ip address
    crc 32
    interface POS1.1
    encapsulation dot1Q 100
    no snmp trap link-status
    bridge-group 100
    router ospf 100
    log-adjacency-changes
    network 192.x.0.x 0.0.0.0 area 0
    ip default-gateway [x.x.x.x]
    ip classless
    no ip http server
    snmp-server community public RO
    snmp-server ifindex persist
    snmp-server trap link ietf
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps tty
    snmp-server enable traps config
    snmp-server enable traps cpu threshold
    snmp-server enable traps entity
    snmp-server enable traps syslog
    snmp-server enable traps hsrp
    snmp-server enable traps config-copy
    snmp-server enable traps bridge
    snmp-server enable traps ospf state-change
    snmp-server enable traps ospf errors
    snmp-server enable traps ospf retransmit
    snmp-server enable traps ospf lsa
    snmp-server enable traps ospf cisco-specific state-change
    snmp-server enable traps ospf cisco-specific errors
    snmp-server enable traps ospf cisco-specific retransmit
    snmp-server enable traps ospf cisco-specific lsa
    snmp-server enable traps bgp
    snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
    snmp-server enable traps ipmulticast
    snmp-server enable traps rtr
    snmp-server enable traps mpls traffic-eng
    snmp-server enable traps mpls ldp
    snmp-server enable traps rsvp
    snmp-server enable traps l2tun session
    snmp-server enable traps mpls vpn
    snmp-server host x.x.x.x public
    control-plane
    line con 0
    line vty 0 4
    password -
    logging synchronous level 4
    login
    end

  • Help with Essbase Ports

    Does anyone knows if you can set a specific port for each APP.
    Before we had Essbase 5.0.2 and we have upgraded to Essbase 9.3.1.
    Several users connect to different DB from the internet. We had configured 3 ports for access in the firewall, 33005, 33010 and 33015.
    Each port was used to access a different DB,
    DB A -> 33005
    DB B -> 33010
    DB C -> 33015
    The problem that we have now is that every DB we start uses 2 ports, so when we start the 3 DB, the first one uses 33005 and 33010, the second uses 33015 and 33020 so the third can not be accessed through the internet.
    I have try with PORTINC, but the main problem is that the open ports ends with 5, so I can not make the 3 DB visible.
    So what I would like to know if you can assign an specific port to a specific DB.
    I want to avoid any modification to the firewall, because that would mean I have to make a request to another area and that takes time.
    Thanks in advance.

    I don't believe the ports can be isolated to specific databases (unless the databases are isolated to individual servers, that is -- and you don't want that).
    In version 5, the ports did use increments of 5. This is no longer the case though, since version 7, the default is now 1 (which makes a lot more sense now). You should open up a wide range for "other" reasons (mostly to avoid the issue with "unable to send/unable to receive" due to all available ports being in use). You should look at the technical reference for the PORTINC, SERVERPORTBEGIN, and SERVERPORTEND entries and match the firewall to the settings applied to the server.
    Basically, the need to keep the number of ports to a minimum should be evaluated against the need to provide sufficient access. If this is a firewall issue that IT is restricting access to, you should consider VPN access security as an alternative to public exposure to the essbase server.

  • How to add specific ports to OS X Lion firewall

    I need to add specific ports/port ranges to the OS X Lion clients' firewalls, any ideas?
    OS X Lion firewall settings only allow adding applications.  There is no "LDAP" application, it's built into the Network preferences settings.  The LDAP server is an OS X Lion Server running Open Directory.

    iosw wrote:
    I guess the flexibility in the regular Lion clients with ports is not possible.  It's only possible with OS X Lion Server, fair enough.
    No, you can configure both the client and server as much as you want. The only issue is that most people just don't understand what a firewall does (they think it is the same as anti-virus) so neither Apple nor I will bother explaining all the nitty-gritty details right off the bat.
    The client version of Lion doesn't need to be providing any services at all. Hence, there is really no need to run the firewall. If you are doing something fancy that the application firewall doesn't quite support, then you might want to run the real ipfw firewall instead. It is also installed on the client, but isn't a tool for the great unwashed.
    Personally, I find the fancy stuff pretty interesting, but I don't think you are doing that.
    We're trying to configure SSL within the Lion clients and didn't know if there was an incoming requirement.  There's a bug (logged even by Apple) when Lion client's attempt to bind to an SSL enabled Open Directory server.  So the firewall preferences wasn't the reason for this failure.  We're resorting to non-SSL binding until Apple fixes the problem, although we running on a private network and can get away with non-SSL for the time being.
    You might want to ask about this in the Server forums. This could be a situation where Apple isn't going to bother explaining the details on how to fix it because it would just confuse most people and they may already have it fixed in-house. It has already been discussed and some people say they have fixes. See the details in this thread.

  • WRT610N V2 blocks traffic on specific port after large transfer

    Goodday,
    It came to my attention that when i transfer a large amount of files to the USB storage device, which can be attached to the router, it closes the port and can't be reopened anymore.
    To solve this problem a power cycle/reboot is needed. 
    I also had a WRT610 V1 that didnt have this problem.
    It looks a bit like there is a counter which counts the amount of data transfered thru a socket (on a specific port) and if that exceeds a certain amount it will block that port.
    I'm wondering if more people are experiencing this.
    By the way: this is the second device the retailer gave me. First one had the exact same issue. This also happend to port 80 (internet) as well.
    Thanks in advance.
    Kind regards,
    Xionax Lomax
    Message Edited by Xionax on 01-19-2010 10:40 AM

    Have you tried with different computer..?
    Try with the different computer and check..
    Try to reduce the Card speed of NIC on the computer to 10 Mbps half duplex and check if that make any difference.

  • SG300 - ip address restricted to specific port??

    I have just set up an SG300 with protected ports so that different ports can not see the traffic on other ports. Now I am being asked to restrict specific ports to using only specific ip addresses. Is this possible with this switch?
    Each port will need to allow several (5-6) addresses.
    Thanks,
    TonyT

    ACL might work. Here are more details:
    We provide off-site mirrored storage for about a dozen customers. Each one provides their own firewall and vpn equiptment. Each customer has use of one protected port on the SG300 connected to their equiptment.
    We have a class-C IP range and we tell each customer what ip addresses they can use. For example, Joe can use .8-.15, Bob can use .16-.23, etc.
    We want to protect Joe should Bob fat-finger an address and ends up using .9 (intending .19)  while Joe is already using .9. We want only Bob to get errors and not Joe.
    Can it be done on a SG300?
    Tx,
    TonyT

  • Cisco WLC2125 Reporting Traps to a specific port

    Hi all,
    I am currently looking into reporting options for my Cisco WLC2125. From what I can see, I have two options, SNMP or Syslog however I would like to assign either Syslog or SNMP traffic via a specific port on the controller.
    The reason is because i want to keep this traffic seperate to my wireless network.
    My knowledge of controllers (and syslog and SNMP for that matter) but I can enter IP addresses for the servers however i cannot see how to assign this traffic to a specific port.
    Is this possible? If so how?
    Many Thanks,
    -c

    No, its not possible with a 2100.  Best practices say you should only have one connection from a 2100 controller to the network, so all traffic to the network would go out that port.
    https://supportforums.cisco.com/docs/DOC-11760

  • How do i configure telnet service to use a specific port number

    How do I configure a specific port number to the telnet service other than the default port number.  I opened /System/Library/LaunchDaemon/telnet.plist with XCode but it won't let me modify the port number.  Is there another place / item that I need to go to?

    Telnet is obsolete and insecure. Use ssh instead.

Maybe you are looking for

  • How do you set the duration of images before importing into a timeline

    Is there a way to do a batch import of images where once I place them into a video group I can set the duration of each image automatically by detereming the overall timelime lenght as opposed to manually setting the duration of each image?

  • RE: Is tempo change possible with imported song from i-Tunes

    I have an AAC Audio file Which is an i-Tunes Data Base File . I produced the song in logic as a WAV format File . Imported back into Logic ,( with no backup uncompressed copy of the File made , prior to putting it into i-Tunes).The File is now a WAV

  • Change password in Workspace

    Hi, I launched the preferences window from the File menu to change the password for a user. The fields in the authentication tab are greyed out with the following message: "Contact your administrator to have this feature enabled for use" This is even

  • Using dynamic values in the IN clause

    hey guys , is it possible to use dynamic values for comparing in the IN clause while writting query in views, in adf bc .

  • Hellllllllp please... Problems with syncing photos

    Hi all - when I try to sync new photos onto my iphone 3g it removes all the photos I currently have on. Why is this happening and what can I do to stop it? Have looked everywhere for hints or tips & can't find a thing. PS - its also doing it to my mu