Help accessing field inside class

Hello,
I got a problem when trying to access my textfields in my field class, here is what I'm doing:
Fields.class
public class Fields extends JFrame {
   public Fields() {}
   public Component emploField() {
   JTextField f_Name;
   JPanel f_Panel, main_Panel;
   f_Panel.setLayout( new GridLayout(8, 2 );
   main_Panel.setLayout( new GridLayout( 2, 1 ) );
   f_Name = new JTextField(20);
   f_Panel.add(f_Name);
   main_Panel.add( f_Panel );
   return main_Panel;
}my main class
displayGUI.class
public class DisplayGui extends JFrame {
  protected Fields fild;
  protected JPanel panel;
  public DisplayGui() {
   fild = new Fields();
   panel = new JPanel();
   panel.add( field.emploField() );
   add(panel);
   setSize(300, 300 );
   show();
}It's working perfect to display my fields, but if i try
fild.emploField().f_Name.setText("Type Your Name Here");
//In my DisplayGui classI got a error
Cannot Resolve Symbol
Variable f_Name
java.awt.Component
fild.emploField().f_Name.setText("Type your name here");
^
What I'm doing wrong?
Thank You

no, that wont work, and if it did the newly created component will not be displayed. you shoud instantiate an EmployeeField object with the traits you like, then you will be able to tweek it.
class EmployeeField extends JPanel{
   public JTextArea textArea
   public EmployeeField(){
      // create and add whatever you want
      textArea = new JTextArea("area");
      this.add(textArea);
}then in your main
empField = new EmpField();
and later
empField.textArea.setTet("newText");

Similar Messages

  • Help accessing methods in classes load with forName()

    Hi all,
    I am dynamically loading classes at runtime by using Class.forName() and .newInstance(). Is there any way I can access the methods of those classes after they are dynamically loaded? It doesnt seem that they are available for use.
    Any help would be appreciated.
    Ryan

    To clarify, are you asking how to invoke a method on an Object without knowing its class? In any case you should use the reflection api that are avaliable.
    Ex: cl = Class.forName(); Method[] methods = cl.getMethods(); for(int i = methods.length; i-- > 0;) System.out.println(methods[i-1].getName());
    or
    methods[i-1].invoke(cl.newInstance(), new Object[]{});

  • Field symbols inside class

    Is it possible to declare field symbols inside classes?
    Thanks in advance.
    Hema
    Moderator message: please search for information and try yourself before asking.
    Edited by: Thomas Zloch on Dec 23, 2010 10:55 AM

    Hi Hemalatha,
    We can use Field Symbols in classes.
    local field_symbols within methods are allowed.
    you can only use field-symbols within method (locally), not as direct class attribute (globally).
    U can check with this sample code.
    Sample code is given below:
    CLASS c1 DEFINITION.
    PUBLIC SECTION.
    METHODS m1 IMPORTING oref TYPE REF TO object attr TYPE string.
    ENDCLASS.
    CLASS c1 IMPLEMENTATION.
    METHOD m1.
    FIELD-SYMBOLS <attr> TYPE ANY.
    ASSIGN oref->(attr) TO <attr>.
    WRITE <attr> ...
    ENDMETHOD.
    ENDCLASS.
    I hope u got this .....

  • Simultaneously field access in a class by many threads. What pattern should

    Hi all,
    Sorry if it's a newbie question, but I didn't find the path to solve this problem in the forums, so I put this question:
    I have many threads that may run simultaneously with need to access field values in a class instance that control some counters. These threads should access these values and update them too.
    My class that manage these counters is something like this (I suppose i should be like this) :
    public class Counter {
         private int min;
         private int max;
         private int current;
         public TrataContadores(){
         public synchronized int getCurrent() {
              return current;
         public synchronized int getMax() {
              return max;
         public synchronized int getMin() {
              return min;
         public synchronized void setCurrent(int current) {
              this.current = current;
         public synchronized void setMax(int max) {
              this.max = max;
         public synchronized void setMin(int min) {
              this.min = min;
    }Well, what I don't know is how to make an instance of this class visible for all threads coming alive. I thought about make an static reference to an object of this class and all threads would look for this instance. Would it work properly ?
    What could be the best practice to implement int this case ?
    I don't know if I could be clear in my explanation. I hope so.
    Thanks.

    Thanks dubwai.
    I'll take a look at singleton implementation. Just to be clear, I'm advocating against using Singleton.
    I believe I understood what you mean about modifying
    more than one field at same time. If I need to do
    that, I would do it by calling setters methods. Even
    this way I would have problems and neither volatile
    nor sinchronized would solve it ?Not the way you have. Synchronizing the method only blocks other threads during the execution of that method. If you call two synchronized methods, each call acquires and releases the lock separately. Say you have one thread that needs to update max and current together and a second thread that needs to read current and then max.
    Thread 1 acquires the lock. Sets max.
    Thread 1 releases the lock.
    Thread 2 acquires the lock. Reads current.
    Thread 2 releases the lock.
    Thread 1 acquires the lock. Sets current.
    Thread 1 releases the lock.
    Thread 2 acquires the lock. Reads max.
    Thread 2 releases the lock.
    The solution is to hold the lock across the entire set of operations that need to occur together. It's easier to understand if you get rid of the syntactic sugar of putting synchronized on the method declaration. When you declare getMax as synchronized, it really compiles to this:
    public int getMax()
        synchronized(this) {
            return max;
    }The Object you synchronize on is essentially a key to find a lock. Don't think that you are 'synchronizing the object'. Synchronizing on an Object doesn't affect that Object. It only affects other threads that also synchronize on that exact same Object.

  • Why eclipse gives me warning if I access in inner class a parent  field ?

    I have a class
    class A{
    private Map fValues;
    A(){
    fValues= new HashMap();
    prrotected class B {
    B(){
    fValues.get("String");
    Above class is only for an example to expalin my problem.
    Inner class B wants to access fValues from class A .
    The eclipse gives me a warning
    Access to enclosing method fValues from the type A is emulated by a synthetic accessor method. Increasing its visibility will improve your performance
         I order to get rid of this warning I must make fValues public is this the only solution ?
    miro

    miro_connect wrote:
    I have a class
    class A{
    private Map fValues;
    A(){
    fValues= new HashMap();
    prrotected class B {
    B(){
    fValues.get("String");
    Above class is only for an example to expalin my problem.
    Inner class B wants to access fValues from class A .
    The eclipse gives me a warning
    Access to enclosing method fValues from the type A is emulated by a synthetic accessor method. Increasing its visibility will improve your performance
         I order to get rid of this warning I must make fValues public is this the only solution ?
    miroWhat happens if you remove the modifier? (That is uses default)

  • Anyone can Help on {suppress} [database fields] inside the [fields]

    Reason to put database fields inside the fields
    1. I put in (word and database fields) inside fields box in order to let my word display smoothly one by one.
    Problem is , i am in section report footer d, i plan to suppress {Qrev if the value is "AAA"}
    got this type of function?
    If the Qrev = "AAA" than  suppress/hide it.
    Design screen :
    We will the undersigned, hereby acknowledge my acceptance of the above quote and agreed to the rates, terms and conditions stated herein as per your reference no: {QRef}  dates
    Display screen=
    We will the undersigned, hereby acknowledge my acceptance of the above quote and agreed to the rates, terms and conditions stated herein as per your reference no: 2014    AAA dates 10 march 2009
    wanted display screen
    We will the undersigned, hereby acknowledge my acceptance of the above quote and agreed to the rates, terns and conditions stated herein as per your reference no: 2014   dates 10 march 2009

    As what u say, i try to key in a [formula fields] call Qrev
    here the code :
    if {Quotation.QRev} = "AAA" then
        {Quotation.QRev} = " "
    We will the undersigned, hereby acknowledge my acceptance of the above quote and agreed to the rates,
    terns and conditions stated herein as per your reference no: MKT-2009/05/0018 True dates 19 Jun 2009
    but the Qrev.wouldnt be go delete / as a blank value. The value will only become  true or false
    Edited by: chee85 on Sep 18, 2009 7:40 AM

  • Accessing the inner class written inside the method

    Hi all,
    Can any of you tell me how to access the inner class's method which is written inisde the outer class's method. THe code fragment is
    class Outer
    private static final int ID = 3;
    public String name;
    public void methodA( int nn )
    final int serialN = 11;
    class inner
    void showResult()
    System.out.println( "Rslt= "+ID );
    } // end class inner
    // new inner().showResult();
    } // end methodA
    class Sample
    public static void main(String a[])
    //access the showResult of Inner class??
    Thanks in advance.
    aah

    class Outer {
      private static final int ID = 3;
      public String name;
      public void methodA( int nn ) {
        final int serialN = 11;
        class inner {
          void showResult() {
            System.out.println( "Rslt= "+ID );
        } // end class inner
        new inner().showResult();
      } // end methodA
    class Sample {
      public static void main(String a[]) {
        new Outer().methodA(5);
    }

  • Internet Access from Inside to Outside ASA 5510 ver 9.1

    Hi everyone, I need help setting up an ASA 5510 to allow all traffic going from the inside to outside so I can get internet access through it. I have worked on this for days and I have finally got traffic moving between my router and my ASA, but that is it. Everything is blocked because of NAT rules I assume.
    I get errors like this when I try Packet Tracer:
    (nat-xlate-failed) NAT failed
    (acl-drop) Flow is denied by configured rule
    Version Information:
    Cisco Adaptive Security Appliance Software Version 9.1(4)
    Device Manager Version 7.1(5)
    Compiled on Thu 05-Dec-13 19:37 by builders
    System image file is "disk0:/asa914-k8.bin"
    Here is my ASA config, all I want for this exercise is to pass traffic from the inside network to the outside to allow internet access so I can access the internet and then look for specific acl's or nat for specific services:
    Thank You!
    Config:
    ASA5510# sh running-config
    : Saved
    ASA Version 9.1(4)
    hostname ASA5510
    domain-name
    inside.int
    enable password <redacted> encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd <redacted> encrypted
    names
    dns-guard
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    interface Ethernet0/1
    description WAN Interface
    nameif Outside
    security-level 0
    ip address 199.199.199.123 255.255.255.240
    boot system disk0:/asa914-k8.bin
    ftp mode passive
    dns domain-lookup Outside
    dns server-group DefaultDNS
    name-server 199.199.199.4
    domain-name
    inside.int
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    access-list USERS standard permit 10.10.1.0 255.255.255.0
    access-list OUTSIDE-IN extended permit ip any any
    access-list INSIDE-IN extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu Inside 1500
    mtu Outside 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-715.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
      nat (Inside,Outside) dynamic interface
    access-group INSIDE-IN in interface Inside
    access-group OUTSIDE-IN in interface Outside
    router rip
    network 10.0.0.0
    network 199.199.199.0
    version 2
    no auto-summary
    route Outside 0.0.0.0 0.0.0.0 199.199.199.113 1
    route Inside 172.16.10.0 255.255.255.0 10.10.1.2 1
    route Inside 172.16.20.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.1.0 255.255.255.0 10.10.1.2 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 Inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Inside
    ssh timeout 60
    ssh version 2
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username <redacted> password <redacted> encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
      parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns migrated_dns_map_1
      inspect ftp
      inspect h323 h225
      inspect h323 ras
       inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
       destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
       subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    password encryption aes
    Cryptochecksum:
    <redacted>
    : end
    SH NAT:
    ASA5510# sh nat
    Manual NAT Policies (Section 1)
    1 (Inside) to (Outside) source dynamic any interface
        translate_hits = 0, untranslate_hits = 0
    Auto NAT Policies (Section 2)
    1 (Inside) to (Outside) source dynamic inside-net interface
         translate_hits = 0, untranslate_hits = 0
    SH RUN NAT:
    ASA5510# sh run nat
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
    nat (Inside,Outside) dynamic interface
    SH RUN OBJECT:
    ASA5510(config)# sh run object
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    Hi all,Hello everyone, I need some help before my head explodes. Idddddddd

    Hello Mitchell,
    First of all how are you testing this:
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    Take in consideration that the netmask is /30
    The Twice NAT is good, ACLs are good.
    do the following and provide us the result
    packet-tracer input inside tcp 10.10.1.2 1025 4.2.2.2 80
    packet-tracer input inside tcp 192.168.1.100 1025 4.2.2.2 80
    And provide us the result!
    Looking for some Networking Assistance? 
    Contact me directly at [email protected]
    I will fix your problem ASAP.
    Cheers,
    Julio Carvajal Segura
    Note: Check my website, there is a video about this that might help you.
    http://laguiadelnetworking.com

  • JSF Table StyleClass issue for a specific Field inside the Table

    Hi There,
    Am having an issue of dynamically setting the styleClass for a specific field inside a DataTable. Here is how the JSF code is ..
    <h:column>
    <h:panelGrid id="column4" columns="1" cellpadding="0" cellspacing="0">
    <h:inputText id="numberOfApps" value="#{row.submitNumber}" styleClass="#{row.customStyleClass}" maxlength="6" converter="MyNumberConverter" />
    </h:panelGrid>
    </h:column>
    This Table has a specific column which has a input Text Box where user enter's data. This data will be validated in the bean where in after the validation if its exceeding a limit we should throw an error message and also highlight the field with a specific styleClass.
    I am setting the StyleClass dynamically based on the User Input, so that I can display a highlited Error Field on the screen. Strangely enough, styleclass is getting set as expected for the first submit but doesnt show any styles for further submits. Even the existing style is getting removed from the second submit onwards. I am setting this "customStleClass" dynamic parameter as a Bean Property. Am sure these values are properly set coz to make sure I have put an h:output tag inside that table to display the customStyleClass values and they are getting set as expected but I see blank value for the class="" in the source of the Page.
    Any help would be appreciated.
    Thanks
    Edited by: Lalith on Jan 14, 2008 10:23 AM

    One option is you find the data element of that field GUID.
    Now go to SE11 transaction and in data type put that data element and press where used list. In that select tables.
    This will give you a list of tables where that field is used.
    But again if there are lots of them it will be difficult to find.
    The only option in that case is debug the extractor and find out.

  • Access field value in ALV

    Hello experts,
    I have created an simple ALV Grid report, in that I have implemented double click event n I want to create a new ALV grid with new data to be displayed. So I want to access field value ie using SLIS_SELFIELD or anything. Could anyone please guide me how can I access a field value using slis though SLIS_SELFIELD has methods like SEL_TAB_FIELD... I wan to access something like SEL_FIELD_VALUE but its not available in the class.
    Thanks in advance...
    Regards,
    Viral Patel

    Hi Viral,
    SLIS_SELFIELD has an attribute named VALUE which holds the value you selected row & TBAINDEX holds the row number.
    Refer below code snippet :-
    FORM user_command
              USING s_ucomm LIKE sy-ucomm
              s_selfield TYPE slis_selfield.                    "#EC CALLED
      CASE s_ucomm.
        WHEN '&IC1'.
          CLEAR wa_podat2.
          READ TABLE itab_podat2 INTO wa_podat2 INDEX s_selfield-tabindex.
          CHECK sy-subrc = 0.
          IF wa_podat2-ebeln = s_selfield-value.
            SET PARAMETER ID 'BES' FIELD wa_podat2-ebeln.
            IF wa_podat2-ebeln IS NOT INITIAL.
              CALL TRANSACTION c_tcode.
            ENDIF.
    For above event to happen, you have to use parameter I_CALLBACK_USER_COMMAND of  REUSE_ALV_GRID_DISPLAY as below :-
    CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'
        EXPORTING
          i_callback_program      = l_repid
          i_callback_user_command = 'USER_COMMAND'
          it_fieldcat             = itab_fieldcat
          it_events               = itab_events
        TABLES
          t_outtab                = itab_podat2[].
    Regards
    Abhii
    Edited by: Abhii on Nov 30, 2009 11:25 AM

  • Need help accessing the router web page.  I have been tol...

    Need help accessing the router web page.  I have been told my router is acting like a switch and the IP address is not in the proper range.  I have tried reseting the router (hold for 30 sec and unplug for 5 mins).  Didn't work.
    thanks

    What router are you using?  Almost all Linksys routers use 192.168.1.1 as the default local IP address, but there is at least one that uses 192.168.16.1 , namely the WTR54GS  (not the WRT54GS).
    You need to try again to reset the router to factory defaults.
    To reset your router to factory defaults, use the following procedure:
    1) Power down all computers, the router, and the modem, and unplug them from the wall.
    2) Disconnect all wires from the router.
    3) Power up the router and allow it to fully boot (1-2 minutes).
    4) Press and hold the reset button for 30 seconds, then release it, then let the router reset and reboot (2-3 minutes).
    5) Power down the router.
    6) Connect one computer by wire to port 1 on the router (NOT to the internet port).
    7) Power up the router and allow it to fully boot (1-2 minutes).
    8) Power up the computer (if the computer has a wireless card, make sure it is off).
    9) Try to ping the router. To do this, click the "Start" button > All Programs > Accessories > Command Prompt. A black DOS box will appear. Enter the following: "ping 192.168.1.1" (no quotes), and hit the Enter key. You will see 3 or 4 lines that start either with "Reply from ... " or "Request timed out." If you see "Reply from ...", your computer has found your router.
    10) Open your browser and point it to 192.168.1.1. This will take you to your router's login page. Leave the user name blank (note: a few Linksys routers have a default user name of "admin" (with no quotes)), and in the password field, enter "admin" (with no quotes). This will take you to your router setup page. Note the version number of your firmware (usually listed near upper right corner of screen). Exit your browser.
    If you get this far without problems, try the setup disk (or setup the router manually, if you prefer), and see if you can get your router setup and working.
    If you cannot get "Reply from ..." in step 9 above, your router is dead.
    If you get a reply in step 9, but cannot complete step 10, then either your router is dead or the firmware is corrupt. In this case, use the Linksys tftp.exe program to try to reload your router with the latest firmware. After reloading the firmware, repeat the above procedure starting with step 1.
    If you need additional help, please state your ISP, the make and model of your modem, your router's firmware version, and the results of steps 9 and 10. Also, if you get any error messages, copy them exactly and report back.
    Please let me know how things turn out for you.
    Message Edited by toomanydonuts on 01-21-2008 04:40 AM

  • Using external XML document to update / change text fields inside of published captivate output.

    Hello
    I currently have a project where the client has requested to have the ability to update the text fields inside the project at a later date.
    This is due to the nature of the content changing rather rapidly, i would like to set this up so the client can manage this them selfs.
    What would the best way to do this be?
    I'm thinking XML, an external XML sheet were by Captivate imports the text from this XML sheet and then displays it within the specific text fields contained within the captivate output.
    This way the client would just update the external XML document(cut and paste the text in) and then the text would be dynamically updated in the published Captivate document.
    any help would be amazing !
    Thanks in advance
    Nick

    Hi Lieve
    But isn't this thread more about an end user having an ability to change text after the Captivate has been published and delivered? I could see where that might be useful if making changes then publishing to create a new output. But I'm interpreting that the situation here is that a Captivate project has been published and delivered, and some mechanism is desired that allows the recipient to modify an external XML file to influence changes in the already compiled Captivate output.
    Cheers... Rick

  • Cannot access Graphics - bad class file

    Hey.
    When I try to compile my source I get an error saying...
    .\Man.java:146: cannot access Graphics
    bad class file: .\Graphics.java
    file does not contain class Graphics
    Please remove the files or make sure it appears in the correct subdirectory.
    It's on a different computer so that's not exactly it, but it's close enough. Compiler was working fine until the other day when i found out that all the source files were zipped up in src.zip, I had to extract Graphics.java so I could open it in emacs, and after I did that it started giving me that error message. There's nothhing wrong with my source, and I didn't move Graphics, it's still in the correct place exactly as it was, and i looked at it, all the right stuff is still inside. I'm quite confused.
    So do I have to reinstall? That would mean a massive download on my 56k and I kinda wanna carry on with my work.

    You should not need to unzip src.zip to use the Graphics class or any class that comes with j2sdk. The compiled classes are in jar files that are installed in certain directories when you install the j2sdk.
    You should only need to have a line "import java.awt.Graphics;" near the start of your source code.
    The error most likely occurred when the compiler found a Graphics.class file but inside the file is java.awt.Graphics class, not a plain Graphics class.

  • Using specifc partner function as access field for pricing

    Hi all,
    i am planning to add a specific partner function as an access field in combination with the material with which i will maintain the condition record & i want this condition record to be fetched for my respective condition type.
    i did the following, i still dont get the value.
    copied the new field in the KOMK table (structure & activated it),  assigned it to the relevant access sequence & hence to the condition type, i still dont get the condition record value ( condition record is a valid one too).
    what am i missing here?

    Hello,
    Go to Sales Order - Item Detals - Condition Tab & Click on "Analysis". Here check the Accesses & whether system has found the Condition Record.
    Also, as mentioned by Ankur above, most probably the new Partner Function or either of the Accesses will not be prosent in Sales Order.
    Hope this helps,
    Thanks,
    Jignesh Mehta

  • F4 help for fields in maintenance view resp. generated maintenance screen

    Hello,
    I’m new to ABAP and I have to deal with the following requirement:
    I have a maintenance view V1 what from a maintenance screen was generated automatically by the maintenance screen generator.
    Now I have to add a search help for one field F1 of the maintenance screen. The values for the search help of F1 depend on a specific value of a second field F2 of the maintenance screen. So I need value of F2 as import parameter for f4-help. F1 and F2 come from different tables.
    As I’m new to ABAP I have several questions or thoughts:
    - I’m not able to easily add a search help to F1 because I’m using the maintenance view V1 and that’s why it is not possible to assign the import parameter F2 to the search help – right?
    - In general, its not that easy to add search help to views than tables or structures - why?
    - I’m not able to just modify the generated objects because further automatic generation of the maintenance screen will delete it – right?
    - The generated function module provides user includes to add user specific coding. Is there any chance to add a f4-help to field F1 and assign value of F2 to that search help as import parameter with coding in user include?
    - any other ideas? I did not expect this topic to be so complicated as the requirement to change f4-help in a maintenance view resp. screen isn't very special.
    can anyone help me?
    Thank You!
    Regards
    Fabian

    Hi Fabian,
    Phew! Thats quite a few questions in one... I'll try to answer them to best of my knowledge..
    You can definitely have an external Search Help for a field of a Maintenance View, by calling it directly in the Screen Action Flow, using a PROCESS ON VALUE-REQUEST (like PAI or PBO). While defining such custom code on a generated screen, always make sure you do not write the coding inside the generated includes (SVIM* or <FUGR>TOP, <FUGR>DAT, etc..). Define new includes, or use those which are not generated by View Maintenance. This way, even if the dialogue is regenerated, your custom code will not vanish.
    This will answer your questions 1 and 2 generally, and your question 3 also.
    A Maintenance View, is something where values are read and populated purely at run-time. It does not have an Entry Help or such options, as it depends on the underlying tables. I hope this further helps with questions 1 and 2.
    Coming to your question 4 and 5, which form the main question - pre-filling value of F2 while calling search-help for F1 - yes, it is possible. On the view maintenance screen, there are standard structure variables (like EXTRACT TOTAL etc), which will give you the field values of the current record. But, it can no way assure that when you call the help for F1, the field F2 is already filled!
    For this, I can suggest that you programmatically implement a check to see if F2 value is filled, and read if it is. Or, if it is not filled, maybe you can shoot a Pop-up for F2, take the value at run-time, find help for F1 and get value, and also fill the F2 value (from your implementation) into the currect screen F2 value! (Phew...it is complex...)
    But am sorry, there is no other way, wherein you can gaurentee that F2 value is pre-filled always, when you can help for F1. (You could try making F2 as obligatory on screen, but it still doesnt necessarily solve this purpose..!).
    Hope it helps. Get back to me by e-mail if you need more help, or simple post a reply.
    Regards,
    Rekha

Maybe you are looking for