Help in config. of Site priority conflict resolution method

Hi,
I am testing Materialized View Replication (one master site and one MV site) .To resolve
conflict I employ Site Priority Conflict Resolution Method but I am not able to insert or update the records. I am getting transaction error while I insert or update the records.
This is my conflict resolution script i used Please help me out.
CONNECT repuser/[email protected]
BEGIN DBMS_REPCAT.SUSPEND_MASTER_ACTIVITY (gname => 'rep_repg');END;/
BEGIN
DBMS_REPCAT.ALTER_MASTER_REPOBJECT (sname => 'repuser',
oname => 'Name',type => 'TABLE',ddl_text => 'ALTER TABLE repuser.Name ADD (site VARCHAR2(20))');END;/
BEGIN
DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT (sname => 'repuser',oname => 'name',type => 'TABLE',
min_communication => TRUE);END;/
BEGIN
DBMS_REPCAT.CREATE_MASTER_REPOBJECT (gname => 'rep_repg',
type => 'TRIGGER',oname => 'insert_site',sname => 'repuser',ddl_text => 'CREATE TRIGGER repuser.insert_site
BEFORE UPDATE ON repuser.name FOR EACH ROW
BEGIN
IF DBMS_REPUTIL.FROM_REMOTE = FALSE THEN
SELECT global_name INTO :NEW.SITE FROM GLOBAL_NAME;
END IF;END;');END;/
BEGIN
DBMS_REPCAT.MAKE_COLUMN_GROUP (sname => 'repuser',
oname => 'Name',column_group => 'name_sitepriority_cg',
list_of_column_names => 'S_NO,FIRSTNAME,LASTNAME,site');
END;/
BEGIN
DBMS_REPCAT.DEFINE_SITE_PRIORITY (gname => 'rep_repg',
name => 'name_sitepriority_pg');END;/
BEGIN
DBMS_REPCAT.ADD_SITE_PRIORITY_SITE (gname => 'rep_repg',
name => 'name_sitepriority_pg',site => 'orcl.world',
priority => 100);END;/
BEGIN
DBMS_REPCAT.ADD_SITE_PRIORITY_SITE (gname => 'rep_repg',
name => 'name_sitepriority_pg',site => 'mvsite1.world',
priority => 50);END;/
BEGIN
DBMS_REPCAT.ADD_UPDATE_RESOLUTION (sname => 'repuser',
oname => 'Name',column_group => 'name_sitepriority_cg',
sequence_no => 1,method => 'SITE PRIORITY',
parameter_column_name => 'site',
priority_group => 'name_sitepriority_pg');END;/
BEGIN
DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT (sname => 'repuser',oname => 'Name',type => 'TABLE', min_communication => TRUE);END;/
BEGIN
DBMS_REPCAT.RESUME_MASTER_ACTIVITY (
gname => 'rep_repg');END;/

Hi,
I am testing Materialized View Replication (one master site and one MV site) .To resolve
conflict I employ Site Priority Conflict Resolution Method but I am not able to insert or update the records. I am getting transaction error while I insert or update the records.
This is my conflict resolution script i used Please help me out.
CONNECT repuser/[email protected]
BEGIN DBMS_REPCAT.SUSPEND_MASTER_ACTIVITY (gname => 'rep_repg');END;/
BEGIN
DBMS_REPCAT.ALTER_MASTER_REPOBJECT (sname => 'repuser',
oname => 'Name',type => 'TABLE',ddl_text => 'ALTER TABLE repuser.Name ADD (site VARCHAR2(20))');END;/
BEGIN
DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT (sname => 'repuser',oname => 'name',type => 'TABLE',
min_communication => TRUE);END;/
BEGIN
DBMS_REPCAT.CREATE_MASTER_REPOBJECT (gname => 'rep_repg',
type => 'TRIGGER',oname => 'insert_site',sname => 'repuser',ddl_text => 'CREATE TRIGGER repuser.insert_site
BEFORE UPDATE ON repuser.name FOR EACH ROW
BEGIN
IF DBMS_REPUTIL.FROM_REMOTE = FALSE THEN
SELECT global_name INTO :NEW.SITE FROM GLOBAL_NAME;
END IF;END;');END;/
BEGIN
DBMS_REPCAT.MAKE_COLUMN_GROUP (sname => 'repuser',
oname => 'Name',column_group => 'name_sitepriority_cg',
list_of_column_names => 'S_NO,FIRSTNAME,LASTNAME,site');
END;/
BEGIN
DBMS_REPCAT.DEFINE_SITE_PRIORITY (gname => 'rep_repg',
name => 'name_sitepriority_pg');END;/
BEGIN
DBMS_REPCAT.ADD_SITE_PRIORITY_SITE (gname => 'rep_repg',
name => 'name_sitepriority_pg',site => 'orcl.world',
priority => 100);END;/
BEGIN
DBMS_REPCAT.ADD_SITE_PRIORITY_SITE (gname => 'rep_repg',
name => 'name_sitepriority_pg',site => 'mvsite1.world',
priority => 50);END;/
BEGIN
DBMS_REPCAT.ADD_UPDATE_RESOLUTION (sname => 'repuser',
oname => 'Name',column_group => 'name_sitepriority_cg',
sequence_no => 1,method => 'SITE PRIORITY',
parameter_column_name => 'site',
priority_group => 'name_sitepriority_pg');END;/
BEGIN
DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT (sname => 'repuser',oname => 'Name',type => 'TABLE', min_communication => TRUE);END;/
BEGIN
DBMS_REPCAT.RESUME_MASTER_ACTIVITY (
gname => 'rep_repg');END;/

Similar Messages

  • Site Priority Conflict Resolution

    I'm using Oracle9i version 9.2.0.1.0 running in Windows Server 2003
    I am testing Materialized View Replication ( 1 Master site and multiple
    materialized view site) for my Advanced Replication setup. To resolve
    conflict I employ Site Priority Conflict Resolution Method.
    I successfully pushed data from mview site-1 to the master site.
    When I pushed data from mview site-2 to the master site with the same
    data previously pushed from mview site-1, unique constraint is violated
    hence a failure in replication. It seems my conflict resolution is not
    working. Can anybody help me resolve my problem?
    Arnel

    master group - MG_SRD_ALL
    exec dbms_repcat.define_site_priority('MG_SRD_ALL', 'SPS BERE');
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISSPCB1.WORLD', 100);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSPE1.WORLD', 90);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSJH1.WORLD', 80);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSCK1.WORLD', 70);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSST1.WORLD', 60);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSPI1.WORLD', 50);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSPT1.WORLD', 40);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSCB1.WORLD', 30);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISPSTA1.WORLD', 20);
    exec dbms_repcat.add_site_priority_site('MG_SRD_ALL', 'SPS BERE', 'GISHSCB1.WORLD', 10);
    create snapshot log on &datausr..LESPRUSEK with primary key;
    prompt Creating rep. object &datausr..LESPRUSEK in group MG_SRD_ALL
    begin
    dbms_repcat.create_master_repobject(
    gname => '"MG_SRD_ALL"',
    type => 'TABLE',
    oname => '"LESPRUSEK"',
    sname => '"&datausr"',
    use_existing_object => TRUE,
    copy_rows => TRUE);
    end;
    EXECUTE sys.DBMS_REPCAT.make_column_group( -
    sname => '&datausr', -
    oname => 'LESPRUSEK', -
    column_group => 'CG_LESPRUSEK', -
    LIST_OF_COLUMN_NAMES => ' -
    SEMOBJ_ID -
    ,MSLINK -
    ,MAPID -
    ,DATUM -
    ,DURCHID -
    ,K_EC -
    ,EC_OLD -
    ,TEU_ID -
    ,K_TYPPTE -
    ,NNUSEK_ID -
    ,NNKABEL_ID -
    ,USEKVVN_ID -
    ,USEKVN_ID -
    ,KABELVN_ID -
    ,DELKA -
    ,UD_PLOCHA -
    ,POZNAMKA -
    ,K_OJ_INFO -
    ,C_EVSTR -
    ,C_VP -
    ,K_ZAR -
    ,NAZEV_I -
    ,NAZEV_II -
    ,SITE_NAME -
    ,K_PRES_ZAK -
    ,AU_ID -
    begin
    dbms_repcat.add_update_resolution(
    sname => '&datausr',
    oname =>'LESPRUSEK',
    column_group => '"CG_LESPRUSEK"',
    sequence_no => 0 + 2,
    method => 'Site Priority',
    parameter_column_name => '"SITE_NAME"',
    priority_group => '"SPS BERE"');
    end;
    EXECUTE sys.DBMS_REPCAT.generate_replication_support( -
    sname => '&datausr', -
    oname => 'LESPRUSEK', -
    type => 'TABLE');
    column SITE_NAME - is filled by global_name by trigger
    CREATE OR REPLACE TRIGGER &&datausr..TQ_LESPRUSEK
    BEFORE INSERT OR UPDATE ON &&datausr..LESPRUSEK FOR EACH ROW
    BEGIN
    IF NOT (DBMS_SNAPSHOT.I_AM_A_REFRESH OR DBMS_REPUTIL.FROM_REMOTE) THEN
    :NEW.SITE_NAME := glname_pkg.global_name;
    END IF;
    END;
    show err

  • Conflicts resolution methods in Oracle Lite

    Can anyone please provide the answers of the following questions?
    1_What Methods are used for Conflict detection and resolution for concurrent updates by multiple clients in Oracle lite databases?
    2_ Is there any method that extract semantic relation from the concurrent update transactions and create a global update schedule?
    3_ Does oracle lite use conflict avoidance mechanism?
    4_ What replication method is used by Oracle Lite Database?

    In terms of conflict resolution with oracle lite, which end do you mean? conflict resolution in the client database (ie: oracle lite) or on the server side when processing client uploads (this is just a standard oracle database), also not sure what you are trying to achieve
    *1_What Methods are used for Conflict detection and resolution for concurrent updates by multiple clients in Oracle lite databases?*
    I assume in the following that you are talking about dealing with uploads
    Depending on how the publication items are defined, the process is quite different.
    a) fast refresh publication items
    When the client synchronises, the upload data is uploaded as a packed binary file which is then unpacked and inserted into in queue tables in the mobileadmin repsitory (table names begin CFM$ followed by the publication item name). This is the only action that happens during the actual sync process.
    A second and independent process, not linked to the actual synchronisation - the MGP process, runs on the mobile server, and this has three phases - apply, process logs and compose that run one after the other. You can set the MGP to only do the apply phase, or all three.
    during the apply phase the data in the in queue tables for a particular user/transaction will be applied to the server database. Normally the MGP process is set to have three threads (this can be changed, but three is the default), and therefore three client uploads will be processed in parallel, but each of these threads is independant of the others and therefore should be seen as seperate transactions.
    It should be noted that even if you have 50 or 100 users synchronising concurrently, only three upload sets will be processed at any one time, and almost certainly a period of time after the synchronisation has completed (may be many hours depending on the MGP cycle time)
    As each of the apply threads is a seperate transaction, there is no concept of concurrency built in, and the only conflict resolution by default is based on the server wins/client wins setting of the publication item. where multiple users are updating the the same server record with 'client wins', the first user will update the data, and then the next user will update the data (just a repeat of the previous one). NOTE also that in the case of an update, ALL columns in the record are updated, there is no column level update.
    There are customisation options available to provide finer grained control over the apply process, look at the PLSQL callback packages registered against each publication item for beforeapply, afterapply, beforetranapply and aftertranapply, Apply DML procedures against the publication items and also the CUSTOMIZE package at the MGP level
    b) complete refresh publication items
    where the publication as a whole has a mixture of fast and complete refresh publication items, these normally work in the same way as the fast refresh described above. Where however you just have complete refresh items the data MAY be written directly to the server table on upload
    c) queue based publication items
    These work in realtime, rather than with a delay for the MGP process to pick up the data.
    When the user synchronises, the uploaded data is is written to the in queue tables in the same way, but when this is completed, a package (defined as part of the publication definition) is called, and the procedure upload_complete is run passing in the user and transaction identifiers. This package needs to be hand crafted, but you have full control over what and how all of the uploaded data is processed, but again this is a single transaction for that user. If you want to look at other sessions running, you need to find a way to implement this.
    *2_ Is there any method that extract semantic relation from the concurrent update transactions and create a global update schedule?*
    As noted above, the uploads may be processed in parallel, but they are seperate transactions, so no built ins
    *3_ Does oracle lite use conflict avoidance mechanism?*
    Only the basic oracle stuff, unless you use the customisation options to write your own
    *4_ What replication method is used by Oracle Lite Database?*
    The different types of publication items select data from the server database for download in different ways
    a) fast refresh
    change logging tables and triggers are created in the server database. These are scanned during the MGP process logs phase to determine what changes have happened since the last MGP compose, and what publication items they affect. The MGP compose then runs and this uses the same three threads to process the users in alphabetical order using the change keys to populate data in out queue tables (prefixed CMP$) in the repository. These have the PK values for the data, plus a transaction types (insert/update/delete). All the MGP process does is populate these out queue tables.
    When the user synchronises, the data in the out queue tables is used as a key list to extract the data from the actual server tables into a packed binary file, and this is sent to the client.
    b) complete refresh
    there is no pre-preparation in this case, the data is streamed directly from the server database into the packed binary download file
    c) queue based items
    in real time when the user is synchronising after the apply has been done by the uploade_complete procedure, a second procedure download_init is called. Within this you have to code the data extract, and MUST populate tables (you also need to create them) CTM$<publication item name> these are effectively out queue tables, but contain all of the data, not just the PK values. At the end of the procedure, the data is streamed from these into the binary file for download.
    Depending on the definition of your apublication, you could have one or more of the above types (VERY bad idea to mix queue based and fast refresh unless you are very sure about what you are doing) and therefore there may be a mix of different actions happening at different times
    In conclusion i would say that try and send seperate data to clients so that they do not interfere with each other, and for inserts use uniqueue keys or sequences. If you MUST send the same data to different clients for update, then the queue based approach provides the best control, but as it is real time is not as scalable for large data sets.

  • User-Defined Conflict Resolution

    Dear,
    I'm going to design User-Defined Conflict Resolution method. But reference site / documents is very few. It's difficult to find them.
    Have you ever designed that ?
    Do you have any sample scripts for that ?
    Thanks for advance.

    There is an example in the Replication Management API Reference Manual Appendix B. http://technet.oracle.com/doc/oracle8i_816/server.816/a76958/user_con.htm#133

  • How to query the conflict resolution actually implemente

    Hi all.
    Can anyone tell me an easy way to report the conflict resolution procedures that a replicated object has implemented?
    How do I know if a table has for example, site priority resolution and how it is done?
    In general, is there a script to report all the replication configuration being used?
    Thank you.

    Assuming you are referring to Streams, you can download a Streams health check script at My Oracle Support (be sure to get the correct version, they cover 10gR1, R2, 11gR1, and R2). The output of the script will detail all of your rules and rule sets, process names, users, and so on. If you are calling a procedure to deal with conflict resolution, the action on error should reflect your procedure name, as an example.
    If you are referring to GoldenGate, you can look at the appropriate parameter files (typically Replicat for conflict resolution purposes).
    In either case, there is no setting or parameter that tags one source as the primary (or not). That designation is from a coding perspective. This implies that you capture the source of a record so you can evaluate "if error (whatever it is), then use record from source A."

  • Access List and Conflict Resolution Problem!

    My configuration for Allow and Deny is not allowing me to load images and CSS files through the gateway on a URLScraper channel.
    I'm trying to figure out how to control access to resources using the Access List service, and I'm running into trouble. The Sun ONE Portal Server, Secure Remote Access 6.0 Administrator's Guide (Doc 816-6421-10) states:
    Setting the Conflict Resolution Level
    You can set the priority level for the dynamic attributes. If a user inherits multiple attribute templates, say from an organization and a role assignment, and there is a template conflict between the attributes in the two templates, the template with the highest priority is inherited. There are seven settings available ranging from Highest to Lowest.
    See the Administration Guide, iPlanet Directory Server Access Management Edition for more details on conflict resolution.
    Unfortunately the referenced Adminstration Guide for DSAME contains exactly 0 occurances of the word "conflict" in its 136 pages, so that reference was less than helpful. Chapter 17 of that document (Doc 816-5620-10) describes URL Policy Agent Attributes, which sheds some light on what the URL Deny and URL Allow settings mean. The key sentence is, "An empty Deny list will allow only those resources that are allowed by the Allow list."
    So, I've set up my Access List services as follows:
    o URL Deny is blank on all Access Lists
    o URL Allow set as follows
    ---- isp
    ------- http://portal.acme.com/portal/* (company name changed to protect the guilty!)
    ---- acme.com organization
    ------- Conflict Resolution: Highest
    ------- http://portal.acme.com/portal/* (same as above)
    ---- Acme Customers Role - shared role for all Acme customers
    ------- Conflict Resolution: Medium
    ------- http://www.acme.com/*
    ------- http://support.acme.com/*
    ------- http://support2.acme.com/*
    ---- RoadRunner role - specific role for a specific customer
    ------- Conflict Resolution: Medium
    ------- http://roadrunnerinfo.acme.com/*
    The Desktop services in each of the above two roles includes channels from the hosts in the URL Allow lists.
    The behavior I'm seeing with this configuration is that the desktop channels include information from the scraped HTML, and the URLs are rewritten for the included images and CSS files and such. However, the gateway is denying access to the images referenced by the rewritten URL. That is, an image with a URL of https://portal.acme.com/http://roadrunnerinfo.acme.com/images/green.gif shows up as a broken image on the desktop. Attempting to access the URL to the image directly results in an "Access to this resource is denied !! Contact your administrator" error message.
    If I set the conflict resolution on the acme.corp organization to Medium (or anything lower than the two role conflict resolution levels) results in the same error message as soon as the customer logs in (no desktop rendered). The same error occurs if I set the conflict resolution in the two roles to Highest (same as the top level organization), again with no desktop rendered on login.
    If I put all the above referenced URLs in the acme.com organization Access List service, then I am successfully able to fetch all the resources (images, CSS, etc.) in the URLScraper HTML. Likewise if I put "*" in that Access List. However, this is less than ideal, as it would potentially allow other customers to view data that isn't theirs (Wile E. Coyote user should not be able to get to Road Runner data, and vice versa, and neither one of them should get at Acme private information!).
    So, what am I doing wrong? Also, does anyone have any leads on where I can read up on how Access Lists and conflict resolution are supposed to work, since Sun neglected to include a valid reference in the Administrator's Guide, Portal Server 6.0 SRA?
    Thanks!
    -matt

    Did you ever get anywhere with this. My experiments seem to inidicate that you cannot successfully combine Access and Deny directives, across roles or organizational defaults and a role.

  • Hot Synch Manager Settings (Conflict Resolution​)

    Hello,
    I synch an office desktop and a home desktop with one Palm Z22.  I have had a lot of problems with duplicate appointments !  How should I configure the Hot Sync Manager settings?  I have the conduits (calendar, note pad, etc. ) set on "synchonize the files".  But when I click on "change" and then "settings", I'm brought to the option of "Conflict Resolution" and the choices are duplicate, Outlook wins, Handheld wins, or ignore.  Which should I choose if I want to avoid duplicate appointments ?
    Thank you.
    Nancy
    Post relates to: Zire
    This question was solved.
    View Solution.

    Yes, that's what I'd set it to.  You want the information to flow in only one direction on the slave computer.   Handheld --> computer.
    WyreNut
    Post relates to: Centro (AT&T)
    I am a Volunteer here, not employed by HP.
    You too can become an HP Expert! Details HERE!
    If my post has helped you, click the Kudos Thumbs up!
    If it solved your issue, Click the "Accept as Solution" button so others can benefit from the question you asked!

  • No Windows for conflict resolution in Isync

    Hello,
    After a synchro with iSync, I see conflicts. When I try to resolve them.
    The resolve conflit app is launched but i have no windows. To be clear I have not the possibility to resolve conflict because the windows apps do not appears. But I have the app icon launched in the dock.
    Thanks for the help.
    Regards,
    Nicolas

    Hi Prashil,
    Thanks for reply.
    I have the access to DTR. Can you provide any Documentation on this..???
    <b>Whether the Conflict Resolution when Support Packs applied are same as Integration Conflicts..??</b>
    If so, Plz send any documentation on Integration Conflicts, if you have..???
    Plz respond ASAP...
    Thanks||
    Dev..

  • Conflict resolution for a table with LOB column ...

    Hi,
    I was hoping for some guidance or advice on how to handle conflict resolution for a table with a LOB column.
    Basically, I had intended to handle the conflict resolution using the MAXIMUM prebuilt update conflict handler. I also store
    the 'update' transaction time in the same table and was planning to use this as the resolution column to resolve the conflict.
    I see however these prebuilt conflict handlers do not support LOB columns. I assume therefore I need to code a customer handler
    to do this for me. I'm not sure exactly what my custom handler needs to do though! Any guidance or links to similar examples would
    be very much appreciated.

    Hi,
    I have been unable to make any progress on this issue. I have made use of prebuilt update handlers with no problems
    before but I just don't know how to resolve these conflicts for LOB columns using custom handlers. I have some questions
    which I hope make sense and are relevant:
    1.Does an apply process detect update conflicts on LOB columns?
    2.If I need to create a custom update/error handler to resolve this, should I create a prebuilt update handler for non-LOB columns
    in the table and then a separate one for the LOB columns OR is it best just to code a single custom handler for ALL columns?
    3.In my custom handler, I assume I will need to use the resolution column to decide whether or not to resolve the conflict in favour of the LCR
    but how do I compare the new value in the LCR with that in the destination database? I mean how do I access the current value in the destination
    database from the custom handler?
    4.Finally, if I need to resolve in favour of the LCR, do I need to call something specific for LOB related columns compared to non-LOB columns?
    Any help with these would be very much appreciated or even if someone can direct me to documentation or other links that would be good too.
    Thanks again.

  • Need Help on Configuring the Site to Site VPN from Cisco 2811 to Websense Cloud for web Traffic redirect

    Hi All,
    I need help on Configuring the Site to Site VPN from Cisco 2811 to Websense Cloud for web Traffic redirect
    2811 having C2800NM-ADVIPSERVICESK9-M
    2811 router connects to the Internet SW then connects to the Internet router.
    Note- For Authentication am using the Device ID & Pre share key. I am worried as all user traffic goes with PAT and not firing up my tunnel for port 80 traffic. Can you please suggest what can be the issue ?
    Below is router config for VPN & NAT
    crypto keyring ISR_Keyring
      pre-shared-key hostname vpn.websense.net key 2c22524d554556442d222d565f545246
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp keepalive 10
    crypto isakmp profile isa-profile
       keyring ISR_Keyring
       self-identity user-fqdn [email protected]
       match identity user vpn-proxy.websense.net
    crypto ipsec transform-set ESP-NULL-SHA esp-null esp-sha-hmac
    crypto map GUEST_WEB_FILTER 10 ipsec-isakmp
    set peer vpn.websense.net dynamic
    set transform-set ESP-NULL-SHA
    set isakmp-profile isa-profile
    match address 101
    interface FastEthernet0/1
    description connected to Internet
    ip address 216.222.208.101 255.255.255.128
    ip access-group HVAC_Public in
    ip nat outside
    ip virtual-reassembly
    duplex full
    speed 100
    no cdp enable
    crypto map GUEST_WEB_FILTER
    access-list 101 permit tcp 192.168.8.0 0.0.3.255 any eq www
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 host 85.115.41.187 log
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 host 85.115.41.181 log
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 host 85.115.41.182 log
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 86.111.216.0 0.0.1.255
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 116.50.56.0 0.0.7.255
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 86.111.220.0 0.0.3.255
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 103.1.196.0 0.0.3.255
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 177.39.96.0 0.0.3.255
    access-list 103 deny   ip 192.168.8.0 0.0.3.255 196.216.238.0 0.0.1.255
    access-list 103 permit ip 192.168.8.0 0.0.3.255 any
    ip nat pool mypool 216.222.208.101 216.222.208.101 netmask 255.255.255.128
    ip nat inside source list 103 interface FastEthernet0/1 overload
    ip nat inside source route-map nonat pool mypool overload

    How does Websense expect your source IPs in the tunnel? 192.168.8.0 0.0.3.255 or PAT'ed 216.222.208.101 ?
    Check
    show crypto isakmp sa
    show crypto ipsec sa
    show crypto session
    You'd better remove the preshared key from your post.

  • Merge/Refresh Workspace: Question concerning conflict resolution

    hi!
    thank's so far for answering our last question,now another question popped up during developing :)
    we now have a state with our application where the user can select which objects to merge/refresh and finally commit these changes.
    if there have been any conflicts he had to select a resolve operation for them. so far so good.
    now, our method that performs the merging looks (no surprise) something like that: (the numbers are markers, used later on)
    (1)
    beginResolve();
    do a few resolveConflicts();
    (*) commit;
    commitResolve();
    (2)
    (3)
    do_merge/refresh_operations_of_death_in_correct_order();
    (4)
    ok, first question is concerning the line with the (*).
    it seems we cannot call commitResolve() when there is an open transaction? as we run a spring managed application we first had it that way, that all of the above lines were executed within on transaction (that is, the complete merge/refresh operation going from (1) to (4)).
    that didn't work, as we got exceptions on commitResolve(), that there is an open database transaction. is that because of the transaction wrapping the complete method? or did we do something else wrong?
    now we split the method in two parts: one for the conflict resolution ((1) to (2) and one for the rest ((3) to (4)), both running within a transaction now. that works.
    however, I feel a little bit unsafe with that, questions are:
    if the first part runs in an own transaction and is commited: does the commitResolve() actually write data? or is that just something temporary on a per-session base? because, if something fails in the second part ((3) to (4)) then the transaction of that part of course rolls back fine, but the result of the conflict resolve part is probably still there? could we then, somewhere in the exception handling of the second transaction, call rollbackResolve()? or does it always have to happen within a conflict resolution session, that means, within (1) to (2)? the docs state the latter, but we're not really sure.
    if something fails for whatever reason during the actual merge/refresh part, we need to make sure, that everything is rolled back to the state before
    starting the whole process. it would be very dangerous to have some resolved conflicts hanging around that get merged/refreshed sometime later when the user doesn't even think about them.
    btw, we also found the docs a bit inconsistent concerning conflict resolution. at some point it is explained, that after calling the resolveConflicts() a commit is needed, at another point this is left out and it is said, that one would just need to call commitResolve() afterwards and THEN a commit. it seems only the first explanation is correct (with another commit after the commitResolve()).
    so, if you could clarify a bit on how a conflict resolution + merge/refresh session should look like concerning the management and scope of transactions, that would be really of great help and highly appreciated! the first tests worked fine with the way we have it working right now, but we always feel like there's a huge pitfall hiding somewhere ;)
    best regards,
    Andreas

    Hi Ben,
    after your explanation I agree. As the workspaces only carry the difference information of course there actually is no data in the child workspace if the object has been deleted in the parent.
    I guess for the first we should not display this object to the user except when he's attempting to do a refresh, but not for a merge (or the other way round if the delete was done in the
    child and NC in parent).
    We didn't realize there is a rollbackTable with a WHERE clause, quite nice! Still, nothing practicable for us as we can't really know when a user might want to undo a delete and thus
    which savepoint to use.
    Reinserting would work, yes. We even tried that once for another scenario. Though in our case it would be important that the object also gets the same PK again, which is possible but still
    feels like an ugly hack :-) Anyway, back to topic.
    For the second scenario I was unfortunately mixing some WM and our users' terminology, thus it was not 100% clear. Sorry for that. What I meant was the following:
    1) create new object in child
    2) merge this object to parent
    2a) DIFF is clear now, everything OK
    3) goto parent workspace, new object is there
    4) modify the new object there
    5) goto child workspace again
    6) open differences-viewer of our application <- here I wrote the users do a refresh, I meant they are >planning< to do a refresh, but not actually did it yet
    OK, at point 6) we now get the diff information from the DIFF view and have an U for the parent and an I for the child. After your explanations and thinking over it some time we realized, that
    this of course is totally correct: the last change in the parent was the update, the last change in the child the insert.
    As the current version of our differences-viewer more or less displays the information from the DIFF-views in a straight way, the user now sees, that the object was updated in parent and new/inserted in child,
    because those are the last operations for this row in both of the workspaces. That's what I meant is not intuitive, especially if they did not do all the operations themselves like in our small example and within
    the timespan of 2 minutes.
    It seems, we have to build some more abstraction around our current process?
    To us it seems there are two solutions to this "problem", correct us if we oversee something:
    1) currently synchronization within our application is directional, so either merge or refresh (except for conflict resolution, where the user might also want to decide to keep the object from the target workspace)
    Thus we simply can ignore the DiffCode for the target workspace, except for conflicts, where we easily get the information from the CONF views
    EDIT: no, we cannot simply ignore the target diffcode :( After some more thinking we have the same problem as with a real bidirectional synchronization process.
    2) on the long run we actually planned to provide a bidirectional merge-tool to the user. In that case it's not that easy, as there is no single target workspace.
    We didn't go into details yet, but probably we would need to retrieve further information, like e.g. the change timestamps for the DIFF rows for child and parent?
    Then we could see what was actually the last change and display only that (except for U/U conflicts, but then again we get that information from the CONF view)
    Any hints on how to do something like that the best way?
    EDIT: We think it boils down to the question: how can we know, which parts of the DIFF have already been handled in a merge/refresh before and which haven't?
    And another question, this time concerning the original topic: conflict resolution.
    Is it possible in some way to ignore conflicts during a merge or refresh? Our users will definitely need that. The only idea we came up with yet would be again to use a savepoint (as you suggested
    already concerning error rollback), that is have a savepoint (e.g. for the last time the workspace was synchronized) and then "fake resolve" the conflict (use CHILD with resolveconflicts) but do not
    include the row in the following mergeTable() call. After merging has succeeded, use rollbackTable() for that row to the previous savepoint. Would that work?
    Thanks again and regards,
    Andreas Schilling
    Edited by: aschilling on Dec 15, 2009 9:33 AM

  • Conflict resolution including the CRT DUMMYfor Add-On ST-SER rel.700_2007_1

    Dear all,
    Environment  #    32 bit win2k3, SAP   & Orc with 10.2.0.2.0
    We are in process of applying suport packs for Solution manager 7.0,  SAPKITL25 is finished
    When applying SAPKITL26 with  SAPKB70015, SAPKA70015 I am gettign the following CRT is required
    ST-SER rel.700_2007_1 .
    I did this add-on & applied support packs for this component ST-SER rel.700_2007_1 - 1,2
    &  tried  SAPKITL26 with  SAPKB70015, SAPKA70015 again but the error repeats . What is the last support pack in 32 BIT sap system fo Solution manager.
    Error -
    Phase ADDON_CONFLICTS_?: Explanation of Errors
    onflicts were found between the Support Packages that you want to
    mport and the Add-Ons installed in the system. To guarantee the
    onsistency of your system, the import is interrupted until all Conflict
    esolution Transports (CRTs) for the listed Support Packages are
    ncluded in the queue.
    o include the CRTs in the queue, proceed as follows:
    Write down the Support Packages and Add-Ons that have conflicts.
    Leave this screen by choosing 'Cancel' (F12).
    Load the CRTs for the Support Packages with conflicts from the SAP
    Service Marketplace or request them from your Add-On supplier.
    Define the extended queue again in the Support Package Manager.
    Import the queue. The Support Package Manager executes all steps from
    the beginning.
    f the problem involves an SAP Add-On, see SAP Note 53902, which tells
    ou which CRTs resolve the conflicts. Otherwise contact the supplier of
    our Add-On for details on how to proceed.
    he following contains a table of Support Packages for each Add-On for
    hich conflicts were detected. The column 'Information on the Conflict
    esolution' specifies how you can resolve a conflict. For more
    nformation, select the corresponding 'Information for the Conflict
    esolution'.
    onflicts Between Add-On ST-SER 700_2007_1 and Support Packages
    omponent    Release      Support Package        Information on
                                                    Conflict Resolution
    T           400          SAPKITL426             CRT: DUMMY
    Is this a known error or how to overcome this & clues on the following..
    -Rahul

    Dear Sunny,
    I went through the sap notes & found that i need to download ST-SER 700_2008_1.
    SAP Solution Manager 7.0 (Software component ST 400)
    ST 400 SP16 (SAPKITL426)
    With SP16 (SAPKITL426) SAP strictly recommends to upgrade your ST-SER tothe release 700_2008_1 or higher. Therefore use transaction SAINT instead of transaction SPAM to patch your system to SAP Solution Manager 7.0. If you try to patch your system via SPAM and your ST-SER release is 700_2007_1 or less you will receive one of the following information within SPAM during phase ADDON_CONFLICTS_?:
                        a) Conflicts Between Add-On ST-SER 700_2005_2 and Support Packages SAPKITL426 Include CRT
                        b) Conflicts Between Add-On ST-SER 700_2006_1 and Support Packages SAPKITL426 Include CRT
                        c) Conflicts Between Add-On ST-SER 700_2006_2 and Support Packages SAPKITL426 Include CRT
                        c) Conflicts Between Add-On ST-SER 700_2007_1 and Support Packages SAPKITL426 Include CRT
                        *Please be aware there is no physical Conflict Resolution Transport (CRT) available to solve this conflict (it is not planned to provide such a CRT). You have to patch your system via SAINT not via SPAM:*
                        1. Delete your SPAM-QUEUE by pressing the Display/Define button within SPAM.
                        2. Download all ST-SER Delta-Upgrade packages from the Software Download Center into your EPS-Inbox.
                        3. Call transaction SAINT and press Start button.
                        4. Select ST-SER 700_2008_1 or higher and press Continue button
                        All neccessary component packages will automatically be included into a valid SAINT-queue
    but  ST-SER 700_2008_1 not available to download & also noticed there are no manual CRT's
    how should i manage to patch system with ST-SER 700_2008_1 when it is not availble to download
    Thanks & regards,
    rahul

  • Where do I set up rules for conflict resolution when syncing iTunes with Outlook?

    I just got an iPhone 5 and I'm coming from a Blackberry.  I've been syncing Outlook Calendar and Contacts to a portable device for over 10 years, even back in the day of the pocket pc and more recently the Blackberry.  My iPhone 5 syncs great and seemlessly with Outlook using iTunes.  I've had no issues as of yet.  The problem for me is, it just seems "too" easy.  I didn't see anywhere where I could set rules for conflict resolutions.  For example, if your pc says one thing but your iPhone says another, who wins and supercedes the other?  What if by accident your iPhone loses all of its data, then iTunes syncs with your pc - will it delete all the Outlook data on your pc because it thinks it's syncing with updated data from your iPhone?  (in my case data I've had for over 10 years) 
    With the Blackberry software it asked you to set up rules for conflict resolution when first connecting the phone (including an option to ask you first).  In my case, I chose to have it ask me whenever it discovered a conflict.  So whenever I synced, it specifically alerted me exactly how many items are being synced, and then if there were any conflicts, it'd stop and then ask me which device I want to supercede the other.  This gave me a lot of piece of mind.  Now after getting my iPhone and using iTunes to sync, it's been great so far but I have to say that I don't have as much piece of mind.  Does anyone have any feedback on how to set up conflict resolution with iTunes and Outlook or does it not exist at all?  Again, what would happen if there was a conflict between the two devices? 

    Yes! Thankyou for that. I had of course put the context.xml file in the web-inf directory.
    I followed your example to the letter and it still wouldn't work. Or rather, I followed to the letter expect for the difference between "WEB" and "META".
    Once I worked that out, it started working like a dream.
    Note to anyone else who has a similar problem, make sure you REALLY look at the answer given. Make sure you REALLY do have all the files in the suggested places. It will save you time.
    Thanks again.

  • Help! My DW site displays in FireFox, but does not work in IE

    Help! My DW site displays fine in FireFox, but only the background loads in Internet Explorer and I get an error message that the site cannot open. The site is www.bransonareagolfcouncil.com

    You've got lots of validation errors:
    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.bransonareagolfcouncil.com%2F
    Also, this forum is for DW application development. In the future try posting to the Dreamweaver forum.

  • Syncing contacts conflict resolution

    I had given up trying to sync my torch with my MAC. It causes me more trouble and I spend more time trying to correct all the errors than if I were to just manually enter the information twice (once on the phone, once on the computer). I decided to try again and am kicking myself for doing so.
    I had updated contact information for several of my contacts on the phone. When the conflict resolution screen popped up, I chose the information on the phone since that is the current one. Once the sync was completed, I checked the phone and saw that the contact information had been changed back to the old. 
    This is so frustrating. Is anyone else experiencing this issue? Any suggestions or ideas on what I might be doing wrong?

    I use a Mac, so I'm not sure everything works exactly the same in Windows, but here's how I'd do it:
    1. in your address book, create a group for your old contacts
    2. connect your Touch to your computer
    3. select it in the left column of iTunes
    4. click on the Info tab at the top of the right column
    5. under Sync AddressBook Contacts (or whatever your address book is called), click Selected Groups
    6. now check off the groups you do want on your Touch and leave the others unchecked.
    I hope this will work for you! Good luck.

Maybe you are looking for

  • HP Officejet Pro 8610 - Error Code: " 0xc19a0013" (missing or failed printhead)

    I purchased the printer (HP Officejet Pro 8610 e-All-in-one printer) in January, 2015.  The printer functioned properly - copy, fax, and scan, until two days ago.  Now, it does not print at all.  Received an error code: "0xc19a0013" (Missing or Faile

  • LEFT Join not working

    Hi guys, I am not sure why the left join is not working.. when I try to use the and condition out of the left join condition. The database is relational but the requirement is for reporting. I have 2 user inputs and I should get the query results as

  • How to transfer apps from iphone 5 to 5c

    How to transfer apps from iPhone 5 to 5 c

  • Automatic PO ME59

    I understand ME59 is used only for automatic PO. What prerequisite ? Can anybody advise ?

  • Help! Connection pointbase error

    i used webserver7.0. this is my server.xml: <jdbc-resource> <jndi-name>jdbc/sample</jndi-name> <datasource-class>com.pointbase.jdbc.jdbcUniversalDriver</datasource-class> <property> <name>password</name> <value>PBPUBLIC</value> </property> <property>