HELP ME FOR DOING AN ASSIGNMENT

Sir,
I got an assignment in Java.I have some doubts regarding this.The assignment is as follows.
There should be a GUI in Swing.The assignment is to append two text files and store(save) the appended file in a new file.Also the appended file has to be displayed in a file viewer as part of this GUI.The two files are to be browsed from the directory using two BROWSE button.A SAVE AS button is necessary to save the file in the destination file.GUI should also contain an APPEND button,a VIEW button,a PAUSE button,a RESUME button and an EXIT button.On clicking the APPEND button,the two text files have to be appended.On clicking the VIEW button,the appended file has to be displayed character by character in a file viewer as part of the GUI.Character by character displaying of the appended file should be performed using multithreading.On clicking the PAUSE button,the file displaying should be paused.On clicking the RESUME button,the file displaying should be continued.EXIT button is for exiting from the GUI.
I have to submit this assignment on 5th Oct,2005.I am a fresher in Java.So I am encountering several problems while doing this project.Please help me out.If you send me the code,I would be very thankful to you.
Sincerely,
Anjali P

I am encountering several problems while doing thisproject.
Please be a little more explicit about what you're
doing, what you expect to happen, and what you
actually observe.
Please post a
short,
concise, executable example of what you're
trying to do. This does not have to be the actual
code you are using. Write a small example that
demonstrates your intent, and only that. Wrap the
code in a class and give it a main method that runs
it - if we can just copy and paste the code into a
text file, compile it and run it without any changes,
then we can be sure that we haven't made incorrect
assumptions about how you are using it.
Post your code between [code] and
[/code] tags. Cut and paste the code, rather
than re-typing it (re-typing often introduces subtle
errors that make your problem difficult to
troubleshoot). Please preview your post when
posting code.
Please assume that we only have the core API.
We have no idea what SomeCustomClass is, and neither
does our collective compiler.
If you have an error message, post the exact,
complete error along with a full stack trace, if
possible. Make sure you're not swallowing any
Exceptions.
Help us help you solve your problem.
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.io.*;
import java.util.*;
class main_Form extends JFrame implements ActionListener
     JButton b1=new JButton("APPEND");
     JButton b2=new JButton("VIEW");
     JButton b3=new JButton("PAUSE");
     JButton b4=new JButton("RESUME");
     JButton b5=new JButton("BROWSE FILE 1");
     JButton b6=new JButton("BROWSE FILE 2");
     JButton b7=new JButton("EXIT");
     JLabel l1=new JLabel("FILE 1");
     JLabel l2=new JLabel("FILE 2");
     JFrame f=new JFrame();
     JTextField tf1=new JTextField(15);
     JTextField tf2=new JTextField(15);
     TextArea ta= new TextArea("   ", 100, 100);
     JPanel p=new JPanel();
     Container c=getContentPane();
     public main_Form()
          setSize(700,500);
          p.setLayout(null);
          b1.setBounds(10,400,100,20);
          b2.setBounds(120,400,100,20);
          b3.setBounds(240,400,100,20);
          b4.setBounds(360,400,100,20);
          b5.setBounds(550,100,100,20);
          b6.setBounds(550,300,100,20);
          b7.setBounds(480,400,100,20);
          l1.setBounds(400,100,100,20);
          l2.setBounds(400,300,100,20);
          tf1.setBounds(450,100,100,20);
          tf2.setBounds(450,300,100,20);
          ta.setBounds(10,15,300,300);
          p.add(b1);
          p.add(b2);
          p.add(b3);
          p.add(b4);
          p.add(b5);
          p.add(b6);
          p.add(b7);
          p.add(l1);
          p.add(l2);
          p.add(tf1);
          p.add(tf2);
          p.add(ta);
          c.add(p);
          b5.addActionListener(new browseFile1());
          b6.addActionListener(new browseFile2());
          b7.addActionListener(this);
          b1.addActionListener(this);
     class browseFile1 implements ActionListener
          public void actionPerformed(ActionEvent ae)
               JFileChooser fc=new JFileChoose();
               int fVal =fc.showOpenDialog(main_Form.this);
               if(fVal == JFileChooser.APPROVE_OPTION)
                    System.out.println("APP 1");
                    tf1.setText(fc.getSelectedFile()+"");
               if(fVal == JFileChooser.CANCEL_OPTION)
                    tf1.setText("");
     class browseFile2 implements ActionListener
          public void actionPerformed(ActionEvent ae)
               JFileChooser fc=new JFileChooser();
               int fVal =fc.showOpenDialog(main_Form.this);
               if(fVal == JFileChooser.APPROVE_OPTION)
                    System.out.println("APP 2");
                    tf2.setText(fc.getSelectedFile()+"");
               if(fVal == JFileChooser.CANCEL_OPTION)
                    tf2.setText("");
     public void actionPerformed(ActionEvent ae)
          if(ae.getSource().equals(b7))
          this.hide();
          if(ae.getSource().equals(b1))
               try
                    FileInputStream f1=new FileInputStream(tf1.getText()+"");
                FileInputStream f2=new FileInputStream(tf2.getText()+"");
                  FileOutputStream outStream = new FileOutputStream("file3.txt");
                  SequenceInputStream f3=new SequenceInputStream(f1,f2);
                  int c=0;
                while((c=f3.read())!=-1)
                         outStream.write((char)c);
                         System.out.println((char)c);
               catch(Exception e)
                    System.out.println(e+"f1 file nt found");
            File f=new File("file3.txt");
     public static void main(String[] args)
          main_Form m1=new main_Form();
          m1.show();
          System.out.println("Hello World!");
}Sir,
This is only what i did.I dont have enough idea about multithreading.So I failed in writing the code for VIEW button,PAUSE button,RESUME button.This is the problem I am facing.The following is the attempt which I have made in writing the code for VIEW button.
import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.io.*;
import java.util.*;
import java.lang.Thread;
import java.lang.System;
class main_Form1 extends JFrame implements ActionListener
     JButton b1=new JButton("APPEND");
     JButton b2=new JButton("VIEW");
     JButton b3=new JButton("PAUSE");
     JButton b4=new JButton("RESUME");
     JButton b5=new JButton("BROWSE FILE 1");
     JButton b6=new JButton("BROWSE FILE 2");
     JButton b7=new JButton("EXIT");
     JLabel l1=new JLabel("FILE 1");
     JLabel l2=new JLabel("FILE 2");
     JFrame f=new JFrame();
     JTextField tf1=new JTextField(15);
     JTextField tf2=new JTextField(15);
     TextArea ta= new TextArea("   ", 100, 100);
     JPanel p=new JPanel();
     Container c=getContentPane();
     public main_Form1()
          setSize(700,500);
          p.setLayout(null);
          b1.setBounds(10,400,100,20);
          b2.setBounds(120,400,100,20);
          b3.setBounds(240,400,100,20);
          b4.setBounds(360,400,100,20);
          b5.setBounds(550,100,100,20);
          b6.setBounds(550,300,100,20);
          b7.setBounds(480,400,100,20);
          l1.setBounds(400,100,100,20);
          l2.setBounds(400,300,100,20);
          tf1.setBounds(450,100,100,20);
          tf2.setBounds(450,300,100,20);
          ta.setBounds(10,15,300,300);
          p.add(b1);
          p.add(b2);
          p.add(b3);
          p.add(b4);
          p.add(b5);
          p.add(b6);
          p.add(b7);
          p.add(l1);
          p.add(l2);
          p.add(tf1);
          p.add(tf2);
          p.add(ta);
          c.add(p);
          b5.addActionListener(new browseFile1());
          b6.addActionListener(new browseFile2());
          b7.addActionListener(this);
          b1.addActionListener(this);
                b2.addActionListener(this);
     class browseFile1 implements ActionListener
          public void actionPerformed(ActionEvent ae)
               JFileChooser fc=new JFileChooser();
               int fVal =fc.showOpenDialog(main_Form1.this);
               if(fVal == JFileChooser.APPROVE_OPTION)
                    System.out.println("APP 1");
                    tf1.setText(fc.getSelectedFile()+"");
               if(fVal == JFileChooser.CANCEL_OPTION)
                    tf1.setText("");
     class browseFile2 implements ActionListener
          public void actionPerformed(ActionEvent ae)
               JFileChooser fc=new JFileChooser();
               int fVal =fc.showOpenDialog(main_Form1.this);
               if(fVal == JFileChooser.APPROVE_OPTION)
                    System.out.println("APP 2");
                    tf2.setText(fc.getSelectedFile()+"");
               if(fVal == JFileChooser.CANCEL_OPTION)
                    tf2.setText("");
     public void actionPerformed(ActionEvent ae)
          if(ae.getSource().equals(b7))
          this.hide();
          if(ae.getSource().equals(b1))
               try
                    FileInputStream f1=new FileInputStream(tf1.getText()+"");
                FileInputStream f2=new FileInputStream(tf2.getText()+"");
                  FileOutputStream outStream = new FileOutputStream("file3.txt");
                  SequenceInputStream f3=new SequenceInputStream(f1,f2);
                  int c=0;
                while((c=f3.read())!=-1)
                         outStream.write((char)c);
                         System.out.println((char)c);
               catch(Exception e)
                    System.out.println(e+"f1 file nt found");
            File f=new File("file3.txt");
                    if(ae.getSource().equals(b2))
                              try
                        public void run()
                              // FileInputStream inStream = new FileInputStream("file3.txt");   
                        int c=0;
                        while((c=f3.read())!=-1)
                         ta.setText((char)c);
                         System.out.println("HaiAnju"+(char)c);
                                        Thread.sleep(1000);
                              }catch(Exception e){System.out.println(e+"Run Exception");}
     public static void main(String[] args)
          main_Form1 m1=new main_Form1();
          m1.show();
          m1.start();
          System.out.println("Hello World!");
        }

Similar Messages

  • Help reqd for coding to assign the  field as mandatory.

    HI all,
    I got the user exit and also assigned the component as "EXIT_SAPLMRIM_002"..im now here to create a code under the include program of "ZM08U09"....for to make the amount field as mandatory(obligatory)..with some pop-up message...
    how to do that....
    Do u people have any experience on this...pls post ur comments on urgent basis.
    thanks & regards
    sankar.

    Hi Sriram.P
    thanks for ur prompt reply
    ...but actually,my problem is...i dont know the exact table for miro (invfp-wrbtr showing in the screen)....i've already prepared some coding but the table i've mentioned is not the correct one...
    Do u know the table for Incoming invoices records (MIRO)
    thanks & regards
    sankar.

  • Help required for doing LIKE search in SQL

    Hello All,
    I have situation like below 
    DECLARE @TempTable TABLE (Name1 VarCHar(100), Name2 VarChar(100))
    INSERT INTO @TempTable(Name1, Name2)
    VALUES('_HASKAR','BHASK_R')
    SELECT * 
    FROM @TempTable 
    WHERE Name1 LIKE Name2
    Both the columns are having WildCard (underscores). How can I do like search so that the where condition will be TRUE?
    Regards,
    Amar Ankatha
    amar ankatha

    Hi,
    If I understand correctly, the position of H, A, S, K, R is fixed in the strings and you can use
    SUBSTRING function.
    DECLARE @TempTable TABLE (Name1 VarCHar(100), Name2 VarChar(100))
    INSERT INTO @TempTable(Name1, Name2)
    VALUES('_HASKAR','BHASK_R')
    SELECT *
    FROM @TempTable
    WHERE substring(Name1,2,4) = substring (name2,2,4) and right(Name1, 1) = right(Name2, 1)
    Thanks.
    Tracy Cai
    TechNet Community Support

  • Ran CATT Script for the role assignment to users

    Hi All,
    I have ran ECATT script for doing role assignment in QAS and completed successfully. I did this through CUA. What is the next step after running catt script? Do I need to doing anything with PFUD in each child system? Because I checked in the child systems many derived single roles are not generated in QAS.(RED). Is it because of running catt script or it might have came like that only from development? Please advise..
    Regards,
    Masood

    >
    Salman123 wrote:
    > Please let me know how should I proceed from here
    Hi,
    I have told you why the error message is there.  What do you not understand about the resolution? Your parent roles are out of sync with the child roles so you need to re-sync them.   An example of how do do this is to "adjust derived" from the master role.  Only when you have done this will your roles be in sync again.

  • Could someone help me with instructions for doing a clean install for iMac with mountain lion 10.8.4 ?

       Could someone help me with instructions for doing a clean install for Could someone help me with instructions for doing a clean install for an early 2009 iMac 20"  with Mountain Lion 10.8.4 ?
       Thank You,
                                leetruitt

       Barney,  William,  nbar, Galt\'s Gulch:
       A nephew stayed with us to take a course at the local community college last semester. I allowed him use of my mac for research just after I installed Mountain Lion. He decided to "help out" and ran a 3rd party clean and tune up app., Magician.  The tune up wiped over 1200 titles of my music in iTunes,  also a path of folders with names containing nothing but more empty folders with names. Almost every program I open and run for a short time crashes, also folders and programs are in wrong places, or cannot be located (the nephew, for instance). Up to this time I have always been able to track a problem far enough to resolve it by careful persistence and good luck, but I do not have the tech savvy to solve this one without getting in deeper. I have run disk utility saveral times and always get  variations of this:
    ACL found but not expected on
    "private/etc/resolve.conf"
    "private/etc/raddb/sites-enabled/inner-tunnel"
    "private/etc/rabbd/sites-enabled/control-socket"
         Also, after four years of intense daily use it is cluttered with much junk,  and every app that I was curious about, and I am a very curious guy.
       So I know my limits, (and now my nephew). I dumped my pc for a Strawberry iMac a few years ago, and so far every problem I've encountered, or brought on myself, the Mac has resolved with its own inner elegance - in spite of my novice bungels - and now I honestly feel ashamed, in addition to the need to apologize to a machine for allowing a peasant into the Royal Grounds - so I am calling the Wise Ones in for this one.
       Crazy, I know, but to me a Mac represents something far beyond the ordinary  input ➛ process  ➛ output  title/function customarily assigned to a machine - I sense an odd kind of morality involved, one that I need to respect.
        So, these are my reasons for wanting to do a clean install, correctly.
            Thank you,  Truitt

  • HT3986 I installed windows 7 to my macbook pro, but my mousepad does not work in windows 7 and also i can not connect my windows 7 to projector, but i can use my macbook's mouse pad and i can connect my mac to projector,so please help me for windows 7 pro

    I installed windows 7 to my macbook pro, but my mousepad does not work in windows 7 and also i can not connect my windows 7 to projector, but i can use my macbook's mouse pad and i can connect my mac to projector,so please help me for windows 7 problem

    i try to download now, do you think when i download and install the windows support software, can i fix the problem?

  • HT1766 I have restored my new phone from I cloud but when I connect to my PC to put some music on it asks for  set up as new phone or back up from a date from iTunes that is too old. Help it's doing my head in

    I have restored my new phone from I cloud but when I connect to my PC to put some music on it asks for  set up as new phone or back up from a date from iTunes that is too old. Help it's doing my head in

    Select setup as "New", the next screen should prompt you to rename your phone. Just name it what you already have it named. After that, you should be able to sync and all of your data & settings will still be exactly as you've already set them up on your phone. The message is more threatening than what really happens.

  • Hello everyone! I'm having a trouble... I need to download Adobe Illustrator for windows 8, but i'm not able for doing that. Can you help me Please?

    Hello everyone! I'm having a trouble... I need to download Adobe Illustrator for windows 8, but i'm not able for doing that. Can you help me Please?

    Downloadable installation files available:
    Suites and Programs:  CC 2014 | CC | CS6 | CS5.5 | CS5 | CS4, CS4 Web Standard | CS3
    Acrobat:  XI, X | 9,8 | 9 standard
    Premiere Elements:  13 | 12 | 11, 10 | 9, 8, 7 win | 8 mac | 7 mac
    Photoshop Elements:  13 |12 | 11, 10 | 9,8,7 win | 8 mac | 7 mac
    Lightroom:  5.7.1| 5 | 4 | 3
    Captivate:  8 | 7 | 6 | 5.5, 5 | 1
    Contribute:  CS5 | CS4, CS3 | 3,2
    FrameMaker:  12, 11, 10, 9, 8, 7.2
    Download and installation help for Adobe links
    Download and installation help for Prodesigntools links are listed on most linked pages.  They are critical; especially steps 1, 2 and 3.  If you click a link that does not have those steps listed, open a second window using the Lightroom 3 link to see those 'Important Instructions'.

  • I can't redeem my iTunes gift card, my phone is un activated, help desk has not helped. What does it mean my phone is un activated and how can I redeem my gift card for my 5c living I. The Caribbean

    I can't redeem my iTunes gift card, my phone is un activated, help desk has not helped. What does it mean my phone is un activated and how can I redeem my gift card for my 5c living I. The Caribbean

    (Typing all in capitals is considered shouting, makes posts difficult to read and may mean that people are less likely to reply.)
    There isn't a phone number for iTunes Support.
    If you've forgotten your answers to your security questions then you can get them reset : If you forgot the answers to your Apple ID security questions
    If you have a credit card on your account then its details have to complete - and asking for their details is also a way of checking that you have a valid billing address in that country. As long as you are buying content for yourself and not trying to gift content (you can't use your balance for gifting) then the purchase price (plus any applicable taxes) should be deducted from your balance. If it's not then you contact iTunes Support :  http://www.apple.com/support/itunes/contact/ - click on Contact iTunes Store Support on the right-hand side of the page, then Purchases, Billing & Redemption

  • I´m doing a design for presale, where I will need a router what support PAT for 500 or a little more of users, it not need any more features only static routing and dhcp pool for 500 users, can you help me for know what router recommend?

    I´m doing a design for presale, where  I will  need a router what support PAT for 500 or a little more of users, it  not need any more features only static routing and dhcp pool for 500 users, can you help me for know what router recommend?

    What is your WAN speed currently and projected WAN speed in the next 3 years?

  • I have tried to cancel my contract for acrobat pro subscription, but when I follow the instruction, I only get circled around. Also on the phonme I never get an answer. Can you help me? Does anyone have a fax address where I could place my cancellation ?

    I have tried to cancel my contract for acrobat pro subscription, but when I follow the instruction, I only get circled around. Also on the phonme I never get an answer. Can you help me? Does anyone have a fax address where I could place my cancellation ?

    Cancel http://helpx.adobe.com/x-productkb/policy-pricing/return-cancel-or-change-order.html
    -or by telephone http://helpx.adobe.com/x-productkb/global/phone-support-orders.html

  • Task 0085 for parallel SID assignment terminated with errors

    Hi,
    While activating the ODS object we are getting the following error
    Task 0085 for parallel SID assignment terminated with errors
    Can anyone help me on this issue.
    Thanks
    Sheela Datla

    Hi Sheela,
    Does the problem happen with activating the ODS object (definition) itself or with activating the data in the
    ODS? I think that there must be other errors apart from Task 0085. At the time of the error you should check in
    sm21 and st22 for additional error messages and dumps. If the problem is with the activation of data in the ODS
    you should also check sm37 for the job that is created for the ODS activation , you may find more detailed
    information in the job log. You should also check the activation step in the 'Details' TAB in the monitor for
    the load there may also be more detailed information here.
    In transaction rscusta2 (ODS customizing) you should try the following setting for the activation:
    No. of Par. Proc.    3          
    Min. No. Data Recs.  10000     
    Wait Time in Sec.      600
    Before changing the values you have in RSCUSTA2 please take note of the values you have already in
    case you want to change them back.
    Best Regards,
    Des.

  • Fi Document is not generating in MIGO for multiple account assignment in PO

    Hi,
    I have have created  asset po DG set 111 quanity is 4, i have created 4 different assets and assign quanity 1 to each dg sets in account assignment. While doing GRN system is not generating FI document for this po. if  i am giving one quanity or single account assignment for as 4 then it is generating FI quantity.
    PLease help me out why system is not generating FI document for multiple accont assignment in MIGO.
    Thanks in advance
    KISHORE

    Hi
    There is no option if you are not on EhP4... Do MIRO and see if the FI doc is generated
    Only way is to do MIRO immediately after MIGO.. OR Schedule ERS (Evaluated Receipt Settlement) which runs every hour in the background so that MIRO is posted automatically based on MIGO document.... Basically, you have to do MIRO after MIGO.. Whether you do it manually or through ERS is a matter of choice
    Regards
    Ajay M

  • DHCP server does not assign IP addresses SG500 firmware 1.3.5

    good day collegues
    has any of you come across the following issue:
    my switch (after upgrading to the newest firmware 1.3.5) does not assign IP addresses to some of the hosts.
    after a couple of hours I managed (do not even how) to force my switch to assign IP addresses only to some of the hosts.
    still some of them cannot get the IP address and remain with "funny" IP address like i.e. 169.254.100.100
    additional info
    1. if I boot my switch with the previous version of firmware (1.3.0.6) everything is OK. all my hosts get correct IP addresess
    2. the hosts which do not get IP address were perviously entered in stat host table - now removed, ARP cleared, etc, everything many many times rebooted.
    I ran out of ideas, could you pleae give me some hints ?
    the config below:
    config-file-header
    SG500
    v1.3.5.58 / R750_NIK_1_35_647_358
    CLI v1.0
    set system mode router queues-mode 4
    file SSD indicator encrypted
    ssd-control-start
    ssd config
    ssd file passphrase control unrestricted
    no ssd file integrity control
    ssd-control-end zzz
    no spanning-tree
    vlan database
    vlan 11,13-14
    exit
    voice vlan oui-table add 0001e3 Siemens_AG_phone________
    voice vlan oui-table add 00036b Cisco_phone_____________
    voice vlan oui-table add 00096e Avaya___________________
    voice vlan oui-table add 000fe2 H3C_Aolynk______________
    voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
    voice vlan oui-table add 00d01e Pingtel_phone___________
    voice vlan oui-table add 00e075 Polycom/Veritel_phone___
    voice vlan oui-table add 00e0bb 3Com_phone______________
    no ip dhcp snooping verify
    ip dhcp snooping information option allowed-untrusted
    ip dhcp snooping vlan 11
    ip dhcp snooping vlan 13
    ip dhcp snooping vlan 14
    ip arp inspection logging interval infinite
    green-ethernet energy-detect
    no eee enable
    arp timeout 1
    ip dhcp server
    ip dhcp pool host q409
    address 10.10.11.2 255.255.255.0 client-identifier 01:00:08:9b:ac:8f:92
    default-router 10.10.11.254
    dns-server 10.10.10.1
    exit
    ip dhcp pool host PCH-100
    address 10.10.11.10 255.255.255.0 client-identifier 01:00:06:dc:41:ef:ef
    default-router 10.10.11.254
    dns-server 10.10.10.1
    exit
    ip dhcp pool host q209
    address 10.10.13.3 255.255.255.0 client-identifier 01:00:08:9b:ac:72:ba
    client-name q209
    default-router 10.10.13.254
    dns-server 8.8.8.8
    exit
    exit
    ip dhcp pool network HOME
    address low 10.10.11.1 high 10.10.11.254 255.255.255.0
    lease infinite
    default-router 10.10.11.254
    dns-server 10.10.10.1
    exit
    ip dhcp pool network GUESTS
    address low 10.10.14.1 high 10.10.14.254 255.255.255.0
    lease infinite
    netbios-node-type b-node
    default-router 10.10.14.254
    dns-server 10.10.10.1 62.233.233.233
    exit
    ip dhcp relay address 10.10.10.1
    ip dhcp relay address 10.10.11.254
    ip dhcp relay address 10.10.13.254
    ip dhcp relay address 10.10.14.254
    no boot host auto-config
    no qos
    qos advanced-mode trust dscp
    qos wrr-queue wrtd
    exit
    hostname SG500
    line telnet
    exec-timeout 0
    exit
    logging buffered debugging
    no logging file
    aaa authentication login Telnet local
    aaa authentication enable Telnet enable
    aaa authentication dot1x default none
    line telnet
    login authentication Telnet
    enable authentication Telnet
    password 999 encrypted
    exit
    no passwords complexity enable
    passwords aging 0
    username 999 password encrypted 999 privilege 15
    ip http timeout-policy 0 http-only
    clock timezone " " 1
    clock summer-time web recurring eu
    clock source sntp
    clock source browser
    sntp unicast client enable
    clock dhcp timezone
    ip domain name 999
    ip name-server  10.10.10.1 62.233.233.233 8.8.8.8
    ip host 999 10.10.13.3
    ip telnet server
    no service mirror-configuration
    no security-suite deny syn-fin
    security-suite syn protection mode disabled
    interface vlan 1
    ip address 10.10.10.254 255.255.255.0
    no ip address dhcp
    interface vlan 11
    name HOME
    ip address 10.10.11.254 255.255.255.0
    ip dhcp relay enable
    interface vlan 13
    name DMZ
    ip address 10.10.13.254 255.255.255.0
    ip dhcp relay enable
    interface vlan 14
    name GUESTS
    ip address 10.10.14.254 255.255.255.0
    ip dhcp relay enable
    interface gigabitethernet1/10
    description "(99) QNAP 409"
    switchport trunk native vlan 11
    exit
    macro auto disabled
    macro auto processing type host enabled
    macro auto processing type ip_phone disabled
    macro auto processing type ip_phone_desktop disabled
    macro auto processing type router enabled
    mac address-table aging-time 10
    ip default-gateway 10.10.10.1
    snmp-server set  999 permit

    Hi Andbor, please make a backup config of your file, factory reset the switch.
    After this, manually configure a DHCP scope without any other configuration.
    Just something simple like this
    ip dhcp pool network GUESTS
    address low 10.10.14.1 high 10.10.14.254 255.255.255.0
    lease infinite
    netbios-node-type b-node
    default-router 10.10.14.254
    dns-server 10.10.10.1 62.233.233.233
    Verify your machine receive IP address with no other configuration.
    In some ways, I'm afraid some of your connections black listed due to the arp inspection.
    -Tom
    Please mark answered for helpful posts

  • Help URL for ESS web dynpro applications

    Hi gurus,
      I am trying to assign help URL for a standard ESS iView( Record working time).
      When i go to the iView properties i have property showhelp. I have the same property for the page record working time.
      When i set this property to yes at the page level the help option shows up and whn i set this at the iView level the help option does not show up ( in the right hand corner of the page or iView)
      My main question... how do i set up the help url for this help. becuase even for page when i click on help it says "no help found"
      I want to give a URL for this help link.
       Any thoughts on why this option is not popping up when i set the show help option for iView and how to enable the help URL for iView as well.
       Appreciate any help on the same.
    regards
    Sam

    The Help option should show up in the iview tray if you set it at the iView level.  Im not sure why that part isnt working for you.
    For the iView help, you can set the property URL to Help Topic property on the iview or page. 
    If your version doesnt have this property, you can use the PCD inspector (available under system administration>Support>Portal Content Directory-->PCD Inspector).  Browse to the iview, click on prop editor, click the Switch to PCM property.  Edit the com.sap.portal.iview.HelpUrl and enter your help url.
    Hope this helps-
    Marty
    Message was edited by:
            Marty McCormick

Maybe you are looking for

  • How do I add a forum to me site using iweb 08?

    I have all the sources such as i web 08, mobile me account and my own domain name website all set up and running fine. I would like to add a forum where people can add comments and pictures. How can I do this?

  • Mapping attributes to elements

    Hi, I have a file that looks similar to this...(I've simplified it for the post) <XPacket>    <XField Type="integer" Name="SerialNumber">13781</XField>    <XField Type="string" Name="Mfr">Johnson</XField>    <XField Type="XPacket" Name="Counters">   

  • Error with IT0008

    hi all, im trying to create 0008 for a pernr and i get the mesg saying No entry in table T510 for the key 1001RR3MGR     00 on 05.05.1991 i maintained the payscale type, area, group and level and checked the above table. could someone suggest where i

  • WPA connection problems

    I tried connecting to my home network, which is protected with a WPA password - however, i forgot what it was and typed in an incorrect one 3 times before checking from the keychain access what it should be. Unfortunately, when i now go on to join th

  • Microsoft Word chewing up CPU!!!

    I can't find an appropriate forum for this, so here goes... I'm trying to edit a document in Microsoft Word and it's chewing up my CPU. In less than a minute, the fan comes on at full speed. If I scroll up or down, for example, I sometimes have to wa