How to display features to different login authentication levels?

I am not too well versed in dreamweaver.  I have created a user login system with different levels of security access (users and administrators).  I want to be able to have the same pages display different links and data based on what they are logged in as.  This would be via PHP.  Is there any tutorials or resources that would help me do so?

The best tutorial for you would be one that starts at the beginning. Trying to implement security features by copying and pasting code from a tutorial without understanding the fundamentals of the language is not a good way to start. Once you've learned the basics, you'll be able to figure out what you want to do by yourself. At a minimum, you need to learn PHP syntax and control structures (which makes up the bulk or your question).  It's not hard, and if you have any prior programming experience, it's much easier.
Lots of good info on the web, here's one example.
https://phpacademy.org/videos/learn-php

Similar Messages

  • How can I set up SSL login authentication on one domain for multiple domains

    Our site currently runs in 22 countries with 22 different
    country domains:
    www.mysite.com
    www.mysite.co.uk
    www.mysite.fr
    etc
    We want to use SSL on our login pages but realise that the
    cost of certification for every domain is expensive. One solution
    would be to channel all login activity to a single domain, eg:
    www.mysite.com/login.cfm?site=fr which would then redirect to
    www.mysite.fr – this is how Google do it
    But, currently we are using encrypted cookies for login
    authentication so we would have the problem of having to transfer
    the cookie info across domains securely. Is there any way of going
    about this?
    Any other suggestions would be great, too. We do plan to move
    to session management for logins but this is a longer term project
    so we are hoping to sort out the SSL prior to that.

    Can you not pass the values you need as URL parameters?
    Encrypt them befor you send them and then decrypt them on the new
    domain. Then add them to whatever place you need (cookie, session,
    etc.)?

  • How to run MRP on different storage location level ?

    Dear Experts,
    Need your valuable guidance to solve the below requirement form the client-
    1) My client want to enter a "safety stock level" for one spare part/ Material on the basis of individual storage locations.
               For sake of example: in SL01 he wants the safety stock for particular material set to 5
                                  In FS18 he wants the safety stock set to 2
                                  In FS15 he wants the safety stock set to 1
    Kindly tell me whether it is possible? & guide me how to do it.
    2) Also tell me how to run MRP on a storage location level?
               This is because after maintaining different safety stocks for one material in different storage locations,  is it possible to appear each storage location with their differing safety stock levels?
    I checked the MRP type maintained & its-1 (plant) & not as- 2 (storage location).
    Kindly guide me for the above issue
    Thanks in advance for your support.
    Regards,
    Mehul

    Hi Umashanker,
    Thanks for your suggession . Accordingly I have resolved the issue.
    Regards,
    Mehul

  • How to display data in different xl sheets-urgent

    hi all,
    i have an urgent requirement. any body can send me the sample code to display the data in different xlsheets.
    thanks,
    maheedhar.t

    Hey do like this.
    CALL FUNCTION 'MS_EXCEL_OLE_STANDARD_DAT'
      EXPORTING
        file_name                       = 'C:SAMitab1.xls'
        DATA_SHEET_NAME                 = 'First internal table'
      TABLES
       DATA_TAB                        = itab1
       FIELDNAMES                      = fldnm1
    * EXCEPTIONS
    *   FILE_NOT_EXIST                  = 1
    *   FILENAME_EXPECTED               = 2
    *   COMMUNICATION_ERROR             = 3
    *   OLE_OBJECT_METHOD_ERROR         = 4
    *   OLE_OBJECT_PROPERTY_ERROR       = 5
    *   INVALID_PIVOT_FIELDS            = 6
    *   DOWNLOAD_PROBLEM                = 7
    *   OTHERS                          = 8
    IF sy-subrc <> 0.
    * MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    *         WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.
    CALL FUNCTION 'MS_EXCEL_OLE_STANDARD_DAT'
      EXPORTING
        file_name                       = 'C:SAMitab2.xls'
        DATA_SHEET_NAME                 = '2nd internal table'
      TABLES
       DATA_TAB                        = itab2
       FIELDNAMES                      = fldnm2
    * EXCEPTIONS
    *   FILE_NOT_EXIST                  = 1
    *   FILENAME_EXPECTED               = 2
    *   COMMUNICATION_ERROR             = 3
    *   OLE_OBJECT_METHOD_ERROR         = 4
    *   OLE_OBJECT_PROPERTY_ERROR       = 5
    *   INVALID_PIVOT_FIELDS            = 6
    *   DOWNLOAD_PROBLEM                = 7
    *   OTHERS                          = 8
    IF sy-subrc <> 0.
    * MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    *         WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.
    Reward points if useful...
    Cheers,
    Sam

  • How to display DVD timecode to the frame level?

    I know you can advance frame by frame with (assumes DVD
    object is called "mydvd")
    member("mydvd").frameStep(1)
    but.......how do see what frame you see the frames in the DVD
    controller object?
    The DVD object only shows to the nearest sec it seems. Can I
    change this or make a text field that will do it?
    When doing trace (member("mydvd").currentTime), the command
    only shows to the nearest sec. (even though it has the "00" and the
    end for frames.....example 115 sec. = 11500
    I tried this for a custom text field:
    member("mytextfield").text = "" &
    member("mydvd").currentTime
    but this does not work ....it gives an error I was kind of
    expecting to see at least the results of a trace command
    It is strange that you can control a DVD frame by frame by
    not view the frame you are actually on...there has to be a way
    right?
    any help would be great!!!
    thanks

    Anybody have any ideas on this?
    I was thinking that if I could get below to work:
    member("mytextfield").text = "" &
    member("mydvd").currentTime
    then I could create a button that would step a frame and
    would make the text result, (text result + 1) to show a somewhat
    more accurate timecode as I click.
    However this could be off as much as 29 frames if the
    playhead was at 04 sec 29 frames and it reported back 04 sec. as I
    believe it does (at least for reporting back timecode)
    any ideas on you to read the DVD timecode and place into a
    text field....wish I could just add frames feature to the DVD
    control component.
    Kyle

  • How to display error documents in selection screen level

    Hi,
      Currently Iam doing Smartforms for journal voucher. Iam taking multiple documents as input and displaying relavent item data for each.
    Now, my requirement is i want to display invalid document numbers at selection screen level. For example there are 30 invalid document number i want to display them before start-of-selection.
    Thanks in advance,
    Regards,
    Chinna..

    i have a query......say i am using a selet-options s_ebeln for ekko-ebeln.
    i want to display error messages for
    1>lower limit cant be greater than upper limit?
    2>for special cahracters given in the select-options fields.....etc...
    now when i am writing the code......
    if s_ebeln-low gt s_ebeln-high.
    message e001.
    it is showing SAP's message not mine.
    but ....if my s_ebeln-high field is 0.
    then my message is showing.
    pls give me the codes for these?

  • CK13N How to display Costing for a product with level as the transaction IH

    Hello to all:
    When I calculate the cost of a product, in the transaction CK13N I use the button Costing Stucture On to display the detail by item but there is no level notion.
    I would like to display the cost like in hte transaction IH05, depending of the level in the bom.
    Is somebody know a mean to do that.
    Thanks in advance.
    Regards.
    Jean-marc

    Hi Jean
    With "Print preview of entire hierarchy", what I see in my system is exactly what you want
    What i did is this
    1. Execute CK11N for p1
    2. Do not click on Costing Str on or off
    3. SImply click on the printer icon as i said and "Print preview of entire hierarchy"
    What I see is
    P1
    Under P1, I see
    AS1
        - C2
        - C3
    C1
    Regards
    Ajay M

  • Not able to display data in different columns using Unicode encoding

    Hi,
    Iam using Unicode encoding in my Java appln to support Japanese characters while downloading CSV report. But using the Unicode encoding displays all data in the first column of Excel sheet.
    Please let me know how to display data in different columns using Unicode encoding in Excel sheet.

    Hi Venkat,
    After extracting data into DSO check the request whether active or not.
    Check data in DSO in contents.
    If is there any restrictions on info providers in Queries.
    Let us know status clearly.......
    Reg
    Pra

  • How to display value in two rows?

    Hi,
    There are two column value in db which will be displayed in on table cell.
    How to display them in different row in the same cell?
    thanks!
    Beavey

    Hi Saichand.V,
    Thank you for your replay!
    I try it, but the layout is not right.
    I using the following method:
    Using "Edit Formula" in table, then "Column Formula" is set as "CONCAT(CONCAT('Facility: ',PRO_M_FACILITY.ABBR_NAME), CONCAT('<&#13;>Department: ',PRO_M_DEPARTMENT.DEPARTMENT_NAME) )". I want to use "<&#13;>" to display "Department: XXXXXXX" in the second row, but it also does not work.
    Regards,
    Beavey
    Edited by: Beavey on Dec 6, 2009 4:37 PM

  • HT204053 Just updated my login to apple on mac but ipad still displaying old email for login.  Anyone know how to update ipad to new login details?

    Just updated my login to apple on mac but ipad still displaying old email for login.  Anyone know how to update ipad to new login details?

    Hello Beeched,
    Thank you for the question.  Are you seeing the previous Apple ID in the iTunes and App Store?  If you are, use these steps to sign in with your new Apple ID:
    Sign in with a different Apple ID
    Tap Settings > iTunes & App Stores.
    Tap your Apple ID.
    If you see the option to Sign In, you can change your Apple ID now.
    Tap Sign Out.
    Enter your Apple ID and Password and tap Sign In.
    Or if you don't have another Apple ID, tap Create New Apple ID.
    You can find the full article here:
    iOS: Sign in with a different Apple ID in the iTunes Store, App Store, and iBooks Store
    http://support.apple.com/kb/ht1311
    If you trying to change the Apple ID signed into iCloud, use these steps:
    On your iOS device’s Home screen, go to Settings > iCloud, then at the bottom of the screen, tap Delete Account.
    iCloud: Change iCloud feature settings
    http://support.apple.com/kb/PH2613
    Once you delete the account from your device, you will have an option to sign in with your new Apple ID in Settings>iCloud.
    Thank you for using Apple Support Communities.
    Best,
    Sheila M.

  • How to set up local server to use a remote server for login authentication?

    Thank you in advance for any help you can offer.
    We are trying to set up a "sub-network" (dont' know if this is the right terminology) using a 10.4 Server OS, to manage a set of clients... the trick is that the client login/home directory information is on a different remote server, and shall remain there, for the most part.
    To make it easy to understand here's the environment:
    *Local Server:* 10.4 G4 Server Quicksilver 1G dual--we have total control of this one
    *Main/remote server:* 10.5 Xserve.. don't know which vintage--we have very very very little input on this machine.. effectively at the mercy of the sysadmin of this system who is very conservative in changing anything (hence the need for a separate server to install applications and client machine-specific profiles, etc since the Xserve admin refuses do it). This serves MacBooks/MacBookPros and few iMacs. (no Windows PC.. as that group of comptuers have their own server)
    client: ~20 eMacs/iBooks all running 10.4.
    use environment: elementary school-->very low network demand (no e-mail, just running local apps linking to server(s) for licensing and login, and some file saving small files on remote server, user preferences, etc).
    The remote server (the Xserve) has all the login authentication, as well as the home directories. every school year, the directories get updated as new students enroll and old students graduate. Currently all the clients are directly linked to the Xserve via LDAP while we bring the local server on-line.
    the local sever (our G4 Quicksilver) will have few network applications that will support the client machines. We also will be setting up computer accounts and groups for our clients so that we can properly set their environments (the Xserve admin will not do this on the Xserve, so currently all the clients are connecting to the server as a "guest computer" from what little I understand watching what was done)
    now, what is the best way to approach this type of set up with minimal "inconvenience" of the Xserve admin?
    I am pretty experienced with standalone UNIX and macOS X administration, but a novice to this whole Server and network setup thing. Any suggestions, instructions, pointers to URLs with how-tos is much appreciated. I am not afraid to use Terminal (grew up on UNIX before GUI), etc., and willing to try safe but unconventional setups if that is what's needed...
    thanks for any help!

    Oh never mind.... I figured it out myself helps to read up on the manuals. d'oh. sorry for the bandwidth waste...

  • How to display the header data on different position in alv report

    hi all,
    how to display the header data on different position in alv report.
    for example ,
    customer                                                   name
      xxxx                                                         xxxx
                     vendor        name     street 
                      xxxx         xxxx      xxxxx
    pls   help me .

    hi
    as per my understanding you need to trnasfer header internal table data  to pdf..
    please check the following links for internal table to pdf..
    Convertion of Internal table data to PDF
    This link is related to ur issue
    Re: how to insert the calling of the FM: OTF to PDF
    Thanks

  • How can my wife and I share cloud with 2 different login's

    How can my wife and I share cloud with 2 different login's

    If you each have separate iCloud accounts with different IDs, you can add the other person's account to your device(s) by going to Settings>Mail,Contacts,Calendars>Add Account>iCloud and signing in with their ID.  These "secondary accounts" will sync mail, contacts, calendars, reminders and notes.

  • How can I access a response file on the same computer but with different login?

    When trying to access a response file on the same computer that was used to set it up, but with a different login, I get an error message that the network resource was not found. How can I retrieve the responses on the same computer but under a different login/username?

    The response file is associated with a specific login (as determined under Edit > Preferences > Identity) so you cannot retrieve it if you're using a different login.

  • How to use 2 AAA server for different login purpose

    Hello, could you help me?
    This is a part of my configuration; I would like to add another TACACS server, witch should take care of the telnet at vty 0 4.
    The Tacacs server 10.20.30.40 takes care of the virtual access, and I have another Tacacs server who takes care of login on our network equipment.
    ! Cisco 7204 with system flash c7200-io3s56i-mz.121-4.bin
    aaa new-model
    aaa authentication login default group tacacs+
    aaa authentication login no_tacacs enable
    aaa authentication ppp default group tacacs+
    aaa authorization exec default group tacacs+
    aaa authorization network default group tacacs+
    aaa accounting exec default start-stop group tacacs+
    aaa accounting network default start-stop group tacacs+
    aaa accounting connection default start-stop group tacacs+
    virtual-profile virtual-template 1
    virtual-profile aaa
    interface Serial2/0:15
    description ISDN30
    no ip address
    encapsulation ppp
    no ip route-cache
    no keepalive
    dialer pool-member 10
    isdn switch-type primary-net5
    isdn tei-negotiation first-call
    isdn caller xxxxxxx
    no fair-queue
    compress stac
    no cdp enable
    ppp authentication chap
    ppp multilink
    interface Virtual-Template1
    ip unnumbered FastEthernet1/0
    ip nat outside
    ppp authentication chap
    tacacs-server host 10.20.30.40 key ********
    line con 0
    exec-timeout 20 0
    password ************
    login authentication no_tacacs
    transport input none
    flowcontrol hardware
    line aux 0
    line vty 0 4
    access-class 1 in
    exec-timeout 60 0
    password *************
    login authentication no_tacacs
    transport input telnet
    transport output telnet
    If I just add
    aaa authentication login vtymethod group tacacs+ enable
    tacacs-server host 10.50.60.70 key ********
    line vty 0 4
    login authentication vtymethod
    My telnet request ask 10.20.30.40 and I have a deny! Could you help to make a secure solution?
    Thanks

    Jens
    I believe that your solution would be to configure a different tacacs server group with the new server in the new group and to use the new group to authenticate for your vty. The config might look something like this:
    aaa group server tacacs+ vty_TAC
    server 10.50.60.70
    aaa authentication login vtymethod group vty_TAC enable
    tacacs-server host 10.50.60.70 key ********
    I have configured this type of thing and it worked well. When I configured it I explicitly configured (and named) two different TACACS server groups and referenced specific server groups for each authentication method. I am not clear whether it works to keep the default group tacacs+ and use it for your normal authentication or whether you may need to configure a non-default group for it.
    Give it a try and let us know what happens.
    HTH
    Rick

Maybe you are looking for

  • Purpose of debug class and limits in pipelinesession

    Hi What is the purpose of debug class(com.bea.p13n.util.debug.Debug)? I found it in an InputProcessor. Also I am unable to find the javadocs for it. My next question may seem trivial, but is there any limitation to the number of attributes that can b

  • Video scaling worse in FCP5.1 than in Quicktime 7 ?!

    i have some footage shot on the Phantom 5.1 camera. it is at a custom resolution: 768x1024 (portrait format) / square pixel aspect ratio / 25fps / Photo-JPEG compressor / not interlaced i'm trying to downscale it to PAL to make a standard definition

  • Battery life seems diminished after 10.6.3 update

    My battery power seems to be diminished quite a bit since the 10.6.3 update. I used to get between 3 and 4 hours when just web surfing and email (nothing else active) and the screen brightness turned down to about 60%. Since the update I'm getting cl

  • FInder crash when viewing Preferences folder

    I am getting a repeatable Finder crash when scrolling through my User/Library/Preferences folder. This happens when in Column view. Finder does not crash when in Icon or List view. I did get one crash when in CoverFlow view, but it took a lot of scro

  • Programs automatically open last several documents - causing serious lag and confusion.

    Since upgrading to Lion (clean install of 10.7.3), I've noticed that many programs have some extreme lag.  Programs that used to love because they were so fast (like preview) now take up to 45 seconds of spinning pinwheels before opening.  I've also