How to Implement BW in IT Service Desk/IT Help Desk /IT Complain Surveillance Dept/IT Customer Support Dept?

Hi
If a organization have 200 to 300 daily complains of there IT equipment/Software/Network e.t.c.
How to Implement BW in IT Service Desk/IT Help Desk /IT Complain Surveillance Dept/IT Customer Support Dept?
Is there any standard DataSources/InfoObjects/DSOs/InfoCubes etc. available in SAP BI Content?

Imran,
The point I think was to ensure that you knew exactly what was required. A customer service desk can have many interpretations from a BI perspective.
You could have :
1. Operational reports - calls attended per shift , Average number of calls per person , Seasonality in the calls coming in etc
2. Analytic views - Utilization of resources , Average call time and trending , customer satisfaction , average wait time
3. Strategic - Call volumes corresponding to campaigns etc , Employee churn and related call times
Based on these you would then have to construct your models which would be populated by data from the MySQL instance for you to report.
Else if you have BWA you could have data discovery instead or if you have HANA - you could do even more and if you have a HANA sidecar - you technically dont need BW. The possibilities are virtually endless - it depends on how you want to drive it and how the end user ( client ) sees value in the same.

Similar Messages

  • How to implement a call back service?

    hi all,
    i have a method which calls a particular function module. i want to achieve the following two things in the code:
    1. after calling the function module, i want the program flow to get paused - it should wait for a notification from the function module to proceed further.
    2. the function module should send a call back to the method intimating that it is done with the job.
    due to the scenario, synchronous call wil not solve the purpose. i need to use explicit wait and notificaion / call back service.
    any help would be greatly appreciated. thank you.
    rgds,
    ram

    Hello. Have you taken a look at  CALL FUNCTION ... STARTING NEW TASK ...
    See example below. Regards, Peter
    DATA: INFO LIKE RFCSI,
    Result of RFC_SYSTEM_INFO function
          SEMAPHORE(1) VALUE SPACE,    "For WAIT condition
          MSG(80)      VALUE SPACE.    "Handling of exceptions
          RET_SUBRC LIKE SY-SUBRC.     "Handling of SUBRC
    CALL FUNCTION 'RFC_SYSTEM_INFO'
         STARTING NEW TASK 'INFO'
         DESTINATION 'NONE'
         PERFORMING RETURN_INFO ON END OF TASK
         EXCEPTIONS
             COMMUNICATION_FAILURE = 1 MESSAGE MSG
             SYSTEM_FAILURE        = 2 MESSAGE MSG.
    IF SY-SUBRC = 0.
      WRITE: 'Wait for reply'.
      WAIT UNTIL SEMAPHORE = 'X'.
      IF RET_SUBRC <> 0.
         WRITE MSG.
      ELSE.
        WRITE: / 'Destination =', INFO-RFCDEST.
      ENDIF.
    ELSE.
      WRITE MSG.
    ENDIF.
    FORM RETURN_INFO USING TASKNAME.
      RECEIVE RESULTS FROM FUNCTION 'RFC_SYSTEM_INFO'
          IMPORTING  RFCSI_EXPORT = INFO
          EXCEPTIONS
             COMMUNICATION_FAILURE = 1 MESSAGE MSG
             SYSTEM_FAILURE        = 2 MESSAGE MSG.
      RET_SUBRC = SY-SUBRC. "Set RET_SUBRC
      SEMAPHORE = 'X'. "Reset semaphore
    ENDFORM.

  • How to implement "press any key to continue",please help

    my problem is when the "press any key to close the dos" has displayed in the dos , how can realize to close the dos when i press any button.
    i have try to use system.in.read();but this method doesn't end until i press the "enter"button.

    public class P {
         public static void main(String[] args){
              System.out.println("XXX");
              System.out.println("press any key to close&#65281;");
    //want to System.exit(0) when user type the any key.
              BufferedReader stdin = new BufferedReader(new InputStreamReader(System.in));
              try {
                   int ch = stdin.read();
                   if(ch !=-1){
                        System.exit(0);
              } catch( Exception e ){
    i run this programe by wrote "java P" in the XXX.bat
    Edited by: azhi on Mar 4, 2008 5:23 AM
    Edited by: azhi on Mar 4, 2008 5:29 AM

  • How to implement the FigureThing, AnimatedThing, and Animatible. HELP!!!!

    FigureThing Specification
    abstract class FigureThing implements Cloneable
    // Overviews:
    // FigureThing is an abstraction of a figure object.
    // This class is abstract and must be overridden by a subclass.
    // FigureThings are mutable and cloneable.
    // A typical FigureThing consists of a set of properties:
    // {location, color, shape, size}
    public FigureThing()
    // effects: Initializes this with a random color
    // such that its location is (0, 0).
    public abstract void draw(Graphics g);
    // effects: draws this onto g
    public abstract boolean hitTest(Point pt);
    // effects: returns true if the point pt lies inside the bounding rectangle
    // of this. Returns false otherwise.
    public abstract Rectangle getBounds();
    // effects: returns the bounding rectangle of this.
    public abstract void setSize(int width, int height) throws ImpossibleSizeException;
    // modifies: this
    // effects: Resizes this so that its bounding rectangle has width
    // <width> and height <height>,
    // unless this cannot be resized to the specified dimension
    // => no modifications to this, throw ImpossibleSizeException.
    // (the exception suggests an alternative dimension
    // that is supported by this)
    public Object clone() throws CloneNotSupportedException
    // effects: standard clone operator
    public Point getLocation()
    // effects: returns the top left corner of the
    // bounding rectangle of this.
    public void setLocation(Point pt)
    // modifies: this
    // effects: moves this to pt, i.e. this.getLocation()
    // returns pt after call has completed.
    public Color getColor()
    // effects: returns this's color
    public void setColor(Color c)
    // modifies: this
    // effects: sets this's color to be c
    AnimatedThing Specification
    abstract class AnimatedThing extends FigureThing implements Animatible
    // Overviews: An AnimatedThing is a FigureThing with an additional property:
    // velocity. Thus, a typical AnimatedThing is
    // {location, color, shape, size, velocity}
    AnimatedThing()
    // effects: Initializes an AnimatedThing object in a similar way to
    // initializing a FigureThing object. Each of the horizontal
    // and vertical velocities of the new object is set to a random
    // integral value i s.t. -3 <= i <= 3 and i != 0
    public void setVelocity(int vx, int vy)
    // modifies: this
    // effects: Sets the horizontal velocity of this to vx and
    // the vertical velocity of this to vy.
    public int getHVelocity()
    // effects: Returns the horizontal velocity of this.
    public int getVVelocity()
    // effects: Returns the vertical velocity of this.
    public void step(Dimension bound)
    // modifies: this
    // effects: Let p = location
    // v = (vx, vy) = velocity
    // r = the bounding rectangle of this
    // Set p_post = p + v
    // unless doing so will bring part of r outside bound
    // => If the horizontal component of the attempted motion
    // of r is away from the center of bound,
    // set vx_post = -vx
    // And if the vertical component of the attempted motion
    // of r is away from the center of bound,
    // set vy_post = -vy
    // Set p_post = p
    public Object clone() throws CloneNotSupportedException
    // effects: standard clone operator
    Animatible Interface
    interface Animatible
    // Overviews: Animatibles are objects that can be animated.
    // Animation is achieved by invoking a number of steps
    // of small modifications, movements, or transformations
    // on this.
    public void step(Dimension bound);
    // modifies: this
    // effects: Updates the state of this to the appropriate value for
    // the next animation step. The argument bound indicates
    // the dimension of the area within which this is allowed
    // to move.

    You say the names of the Classes like they are standard or something LOL. Sounds like a fun homework assignment. Get to work!! and good luck.

  • How to implement XP Cisco VPN client. Please help!!!

    Hi,
    I am trying to configure remote access for XP desktops using CVPN client software and a Cisco 805 router with IOS IPSec capable( authentication should be local). The remote desktops are behind adsl router wich does nat translations but allow IPSes passthrough.
    I have configured it but does not working.
    Can you please help me?
    Thanks in advance
    David

    Hi guys, Solved.
    This very useful link:
    http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Virtual%20Private%20Networks&topic=General&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dd7d54c/0
    David

  • How to implement production planning in thermal power plant-help needed

    water is fed to boiler drum through boiler feed pump and it is taken to boiler drum.
    then water is heated is taken through water tubes and moving towards bottom.the heat produced due to burning of coal surrounds the the water tubes amd the water in water tubes , get converted to steam and that steam is taken to super heaters in 3- stages(platen, radian like stages) and finally it gets super heated at final super heater and it is to turbine through main steam temperature control valve and temp of steam is 510 c and when it reaches turbine it 's temp reduces to 504 c and it first enteres first stage of turbine, it's pressure get reduced at sucessive stage, when it leaves the tubine, steam pressure is only 0.8 kg/cm2 and when in entersrs turbine it's pressure is 88 kg/cm2.
    then it is taken to water cooled condenser and it is cooled and it is taken to cooling towers and finally it is taken to bfp and fresh addition of incoming water takes place.chemical dosing takes place here.finally taken to boiler drum.
    the coal from coal yard after taken from coal through coal conveyors, it reaches the boiler firing elevation through coal pipes located at 14 meters from ground.
    intial firing is done with light diesel oil and after flame stabilization, we will use high density furnace oil. then after that we will go for coal.if there is any fluctuation in stability of flame or reduction of temp of furnace, then hfo oil gun is taken for use.
    the flue gas from furnace , is taken ttrough , air ptr-heater and frsher air from primary air fan and forced draft fan will mix with flue gas in pre-heater and takes the heat of flue gas. so wastage heat is reduced somewhat.
    the heavy ash formed in furnace is taken through downwards and from that to storage of heavy ash by heavy ash conveyor.
    the fly ash is taken through esp(electo static precipitator)by flue gas and finally to fly ash gets seperated from fly ash storage.the exhaust came out from chimney.
    this is the process in power plant.
    turbine vaccum is created by ejector
    regards,

    water is fed to boiler drum through boiler feed pump and it is taken to boiler drum.
    then water is heated is taken through water tubes and moving towards bottom.the heat produced due to burning of coal surrounds the the water tubes amd the water in water tubes , get converted to steam and that steam is taken to super heaters in 3- stages(platen, radian like stages) and finally it gets super heated at final super heater and it is to turbine through main steam temperature control valve and temp of steam is 510 c and when it reaches turbine it 's temp reduces to 504 c and it first enteres first stage of turbine, it's pressure get reduced at sucessive stage, when it leaves the tubine, steam pressure is only 0.8 kg/cm2 and when in entersrs turbine it's pressure is 88 kg/cm2.
    then it is taken to water cooled condenser and it is cooled and it is taken to cooling towers and finally it is taken to bfp and fresh addition of incoming water takes place.chemical dosing takes place here.finally taken to boiler drum.
    the coal from coal yard after taken from coal through coal conveyors, it reaches the boiler firing elevation through coal pipes located at 14 meters from ground.
    intial firing is done with light diesel oil and after flame stabilization, we will use high density furnace oil. then after that we will go for coal.if there is any fluctuation in stability of flame or reduction of temp of furnace, then hfo oil gun is taken for use.
    the flue gas from furnace , is taken ttrough , air ptr-heater and frsher air from primary air fan and forced draft fan will mix with flue gas in pre-heater and takes the heat of flue gas. so wastage heat is reduced somewhat.
    the heavy ash formed in furnace is taken through downwards and from that to storage of heavy ash by heavy ash conveyor.
    the fly ash is taken through esp(electo static precipitator)by flue gas and finally to fly ash gets seperated from fly ash storage.the exhaust came out from chimney.
    this is the process in power plant.
    turbine vaccum is created by ejector
    regards,

  • How to implement Personal Information for non supported countries

    Hi,
       Can anyone give me some tips on how to implement Personal Information ESS services for countries which are not supported by the standard business package. We need to implement for the following countries as well as a part of global implementation.
    Cyprus
    Czech Republic
    Egypt
    Ireland
    Luxembourg
    Monaco
    Russia
    Ukraine
    Regards,
    Subhadip

    Hi Subhadip,
    You need to the following customization settings in SPRO.
    Personnel Management->ESS->Service Specific settings->OWn Data->Reuse Country Specific Application
    Just follow the IMG documentation and it should be done.  Basically we do,
    1.  Identify the Infotype and the country for which we want to re-use existing application (e.g Egypt).
    2.  Select the country from which you want to copy the screens (e.g. Australia, India)
    3. Specify the "Use Case and Active Subtypes" for that country.  Follow the documentation for this node.
    4. Maintain country specific entries for services (in this case will add entries for the new countries added).
    Hope this helps.
    Regards,
    Jigar

  • How to implement this in Oracle Apps 11i

    Hello Friends
    I am working as a consultant for a manufacturing company.
    They have a format for charging Excise and Sales tax on their products (example below). I dont know how to implement this using oracle apps. Please help me ASAP.
    eg.
    Product A:
    MRP = Rs. 100
    Assessable Value (i.e. the value at which I have contract with the Government to pay Excise Duty) = 60% of MRP = Rs. 60 in this case.
    Excise Duty = 16% of AV =0.16*60 = Rs. 9.6
    Now, let’s suppose I am selling my product to a dealer at 30% discount.
    Therefore, Sale Price = 70% of MRP = Rs. 70
    Sales Tax = 4% of Sale Price = 0.04*70 = 2.8
    Therefore, total revenue from the deal = 70-9.6-2.8 = Rs. 57.6

    you can use Advance Pricing or creating discount or attiribute while calculating.
    this is not much complex, possible even with Advance Pricing too. Thanks
    Shiv

  • How can i call skype customer support

    how can i call skype customer support +1800 is not working

    Hi, itsolution123, and welcome to the Community,
    Here is a link to the instruction on how to contact Skype Customer Service via their secure portal: Contact Customer Service
    Skype is aware there can be problems reaching their customer support unit.  If you experience difficulty reaching Skype Customer Service, try again using a different web browser and choosing a different path through the various drop-down menu options presented. Also, look to approve a pop-up dialogue box which would connect you to start an instant message chat with a customer service agent. If you have pop-ups blocked in your browser settings, this will also impede reaching an agent.
    Regards,
    Elaine
    Was your question answered? Please click on the Accept as a Solution link so everyone can quickly find what works! Like a post or want to say, "Thank You" - ?? Click on the Kudos button!
    Trustworthy information: Brian Krebs: 3 Basic Rules for Online Safety and Consumer Reports: Guide to Internet Security Online Safety Tip: Change your passwords often!

  • Hi, I have had my MacBook Pro stolen and the police have mentioned about using iCloud to see if I can track it's whereabouts - however I have no idea if I had iCloud on my MacBook or how to track it if I did - can anyone help me please? Thanks :)

    Hi, I have had my MacBook Pro stolen and the police have mentioned about using iCloud to see if I can track it's whereabouts - however I have no idea if I had iCloud on my MacBook or how to track it if I did - can anyone help me please? Thanks

    Welcome to the Apple Support Communities
    To see if you have iCloud, open http://www.icloud.com and log in with your Apple ID. If you can access to iCloud, you have iCloud. If you get an error message or you can't access, you don't have iCloud. This only works if you only have the Mac (not an iPhone, iPod touch or iPad with iCloud).
    Apart from that, "Find my Mac" must be turned on in the Mac in order to track it, so if it wasn't turned on, you won't be able to track it. If it was turned on, the computer must be connected to the Internet to be tracked.
    If you can access to iCloud through http://www.icloud.com, choose "Find my iPhone" and look at the Devices list. If your MacBook Pro shows up, "Find my Mac" is turned on, so see if you can track it and tell to the police that it's possible to track your MacBook Pro

  • How to implement sheduling services in Ep

    Hi all,
    I would like to know how to implement scheduling services in ep in the sense .. running jobs in portal .
    Any pointers to this would be of great help.
    Thanks& Regards,
    Uma,

    Hi Uma,
    If you have not already done so, try the following weblog by Prakash.
    <b>Did you know you can schedule jobs in portal using KM's Scheduler Task?>
    Hope this helps you
    Ranjith

  • How  to implement "my appraisals" service in ESS ?

    hi,
    i am configuring ESS in EP 6.0. My back end system is MySAP ERP. i wanted to implement "My Appraisals" service in ESS but i dont see any iview for it . Can anyone tell me how to implement it in ESS?
    regards,
    aditi

    Hi Aditi
    if u dont' found ZEMPLOYEE_CAREER_MBO  (customer specific)
    crate ur own by following
    spro ->IMG ->cross-application components ->Homepage Framework-> resources ->define resources ->define resources (add entry)
    click on new entry
    specifi the following
    resource key -
    >ZEMPLOYEE_CAREER_MBO
    description -
    >Appraisals In Process
    object name----->hap_document/documents_todo.htm
    url of pcd page-->pcd:portal_content/com.sap.pct/every_user/com.sap.pct.ess.employee/com.sap.pct.ess.roles/com.sap.pct.ess.employee_self_service/com.sap.pct.ess.employee_self_service/com.sap.pct.ess.area_career_job/com.sap.pct.ess.bsp_career_job
    save ur entry. release the request.
    now create the service.
    spro ->IMG ->cross-application components ->Homepage Framework-> services->define services->define services(add entry)
    click on new entry specifie following
    service key -->EMPLOYEE_CAREER_APPRAISALS
    service link text-->Appraisals
    service type--->service build with BSP
    link resource--->ZEMPLOYEE_CAREER_MBO
    save ur entry.
    now click on assign services to subarea->Assign Services to Subareas (Find Entries)
    create new entry.
    subarea key---->EMPLOYEE_CAREER_SUBAPPRAISALS
    service key short---->EMPLOYEE_CAREER_APPRAISALS
    position--->1
    if u have any query revert back
    regards,
    kaushal

  • How to Implement Management Chain in External routing Service

    hi,
    I am using External Routing Service to Assign & route the tasks.
    I will get the authorisation workflow in our external Routing class , Now I am suppose to implement that workflow in BPM worklist for that human task.
    One way is to know the way to implement management chain in the External Routing Service.
    I have found some BPEL classes for doing the same eg. ParticipantsType.ManagementChain, objFactory.createParticipantsTypeManagementChain().
    But not able to find any sample code to implement.
    Does any body knows how to implement the same.
    Is their any other way to resolve this issue.
    you can also refer the following thread to understand the problem statement: PROGRAMMATICALLY PERSISTING THE APPROVAL WORKFLOW FOR A HUMAN TASK.
    thanks
    Jagdish

    I have tried the below mentioned code for implemnting management chain...
         private Participants createParticipant() {
              System.out.println("1");
              String user = users[numberOfApprovals++];
              ObjectFactory objFactory = new ObjectFactory();
              Participants participants = objFactory.createParticipants();
              participants.setIsAdhocRoutingSupported(false);
                   StageType stage = objFactory.createParticipantsTypeStage();
                   stage.setName("Stage1");
                   System.out.println("2");
                   SequentialParticipant seqParticipant = objFactory.createParticipantsTypeSequentialParticipant();
                   seqParticipant.setName("Stage1.Participant1");
                   System.out.println("3");
                   ListType listType = objFactory.createList();
                   ManagementChainListType managementListType = objFactory.createManagementChainListType();
                   // adding Resource in the management chain
                   ResourceType resourceChain = objFactory.createResourceType("fkafka");
                   resourceChain.setIsGroup(false);
                   resourceChain.setType("STATIC");
                   resourceChain.setIdentityType("user");
                   managementListType.getResource().add(resourceChain);
                   System.out.println("4");
                   // adding levels in the management chain
                   ParameterType levelParameterType = objFactory.createParameterType("2");
                   levelParameterType.setType("STATIC");
              managementListType.setLevels(levelParameterType);
                   System.out.println("5");
                   // adding title in the management chain                    
                   ParameterType titleParameterType = objFactory.createParameterType("Vice President");
                   titleParameterType.setType("STATIC");
                   managementListType.setTitle(titleParameterType);
                   System.out.println("6");
                   listType.setManagementChain(managementListType);
                   System.out.println("7");
                   seqParticipant.setList(listType);
                   System.out.println("8");
                   stage.getParticipantOrSequentialParticipantOrAdhoc().add(seqParticipant);
                   System.out.println("9");
              participants.getParticipantOrSequentialParticipantOrAdhoc().add(stage);
              System.out.println("10");
              return participants;
    The above code doesnot give error during execution but It doesnot work, what It's suppose to be...
    what It does is..It calls onInitiation method number of times [equal to the number of levels given in hierachy +1] at one shot. without being assigned to anybody and come out of the human task.
    please let me know..If am missing something...
    thanks
    Jagdish Khera

  • How to implement redundant with 1 CE router to 2 MPLS service providers

    Dear all,
    Our head-office are currently have 1 Cisco CPE 3825 router with 2 WAN connections to our branches. We are now using static routing protocol in our network infrastructure, we consider how to implement the redundancy for networks by the redundant circuits connection to 2 MPLS providers, only when the primary connection to the primary MPLS L3 provider fail, the backup link to the second MPLS Layer 2 provider automatically active. Anybody knows where can I find information, tips or examples, how we'd handle the routing for that?
    We are now have:
    1 G0/1 interface connect to primary MPLS L3 Provider (the 2nd G0/2 interface is a leased-line connection to our partner, and we not consider here)
    1 HWIC (layer 2) card, with 4 ports, which has interface F0/2/3 connected to the backup MPLS Layer 2 provider.
    Thanks in advance.
    PS: Current configuration : 3727 bytes
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Router
    boot-start-marker
    boot system flash c3825-entservicesk9-mz.123-11.T7.bin
    boot-end-marker
    logging buffered 4096 debugging
    logging monitor xml
    no aaa new-model
    ip subnet-zero
    ip cef
    no ftp-server write-enable
    no spanning-tree vlan 4
    no spanning-tree vlan 5
    interface GigabitEthernet0/1
    description connect to VDC MPLS$ETH-WAN$
    mtu 1480
    ip address 222.x.x.66 255.255.255.252
    ip flow ingress
    ip flow egress
    service-policy output SDM-QoS-Policy-1
    ip route-cache flow
    duplex auto
    speed auto
    media-type rj45
    fair-queue 64 256 256
    no cdp enable
    interface FastEthernet0/2/0
    switchport access vlan 2
    no cdp enable
    interface FastEthernet0/2/3
    description ToTBToverFPT
    switchport access vlan 5
    no cdp enable
    interface Vlan2
    description CONNECT TO MPLS_VDC
    ip address 192.168.201.9 255.255.248.0
    interface Vlan5
    description Connect to HoChiMinhCity
    ip address 172.16.1.5 255.255.255.252
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.16.244.0 255.255.255.0 222.255.33.65
    ip route 192.168.0.0 255.255.248.0 222.255.33.65
    ip route 192.168.24.0 255.255.254.0 222.255.33.65
    ip route 192.168.30.0 255.255.254.0 222.255.33.65
    ip route 192.168.32.0 255.255.254.0 222.255.33.65
    ip route 222.x.x.68 255.255.255.252 222.255.33.65
    ip route 222.255.33.72 255.255.255.252 222.255.33.65
    ip route 222.x.x.196 255.255.255.252 222.255.33.65
    ip route 222.x.x.200 255.255.255.252 222.255.33.65
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 3
    control-plane
    line con 0
    logging synchronous
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    password
    login
    transport input telnet
    line vty 5 14
    privilege level 15
    password
    login
    transport input telnet
    line vty 15
    privilege level 15
    password
    login
    transport input telnet
    parser view SDM_Monitor
    scheduler allocate 20000 1000
    end

    Hi Mr jianqu,
    Because of our customer now has 2 main central offices, and all other sub branches are now connected to each of these main central office via one primary full-meshed MPLS VPN of 1st Service Provider, so If I use the float static routes, and when there is a failure at one link at a CENTRAL CE Router to primary link to primary MPLS VPN Service Provider, but still there is no failure at the other site from a router CE sub branch with the the PE of the primary full-meshed MPLS VPN Layer 3 Service Provider,so It cannot cause a failover to a second redundant link of the 2nd Service Provider?
    So with our system, do we only have one solution like this:
    -Configure BGP as the routing protocol between the CE and the PE routers.
    -Use local preference and Multi Exit Discriminator (MED) when running BGP inside a our customer VPN to select the primary and backup links.
    -Use AS-override feature to support overlapping AS numbers between customer sites

  • How to Implement Async JAX-WS 2.1 Service

    I would appreciate some guidance, or links to documentation, on how to implement an asynchronous JAX-WS 2.1 web service (note that I am NOT asking how to implement a client program that invokes a JAX-WS web service asynchronously b/c BPEL will be invoking the service).
    Ultimately, what I need to accomplish is to:
    (a) implement a JAX-WS web service that can be invoked asynchronously
    (b) deploy that JAX-WS web service to Oracle WebLogic 10.3 and
    (c) invoke the JAX-WS web service asynchronously from Oracle BPEL Process Manager 10.1.3.3.
    As an example, let's say I have the following class that I'd like to expose as an async JAX-WS web service:
    <pre>
    public class EngineConfigurationService
    public Configuration configureEngine(ConfigurationRequest aRequest)
    //....arbitrary amounts of long-running computation happens here...
    return configuration;
    </pre>
    How would I annotate this class to allow it to be consumed as an async JAX-WS web service? Would I need any other classes (e.g., a "response" class)?
    Thanks in advance for any help.
    Dave

    I recently developed a test async web service and deployed it on weblogic 9. What I did was 1.) create a java class with with standard ws annotations.
    2.)Compile it using jwsc ant task setting the attribute enableAsyncService="true".
    I am pasting the java file and the ant target here for your reference.
    <taskdef name="jwsc" classname="weblogic.wsee.tools.anttasks.JwscTask" classpathref="classpath.basic"/>
    <target name="buildWebService">
         <jwsc
         srcdir="${basedir}/src/com/test/"
         sourcepath="${basedir}/src/com/test/"
         destdir="${basedir}/build"
         classpathref="classpath.basic"
         keepGenerated="true"
         enableAsyncService="true"
         debug="on">
         <module contextPath="TestAsyncWS" name="TestAsyncWS" explode="false" >
              <jws file="TestAsyncWS.java">
         <WLHttpTransport contextPath="TestAsyncWS" serviceUri="TestAsyncWS" portName="TestAsyncWS" />
         </jws>
         <FileSet dir="${basedir}/src" >
         <include name="**/*.java" />
         </FileSet>
         </module>
              </jwsc>     
         </target>
    and here is the java class
    package com.test;
    import javax.jws.WebMethod;
    import javax.jws.WebService;
    import javax.jws.soap.SOAPBinding;
    @WebService (name = "TestAsyncWS", targetNamespace = "java:com.test")
    public class TestAsyncWS
         public TestAsyncWS()
         @WebMethod()
              public String sayHello(String textToDisplay)
              String result = "I can still work.Here is what you sent to me. "+ textToDisplay;
              System.out.println(result);
              try {
                   Thread.sleep(20000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              return result;
    }

Maybe you are looking for

  • Orange bar on bottom of clip

    Hi! I can't find a way to get rid of the orange bar on the bottom of a movie clip..... any ideas? thank you, tch60

  • Notes on TLF Markup

    I wrote some notes on TLF markup and published them on the TLF blog. http://blogs.adobe.com/tlf/2009/09/tlf-markup-overview.html It's pretty basic - the goal is to give you the tools to understand the markup. Hope it helps! Richard

  • Authorisation popup on SAPBWSetOpenerUrl

    Hello Experts, I have a web application that has several tabs, which are each linked to different web templates.  When I execute the web application, the first tab is executed.  I select a node from a hierarchy into a variable.  When I am in the web

  • Media Encoder CS6 Timecode

    Having terrible issues bringing in a simple sequence into Media Encoder for a client preview output. Issues:  Sequence starts at 01:00:00:00 - Comprised of RED files back to back. About 43 minutes worth.  I lay a Timecode generator on the video and a

  • JAXB vs. xs:Time

    Hello, I'm trying to read XML file using JAXB. The problem is when I'm trying to parse tag that have XML type xs:time I receve a null as XMLGregorianCalendar from this field because it represented as <TimeTag>14:00:00-06:00</TimeTag> without year-mon