How to Implement Management Chain in External routing Service

hi,
I am using External Routing Service to Assign & route the tasks.
I will get the authorisation workflow in our external Routing class , Now I am suppose to implement that workflow in BPM worklist for that human task.
One way is to know the way to implement management chain in the External Routing Service.
I have found some BPEL classes for doing the same eg. ParticipantsType.ManagementChain, objFactory.createParticipantsTypeManagementChain().
But not able to find any sample code to implement.
Does any body knows how to implement the same.
Is their any other way to resolve this issue.
you can also refer the following thread to understand the problem statement: PROGRAMMATICALLY PERSISTING THE APPROVAL WORKFLOW FOR A HUMAN TASK.
thanks
Jagdish

I have tried the below mentioned code for implemnting management chain...
     private Participants createParticipant() {
          System.out.println("1");
          String user = users[numberOfApprovals++];
          ObjectFactory objFactory = new ObjectFactory();
          Participants participants = objFactory.createParticipants();
          participants.setIsAdhocRoutingSupported(false);
               StageType stage = objFactory.createParticipantsTypeStage();
               stage.setName("Stage1");
               System.out.println("2");
               SequentialParticipant seqParticipant = objFactory.createParticipantsTypeSequentialParticipant();
               seqParticipant.setName("Stage1.Participant1");
               System.out.println("3");
               ListType listType = objFactory.createList();
               ManagementChainListType managementListType = objFactory.createManagementChainListType();
               // adding Resource in the management chain
               ResourceType resourceChain = objFactory.createResourceType("fkafka");
               resourceChain.setIsGroup(false);
               resourceChain.setType("STATIC");
               resourceChain.setIdentityType("user");
               managementListType.getResource().add(resourceChain);
               System.out.println("4");
               // adding levels in the management chain
               ParameterType levelParameterType = objFactory.createParameterType("2");
               levelParameterType.setType("STATIC");
          managementListType.setLevels(levelParameterType);
               System.out.println("5");
               // adding title in the management chain                    
               ParameterType titleParameterType = objFactory.createParameterType("Vice President");
               titleParameterType.setType("STATIC");
               managementListType.setTitle(titleParameterType);
               System.out.println("6");
               listType.setManagementChain(managementListType);
               System.out.println("7");
               seqParticipant.setList(listType);
               System.out.println("8");
               stage.getParticipantOrSequentialParticipantOrAdhoc().add(seqParticipant);
               System.out.println("9");
          participants.getParticipantOrSequentialParticipantOrAdhoc().add(stage);
          System.out.println("10");
          return participants;
The above code doesnot give error during execution but It doesnot work, what It's suppose to be...
what It does is..It calls onInitiation method number of times [equal to the number of levels given in hierachy +1] at one shot. without being assigned to anybody and come out of the human task.
please let me know..If am missing something...
thanks
Jagdish Khera

Similar Messages

  • External Routing Service

    has anyone implemented an external routing service for the human task activity? I find the documentation lacking in that direction. I need to be able to define the assignee as a user or group at runtime. Apparently you can't do that in 10.1.3.1 without an external routing service

    I think that what you need is writing a external routing policy. That is also what I am trying to do. Here is the only doc I have found on the subject :
    http://download-uk.oracle.com/docs/cd/B31017_01/integrate.1013/b28981/workflow.htm#BABGCHHD
    I think we both want to make the same thing : make the human tasks more dynamic. ANd according to me, the external routing policy is the best (or less bad) solution.
    As in the example below
    What I still don't manage to do is creating a Participant that is "Parallel "or "Management Chain".
    This work fine in the onOutcomeUpdated() method :
    ObjectFactory objFactory = new ObjectFactory();
    Participants participants = objFactory.createParticipants();
    Participant participant = objFactory.createParticipantsTypeParticipant();
    participant.setName("Loan Agent");
    ResourceType resource2 = objFactory.createResourceType(user);
    resource2.setIsGroup(false);
    resource2.setType("STATIC");
    participant.getResource().add(resource2);
    But this doesn't work :
    ObjectFactory objFactory = new ObjectFactory();
    Participants participants = objFactory.createParticipants();
    Parallel participant = objFactory.createParticipantsTypeParallel();
    participant.setName("Loan Agent");
    ResourceType resource2 = objFactory.createResourceType(user);
    resource2.setIsGroup(false);
    resource2.setType("STATIC");
    participant.getResource().add(resource2);
    Does anyone have an idea of how to make this bit of code work? Or any other idea about how to make a human task dynamically change its behaviour (for example switching from sequential pattern to parallel pattern according to a user action) is welcome!
    Thomas

  • Parallel participants blocks in External Routing Service

    I'm trying to configure an External Routing service (it implements IAssignmentService interface) as described in Developer's Guide for Oracle SOA Suite[1].
    The assignment stage configuration needed: one or more parallel participants blocks in the same stage, each one configured with different participants and voting rules.
    The CustomAssignmentService below shows my custom External Routing Service: when I try to add two or more parallel participants, only the first one it is assigned to the task.
    I haven't found documentation: how can I implement parallel participants blocks in External Routing Service?
    Product version: SOA Suite 11.1.1.6
    References:
    [1] http://docs.oracle.com/cd/E28389_01/dev.1111/e10224/bp_hwfmodel.htm#BABCFHCC
    ----------- CustomAssignmentService.java ------------------
    package br.com.iprocess;
    import java.util.Map;
    import oracle.bpel.services.workflow.metadata.routingslip.model.*;
    import oracle.bpel.services.workflow.metadata.routingslip.model.Participants;
    import oracle.bpel.services.workflow.metadata.routingslip.model.ParticipantsType.*;
    import oracle.bpel.services.workflow.task.IAssignmentService;
    import oracle.bpel.services.workflow.task.ITaskAssignee;
    import oracle.bpel.services.workflow.task.model.Task;
    import oracle.bpel.services.workflow.IWorkflowConstants;
    public class CustomAssignmentService implements IAssignmentService {
    private final String OUTCOME_APPROVE = "APPROVE";
    private final String OUTCOME_REJECT = "REJECT";
    public Participants onInitiation(Task task, Map propertyBag) {
    return createParticipant(task, propertyBag);
    public Participants onReinitiation(Task task, Map propertyBag) {
    return createParticipant(task, propertyBag);
    public Participants onOutcomeUpdated(Task task, Map propertyBag,
    String updatedBy, String outcome) {
    return null;
    public Participants onAssignmentSkipped(Task task, Map propertyBag) {
    return null;
    public java.util.List getAssigneesToRequestForInformation(Task task,
    Map propertyBag) {
    return null;
    public java.util.List getReapprovalAssignees(Task task, Map propertyBag,
    ITaskAssignee infoRequestedAssignee) {
    return null;
    public Participants createParticipant(Task task, Map propertyBag) {
    ObjectFactory objFactory = new ObjectFactory();
    Participants participants = objFactory.createParticipants();
    participants.getParticipantOrSequentialParticipantOrAdhoc().add(addParticipantsGroup1(objFactory));
    participants.getParticipantOrSequentialParticipantOrAdhoc().add(addParticipantsGroup2(objFactory));
    return participants;
    private Parallel addParticipantsGroup2(ObjectFactory objFactory) {
    Parallel parallelParticipant = objFactory.createParticipantsTypeParallel();
    ParallelCompletionCriteriaType vote = objFactory.createParallelCompletionCriteriaType();
    ParameterType defaultOutcome = objFactory.createParameterType(OUTCOME_REJECT);
    defaultOutcome.setType("STATIC");
    vote.setDefaultOutcome(defaultOutcome);
    String defaultPercentage = "51";
    ParameterType percentageOfOutcome = objFactory.createParameterType(defaultPercentage);
    percentageOfOutcome.setType("STATIC");
    vote.getOutcomePercentage().add(percentageOfOutcome);
    parallelParticipant.setAllResponders(vote);
    Resource resource = objFactory.createResource();
    resource.setValue("manager1, manager2");
    resource.setIsGroup(false);
    resource.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource);
    Resource resource2 = objFactory.createResource();
    resource2.setValue("manager3");
    resource2.setIsGroup(false);
    resource2.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource2);
    return parallelParticipant;
    private Parallel addParticipantsGroup1(ObjectFactory objFactory) {
    Parallel parallelParticipant = objFactory.createParticipantsTypeParallel();
    ParallelCompletionCriteriaType vote = objFactory.createParallelCompletionCriteriaType();
    ParameterType defaultOutcome = objFactory.createParameterType(OUTCOME_REJECT);
    defaultOutcome.setType("STATIC");
    vote.setDefaultOutcome(defaultOutcome);
    String defaultPercentage = "51";
    ParameterType percentageOfOutcome = objFactory.createParameterType(defaultPercentage);
    percentageOfOutcome.setType("STATIC");
    vote.getOutcomePercentage().add(percentageOfOutcome);
    parallelParticipant.setAllResponders(vote);
    Resource resource = objFactory.createResource();
    resource.setValue("operator1, operator2, operator3");
    resource.setIsGroup(false);
    resource.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource);
    return parallelParticipant;
    }

    I'm trying to configure an External Routing service (it implements IAssignmentService interface) as described in Developer's Guide for Oracle SOA Suite[1].
    The assignment stage configuration needed: one or more parallel participants blocks in the same stage, each one configured with different participants and voting rules.
    The CustomAssignmentService below shows my custom External Routing Service: when I try to add two or more parallel participants, only the first one it is assigned to the task.
    I haven't found documentation: how can I implement parallel participants blocks in External Routing Service?
    Product version: SOA Suite 11.1.1.6
    References:
    [1] http://docs.oracle.com/cd/E28389_01/dev.1111/e10224/bp_hwfmodel.htm#BABCFHCC
    ----------- CustomAssignmentService.java ------------------
    package br.com.iprocess;
    import java.util.Map;
    import oracle.bpel.services.workflow.metadata.routingslip.model.*;
    import oracle.bpel.services.workflow.metadata.routingslip.model.Participants;
    import oracle.bpel.services.workflow.metadata.routingslip.model.ParticipantsType.*;
    import oracle.bpel.services.workflow.task.IAssignmentService;
    import oracle.bpel.services.workflow.task.ITaskAssignee;
    import oracle.bpel.services.workflow.task.model.Task;
    import oracle.bpel.services.workflow.IWorkflowConstants;
    public class CustomAssignmentService implements IAssignmentService {
    private final String OUTCOME_APPROVE = "APPROVE";
    private final String OUTCOME_REJECT = "REJECT";
    public Participants onInitiation(Task task, Map propertyBag) {
    return createParticipant(task, propertyBag);
    public Participants onReinitiation(Task task, Map propertyBag) {
    return createParticipant(task, propertyBag);
    public Participants onOutcomeUpdated(Task task, Map propertyBag,
    String updatedBy, String outcome) {
    return null;
    public Participants onAssignmentSkipped(Task task, Map propertyBag) {
    return null;
    public java.util.List getAssigneesToRequestForInformation(Task task,
    Map propertyBag) {
    return null;
    public java.util.List getReapprovalAssignees(Task task, Map propertyBag,
    ITaskAssignee infoRequestedAssignee) {
    return null;
    public Participants createParticipant(Task task, Map propertyBag) {
    ObjectFactory objFactory = new ObjectFactory();
    Participants participants = objFactory.createParticipants();
    participants.getParticipantOrSequentialParticipantOrAdhoc().add(addParticipantsGroup1(objFactory));
    participants.getParticipantOrSequentialParticipantOrAdhoc().add(addParticipantsGroup2(objFactory));
    return participants;
    private Parallel addParticipantsGroup2(ObjectFactory objFactory) {
    Parallel parallelParticipant = objFactory.createParticipantsTypeParallel();
    ParallelCompletionCriteriaType vote = objFactory.createParallelCompletionCriteriaType();
    ParameterType defaultOutcome = objFactory.createParameterType(OUTCOME_REJECT);
    defaultOutcome.setType("STATIC");
    vote.setDefaultOutcome(defaultOutcome);
    String defaultPercentage = "51";
    ParameterType percentageOfOutcome = objFactory.createParameterType(defaultPercentage);
    percentageOfOutcome.setType("STATIC");
    vote.getOutcomePercentage().add(percentageOfOutcome);
    parallelParticipant.setAllResponders(vote);
    Resource resource = objFactory.createResource();
    resource.setValue("manager1, manager2");
    resource.setIsGroup(false);
    resource.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource);
    Resource resource2 = objFactory.createResource();
    resource2.setValue("manager3");
    resource2.setIsGroup(false);
    resource2.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource2);
    return parallelParticipant;
    private Parallel addParticipantsGroup1(ObjectFactory objFactory) {
    Parallel parallelParticipant = objFactory.createParticipantsTypeParallel();
    ParallelCompletionCriteriaType vote = objFactory.createParallelCompletionCriteriaType();
    ParameterType defaultOutcome = objFactory.createParameterType(OUTCOME_REJECT);
    defaultOutcome.setType("STATIC");
    vote.setDefaultOutcome(defaultOutcome);
    String defaultPercentage = "51";
    ParameterType percentageOfOutcome = objFactory.createParameterType(defaultPercentage);
    percentageOfOutcome.setType("STATIC");
    vote.getOutcomePercentage().add(percentageOfOutcome);
    parallelParticipant.setAllResponders(vote);
    Resource resource = objFactory.createResource();
    resource.setValue("operator1, operator2, operator3");
    resource.setIsGroup(false);
    resource.setType("STATIC");
    parallelParticipant.getResourceOrRoutingSlip().add(resource);
    return parallelParticipant;
    }

  • Using External Routing Service to Route the task

    Hi,
    I am using External Routing Service to Route the task and have placed the jar file at
    /oracle/app/product/fmw/Oracle_SOA1/soa/modules/oracle.soa.ext_11.1.1
    I have modified the Manifest.mf file for "oracle.soa.ext.jar" as
    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.7.1
    Created-By: 17.0-b17 (Sun Microsystems Inc.)
    Implementation-Vendor: Oracle
    Implementation-Title: Oracle SOA EXT
    Implementation-Version: 11.1.1
    Product-Name: Oracle SOA EXT
    Class-Path: ./routing/lib/jaxrpc.jar ./routing/lib/axis-update.jar ./routing/lib/axis.jar ./routing/lib/log4j-1.2.11.jar ./routing/lib/orabpel.jar ./routing/lib/bpm-services.jar ./routing/lib/xmlparserv2.jar ./routing/lib/wsdl4j-1.5.1.jar ./routing/lib/commons-discovery-0.2.jar ./routing/workflow.routing.jar
    Product-Version: 11.1.1.4.0
    Specification-Version: 11.1.1
    Extension-Name: oracle.soa.ext
    but it's failing to get the ExternalRoutingService.class and throws exception
    Missing class: ExternalRoutingService
         Dependent class: oracle.bpel.services.workflow.task.impl.RoutingSlipInterpretor
         Loader: weblogic.utils.classloaders.GenericClassLoader@2080514773
         Code-Source: /oracle/app/product/fmw/Oracle_SOA1/soa/modules/oracle.soa.workflow_11.1.1/bpm-services.jar
         Configuration: /oracle/app/product/fmw/Oracle_SOA1/soa/modules/oracle.soa.workflow_11.1.1/bpm-services.jar
    I tried adding the workflow.routing.jar to classpath (as this jar contains the ExternalRoutingService.class) and then gives error for IAssignmentService saying class not found IAssignmentService.class

    Hi Pranay,
    Did you find solution for this?
    I am also facing same issue.
    Thanks
    Balaji

  • How to implement redundant with 1 CE router to 2 MPLS service providers

    Dear all,
    Our head-office are currently have 1 Cisco CPE 3825 router with 2 WAN connections to our branches. We are now using static routing protocol in our network infrastructure, we consider how to implement the redundancy for networks by the redundant circuits connection to 2 MPLS providers, only when the primary connection to the primary MPLS L3 provider fail, the backup link to the second MPLS Layer 2 provider automatically active. Anybody knows where can I find information, tips or examples, how we'd handle the routing for that?
    We are now have:
    1 G0/1 interface connect to primary MPLS L3 Provider (the 2nd G0/2 interface is a leased-line connection to our partner, and we not consider here)
    1 HWIC (layer 2) card, with 4 ports, which has interface F0/2/3 connected to the backup MPLS Layer 2 provider.
    Thanks in advance.
    PS: Current configuration : 3727 bytes
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Router
    boot-start-marker
    boot system flash c3825-entservicesk9-mz.123-11.T7.bin
    boot-end-marker
    logging buffered 4096 debugging
    logging monitor xml
    no aaa new-model
    ip subnet-zero
    ip cef
    no ftp-server write-enable
    no spanning-tree vlan 4
    no spanning-tree vlan 5
    interface GigabitEthernet0/1
    description connect to VDC MPLS$ETH-WAN$
    mtu 1480
    ip address 222.x.x.66 255.255.255.252
    ip flow ingress
    ip flow egress
    service-policy output SDM-QoS-Policy-1
    ip route-cache flow
    duplex auto
    speed auto
    media-type rj45
    fair-queue 64 256 256
    no cdp enable
    interface FastEthernet0/2/0
    switchport access vlan 2
    no cdp enable
    interface FastEthernet0/2/3
    description ToTBToverFPT
    switchport access vlan 5
    no cdp enable
    interface Vlan2
    description CONNECT TO MPLS_VDC
    ip address 192.168.201.9 255.255.248.0
    interface Vlan5
    description Connect to HoChiMinhCity
    ip address 172.16.1.5 255.255.255.252
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.16.244.0 255.255.255.0 222.255.33.65
    ip route 192.168.0.0 255.255.248.0 222.255.33.65
    ip route 192.168.24.0 255.255.254.0 222.255.33.65
    ip route 192.168.30.0 255.255.254.0 222.255.33.65
    ip route 192.168.32.0 255.255.254.0 222.255.33.65
    ip route 222.x.x.68 255.255.255.252 222.255.33.65
    ip route 222.255.33.72 255.255.255.252 222.255.33.65
    ip route 222.x.x.196 255.255.255.252 222.255.33.65
    ip route 222.x.x.200 255.255.255.252 222.255.33.65
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 3
    control-plane
    line con 0
    logging synchronous
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    password
    login
    transport input telnet
    line vty 5 14
    privilege level 15
    password
    login
    transport input telnet
    line vty 15
    privilege level 15
    password
    login
    transport input telnet
    parser view SDM_Monitor
    scheduler allocate 20000 1000
    end

    Hi Mr jianqu,
    Because of our customer now has 2 main central offices, and all other sub branches are now connected to each of these main central office via one primary full-meshed MPLS VPN of 1st Service Provider, so If I use the float static routes, and when there is a failure at one link at a CENTRAL CE Router to primary link to primary MPLS VPN Service Provider, but still there is no failure at the other site from a router CE sub branch with the the PE of the primary full-meshed MPLS VPN Layer 3 Service Provider,so It cannot cause a failover to a second redundant link of the 2nd Service Provider?
    So with our system, do we only have one solution like this:
    -Configure BGP as the routing protocol between the CE and the PE routers.
    -Use local preference and Multi Exit Discriminator (MED) when running BGP inside a our customer VPN to select the primary and backup links.
    -Use AS-override feature to support overlapping AS numbers between customer sites

  • How to use management chain and escalation hierarchies with LDAP

    Hi,
    I have experienced now with the management chain pattern and escalation feature. I have used the standard file-based security provider (JAZN and user-properties.xml). You can easily define a user hierarchy using the user-properties.xml file to define the escalation path and the management chain in terms of hierarchy levels.
    In a production environment in most cases you will use LDAP as the security provider. I wonder if it is possible to define such an user hierarchy in LDAP. I now you can create a role-based hierarchy, but in cases this will be to much and you need user based hierarchy.
    Another issue is that you can also define a highest level op approval. Hower you onlyonly define manager/director/ceo, used in the user-properties.xml file. How can you tell jdeveloper to use other custom roles?
    Does anyone has experience of suggentions om this issue?
    Kind regards,
    -Tom

    Tom,
    I can address parts of your question, please see below:
    How can you tell jdeveloper to use other custom roles?JDeveloper picks up users from the Integration Server connection. So, if the server is configured with the LDAP configured server, you will see users and groups from that registry. JDeveloper (the human task editor dialog) does not go directly against the LDAP.
    I wonder if it is possible to define such an user hierarchy in LDAPYes. That is the way it has been designed.
    I now you can create a role-based hierarchy, but in cases this will
    be to much and you need user based hierarchy.Making a user specific hierarchy has problems - what if a user leaves the company? The role based hierarchies solve this problem very well. May be I misunderstand your question.
    I will have a colleague, who works on identity management, look at your question.
    Regards,
    Sidda.

  • How  to Implement a Chained Hash Table with Linked Lists

    I'm making a migration from C/C++ to Java, and my task is to implement a Chained Hash Table with a Linked List. My problem is to put the strings(in this case names) hashed by the table using de Division Metod (H(k)= k mod N) in to a Linked list that is handling the colisions. My table has an interface implemented(public boolean insert(), public boolean findItem(), public void remove()). Any Help is needed. Thanks for everyone in advance.

    OK. you have your hash table. What you want it to do is keep key/value pairs in linked lists, so that when there is a collision, you add the key/value pair to the linked list rather than searching for free space on the table.
    This means that whenever you add an item, you hash it out, check to see if there is already a linked list and if not, create one and put it in that slot. Then in either case you add the key/value pair to the linked list if the key is not already on the linked list. If it is there you have to decide whether your requirements are to give an error or allow duplicate keys or just keep or modify one or the other (old/new).
    When you are searching for a key, you hash it out once again and check to see if there is a linked list at that slot. If there is one, look for the key and if it's there, return it and if not, or if there was no linked list at that slot, return an error.
    You aren't clear on whether you can simply use the provided linked-list implementations in the Java Collections or whether you have to cobble the linked list yourself. In any case, it's up to you.
    Is this what you're asking?
    Doug

  • How to Implement Async JAX-WS 2.1 Service

    I would appreciate some guidance, or links to documentation, on how to implement an asynchronous JAX-WS 2.1 web service (note that I am NOT asking how to implement a client program that invokes a JAX-WS web service asynchronously b/c BPEL will be invoking the service).
    Ultimately, what I need to accomplish is to:
    (a) implement a JAX-WS web service that can be invoked asynchronously
    (b) deploy that JAX-WS web service to Oracle WebLogic 10.3 and
    (c) invoke the JAX-WS web service asynchronously from Oracle BPEL Process Manager 10.1.3.3.
    As an example, let's say I have the following class that I'd like to expose as an async JAX-WS web service:
    <pre>
    public class EngineConfigurationService
    public Configuration configureEngine(ConfigurationRequest aRequest)
    //....arbitrary amounts of long-running computation happens here...
    return configuration;
    </pre>
    How would I annotate this class to allow it to be consumed as an async JAX-WS web service? Would I need any other classes (e.g., a "response" class)?
    Thanks in advance for any help.
    Dave

    I recently developed a test async web service and deployed it on weblogic 9. What I did was 1.) create a java class with with standard ws annotations.
    2.)Compile it using jwsc ant task setting the attribute enableAsyncService="true".
    I am pasting the java file and the ant target here for your reference.
    <taskdef name="jwsc" classname="weblogic.wsee.tools.anttasks.JwscTask" classpathref="classpath.basic"/>
    <target name="buildWebService">
         <jwsc
         srcdir="${basedir}/src/com/test/"
         sourcepath="${basedir}/src/com/test/"
         destdir="${basedir}/build"
         classpathref="classpath.basic"
         keepGenerated="true"
         enableAsyncService="true"
         debug="on">
         <module contextPath="TestAsyncWS" name="TestAsyncWS" explode="false" >
              <jws file="TestAsyncWS.java">
         <WLHttpTransport contextPath="TestAsyncWS" serviceUri="TestAsyncWS" portName="TestAsyncWS" />
         </jws>
         <FileSet dir="${basedir}/src" >
         <include name="**/*.java" />
         </FileSet>
         </module>
              </jwsc>     
         </target>
    and here is the java class
    package com.test;
    import javax.jws.WebMethod;
    import javax.jws.WebService;
    import javax.jws.soap.SOAPBinding;
    @WebService (name = "TestAsyncWS", targetNamespace = "java:com.test")
    public class TestAsyncWS
         public TestAsyncWS()
         @WebMethod()
              public String sayHello(String textToDisplay)
              String result = "I can still work.Here is what you sent to me. "+ textToDisplay;
              System.out.println(result);
              try {
                   Thread.sleep(20000);
              } catch (InterruptedException e) {
                   e.printStackTrace();
              return result;
    }

  • How to pass credentials to an external web service from BPEL in 11g

    Hi All,
    I am using JDev,SOA 11.1.1.2.0.
    In our process we are calling siebel service which is a secured one and it does not use wsse security headers.
    In siebel service i am passing username and password through soap headers.
    What we need to do apart from this?
    In 10g we have done this by passing these values through invoke activity.
    In 11g i did not find any thing like this.
    Please help me out.
    Regards
    PavanKumar.M

    go to composite
    Right click on the external reference service and select “Configure WS policies” :done
    Under the security tab, click add button and select “oracle/ wss_username_token_client_policy :done
    6. Now Open the property Inspector window and click the add button under “Binding properties” tab. :done
    7. Include the “oracle.webservices.auth.username--> :done
    value-->password :done
    8. Include the “oracle.webservices.auth.password”-->name :done
    value-->password :done
    Thanks

  • How to implement Manager Selfservice - Recording Working Time - BP

    Hi!
    I would like to have a stepby step approach to implement business package for recording working time.
    What I need is the following information?
    1. Pre-requisites
    2. How to create the iview ?
    3. What R3 configurations need?
    you can email if you have good documentation on this to [email protected]
    Thank you
    Ramesh

    The primary limitation you will encounter when trying to do high speed
    digital I/O using your E-Series hardware is that the digital lines are
    all software timed.  This means that for each and every digital
    read it is necessary for your software to issue a command to your
    hardware, read a single point, then receive the response from the
    board.  This prevents you from performing digital operations at
    very high speed.  In general, I would say that 100 microseconds is
    a very good response using software-timed digital I/O on a Windows
    computer.
    It is difficult to make a good recommendation without more detail about
    what you are trying to do.  You may need to consider switching to
    a Real-Time operating system, or upgrading your DAQ hardware to a board
    that will allow you to time your digital acquisitions on the board
    itself.  These devices, such as the m-Series DAQ or the PCI-653x
    series, would allow you to use hardware triggers for your digital
    acquisitions, change detection, and buffered data acquisitions to
    reduce the software overhead involved in a rapid acquisition.

  • How to implement the odata model with web service

    hi dear all,
    i am trying to expose the web service as odata service in gwpa (not the NW Gateway) and i want to deploy it into smp 3.0
    but cannot find any helpful materials on it.
    could you give me some guide?
    thank you very much
    best regards
    lawrence

    Hi Lawrence,
    There are plenty blogs available. You can check either
    Marvin Hoffmann
    How to use Integration Gateway with SMP 3.0 (Part 1)
    Let me know if you face any issues.
    Rgrds,
    Jitendra

  • How to manage firefox from external program

    How I can manage Firefox from external program?
    I have several site's with very complex contents - AJAX, SSL and so on. And I would like to "give tasks" to Firefox - give me HTML of this page after all updates using AJAX or click on that links.
    It's it possible? if yes than how?

    Hai follow the bellow steps
    Sending system side(SEND--800)
    Create function module by using Tcode SE37 or SE80
    goto attributes select remote function
    activate
    Receiving system side(RECE--000)
    goto Tcode SM59
    here select the R/3 Connections-->click on Create Button
    give RFC Desstination : TESTRFC
         Connection Type  : 3 for Connecting two systems
         Description      : Some meaningful Description
    Press enter
    give Target system Name : SEND
              Language      : EN
              Client        : 800
              user Name     : sapuser
              Password      : xxxxxx
    save this connections & click on test connections(f8)
                          & Remote logon(f7)---> it will open a session
                            with client 800 that is your sending system
                            then only your RFC is correct
    create a report in SE38 Tcode
    data : c1 type i.
    data : itab like mara occurs 0 with header line.
    call function 'ZRFCFM' destination 'TESTRFC' --->Function Module 'ZRFCFM' your just create at Sending system
         exporting
         importing
         exceptions.
    Thanks & regards
    Sreenivasulu P

  • Connecting to an external web service from Oracle BPEL

    How do we connect to an external web service using its wsdl (possibly implemented in .NET) from Oracle BPEL process?
    Any specific details/examples greatly appreciated.
    Thanks,
    JN

    How do we connect to an external web service using its wsdl (possibly implemented in .NET) from Oracle BPEL process?
    Any specific details/examples greatly appreciated.
    Thanks,
    JN

  • How do I route back to subordinate when rejected in management chain task?

    Hi I wish to create following configuration in BPEL:
    1) A Worker has a Manager.
    2) When the Worker approves the task, it is sent to the Manager for approval.
    3) When the Worker rejects the task, its done. However, when the Manager rejects the task it is sent back to the Worker again for another full approval/reject cycle.
    I'm using a management chain human task for this, and it mostly works. However, I'm having trouble getting the task to automatically go back to the Worker when the Manager rejects it.
    I believe I need to surround the management chain task with a while loop, and control it whether or not you iterate over the task again with a flag variable which is set on the REJECT path of the task, and cleared on the others. However when I do that and the manager rejects the task, it just seems to skip the entire management chain task and goes to complete.
    What Im thinking is I need to reset/set some variables on the task when Im setting the flag variable so it comes back in as a regular task (like change the status from completed, etc).
    Can anyone offer me some tips on how to do this properly, or (hopefully ;>) some sample code?
    Thanks!
    Chris

    You could listen to the onTaskUpdated operation of your Workflow Task. There you could check for the condition that your manager has rejected the Task. Rest of the logic you would have to implement in BPEL as your rightly think. Expand the Human Task to see the receive activity

  • How to implement row level security using external tables

    Hi All Gurus/ Masters,
    I want to implement row level security using external tables, as I'm not sure how to implement that. and I'm aware of using it by RPD level authentication.
    I can use a filter condition in my user level so that he can access his data only.
    But when i have 4 tables in external tables
    users
    groups
    usergroups
    webgrups
    Then in which table I need to give the filter conditions..
    Pl let me know this ...

    You pull the Group into a repository variable using a session variable init block, then reference that variable in the data filters either in the LTS directly or in the security management as Filters. You reference it with the syntax VALUEOF("NQ_SESSION.Variable Name")
    Hope this helps

Maybe you are looking for

  • ORACLE 10g IN THE W2K - Is able to help me?

    Hi, I is installing the Oracle 10g in a Pentiun 4, Windows 2000 and service pack 4, by in the installation appears an alert informing that was not possivel carry OCI. The installation continues normally to that the assitente try create the DB, there

  • IPhoto 11...Thumbnails show, but pictures gone??

    Recently I went under iPhoto to find a picture I needed from an event that happened last year.  When I went under iPhoto, all my thumbnails/events show just fine, but when I double click one of the pictures in the events and it shows in the large win

  • ICal and "To Do List"

    Thanks for taking the time to read my post! I just switched from a PC to an iMac last week so please bear wtih me if the answer to my question seems obvious. I run a small business and live and die by my calendar and customer database. I have success

  • Question on  BAPI_ACC_DOCUMENT_POST

    Hi What should be passed for the OBJ_TYPE in DOCUMENTHEADER (one of the Import Parameters) when you call the BAPI - BAPI_ACC_DOCUMENT_POST. I tried BKPFF, RFBU.. both did not work.. Thanks Geetha

  • Bi publisher dual graphs

    Hi, I'm using BI Publisher and I'm trying to create a bar graph combined with a line graph (within the same graph) The BI Beans DTD does not seem to have an graph type for this. Is this possible?