How to pass our request through WAP gateway.

Hi,
As mentioned in
http://developers.sun.com/techtopics/mobility/midp/articles/network/index.html
Java phones tries to reach the server directly, but how to connect to server if there is Gateway is present in between phone and web server
(i.e. phone -> gateway -> server)
in such a case how to make a connection to web server
I tried with
   HttpConnection hc=Connector.open(url);
   hc.setRequestProperty("HttpProsy","proxy-ip");
but its not working
is there any other workaround to solve this problem
Plz help
@rjun

Hi,
use the af:commandLink and in the action property binding to your Managed Bean method. In this method, make what you need , and after that redirect to your url.
The code will be some like that:
public void myAction(){
FacesContext ctx = FacesContext.getCurrentInstance();
ExternalContext ectx = ctx.getExternalContext();
HttpServletResponse response = (HttpServletResponse)ectx.getResponse();
response.addCookie(new Cookie("test","test"));
try {
ctx.getExternalContext().redirect(URL);
response.sendRedirect(url);
} catch (IOException ex) {
ex.printStackTrace();
ctx.responseComplete();
}

Similar Messages

  • How to pass soap request message to server?

    how i can pass soap request message to server using http request header? the soap
    message contains remote procedure call which invokes the method at serverside?
    and where i have to write that header request?
    so i dont know how to pass the request soap message document
    [addsoaprequest.xml]

    Hello,
    We have a diagnostic tool called Post [1] that will post the request
    directly to a SOAP server. You can also try the graphical tool WeX [2]
    so you can see what is happening at the wire level.
    I may have misunderstood your question and goal. The purpose of the
    JAX-RPC [3] API is to provide a high-level abstraction of SOAP
    communications such as you describe.
    What is your use case?
    Thanks,
    Bruce
    [1]
    http://edocs.bea.com/wls/docs81/webserv/trouble.html#1066132
    [2]
    http://webservice.bea.com/wex.zip
    [3]
    http://java.sun.com/xml/jaxrpc/index.html
    Nisha Kothari wrote:
    >
    how i can pass soap request message to server using http request header? the soap
    message contains remote procedure call which invokes the method at serverside?
    and where i have to write that header request?
    so i dont know how to pass the request soap message document
    Name: addsoaprequest.xml
    addsoaprequest.xml Type: ACT Project (text/xml)
    Encoding: base64

  • TS1702 I cannot get an unlocked version of drivesafe.ly to operate on any accounts on my iphone 4S and have had no help when I asked them for support.  I am now trying to figure out how to refund the product.  Anyone know how to make that request through

    I cannot get an unlocked version of drivesafe.ly to operate on any accounts on my iphone 4S and have had no help when I asked them for support.  I am now trying to figure out how to refund the product.  Anyone know how to make that request through itunes?

    Try assigning Queen as the Album Artist on the compilations in iTunes on your computer.

  • Error When Sending Service Request Through OWSM Gateway

    We are trying to test using OWSM Gateways and Server Agents to sign and then verify messages being passed to a web service on a server. We have been able to get this to work with a simple HelloWorld type service without any problems. We then followed the exact same steps to do this with an actual service and it is not working.
    We run the test from the "Test Page" inside the ccore GUI. We first test the connection directly to the service and receive a message about it missing the WS Security header. This is somewhat expected. Then, we send through the gateway which is set up to sign the message and pass along the header and receive the same error message:
    <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault xmlns="http://schemas.oblix.com/ws/2003/08/Faults"><faultcode xmlns="">:GenericFault</faultcode><faultstring xmlns="">WS-Security process failure:FAULT CODE: InvalidSecurity FAULT MESSAGE: Missing WS Security header in the SOAP message</faultstring><faultactor xmlns=""></faultactor></env:Fault></env:Body></env:Envelope>
    We have checked the OWSM logs and can see that both times the server agent receives the request. The gateway logs, however, do not show any requests or responses even though the message should have gone through it. We do see these messages in the logs when testing our HelloWorld service with the same sign/verify settings. A review of the gateway.log file shows the following message displayed each time we submit a test to the malfunctioning service:
    2007-10-18 10:30:22,263 INFO [AJPRequestHandler-HTTPThreadGroup-54] gateway.WSDLRegistry - Exception occured in updateWSDL
    We have until tomorrow to get this issue resolved before development presses to move forward without OWSM security and we cannot have that. Your immediate assistance is required. Thank you.

    Some additional research has been done here and it seems that web services created with SOAP 1.1 (such as the HelloWorld service) work just fine. The problem is with services created with SOAP 1.2. Are there separate configurations or changes that need to be made for SOAP 1.2 services?

  • How to forward DHCP requests through 1140N AP

    We have an 1140N AP connected to a switch and our "network partner" controls the router and will hand out DHCP and do the NAT for this WLAN.  How can I configure the AP to forward DCHP requests through.
    I have WPA2 PSK (TKIP) setup and the client is able to authenticate however we fail to get an address.  In this case the Ethernet interface was left alone so it has the default config and it gets a DHCP address fine.  How can I configure this AP to enable the rest of the WiFI clients to get an IP?

    Here is my cleaned config.  I put helpers everywhere and still can't an IP. 
    I don't have control over the switch or router that this will plug into nor the setup.  The switchport it will plug into has a VLAN designated for Guest Wireless access.  I suspect that I need to redo the config without VLAN10 involved correct?
    Current configuration : 4880 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname [removed]
    enable secret [removed]
    no aaa new-model
    dot11 syslog
    dot11 ssid {removed]
       vlan 10
       authentication open
       authentication key-management wpa version 2
       guest-mode
       wpa-psk ascii 7 [removed]
    crypto pki trustpoint TP-self-signed-1278736388
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1278736388
    revocation-check none
    rsakeypair TP-self-signed-1278736388
    crypto pki certificate chain TP-self-signed-1278736388
    certificate self-signed 01
      3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31323738 37333633 3838301E 170D3032 30333035 32323138
      33335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373837
      33363338 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100BDA9 327F8A3C CFB3C216 F23AA107 CEEE007D CFC2A89C 9064A4F2 66A07EB7
      EB7F3602 74B505D1 9A374875 1DC71A58 607632F3 2A41250B 6BB79B68 D5C1E00D
      B7AA55EB 4E36668B 9BF92E94 C2B0699D A009902A D7A802D1 DCF699F2 99F20B0B
      D5BAB32F 3F8749B2 6C641CF2 6BC7FE8C 3078876C DAC97CFD 69BA42E5 98F81B37
      70830203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603
      551D1104 19301782 1561702E 736F732D 61642E73 74617465 2E6E762E 7573301F
      0603551D 23041830 1680141A 78042A2D A7149DAC E90E1EAF 6496AB47 DF674630
      1D060355 1D0E0416 04141A78 042A2DA7 149DACE9 0E1EAF64 96AB47DF 6746300D
      06092A86 4886F70D 01010405 00038181 00B38305 C973DD31 F23C1B17 78181DF9
      A5A8A409 FDBAEF54 DF94DB89 815954EA 45322B5B BDB32C6A F0353228 ADD4A398
      CC249C49 A4C9C66D 08712AC7 7C5D12D5 C412933C 9E2893C3 4A432577 2FCA9A67
      2F89FF79 8FA0DECD 88CBB2C1 A5DA778A 80839D51 1883EEE7 A8754EC9 283E25E0
      7D91F064 AC633286 81232031 0BEF403E C1
      quit
    username [removed] privilege 15 password [removed]
    bridge irb
    interface Dot11Radio0
    no ip address
    ip helper-address 10.135.14.1
    no ip route-cache
    encryption vlan 10 mode ciphers tkip
    ssid [removed]
    antenna gain 0
    speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.10
    encapsulation dot1Q 10
    ip helper-address 10.135.14.1
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface Dot11Radio1
    no ip address
    ip helper-address 10.135.14.1
    no ip route-cache
    encryption vlan 10 mode ciphers tkip
    ssid [removed]
    antenna gain 0
    dfs band 3 block
    speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
    channel dfs
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio1.10
    encapsulation dot1Q 10
    ip helper-address 10.135.14.1
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    no keepalive
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    no bridge-group 10 source-learning
    bridge-group 10 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    ip helper-address 10.135.14.1
    no ip route-cache
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http help-path
    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    banner motd ^C
    Access to this device is restricted to authorized users. Unauthorized access is a violation of state and federal, civil and criminal laws (e.g., NRS 205.4765). Evidence of unauthorized access will be provided to law enforcement personnel.
    ^C
    line con 0
    password [removed]
    login local
    line vty 0 4
    password [removed]
    login local
    end
    Current configuration : 4880 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname [removed]
    enable secret [removed]
    no aaa new-model
    dot11 syslog
    dot11 ssid {removed]
       vlan 10
       authentication open
       authentication key-management wpa version 2
       guest-mode
       wpa-psk ascii 7 [removed]
    crypto pki trustpoint TP-self-signed-1278736388
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1278736388
    revocation-check none
    rsakeypair TP-self-signed-1278736388
    crypto pki certificate chain TP-self-signed-1278736388
    certificate self-signed 01
      3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31323738 37333633 3838301E 170D3032 30333035 32323138
      33335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373837
      33363338 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100BDA9 327F8A3C CFB3C216 F23AA107 CEEE007D CFC2A89C 9064A4F2 66A07EB7
      EB7F3602 74B505D1 9A374875 1DC71A58 607632F3 2A41250B 6BB79B68 D5C1E00D
      B7AA55EB 4E36668B 9BF92E94 C2B0699D A009902A D7A802D1 DCF699F2 99F20B0B
      D5BAB32F 3F8749B2 6C641CF2 6BC7FE8C 3078876C DAC97CFD 69BA42E5 98F81B37
      70830203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603
      551D1104 19301782 1561702E 736F732D 61642E73 74617465 2E6E762E 7573301F
      0603551D 23041830 1680141A 78042A2D A7149DAC E90E1EAF 6496AB47 DF674630
      1D060355 1D0E0416 04141A78 042A2DA7 149DACE9 0E1EAF64 96AB47DF 6746300D
      06092A86 4886F70D 01010405 00038181 00B38305 C973DD31 F23C1B17 78181DF9
      A5A8A409 FDBAEF54 DF94DB89 815954EA 45322B5B BDB32C6A F0353228 ADD4A398
      CC249C49 A4C9C66D 08712AC7 7C5D12D5 C412933C 9E2893C3 4A432577 2FCA9A67
      2F89FF79 8FA0DECD 88CBB2C1 A5DA778A 80839D51 1883EEE7 A8754EC9 283E25E0
      7D91F064 AC633286 81232031 0BEF403E C1
      quit
    username [removed] privilege 15 password [removed]
    bridge irb
    interface Dot11Radio0
    no ip address
    ip helper-address 10.135.14.1
    no ip route-cache
    encryption vlan 10 mode ciphers tkip
    ssid [removed]
    antenna gain 0
    speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.10
    encapsulation dot1Q 10
    ip helper-address 10.135.14.1
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface Dot11Radio1
    no ip address
    ip helper-address 10.135.14.1
    no ip route-cache
    encryption vlan 10 mode ciphers tkip
    ssid [removed]
    antenna gain 0
    dfs band 3 block
    speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
    channel dfs
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio1.10
    encapsulation dot1Q 10
    ip helper-address 10.135.14.1
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    no keepalive
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    no bridge-group 10 source-learning
    bridge-group 10 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    ip helper-address 10.135.14.1
    no ip route-cache
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    banner motd ^C
    Access to this device is restricted to authorized users. Unauthorized access is a violation of state and federal, civil and criminal laws (e.g., NRS 205.4765). Evidence of unauthorized access will be provided to law enforcement personnel.
    ^C
    line con 0
    password [removed]
    login local
    line vty 0 4
    password [removed]
    login local
    end

  • How to pass attribute values through variables in JSP  Custom TagLib

    Hi,
    Can anybody help me how to pass values through varuables in the jsp custom tag.
    i am using JSP custom tag. I am unable to pass attribute values through variables.
    <invitation:invdetails invid="<%=invid%>"/> The value is passing as <%=invid%> ,not value of the invid.
    But i am getting throuh the fllowing
    <invitation:invdetails invid='1' />
    Please anybody suggest me how to pass value by using the variable.

    Hi,
    It sounds like you need to set the <rtexprvalue> tag to true in the TLD for your tag. If you do this the tag will read in the value you are trying to pass to it.
    dapanther...

  • How to pass row values through OpenDocument Hyperlink

    Hi all,
    I should pass through an OpenDocument hyperlink the value of a particular row of my report. No problems about the OpenDocument syntax and about the other parameters that come from prompt answers, but I don't know how to pass only the value of that particular row. This value doesn't come from a prompt.
    So for example if the column of my report was "Account number" and the 1° row of the column that comes from the query was "123456", I should pass only the account number "123456" to the linked document.
    Moreover, I have to create the hyperlink on the "Account number" column.
    Hoping having been clear...
    Thanks in advance,
    Riccardo

    Hi Stratos,
    Thanks for the reply but I have not understood very well.
    I try to explain better my issue, making an example of the problem in Open doc syntax
    http://aaaaa.bbbbb.com:8080/OpenDocument/opendoc/openDocument.jsp?iDocID=12345&..............&lsSParam1=()&lsSParam2=()&lsSParam3=()
    The problem is in the 3° paramater. This parameter is not a user response variable, it comes from an object projected in the report. The object is a numeric type.
    The aim is to pass to the 2° report exactly the content of the cell of the 3° parameter, dinamically (I mean depending on the cell selected by the user).
    Thanks.
    Regards,
    Riccardo

  • How to pass form value through URL?

    I have a page set up so that pressing the submit on a form will execute a certain page. For certain reasons I also have a URL HREF link that performs a different function. I need to get the value of a radio button group (all with the same name) and pass that value through the URL if it is pressed. So if someone clicks on the second radio button in the list which has a value of 2, I need to somehow set that to a variable to pass through a URL link. Each time the user changes the radio button I need to dynamically change the variable too.
    Is there any way to do this?

    Thanks for the suggestions everyone. Here is what I have so far:
    I have a cfInput that binds to the radio buttons so the value of the cfinput changes dynamically.
    I have a CFDIV that binds to a separate .cfm page that passes the cfinput through as an argument.
    The .cfm is very basic:
    <cfoutput>
        <cfif isdefined("url.InputText") AND url.InputText NEQ "">
            <cfset FeedVar = #url.InputText#>
        <cfelse>
        </cfif>
    </cfoutput>
    This method appears to work and it sets the Feedvar variable to the appropriate value. However on my first page with the cfdiv tag when I try to pass the #FeedVar# variable through a URL it says it is not defined.
    Any clue if I am doing something wrong passing the new variable back?
    Here is the CFINPUT and CFDIV tags:
    <cfinput type="text" name="update_typeURL" bind="{update_type}" bindonload="true" />
    <cfdiv bind="URL:setURlVar.cfm?InputText={update_type}" ID="theDiv" bindonload="true"  />
    Any ideas on how to read the newly set variable?

  • How to implement a SMS and WAP Gateway  ?

    Folks Hi !!
    I'm a newbie at wireless Java, but I am interested to know how can I implement a gateway application/server that works both as an SMS and WAP gateway.
    I've read some documents on Kannel(open source WAP gateway), but I am interested to know if there are any resources available that would be of help to implement one in Java (API for SMS, WAP etc).
    The second question I have is:
    Where do CIMD2, SMPP, UCP etc. come into Messaging picture ? Do they complement WAP for sending/receving SMS ?(pls excuse me, if I sound weird, I am trying to make sense of things :p )
    I appreciate any help or suggestions to resources.
    Thanks a ton in advance !!
    Cheers :)

    An SMS Gateway needs to communicate with the SMSC using some way or another. You have many options:
    1- Connect a simple GSM phone to the serial port of your pc and use it to send and receive messages.
    2- A GSM modem (like Nokia Premicell, Siemens M20..)
    3- Connect directly to the SMSC.
    If you choose the third option, then there must be a specific protocol to use to talk to the SMSC. Your SMSC might support one or more of these protocols:
    1- SMPP (The good java api for this protocol is available http://opensmpp.logica.com)
    2- UCP (see: http://www.cmg.com)
    3- CIMD2 (see: http://www.nokia.com)
    -- Hani.

  • How To Pass the Request Scope To Another Class

    In my ListThread class, I first retrieve some of the text fields; i.e., request.getParameter( ... );
    Thereafter, I want to pass the request scope together with some parameters to another class; SiteUtil.java., for some further processing. This is what I do:
    public final class ListThread extends HttpServlet
          public doPost( HttpServeltRequest request, HttpServlerResponse response)
                      throws ServletException, IOException
          String offset = request.getParameter( "offset" );
          String size = request.getParameter( "size" );
          SiteUtil.prepareNavigate( request, offset, size,
               MessageInboxConfig.ROWS_IN_THREADS );
    }This is my SiteUtil.java:
    import javax.servlet.http.HttpServletRequest;
    public class SiteUtil
       public static void prepareNavigate  
         (HttpServletRequest request, int offset, int   
                         collectionSize, int totalRows)
          int startOffset = offset + 1;
          int lastOffset = offset + collectionSize;
          request.setAttribute("StartOffset", new Integer(startOffset));
          request.setAttribute("LastOffset", new Integer(lastOffset));
    }Can I pass the request scope and save attributes in the scope this way?

    You can pass the request to that method as a parameter, yes, and you can even modify the request there. The request is just an ordinary Java object, so ordinary Java rules apply. Your code looks fine to me too.
    However don't try to store the request for future use, since after the response is sent back to the client, the request object is never used again. A new one is created for the next request.

  • How to pass pdf documents through idocs

    I wanted to know how to pass pdf document along with a transaction code like sales order or travel expense manager with the help of IDOCs.

    Lily,
    I observe that you have declared lv_xml_data as TYPE xstring & string and get_data method probably expects data of xstring type.
    Have a look at the "Extract the Data" section from following [article.|https://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/c2567f2b-0b01-0010-b7b5-977cbf80665d&overridelayout=true]
    Chintan

  • How to Handle RMA Requests through EDI?

    Hi Folks,
    I have a quick question.
    In general, how do RMA Requests are handled through EDI.
    I don't want RMA requests created in SAP (through VA01) send via EDI.
    How can i handle this situation.
    Please reply in detail.
    Awaiting for your answer,
    Creasy Matt

    Hi veerendra reddy ,
    By default any web server can will have a thread pool to handle client req's.
    In your point also heavy burden to server you are telling that depends on this.
    we can configure this min & max size of this thread pool.
    by default it will be 0-1000 for tomcat server.
    I am not sure in which file this configuration will be.
    But I hope in server.xml or some xml file consists this info.
    If You what you can edit accordingly. to overcome your heavy burden to server.
    Thanks & Regards
    Nagendra

  • How to pass delivery date through BAPI while creating a sale order

    Dear frndz,
         I am using 'BAPI_SALESORDER_CREATEFROMDAT1'
    to create a sale order .
        I don't have any problem..
        But I have to pass schedule line delivery date through this bapi .
       I used REQ_DATE in structure BAPISCHDL.
       But I can' t get it.
       Through which parameter can i meet this..
       The sale order should be created line item wise along with my delivery date..
      Any suggestions...
    regards.
    siva

    Dear frnd,
        Danq for your response..I can't use DLV_DATE for this requirement..
        But I used REQ_DATE in the structure BAPISCHEDULE .
       I came to know that the problem i faced previously  was only
    internal data conversion.
        Now am able to pass my delivery date..
        so I am closing the thread..
    Regards.
    siva

  • How to pass username/password through WebService proxy client to E-BS.

    Hi
    We are using ADF Webservice proxy client to integrate E-Business suite with ADF. It asks for username/password to access details from E-BS. In the generated webservice XSD file, a method is available with 2 parameters.
    1) SOAP header( Contains Username, responsibility and 2 more fields)
    2) Class object(Nested Object)
    However i didn't find "*Password*" field anywhere in it. Then how can I pass "*Password*" along with username to invoke this method?
    When i checked SOAP, the password is defined like this
    <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">XXXX</wsse:Password>a
    Thanks
    Raja

    hi Dario
    Thank you for your post. It is really helpful. Now I got stuck with a doubt, in this piece of code
    final Binding binding = ((BindingProvider) servicePort).getBinding();
    List<Handler> handlerList = binding.getHandlerChain();
    if (handlerList == null)
    handlerList = new ArrayList<Handler>();
    They didn't mention properly about "*servicePort*". What object is this?
    I checked in Oracle document, even in that I was not clear with that piece of code.
    public class HandlerWS{ 
    @Resource WebServiceContext ctx;
    @WebMethod()
    public String getProperty(String propertyName) {  
    return (String) ctx.getMessageContext().get(propertyName);
    public class Main {
    public static void main(String[] args) {
    HandlerWS test;
    try {
    test = new HandlerWS(new URL(args[0] + "?WSDL"), new
    QName("http://example.org", "HandlerWS") );
    } catch (MalformedURLException murl) { throw new RuntimeException(murl); }
    HandlerWSPortType port = test.*getHandlerWSPortTypePort*();
    What is this HandlerWSPortType object???. Can you give me little more explanation about it?
    Thanks

  • How 2 pass a request from a broswer to remote server via a proxy server

    hi my program is on a proxy server it will be lisenting in port 9876
    i have configured in a way that all browsers request pass thro this proxy server
    so when user request for www.yahoo.com in the browser the
    resquest is passed 2 this proxy server. so i got the host name and created a socket.
    i read all the request that has come from the browser such as "GET www.yahoo.com HTTP/1.1 ,,"
    I got the outputstream for the remote socket and i passed all these request to the remote host.. but i could nt get any response frm server can any one help me out?
    ===
    import java.io.*;
    import java.net.*;
    class Proxyserver
    ServerSocket ser;
    Socket myclient;
    BufferedReader br;
    String cf1="\r\n",cf2="\r\n\n",lf="\n";
    OutputStream o_remote;
    public Proxyserver()
    try
    ser=new ServerSocket(9876);
    myclient=ser.accept();
    // read inital requst from browser
    br=new BufferedReader(new InputStreamReader(myclient.getInputStream()));
    String req=br.readLine();
    String temp=req;
    int val=temp.indexOf((int)'/',11);
    String host=req.substring(11,val);
    //connect 2 host
    Socket remote=new Socket(host,80);
    System.out.println(remote.toString());
    o_remote=remote.getOutputStream();
    while(req!=null)
    System.out.println(req);
    o_remote.write(req.getBytes(),0, req.length());
    o_remote.write(cf2.getBytes());
    o_remote.flush();
    req=br.readLine();
    o_remote.write(lf.getBytes());
    o_remote.write(lf.getBytes());
    o_remote.flush();
    // wait for response from remote server
    InputStream in=remote.getInputStream();
    int response=in.read();
    while(response!=-1)
    System.out.println((char)response);
    response=in.read();
    //close all sockets
    remote.close();
    myclient.close();
    ser.close();
    }catch(Exception e){}
    public static void main(String a[])
    new Proxyserver();
    ===
    op i got all the req from the broswer and wrote 2 op stream of remote server but i could nt get the response
    ==
    output"
    Socket[addr=javaworld.com/130.94.4.230,port=80,localport=3225]
    GET http://javaworld.com/ HTTP/1.0
    Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
    Accept-Language: en-us
    User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 1.1.4322)
    Host: javaworld.com
    Proxy-Connection: Keep-Alive

    Hi
    Just look for JspSmartUpload classes ..
    this will help u
    U can use
    <input type=file name=f >
    thanks
    regds

Maybe you are looking for

  • Ipod cannot be updated....

    Ok so I put music on my nano no problem, but when I try to put pictures on it, it gives me the following error message... The Ipod cannot be updated. The disk could not be read from or written to. What do I do???

  • DBLINK FROM ORACLE9I ON WINDOWS TO CONNECT SQL SERVER 2005 ON WINDOWS 2003

    Hello All, please i will need help in connecting oracle9i via dblink to sqlserver 2005. i have done some configurations already * started the listener = which starts alright * the tnsping was also successful but i keep getting ORA-12154:TNS:could not

  • Best way to purchase iPhone

    I plan to upgrade to iPhone 4 from my LG enV Touch as soon as I can.  Is there any advantage in purchasing the iPhone from Verizon or Apple? I have used Apple Care for my Mac and my iPod Touch and find it worth the investment although it only provide

  • I ask LR to resize my images, but LR won´t listen...

    When exporting, I try to resize my images, but they still end up being full size. Anyone else with a similar problem?

  • I am trying to download Remote desktop 3.2 on Os x 10.8.3

    I have tried repeatedly to install Remote desktop onto my mac and keep getting the error message that a newer version is already installed. Which it isn't. Any ideas?