hx:commandExButton inside hx:dataTableEx doesn't work

I have a very strange case. If I put my <hx:commandExButton> outside of <hx:dataTableEx>, when I click on the button backend (page bean) code triggers (doButton1Action method), but when I put my <hx:commandExButton> inside <hx:dataTableEx> (inside <hx:columnEx>) and I click on that button - backend code (doButton1Action method) doesn't trigger (execute), but the form only submits/refresh and the same form shows again.
My code is simple:
<hx:dataTableEx id="tableOsebe" value="#{pc_vseOsebe.osebeList}" var="varosebeList">
<hx:columnEx id="columnPodrobnosti">
     <f:facet name="header">
          <h:outputText styleClass="ap_head" value="Potrdila" />
     </f:facet>
     <hx:requestLink styleClass="requestLink" id="link1" action="#{pc_vseOsebe.doLink1Action}">
          <h:outputText id="text1" styleClass="outputText" value="Podrobnosti"></h:outputText>
     </hx:requestLink>
     <hx:commandExButton type="submit" value="Submit"
          styleClass="commandExButton" id="button1" action="#{pc_vseOsebe.doButton1Action}"></hx:commandExButton>
</hx:columnEx>
</hx:dataTableEx>
public String doButton1Action() {
     int index = getTableOsebe().getRowIndex();
     return "";
public String doLink1Action() {
     int index = getTableOsebe().getRowIndex();
     return "";
}As you can see, I have also tried adding <hx:requestLink> and its backing doLink1Action() method into <hx:columnEx> of <hx:dataTableEx> and situation is a little better. The code executes, but getTableOsebe() always return null which causes NullPointerException.
Strange thing is that I have similar code in another JSF page and it works fine. I have spent days trying to find differences, but those two pages are very the same and I have failed to spot any important differences.
Please help.
P.S. I am using IBM implementation of JSF through Rational Application Developer 7 and WebSphere 6.1

milantomic123 wrote:
I have a very strange case. If I put my <hx:commandExButton> outside of <hx:dataTableEx>, when I click on the button backend (page bean) code triggers (doButton1Action method), but when I put my <hx:commandExButton> inside <hx:dataTableEx> (inside <hx:columnEx>) and I click on that button - backend code (doButton1Action method) doesn't trigger (execute), but the form only submits/refresh and the same form shows again.Put the bean in session scope. If it works, then either your data loading logic is wrong, or there is a conversion/validation error occurred which missed your attention. To fix the first, just make sure that getOsebeList() returns exactly the same during the apply request values phase of the form submit request as it returned during the render response phase of the previous request for display. To fix the second, add <h:messages /> to the page to take note of them all. If you're using JSF 1.2, then you should be able to note the missing message in the appserver logs.
P.S. I am using IBM implementation of JSF through Rational Application Developer 7 and WebSphere 6.1IBM doesn't have a JSF implementation. It only has some simple component libraries. If I am correct, RAD7 by default ships with an early Sun JSF RI 1.1. Not really related to your problem, but I'd recommend to upgrade this to at least 1.x_02, available here: [http://javaserverfaces.dev.java.net]. Get 1.1_02 if you're using Servlet 2.4, or get the newest 1.2_x if you're using Servlet 2.5.

Similar Messages

  • Pdf links inside another Pdf doesn't work

    Hi,
    I am using Adobe Pdf Reader X(10.1.0). I am creating a PDF with html links embedded in it.
    Links to normal files works properly (Like server/idcontent/new/ir.html)
    But links to another pdf file doesn't work(Like server/idcontent/new/ir.pdf). When clicked on a .pdf link nothing happens. But where as other links works perfectly.
    Can any one help me whether I am missing any setting in my Adobe Reader.
    Thanks in advance.
    Ravi.

    How exactly are you creating these files?

  • Watching quicktime videos inside a browser doesn't work.

    I've been trying to watch some of Apple's keynotes and ads on their website, but when I try to watch them I just get a green block where the video should be playing. I've tried using different browsers such has Safari, Firefox and Opera. My quicktime is up to date and I don't have any software updates unless I go to Snow Leopard I guess.

    Your signature shows you as running Snow Leopard. This is the Leopard forum, and as far as I can read that is what you are running?
    The following only applies to those running Tiger or Leopard:
    If you are experiencing trouble viewing QuickTime movies with QuickTime Player or the QuickTime browser-plug-in follow the steps in the link below to ensure that QuickTime is properly installed on your Mac
    http://www.apple.com/quicktime/troubleshooting/
    If you having problems watching WWDC Keynotes, tutorials or Trailers on the Apple website, check your Quicktime Player 7 settings in System Preferences:
    Under Streaming, set for Automatic, enable Instant On and Play Immediately.
    Under Advanced, click Mime Settings and ensure that Streaming (both kinds) are enabled.
    (Note that if you are running Snow Leopard you should be using Quicktime Player 7 and not Quicktime 10.) Snow Leopard does not have a QuickTime System Preference pane. No MIME Settings options. No streaming settings. If a User has migrated from 10.5.8 then those settings have moved over (but no changes can be made). QuickTime Player 7 is in your Applications/Utilities folder (if you've got it installed). If not you can install it from the Snow Leopard DVD (Optional Installs).

  • hx:fileUpload doesn't work with hx:commandExButton

    I am using WebSphere Studio and created a Faces file with a FileUpload Control and CommandLinkButton.
    source:
    <f:view>
         <hx:scriptCollector id="scriptCollector1">
              <h:form styleClass="form" id="form1">
                   <%-- jsf:codeBehind language="java" location="/JavaSource/pagecode/UploadFile.java" --%><%-- /jsf:codeBehind --%>
                   <LINK rel="stylesheet" type="text/css" href="theme/stylesheet.css"
                        title="Style">
                   <P><hx:fileupload styleClass="fileupload" id="fileupload1">
                        <hx:fileProp name="fileName" />
                        <hx:fileProp name="contentType" />
                   </hx:fileupload></P>
                   <hx:commandExButton type="submit" value="Upload"
                        styleClass="commandExButton" id="uploadButton"
                        action="#{pc_UploadFile.doUploadButtonAction}"></hx:commandExButton>
              </h:form>
         </hx:scriptCollector>
    </f:view>
    I have a System.out.println statement in my doUploadButtonAction. This never gets invoked. If I remove the fileupload control from the page. The action works. Any help will be apprecitated.

    milantomic123 wrote:
    I have a very strange case. If I put my <hx:commandExButton> outside of <hx:dataTableEx>, when I click on the button backend (page bean) code triggers (doButton1Action method), but when I put my <hx:commandExButton> inside <hx:dataTableEx> (inside <hx:columnEx>) and I click on that button - backend code (doButton1Action method) doesn't trigger (execute), but the form only submits/refresh and the same form shows again.Put the bean in session scope. If it works, then either your data loading logic is wrong, or there is a conversion/validation error occurred which missed your attention. To fix the first, just make sure that getOsebeList() returns exactly the same during the apply request values phase of the form submit request as it returned during the render response phase of the previous request for display. To fix the second, add <h:messages /> to the page to take note of them all. If you're using JSF 1.2, then you should be able to note the missing message in the appserver logs.
    P.S. I am using IBM implementation of JSF through Rational Application Developer 7 and WebSphere 6.1IBM doesn't have a JSF implementation. It only has some simple component libraries. If I am correct, RAD7 by default ships with an early Sun JSF RI 1.1. Not really related to your problem, but I'd recommend to upgrade this to at least 1.x_02, available here: [http://javaserverfaces.dev.java.net]. Get 1.1_02 if you're using Servlet 2.4, or get the newest 1.2_x if you're using Servlet 2.5.

  • With new update the script subMSO doesn't work anymore.

    I have a problem... In my folios (interactive comics) i have nested MSO..  MSO (1) with another MSO (2) in it and again in MSO (2) there is another MSO (3) and so on...
    I have made them with a script described in this page: http://forums.adobe.com/message/4595857
    All work fine with previews release on dps desktop tool and content viewer 23 24.
    But with new update the button inside Sub-MSOs doesn't work.
    Any Suggest ?
    thanks.

    We just released an update to the DPS tools that addresses the issues around HTML/iFrame and buttons in release 25. You can download the updated components by following the links at http://www.adobe.com/go/learn_dps_install_en.
    Neil

  • My micro inside doesn't work. What can I do?

    My micro doesn't work. I have a last generation imac 27" with OS X 10.8.4..
    Inpossible to use the micro, non only inside but also an extern one.

    Please try doing a couple of PRAM and SMC resets, do at least 2. If you don't know how please click Intel iMac SMC and PRAM resets

  • Hi , my sister got really mad and she banged her iPod touch 5th generation on a table and she banged it so hard that the screen didn't crack but inside the the iPod is damage as in like colors are popping out and the screen doesn't work, can i fixed this?

    Hi , my sister got really mad and she banged her iPod touch 5th generation on a table and she banged it so hard that the screen didn't crack but inside the the iPod is damage as in like colors are popping out and the screen doesn't work, can i fixed this?

    Apple will exchange your iPod for a refurbished one for this price. They do not fix yours.
    Apple - iPod Repair price      
    A third-party place like the following maybe less. Google for more.
    iPhone Repair, Service & Parts: iPod Touch, iPad, MacBook Pro Screens

  • Movieclip(root) doesn't work inside a function

    Hey everyone,
    I'm having this problem.
    In fact, when i publish my FLA with player 9, there is no prob.
    When i publish with selecting player 10, there is this problem.
    I paste my code :
    var leng:int = MovieClip(root).program.websiteXML.pages.titlePage.length();
    trace ("leng"+leng);
    setInterval(function () : void {
              if (MovieClip(root).program.autoCh==true){
               trace("CHANGE");
              MovieClip(root).allContent.controllMenu2['itemButton_' + MovieClip(root).program.linkPic].gotoAndPlay("s4");
              if (MovieClip(root).program.linkPic < int(leng-1)){
                        MovieClip(root).program.linkPic++;
                           }else{
                               //MovieClip(root).allContent.play ();
                             MovieClip(root).program.autoCh=false;
                             MovieClip(root).program.linkPic=1;
                             MovieClip(root).allContent.controllMenu2['itemButton_' + MovieClip(root).program.linkPic].gotoAndPlay("s4");
                             for (var z:uint=1; z<(MovieClip(root).program.linkPic+1); z++) {
                                  var tempMC:MovieClip = MovieClip(MovieClip(root).allContent.controllMenu2)["itemButton_"+z];
                                  Tweener.addTween(tempMC, { x:(z-1)*(45+1)-353, time:1} );     
                             for (var j:uint=(MovieClip(root).program.linkPic+1); j<7; j++) {
                                  var tempMC2:MovieClip = MovieClip(MovieClip(root).allContent.controllMenu2)["itemButton_"+j];
                                  Tweener.addTween(tempMC2, { x:(j-1)*(45+1)+352, time:1} );     
                             MovieClip(root).allContent.controllMenu2['itemButton_' + MovieClip(root).program.linkPic].gotoAndPlay("s3");
                       }}, 4000);
    For leng variable, there is no problem, the value is taken.
    But it's inside SetIntervall, at
    MovieClip(root).program.autoCh
    it tells me that :
    TypeError: Error #1009: Il est impossible d'accéder à la propriété ou à la méthode d'une référence d'objet nul.
        at Function/<anonymous>()[main6_cs3_fla._00button_136::frame1:32]
        at Function/http://adobe.com/AS3/2006/builtin::apply()
        at SetIntervalTimer/onTimer()
        at flash.utils::Timer/_timerDispatch()
        at flash.utils::Timer/tick()
    And if I put the value outside the function :
    var autoChtest = MovieClip(root).program.autoCh;
    And use it :
    if (autoChtest==true)
    There is no errors but my function doesn't work correctly, as autoCh can be "false" in another action.
    Well, I hope this will not scare you, and someone will try to help me, please.
    If someone know anything about this issue or having same problem please tell me.
    Thanks!

    Ok i see more clearly, you know it's diificult for me to understand it because i'm into flash AS since a few weeks.
    And what you say about the way setInterval is use, with the function in it, i'm totally agree with that, it's difficult to read.
    The truth is that this is a template that I bought and it was like that, so to do what i've got to do i needed to change some AS3 code.
    This is how it is now :
    var rootvar = MovieClip(root).root;
    function diapodebut (e:TimerEvent) : void {
        if (rootvar.program.autoCh==true){
            trace("CHANGE");       
            rootvar.allContent.controllMenu2['itemButton_' + rootvar.program.linkPic].gotoAndPlay("s4");
            if (rootvar.program.linkPic < int(leng-1)){
                rootvar.program.linkPic++;
            }else{
                  //MovieClip(root).allContent.play ();
                rootvar.program.autoCh=false;
                rootvar.program.linkPic=1;
            rootvar.allContent.controllMenu2['itemButton_' + rootvar.program.linkPic].gotoAndPlay("s4");
            for (var $z:uint=1; $z<(rootvar.program.linkPic+1); $z++) {
                var tempMC:MovieClip = MovieClip(rootvar.allContent.controllMenu2)["itemButton_"+$z];
                Tweener.addTween(tempMC, { x:($z-1)*(45+1)-353, time:1} );   
            for (var j:uint=(rootvar.program.linkPic+1); j<7; j++) {
                var tempMC2:MovieClip = MovieClip(rootvar.allContent.controllMenu2)["itemButton_"+j];
                Tweener.addTween(tempMC2, { x:(j-1)*(45+1)+352, time:1} );   
            rootvar.allContent.controllMenu2['itemButton_' + rootvar.program.linkPic].gotoAndPlay("s3");
        else
            timerSynchro.stop( );
    var leng:int = MovieClip(root).program.websiteXML.pages.titlePage.length();
    trace ("leng"+leng);
    var timerSynchro:Timer = new Timer( 4000, 6) ;
    timerSynchro.addEventListener( TimerEvent.TIMER, diapodebut);
    timerSynchro.start() ;
    You can see that I use Timer class, i've seen on another website just what you say : use Timer instead of setInterval with AS3.
    If you still find something wrong to you, tell me!
    Thanks again for your help !

  • IPhone 4 doesn't work inside buildings

    My iPhone 4 rarely picks up calls inside my house or other buildings. My husband has no problem at all with his phone a Motorola Atrix 2. Even outdoors it doesn't work correctly when trying to make/receive calls or connect to Safari.

    What did your phone carrier say when you contacted them about the issue?

  • If statement doesn't work in JPanel

    Hi everybody.
    I'd like somebody tell me the reason why the "if" statement doesn't work in a Jpanel but works in a Japplet. I'm including the fragments of code that are relevant to the question.
    Thanks in advance.
    public class Applet_INVEN extends JApplet {
    jTabbedPane jTabbedPane1 = new JTabbedPane();
    Panel_1 p_1 = new Panel_1();
    JLabel jLabel1 = new JLabel();
    JTextField jTextField1 = new JTextField();
    JButton jButton1 = new JButton();
    void jButton1_actionPerformed(ActionEvent e) {
    if (jTextField1.getText() != "0") //------Executes when the condition is true
    jLabel1.setText("bingo");
    public class Panel_1 extends JPanel {//------INSIDE a JPANEL
    JTextField jTextField1 = new JTextField();
    JTextField jTextField2 = new JTextField();
    JTextField jTextField3 = new JTextField();
    JButton jButton1 = new JButton();
    void jButton1_actionPerformed(ActionEvent e) {
    jTextField2.setText(jTextField1.getText()); //----Ever executes, of course!
    if(jTextField1.getText() != "0") //----Never executes, even when
    jTextField3.setText("ojo"); //----the condition is true!

    You shouldn't use the != operator to test equality of Objects. Use Object.equals() instead.
    if (jTextField1.getText() != "0")
    should be
    if ( ! jTextField1.getText().equals("0"))
    or better:
    if ( ! "0".equals(jTextField1.getText())) <-- avoids null pointer exception.

  • IPod to TV using digital camera cable, doesn't work. Help

    Hey
    I've got the iPod 5th Generation 30Gb video. I ripped one of my DVDs onto my computer and then used videora to convert the DVD for use on the ipod. I used iTunes to stick the movie on my iPod.
    The movie plays fine on the ipod, but when I go to connect the iPod to my LG Flatron TV it doesn't work. I am using a cable that came with my digital camera, it only has one black and one yellow rca plug. If I use it with the camera, the black is for video, and the yellow for audio. But on the ipod, I don't get anything. I have checked that the send to TV settings are On.
    I've tried changing the format on the output from PAL to NTSC, nothing.
    One thing I am not sure about is why my cable has got a little box thingy surrounding part of the wire, inside the box thingy are magnets, anyone know why these are here? Could this be what is causing it not to work. What should I do?
    Thanks

    Here is some info for the pinout for the iPod.
    http://www.anythingbutipod.com/archives/2006/04/zen-vision-m-video-cable-other-4 pole-35mm-pinouts.php
    You need to find the pinout of the camera cable you have.
    Probably be easier to get get an AV cable with a 3.5mm plug to (whatever fits into your TV) cable.
    Usually, you simply have to swap the Red and the Yellow for it to work properly.

  • Force Quit Doesn't Work/Freezing, Crashing

    Oy. So I have to put this in context. Clutz that I am I dropped my Macbook Pro a year ago. Resulted in a cracked screen, screwed up optical drive and LED light/audio issues. Other than that it worked. It finally decided to clock out over the summer. Spent the money to get a new logic board(they pretty much gave me new computer and put my stuff on it). A few weeks after I got it back(and am now 4hrs away from nearest Apple store) It would freeze ocassionally(SBBD), no big deal, I'll force quit. Or reinstall that program(back then it was usually Mozilla Firefox, now it's kind of any program). As time has gone on it started freezing more frequently and force quit is no longer working. Had to look up what to do when force quit doesn't work, but the thing is, EVERYTHING freezes. I can usally click on a program(activity monitor) all I want, but it wont open. So this all results in having to force shut down, and it kills me inside to do that. Sooo I can wait until I'm back home and take this baby back to Apple, but I figured I'd give this a shot.
    Should have mentioned this, I recently uprgraded to Mountain Lion about a month ago, hoping it would help. Worked for a while...but no such luck.
    Programs that seem to crash most:
    Sibelius
    Mozilla Firefox
    Google Chrome
    iTunes
    Microsoft Word

    Forgot mention the important part. Was forced to force shutdown last night. Then I turned it back on. It got stuck on the white boot up page with Apple logo and loading circle for about 15 minutes. Fans were really load. Shutdown again and left it off all night. This morning I try it again and it makes an odd noise and till gets stuck on white screen for about five minutes Then it turns grey, and then it turns on.

  • L2TP on Cisco ASA 5505, just doesn't work??!

    This is pretty urgent, client expects me to have this up by lunch today
    So, there is this Cisco ASA 5505 ver 8.4.
    Most things work but now I want to setup a vpn connection...
    I have done this 2 ways, first by using the "VPN Wizard" in ASDM and then 5 hours later removing everything and configuring from cli.
    And it just doesn't work, client (WinXP & Win7) gets "error 792" and sometimes "error 789" (both indicating problem with phase 1, I'm pretty sure of that)
    Googling on those gives a few suggestions none works.
    All I get in the log on Cisco is the "Error processing payload: Payload ID: 1"
    Googling on that only comes up with a few pages telling me this message is caused by an error. (Yeah, I could never have guessed...)
    For the cli config, I followed this tutorial carefully (3 times actually...)
    http://www.cisco.com/en/US/docs/secu...html#wp1117464
    I'm using PSK for IPSec, entered same on Cisco and client - checked several times, this is not a password/PSK issue.
    Ports opened on Cisco: 500, 1701, 4500
    (For a try I opened all ports, no change.)
    And here's the "show run":
    Code:
    ASA Version 8.4(2)
    hostname ciscoasa
    enable password <string> encrypted
    passwd <string> encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.5.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address #.#.#.# 255.255.255.252
    interface Vlan7
    description VLAN till kontor
    no forward interface Vlan2
    nameif kontor
    security-level 100
    ip address 172.16.5.1 255.255.255.0
    ftp mode passive
    clock timezone GMT 0
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Webserver
    host 192.168.5.2
    object network Webserver443
    host 192.168.5.2
    object network rdp
    host 192.168.5.2
    object network vpnserver
    host 192.168.5.2
    object service vpn-service-group
    object network VPN
    host 192.168.5.2
    object-group service Webports tcp-udp
    description Portar för webbserver
    port-object eq 443
    port-object eq www
    object-group service DM_INLINE_TCP_1 tcp
    group-object Webports
    port-object eq www
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group service VPNports tcp-udp
    port-object eq 1701
    port-object eq 4500
    port-object eq 500
    object-group service RDP tcp-udp
    port-object eq 3389
    object-group service vpn-services tcp-udp
    port-object eq 1701
    port-object eq 500
    access-list outside_access_in extended permit tcp any object Webserver eq www
    access-list outside_access_in_1 extended permit tcp any object Webserver object-group DM_INLINE_TCP_1
    access-list outside_access_in_1 remark Ãppnar för vpn
    access-list outside_access_in_1 extended permit object-group TCPUDP any any object-group VPNports
    access-list outside_access_in_1 extended permit object-group TCPUDP any any object-group RDP
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu kontor 1500
    ip local pool vpn1 10.10.10.10-10.10.10.50 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Webserver
    nat (inside,outside) static interface service tcp www www
    object network Webserver443
    nat (inside,outside) static interface service tcp https https
    object network rdp
    nat (inside,outside) static interface service tcp 3389 3389
    access-group outside_access_in_1 in interface outside
    route outside 0.0.0.0 0.0.0.0 79.142.243.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authorization command LOCAL
    aaa authorization exec LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA mode transport
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA mode transport
    crypto ipsec ikev2 ipsec-proposal 3DES-SHA
    protocol esp encryption aes-256 aes-192 aes 3des
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal 3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=ciscoasa
    proxy-ldc-issuer
    crl configure
    crypto ca certificate chain ASDM_TrustPoint0
    .... (sorry, not giving you the cert...)
    crypto ikev2 policy 1
    encryption 3des
    integrity sha
    group 2 1
    prf sha
    lifetime seconds 86400
    crypto ikev1 enable outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 1
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh scopy enable
    ssh 0.0.0.0 0.0.0.0 inside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 10
    console timeout 0
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp
    l2tp tunnel hello 100
    dhcpd dns 8.8.8.8
    dhcpd auto_config outside
    dhcpd address 192.168.5.11-192.168.5.36 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    address-pools value vpn1
    group-policy DfltGrpPolicy attributes
    dns-server value 79.142.240.10
    vpn-tunnel-protocol l2tp-ipsec
    address-pools value vpn1
    username test password <string> nt-encrypted
    username someoneelse password <string> nt-encrypted privilege 15
    username someoneelse attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    service-type admin
    username someone password <string> nt-encrypted privilege 0
    tunnel-group DefaultRAGroup general-attributes
    authorization-server-group LOCAL
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group vpn1 type remote-access
    tunnel-group vpn1 ipsec-attributes
    ikev1 pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command vpnclient
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command dynamic-filter
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege clear level 3 mode exec command dynamic-filter
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:dd92aa6707dc63e8ed7dad47cfecdd47
    : end
    In Pingvino Veritas!

    I lmost got it working now, new problem is that the connection is immediately ended.
    Logs shows that client is authenticated and assigned an ip.
    From the logs, all happens during one second:
    IPAA: Client assigned ip-address from local pool
    IPAA: Local pool request succeeded for tunnel-group
    IPAA: Freeing local pool address
    L2TP Tunnel created, tunnel_id is 24
    L2TP Tunnel deleted, tunnel_id =24
    IPSEC: An outbound remote access SA has been deleted
    IPSEC: An inbound remote access SA has been deleted
    Session is being torn down. Reason: L2TP initiated
    Teardown UDP connection

  • I have a MacBook Pro bought in dec 2009. Currently has mountain lion osx installed. Worked like a dream until today. Randomly froze, so I restarted it. To find I got a grey screen. It wouldn't start. Also note my DVD drive doesn't work, but mountain lion

    I have a MacBook Pro bought in dec 2009. Currently has mountain lion osx installed. Worked like a dream until today. Randomly froze, so I restarted it. To find I got a grey screen. It wouldn't start. Also note my DVD drive doesn't work, but mountain lion was installed via App Store anyway.
    So here's what I done so far:
    tried resetting PRAM - No success
    Done disk utility. Disk verified with no errors. I even re formatted disk. - no success starting.
    Tried re installing mountain lion via download . It froze halfway installing -no success.
    Tried backing up a time machine backup from my USB hard drive. It froze at 1% - no success
    Tried booting from safe mode - no success
    Tried the command line boot - no success.
    Please someone help!

    Sounds like the hard dre has left the building, Died, in the Sh*tter, Gone to the hard drive resting place in the sky.
    Buy a new drive connect it to the system with a SATA to USB adapter and see if you can install Mt Lion on that drive connected externally. If you can then the drive inside your system has failed.
    Oh Wait!!!! You have the 2009 model. They are known for bad drive to logic board cables. So it may not be the drive itself but the cable going from the drive to the logic board. Do the same as above then if the system runs OK with the new drive connected externally install it in the system and see if it boots. If it does you are good to go. If it doesn't then it is more then likely the cable that hs failed.
    I would suggest you also SAVE a copy of that download of Mt Lion and create a USB install drive from it using Lion Disk Maker, once you get your system up and running.

  • Parsing in Weblogic/jsp doesn't work; application-mode (command-line) works

    Hello-
    Parsing my XML file in Weblogic/jsp doesn't work, whereas it works
    in application-mode... (albeit on two different machines)
    Here are the parameters:
    server1:
    weblogic 6.0
    win2k server
    jre1.3
    my personal machine:
    ***no weblogic***
    win2k server
    jre1.3
    When I run my code as an application (command-line style) on my machine,
    parsing in my xml file works fine, and I can do a root.toString() and it
    dumps out the entire xml file, as desired.
    However, running my code inside weblogic (on server1) in JSP, parsing in
    my file and doing a root.toString() results in the following: [dmui: null]
    (where dmui is my root)
    (even though i'm running it on two different machines, i'm positive its the
    same code (the servers share a mapped drive)...
    So, I think its probably because I'm using a different parser, as
    specified by weblogic? There are no exceptions being thrown. Here's my
    (abbreviated) code, which is called either command line style or in a JSP:
    // Imports
    import org.w3c.dom.*;
    import org.w3c.dom.Document;
    import javax.xml.parsers.*;
    import javax.xml.parsers.DocumentBuilderFactory;
    import javax.xml.parsers.DocumentBuilder;
    import org.xml.sax.SAXException;
    import org.xml.sax.SAXParseException;
    DocumentBuilderFactory docBuilderFactory =
    DocumentBuilderFactory.newInstance();
    DocumentBuilder docBuilder = docBuilderFactory.newDocumentBuilder();
    mDocument = docBuilder.parse (inFile);
    myRoot.toString()
    -END
    Doing a System.getProperty("javax.xml.parsers.DocumentBuilderFactory")
    results in:
    server1 (weblogic/jsp):
    "weblogic.apache.xerces.jaxp.DocumentBuilderFactoryImpl"
    my machine (application-mode):
    null
    Does anyone have any ideas about how to get this work? Do I try to set it
    up so that they both use the same parser? Do I change the Weblogic parser?
    If so, to what? And how?
    Am I even close?
    Any help would be appreciated..
    Thanks, Clint
    "[email protected]" <[email protected]> wrote in message
    news:[email protected]...
    No problem, glad you got it worked out :)
    ~Ryan U.
    Jennifer wrote in message <[email protected]>...
    I completely missed setting the property(:-o), foolish mistake. That wasit. Thanks.
    "j.upton" <[email protected]> wrote:
    Jennifer,
    Personally I would get rid of import com.sun.xml.parser.* and use xerces
    which comes with WLS 6.0 now, unless like I said earlier you have a need
    to
    use the sun parser :) Try something like this with your code --I've put
    things to watch for as comments in the code.
    import javax.xml.parsers.*;
    import org.xml.sax.SAXException;
    import org.w3c.dom.*;
    import java.io.FileInputStream;
    public class BasicDOM {
    public BasicDOM (String xmlFile) {
    try{
    FileInputStream inStream;
    Document document;
    /*You must specify a parser for jaxp. You can in a simple view
    think
    of this as being analogous to a driver used by JDBC or JNDI. If you are
    using this in the context of a servlet or JSP and have set an XML
    registry
    with the console this happens automatically. You can also invoke it in
    the
    context of an application on the command line using the -D switch. */
    System.setProperty("javax.xml.parsers.DocumentBuilderFactory",
    >>>
    "weblogic.apache.xerces.jaxp.DocumentBuilderFactoryImpl");
    // create a document factory
    DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
    // specify validating or non-validating parser
    dbf.setValidating(true);
    // obtain a factory
    DocumentBuilder db = dbf.newDocumentBuilder();
    // create a document from the factory
    inStream = new FileInputStream(xmlFile);
    document = db.parse(inStream);
    }//try
    catch (Exception e)
    System.out.println("Unexpected exception reading document!"
    +e);
    System.exit (0);
    }//catch
    }//BasicDom
    // Main Method
    public static void main (String[] args) {
    if (args.length < 1)
    System.exit(1); file://or you can be more verbose
    new BasicDOM(args[0]);
    }//class
    =============================================
    That will give you a basic DOM you can manipulate and parse it fromthere.
    BTW this code
    compiled and ran on WLS 6.0 under Windows 2000.
    Let me know if this helped or you still are having trouble.
    ~Ryan U.
    "Jennifer" <[email protected]> wrote in message
    news:[email protected]...
    Actually I included com.sun.xml.parser.* as one last febble attempt toget
    it working.
    And as for source code, I included the code. If I just put that oneline
    of code
    in, including the imports, it fails giving me an error listed above inthe
    subject
    line. Here is the code again:
    package examples.xml.http;
    import javax.xml.parsers.*;
    import org.xml.sax.SAXException;
    import org.xml.sax.SAXParseException;
    import org.w3c.dom.*;
    import java.util.*;
    import java.net.*;
    import org.xml.sax.*;
    import java.io.*;
    public class BasicDOM {
    static Document document;
    public BasicDOM (String xmlFile) {
    try {
    DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
    } catch (FactoryConfigurationError e){
    System.err.println(e.getException());
    e.printStackTrace();
    // Main Method
    public static void main (String[] args) {
    BasicDOM basicDOM = new BasicDOM (args[0]);

    Hi, Rob
    Does it work in WL9.2?
    It seems I do it exactly as the explained at http://edocs.bea.com/wls/docs81/programming/classloading.html - and it fails :o(.
    I try to run my app.ear with WL9.2 There are 2 components in it: webapp and mdb. The webapp/WEB-INF contains weblogic.xml:
    <weblogic-web-app>
    <container-descriptor>     
    <prefer-web-inf-classes>true</prefer-web-inf-classes>
    </container-descriptor>
    </weblogic-web-app>
    Mdb is expected to run in the same mode, i.e. to prefer the webapp/WEB-INF/*.jar over the parent Weblogic classloader. To do so I add the weblogic-application.xml to the app.ear!/META-INF:
    <weblogic-application>
    <classloader-structure>
    <module-ref>
    <!-- reminder: this webapp contains
    prefer-web-inf-classes -->
    <module-uri>webapp</module-uri>
    </module-ref>
    <classloader-structure>
    <module-ref>
    <module-uri>mdb.jar</module-uri>
    </module-ref>
    </classloader-structure>
    </classloader-structure>
    </weblogic-application>
    Now, when classloader-structure specified, both webabb and mdb prefer the weblogic root loader as if prefer-web-inf-classes not defined at all.

Maybe you are looking for