I am trying to get NAT working on a Cisco 2801 with HWIC-4ESW.

I have a 2801 that had a failed Fe0/1 port.  The Fe0/1 port was used to give sub-interface Fe0/0.200 access to internet.  We installed a HWIC-4ESW into the 2801.  I have successfully moved the sub-interfaces ( 0/0.1 , 0/0.100 , and 0/0.200 ) from the Fe0/0 to the HWIC-4ESW.  I have reconfigured the Fe0/0 to connect to my ISP.  However, I cannot get traffic from vlan200 to pass to the internet over Fe0/0.   I have a guest wireless network set for vlan 200.  Clients get an IP address in the appropriate range (192.168.200.0), but they cannot get to the internet.  Below I have included the results of "sh ip int brief" and some of the "sh run".  I think that it is something simple, but I canot get it working.  
Help would be appreciated.
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 ***.**.244.194 YES manual up up
FastEthernet0/0.200 unassigned YES unset deleted down
Service-Engine0/0 192.168.100.254 YES TFTP up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
FastEthernet0/1/0 unassigned YES unset up up
FastEthernet0/1/1 unassigned YES unset up up
FastEthernet0/1/2 unassigned YES unset administratively down down
FastEthernet0/1/3 unassigned YES unset administratively down down
Serial0/3/0:0 unassigned YES unset down down
Serial0/3/0:1 unassigned YES unset down down
Serial0/3/0:2 unassigned YES unset down down
Serial0/3/0:3 unassigned YES unset down down
Serial0/3/0:4 unassigned YES unset down down
Serial0/3/0:5 unassigned YES unset down down
Serial0/3/0:6 unassigned YES unset down down
Serial0/3/0:7 unassigned YES unset down down
Serial0/3/0:8 unassigned YES unset down down
Serial0/3/0:9 unassigned YES unset down down
Serial0/3/0:10 unassigned YES unset down down
Serial0/3/0:11 unassigned YES unset down down
Serial0/3/0:12 unassigned YES unset down down
Serial0/3/0:13 unassigned YES unset down down
Serial0/3/0:14 unassigned YES unset down down
Serial0/3/0:15 unassigned YES unset down down
Serial0/3/0:23 unassigned YES NVRAM up up
Vlan1 192.168.1.254 YES NVRAM up up
Vlan100 192.168.100.254 YES NVRAM up up
Vlan200 192.168.200.254 YES NVRAM up up
NVI0 ***.12.244.194 YES unset administratively down down
ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.99
ip dhcp excluded-address 192.168.100.200 192.168.100.254
ip dhcp excluded-address 192.168.200.1 192.168.200.99
ip dhcp excluded-address 192.168.200.200 192.168.200.254
ip dhcp pool Phones
network 192.168.100.0 255.255.255.0
option 150 ip 192.168.100.254
default-router 192.168.100.254
dns-server 192.168.1.8
ip dhcp pool guestwireless
network 192.168.200.0 255.255.255.0
default-router 192.168.200.254
dns-server 8.8.8.8 8.8.4.4
ip cef
no ip domain lookup
ip domain name pwa.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
controller T1 0/3/0
pri-group timeslots 1-16,24
controller T1 0/3/1
shutdown
gw-accounting aaa
gw-accounting syslog
interface FastEthernet0/0
description Guestwireless route to internet
ip address ***.**.244.194 255.255.255.240
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
interface Service-Engine0/0
ip unnumbered Vlan100
service-module ip address 192.168.100.200 255.255.255.0
service-module ip default-gateway 192.168.100.254
no cdp enable
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
interface FastEthernet0/1/0
description trunk to switch
switchport mode trunk
duplex full
speed 100
interface FastEthernet0/1/1
description voice
switchport access vlan 100
interface FastEthernet0/1/2
shutdown
interface FastEthernet0/1/3
shutdown
interface Serial0/3/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn supp-service name calling
no cdp enable
interface Vlan1
description Data
ip address 192.168.1.254 255.255.255.0
interface Vlan100
description voice vlan
ip address 192.168.100.254 255.255.255.0
h323-gateway voip bind srcaddr 192.168.100.254
interface Vlan200
description Guestwireless Data
ip address 192.168.200.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
ip nat inside source list 10 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.100.200 255.255.255.255 Service-Engine0/0
ip route 192.168.200.0 255.255.255.0 FastEthernet0/0
ip radius source-interface Vlan100
access-list 10 permit 192.168.200.0 0.0.0.255

So, I just built this in the lab, and it seemed to work ok. I attached a sparse config, but it does let my host on the GuestWireless get the internet via NAT.
R2#sh ip nat translations vrf GuestWireless
Pro Inside global      Inside local       Outside local      Outside global
icmp 17.12.244.194:5   192.168.200.1:5    1.1.1.1:5          1.1.1.1:5
R2#sh ip route vrf GuestWireless
Routing Table: GuestWireless
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 17.12.244.195 to network 0.0.0.0
     17.0.0.0/28 is subnetted, 1 subnets
C       17.12.244.192 is directly connected, FastEthernet0/0
C    192.168.200.0/24 is directly connected, Vlan200
S*   0.0.0.0/0 [1/0] via 17.12.244.195

Similar Messages

  • Trying to get Xgl working following Wiki docs

    Hi all,
    I downloaded Xgl stuff from shadowhand's repo and am trying to get it work now with Gnome or KDE. I can run
    startxgl 1 gnome nvidia
    and play with jelly windows, so Xgl is in principle running.
    Next I tried to follow the suggestions given in Arch Wiki and let GDM/KDM run compiz. However, I had lo luck in that.
    First, for GDM the wiki advises to modify /opt/gnome/etc/gdm/gdm.conf. I do not have this file, it is does not come with gdm package. I copied the file from abs tree (it was there), but modifying it following Wiki did not give me fancy windows under Gnome.
    Next I tried KDM. Wiki tells me to find and modify the line
    ServerCmd=/usr/bin/X -br
    in /opt/kde/share/config/kdm/kdmrc. This time I had the file, but not the line in that file. I added the modified line by hand and did all the rest suggested by Wiki, but it did not give me fancy windows. There was the abovementioned line in the file /opt/kde/share/config/kdm/kdmrc.default, modifying that one had no effect either.
    Can anyone please help me sorting this out? What am I doing wrong and what should be the correct way to get, say, KDE working with Xgl?
    Best regards,
    Jan

    paulicat wrote:
    If you have the gdm package installed, it has to have gdm.conf. So, in this case, do the following:
    Remove the gdm.conf you manually copied to your system.
    Then as root type: slocate -u
    then locate gdm.conf
    Now go and edit the file found with the locate command.
    Before all of this though, make sure you do have the gdm package installed first.
    Of course I have gdm package installed. Still, no gdm.conf:
    # pacman -Ql gdm | grep conf
    gdm /opt/gnome/etc/gdm/custom.conf
    gdm /opt/gnome/share/gconf/
    gdm /opt/gnome/share/gconf/schemas/
    gdm /opt/gnome/share/gconf/schemas/gdm.schemas
    gdm /opt/gnome/share/gdm/defaults.conf
    gdm /opt/gnome/share/gdm/factory-defaults.conf
    Locating gdm.conf gave the following result:
    # slocate -u
    # locate gdm.conf
    /var/abs/extra/gnome/gdm/gdm.conf
    so that's the abs version I was talking about.
    Any other ideas?
    Jan

  • I got a new Ipad 2 and I am trying to get it work in vain. I have downloaded the iTunes on my PC, but even after executing the program nothing happens to the IPAD. I still get the image of the USB cable and the iTunes logo. What am I doing wrong?

    I got a new Ipad 2 and I am trying to get it work in vain. I have downloaded the iTunes on my PC, but even after executing the program nothing happens to the IPAD. I still get the image of the USB cable and the iTunes logo. What am I doing wrong?

    You know that you have to connect the iPad to your PC with the cable that came with it -  and then iTunes should start automatically and it will guide you through the set up process?
    If you have already tried to connect the iPad - and you have launched iTunes - and you still have no luck - reboot your PC and then begin the process again.

  • Motherboard went in my g5 desktop so i go my hard drive extracted with all my data..I now have an ibook g4 laptop and am trying to get gb working but get this message: he Instrument Library is invalid. GarageBand expects a valid Instrument Library folder?

    Motherboard went in my g5 desktop so i go my hard drive extracted with all my data..I now have an ibook g4 laptop running off OSX 10.4.11 and am trying to get Garageband working but get this message: The Instrument Library is invalid. GarageBand expects a valid Instrument Library folder?

    Contact Apple Support:
    http://www.apple.com/support/contact/
    Apple - How to Contact Us:
    http://www.apple.com/contact/
    Be sure to refer to the repair ticket number.
    Sounds like a terrible mixup.
    Good luck & happy computing!

  • I BOUGHT LIGHTROOM 5 IN LAREDO TX AND I TRIED TO GET IN MONTERREY MEXICO THE SERIAL NUMBER WITH THE REDEMPTION CODE BUT APPEARS AN ERROR. MY PC IS WINDOWS 8. COULD SOMEBODY HELP ME?

    I BOUGHT LIGHTROOM 5 IN BEST BUY LAREDO TX AND I TRIED TO GET IN MONTERREY MEXICO THE SERIAL NUMER WITH THE REDEMPTION CODE FROM THE BOX, BUT APPEARS AN ERROR. MY PC IS WINDOWS 8, COULD SOMEBODY HELP ME??

    I don't know that you can purchase Adobe software in the US for installing and using outside of the US.
    Redemption Code Help
    http://helpx.adobe.com/x-productkb/global/redemption-code-help.html
    Serial number and activation chat support (non-CC)
    http://helpx.adobe.com/x-productkb/global/service1.html ( http://adobe.ly/1aYjbSC )

  • Need driver or app for ms life cam 3.0 tried to get one off the internet. cisco wireless router software said malware and virus threat. Is it safe for mac?

    need driver or app for ms life cam 3.0 tried to get one off the internet. cisco wireless router software said malware and virus threat. Is it safe for mac? is this software try to protect my pc or is it A threat to macs to.

    There are a number of extremly dubious sites which claim to offer Drivers for common Hardware, but actually are phishing for identies and credit card numbers and candidates to join a bot-net.
    Make absolutely certain you load drivers ONLY from the manufacturer's web site.

  • [SOLVED] Unity-Overlay Scrollbar.. trying to get it working...

    Hi,
    I'm trying to enable the unity scrollbars inside XFCE.
    I have installed the latest gtk2-ubuntu and gtk3-ubuntu, but run into problems.
    When installing gtk2-ubuntu everything hangs and I cannot login to a XFCE session.
    gtk3-ubuntu installs fine, but no overlay scrollbar is visible.
    I have used the following PKGBUILD (mod from atanas - aur) to install gtk3-ubuntu:
    pkgname=gtk3-ubuntu
    pkgver=3.4.3
    pkgrel=1
    pkgdesc="GTK+ is a multi-platform toolkit (v3) with Ubuntu's modifications"
    arch=('i686' 'x86_64')
    url="http://www.gtk.org/"
    install=gtk3.install
    depends=('atk' 'cairo' 'gtk-update-icon-cache' 'libcups' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage' 'pango' 'shared-mime-info' 'colord')
    makedepends=('gobject-introspection')
    provides=("gtk3=$pkgver")
    conflicts=('gtk3')
    options=('!libtool' '!docs')
    backup=(etc/gtk-3.0/settings.ini)
    license=('LGPL')
    source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/3.4/gtk+-$pkgver.tar.xz
    settings.ini
    016_no_offscreen_widgets_grabbing.patch
    017_no_offscreen_device_grabbing.patch
    043_ubuntu_menu_proxy.patch
    062_ubuntu-set-grab-add.patch
    075_expose_gdkwidget_for_gtkrange.patch
    sha256sums=('846010442a96590469cde16ed6a1fdfe09397e435165459f04d31cfa5713799f'
    'c214d3dcdcadda3d642112287524ab3e526ad592b70895c9f3e3733c23701621'
    'c4a43b254b9719ac026fa6a92366bdc1d32e42fa79461ff8aaa206933b9f9c7e'
    'cb8f4eb9d10c6d8645d23812aaa7d64c14560476f19f8c779d10a546748de684'
    '3c40814a3ba51dbbd169b5fc8f4a3c47aff6c5b97433a1f6c13fa66d465947d9'
    '5a89bd63afb2d97b98eb3b7acb5a568c388aedd94af38a1106233ce033982354'
    '9ee240b355502d6ba449983f794205e6e5401c8acca2a3ce513df7f0502dc988')
    build() {
    cd "$srcdir/gtk+-$pkgver"
    # Don't let offscreen widget do grabbing (fix for ido)
    patch -Np1 -i "$srcdir/016_no_offscreen_widgets_grabbing.patch"
    # Do not allow widgets in an offscreen hierarchy to take grabs (fix for ido)
    patch -Np1 -i "$srcdir/017_no_offscreen_device_grabbing.patch"
    # Add Ubuntu menuproxy module (required for appmenu-gtk)
    patch -Np1 -i "$srcdir/043_ubuntu_menu_proxy.patch"
    # Add ubuntu-set-grab-add signal (required for ido)
    patch -Np1 -i "$srcdir/062_ubuntu-set-grab-add.patch"
    # Add gtk_range_get_event_window to get the event_window for a GtkRange (fix for ido)
    patch -Np1 -i "$srcdir/075_expose_gdkwidget_for_gtkrange.patch"
    # Add support for the ayatana overlay scrollbars (required for overlay-scrollbar)
    #patch -Np1 -i "$srcdir/100_overlay_scrollbar_loading.patch"
    # Partially revert BGO#673440 in order to fix BGO#674157
    #patch -Np1 -i ../wacom.patch
    aclocal -I m4
    libtoolize --copy --force
    automake
    CXX=/bin/false ./configure --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --enable-gtk2-dependency \
    --disable-schemas-compile
    #https://bugzilla.gnome.org/show_bug.cgi?id=655517
    sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
    make
    package() {
    cd "$srcdir/gtk+-$pkgver"
    make DESTDIR="$pkgdir" install
    install -Dm644 "$srcdir/settings.ini" "$pkgdir/etc/gtk-3.0/settings.ini"
    As you can see, I have removed some patches (scrollbar patch, etc.) otherwise it wont compile.
    I don't know if the patches are required, as I thought they merged into the main source?
    Could also someone help me with gtk2-ubuntu? I don't know why this is hanging.
    I have not tried it in a non XFCE-session through.
    Has someone been able to get it working? (Lower version perhaps?)
    Thanks!
    Last edited by beta990 (2012-06-28 09:56:30)

    Oke, given up.. seems like they patch things different in gtk3.. thanks anyway.

  • Is it broke - spent 6 hours trying to get to work :o(

    I got a new 60gb Black iPod video last night, by mistake I put it in the dock for my old 3g ipod without installing from the CD. It started to load music on and then stopped complaining about a read/write error.
    So I thought,,, ok I'll uninstall and install most upto date Itunes and ipod software, did that fine.
    Upon restarting computer, nothing came up so I put ipod in the dock and tried to restore the ipod...
    I get a "Firmware update failure, read error"
    If i try and format the iPod using a CMD prompt, I get "volume to large for FAT 32" and the windows format window doesnt give me any file system choices to format with??
    Also Partition magic doesnt see the drive.
    iTunes seems to load about 400 songs on it then it freezes the whole computer.
    I also get corrupt file messages also in the windows taskbar.
    I have a feeling this could be my USB2.0, so i changed from a PCI port to the computers ports and still the same, I've also uninstalled my USB ports and reinstalled, also reinstalled SP2 to ensure drivers were ok etc - still no luck.
    Is this iPod having a harddrive failure or is it something I can fix as i cant seem to format it using anything?
    Or could it just be my USB is playing up as I tried an external DVD writer on it last week and that also failed (it worked fine on my mates computer).
    Any ideas please as I'm getting fed up now - I was up til 2.30am this morning and am feeling very tired in work today now cos of Steve Jobs lol
      Windows XP Pro  

    Wow didnt have replies a second ago,,,, well things have developed - I dunno how - but its working now :o)
    A mere 10 hours or so trying to get it and its finally restoring over USB2.0 so I'm guessing iTunes is ready to rock and roll onto my nice new shiney iPod.
    I hope I dont have these problems again as I'll be going to see Steve personally :o).
    On another note to anyone else who has the problems - it does seem that it is REALLY picky about your USB, I found that installing windows again did help - but dont think that was really needed (needed doing anyhow), seems that drivers somewhere along the line helped. Not sure how because I'm using the same ones.
    Well thanks for your advice dudes, take it easy

  • IPod Mini was formatted as "Mac," trying to get it working on PC w Windows

    Against my advice, my daughter just purchased a PC. It's an +HP Acer+, w +Windows Vista+.
    Her iPod Mini was *originally formatted* on my computer, an iMac, and all of her iTunes were loaded from this computer.
    However, she tried to get it formatted on her new PC. When she did ...from the installation disk that came w her new iPod Mini, and which said it could be formatted for PC and gave the steps to do so...it froze somewhere in the formatting process.
    Her computer froze and she could not turn it off. I told her to unplug from the wall outlet and re-boot. It worked and everything on the computer seems to be working.
    However, all of her tunes on her iPod are gone. (Quite a few, in the hundreds.)
    It would appear that the problem lies in trying to format and transfer tunes that originally came from a Mac-formatted iPod and tunes that came in from Mac iTunes.
    But that's just conjecture. I don't know what the problem is.
    Any thoughts? Advice?
    Thanks in advance

    Few points :-
    1. If you format an iPod (Restore to factory setting), it will erase all data on the iPod
    2. You should always go for iTunes to Restore the iPod instead of using the old version iPod updater.
    Try to download and install the latest version of Tunes and use to restore the iPod again
    http://www.apple.com/itunes/download/
    3. After finishing the Restore, your iPod (formatted now on a PC) will still able to read by your iMac (but not the other way round), do you update with your iMac (transfer back on the songs to the iPod).
    4. Installa 3rd party software on your PC, use it to copy the music from the iPod to the iTunes on the PC. Please do a Google search for the software, there are plenty

  • When trying to get a scanned photo, funny image (flower) with a "i" letter in it, but no image?

    When i try to get a scanned photo
    from a folder, I get a funny image "flower petal" maybe, with a "i" letter, but no image.  No errors are reported, no image is brought into organizer, just that weird image.  I am scanning at 1200dpi, or 800dpi.  Any idea what this means?

    Are you trying to add songs to a smart playlist?  Does the playlist have a gear icon next to it instead of a music note?
    B-rock

  • I wasted an hour this morning trying to get my work done before you finally informed me your site crashed. I've wasted the last 15 minutes trying to find out h

    completely frustrated w/your site. wasted hour this morning until your sited crashed and the last 20 minutes trying to find out how to send you a simple e-mail !!!!!!!!! Let me know when you get your act together.

    So how does a site crash? is it Firefox crashing?
    * [[Troubleshoot and diagnose Firefox problems]]

  • Palm m130 trying to get to work on Windows 7 64 bit operating system

    I purchased a Palm m130 on Ebay.  It did not come with a driver.  The connection is a 9 pin serial.  Web info says it comes with a usb but, this one did not.  It seems to be in perfect working order.
    All I want to do is to put one e-book on it.
    I know it is supposed to be hot syc'd, but, since I don't have a driver I am sort of at a loss.
    Does any one have an idea?
    thanks
    Brian

    I am moving your question to the Windows Hotsync board, where you will find this thread stickied near the top, discussing Windows 7 & 64 bit Hotsync issues.
    There are no 64-bit USB drivers.  Only way to sync with 64-bit machines is wirelessly, via Wi-Fi, Bluetooth (neither of which your m130 is capable of), or IR.
    smkranz
    I am a volunteer, and not an HP employee.
    Palm OS ∙ webOS ∙ Android

  • Trying to get iTunes working on Windows 8, iTunes wont recognize media folder...

    I was using a Windows 7 machine, running iTunes off my external HDD. I ended up getting a new computer, with Windows 8. I install iTunes and try to direct to the iTunes media folder location on my HDD (Nothing has changed) via the Advanced tab in Preferences within iTunes.
    I can see the iTunes Library.itl, where it has always been, but directing iTunes doesn't seem to do anything.
    Any help would be apprectiated.
    Cheers

    See this migrate iTunes library post.
    Redirecting the media folder isn't the same thing as connecting to a different library file, which is done by holding down shift as you start iTunes.
    tt2

  • HT1296 I am trying to get my work email on my phone.  I went to syncing instructions but do not see a new icon.  I have my personal gmail on my phone, should I have a new icon for my work email?

    I need help getting an additional email account to sych onto my phone

    Setup the email account on the device.

  • FPM - Trying to get it work on Service Pack 13

    I came across the FPM today. Since I had to create a new simple application today I gave FPM a try.
    Basically my application would contain two views:
    1. A tree illustrating a HR organisation structure
    2. A table listing documents based on entry selected in the tree
    I probably need the tree soon again for some other application so I wanted to put the tree and the table into 2 different web dynpro components for reusiability. Without FPM I would have created a 3rd WDA component. The main function of this 3rd component would be to pass the lead selection (an OBJID) from the tree to the table view.
    If I understood the concept of the FPM framework correctly, the FPM_OIF_COMPONENT could help me with this passing of parameters between both WDA components and would even offer a lot more nice features.
    I played around with FPM_DEMO_FLIGHT_OVERVIEW and finally managed to create a configuration that would pass the values. But then things became difficult and maybe someone can help me with my questions (I check already all documents in the library, forums, weblogs and wiki dealing with FPM):
    1. Is a good idea to use FPM without having the Enhancement Package 1? The few tutorials and documents I found contained screenshots which look completely different to mine.
    2. In the example I could see how a button is being defined, but they wont show up in my application: to be more accurate: once a refresh button showed up but just disappeared again. I guess now, that there is some error in my configuration, but instead of telling me, that there is an error, FPM just ignores my button.
    3. Can I never navigate back to the initial screen? In my application that would be a requirement for easy selecting another element of the tree.
    4. In the Flight Demo the DELETE_OBJECT button calls the CONFIRMATION view: how is the button linked to the view? In the component controller of the Flight Demo almost all methods of the interface IF_FPM_UI_BUILDING_BLOCK are empty.
    Regards
    René

    > 1. Is a good idea to use FPM without having the Enhancement Package 1? The few tutorials and documents I found contained screenshots which look completely different to mine.
    I would be more worried bout SP13. I'm not sure the functionality of FPM is really complete on SP13.  I've done FPM application on SP14 but never SP13.  It is true however that the design tools were significantly enhanced and simplified in 7.0 EnhP1; so SAP really recommends that customers wait until the EnhP before doing a lot of FPM development.
    > 2. In the example I could see how a button is being defined, but they wont show up in my application: to be more accurate: once a refresh button showed up but just disappeared again. I guess now, that there is some error in my configuration, but instead of telling me, that there is an error, FPM just ignores my button.
    Hard to say without seeing your application and configuration.  I've never had this happen to me. Once I activated one of the standard buttons in the config. they have always appeared for me. 
    > 3. Can I never navigate back to the initial screen? In my application that would be a requirement for easy selecting another element of the tree.
    Sure - Look at the SDN Mentors' Hands-On Workshop for an example that does this ( SDN Community Day Mentor Hands-On Workshop  and http://code.google.com/p/sdn-mentor-handson-2008/downloads/list ). I use the standard Start Over button.  It fires validation and if passed will return to which ever UIBB you have defined as your Initial Screen.
    > 4. In the Flight Demo the DELETE_OBJECT button calls the CONFIRMATION view: how is the button linked to the view? In the component controller of the Flight Demo almost all methods of the interface IF_FPM_UI_BUILDING_BLOCK are empty.
    Many of the standard buttons will first fire validation methods and then if they haven't received a flag not to continue they will follow their configuration to the next step.  In the case of the delete that would be to go automatically to whatever UIBB is configured for Confirmation.

Maybe you are looking for

  • How do I get past the password prompt with a locked iPhone?

    I updated to iOS7, and everything seemed fine. But then when the phone locked after a few minutes, it asked me for a password to unlock. I never used a password before. So the  phone is asking me for something I didn't have to do before. Now the phon

  • URL Not Changing Session State Variables Specified

    I am trying to change a variable on a target page with a URL, however, the variable never changes. The variable is set to 8. I send the following URL which should change it to 0 but it does not change. We just recently upgraded to 1.6 Why is this not

  • Lenovo G500s Hard Drive Issue (I think)

    OK so dropped my laptop from a heigh of around 10cm the other day, laptop seemed fine and worked fine all evening. Then the day after I come to the laptop its constantly freezing after 4 or so minutes of use. So appears fine then boom its done laptop

  • Class names

    im writing a method to determine if a given string is a valid java identifier, therefor i need to check this name against all java class names. Does anyone know of a way to access all java class names? Thanks

  • Disk Utility showing 13+GB Free Space on HD

    Hi, I just got a new Macbook Pro and looking in Disk Utility in the partition tab it's showing over 13GB of "Free space" after the system partition. Why is this space here, is it really free and is it OK to expand my system partition to fill it? Than